]> git.pld-linux.org Git - packages/gdb.git/commitdiff
- rebase gdb-add-index patch
authorJan Rękorajski <baggins@pld-linux.org>
Fri, 2 Aug 2013 06:50:55 +0000 (08:50 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Fri, 2 Aug 2013 06:50:55 +0000 (08:50 +0200)
gdb-gdb-add-index-script.patch

index 1f447b1b422a54ecee747db94d10d18590b4ee35..d04b4ac02456058f3b678d69a47380243ff2e3a4 100644 (file)
@@ -45,9 +45,9 @@ Index: gdb-7.5.91.20130407/gdb/Makefile.in
 --- gdb-7.5.91.20130407.orig/gdb/Makefile.in   2013-04-11 16:52:51.000000000 +0200
 +++ gdb-7.5.91.20130407/gdb/Makefile.in        2013-04-11 16:53:59.199279388 +0200
 @@ -1053,6 +1053,15 @@ install-only: install-gstack $(CONFIG_IN
-                 $(INSTALL_PROGRAM) gcore \
-                         $(DESTDIR)$(bindir)/$$transformed_name; \
-       fi
+                       $(DESTDIR)$(man1dir)/$$transformed_name.1 ; \
+               $(SHELL) $(srcdir)/../mkinstalldirs $(DESTDIR)$(includedir)/gdb ; \
+               $(INSTALL_DATA) jit-reader.h $(DESTDIR)$(includedir)/gdb/jit-reader.h
 +      transformed_name=`t='$(program_transform_name)'; \
 +                        echo gdb-add-index | sed -e "$$t"` ; \
 +              if test "x$$transformed_name" = x; then \
@@ -79,73 +79,10 @@ Index: gdb-7.5.91.20130407/gdb/doc/gdb.texinfo
  @node Symbol Errors
  @section Errors Reading Symbol Files
  
-@@ -41730,6 +41738,7 @@ switch (die->tag)
- * gdbserver man::               Remote Server for the GNU Debugger man page
- * gcore man::                   Generate a core file of a running program
- * gdbinit man::                 gdbinit scripts
-+* gdb-add-index man::           Add index files to speed up GDB
- @end menu
- @node gdb man
-@@ -42382,6 +42391,54 @@ gdb(1), @code{info -f gdb -n Startup}
- The full documentation for @value{GDBN} is maintained as a Texinfo manual.
- If the @code{info} and @code{gdb} programs and @value{GDBN}'s Texinfo
- documentation are properly installed at your site, the command
-+
-+@smallexample
-+info gdb
-+@end smallexample
-+
-+should give you access to the complete manual.
-+
-+@cite{Using GDB: A Guide to the GNU Source-Level Debugger},
-+Richard M. Stallman and Roland H. Pesch, July 1991.
-+@end ifset
-+@c man end
-+
-+@node gdb-add-index man
-+@heading gdb-add-index
-+
-+@c man title gdb-add-index Add index files to speed up GDB
-+
-+@c man begin SYNOPSIS gdb-add-index
-+gdb-add-index @var{filename}
-+@c man end
-+
-+@c man begin DESCRIPTION gdb-add-index
-+When GDB finds a symbol file, it scans the symbols in the file in order
-+to construct an internal symbol table.  This lets most GDB operations
-+work quickly--at the cost of a delay early on.  For large programs,
-+this delay can be quite lengthy, so GDB provides a way to build an
-+index, which speeds up startup.
-+
-+To determine whether a file contains such an index, use the command
-+@command{readelf -S filename}: the index is stored in a section named
-+@code{.gdb_index}.  Note that the index is never generated for files that do
-+not contain DWARF debug information (sections named @code{.debug_*}).
-+
-+See more in
-+@ifset man
-+the @value{GDBN} manual in node @code{Index Files}
-+-- shell command @code{info -f gdb -n 'Index Files'}.
-+@end ifset
-+@ifclear man
-+@ref{Index Files}.
-+@end ifclear
-+@c man end
-+
-+@c man begin SEEALSO gdb-add-index
-+@ifset man
-+The full documentation for @value{GDBN} is maintained as a Texinfo manual.
-+If the @code{info} and @code{gdb} programs and @value{GDBN}'s Texinfo
-+documentation are properly installed at your site, the command
- @smallexample
- info gdb
-Index: gdb-7.5.91.20130407/gdb/gdb-add-index
+Index: gdb-7.4.50.20120103/gdb/gdb-add-index
 ===================================================================
 --- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ gdb-7.5.91.20130407/gdb/gdb-add-index      2013-04-11 16:53:21.524279909 +0200
++++ gdb-7.4.50.20120103/gdb/gdb-add-index      2012-01-03 15:23:43.296231942 +0100
 @@ -0,0 +1,30 @@
 +#! /bin/sh
 +
@@ -177,30 +114,3 @@ Index: gdb-7.5.91.20130407/gdb/gdb-add-index
 +fi
 +
 +exit 0
-Index: gdb-7.5.91.20130407/gdb/doc/Makefile.in
-===================================================================
---- gdb-7.5.91.20130407.orig/gdb/doc/Makefile.in       2013-04-11 16:50:33.202286928 +0200
-+++ gdb-7.5.91.20130407/gdb/doc/Makefile.in    2013-04-11 16:55:06.993279304 +0200
-@@ -177,7 +177,7 @@ POD2MAN5 = pod2man --center="GNU Develop
-                  --release="gdb-`sed q $(srcdir)/../version.in`" --section=5
- # List of man pages generated from gdb.texi
--MAN1S = gdb.1 gdbserver.1 gcore.1
-+MAN1S = gdb.1 gdbserver.1 gcore.1 gdb-add-index.1
- MAN5S = gdbinit.5
- MANS = $(MAN1S) $(MAN5S)
-@@ -626,6 +626,13 @@ gcore.1: $(GDB_DOC_FILES)
-               mv -f $@.T$$$$ $@) || (rm -f $@.T$$$$ && exit 1)
-       rm -f gcore.pod
-+gdb-add-index.1: $(GDB_DOC_FILES)
-+      touch $@
-+      -$(TEXI2POD) $(MANCONF) -Dgdb-add-index < $(srcdir)/gdb.texinfo > gdb-add-index.pod
-+      -($(POD2MAN1) gdb-add-index.pod | sed -e '/^.if n .na/d' > $@.T$$$$ && \
-+              mv -f $@.T$$$$ $@) || (rm -f $@.T$$$$ && exit 1)
-+      rm -f gdb-add-index.pod
-+
- gdbinit.5: $(GDB_DOC_FILES)
-       touch $@
-       -$(TEXI2POD) $(MANCONF) -Dgdbinit < $(srcdir)/gdb.texinfo > gdbinit.pod
This page took 0.085013 seconds and 4 git commands to generate.