]> git.pld-linux.org Git - packages/gdb.git/commitdiff
- notes about updating patches
authorElan Ruusamäe <glen@pld-linux.org>
Tue, 8 Dec 2009 06:55:56 +0000 (06:55 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- gdbtui linked to gdb
- parallel make broken in all senses

Changed files:
    buildid-locate-rpm-pld.patch -> 1.1
    gdb.spec -> 1.119

buildid-locate-rpm-pld.patch [new file with mode: 0644]
gdb.spec

diff --git a/buildid-locate-rpm-pld.patch b/buildid-locate-rpm-pld.patch
new file mode 100644 (file)
index 0000000..ad8bb0e
--- /dev/null
@@ -0,0 +1,13 @@
+--- gdb-7.0/gdb/symfile.c~     2009-12-08 08:19:05.000000000 +0200
++++ gdb-7.0/gdb/symfile.c      2009-12-08 08:47:21.738081248 +0200
+@@ -2236,8 +2236,8 @@
+       fprintf_unfiltered (gdb_stdlog,
+                           _("Missing separate debuginfo for %s\n"), binary);
+         if (debug != NULL)
+-        fprintf_unfiltered (gdb_stdlog, _("Try: %s %s\n"),
+-                            "yum --enablerepo='*-debuginfo' install", debug);
++        fprintf_unfiltered (gdb_stdlog, _("Try to install package that provides `%s' file\n"),
++                            debug);
+       }
+ }
index b08be94403e9b22c9815d586784c16e0bb0b3139..5f948422bb0730400965d36002bbc89cf90058b7 100644 (file)
--- a/gdb.spec
+++ b/gdb.spec
@@ -5,13 +5,13 @@
 # TODO
 # - python subpkg
 # - remove hacks in python, use sys.lib, use standard python dirs
-# - gdbtui is as big as gdb, but different md5, some kind of duplicate?
-# - change yum install msg to poldek one in buildid-locate-rpm.patch
+# - change install msg to poldek in buildid-locate-rpm-pld.patch when poldek allows it. LP#493922
 #
 # Conditional build:
 %bcond_without python          # build without python support
 
 %define                snap    20090930
+%define                rel             0.3
 Summary:       A GNU source-level debugger for C, C++ and Fortran
 Summary(de.UTF-8):     Symbolischer Debugger für C und andere Sprachen
 Summary(es.UTF-8):     Depurador de programas C y otras lenguajes
@@ -25,7 +25,7 @@ Summary(zh_CN.UTF-8): [开发]C和其他语言的调试器
 Summary(zh_TW.UTF-8):  [.-A開發]C和.$)B其.-A他語.$)B言的調試器
 Name:          gdb
 Version:       7.0
-Release:       0.7.fc12.0.1
+Release:       0.7.fc12.%{rel}
 License:       GPL v3+
 Group:         Development/Debuggers
 Source0:       http://ftp.gnu.org/gnu/gdb/%{name}-%{version}.tar.bz2
@@ -35,13 +35,8 @@ Source1:     http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-ma
 Source4:       libstdc++-v3-python-r151798.tar.bz2
 # Source4-md5: 7507540c50a1edeb2fc22a37bc4a08b8
 
-# PLD
-Patch1000:     %{name}-readline.patch
-Patch1001:     %{name}-info.patch
-Patch1002:     %{name}-passflags.patch
-Patch1005:     %{name}-pretty-print-by-default.patch
-
 # FEDORA -- use the same numbering that they do
+# don't ever modify these patches, apply secondary patch to alter it pld way
 # use:'<,'>!grep -vE '^(\#|$)' in vim to filterout comments, spaces
 Patch1:                %{name}-6.3-rh-dummykfail-20041202.patch
 Patch2:                %{name}-6.3-rh-testversion-20041202.patch
@@ -154,6 +149,13 @@ Patch385:  %{name}-bz528668-symfile-multi.patch
 Patch387:      %{name}-bz539590-gnu-ifunc.patch
 Patch388:      %{name}-bz538626-bp_location-accel-bp-cond.patch
 
+# PLD patches
+Patch1000:     %{name}-readline.patch
+Patch1001:     %{name}-info.patch
+Patch1002:     %{name}-passflags.patch
+Patch1005:     %{name}-pretty-print-by-default.patch
+Patch1006:     buildid-locate-rpm-pld.patch
+
 URL:           http://www.gnu.org/software/gdb/
 BuildRequires: autoconf >= 2.53
 BuildRequires: automake
@@ -252,11 +254,6 @@ GDB w postaci biblioteki statycznej.
 # libstdc++ pretty printers.
 bzip2 -dc %{SOURCE4} | tar xf -
 
-%patch1000 -p1
-%patch1001 -p1
-%patch1002 -p1
-%patch1005 -p1
-
 # Files have `# <number> <file>' statements breaking VPATH / find-debuginfo.sh .
 rm -f gdb/ada-exp.c gdb/ada-lex.c gdb/c-exp.c gdb/cp-name-parser.c gdb/f-exp.c
 rm -f gdb/jv-exp.c gdb/m2-exp.c gdb/objc-exp.c gdb/p-exp.c
@@ -372,6 +369,13 @@ rm -f gdb/jv-exp.c gdb/m2-exp.c gdb/objc-exp.c gdb/p-exp.c
 %patch388 -p1
 %patch124 -p1
 
+# PLD patches
+%patch1000 -p1
+%patch1001 -p1
+%patch1002 -p1
+%patch1005 -p1
+%patch1006 -p1
+
 mv $(basename %{SOURCE4} .tar.bz2) libstdcxxpython
 
 %build
@@ -413,7 +417,7 @@ cp -f /usr/share/automake/config.* .
        --without-x
 
 %{__make} -j1
-%{__make} info
+%{__make} -j1 info
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -422,6 +426,11 @@ install -d $RPM_BUILD_ROOT%{_infodir}
 %{__make} -j1 install install-info \
        DESTDIR=$RPM_BUILD_ROOT
 
+# gdbtui seems all identical to gdb except when invoked as gdbtio, ncurses
+# window is created too.
+echo ".so gdb.1" > $RPM_BUILD_ROOT%{_mandir}/man1/gdbtui.1
+ln -f $RPM_BUILD_ROOT%{_bindir}/{gdb,gdbtui}
+
 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
 cp -a gdb/libgdb.a $RPM_BUILD_ROOT%{_libdir}
 
This page took 0.13831 seconds and 4 git commands to generate.