]> git.pld-linux.org Git - packages/gdb.git/commitdiff
- updated
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 24 Feb 2009 08:23:58 +0000 (08:23 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    gdb-readline.patch -> 1.16

gdb-readline.patch

index ef1ca51e8eb2529e0b6e995b8315a4d4859085f4..4022b63e343a37575c534bcc6418ab3eb46d5326 100644 (file)
@@ -174,3 +174,38 @@ diff -ur gdb-6.7.org/Makefile.in gdb-6.7/Makefile.in
  all-sim: maybe-configure-gdb
  all-fastjar: maybe-all-zlib
  all-fastjar: maybe-all-build-texinfo
+--- gdb-6.8.50.20090224/gdb/tui/tui-io.c~      2009-02-24 09:17:18.617891690 +0100
++++ gdb-6.8.50.20090224/gdb/tui/tui-io.c       2009-02-24 09:17:43.554606911 +0100
+@@ -512,7 +512,7 @@
+ void
+ tui_setup_io (int mode)
+ {
+-  extern int readline_echoing_p;
++  extern int _rl_echoing_p;
+  
+   if (mode)
+     {
+@@ -522,12 +522,12 @@
+       tui_old_rl_prep_terminal = rl_prep_term_function;
+       tui_old_rl_getc_function = rl_getc_function;
+       tui_old_rl_outstream = rl_outstream;
+-      tui_old_readline_echoing_p = readline_echoing_p;
++      tui_old_readline_echoing_p = _rl_echoing_p;
+       rl_redisplay_function = tui_redisplay_readline;
+       rl_deprep_term_function = tui_deprep_terminal;
+       rl_prep_term_function = tui_prep_terminal;
+       rl_getc_function = tui_getc;
+-      readline_echoing_p = 0;
++      _rl_echoing_p = 0;
+       rl_outstream = tui_rl_outstream;
+       rl_prompt = 0;
+       rl_completion_display_matches_hook = tui_rl_display_match_list;
+@@ -564,7 +564,7 @@
+       rl_getc_function = tui_old_rl_getc_function;
+       rl_outstream = tui_old_rl_outstream;
+       rl_completion_display_matches_hook = 0;
+-      readline_echoing_p = tui_old_readline_echoing_p;
++      _rl_echoing_p = tui_old_readline_echoing_p;
+       rl_already_prompted = 0;
+       /* Save tty for SIGCONT.  */
This page took 0.092025 seconds and 4 git commands to generate.