]> git.pld-linux.org Git - packages/gdb.git/blobdiff - gdb.spec
- up to 8.3
[packages/gdb.git] / gdb.spec
index b5e7ae85e73e422f5d70d8d4ca2c40400ce15f44..a3fc5a9015e257f81f89242c9184977503577d71 100644 (file)
--- a/gdb.spec
+++ b/gdb.spec
@@ -1,10 +1,12 @@
 # NOTE: -lib package is used by fpc.spec
 
 # TODO
+# - rpm5 librpm support (gdb/configure.ac checks for 4.x or so)
 # - change install msg to poldek in buildid-locate-rpm-pld.patch when poldek allows it. LP#493922
+# - reenable guile after https://sourceware.org/bugzilla/show_bug.cgi?id=21104 is fixed
 #
 # Conditional build:
-%bcond_without guile           # Guile embedded scripting
+%bcond_with    guile           # Guile embedded scripting
 %bcond_without python          # build without python support
 
 Summary:       A GNU source-level debugger for C, C++ and Fortran
@@ -18,14 +20,13 @@ Summary(tr.UTF-8):  C ve diğer diller için sembolik hata ayıklayıcı
 Summary(uk.UTF-8):     Символьний відладчик для С та інших мов
 Summary(zh_CN.UTF-8):  [开发]C和其他语言的调试器
 Summary(zh_TW.UTF-8):  [.-A開發]C和.$)B其.-A他語.$)B言的調試器
-%define                snap    20120926
 Name:          gdb
-Version:       7.9
-Release:       2
+Version:       8.3
+Release:       1
 License:       GPL v3+
 Group:         Development/Debuggers
 Source0:       http://ftp.gnu.org/gnu/gdb/%{name}-%{version}.tar.xz
-# Source0-md5: e6279f26559d839f0b4218a482bcb43e
+# Source0-md5: bbd95b2f9b34621ad7a19a3965476314
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: 2e8a48939ae282c12bbacdd54e398247
 Source3:       %{name}-gstack.man
@@ -35,13 +36,14 @@ Patch102:   gdb-6.6-buildid-locate-rpm.patch
 Patch103:      gdb-6.6-buildid-locate-core-as-arg.patch
 Patch104:      gdb-6.6-buildid-locate-rpm-librpm-workaround.patch
 Patch105:      gdb-6.6-buildid-locate-misleading-warning-missing-debuginfo-rhbz981154.patch
+Patch106:      gdb-6.6-buildid-locate-rpm-scl.patch
 Patch110:      gdb-6.3-gstack-20050411.patch
-Patch111:      gdb-gdb-add-index-script.patch
+
 Patch112:      gdb-archer-vla-tests.patch
-Patch113:      gdb-vla-intel.patch
-Patch114:      gdb-vla-intel-04of23-fix.patch
-Patch115:      gdb-vla-intel-stringbt-fix.patch
-Patch116:      gdb-vla-intel-logical-not.patch
+Patch113:      gdb-vla-intel-fortran-strides.patch
+Patch114:      gdb-vla-intel-stringbt-fix.patch
+Patch115:      gdb-vla-intel-fortran-vla-strings.patch
+Patch116:      gdb-vla-intel-tests.patch
 Patch1000:     %{name}-readline.patch
 Patch1001:     %{name}-info.patch
 Patch1002:     %{name}-passflags.patch
@@ -51,18 +53,27 @@ URL:                http://www.gnu.org/software/gdb/
 BuildRequires: autoconf >= 2.69
 BuildRequires: automake
 BuildRequires: bison
-BuildRequires: babeltrace-devel
+BuildRequires: babeltrace-devel >= 1.1.0
 BuildRequires: expat-devel
-BuildRequires: flex
-BuildRequires: gettext-tools
+BuildRequires: flex >= 2.6.4
+BuildRequires: gettext-tools >= 0.12.1
 %{?with_guile:BuildRequires:   guile-devel >= 2.0}
+%ifarch %{ix86} %{x8664}
+BuildRequires: libipt-devel
+%endif
 BuildRequires: libselinux-devel
+BuildRequires: libstdc++-devel >= 6:4.8
 BuildRequires: libtool
+BuildRequires: make >= 3.81
+BuildRequires: mpfr-devel
 BuildRequires: ncurses-devel >= 5.2
 BuildRequires: pkgconfig
 BuildRequires: readline-devel
 BuildRequires: rpmbuild(macros) >= 1.219
+BuildRequires: tar >= 1:1.22
 BuildRequires: texinfo >= 4.4
+BuildRequires: xz
+BuildRequires: xz-devel
 BuildRequires: zlib-devel
 %if %{with python}
 BuildRequires: python-devel
@@ -71,7 +82,7 @@ Obsoletes:    python-gdb
 # for traceback module
 Requires:      python-modules
 %endif
-%{?with_guile:Requires:        guile >= 2.0}
+%{?with_guile:Requires:        guile >= 2.0.12}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -173,8 +184,8 @@ GDB w postaci biblioteki statycznej.
 %setup -q
 
 # Files have `# <number> <file>' statements breaking VPATH / find-debuginfo.sh .
-rm -f gdb/ada-exp.c gdb/ada-lex.c gdb/c-exp.c gdb/cp-name-parser.c gdb/f-exp.c
-rm -f gdb/jv-exp.c gdb/m2-exp.c gdb/objc-exp.c gdb/p-exp.c
+%{__rm} gdb/ada-exp.c gdb/ada-lex.c gdb/c-exp.c gdb/cp-name-parser.c gdb/f-exp.c
+%{__rm} gdb/m2-exp.c gdb/p-exp.c
 
 %patch100 -p1
 %patch101 -p1
@@ -182,8 +193,9 @@ rm -f gdb/jv-exp.c gdb/m2-exp.c gdb/objc-exp.c gdb/p-exp.c
 %patch103 -p1
 %patch104 -p1
 %patch105 -p1
+%patch106 -p1
 %patch110 -p1
-%patch111 -p1
+
 %patch112 -p1
 %patch113 -p1
 %patch114 -p1
@@ -223,6 +235,7 @@ done
 cp -f /usr/share/automake/config.* .
 # don't --enable-shared here, there would be libs version mismatch with binutils
 %configure \
+       --disable-silent-rules \
        --with-gdb-datadir=%{_datadir}/gdb \
        --with-separate-debug-dir=/usr/lib/debug \
 %if %{with python}
@@ -266,20 +279,21 @@ install -d $RPM_BUILD_ROOT%{_infodir}
 %{__make} -j1 install install-info \
        DESTDIR=$RPM_BUILD_ROOT
 
-# gdbtui seems all identical to gdb except when invoked as gdbtio, ncurses
+cp -a gdb/libgdb.a $RPM_BUILD_ROOT%{_libdir}
+
+# gdbtui seems all identical to gdb except when invoked as gdbtui, ncurses
 # window is created too.
 echo ".so gdb.1" > $RPM_BUILD_ROOT%{_mandir}/man1/gdbtui.1
 ln -f $RPM_BUILD_ROOT%{_bindir}/{gdb,gdbtui}
 
 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
-cp -a gdb/libgdb.a $RPM_BUILD_ROOT%{_libdir}
+%{__rm} $RPM_BUILD_ROOT%{_mandir}/README.gdb-non-english-man-pages
 
 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
-rm -f $RPM_BUILD_ROOT%{_mandir}/README.gdb-non-english-man-pages
 
 %if %{with python}
 # Temporarily now:
-for LIB in lib lib64; do
+for LIB in lib lib64 libx32; do
        LIBPATH="$RPM_BUILD_ROOT%{_datadir}/gdb/auto-load%{_prefix}/$LIB"
        install -d $LIBPATH
 done
@@ -297,7 +311,7 @@ install libdecnumber/libdecnumber.a $RPM_BUILD_ROOT%{_libdir}
 # These are part of binutils:
 %{__rm} $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/{bfd,opcodes}.mo
 %{__rm} $RPM_BUILD_ROOT%{_infodir}/bfd.info*
-%{__rm} $RPM_BUILD_ROOT%{_includedir}/{ansidecl,bfd,bfdlink,dis-asm,symcat,plugin-api}.h
+%{__rm} $RPM_BUILD_ROOT%{_includedir}/{ansidecl,bfd,bfdlink,diagnostics,dis-asm,symcat,plugin-api}.h
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,opcodes}.la
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,opcodes}.a
 
@@ -322,8 +336,9 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_datadir}/gdb/auto-load
 %dir %{_datadir}/gdb/auto-load%{_prefix}
 %dir %{_datadir}/gdb/auto-load%{_prefix}/lib
-%ifarch %{x8664}
+%ifarch %{x8664} x32
 %dir %{_datadir}/gdb/auto-load%{_prefix}/lib64
+%dir %{_datadir}/gdb/auto-load%{_prefix}/libx32
 %endif
 %{?with_guile:%{_datadir}/gdb/guile}
 %{_datadir}/gdb/syscalls
This page took 0.371723 seconds and 4 git commands to generate.