]> git.pld-linux.org Git - packages/gdb.git/blobdiff - gdb.spec
- updated to 8.1.1
[packages/gdb.git] / gdb.spec
index 3724be802648cf5c61afb32e06cc54ae9e83b8ca..1205c56121bf4c04157e710f20de66e31a3446f0 100644 (file)
--- a/gdb.spec
+++ b/gdb.spec
@@ -1,9 +1,11 @@
 # NOTE: -lib package is used by fpc.spec
 
 # TODO
+# - rpm5 librpm support (gdb/configure.ac checks for 4.x or so)
 # - change install msg to poldek in buildid-locate-rpm-pld.patch when poldek allows it. LP#493922
 #
 # Conditional build:
+%bcond_without guile           # Guile embedded scripting
 %bcond_without python          # build without python support
 
 Summary:       A GNU source-level debugger for C, C++ and Fortran
@@ -17,14 +19,13 @@ Summary(tr.UTF-8):  C ve diğer diller için sembolik hata ayıklayıcı
 Summary(uk.UTF-8):     Символьний відладчик для С та інших мов
 Summary(zh_CN.UTF-8):  [开发]C和其他语言的调试器
 Summary(zh_TW.UTF-8):  [.-A開發]C和.$)B其.-A他語.$)B言的調試器
-%define                snap    20120926
 Name:          gdb
-Version:       7.7.1
-Release:       0.1
+Version:       8.1.1
+Release:       1
 License:       GPL v3+
 Group:         Development/Debuggers
-Source0:       http://ftp.gnu.org/gnu/gdb/%{name}-%{version}.tar.bz2
-# Source0-md5: 77b20b515e7c25f032cb9732a66620fe
+Source0:       http://ftp.gnu.org/gnu/gdb/%{name}-%{version}.tar.xz
+# Source0-md5: 372fa63a53adeee1bfbfd581d8da9e34
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: 2e8a48939ae282c12bbacdd54e398247
 Source3:       %{name}-gstack.man
@@ -34,8 +35,14 @@ Patch102:    gdb-6.6-buildid-locate-rpm.patch
 Patch103:      gdb-6.6-buildid-locate-core-as-arg.patch
 Patch104:      gdb-6.6-buildid-locate-rpm-librpm-workaround.patch
 Patch105:      gdb-6.6-buildid-locate-misleading-warning-missing-debuginfo-rhbz981154.patch
+Patch106:      gdb-6.6-buildid-locate-rpm-scl.patch
 Patch110:      gdb-6.3-gstack-20050411.patch
 Patch111:      gdb-gdb-add-index-script.patch
+Patch112:      gdb-archer-vla-tests.patch
+Patch113:      gdb-vla-intel-fortran-strides.patch
+Patch114:      gdb-vla-intel-stringbt-fix.patch
+Patch115:      gdb-vla-intel-fortran-vla-strings.patch
+Patch116:      gdb-vla-intel-tests.patch
 Patch1000:     %{name}-readline.patch
 Patch1001:     %{name}-info.patch
 Patch1002:     %{name}-passflags.patch
@@ -45,17 +52,24 @@ URL:                http://www.gnu.org/software/gdb/
 BuildRequires: autoconf >= 2.69
 BuildRequires: automake
 BuildRequires: bison
+BuildRequires: babeltrace-devel >= 1.1.0
 BuildRequires: expat-devel
-BuildRequires: flex
-BuildRequires: gettext-devel
+BuildRequires: flex >= 2.6.4
+BuildRequires: gettext-tools >= 0.12.1
+%{?with_guile:BuildRequires:   guile-devel >= 2.0}
 BuildRequires: libselinux-devel
+BuildRequires: libstdc++-devel >= 6:4.8
 BuildRequires: libtool
-BuildRequires: libunwind-devel >= 0.97
+BuildRequires: make >= 3.81
+BuildRequires: mpfr-devel
 BuildRequires: ncurses-devel >= 5.2
 BuildRequires: pkgconfig
 BuildRequires: readline-devel
 BuildRequires: rpmbuild(macros) >= 1.219
+BuildRequires: tar >= 1:1.22
 BuildRequires: texinfo >= 4.4
+BuildRequires: xz
+BuildRequires: xz-devel
 BuildRequires: zlib-devel
 %if %{with python}
 BuildRequires: python-devel
@@ -64,7 +78,7 @@ Obsoletes:    python-gdb
 # for traceback module
 Requires:      python-modules
 %endif
-Requires:      libunwind >= 0.97
+%{?with_guile:Requires:        guile >= 2.0.12}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -166,8 +180,8 @@ GDB w postaci biblioteki statycznej.
 %setup -q
 
 # Files have `# <number> <file>' statements breaking VPATH / find-debuginfo.sh .
-rm -f gdb/ada-exp.c gdb/ada-lex.c gdb/c-exp.c gdb/cp-name-parser.c gdb/f-exp.c
-rm -f gdb/jv-exp.c gdb/m2-exp.c gdb/objc-exp.c gdb/p-exp.c
+%{__rm} gdb/ada-exp.c gdb/ada-lex.c gdb/c-exp.c gdb/cp-name-parser.c gdb/f-exp.c
+%{__rm} gdb/m2-exp.c gdb/p-exp.c
 
 %patch100 -p1
 %patch101 -p1
@@ -175,8 +189,14 @@ rm -f gdb/jv-exp.c gdb/m2-exp.c gdb/objc-exp.c gdb/p-exp.c
 %patch103 -p1
 %patch104 -p1
 %patch105 -p1
+%patch106 -p1
 %patch110 -p1
 %patch111 -p1
+%patch112 -p1
+%patch113 -p1
+%patch114 -p1
+%patch115 -p1
+%patch116 -p1
 
 %patch1000 -p1
 %patch1001 -p1
@@ -218,6 +238,11 @@ cp -f /usr/share/automake/config.* .
        --with-pythondir=%{py_sitescriptdir} \
 %else
        --without-python \
+%endif
+%if %{with guile}
+       --with-guile \
+%else
+       --without-guile \
 %endif
        --disable-gdbtk \
        --disable-shared \
@@ -249,20 +274,21 @@ install -d $RPM_BUILD_ROOT%{_infodir}
 %{__make} -j1 install install-info \
        DESTDIR=$RPM_BUILD_ROOT
 
-# gdbtui seems all identical to gdb except when invoked as gdbtio, ncurses
+cp -a gdb/libgdb.a $RPM_BUILD_ROOT%{_libdir}
+
+# gdbtui seems all identical to gdb except when invoked as gdbtui, ncurses
 # window is created too.
 echo ".so gdb.1" > $RPM_BUILD_ROOT%{_mandir}/man1/gdbtui.1
 ln -f $RPM_BUILD_ROOT%{_bindir}/{gdb,gdbtui}
 
 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
-cp -a gdb/libgdb.a $RPM_BUILD_ROOT%{_libdir}
+%{__rm} $RPM_BUILD_ROOT%{_mandir}/README.gdb-non-english-man-pages
 
 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
-rm -f $RPM_BUILD_ROOT%{_mandir}/README.gdb-non-english-man-pages
 
 %if %{with python}
 # Temporarily now:
-for LIB in lib lib64; do
+for LIB in lib lib64 libx32; do
        LIBPATH="$RPM_BUILD_ROOT%{_datadir}/gdb/auto-load%{_prefix}/$LIB"
        install -d $LIBPATH
 done
@@ -279,8 +305,8 @@ install libdecnumber/libdecnumber.a $RPM_BUILD_ROOT%{_libdir}
 # Remove the files that are part of a gdb build but that are owned and provided by other packages.
 # These are part of binutils:
 %{__rm} $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/{bfd,opcodes}.mo
-%{__rm} $RPM_BUILD_ROOT%{_infodir}/{bfd,configure,standards}.info*
-%{__rm} $RPM_BUILD_ROOT%{_includedir}/{ansidecl,bfd,bfdlink,dis-asm,symcat}.h
+%{__rm} $RPM_BUILD_ROOT%{_infodir}/bfd.info*
+%{__rm} $RPM_BUILD_ROOT%{_includedir}/{ansidecl,bfd,bfdlink,dis-asm,symcat,plugin-api}.h
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,opcodes}.la
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,opcodes}.a
 
@@ -305,14 +331,17 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_datadir}/gdb/auto-load
 %dir %{_datadir}/gdb/auto-load%{_prefix}
 %dir %{_datadir}/gdb/auto-load%{_prefix}/lib
-%ifarch %{x8664}
+%ifarch %{x8664} x32
 %dir %{_datadir}/gdb/auto-load%{_prefix}/lib64
+%dir %{_datadir}/gdb/auto-load%{_prefix}/libx32
 %endif
+%{?with_guile:%{_datadir}/gdb/guile}
 %{_datadir}/gdb/syscalls
 %{_datadir}/gdb/system-gdbinit
 %{_datadir}/gdb/python
 %{_mandir}/man1/gdb.1*
 %{_mandir}/man1/gdbtui.1*
+%{_mandir}/man1/gdb-add-index.1*
 %{_mandir}/man1/gstack.1*
 %{_mandir}/man1/gcore.1*
 %{_mandir}/man5/gdbinit.5*
This page took 0.154205 seconds and 4 git commands to generate.