]> git.pld-linux.org Git - packages/gdb.git/blobdiff - gdb-6.8-bz457187-largefile.patch
- update to 6.8.91.20090930-1 from fedora
[packages/gdb.git] / gdb-6.8-bz457187-largefile.patch
index 6e297d7e71c7aa61da6faea981427f6ce4891046..199d7a290f01fffc1711aeac5ed4789579538495 100644 (file)
@@ -5,31 +5,30 @@ gdb/
        * config.in: Regenerate.
        * configure: Regenerate.
 
-diff -up -rup gdb-orig/configure.ac gdb/configure.ac
---- ./gdb-orig/configure.ac    2009-03-02 23:39:01.000000000 +0100
-+++ ./gdb/configure.ac 2009-03-02 23:40:46.000000000 +0100
-@@ -30,6 +30,7 @@ AC_GNU_SOURCE
- AC_AIX
- AC_ISC_POSIX
+Index: gdb-6.8.50.20090909/gdb/configure.ac
+===================================================================
+--- gdb-6.8.50.20090909.orig/gdb/configure.ac  2009-09-09 20:08:04.000000000 +0200
++++ gdb-6.8.50.20090909/gdb/configure.ac       2009-09-09 20:11:04.000000000 +0200
+@@ -28,6 +28,7 @@ AM_MAINTAINER_MODE
+ AC_PROG_CC
+ AC_USE_SYSTEM_EXTENSIONS
  gl_EARLY
 +AC_SYS_LARGEFILE
  AM_PROG_CC_STDC
  
  AC_CONFIG_AUX_DIR(..)
-diff -up -rup gdb-orig/config.in gdb/config.in
---- ./gdb-orig/config.in       2009-03-02 23:39:01.000000000 +0100
-+++ ./gdb/config.in    2009-03-02 23:40:53.000000000 +0100
-@@ -725,6 +725,9 @@
- # undef _ALL_SOURCE
+Index: gdb-6.8.50.20090909/gdb/config.in
+===================================================================
+--- gdb-6.8.50.20090909.orig/gdb/config.in     2009-09-09 20:08:04.000000000 +0200
++++ gdb-6.8.50.20090909/gdb/config.in  2009-09-09 20:11:33.000000000 +0200
+@@ -751,10 +751,16 @@
+ # endif
  #endif
  
 +/* Number of bits in a file offset, on hosts where this is settable. */
 +#undef _FILE_OFFSET_BITS
 +
- /* Enable GNU extensions on systems that have them.  */
- #ifndef _GNU_SOURCE
- # undef _GNU_SOURCE
-@@ -734,6 +737,9 @@
+ /* Define to 1 so <sys/proc.h> gets a definition of anon_hdl. Works around a
     <sys/proc.h> problem on IRIX 5. */
  #undef _KMEMUSER
  
@@ -39,44 +38,49 @@ diff -up -rup gdb-orig/config.in gdb/config.in
  /* Define to 1 if on MINIX. */
  #undef _MINIX
  
-diff -up -rup gdb-orig/configure gdb/configure
---- ./gdb-orig/configure       2009-03-02 23:39:01.000000000 +0100
-+++ ./gdb/configure    2009-03-02 23:40:49.000000000 +0100
-@@ -862,6 +862,7 @@ Optional Features:
+Index: gdb-6.8.50.20090909/gdb/configure
+===================================================================
+--- gdb-6.8.50.20090909.orig/gdb/configure     2009-09-09 20:10:45.000000000 +0200
++++ gdb-6.8.50.20090909/gdb/configure  2009-09-09 20:11:07.000000000 +0200
+@@ -884,6 +884,7 @@ ac_subst_files='host_makefile_frag'
+ ac_user_opts='
+ enable_option_checking
+ enable_maintainer_mode
++enable_largefile
+ enable_dependency_tracking
+ with_separate_debug_dir
+ with_gdb_datadir
+@@ -1562,6 +1563,7 @@ Optional Features:
    --enable-FEATURE[=ARG]  include FEATURE [ARG=yes]
    --enable-maintainer-mode  enable make rules and dependencies not useful
                          (and sometimes confusing) to the casual installer
 +  --disable-largefile     omit support for large files
    --disable-dependency-tracking  speeds up one-time build
    --enable-dependency-tracking   do not reject slow dependency extractors
-   --enable-targets        alternative target configurations
-@@ -3313,6 +3314,370 @@ _ACEOF
+   --enable-targets=TARGETS
+@@ -4100,6 +4102,204 @@ fi
  
  
  
-+# Check whether --enable-largefile or --disable-largefile was given.
-+if test "${enable_largefile+set}" = set; then
-+  enableval="$enable_largefile"
++# Check whether --enable-largefile was given.
++if test "${enable_largefile+set}" = set; then :
++  enableval=$enable_largefile;
++fi
 +
-+fi;
 +if test "$enable_largefile" != no; then
 +
-+  echo "$as_me:$LINENO: checking for special C compiler options needed for large files" >&5
-+echo $ECHO_N "checking for special C compiler options needed for large files... $ECHO_C" >&6
-+if test "${ac_cv_sys_largefile_CC+set}" = set; then
-+  echo $ECHO_N "(cached) $ECHO_C" >&6
++  { $as_echo "$as_me:${as_lineno-$LINENO}: checking for special C compiler options needed for large files" >&5
++$as_echo_n "checking for special C compiler options needed for large files... " >&6; }
++if test "${ac_cv_sys_largefile_CC+set}" = set; then :
++  $as_echo_n "(cached) " >&6
 +else
 +  ac_cv_sys_largefile_CC=no
 +     if test "$GCC" != yes; then
 +       ac_save_CC=$CC
 +       while :; do
-+       # IRIX 6.2 and later do not support large files by default,
-+       # so use the C compiler's -n32 option if that helps.
-+       cat >conftest.$ac_ext <<_ACEOF
-+/* confdefs.h.  */
-+_ACEOF
-+cat confdefs.h >>conftest.$ac_ext
-+cat >>conftest.$ac_ext <<_ACEOF
++       # IRIX 6.2 and later do not support large files by default,
++       # so use the C compiler's -n32 option if that helps.
++       cat confdefs.h - <<_ACEOF >conftest.$ac_ext
 +/* end confdefs.h.  */
 +#include <sys/types.h>
 + /* Check that off_t can represent 2**63 - 1 correctly.
@@ -95,89 +99,34 @@ diff -up -rup gdb-orig/configure gdb/configure
 +  return 0;
 +}
 +_ACEOF
-+       rm -f conftest.$ac_objext
-+if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
-+  (eval $ac_compile) 2>conftest.er1
-+  ac_status=$?
-+  grep -v '^ *+' conftest.er1 >conftest.err
-+  rm -f conftest.er1
-+  cat conftest.err >&5
-+  echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+  (exit $ac_status); } &&
-+       { ac_try='test -z "$ac_c_werror_flag"
-+                       || test ! -s conftest.err'
-+  { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
-+  (eval $ac_try) 2>&5
-+  ac_status=$?
-+  echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+  (exit $ac_status); }; } &&
-+       { ac_try='test -s conftest.$ac_objext'
-+  { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
-+  (eval $ac_try) 2>&5
-+  ac_status=$?
-+  echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+  (exit $ac_status); }; }; then
++       if ac_fn_c_try_compile "$LINENO"; then :
 +  break
-+else
-+  echo "$as_me: failed program was:" >&5
-+sed 's/^/| /' conftest.$ac_ext >&5
-+
 +fi
-+rm -f conftest.err conftest.$ac_objext
-+       CC="$CC -n32"
-+       rm -f conftest.$ac_objext
-+if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
-+  (eval $ac_compile) 2>conftest.er1
-+  ac_status=$?
-+  grep -v '^ *+' conftest.er1 >conftest.err
-+  rm -f conftest.er1
-+  cat conftest.err >&5
-+  echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+  (exit $ac_status); } &&
-+       { ac_try='test -z "$ac_c_werror_flag"
-+                       || test ! -s conftest.err'
-+  { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
-+  (eval $ac_try) 2>&5
-+  ac_status=$?
-+  echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+  (exit $ac_status); }; } &&
-+       { ac_try='test -s conftest.$ac_objext'
-+  { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
-+  (eval $ac_try) 2>&5
-+  ac_status=$?
-+  echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+  (exit $ac_status); }; }; then
++rm -f core conftest.err conftest.$ac_objext
++       CC="$CC -n32"
++       if ac_fn_c_try_compile "$LINENO"; then :
 +  ac_cv_sys_largefile_CC=' -n32'; break
-+else
-+  echo "$as_me: failed program was:" >&5
-+sed 's/^/| /' conftest.$ac_ext >&5
-+
 +fi
-+rm -f conftest.err conftest.$ac_objext
++rm -f core conftest.err conftest.$ac_objext
 +       break
 +       done
 +       CC=$ac_save_CC
 +       rm -f conftest.$ac_ext
 +    fi
 +fi
-+echo "$as_me:$LINENO: result: $ac_cv_sys_largefile_CC" >&5
-+echo "${ECHO_T}$ac_cv_sys_largefile_CC" >&6
++{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_sys_largefile_CC" >&5
++$as_echo "$ac_cv_sys_largefile_CC" >&6; }
 +  if test "$ac_cv_sys_largefile_CC" != no; then
 +    CC=$CC$ac_cv_sys_largefile_CC
 +  fi
 +
-+  echo "$as_me:$LINENO: checking for _FILE_OFFSET_BITS value needed for large files" >&5
-+echo $ECHO_N "checking for _FILE_OFFSET_BITS value needed for large files... $ECHO_C" >&6
-+if test "${ac_cv_sys_file_offset_bits+set}" = set; then
-+  echo $ECHO_N "(cached) $ECHO_C" >&6
++  { $as_echo "$as_me:${as_lineno-$LINENO}: checking for _FILE_OFFSET_BITS value needed for large files" >&5
++$as_echo_n "checking for _FILE_OFFSET_BITS value needed for large files... " >&6; }
++if test "${ac_cv_sys_file_offset_bits+set}" = set; then :
++  $as_echo_n "(cached) " >&6
 +else
 +  while :; do
-+  ac_cv_sys_file_offset_bits=no
-+  cat >conftest.$ac_ext <<_ACEOF
-+/* confdefs.h.  */
-+_ACEOF
-+cat confdefs.h >>conftest.$ac_ext
-+cat >>conftest.$ac_ext <<_ACEOF
++  cat confdefs.h - <<_ACEOF >conftest.$ac_ext
 +/* end confdefs.h.  */
 +#include <sys/types.h>
 + /* Check that off_t can represent 2**63 - 1 correctly.
@@ -196,40 +145,11 @@ diff -up -rup gdb-orig/configure gdb/configure
 +  return 0;
 +}
 +_ACEOF
-+rm -f conftest.$ac_objext
-+if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
-+  (eval $ac_compile) 2>conftest.er1
-+  ac_status=$?
-+  grep -v '^ *+' conftest.er1 >conftest.err
-+  rm -f conftest.er1
-+  cat conftest.err >&5
-+  echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+  (exit $ac_status); } &&
-+       { ac_try='test -z "$ac_c_werror_flag"
-+                       || test ! -s conftest.err'
-+  { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
-+  (eval $ac_try) 2>&5
-+  ac_status=$?
-+  echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+  (exit $ac_status); }; } &&
-+       { ac_try='test -s conftest.$ac_objext'
-+  { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
-+  (eval $ac_try) 2>&5
-+  ac_status=$?
-+  echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+  (exit $ac_status); }; }; then
-+  break
-+else
-+  echo "$as_me: failed program was:" >&5
-+sed 's/^/| /' conftest.$ac_ext >&5
-+
++if ac_fn_c_try_compile "$LINENO"; then :
++  ac_cv_sys_file_offset_bits=no; break
 +fi
-+rm -f conftest.err conftest.$ac_objext conftest.$ac_ext
-+  cat >conftest.$ac_ext <<_ACEOF
-+/* confdefs.h.  */
-+_ACEOF
-+cat confdefs.h >>conftest.$ac_ext
-+cat >>conftest.$ac_ext <<_ACEOF
++rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
++  cat confdefs.h - <<_ACEOF >conftest.$ac_ext
 +/* end confdefs.h.  */
 +#define _FILE_OFFSET_BITS 64
 +#include <sys/types.h>
@@ -249,60 +169,33 @@ diff -up -rup gdb-orig/configure gdb/configure
 +  return 0;
 +}
 +_ACEOF
-+rm -f conftest.$ac_objext
-+if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
-+  (eval $ac_compile) 2>conftest.er1
-+  ac_status=$?
-+  grep -v '^ *+' conftest.er1 >conftest.err
-+  rm -f conftest.er1
-+  cat conftest.err >&5
-+  echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+  (exit $ac_status); } &&
-+       { ac_try='test -z "$ac_c_werror_flag"
-+                       || test ! -s conftest.err'
-+  { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
-+  (eval $ac_try) 2>&5
-+  ac_status=$?
-+  echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+  (exit $ac_status); }; } &&
-+       { ac_try='test -s conftest.$ac_objext'
-+  { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
-+  (eval $ac_try) 2>&5
-+  ac_status=$?
-+  echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+  (exit $ac_status); }; }; then
++if ac_fn_c_try_compile "$LINENO"; then :
 +  ac_cv_sys_file_offset_bits=64; break
-+else
-+  echo "$as_me: failed program was:" >&5
-+sed 's/^/| /' conftest.$ac_ext >&5
-+
 +fi
-+rm -f conftest.err conftest.$ac_objext conftest.$ac_ext
++rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
++  ac_cv_sys_file_offset_bits=unknown
 +  break
 +done
 +fi
-+echo "$as_me:$LINENO: result: $ac_cv_sys_file_offset_bits" >&5
-+echo "${ECHO_T}$ac_cv_sys_file_offset_bits" >&6
-+if test "$ac_cv_sys_file_offset_bits" != no; then
-+
++{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_sys_file_offset_bits" >&5
++$as_echo "$ac_cv_sys_file_offset_bits" >&6; }
++case $ac_cv_sys_file_offset_bits in #(
++  no | unknown) ;;
++  *)
 +cat >>confdefs.h <<_ACEOF
 +#define _FILE_OFFSET_BITS $ac_cv_sys_file_offset_bits
 +_ACEOF
-+
-+fi
-+rm -f conftest*
-+  echo "$as_me:$LINENO: checking for _LARGE_FILES value needed for large files" >&5
-+echo $ECHO_N "checking for _LARGE_FILES value needed for large files... $ECHO_C" >&6
-+if test "${ac_cv_sys_large_files+set}" = set; then
-+  echo $ECHO_N "(cached) $ECHO_C" >&6
++;;
++esac
++rm -rf conftest*
++  if test $ac_cv_sys_file_offset_bits = unknown; then
++    { $as_echo "$as_me:${as_lineno-$LINENO}: checking for _LARGE_FILES value needed for large files" >&5
++$as_echo_n "checking for _LARGE_FILES value needed for large files... " >&6; }
++if test "${ac_cv_sys_large_files+set}" = set; then :
++  $as_echo_n "(cached) " >&6
 +else
 +  while :; do
-+  ac_cv_sys_large_files=no
-+  cat >conftest.$ac_ext <<_ACEOF
-+/* confdefs.h.  */
-+_ACEOF
-+cat confdefs.h >>conftest.$ac_ext
-+cat >>conftest.$ac_ext <<_ACEOF
++  cat confdefs.h - <<_ACEOF >conftest.$ac_ext
 +/* end confdefs.h.  */
 +#include <sys/types.h>
 + /* Check that off_t can represent 2**63 - 1 correctly.
@@ -321,40 +214,11 @@ diff -up -rup gdb-orig/configure gdb/configure
 +  return 0;
 +}
 +_ACEOF
-+rm -f conftest.$ac_objext
-+if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
-+  (eval $ac_compile) 2>conftest.er1
-+  ac_status=$?
-+  grep -v '^ *+' conftest.er1 >conftest.err
-+  rm -f conftest.er1
-+  cat conftest.err >&5
-+  echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+  (exit $ac_status); } &&
-+       { ac_try='test -z "$ac_c_werror_flag"
-+                       || test ! -s conftest.err'
-+  { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
-+  (eval $ac_try) 2>&5
-+  ac_status=$?
-+  echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+  (exit $ac_status); }; } &&
-+       { ac_try='test -s conftest.$ac_objext'
-+  { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
-+  (eval $ac_try) 2>&5
-+  ac_status=$?
-+  echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+  (exit $ac_status); }; }; then
-+  break
-+else
-+  echo "$as_me: failed program was:" >&5
-+sed 's/^/| /' conftest.$ac_ext >&5
-+
++if ac_fn_c_try_compile "$LINENO"; then :
++  ac_cv_sys_large_files=no; break
 +fi
-+rm -f conftest.err conftest.$ac_objext conftest.$ac_ext
-+  cat >conftest.$ac_ext <<_ACEOF
-+/* confdefs.h.  */
-+_ACEOF
-+cat confdefs.h >>conftest.$ac_ext
-+cat >>conftest.$ac_ext <<_ACEOF
++rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
++  cat confdefs.h - <<_ACEOF >conftest.$ac_ext
 +/* end confdefs.h.  */
 +#define _LARGE_FILES 1
 +#include <sys/types.h>
@@ -374,48 +238,26 @@ diff -up -rup gdb-orig/configure gdb/configure
 +  return 0;
 +}
 +_ACEOF
-+rm -f conftest.$ac_objext
-+if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
-+  (eval $ac_compile) 2>conftest.er1
-+  ac_status=$?
-+  grep -v '^ *+' conftest.er1 >conftest.err
-+  rm -f conftest.er1
-+  cat conftest.err >&5
-+  echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+  (exit $ac_status); } &&
-+       { ac_try='test -z "$ac_c_werror_flag"
-+                       || test ! -s conftest.err'
-+  { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
-+  (eval $ac_try) 2>&5
-+  ac_status=$?
-+  echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+  (exit $ac_status); }; } &&
-+       { ac_try='test -s conftest.$ac_objext'
-+  { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
-+  (eval $ac_try) 2>&5
-+  ac_status=$?
-+  echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+  (exit $ac_status); }; }; then
++if ac_fn_c_try_compile "$LINENO"; then :
 +  ac_cv_sys_large_files=1; break
-+else
-+  echo "$as_me: failed program was:" >&5
-+sed 's/^/| /' conftest.$ac_ext >&5
-+
 +fi
-+rm -f conftest.err conftest.$ac_objext conftest.$ac_ext
++rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
++  ac_cv_sys_large_files=unknown
 +  break
 +done
 +fi
-+echo "$as_me:$LINENO: result: $ac_cv_sys_large_files" >&5
-+echo "${ECHO_T}$ac_cv_sys_large_files" >&6
-+if test "$ac_cv_sys_large_files" != no; then
-+
++{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_sys_large_files" >&5
++$as_echo "$ac_cv_sys_large_files" >&6; }
++case $ac_cv_sys_large_files in #(
++  no | unknown) ;;
++  *)
 +cat >>confdefs.h <<_ACEOF
 +#define _LARGE_FILES $ac_cv_sys_large_files
 +_ACEOF
-+
-+fi
-+rm -f conftest*
++;;
++esac
++rm -rf conftest*
++  fi
 +fi
 +
  
This page took 0.11728 seconds and 4 git commands to generate.