]> git.pld-linux.org Git - packages/gdb.git/blobdiff - gdb-6.3-gstack-20050411.patch
- updated to 14.2
[packages/gdb.git] / gdb-6.3-gstack-20050411.patch
index d6f4cb02402f49dd0052c808b98b62b0b3fc3699..01e8ffacd91ebff1ce9b77b8d60b0156bb9972f7 100644 (file)
@@ -1,14 +1,22 @@
+From FEDORA_PATCHES Mon Sep 17 00:00:00 2001
+From: Andrew Cagney <cagney@gnu.org>
+Date: Fri, 27 Oct 2017 21:07:50 +0200
+Subject: gdb-6.3-gstack-20050411.patch
+
+;; Add a wrapper script to GDB that implements pstack using the
+;; --readnever option.
+;;=push
+
 2004-11-23  Andrew Cagney  <cagney@redhat.com>
 
        * Makefile.in (uninstall-gstack, install-gstack): New rules, add
        to install and uninstall.
        * gstack.sh, gstack.1: New files.
 
-Index: gdb-7.4.50.20120103/gdb/Makefile.in
-===================================================================
---- gdb-7.4.50.20120103.orig/gdb/Makefile.in   2012-01-03 05:52:15.000000000 +0100
-+++ gdb-7.4.50.20120103/gdb/Makefile.in        2012-01-03 05:53:25.974210230 +0100
-@@ -1017,7 +1017,7 @@ gdb.z:gdb.1
+diff --git a/gdb/Makefile.in b/gdb/Makefile.in
+--- a/gdb/Makefile.in
++++ b/gdb/Makefile.in
+@@ -2035,7 +2035,7 @@ info install-info clean-info dvi pdf install-pdf html install-html: force
  install: all
        @$(MAKE) $(FLAGS_TO_PASS) install-only
  
@@ -17,7 +25,7 @@ Index: gdb-7.4.50.20120103/gdb/Makefile.in
        transformed_name=`t='$(program_transform_name)'; \
                          echo gdb | sed -e "$$t"` ; \
                if test "x$$transformed_name" = x; then \
-@@ -1039,7 +1039,25 @@ install-only: $(CONFIG_INSTALL)
+@@ -2085,7 +2085,25 @@ install-guile:
  install-python:
        $(SHELL) $(srcdir)/../mkinstalldirs $(DESTDIR)$(GDB_DATADIR)/python/gdb
  
@@ -44,8 +52,8 @@ Index: gdb-7.4.50.20120103/gdb/Makefile.in
        transformed_name=`t='$(program_transform_name)'; \
                          echo gdb | sed -e $$t` ; \
                if test "x$$transformed_name" = x; then \
-@@ -1051,6 +1069,18 @@ uninstall: force $(CONFIG_UNINSTALL)
-                     $(DESTDIR)$(man1dir)/$$transformed_name.1
+@@ -2116,6 +2134,18 @@ uninstall: force $(CONFIG_UNINSTALL)
+       rm -f $(DESTDIR)$(bindir)/$$transformed_name
        @$(MAKE) DO=uninstall "DODIRS=$(SUBDIRS)" $(FLAGS_TO_PASS) subdir_do
  
 +.PHONY: uninstall-gstack
@@ -59,14 +67,14 @@ Index: gdb-7.4.50.20120103/gdb/Makefile.in
 +              fi ; \
 +              rm -f $(DESTDIR)$(bindir)/$$transformed_name$(EXEEXT) \
 +                    $(DESTDIR)$(man1dir)/$$transformed_name.1
-+ 
++
  # The C++ name parser can be built standalone for testing.
  test-cp-name-parser.o: cp-name-parser.c
        $(COMPILE) -DTEST_CPNAMES cp-name-parser.c
-Index: gdb-7.4.50.20120103/gdb/gstack.sh
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ gdb-7.4.50.20120103/gdb/gstack.sh  2012-01-03 05:52:37.278385632 +0100
+diff --git a/gdb/gstack.sh b/gdb/gstack.sh
+new file mode 100644
+--- /dev/null
++++ b/gdb/gstack.sh
 @@ -0,0 +1,43 @@
 +#!/bin/sh
 +
@@ -97,11 +105,11 @@ Index: gdb-7.4.50.20120103/gdb/gstack.sh
 +    fi
 +fi
 +
-+GDB=${GDB:-/usr/bin/gdb}
++GDB=${GDB:-gdb}
 +
 +# Run GDB, strip out unwanted noise.
 +# --readnever is no longer used since .gdb_index is now in use.
-+$GDB --quiet -nx /proc/$1/exe $1 <<EOF 2>&1 | 
++$GDB --quiet -nx $GDBARGS /proc/$1/exe $1 <<EOF 2>&1 |
 +set width 0
 +set height 0
 +set pagination no
@@ -111,11 +119,59 @@ Index: gdb-7.4.50.20120103/gdb/gstack.sh
 +    -e 's/^\((gdb) \)*//' \
 +    -e '/^#/p' \
 +    -e '/^Thread/p'
-Index: gdb-7.4.50.20120103/gdb/testsuite/gdb.base/gstack.exp
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ gdb-7.4.50.20120103/gdb/testsuite/gdb.base/gstack.exp      2012-01-03 05:52:37.279385629 +0100
-@@ -0,0 +1,66 @@
+diff --git a/gdb/testsuite/gdb.base/gstack.c b/gdb/testsuite/gdb.base/gstack.c
+new file mode 100644
+--- /dev/null
++++ b/gdb/testsuite/gdb.base/gstack.c
+@@ -0,0 +1,43 @@
++/* This testcase is part of GDB, the GNU debugger.
++
++   Copyright 2005, 2007, 2008, 2009 Free Software Foundation, Inc.
++
++   This program is free software; you can redistribute it and/or modify
++   it under the terms of the GNU General Public License as published by
++   the Free Software Foundation; either version 3 of the License, or
++   (at your option) any later version.
++
++   This program is distributed in the hope that it will be useful,
++   but WITHOUT ANY WARRANTY; without even the implied warranty of
++   MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
++   GNU General Public License for more details.
++
++   You should have received a copy of the GNU General Public License
++   along with this program.  If not, see <http://www.gnu.org/licenses/>.  */
++
++#include <stdio.h>
++#include <unistd.h>
++#include <string.h>
++
++void
++func (void)
++{
++  const char msg[] = "looping\n";
++
++  /* Use the most simple notification not to get caught by attach on exiting
++     the function.  */
++  write (1, msg, strlen (msg));
++
++  for (;;);
++}
++
++int
++main (void)
++{
++  alarm (60);
++  nice (100);
++
++  func ();
++
++  return 0;
++}
+diff --git a/gdb/testsuite/gdb.base/gstack.exp b/gdb/testsuite/gdb.base/gstack.exp
+new file mode 100644
+--- /dev/null
++++ b/gdb/testsuite/gdb.base/gstack.exp
+@@ -0,0 +1,84 @@
 +# Copyright (C) 2012 Free Software Foundation, Inc.
 +
 +# This program is free software; you can redistribute it and/or modify
@@ -133,7 +189,7 @@ Index: gdb-7.4.50.20120103/gdb/testsuite/gdb.base/gstack.exp
 +
 +set testfile gstack
 +set executable ${testfile}
-+set binfile ${objdir}/${subdir}/$executable
++set binfile [standard_output_file $executable]
 +if {[build_executable ${testfile} ${executable} "" {debug}] == -1} {
 +    return -1
 +}
@@ -146,6 +202,10 @@ Index: gdb-7.4.50.20120103/gdb/testsuite/gdb.base/gstack.exp
 +    fail $test
 +    return
 +}
++
++# The spawn id of the test inferior.
++set test_spawn_id $res
++
 +set use_gdb_stub 1
 +set pid [exp_pid -i $res]
 +gdb_expect {
@@ -161,72 +221,38 @@ Index: gdb-7.4.50.20120103/gdb/testsuite/gdb.base/gstack.exp
 +      return
 +    }
 +}
-+gdb_exit
 +
 +# Testcase uses the most simple notification not to get caught by attach on
 +# exiting the function.  Still we could retry the gstack command if we fail.
 +
 +set test "spawn gstack"
-+set command "sh -c GDB=$GDB\\ sh\\ ${srcdir}/../gstack.sh\\ $pid\\;echo\\ GSTACK-END"
++set command "sh -c GDB=$GDB\\ GDBARGS=-data-directory\\\\\\ $BUILD_DATA_DIRECTORY\\ sh\\ ${srcdir}/../gstack.sh\\ $pid\\;echo\\ GSTACK-END"
 +set res [remote_spawn host $command];
 +if { $res < 0 || $res == "" } {
 +    perror "Spawning $command failed."
 +    fail $test
 +}
-+set pid [exp_pid -i $res]
++
++set gdb_spawn_id $res
++
 +gdb_test_multiple "" $test {
 +    -re "^#0 +(0x\[0-9a-f\]+ in )?\\.?func \\(\\) at \[^\r\n\]*\r\n#1 +0x\[0-9a-f\]+ in \\.?main \\(\\) at \[^\r\n\]*\r\nGSTACK-END\r\n\$" {
 +      pass $test
 +    }
 +}
-+gdb_exit
-+
-+remote_exec host "kill -9 $pid"
-Index: gdb-7.4.50.20120103/gdb/testsuite/gdb.base/gstack.c
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ gdb-7.4.50.20120103/gdb/testsuite/gdb.base/gstack.c        2012-01-03 05:52:37.279385629 +0100
-@@ -0,0 +1,43 @@
-+/* This testcase is part of GDB, the GNU debugger.
-+
-+   Copyright 2005, 2007, 2008, 2009 Free Software Foundation, Inc.
-+
-+   This program is free software; you can redistribute it and/or modify
-+   it under the terms of the GNU General Public License as published by
-+   the Free Software Foundation; either version 3 of the License, or
-+   (at your option) any later version.
-+
-+   This program is distributed in the hope that it will be useful,
-+   but WITHOUT ANY WARRANTY; without even the implied warranty of
-+   MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-+   GNU General Public License for more details.
-+
-+   You should have received a copy of the GNU General Public License
-+   along with this program.  If not, see <http://www.gnu.org/licenses/>.  */
 +
-+#include <stdio.h>
-+#include <unistd.h>
-+#include <string.h>
++gdb_test_multiple "" "gstack exits" {
++    eof {
++      set result [wait -i $gdb_spawn_id]
++      verbose $result
 +
-+void
-+func (void)
-+{
-+  const char msg[] = "looping\n";
++      gdb_assert { [lindex $result 2] == 0 } "gstack exits with no error"
++      gdb_assert { [lindex $result 3] == 0 } "gstack's exit status is 0"
 +
-+  /* Use the most simple notification not to get caught by attach on exiting
-+     the function.  */
-+  write (1, msg, strlen (msg));
-+  
-+  for (;;);
++      remote_close host
++      clear_gdb_spawn_id
++    }
 +}
 +
-+int
-+main (void)
-+{
-+  alarm (60);
-+  nice (100);
-+
-+  func ();
-+
-+  return 0;
-+}
++# Kill the test inferior.
++kill_wait_spawned_process $test_spawn_id
This page took 0.067816 seconds and 4 git commands to generate.