]> git.pld-linux.org Git - packages/gdb.git/blob - gdb.spec
- updated to 14.1 + rebased Fedora buildid patches set
[packages/gdb.git] / gdb.spec
1 # NOTE: -lib package is used by fpc.spec
2
3 # TODO
4 # - rpm5 librpm support (gdb/configure.ac checks for 4.x or so)
5 # - change install msg to poldek in buildid-locate-rpm-pld.patch when poldek allows it. LP#493922
6 #
7 # Conditional build:
8 %bcond_without  guile           # Guile embedded scripting
9 %bcond_without  python          # build without python support
10
11 Summary:        A GNU source-level debugger for C, C++ and Fortran
12 Summary(de.UTF-8):      Symbolischer Debugger für C und andere Sprachen
13 Summary(es.UTF-8):      Depurador de programas C y otras lenguajes
14 Summary(fr.UTF-8):      Débugger symbolique pour C et d'autres langages
15 Summary(pl.UTF-8):      Symboliczny odpluskwiacz dla C i innych języków
16 Summary(pt_BR.UTF-8):   Depurador de programas C e outras linguagens
17 Summary(ru.UTF-8):      Символический отладчик для C и других языков
18 Summary(tr.UTF-8):      C ve diğer diller için sembolik hata ayıklayıcı
19 Summary(uk.UTF-8):      Символьний відладчик для С та інших мов
20 Summary(zh_CN.UTF-8):   [开发]C和其他语言的调试器
21 Summary(zh_TW.UTF-8):   [.-A開發]C和.$)B其.-A他語.$)B言的調試器
22 Name:           gdb
23 Version:        8.1
24 Release:        1
25 License:        GPL v3+
26 Group:          Development/Debuggers
27 Source0:        http://ftp.gnu.org/gnu/gdb/%{name}-%{version}.tar.xz
28 # Source0-md5:  f46487561f9a16916a8102316f7fd105
29 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
30 # Source1-md5:  2e8a48939ae282c12bbacdd54e398247
31 Source3:        %{name}-gstack.man
32 Patch100:       gdb-6.6-buildid-locate.patch
33 Patch101:       gdb-6.6-buildid-locate-solib-missing-ids.patch
34 Patch102:       gdb-6.6-buildid-locate-rpm.patch
35 Patch103:       gdb-6.6-buildid-locate-core-as-arg.patch
36 Patch104:       gdb-6.6-buildid-locate-rpm-librpm-workaround.patch
37 Patch105:       gdb-6.6-buildid-locate-misleading-warning-missing-debuginfo-rhbz981154.patch
38 Patch106:       gdb-6.6-buildid-locate-rpm-scl.patch
39 Patch110:       gdb-6.3-gstack-20050411.patch
40 Patch111:       gdb-gdb-add-index-script.patch
41 Patch112:       gdb-archer-vla-tests.patch
42 Patch113:       gdb-vla-intel-fortran-strides.patch
43 Patch114:       gdb-vla-intel-stringbt-fix.patch
44 Patch115:       gdb-vla-intel-fortran-vla-strings.patch
45 Patch116:       gdb-vla-intel-tests.patch
46 Patch1000:      %{name}-readline.patch
47 Patch1001:      %{name}-info.patch
48 Patch1002:      %{name}-passflags.patch
49 Patch1005:      %{name}-pretty-print-by-default.patch
50 Patch1006:      buildid-locate-rpm-pld.patch
51 URL:            http://www.gnu.org/software/gdb/
52 BuildRequires:  autoconf >= 2.69
53 BuildRequires:  automake
54 BuildRequires:  bison
55 BuildRequires:  babeltrace-devel >= 1.1.0
56 BuildRequires:  expat-devel
57 BuildRequires:  flex >= 2.6.4
58 BuildRequires:  gettext-tools >= 0.12.1
59 %{?with_guile:BuildRequires:    guile-devel >= 2.0}
60 BuildRequires:  libselinux-devel
61 BuildRequires:  libstdc++-devel >= 6:4.8
62 BuildRequires:  libtool
63 BuildRequires:  make >= 3.81
64 BuildRequires:  ncurses-devel >= 5.2
65 BuildRequires:  pkgconfig
66 BuildRequires:  readline-devel
67 BuildRequires:  rpmbuild(macros) >= 1.219
68 BuildRequires:  texinfo >= 4.4
69 BuildRequires:  xz-devel
70 BuildRequires:  zlib-devel
71 %if %{with python}
72 BuildRequires:  python-devel
73 BuildRequires:  rpm-pythonprov
74 Obsoletes:      python-gdb
75 # for traceback module
76 Requires:       python-modules
77 %endif
78 %{?with_guile:Requires: guile >= 2.0.12}
79 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
80
81 %description
82 Gdb is a full featured, command driven debugger. Gdb allows you to
83 trace the execution of programs and examine their internal state at
84 any time. Gdb works for C and C++ compiled with the GNU C compiler
85 gcc.
86
87 %description -l de.UTF-8
88 dem Sie die Ausführung von Programmen verfolgen und jederzeit den
89 inneren Zustand überprüfen können. Er funktioniert für C und mit GNU C
90 kompiliertes C++.
91
92 %description -l es.UTF-8
93 Este es un debugger orientado a comandos repleto de características.
94 Te permite rastrear la ejecución de programas y examinar su estado
95 interno a cualquier momento. Funciona para C y C++ compilado con el
96 compilador GNU C.
97
98 %description -l fr.UTF-8
99 Débugger complet, piloté par commandes. Permet de tracer l'exécution
100 des programmes et d'examiner à tout moment leur état interne.
101 Fonctionne avec les binaires C et C++ compilés avec le compilateur C
102 de GNU, gcc.
103
104 %description -l pl.UTF-8
105 Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalającym
106 śledzić wykonywanie programu i badać jego stan wewnętrzny. Gdb
107 umożliwia odpluskwianie programów napisanych w C/C++ i skompilowanych
108 przy pomocy kompilatora GNU (gcc).
109
110 %description -l pt_BR.UTF-8
111 Este é um debugger orientado a comandos repleto de características.
112 Ele permite à você rastrear a execução de programas e examinar o seu
113 estado interno a qualquer momento. Ele funciona para para C e C++
114 compilado com o compilador GNU C.
115
116 %description -l ru.UTF-8
117 Это полноценный отладчик, управляемый командами. Он позволяет
118 трассировать исполнение программ и изучать их внутреннее состояние в
119 любой момент времени. Работает с программами на C и C++,
120 скомпилированными GNU компилятором C (gcc, egcs, pgcc).
121
122 %description -l tr.UTF-8
123 Bir komut arayüzü üzerinden programcıya programını adım adım izleme
124 (trace) ve herhangi bir anda programın durumunu inceleme olanağı
125 verir.
126
127 %description -l uk.UTF-8
128 Це повноцінний відладчик, що керується командами. Він дозволяє
129 трасувати виконання програм та вивчати їх внутрішній стан в довільний
130 момент часу. Працює з програмами на C та C++, зкомпільованими
131 компіляторами GNU C (gcc, egcs, pgcc).
132
133 %package gdbserver
134 Summary:        A standalone server for GDB (the GNU source-level debugger)
135 Summary(pl.UTF-8):      Samodzielny serwer GDB (debuggera GNU)
136 Group:          Development/Debuggers
137
138 %description gdbserver
139 GDB, the GNU debugger, allows you to debug programs written in C, C++,
140 Java, and other languages, by executing them in a controlled fashion
141 and printing their data.
142
143 This package provides a program that allows you to run GDB on a
144 different machine than the one which is running the program being
145 debugged.
146
147 %description gdbserver -l pl.UTF-8
148 GDB (GNU debugger) pozwala śledzić programy napisane w C, C++, Javie i
149 innych językach programowania poprzez wykonywanie ich w sposób
150 kontrolowany oraz wypisywanie ich danych.
151
152 Ten pakiet zawiera program pozwalający uruchamiać GDB na innej
153 maszynie niż ta, na której działa śledzony program.
154
155 %package lib
156 Summary:        GDB in the form of a static library
157 Summary(pl.UTF-8):      GDB w postaci biblioteki statycznej
158 Group:          Development/Debuggers
159 # libraries that needs to be linked to fulfill libgdb.a symbol requirements
160 Requires:       binutils-devel >= 2.17.50
161 Requires:       expat-devel
162 Requires:       libselinux-devel
163 Requires:       libsepol-devel
164 Requires:       ncurses-devel
165 Requires:       python-devel
166 Requires:       readline-devel
167 Requires:       xz-devel
168 Requires:       zlib-devel
169
170 %description lib
171 GDB in the form of a static library.
172
173 %description lib -l pl.UTF-8
174 GDB w postaci biblioteki statycznej.
175
176 %prep
177 %setup -q
178
179 # Files have `# <number> <file>' statements breaking VPATH / find-debuginfo.sh .
180 rm -f gdb/ada-exp.c gdb/ada-lex.c gdb/c-exp.c gdb/cp-name-parser.c gdb/f-exp.c
181 rm -f gdb/jv-exp.c gdb/m2-exp.c gdb/objc-exp.c gdb/p-exp.c
182
183 %patch100 -p1
184 %patch101 -p1
185 %patch102 -p1
186 %patch103 -p1
187 %patch104 -p1
188 %patch105 -p1
189 %patch106 -p1
190 %patch110 -p1
191 %patch111 -p1
192 %patch112 -p1
193 %patch113 -p1
194 %patch114 -p1
195 %patch115 -p1
196 %patch116 -p1
197
198 %patch1000 -p1
199 %patch1001 -p1
200 %patch1002 -p1
201 %patch1005 -p1
202 %patch1006 -p1
203
204 # Change the version that gets printed at GDB startup, so it is PLD Linux specific.
205 cat > gdb/version.in << EOF
206 %{version}-%{release} (PLD Linux)
207 EOF
208
209 sed -i -e 's#_GCC_AUTOCONF_VERSION\], \[2\.64\]#_GCC_AUTOCONF_VERSION], [2.69]#g' config/override.m4
210
211 %build
212 # omit hand-written gdb/testsuite aclocal.m4
213 for dir in gdb gdb/gdbserver ; do
214         olddir=$(pwd)
215         cd $dir
216         %{__rm} aclocal.m4
217         %{__aclocal} $(grep '^ACLOCAL_AMFLAGS' Makefile.in | sed -e 's/.*=//')
218         cd $olddir
219 done
220 for dir in $(find gdb -name 'configure.in' -o -name 'configure.ac'); do
221         dir=$(dirname "$dir")
222         olddir=$(pwd)
223         cd $dir
224         %{__autoconf}
225         grep -q AC_CONFIG_HEADER configure.* && %{__autoheader}
226         cd $olddir
227 done
228 cp -f /usr/share/automake/config.* .
229 # don't --enable-shared here, there would be libs version mismatch with binutils
230 %configure \
231         --with-gdb-datadir=%{_datadir}/gdb \
232         --with-separate-debug-dir=/usr/lib/debug \
233 %if %{with python}
234         --with-python=yes \
235         --with-pythondir=%{py_sitescriptdir} \
236 %else
237         --without-python \
238 %endif
239 %if %{with guile}
240         --with-guile \
241 %else
242         --without-guile \
243 %endif
244         --disable-gdbtk \
245         --disable-shared \
246         --enable-gdbcli \
247         --enable-gdbmi \
248         --enable-multi-ice \
249         --enable-netrom \
250         --enable-nls \
251         --enable-tui \
252         --with-system-readline \
253         --with-cpu=%{_target_cpu} \
254 %ifnarch alpha
255         --with-mmalloc \
256 %endif
257         --without-included-gettext \
258         --without-included-regex \
259         --without-x
260
261 %{__make}
262 %{__make} -j1 info
263
264 # gdb/ChangeLog: Build gdb directly from *.o files not using libgdb.a.
265 %{__make} -C gdb libgdb.a
266
267 %install
268 rm -rf $RPM_BUILD_ROOT
269 install -d $RPM_BUILD_ROOT%{_infodir}
270
271 %{__make} -j1 install install-info \
272         DESTDIR=$RPM_BUILD_ROOT
273
274 cp -a gdb/libgdb.a $RPM_BUILD_ROOT%{_libdir}
275
276 # gdbtui seems all identical to gdb except when invoked as gdbtui, ncurses
277 # window is created too.
278 echo ".so gdb.1" > $RPM_BUILD_ROOT%{_mandir}/man1/gdbtui.1
279 ln -f $RPM_BUILD_ROOT%{_bindir}/{gdb,gdbtui}
280
281 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
282 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.gdb-non-english-man-pages
283
284 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
285
286 %if %{with python}
287 # Temporarily now:
288 for LIB in lib lib64 libx32; do
289         LIBPATH="$RPM_BUILD_ROOT%{_datadir}/gdb/auto-load%{_prefix}/$LIB"
290         install -d $LIBPATH
291 done
292
293 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
294 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
295 %py_postclean
296 %endif
297
298 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_mandir}/man1/gstack.1
299
300 install libdecnumber/libdecnumber.a $RPM_BUILD_ROOT%{_libdir}
301
302 # Remove the files that are part of a gdb build but that are owned and provided by other packages.
303 # These are part of binutils:
304 %{__rm} $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/{bfd,opcodes}.mo
305 %{__rm} $RPM_BUILD_ROOT%{_infodir}/bfd.info*
306 %{__rm} $RPM_BUILD_ROOT%{_includedir}/{ansidecl,bfd,bfdlink,dis-asm,symcat,plugin-api}.h
307 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,opcodes}.la
308 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,opcodes}.a
309
310 %clean
311 rm -rf $RPM_BUILD_ROOT
312
313 %post   -p /sbin/postshell
314 -/usr/sbin/fix-info-dir -c %{_infodir}
315
316 %postun -p /sbin/postshell
317 -/usr/sbin/fix-info-dir -c %{_infodir}
318
319 %files
320 %defattr(644,root,root,755)
321 %doc gdb/{ChangeLog,NEWS,PROBLEMS,README}
322 %attr(755,root,root) %{_bindir}/gdb
323 %attr(755,root,root) %{_bindir}/gdbtui
324 %attr(755,root,root) %{_bindir}/gdb-add-index
325 %attr(755,root,root) %{_bindir}/gstack
326 %attr(755,root,root) %{_bindir}/gcore
327 %dir %{_datadir}/gdb
328 %dir %{_datadir}/gdb/auto-load
329 %dir %{_datadir}/gdb/auto-load%{_prefix}
330 %dir %{_datadir}/gdb/auto-load%{_prefix}/lib
331 %ifarch %{x8664} x32
332 %dir %{_datadir}/gdb/auto-load%{_prefix}/lib64
333 %dir %{_datadir}/gdb/auto-load%{_prefix}/libx32
334 %endif
335 %{?with_guile:%{_datadir}/gdb/guile}
336 %{_datadir}/gdb/syscalls
337 %{_datadir}/gdb/system-gdbinit
338 %{_datadir}/gdb/python
339 %{_mandir}/man1/gdb.1*
340 %{_mandir}/man1/gdbtui.1*
341 %{_mandir}/man1/gdb-add-index.1*
342 %{_mandir}/man1/gstack.1*
343 %{_mandir}/man1/gcore.1*
344 %{_mandir}/man5/gdbinit.5*
345 %lang(es) %{_mandir}/es/man1/*
346 %lang(fr) %{_mandir}/fr/man1/*
347 %lang(hu) %{_mandir}/hu/man1/*
348 %lang(ja) %{_mandir}/ja/man1/*
349 %lang(pl) %{_mandir}/pl/man1/*
350 %{_infodir}/annotate.info*
351 %{_infodir}/gdb.info*
352 %{_infodir}/stabs.info*
353
354 %files gdbserver
355 %defattr(644,root,root,755)
356 %attr(755,root,root) %{_bindir}/gdbserver
357 %{_mandir}/man1/gdbserver.1*
358 %attr(755,root,root) %{_libdir}/libinproctrace.so
359
360 %files lib
361 %defattr(644,root,root,755)
362 %{_libdir}/libdecnumber.a
363 %{_libdir}/libgdb.a
364 %{_includedir}/gdb
This page took 0.047892 seconds and 3 git commands to generate.