]> git.pld-linux.org Git - packages/gdb.git/blame_incremental - gdb.spec
- updated to 14.1 + rebased Fedora buildid patches set
[packages/gdb.git] / gdb.spec
... / ...
CommitLineData
1# NOTE: -lib package is used by fpc.spec
2
3# TODO
4# - rpm5 librpm support (gdb/configure.ac checks for 4.x or so)
5# - change install msg to poldek in buildid-locate-rpm-pld.patch when poldek allows it. LP#493922
6#
7# Conditional build:
8%bcond_without guile # Guile embedded scripting
9%bcond_without python # build without python support
10
11Summary: A GNU source-level debugger for C, C++ and Fortran
12Summary(de.UTF-8): Symbolischer Debugger für C und andere Sprachen
13Summary(es.UTF-8): Depurador de programas C y otras lenguajes
14Summary(fr.UTF-8): Débugger symbolique pour C et d'autres langages
15Summary(pl.UTF-8): Symboliczny odpluskwiacz dla C i innych języków
16Summary(pt_BR.UTF-8): Depurador de programas C e outras linguagens
17Summary(ru.UTF-8): Символический отладчик для C и других языков
18Summary(tr.UTF-8): C ve diğer diller için sembolik hata ayıklayıcı
19Summary(uk.UTF-8): Символьний відладчик для С та інших мов
20Summary(zh_CN.UTF-8): [开发]C和其他语言的调试器
21Summary(zh_TW.UTF-8): [.-A開發]C和.$)B其.-A他語.$)B言的調試器
22%define snap 20120926
23Name: gdb
24Version: 8.0.1
25Release: 1
26License: GPL v3+
27Group: Development/Debuggers
28Source0: http://ftp.gnu.org/gnu/gdb/%{name}-%{version}.tar.xz
29# Source0-md5: 48cac527e6f3018b865ece021e9723ac
30Source1: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
31# Source1-md5: 2e8a48939ae282c12bbacdd54e398247
32Source3: %{name}-gstack.man
33Patch0: x32.patch
34Patch100: gdb-6.6-buildid-locate.patch
35Patch101: gdb-6.6-buildid-locate-solib-missing-ids.patch
36Patch102: gdb-6.6-buildid-locate-rpm.patch
37Patch103: gdb-6.6-buildid-locate-core-as-arg.patch
38Patch104: gdb-6.6-buildid-locate-rpm-librpm-workaround.patch
39Patch105: gdb-6.6-buildid-locate-misleading-warning-missing-debuginfo-rhbz981154.patch
40Patch106: gdb-6.6-buildid-locate-rpm-scl.patch
41Patch110: gdb-6.3-gstack-20050411.patch
42Patch111: gdb-gdb-add-index-script.patch
43Patch112: gdb-archer-vla-tests.patch
44Patch113: gdb-vla-intel-fortran-strides.patch
45Patch114: gdb-vla-intel-stringbt-fix.patch
46Patch115: gdb-vla-intel-fortran-vla-strings.patch
47Patch116: gdb-vla-intel-tests.patch
48Patch1000: %{name}-readline.patch
49Patch1001: %{name}-info.patch
50Patch1002: %{name}-passflags.patch
51Patch1005: %{name}-pretty-print-by-default.patch
52Patch1006: buildid-locate-rpm-pld.patch
53URL: http://www.gnu.org/software/gdb/
54BuildRequires: autoconf >= 2.69
55BuildRequires: automake
56BuildRequires: bison
57BuildRequires: babeltrace-devel >= 1.1.0
58BuildRequires: expat-devel
59BuildRequires: flex >= 2.6.4
60BuildRequires: gettext-tools >= 0.12.1
61%{?with_guile:BuildRequires: guile-devel >= 2.0}
62BuildRequires: libselinux-devel
63BuildRequires: libstdc++-devel >= 6:4.8
64BuildRequires: libtool
65BuildRequires: make >= 3.81
66BuildRequires: ncurses-devel >= 5.2
67BuildRequires: pkgconfig
68BuildRequires: readline-devel
69BuildRequires: rpmbuild(macros) >= 1.219
70BuildRequires: texinfo >= 4.4
71BuildRequires: xz-devel
72BuildRequires: zlib-devel
73%if %{with python}
74BuildRequires: python-devel
75BuildRequires: rpm-pythonprov
76Obsoletes: python-gdb
77# for traceback module
78Requires: python-modules
79%endif
80%{?with_guile:Requires: guile >= 2.0.12}
81BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
82
83%description
84Gdb is a full featured, command driven debugger. Gdb allows you to
85trace the execution of programs and examine their internal state at
86any time. Gdb works for C and C++ compiled with the GNU C compiler
87gcc.
88
89%description -l de.UTF-8
90dem Sie die Ausführung von Programmen verfolgen und jederzeit den
91inneren Zustand überprüfen können. Er funktioniert für C und mit GNU C
92kompiliertes C++.
93
94%description -l es.UTF-8
95Este es un debugger orientado a comandos repleto de características.
96Te permite rastrear la ejecución de programas y examinar su estado
97interno a cualquier momento. Funciona para C y C++ compilado con el
98compilador GNU C.
99
100%description -l fr.UTF-8
101Débugger complet, piloté par commandes. Permet de tracer l'exécution
102des programmes et d'examiner à tout moment leur état interne.
103Fonctionne avec les binaires C et C++ compilés avec le compilateur C
104de GNU, gcc.
105
106%description -l pl.UTF-8
107Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalającym
108śledzić wykonywanie programu i badać jego stan wewnętrzny. Gdb
109umożliwia odpluskwianie programów napisanych w C/C++ i skompilowanych
110przy pomocy kompilatora GNU (gcc).
111
112%description -l pt_BR.UTF-8
113Este é um debugger orientado a comandos repleto de características.
114Ele permite à você rastrear a execução de programas e examinar o seu
115estado interno a qualquer momento. Ele funciona para para C e C++
116compilado com o compilador GNU C.
117
118%description -l ru.UTF-8
119Это полноценный отладчик, управляемый командами. Он позволяет
120трассировать исполнение программ и изучать их внутреннее состояние в
121любой момент времени. Работает с программами на C и C++,
122скомпилированными GNU компилятором C (gcc, egcs, pgcc).
123
124%description -l tr.UTF-8
125Bir komut arayüzü üzerinden programcıya programını adım adım izleme
126(trace) ve herhangi bir anda programın durumunu inceleme olanağı
127verir.
128
129%description -l uk.UTF-8
130Це повноцінний відладчик, що керується командами. Він дозволяє
131трасувати виконання програм та вивчати їх внутрішній стан в довільний
132момент часу. Працює з програмами на C та C++, зкомпільованими
133компіляторами GNU C (gcc, egcs, pgcc).
134
135%package gdbserver
136Summary: A standalone server for GDB (the GNU source-level debugger)
137Summary(pl.UTF-8): Samodzielny serwer GDB (debuggera GNU)
138Group: Development/Debuggers
139
140%description gdbserver
141GDB, the GNU debugger, allows you to debug programs written in C, C++,
142Java, and other languages, by executing them in a controlled fashion
143and printing their data.
144
145This package provides a program that allows you to run GDB on a
146different machine than the one which is running the program being
147debugged.
148
149%description gdbserver -l pl.UTF-8
150GDB (GNU debugger) pozwala śledzić programy napisane w C, C++, Javie i
151innych językach programowania poprzez wykonywanie ich w sposób
152kontrolowany oraz wypisywanie ich danych.
153
154Ten pakiet zawiera program pozwalający uruchamiać GDB na innej
155maszynie niż ta, na której działa śledzony program.
156
157%package lib
158Summary: GDB in the form of a static library
159Summary(pl.UTF-8): GDB w postaci biblioteki statycznej
160Group: Development/Debuggers
161# libraries that needs to be linked to fulfill libgdb.a symbol requirements
162Requires: binutils-devel >= 2.17.50
163Requires: expat-devel
164Requires: libselinux-devel
165Requires: libsepol-devel
166Requires: ncurses-devel
167Requires: python-devel
168Requires: readline-devel
169Requires: xz-devel
170Requires: zlib-devel
171
172%description lib
173GDB in the form of a static library.
174
175%description lib -l pl.UTF-8
176GDB w postaci biblioteki statycznej.
177
178%prep
179%setup -q
180
181%patch0 -p1
182
183# Files have `# <number> <file>' statements breaking VPATH / find-debuginfo.sh .
184rm -f gdb/ada-exp.c gdb/ada-lex.c gdb/c-exp.c gdb/cp-name-parser.c gdb/f-exp.c
185rm -f gdb/jv-exp.c gdb/m2-exp.c gdb/objc-exp.c gdb/p-exp.c
186
187%patch100 -p1
188%patch101 -p1
189%patch102 -p1
190%patch103 -p1
191%patch104 -p1
192%patch105 -p1
193%patch106 -p1
194%patch110 -p1
195%patch111 -p1
196%patch112 -p1
197%patch113 -p1
198%patch114 -p1
199%patch115 -p1
200%patch116 -p1
201
202%patch1000 -p1
203%patch1001 -p1
204%patch1002 -p1
205%patch1005 -p1
206%patch1006 -p1
207
208# Change the version that gets printed at GDB startup, so it is PLD Linux specific.
209cat > gdb/version.in << EOF
210%{version}-%{release} (PLD Linux)
211EOF
212
213sed -i -e 's#_GCC_AUTOCONF_VERSION\], \[2\.64\]#_GCC_AUTOCONF_VERSION], [2.69]#g' config/override.m4
214
215%build
216# omit hand-written gdb/testsuite aclocal.m4
217for dir in gdb gdb/gdbserver ; do
218 olddir=$(pwd)
219 cd $dir
220 %{__rm} aclocal.m4
221 %{__aclocal} $(grep '^ACLOCAL_AMFLAGS' Makefile.in | sed -e 's/.*=//')
222 cd $olddir
223done
224for dir in $(find gdb -name 'configure.in' -o -name 'configure.ac'); do
225 dir=$(dirname "$dir")
226 olddir=$(pwd)
227 cd $dir
228 %{__autoconf}
229 grep -q AC_CONFIG_HEADER configure.* && %{__autoheader}
230 cd $olddir
231done
232cp -f /usr/share/automake/config.* .
233# don't --enable-shared here, there would be libs version mismatch with binutils
234%configure \
235 --with-gdb-datadir=%{_datadir}/gdb \
236 --with-separate-debug-dir=/usr/lib/debug \
237%if %{with python}
238 --with-python=yes \
239 --with-pythondir=%{py_sitescriptdir} \
240%else
241 --without-python \
242%endif
243%if %{with guile}
244 --with-guile \
245%else
246 --without-guile \
247%endif
248 --disable-gdbtk \
249 --disable-shared \
250 --enable-gdbcli \
251 --enable-gdbmi \
252 --enable-multi-ice \
253 --enable-netrom \
254 --enable-nls \
255 --enable-tui \
256 --with-system-readline \
257 --with-cpu=%{_target_cpu} \
258%ifnarch alpha
259 --with-mmalloc \
260%endif
261 --without-included-gettext \
262 --without-included-regex \
263 --without-x
264
265%{__make}
266%{__make} -j1 info
267
268# gdb/ChangeLog: Build gdb directly from *.o files not using libgdb.a.
269%{__make} -C gdb libgdb.a
270
271%install
272rm -rf $RPM_BUILD_ROOT
273install -d $RPM_BUILD_ROOT%{_infodir}
274
275%{__make} -j1 install install-info \
276 DESTDIR=$RPM_BUILD_ROOT
277
278cp -a gdb/libgdb.a $RPM_BUILD_ROOT%{_libdir}
279
280# gdbtui seems all identical to gdb except when invoked as gdbtui, ncurses
281# window is created too.
282echo ".so gdb.1" > $RPM_BUILD_ROOT%{_mandir}/man1/gdbtui.1
283ln -f $RPM_BUILD_ROOT%{_bindir}/{gdb,gdbtui}
284
285bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
286%{__rm} $RPM_BUILD_ROOT%{_mandir}/README.gdb-non-english-man-pages
287
288rm -f $RPM_BUILD_ROOT%{_infodir}/dir
289
290%if %{with python}
291# Temporarily now:
292for LIB in lib lib64 libx32; do
293 LIBPATH="$RPM_BUILD_ROOT%{_datadir}/gdb/auto-load%{_prefix}/$LIB"
294 install -d $LIBPATH
295done
296
297%py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
298%py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
299%py_postclean
300%endif
301
302cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_mandir}/man1/gstack.1
303
304install libdecnumber/libdecnumber.a $RPM_BUILD_ROOT%{_libdir}
305
306# Remove the files that are part of a gdb build but that are owned and provided by other packages.
307# These are part of binutils:
308%{__rm} $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/{bfd,opcodes}.mo
309%{__rm} $RPM_BUILD_ROOT%{_infodir}/bfd.info*
310%{__rm} $RPM_BUILD_ROOT%{_includedir}/{ansidecl,bfd,bfdlink,dis-asm,symcat,plugin-api}.h
311%{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,opcodes}.la
312%{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,opcodes}.a
313
314%clean
315rm -rf $RPM_BUILD_ROOT
316
317%post -p /sbin/postshell
318-/usr/sbin/fix-info-dir -c %{_infodir}
319
320%postun -p /sbin/postshell
321-/usr/sbin/fix-info-dir -c %{_infodir}
322
323%files
324%defattr(644,root,root,755)
325%doc gdb/{ChangeLog,NEWS,PROBLEMS,README}
326%attr(755,root,root) %{_bindir}/gdb
327%attr(755,root,root) %{_bindir}/gdbtui
328%attr(755,root,root) %{_bindir}/gdb-add-index
329%attr(755,root,root) %{_bindir}/gstack
330%attr(755,root,root) %{_bindir}/gcore
331%dir %{_datadir}/gdb
332%dir %{_datadir}/gdb/auto-load
333%dir %{_datadir}/gdb/auto-load%{_prefix}
334%dir %{_datadir}/gdb/auto-load%{_prefix}/lib
335%ifarch %{x8664} x32
336%dir %{_datadir}/gdb/auto-load%{_prefix}/lib64
337%dir %{_datadir}/gdb/auto-load%{_prefix}/libx32
338%endif
339%{?with_guile:%{_datadir}/gdb/guile}
340%{_datadir}/gdb/syscalls
341%{_datadir}/gdb/system-gdbinit
342%{_datadir}/gdb/python
343%{_mandir}/man1/gdb.1*
344%{_mandir}/man1/gdbtui.1*
345%{_mandir}/man1/gdb-add-index.1*
346%{_mandir}/man1/gstack.1*
347%{_mandir}/man1/gcore.1*
348%{_mandir}/man5/gdbinit.5*
349%lang(es) %{_mandir}/es/man1/*
350%lang(fr) %{_mandir}/fr/man1/*
351%lang(hu) %{_mandir}/hu/man1/*
352%lang(ja) %{_mandir}/ja/man1/*
353%lang(pl) %{_mandir}/pl/man1/*
354%{_infodir}/annotate.info*
355%{_infodir}/gdb.info*
356%{_infodir}/stabs.info*
357
358%files gdbserver
359%defattr(644,root,root,755)
360%attr(755,root,root) %{_bindir}/gdbserver
361%{_mandir}/man1/gdbserver.1*
362%attr(755,root,root) %{_libdir}/libinproctrace.so
363
364%files lib
365%defattr(644,root,root,755)
366%{_libdir}/libdecnumber.a
367%{_libdir}/libgdb.a
368%{_includedir}/gdb
This page took 0.029684 seconds and 4 git commands to generate.