]> git.pld-linux.org Git - packages/gdal.git/commitdiff
- Version: 1.7.2
authorJacek Konieczny <jajcus@pld-linux.org>
Sat, 12 Jun 2010 16:20:15 +0000 (16:20 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- updated for ruby 1.9

Changed files:
    gdal-dods.patch -> 1.4
    gdal-ogdi.patch -> 1.2
    gdal-ruby.patch -> 1.3
    gdal.spec -> 1.71

gdal-dods.patch [deleted file]
gdal-ogdi.patch [deleted file]
gdal-ruby.patch
gdal.spec

diff --git a/gdal-dods.patch b/gdal-dods.patch
deleted file mode 100644 (file)
index cb92c2a..0000000
+++ /dev/null
@@ -1,70 +0,0 @@
---- gdal-1.3.0/configure.in.orig       2005-09-03 13:07:50.228591000 +0200
-+++ gdal-1.3.0/configure.in    2005-09-03 15:46:35.931464216 +0200
-@@ -1396,9 +1396,11 @@
-     if test -x $DODS_BIN/opendap-config ; then 
-       dnl OPeNDAP 3.4 and earlier lack opendap-config, but use it if avail.
-       LIBS="$LIBS `$DODS_BIN/opendap-config --libs`"
-+      DODS_INC="`$DODS_BIN/opendap-config --cflags`"
-     elif test -x $DODS_BIN/dap-config ; then 
-       dnl OPeNDAP 3.4 and earlier lack opendap-config, but use it if avail.
-       LIBS="$LIBS `$DODS_BIN/dap-config --libs`"
-+      DODS_INC="`$DODS_BIN/dap-config --cflags`"
-     else
-       dnl Otherwise try to put things together in a more primitive way.
-       LIBS="$LIBS -L$DODS_LIB -ldap++ -lpthread -lrx"
-
---- gdal-1.6.1/frmts/dods/dodsdataset2.cpp.org 2009-07-15 12:54:31.160838902 +0200
-+++ gdal-1.6.1/frmts/dods/dodsdataset2.cpp     2009-07-15 12:58:38.080454628 +0200
-@@ -693,15 +693,15 @@
- /* -------------------------------------------------------------------- */
- /*      Try and fetch the corresponding DAS subtree if it exists.       */
- /* -------------------------------------------------------------------- */
--    AttrTable *poFileInfo = oDAS.find_container( "GLOBAL" );
-+    AttrTable *poFileInfo = oDAS.container()->find_container( "GLOBAL" );
-     if( poFileInfo == NULL )
-     {
--        poFileInfo = oDAS.find_container( "NC_GLOBAL" );
-+        poFileInfo = oDAS.container()->find_container( "NC_GLOBAL" );
-       if( poFileInfo == NULL )
-       {
--          poFileInfo = oDAS.find_container( "HDF_GLOBAL" );
-+          poFileInfo = oDAS.container()->find_container( "HDF_GLOBAL" );
-           if( poFileInfo == NULL )
-           {
-@@ -1275,7 +1275,7 @@
- /* -------------------------------------------------------------------- */
- /*      Try and fetch the corresponding DAS subtree if it exists.       */
- /* -------------------------------------------------------------------- */
--    AttrTable *poBandInfo = poDODS->GetDAS().find_container( oVarName );
-+    AttrTable *poBandInfo = poDODS->GetDAS().container()->find_container( oVarName );
-     if( poBandInfo == NULL )
-     {
---- gdal-1.6.1/ogr/ogrsf_frmts/dods/ogrdodsdatasource.cpp~     2009-07-15 13:13:25.060367275 +0200
-+++ gdal-1.6.1/ogr/ogrsf_frmts/dods/ogrdodsdatasource.cpp      2009-07-15 13:13:49.337227887 +0200
-@@ -196,9 +196,9 @@
-     for( dv_i = oDAS.container()->attr_begin(); dv_i != oDAS.container()->attr_end(); dv_i++ )
-     {
-         if( EQUALN(oDAS.get_name(dv_i).c_str(),"ogr_layer_info",14) 
--            && oDAS.is_container( dv_i ) )
-+            && oDAS.container()->is_container( dv_i ) )
-         {
--            AttrTable *poAttr = oDAS.get_attr_table( dv_i );
-+            AttrTable *poAttr = oDAS.container()->get_attr_table( dv_i );
-             string target_container = poAttr->get_attr( "target_container" );
-             BaseType *poVar = poDDS->var( target_container.c_str() );
-             
---- gdal-1.6.1/ogr/ogrsf_frmts/dods/ogrdodsdatasource.cpp~     2009-07-15 13:14:32.077112316 +0200
-+++ gdal-1.6.1/ogr/ogrsf_frmts/dods/ogrdodsdatasource.cpp      2009-07-15 13:34:25.010626056 +0200
-@@ -193,7 +193,7 @@
- /* -------------------------------------------------------------------- */
-     AttrTable::Attr_iter dv_i;
--    for( dv_i = oDAS.attr_begin(); dv_i != oDAS.attr_end(); dv_i++ )
-+    for( dv_i = oDAS.container()->attr_begin(); dv_i != oDAS.container()->attr_end(); dv_i++ )
-     {
-         if( EQUALN(oDAS.get_name(dv_i).c_str(),"ogr_layer_info",14) 
-             && oDAS.container()->is_container( dv_i ) )
diff --git a/gdal-ogdi.patch b/gdal-ogdi.patch
deleted file mode 100644 (file)
index fd32521..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
---- gdal-1.5.1/configure.in.orig       2008-06-05 21:13:18.624424000 +0200
-+++ gdal-1.5.1/configure.in    2008-06-05 22:51:48.869222202 +0200
-@@ -869,19 +869,19 @@
- elif test "$with_ogdi" = "yes" -o "$with_ogdi" = "" ; then
--  AC_CHECK_LIB(ogdi31,cln_GetLayerCapabilities,HAVE_OGDI=yes,HAVE_OGDI=no,)
-+  AC_CHECK_LIB(ogdi,cln_GetLayerCapabilities,HAVE_OGDI=yes,HAVE_OGDI=no,)
-   if test "$HAVE_OGDI" = "yes" ; then   
--    LIBS="-logdi31 $LIBS"
-+    LIBS="-logdi $LIBS"
-   fi
- else
-   HAVE_OGDI=yes
--  LIBS="-L$with_ogdi -L$with_ogdi/lib -logdi31 $LIBS"
-+  LIBS="-L$with_ogdi -L$with_ogdi/lib -logdi $LIBS"
-   OGDI_INCLUDE="-I$with_ogdi -I$with_ogdi/include"
--  echo "using libogdi31 from $with_ogdi."
-+  echo "using libogdi from $with_ogdi."
- fi
index c0ca10fd1ee88a3f7a28e7010d7199301ce4995b..7230e834c4fbe06eef7d8cc7c90a291c91657921 100644 (file)
@@ -1,24 +1,27 @@
---- gdal-1.5.1/swig/ruby/RubyMakefile.mk.orig  2006-12-21 03:49:08.000000000 +0100
-+++ gdal-1.5.1/swig/ruby/RubyMakefile.mk       2008-06-06 21:48:10.535282314 +0200
-@@ -17,7 +17,7 @@
+diff -dur gdal-1.7.2.orig/swig/ruby/RubyMakefile.mk gdal-1.7.2/swig/ruby/RubyMakefile.mk
+--- gdal-1.7.2.orig/swig/ruby/RubyMakefile.mk  2010-04-24 01:22:08.000000000 +0200
++++ gdal-1.7.2/swig/ruby/RubyMakefile.mk       2010-06-12 11:15:23.000000000 +0200
+@@ -17,15 +17,15 @@
  
  include $(GDAL_ROOT)/GDALmake.opt
  
 -RUBY_MODULES = gdal.so ogr.so gdalconst.so osr.so
+-RUBY_INCLUDE_DIR := $(shell ruby -rrbconfig -e "puts Config::CONFIG['archdir']")
++RUBY_INCLUDE_DIR := $(shell ruby -rrbconfig -e "puts Config::CONFIG['rubyhdrdir']")
 +RUBY_MODULES = gdal.la ogr.la gdalconst.la osr.la
- RUBY_INCLUDE_DIR := $(shell ruby -rrbconfig -e "puts Config::CONFIG['archdir']")
  RUBY_LIB_DIR := $(shell ruby -rrbconfig -e "puts Config::CONFIG['libdir']")
  RUBY_SO_NAME := $(shell ruby -rrbconfig -e "puts Config::CONFIG['RUBY_SO_NAME']")
-@@ -25,7 +25,7 @@
+ RUBY_EXTENSIONS_DIR := $(shell ruby -rrbconfig -e "puts Config::CONFIG['sitearchdir']")
  INSTALL_DIR := $(RUBY_EXTENSIONS_DIR)/gdal
  
- RUBY_INCLUDE = -I$(RUBY_INCLUDE_DIR)
--LDFLAGS += -shared -L$(RUBY_LIB_DIR)
-+LDFLAGS += -shared -module -avoid-version -rpath $(INSTALL_DIR) -L$(RUBY_LIB_DIR)
+-RUBY_INCLUDE = -I$(RUBY_INCLUDE_DIR)
++RUBY_INCLUDE = -I$(RUBY_INCLUDE_DIR) -I$(RUBY_INCLUDE_DIR)/$(shell ruby -rrbconfig -e "puts Config::CONFIG['arch']")
+-LDFLAGS += -Xcompiler -shared -L$(RUBY_LIB_DIR)
++LDFLAGS += -Xcompiler -shared -module -avoid-version -rpath $(INSTALL_DIR) -L$(RUBY_LIB_DIR)
  RUBY_LIB := -l$(RUBY_SO_NAME)
  
  build: $(RUBY_MODULES)
-@@ -44,14 +44,14 @@
+@@ -43,14 +43,14 @@
  install: $(INSTALL_DIR)
        $(INSTALL) $(RUBY_MODULES) $(DESTDIR)$(INSTALL_DIR) 
  
 -%.o: %.c
 +%.lo: %.c
        $(CC) $(CFLAGS) $(GDAL_INCLUDE)  $(RUBY_INCLUDE) -c $<
+diff -dur gdal-1.7.2.orig/swig/include/ruby/gdal_ruby.i gdal-1.7.2/swig/include/ruby/gdal_ruby.i
+--- gdal-1.7.2.orig/swig/include/ruby/gdal_ruby.i      2010-04-24 01:22:09.000000000 +0200
++++ gdal-1.7.2/swig/include/ruby/gdal_ruby.i   2010-06-12 14:21:11.000000000 +0200
+@@ -36,7 +36,7 @@
+     CPLXMLNode *psChild;
+     char       *pszText = NULL;
+-    nChildCount = RARRAY(rubyArray)->len - 2;
++    nChildCount = RARRAY_LEN(rubyArray) - 2;
+     if( nChildCount < 0 )
+     {
+                rb_raise(rb_eRuntimeError, "Error in input XMLTree, child count is less than zero.");
+diff -dur gdal-1.7.2.orig/swig/include/ruby/typemaps_ruby.i gdal-1.7.2/swig/include/ruby/typemaps_ruby.i
+--- gdal-1.7.2.orig/swig/include/ruby/typemaps_ruby.i  2010-04-24 01:22:09.000000000 +0200
++++ gdal-1.7.2/swig/include/ruby/typemaps_ruby.i       2010-06-12 14:22:07.000000000 +0200
+@@ -147,7 +147,7 @@
+   Check_Type($input, T_ARRAY);
+   /* Get the length */
+-  int seq_size = RARRAY($input)->len;
++  int seq_size = RARRAY_LEN($input);
+   
+   if ( seq_size != $dim0 ) {
+     rb_raise(rb_eRangeError, "sequence must have length %i.", seq_size);
+@@ -225,7 +225,7 @@
+   Check_Type($input, T_ARRAY);
+   /* Get the length */
+-  $1 = RARRAY($input)->len;
++  $1 = RARRAY_LEN($input);
+   
+   /* Allocate space for the C array. */
+   $2 = (int*) malloc($1*sizeof(int));
+@@ -315,7 +315,7 @@
+   /* Check if is a list */
+   Check_Type($input, T_ARRAY);
+-  $1 = RARRAY($input)->len;
++  $1 = RARRAY_LEN($input);
+   tmpGCPList = (GDAL_GCP*) malloc($1*sizeof(GDAL_GCP));
+   $2 = tmpGCPList;
+@@ -386,7 +386,7 @@
+   /* is the provided object an array or a hash? */
+   if ( TYPE($input) == T_ARRAY) {
+     /* get the size of the array */
+-    int size = RARRAY($input)->len;
++    int size = RARRAY_LEN($input);
+     
+     for (int i = 0; i < size; i++) {
+       /* get the ruby object */
+@@ -489,7 +489,7 @@
+   /* Check if is a list */
+   Check_Type($input, T_ARRAY);
+-  int size = RARRAY($input)->len;
++  int size = RARRAY_LEN($input);
+   for (int i = 0; i < size; i++) {
+     VALUE item = rb_ary_entry($input, i);
+     char *pszItem = StringValuePtr(item);
+@@ -744,4 +744,4 @@
+       /* %typemap(out) GByte* */
+       
+       /* Stops insertion of default type map. */
+-}
+\ No newline at end of file
++}
index bf95d8a257dbdd0368163505b54d5d14876b47d0..e85c9a8c0a9ee0b09c659f974d79f964eb0751c5 100644 (file)
--- a/gdal.spec
+++ b/gdal.spec
@@ -1,4 +1,4 @@
-# TODO: csharp, java
+# TODO: csharp, java, mysql
 #
 # Conditional build:
 %bcond_without odbc    # disable odbc support
@@ -8,18 +8,16 @@
 Summary:       Geospatial Data Abstraction Library
 Summary(pl.UTF-8):     Biblioteka abstrakcji danych dotyczÄ…cych powierzchni Ziemi
 Name:          gdal
-Version:       1.6.1
-Release:       6
+Version:       1.7.2
+Release:       0.1
 License:       BSD-like
 Group:         Libraries
 Source0:       ftp://ftp.remotesensing.org/gdal/%{name}-%{version}.tar.gz
-# Source0-md5: 4059285a5cef41ff975ed0ec02a97009
-Patch0:                %{name}-dods.patch
-Patch1:                %{name}-perl.patch
-Patch2:                %{name}-ruby.patch
-Patch3:                %{name}-asneeded.patch
-Patch4:                %{name}-ogdi.patch
-Patch5:                %{name}-python_install.patch
+# Source0-md5: 05351f8cb61761ae579667e24a297fe6
+Patch0:                %{name}-perl.patch
+Patch1:                %{name}-ruby.patch
+Patch2:                %{name}-asneeded.patch
+Patch3:                %{name}-python_install.patch
 URL:           http://www.gdal.org/
 BuildRequires: autoconf >= 2.52
 BuildRequires: automake
@@ -173,11 +171,13 @@ osr.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
-%patch4 -p1
-%patch5 -p1
 
 # need to regenerate (old ones don't support perl 5.10)
 rm swig/perl/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
+# includes updated for Ruby 1.9
+rm swig/ruby/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
+
+rm -rf man
 
 %build
 # $PYTHON_INCLUDES is set only with --with-ogpython, but we have --with-python,
@@ -208,11 +208,14 @@ cp -f /usr/share/automake/config.* .
 
 # regenerate where needed
 %{__make} -j1 -C swig/perl generate
+%{__make} -j1 -C swig/ruby generate
 
 %{__make} -j1
 
 %{__make} -j1 docs
 
+%{__make} -j1 man
+
 %install
 rm -rf $RPM_BUILD_ROOT
 
This page took 0.045291 seconds and 4 git commands to generate.