]> git.pld-linux.org Git - packages/gdal.git/commitdiff
- fix building with poppler 0.82
authorJan Rękorajski <baggins@pld-linux.org>
Wed, 30 Oct 2019 08:59:50 +0000 (09:59 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Wed, 30 Oct 2019 08:59:50 +0000 (09:59 +0100)
gdal.spec
poppler-0.82.patch [new file with mode: 0644]

index 94296e31c440c4ede0a3ada478eb9e63119f0dec..ad82eca79bc5975f9bb2b8bbad5d21bbbbaa05ff 100644 (file)
--- a/gdal.spec
+++ b/gdal.spec
@@ -56,11 +56,12 @@ Group:              Libraries
 Source0:       https://github.com/OSGeo/gdal/releases/download/v%{version}/%{name}-%{version}.tar.gz
 # Source0-md5: 2b397c041e6b0b10ec7c49fd76e9fa99
 Patch0:                %{name}-perl.patch
-Patch2:                %{name}-pc.patch
-Patch9:                %{name}-dds.patch
-Patch12:       %{name}-rasdaman.patch
-Patch13:       %{name}-pluginsdir.patch
-Patch15:       libx32.patch
+Patch1:                %{name}-pc.patch
+Patch2:                %{name}-dds.patch
+Patch3:                %{name}-rasdaman.patch
+Patch4:                %{name}-pluginsdir.patch
+Patch5:                libx32.patch
+Patch6:                poppler-0.82.patch
 URL:           http://www.gdal.org/
 # 1.x or 2.x supported
 BuildRequires: CharLS-devel
@@ -98,6 +99,7 @@ BuildRequires:        libpng-devel >= 2:1.2.8
 %{?with_spatialite:BuildRequires:      libspatialite-devel}
 BuildRequires: libstdc++-devel
 BuildRequires: libtiff-devel >= 4.0
+BuildRequires: libtirpc-devel
 BuildRequires: libtool
 BuildRequires: libuuid-devel
 BuildRequires: libwebp-devel
@@ -265,11 +267,12 @@ Moduł Pythona GDAL.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 %patch2 -p1
-%patch9 -p1
-%patch12 -p1
-%patch13 -p1
-%patch15 -p1
+%patch3 -p1
+%patch4 -p1
+%patch5 -p1
+%patch6 -p1
 
 # need to regenerate (old ones don't support perl 5.10)
 %{__rm} swig/perl/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
diff --git a/poppler-0.82.patch b/poppler-0.82.patch
new file mode 100644 (file)
index 0000000..1c4a651
--- /dev/null
@@ -0,0 +1,53 @@
+From 20c3fc7cb4a4ec2a67642bd83ddb6e403488b0fe Mon Sep 17 00:00:00 2001
+From: Even Rouault <even.rouault@spatialys.com>
+Date: Tue, 22 Oct 2019 13:11:57 +0200
+Subject: [PATCH] PDF: fix build against Poppler 0.82.0dev
+
+---
+ gdal/frmts/pdf/pdfdataset.cpp | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/gdal/frmts/pdf/pdfdataset.cpp b/gdal/frmts/pdf/pdfdataset.cpp
+index 15537ca7fd7..8f944c40d30 100644
+--- a/gdal/frmts/pdf/pdfdataset.cpp
++++ b/gdal/frmts/pdf/pdfdataset.cpp
+@@ -205,7 +205,11 @@ class GDALPDFOutputDev : public SplashOutputDev
+         virtual void drawChar(GfxState *state, double x, double y,
+                               double dx, double dy,
+                               double originX, double originY,
+-                              CharCode code, int nBytes, Unicode *u, int uLen) override
++                              CharCode code, int nBytes,
++#if POPPLER_MAJOR_VERSION >= 1 || POPPLER_MINOR_VERSION >= 82
++                              const
++#endif
++                              Unicode *u, int uLen) override
+         {
+             if (bEnableText)
+                 SplashOutputDev::drawChar(state, x, y, dx, dy,
+From 94daceefebd464858888ddc85170c1a8c4bd50d7 Mon Sep 17 00:00:00 2001
+From: Even Rouault <even.rouault@spatialys.com>
+Date: Sun, 29 Sep 2019 23:55:18 +0200
+Subject: [PATCH] PDF: fix build against Poppler 0.82.0dev
+
+---
+ gdal/frmts/pdf/pdfdataset.cpp | 7 ++++++-
+ 1 file changed, 6 insertions(+), 1 deletion(-)
+
+diff --git a/gdal/frmts/pdf/pdfdataset.cpp b/gdal/frmts/pdf/pdfdataset.cpp
+index 3d68f92abe8..b3db5374227 100644
+--- a/gdal/frmts/pdf/pdfdataset.cpp
++++ b/gdal/frmts/pdf/pdfdataset.cpp
+@@ -265,7 +265,12 @@ class GDALPDFOutputDev : public SplashOutputDev
+         virtual void drawImage(GfxState *state, Object *ref, Stream *str,
+                                int width, int height, GfxImageColorMap *colorMap,
+-                               GBool interpolate, int *maskColors, GBool inlineImg) override
++                               GBool interpolate,
++#if POPPLER_MAJOR_VERSION >= 1 || POPPLER_MINOR_VERSION >= 82
++                               const
++#endif
++                               int *maskColors,
++                               GBool inlineImg) override
+         {
+             if (bEnableBitmap)
+                 SplashOutputDev::drawImage(state, ref, str,
This page took 0.052498 seconds and 4 git commands to generate.