]> git.pld-linux.org Git - packages/gdal.git/commitdiff
- merged 1.8.0 from DEVEL (libtiff 4 required)
authorJakub Bogusz <qboosh@pld-linux.org>
Mon, 16 Jan 2012 19:49:26 +0000 (19:49 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- added libpng patch to fix build with libpng 1.5.x

Changed files:
    gdal-asneeded.patch -> 1.3
    gdal-libdap.patch -> 1.2
    gdal-libpng.patch -> 1.1
    gdal-perl.patch -> 1.4
    gdal.spec -> 1.95

gdal-asneeded.patch
gdal-libdap.patch [deleted file]
gdal-libpng.patch [new file with mode: 0644]
gdal-perl.patch
gdal.spec

index cdf552d2d985ea051a274e6c491492704a1421e4..024ea3387e9d4ecfb69954915c3e7a1ad1bd8da4 100644 (file)
@@ -1,5 +1,5 @@
---- gdal-1.5.1/m4/ax_xerces.m4.orig    2007-12-07 01:26:11.000000000 +0100
-+++ gdal-1.5.1/m4/ax_xerces.m4 2008-06-05 22:45:13.942715785 +0200
+--- gdal-1.8.0/m4/ax_lib_xerces.m4.orig        2007-12-07 01:26:11.000000000 +0100
++++ gdal-1.8.0/m4/ax_lib_xerces.m4     2008-06-05 22:45:13.942715785 +0200
 @@ -116,8 +116,8 @@
          saved_CPPFLAGS="$CPPFLAGS"
          CPPFLAGS="$CPPFLAGS -I$xerces_include_dir -I$xerces_include_dir2"
diff --git a/gdal-libdap.patch b/gdal-libdap.patch
deleted file mode 100644 (file)
index 1da75b7..0000000
+++ /dev/null
@@ -1,107 +0,0 @@
---- gdal-1.7.2/ogr/ogrsf_frmts/dods/ogrdodsdatasource.cpp.orig 2010-04-24 01:21:25.000000000 +0200
-+++ gdal-1.7.2/ogr/ogrsf_frmts/dods/ogrdodsdatasource.cpp      2010-10-11 07:45:03.847736015 +0200
-@@ -150,7 +150,7 @@ int OGRDODSDataSource::Open( const char
-     try 
-     {
--        poConnection = new AISConnect( oBaseURL );
-+        poConnection = new Connect( oBaseURL );
-         version = poConnection->request_version();
-     } 
-     catch (Error &e) 
---- gdal-1.7.2/ogr/ogrsf_frmts/dods/ogr_dods.h.orig    2010-04-24 01:21:25.000000000 +0200
-+++ gdal-1.7.2/ogr/ogrsf_frmts/dods/ogr_dods.h 2010-10-11 07:45:35.795741882 +0200
-@@ -61,7 +61,7 @@
- #include <Sequence.h>
- #include <Grid.h>
--#include <AISConnect.h>               
-+#include <Connect.h>          
- #include <DDS.h>
- #include <DAS.h>
- #include <BaseTypeFactory.h>
-@@ -122,7 +122,7 @@ class OGRDODSLayer : public OGRLayer
-     virtual int         ProvideDataDDS();
-     int                 bDataLoaded;
--    AISConnect         *poConnection;
-+    Connect            *poConnection;
-     DataDDS            *poDataDDS;
-     BaseType           *poTargetVar;
-@@ -300,7 +300,7 @@ class OGRDODSDataSource : public OGRData
-     void                AddLayer( OGRDODSLayer * );
-   public: // Just intended for read access by layer classes.
--    AISConnect         *poConnection;
-+    Connect            *poConnection;
-     DAS                 oDAS;
-     DDS                 *poDDS;
---- gdal-1.7.2/ogr/ogrsf_frmts/dods/ogrdodslayer.cpp.orig      2010-04-24 01:21:25.000000000 +0200
-+++ gdal-1.7.2/ogr/ogrsf_frmts/dods/ogrdodslayer.cpp   2010-10-11 07:45:57.947740205 +0200
-@@ -213,7 +213,7 @@ int OGRDODSLayer::ProvideDataDDS()
-     bDataLoaded = TRUE;
-     try
-     {
--        poConnection = new AISConnect( poDS->oBaseURL );
-+        poConnection = new Connect( poDS->oBaseURL );
-         CPLDebug( "DODS", "request_data(%s,%s)",
-                   poDS->oBaseURL.c_str(),
-                   (poDS->oProjection + poDS->oConstraints).c_str() );
---- gdal-1.7.2/frmts/dods/dodsdataset2.cpp.orig        2010-04-24 01:21:55.000000000 +0200
-+++ gdal-1.7.2/frmts/dods/dodsdataset2.cpp     2010-10-11 07:24:26.275734339 +0200
-@@ -50,7 +50,7 @@
- #include <Sequence.h>
- #include <Grid.h>
--#include <AISConnect.h>               
-+#include <Connect.h>          
- #include <DDS.h>
- #include <DAS.h>
- #include <BaseTypeFactory.h>
-@@ -203,7 +203,7 @@ static int GetDimension( string oCE, con
- class DODSDataset : public GDALDataset
- {
- private:
--    AISConnect *poConnect;    //< Virtual connection to the data source
-+    Connect *poConnect;       //< Virtual connection to the data source
-     string oURL;              //< data source URL
-     double adfGeoTransform[6];
-@@ -214,7 +214,7 @@ private:
-     DDS   *poDDS;
-     BaseTypeFactory *poBaseTypeFactory;
--    AISConnect *connect_to_server() throw(Error);
-+    Connect *connect_to_server() throw(Error);
-     static string      SubConstraint( string raw_constraint, 
-                                       string x_constraint, 
-@@ -242,7 +242,7 @@ public:
-     static GDALDataset *Open(GDALOpenInfo *);
-     /// Return the connection object
--    AISConnect *GetConnect() { return poConnect; }
-+    Connect *GetConnect() { return poConnect; }
-     /// Return the data source URL
-     string GetUrl() { return oURL; }
-@@ -339,7 +339,7 @@ DODSDataset::~DODSDataset()
- /*                         connect_to_server()                          */
- /************************************************************************/
--AISConnect *
-+Connect *
- DODSDataset::connect_to_server() throw(Error)
- {
-     // does the string start with 'http?'
-@@ -375,7 +375,7 @@ DODSDataset::connect_to_server() throw(E
- /* -------------------------------------------------------------------- */
- /*      Connect, and fetch version information.                         */
- /* -------------------------------------------------------------------- */
--    AISConnect *poConnection = new AISConnect(oURL);
-+    Connect *poConnection = new Connect(oURL);
-     string version = poConnection->request_version();
-     /*    if (version.empty() || version.find("/3.") == string::npos)
-     {
diff --git a/gdal-libpng.patch b/gdal-libpng.patch
new file mode 100644 (file)
index 0000000..d4cfdf1
--- /dev/null
@@ -0,0 +1,38 @@
+--- gdal-1.8.0/frmts/png/pngdataset.cpp.orig   2011-01-14 06:19:04.000000000 +0100
++++ gdal-1.8.0/frmts/png/pngdataset.cpp        2012-01-16 19:36:37.513649497 +0100
+@@ -1315,7 +1315,7 @@
+     * instead of an int, which is what fread() actually returns.
+     */
+    check = (png_size_t)VSIFReadL(data, (png_size_t)1, length,
+-                                 (VSILFILE*)png_ptr->io_ptr);
++                                 (VSILFILE*)png_get_io_ptr(png_ptr));
+    if (check != length)
+       png_error(png_ptr, "Read Error");
+@@ -1330,7 +1330,7 @@
+ {
+    png_uint_32 check;
+-   check = VSIFWriteL(data, 1, length, (VSILFILE*)(png_ptr->io_ptr));
++   check = VSIFWriteL(data, 1, length, (VSILFILE*)png_get_io_ptr(png_ptr));
+    if (check != length)
+       png_error(png_ptr, "Write Error");
+@@ -1341,7 +1341,7 @@
+ /************************************************************************/
+ static void png_vsi_flush(png_structp png_ptr)
+ {
+-    VSIFFlushL( (VSILFILE*)(png_ptr->io_ptr) );
++    VSIFFlushL( (VSILFILE*)png_get_io_ptr(png_ptr) );
+ }
+ /************************************************************************/
+@@ -1357,7 +1357,7 @@
+     // libpng is generally not built as C++ and so won't honour unwind
+     // semantics.  Ugg. 
+-    jmp_buf* psSetJmpContext = (jmp_buf*) png_ptr->error_ptr;
++    jmp_buf* psSetJmpContext = (jmp_buf*) png_get_error_ptr(png_ptr);
+     if (psSetJmpContext)
+     {
+         longjmp( *psSetJmpContext, 1 );
index 2f50e92efd2d9ff24489ffa9e31746f406fe2fc0..b083600a655775b6a37c592ac034f54eb9f7770e 100644 (file)
@@ -1,9 +1,11 @@
-diff -Nur gdal-1.6.1.orig/swig/perl/GNUmakefile gdal-1.6.1/swig/perl/GNUmakefile
---- gdal-1.6.1.orig/swig/perl/GNUmakefile      2008-09-13 12:49:45.000000000 +0100
-+++ gdal-1.6.1/swig/perl/GNUmakefile   2009-07-08 21:20:24.000000000 +0100
-@@ -46,4 +46,4 @@
-       $(MAKE) -f Makefile_Geo__GDAL dist
+--- gdal-1.8.0/swig/perl/GNUmakefile.orig      2011-01-14 06:19:06.000000000 +0100
++++ gdal-1.8.0/swig/perl/GNUmakefile   2011-01-26 17:16:08.978356589 +0100
+@@ -26,7 +26,7 @@
+ gdal_wrap.cc: generate
  
  Makefile_Geo__GDAL:
--      perl Makefile.PL
+-      perl Makefile.PL INSTALL_BASE=$(INST_PREFIX)
 +      perl Makefile.PL INSTALLDIRS=vendor
+ test: build
+       $(MAKE) -f Makefile_Geo__GDAL test
index d804bf6d94c8d9cf0deb62fc2cdbcd32933368d3..5ce4b6720f52484d8b797e15cfef4b874fcc4313 100644 (file)
--- a/gdal.spec
+++ b/gdal.spec
@@ -1,4 +1,6 @@
-# TODO: csharp, java, mysql
+# TODO:
+# - wait for newer pcidsk, switch to external again
+# - csharp, java, mysql
 #
 # Conditional build:
 %bcond_without odbc    # disable odbc support
 Summary:       Geospatial Data Abstraction Library
 Summary(pl.UTF-8):     Biblioteka abstrakcji danych dotyczÄ…cych powierzchni Ziemi
 Name:          gdal
-Version:       1.7.3
-Release:       11
+Version:       1.8.0
+Release:       1
 License:       BSD-like
 Group:         Libraries
 Source0:       ftp://ftp.remotesensing.org/gdal/%{name}-%{version}.tar.gz
-# Source0-md5: c4673970bd2285032de9ae9bbd82754a
+# Source0-md5: c762cdab0f7e51a677ba49278a8a263d
 Patch0:                %{name}-perl.patch
 Patch1:                %{name}-ruby.patch
 Patch2:                %{name}-asneeded.patch
 Patch3:                %{name}-python_install.patch
-Patch4:                %{name}-libdap.patch
-Patch5:                %{name}-doxy.patch
+Patch4:                %{name}-doxy.patch
+Patch5:                %{name}-libpng.patch
 URL:           http://www.gdal.org/
 BuildRequires: autoconf >= 2.52
 BuildRequires: automake
@@ -37,13 +39,13 @@ BuildRequires:      libgeotiff-devel >= 1.2.1
 BuildRequires: libjpeg-devel >= 6b
 BuildRequires: libpng-devel >= 2:1.2.8
 BuildRequires: libstdc++-devel
-BuildRequires: libtiff-devel >= 3.6.0
+BuildRequires: libtiff-devel >= 4.0
 BuildRequires: libtool
 BuildRequires: libuuid-devel
 BuildRequires: libxml2-devel
 BuildRequires: netcdf-devel
 BuildRequires: ogdi-devel >= 3.1
-BuildRequires: pcidsk-devel
+#BuildRequires:        pcidsk-devel > 0.3
 BuildRequires: perl-devel
 BuildRequires: postgresql-backend-devel
 BuildRequires: postgresql-devel
@@ -69,7 +71,7 @@ BuildRequires:        zlib-devel >= 1.1.4
 Requires:      geos >= 2.2
 Requires:      libgeotiff >= 1.2.1
 Requires:      libpng >= 2:1.2.8
-Requires:      libtiff >= 3.6.0
+Requires:      libtiff >= 4.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -106,10 +108,10 @@ Requires: libgeotiff-devel >= 1.2.1
 Requires:      libjpeg-devel
 Requires:      libpng-devel >= 2:1.2.8
 Requires:      libstdc++-devel
-Requires:      libtiff-devel >= 3.6.0
+Requires:      libtiff-devel >= 4.0
 Requires:      netcdf-devel
 Requires:      ogdi-devel >= 3.1
-Requires:      pcidsk-devel
+#Requires:     pcidsk-devel > 0.3
 Requires:      postgresql-devel
 Requires:      sqlite3-devel >= 3
 %{?with_odbc:Requires: unixODBC-devel}
@@ -197,11 +199,11 @@ export PYTHON_INCLUDES=-I%{py_incdir}
 %{__aclocal} -I m4
 %{__autoconf}
 # disable grass/libgrass here, it can be built from separate gdal-grass package
+# note: "WARNING: unrecognized options: --with-hide-internal-symbols" is caused by configure bug; option DOES take effect
 %configure \
        --datadir=%{_datadir}/gdal \
        --with-dods-root=/usr \
        --with-hide-internal-symbols \
-       --with-pcidsk=/usr \
        --with-perl \
        --with-python \
        %{?with_ruby:--with-ruby} \
@@ -211,6 +213,7 @@ export PYTHON_INCLUDES=-I%{py_incdir}
        --with-xerces-lib="-lxerces-c" \
        --without-grass \
        --without-libgrass
+#      --with-pcidsk=/usr (needs > 0.3)
 # --with-php needs Zend API update
 # java broken, no configure option
 # csharp builds, but has no configure option
@@ -246,10 +249,8 @@ cp -a ogr/html _html/ogr
 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OSR/.packlist
 
 # some doxygen trash
-%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Geo/GDAL.dox
-%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Geo/GDAL/Const.dox
-%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Geo/OGR.dox
-%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Geo/OSR.dox
+%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Geo/{GDAL.dox,GDAL/Const.dox,OGR.dox,OSR.dox}
+%{__rm} $RPM_BUILD_ROOT%{_bindir}/gdal_{fillnodata,sieve}.dox
 
 %if %{with ruby}
 %{__rm} $RPM_BUILD_ROOT%{ruby_sitearchdir}/gdal/*.la
@@ -271,6 +272,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/gdal2tiles.py
 %attr(755,root,root) %{_bindir}/gdal2xyz.py
 %attr(755,root,root) %{_bindir}/gdal_contour
+%attr(755,root,root) %{_bindir}/gdal_calc.py
 %attr(755,root,root) %{_bindir}/gdal_fillnodata.py
 %attr(755,root,root) %{_bindir}/gdal_grid
 %attr(755,root,root) %{_bindir}/gdal_merge.py
@@ -288,6 +290,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/gdalident.py
 %attr(755,root,root) %{_bindir}/gdalimport.py
 %attr(755,root,root) %{_bindir}/gdalinfo
+%attr(755,root,root) %{_bindir}/gdallocationinfo
 %attr(755,root,root) %{_bindir}/gdalmanage
 %attr(755,root,root) %{_bindir}/gdaltindex
 %attr(755,root,root) %{_bindir}/gdaltransform
@@ -317,6 +320,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/gdalbuildvrt.1*
 %{_mandir}/man1/gdaldem.1*
 %{_mandir}/man1/gdalinfo.1*
+%{_mandir}/man1/gdallocationinfo.1*
 %{_mandir}/man1/gdaltindex.1*
 %{_mandir}/man1/gdaltransform.1*
 %{_mandir}/man1/gdalwarp.1*
This page took 0.053381 seconds and 4 git commands to generate.