]> git.pld-linux.org Git - packages/gdal.git/blobdiff - gdal.spec
adjusted upstream patch to fix build with poppler 0.69.0
[packages/gdal.git] / gdal.spec
index b5763df7c7923782c5308b17bed6ce68f4bf3723..f477e3c35f8d0af28ff72e55e6d69cdc2993f571 100644 (file)
--- a/gdal.spec
+++ b/gdal.spec
@@ -33,7 +33,7 @@
 %bcond_without openjpeg        # OpenJPEG 2 (JPEG2000) support
 %bcond_with    podofo          # PDF support via podofo instead of poppler
 %bcond_without poppler         # PDF support via poppler
-%bcond_without rasdaman        # Rasdaman support
+%bcond_with    rasdaman        # Rasdaman support
 %bcond_without spatialite      # SpatiaLite support
 %bcond_without xerces          # Xerces support
 %bcond_without java            # Java and MDB support
 Summary:       Geospatial Data Abstraction Library
 Summary(pl.UTF-8):     Biblioteka abstrakcji danych dotyczÄ…cych powierzchni Ziemi
 Name:          gdal
-Version:       2.0.2
-Release:       17
+Version:       2.2.4
+Release:       9
 License:       BSD-like
 Group:         Libraries
 Source0:       http://download.osgeo.org/gdal/%{version}/%{name}-%{version}.tar.xz
-# Source0-md5: 940208e737c87d31a90eaae43d0efd65
+# Source0-md5: 51b1df61dbdf81473689fab3075e7a5e
 Patch0:                %{name}-perl.patch
-Patch1:                %{name}-python_install.patch
+Patch1:                %{name}-poppler.patch
 Patch2:                %{name}-php.patch
 Patch3:                %{name}-fpic.patch
-Patch5:                %{name}-grass.patch
-Patch7:                %{name}-link.patch
-Patch8:                %{name}-fyba.patch
 Patch9:                %{name}-dds.patch
 Patch11:       %{name}-armadillo.patch
 Patch12:       %{name}-rasdaman.patch
 Patch13:       %{name}-pluginsdir.patch
-Patch14:       %{name}-uchar.patch
 Patch15:       libx32.patch
 URL:           http://www.gdal.org/
 %{?with_php:BuildRequires:     %{php_name}-devel}
@@ -285,17 +281,13 @@ osr.
 %prep
 %setup -q
 %patch0 -p1
-%patch1 -p1
+%patch1 -p2
 %patch2 -p1
 %patch3 -p1
-%patch5 -p1
-%patch7 -p1
-%patch8 -p1
 %patch9 -p1
 %patch11 -p1
 %patch12 -p1
 %patch13 -p1
-%patch14 -p1
 %patch15 -p1
 
 # need to regenerate (old ones don't support perl 5.10 or php 5.5)
@@ -319,11 +311,11 @@ sed -i -e 's|^$(INSTALL_DIR):|$(DESTDIR)$(INSTALL_DIR):|' swig/ruby/RubyMakefile
 sed -i -e 's|^install: $(INSTALL_DIR)|install: $(DESTDIR)$(INSTALL_DIR)|' swig/ruby/RubyMakefile.mk
 
 # our man path
-sed -i -e 's#^mandir=.*##g' configure.in
+sed -i -e 's#^mandir=.*##g' configure.ac
 
 %{__rm} -r man
 
-%{__sed} -i -e 's,DODS_INC="-I.*,DODS_INC="$(pkg-config --cflags libdap)",' configure.in
+%{__sed} -i -e 's,DODS_INC="-I.*,DODS_INC="$(pkg-config --cflags libdap)",' configure.ac
 
 %build
 %ifarch %{x8664}
@@ -425,10 +417,6 @@ EOF
 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OGR/.packlist
 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OSR/.packlist
 
-# some doxygen trash
-%{__rm} $RPM_BUILD_ROOT%{_bindir}/gdal{compare,move}.dox
-%{__rm} $RPM_BUILD_ROOT%{_bindir}/gdal_{calc,edit,fillnodata,polygonize,proximity,sieve}.dox
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -444,41 +432,45 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/gcps2wld.py
 %attr(755,root,root) %{_bindir}/gdal2tiles.py
 %attr(755,root,root) %{_bindir}/gdal2xyz.py
-%attr(755,root,root) %{_bindir}/gdal_auth.py
-%attr(755,root,root) %{_bindir}/gdal_contour
-%attr(755,root,root) %{_bindir}/gdal_calc.py
-%attr(755,root,root) %{_bindir}/gdal_edit.py
-%attr(755,root,root) %{_bindir}/gdal_fillnodata.py
-%attr(755,root,root) %{_bindir}/gdal_grid
-%attr(755,root,root) %{_bindir}/gdal_merge.py
-%attr(755,root,root) %{_bindir}/gdal_polygonize.py
-%attr(755,root,root) %{_bindir}/gdal_proximity.py
-%attr(755,root,root) %{_bindir}/gdal_rasterize
-%attr(755,root,root) %{_bindir}/gdal_retile.py
-%attr(755,root,root) %{_bindir}/gdal_sieve.py
-%attr(755,root,root) %{_bindir}/gdal_translate
 %attr(755,root,root) %{_bindir}/gdaladdo
+%attr(755,root,root) %{_bindir}/gdal_auth.py
 %attr(755,root,root) %{_bindir}/gdalbuildvrt
+%attr(755,root,root) %{_bindir}/gdal_calc.py
 %attr(755,root,root) %{_bindir}/gdalchksum.py
 %attr(755,root,root) %{_bindir}/gdalcompare.py
+%attr(755,root,root) %{_bindir}/gdal_contour
 %attr(755,root,root) %{_bindir}/gdaldem
+%attr(755,root,root) %{_bindir}/gdal_edit.py
 %attr(755,root,root) %{_bindir}/gdalenhance
+%attr(755,root,root) %{_bindir}/gdal_fillnodata.py
+%attr(755,root,root) %{_bindir}/gdal_grid
 %attr(755,root,root) %{_bindir}/gdalident.py
 %attr(755,root,root) %{_bindir}/gdalimport.py
 %attr(755,root,root) %{_bindir}/gdalinfo
 %attr(755,root,root) %{_bindir}/gdallocationinfo
 %attr(755,root,root) %{_bindir}/gdalmanage
+%attr(755,root,root) %{_bindir}/gdal_merge.py
 %attr(755,root,root) %{_bindir}/gdalmove.py
+%attr(755,root,root) %{_bindir}/gdal_pansharpen.py
+%attr(755,root,root) %{_bindir}/gdal_polygonize.py
+%attr(755,root,root) %{_bindir}/gdal_proximity.py
+%attr(755,root,root) %{_bindir}/gdal_rasterize
+%attr(755,root,root) %{_bindir}/gdal_retile.py
 %attr(755,root,root) %{_bindir}/gdalserver
+%attr(755,root,root) %{_bindir}/gdal_sieve.py
 %attr(755,root,root) %{_bindir}/gdalsrsinfo
 %attr(755,root,root) %{_bindir}/gdaltindex
 %attr(755,root,root) %{_bindir}/gdaltransform
+%attr(755,root,root) %{_bindir}/gdal_translate
 %attr(755,root,root) %{_bindir}/gdalwarp
+%attr(755,root,root) %{_bindir}/gnmanalyse
+%attr(755,root,root) %{_bindir}/gnmmanage
 %attr(755,root,root) %{_bindir}/mkgraticule.py
 %attr(755,root,root) %{_bindir}/nearblack
 %attr(755,root,root) %{_bindir}/ogr2ogr
 %attr(755,root,root) %{_bindir}/ogrinfo
 %attr(755,root,root) %{_bindir}/ogrlineref
+%attr(755,root,root) %{_bindir}/ogrmerge.py
 %attr(755,root,root) %{_bindir}/ogrtindex
 %attr(755,root,root) %{_bindir}/pct2rgb.py
 %attr(755,root,root) %{_bindir}/rgb2pct.py
@@ -521,6 +513,11 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/ogrtindex.1*
 %{_mandir}/man1/pct2rgb.1*
 %{_mandir}/man1/rgb2pct.1*
+%{_mandir}/man1/gdal_pansharpen.1*
+%{_mandir}/man1/gnm_utilities.1*
+%{_mandir}/man1/gnmanalyse.1*
+%{_mandir}/man1/gnmmanage.1*
+%{_mandir}/man1/ogrmerge.1*
 
 %files devel
 %defattr(644,root,root,755)
@@ -549,11 +546,14 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/GDAL.so
 %dir %{perl_vendorarch}/auto/Geo/GDAL/Const
 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.so
+%dir %{perl_vendorarch}/auto/Geo/GNM
+%attr(755,root,root) %{perl_vendorarch}/auto/Geo/GNM/GNM.so
 %dir %{perl_vendorarch}/auto/Geo/OGR
 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OGR/OGR.so
 %dir %{perl_vendorarch}/auto/Geo/OSR
 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OSR/OSR.so
 %{_mandir}/man3/Geo::GDAL.3pm*
+%{perl_vendorarch}/Geo/GNM.pm
 
 %if %{with php}
 %files -n %{php_name}-gdal
@@ -570,6 +570,7 @@ rm -rf $RPM_BUILD_ROOT
 %{py_sitedir}/gdal.py[co]
 %{py_sitedir}/gdalconst.py[co]
 %{py_sitedir}/gdalnumeric.py[co]
+%{py_sitedir}/gnm.py[co]
 %{py_sitedir}/ogr.py[co]
 %{py_sitedir}/osr.py[co]
 %{py_sitedir}/GDAL-*.egg-info
@@ -577,6 +578,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal.so
 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal_array.so
 %attr(755,root,root) %{py_sitedir}/osgeo/_gdalconst.so
+%attr(755,root,root) %{py_sitedir}/osgeo/_gnm.so
 %attr(755,root,root) %{py_sitedir}/osgeo/_ogr.so
 %attr(755,root,root) %{py_sitedir}/osgeo/_osr.so
 %{py_sitedir}/osgeo/*.py[co]
This page took 0.032083 seconds and 4 git commands to generate.