]> git.pld-linux.org Git - packages/gdal.git/blobdiff - gdal.spec
adjusted upstream patch to fix build with poppler 0.69.0
[packages/gdal.git] / gdal.spec
index 4bb059b9b2c693a6adfa2b5a6f631868f841a7c4..f477e3c35f8d0af28ff72e55e6d69cdc2993f571 100644 (file)
--- a/gdal.spec
+++ b/gdal.spec
@@ -25,6 +25,7 @@
 %bcond_without fyba            # SOSI geodata support using FYBA
 %bcond_with    grass           # GRASS support (note: dependency loop; use gdal-grass.spec instead)
 %bcond_without gta             # GTA format support
+%bcond_without kea             # KEA format support
 %bcond_without mysql           # MySQL DB support
 %bcond_with    oci             # ORACLE OCI DB and Georaster support
 %bcond_without odbc            # ODBC DB support
 %bcond_without openjpeg        # OpenJPEG 2 (JPEG2000) support
 %bcond_with    podofo          # PDF support via podofo instead of poppler
 %bcond_without poppler         # PDF support via poppler
-%bcond_without rasdaman        # Rasdaman support
+%bcond_with    rasdaman        # Rasdaman support
 %bcond_without spatialite      # SpatiaLite support
 %bcond_without xerces          # Xerces support
 %bcond_without java            # Java and MDB support
-%bcond_without php             # PHP binding
-%bcond_without ruby            # Ruby binding
+%bcond_with    php             # PHP binding [PHP 7 not supported by swig 3.0.x]
+%bcond_with    ruby            # Ruby binding [not available as of 2.0.2]
 
 %if %{with podofo}
 %undefine      with_poppler
 Summary:       Geospatial Data Abstraction Library
 Summary(pl.UTF-8):     Biblioteka abstrakcji danych dotyczÄ…cych powierzchni Ziemi
 Name:          gdal
-Version:       1.11.2
-Release:       6
+Version:       2.2.4
+Release:       9
 License:       BSD-like
 Group:         Libraries
 Source0:       http://download.osgeo.org/gdal/%{version}/%{name}-%{version}.tar.xz
-# Source0-md5: 90221810dd9ca656ee23d434d4266ef6
+# Source0-md5: 51b1df61dbdf81473689fab3075e7a5e
 Patch0:                %{name}-perl.patch
-Patch1:                %{name}-python_install.patch
+Patch1:                %{name}-poppler.patch
 Patch2:                %{name}-php.patch
 Patch3:                %{name}-fpic.patch
-Patch4:                %{name}-format-security.patch
-Patch5:                %{name}-grass.patch
-Patch6:                %{name}-sse.patch
-Patch7:                %{name}-link.patch
-Patch8:                %{name}-fyba.patch
 Patch9:                %{name}-dds.patch
 Patch11:       %{name}-armadillo.patch
 Patch12:       %{name}-rasdaman.patch
 Patch13:       %{name}-pluginsdir.patch
-Patch14:       poppler-0.31.patch
+Patch15:       libx32.patch
 URL:           http://www.gdal.org/
 %{?with_php:BuildRequires:     %{php_name}-devel}
 %{?with_opencl:BuildRequires:  OpenCL-devel >= 1.0}
@@ -92,7 +88,8 @@ BuildRequires:        jasper-devel
 %{?with_java:BuildRequires:    jdk}
 %{?with_java:BuildRequires:    jpackage-utils}
 BuildRequires: json-c-devel >= 0.11
-BuildRequires: libcsf-devel
+%{?with_kea:BuildRequires:     kealib-devel}
+BuildRequires: libcsf-devel >= 2.0-0.041111.6
 BuildRequires: libdap-devel >= 3.10
 BuildRequires: libgeotiff-devel >= 1.2.1
 %{?with_gta:BuildRequires:     libgta-devel}
@@ -106,7 +103,7 @@ BuildRequires:      libtool
 BuildRequires: libuuid-devel
 BuildRequires: libwebp-devel
 BuildRequires: libxml2-devel >= 2
-%{?with_mysql:BuildRequires:   mysql-devel}
+%{?with_mysql:BuildRequires:   /usr/bin/mysql_config}
 BuildRequires: netcdf-devel >= 4.1
 BuildRequires: ogdi-devel >= 3.1
 %{?with_openjpeg:BuildRequires:        openjpeg2-devel >= 2.0.0-2}
@@ -183,6 +180,7 @@ Requires:   hdf-devel >= 4.0
 Requires:      hdf5-devel
 Requires:      jasper-devel
 Requires:      json-c-devel >= 0.11
+%{?with_kea:Requires:  kealib-devel}
 Requires:      libcsf-devel
 Requires:      libdap-devel >= 3.10
 Requires:      libgeotiff-devel >= 1.2.1
@@ -195,7 +193,7 @@ Requires:   libtiff-devel >= 4.0
 Requires:      libuuid-devel
 Requires:      libwebp-devel
 Requires:      libxml2-devel >= 2
-%{?with_mysql:Requires:        mysql-devel}
+%{?with_mysql:Requires:        /usr/bin/mysql_config}
 Requires:      netcdf-devel >= 4
 Requires:      ogdi-devel >= 3.1
 %{?with_openjpeg:Requires:     openjpeg2-devel >= 2.0.0-2}
@@ -283,19 +281,14 @@ osr.
 %prep
 %setup -q
 %patch0 -p1
-%patch1 -p1
+%patch1 -p2
 %patch2 -p1
 %patch3 -p1
-%patch4 -p1
-%patch5 -p1
-%patch6 -p1
-%patch7 -p1
-%patch8 -p1
 %patch9 -p1
 %patch11 -p1
 %patch12 -p1
 %patch13 -p1
-%patch14 -p1
+%patch15 -p1
 
 # need to regenerate (old ones don't support perl 5.10 or php 5.5)
 %{__rm} swig/{perl,php}/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
@@ -318,11 +311,11 @@ sed -i -e 's|^$(INSTALL_DIR):|$(DESTDIR)$(INSTALL_DIR):|' swig/ruby/RubyMakefile
 sed -i -e 's|^install: $(INSTALL_DIR)|install: $(DESTDIR)$(INSTALL_DIR)|' swig/ruby/RubyMakefile.mk
 
 # our man path
-sed -i -e 's#^mandir=.*##g' configure.in
+sed -i -e 's#^mandir=.*##g' configure.ac
 
 %{__rm} -r man
 
-%{__sed} -i -e 's,DODS_INC="-I.*,DODS_INC="$(pkg-config --cflags libdap)",' configure.in
+%{__sed} -i -e 's,DODS_INC="-I.*,DODS_INC="$(pkg-config --cflags libdap)",' configure.ac
 
 %build
 %ifarch %{x8664}
@@ -351,6 +344,7 @@ jvm_arch=x32
        --with-hide-internal-symbols \
        %{?with_java:--with-java=%{java_home}} \
        --with-liblzma \
+       %{!?with_kea:--without-kea} \
        %{?with_java:--with-mdb --with-jvm-lib-add-rpath --with-jvm-lib=%{java_home}/jre/lib/$jvm_arch/server} \
        %{?with_mysql:--with-mysql} \
        %{?with_oci:--with-oci --with-oci-include=/usr/include/oracle/client --with-oci-lib=%{_libdir}} \
@@ -395,7 +389,6 @@ rm -rf $RPM_BUILD_ROOT
 
 rm -rf _html
 cp -a html _html
-cp -a ogr/html _html/ogr
 
 %if %{with php}
 # missing in make install
@@ -424,10 +417,6 @@ EOF
 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OGR/.packlist
 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OSR/.packlist
 
-# some doxygen trash
-%{__rm} $RPM_BUILD_ROOT%{_bindir}/gdal{compare,move}.dox
-%{__rm} $RPM_BUILD_ROOT%{_bindir}/gdal_{calc,edit,fillnodata,polygonize,proximity,sieve}.dox
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -443,47 +432,51 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/gcps2wld.py
 %attr(755,root,root) %{_bindir}/gdal2tiles.py
 %attr(755,root,root) %{_bindir}/gdal2xyz.py
-%attr(755,root,root) %{_bindir}/gdal_auth.py
-%attr(755,root,root) %{_bindir}/gdal_contour
-%attr(755,root,root) %{_bindir}/gdal_calc.py
-%attr(755,root,root) %{_bindir}/gdal_edit.py
-%attr(755,root,root) %{_bindir}/gdal_fillnodata.py
-%attr(755,root,root) %{_bindir}/gdal_grid
-%attr(755,root,root) %{_bindir}/gdal_merge.py
-%attr(755,root,root) %{_bindir}/gdal_polygonize.py
-%attr(755,root,root) %{_bindir}/gdal_proximity.py
-%attr(755,root,root) %{_bindir}/gdal_rasterize
-%attr(755,root,root) %{_bindir}/gdal_retile.py
-%attr(755,root,root) %{_bindir}/gdal_sieve.py
-%attr(755,root,root) %{_bindir}/gdal_translate
 %attr(755,root,root) %{_bindir}/gdaladdo
+%attr(755,root,root) %{_bindir}/gdal_auth.py
 %attr(755,root,root) %{_bindir}/gdalbuildvrt
+%attr(755,root,root) %{_bindir}/gdal_calc.py
 %attr(755,root,root) %{_bindir}/gdalchksum.py
 %attr(755,root,root) %{_bindir}/gdalcompare.py
+%attr(755,root,root) %{_bindir}/gdal_contour
 %attr(755,root,root) %{_bindir}/gdaldem
+%attr(755,root,root) %{_bindir}/gdal_edit.py
 %attr(755,root,root) %{_bindir}/gdalenhance
+%attr(755,root,root) %{_bindir}/gdal_fillnodata.py
+%attr(755,root,root) %{_bindir}/gdal_grid
 %attr(755,root,root) %{_bindir}/gdalident.py
 %attr(755,root,root) %{_bindir}/gdalimport.py
 %attr(755,root,root) %{_bindir}/gdalinfo
 %attr(755,root,root) %{_bindir}/gdallocationinfo
 %attr(755,root,root) %{_bindir}/gdalmanage
+%attr(755,root,root) %{_bindir}/gdal_merge.py
 %attr(755,root,root) %{_bindir}/gdalmove.py
+%attr(755,root,root) %{_bindir}/gdal_pansharpen.py
+%attr(755,root,root) %{_bindir}/gdal_polygonize.py
+%attr(755,root,root) %{_bindir}/gdal_proximity.py
+%attr(755,root,root) %{_bindir}/gdal_rasterize
+%attr(755,root,root) %{_bindir}/gdal_retile.py
 %attr(755,root,root) %{_bindir}/gdalserver
+%attr(755,root,root) %{_bindir}/gdal_sieve.py
 %attr(755,root,root) %{_bindir}/gdalsrsinfo
 %attr(755,root,root) %{_bindir}/gdaltindex
 %attr(755,root,root) %{_bindir}/gdaltransform
+%attr(755,root,root) %{_bindir}/gdal_translate
 %attr(755,root,root) %{_bindir}/gdalwarp
+%attr(755,root,root) %{_bindir}/gnmanalyse
+%attr(755,root,root) %{_bindir}/gnmmanage
 %attr(755,root,root) %{_bindir}/mkgraticule.py
 %attr(755,root,root) %{_bindir}/nearblack
 %attr(755,root,root) %{_bindir}/ogr2ogr
 %attr(755,root,root) %{_bindir}/ogrinfo
 %attr(755,root,root) %{_bindir}/ogrlineref
+%attr(755,root,root) %{_bindir}/ogrmerge.py
 %attr(755,root,root) %{_bindir}/ogrtindex
 %attr(755,root,root) %{_bindir}/pct2rgb.py
 %attr(755,root,root) %{_bindir}/rgb2pct.py
 %attr(755,root,root) %{_bindir}/testepsg
 %attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libgdal.so.1
+%attr(755,root,root) %ghost %{_libdir}/libgdal.so.20
 %dir %{_libdir}/gdalplugins
 %{_datadir}/gdal
 %{_mandir}/man1/gdal2tiles.1*
@@ -520,6 +513,11 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/ogrtindex.1*
 %{_mandir}/man1/pct2rgb.1*
 %{_mandir}/man1/rgb2pct.1*
+%{_mandir}/man1/gdal_pansharpen.1*
+%{_mandir}/man1/gnm_utilities.1*
+%{_mandir}/man1/gnmanalyse.1*
+%{_mandir}/man1/gnmmanage.1*
+%{_mandir}/man1/ogrmerge.1*
 
 %files devel
 %defattr(644,root,root,755)
@@ -548,10 +546,14 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/GDAL.so
 %dir %{perl_vendorarch}/auto/Geo/GDAL/Const
 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.so
+%dir %{perl_vendorarch}/auto/Geo/GNM
+%attr(755,root,root) %{perl_vendorarch}/auto/Geo/GNM/GNM.so
 %dir %{perl_vendorarch}/auto/Geo/OGR
 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OGR/OGR.so
 %dir %{perl_vendorarch}/auto/Geo/OSR
 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OSR/OSR.so
+%{_mandir}/man3/Geo::GDAL.3pm*
+%{perl_vendorarch}/Geo/GNM.pm
 
 %if %{with php}
 %files -n %{php_name}-gdal
@@ -568,6 +570,7 @@ rm -rf $RPM_BUILD_ROOT
 %{py_sitedir}/gdal.py[co]
 %{py_sitedir}/gdalconst.py[co]
 %{py_sitedir}/gdalnumeric.py[co]
+%{py_sitedir}/gnm.py[co]
 %{py_sitedir}/ogr.py[co]
 %{py_sitedir}/osr.py[co]
 %{py_sitedir}/GDAL-*.egg-info
@@ -575,6 +578,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal.so
 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal_array.so
 %attr(755,root,root) %{py_sitedir}/osgeo/_gdalconst.so
+%attr(755,root,root) %{py_sitedir}/osgeo/_gnm.so
 %attr(755,root,root) %{py_sitedir}/osgeo/_ogr.so
 %attr(755,root,root) %{py_sitedir}/osgeo/_osr.so
 %{py_sitedir}/osgeo/*.py[co]
This page took 0.071487 seconds and 4 git commands to generate.