- release 16 (by relup.sh)
[packages/gdal.git] / gdal.spec
index 653ea90..ebbff85 100644 (file)
--- a/gdal.spec
+++ b/gdal.spec
@@ -25,6 +25,7 @@
 %bcond_without fyba            # SOSI geodata support using FYBA
 %bcond_with    grass           # GRASS support (note: dependency loop; use gdal-grass.spec instead)
 %bcond_without gta             # GTA format support
+%bcond_without kea             # KEA format support
 %bcond_without mysql           # MySQL DB support
 %bcond_with    oci             # ORACLE OCI DB and Georaster support
 %bcond_without odbc            # ODBC DB support
@@ -36,8 +37,8 @@
 %bcond_without spatialite      # SpatiaLite support
 %bcond_without xerces          # Xerces support
 %bcond_without java            # Java and MDB support
-%bcond_without php             # PHP binding
-%bcond_without ruby            # Ruby binding
+%bcond_with    php             # PHP binding [PHP 7 not supported by swig 3.0.x]
+%bcond_with    ruby            # Ruby binding [not available as of 2.0.2]
 
 %if %{with podofo}
 %undefine      with_poppler
 Summary:       Geospatial Data Abstraction Library
 Summary(pl.UTF-8):     Biblioteka abstrakcji danych dotyczÄ…cych powierzchni Ziemi
 Name:          gdal
-Version:       1.11.2
-Release:       5
+Version:       2.0.2
+Release:       16
 License:       BSD-like
 Group:         Libraries
 Source0:       http://download.osgeo.org/gdal/%{version}/%{name}-%{version}.tar.xz
-# Source0-md5: 90221810dd9ca656ee23d434d4266ef6
+# Source0-md5: 940208e737c87d31a90eaae43d0efd65
 Patch0:                %{name}-perl.patch
 Patch1:                %{name}-python_install.patch
 Patch2:                %{name}-php.patch
 Patch3:                %{name}-fpic.patch
-Patch4:                %{name}-format-security.patch
 Patch5:                %{name}-grass.patch
-Patch6:                %{name}-sse.patch
 Patch7:                %{name}-link.patch
 Patch8:                %{name}-fyba.patch
 Patch9:                %{name}-dds.patch
 Patch11:       %{name}-armadillo.patch
 Patch12:       %{name}-rasdaman.patch
 Patch13:       %{name}-pluginsdir.patch
-Patch14:       poppler-0.31.patch
+Patch14:       %{name}-uchar.patch
+Patch15:       libx32.patch
 URL:           http://www.gdal.org/
 %{?with_php:BuildRequires:     %{php_name}-devel}
 %{?with_opencl:BuildRequires:  OpenCL-devel >= 1.0}
@@ -92,7 +92,8 @@ BuildRequires:        jasper-devel
 %{?with_java:BuildRequires:    jdk}
 %{?with_java:BuildRequires:    jpackage-utils}
 BuildRequires: json-c-devel >= 0.11
-BuildRequires: libcsf-devel
+%{?with_kea:BuildRequires:     kealib-devel}
+BuildRequires: libcsf-devel >= 2.0-0.041111.6
 BuildRequires: libdap-devel >= 3.10
 BuildRequires: libgeotiff-devel >= 1.2.1
 %{?with_gta:BuildRequires:     libgta-devel}
@@ -183,6 +184,7 @@ Requires:   hdf-devel >= 4.0
 Requires:      hdf5-devel
 Requires:      jasper-devel
 Requires:      json-c-devel >= 0.11
+%{?with_kea:Requires:  kealib-devel}
 Requires:      libcsf-devel
 Requires:      libdap-devel >= 3.10
 Requires:      libgeotiff-devel >= 1.2.1
@@ -286,9 +288,7 @@ osr.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
-%patch4 -p1
 %patch5 -p1
-%patch6 -p1
 %patch7 -p1
 %patch8 -p1
 %patch9 -p1
@@ -296,6 +296,7 @@ osr.
 %patch12 -p1
 %patch13 -p1
 %patch14 -p1
+%patch15 -p1
 
 # need to regenerate (old ones don't support perl 5.10 or php 5.5)
 %{__rm} swig/{perl,php}/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
@@ -351,6 +352,7 @@ jvm_arch=x32
        --with-hide-internal-symbols \
        %{?with_java:--with-java=%{java_home}} \
        --with-liblzma \
+       %{!?with_kea:--without-kea} \
        %{?with_java:--with-mdb --with-jvm-lib-add-rpath --with-jvm-lib=%{java_home}/jre/lib/$jvm_arch/server} \
        %{?with_mysql:--with-mysql} \
        %{?with_oci:--with-oci --with-oci-include=/usr/include/oracle/client --with-oci-lib=%{_libdir}} \
@@ -395,7 +397,6 @@ rm -rf $RPM_BUILD_ROOT
 
 rm -rf _html
 cp -a html _html
-cp -a ogr/html _html/ogr
 
 %if %{with php}
 # missing in make install
@@ -483,7 +484,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/rgb2pct.py
 %attr(755,root,root) %{_bindir}/testepsg
 %attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libgdal.so.1
+%attr(755,root,root) %ghost %{_libdir}/libgdal.so.20
 %dir %{_libdir}/gdalplugins
 %{_datadir}/gdal
 %{_mandir}/man1/gdal2tiles.1*
@@ -552,6 +553,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OGR/OGR.so
 %dir %{perl_vendorarch}/auto/Geo/OSR
 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OSR/OSR.so
+%{_mandir}/man3/Geo::GDAL.3pm*
 
 %if %{with php}
 %files -n %{php_name}-gdal
This page took 0.064218 seconds and 4 git commands to generate.