]> git.pld-linux.org Git - packages/gdal.git/blobdiff - gdal.spec
- release 16 (by relup.sh)
[packages/gdal.git] / gdal.spec
index 2f8af60239db8c3d7eff914e28ae35ce52285b6a..ebbff85ffe38c321a9e66681a1cc20c47475359a 100644 (file)
--- a/gdal.spec
+++ b/gdal.spec
@@ -2,7 +2,6 @@
 # - be reasonable about devel dependencies - you do not need all of them to
 #   use gdal (probably a gdal module or driver shall not imply devel
 #   dependency)
-# - rasdaman (--with-rasdaman; http://rasdaman.eecs.jacobs-university.de/trac/rasdaman/wiki/Download)
 # - libjpeg12 (needs patching to use system one, --with-jpeg12 is not sufficient as of 1.9.2)
 # - libkml (1.3.0 needed, not released yet)
 # - wait for newer pcidsk, switch to external again
@@ -14,7 +13,6 @@
 #   - Kakadu/JPEG2000 (http://www.kakadusoftware.com/)
 #   - MrSID (http://www.lizardtech.com/developer/)
 #   - MSG/EUMETSAT (http://www.eumetsat.int/Home/Main/DataAccess/SupportSoftwareTools/index.htm)
-#   - Oracle/OCI >= 10.0.1 (for georaster); Oracle/OCI >= 8.1.7 (as DB)
 #   - Ingres (--with-ingres=/path)
 #   - Informix DB (--with-idb)
 #   - DWGdirect (members only? http://www.opendwg.org/)
@@ -25,8 +23,9 @@
 %bcond_without crnlib          # DDS support via crunch/crnlib
 %bcond_without epsilon         # EPSILON wavelet compression support
 %bcond_without fyba            # SOSI geodata support using FYBA
-%bcond_with    grass           # GRASS support (note: dependency loop)
+%bcond_with    grass           # GRASS support (note: dependency loop; use gdal-grass.spec instead)
 %bcond_without gta             # GTA format support
+%bcond_without kea             # KEA format support
 %bcond_without mysql           # MySQL DB support
 %bcond_with    oci             # ORACLE OCI DB and Georaster support
 %bcond_without odbc            # ODBC DB support
 %bcond_without spatialite      # SpatiaLite support
 %bcond_without xerces          # Xerces support
 %bcond_without java            # Java and MDB support
-%bcond_without php             # PHP binding
-%bcond_without ruby            # Ruby binding
+%bcond_with    php             # PHP binding [PHP 7 not supported by swig 3.0.x]
+%bcond_with    ruby            # Ruby binding [not available as of 2.0.2]
 
 %if %{with podofo}
 %undefine      with_poppler
 %endif
+%if 0%{!?php_name:1}
 %define                php_name        php55
+%endif
 Summary:       Geospatial Data Abstraction Library
 Summary(pl.UTF-8):     Biblioteka abstrakcji danych dotyczÄ…cych powierzchni Ziemi
 Name:          gdal
-Version:       1.11.0
-Release:       3
+Version:       2.0.2
+Release:       16
 License:       BSD-like
 Group:         Libraries
 Source0:       http://download.osgeo.org/gdal/%{version}/%{name}-%{version}.tar.xz
-# Source0-md5: 31f2c4a7230b40e5fdc3cf12a100f96b
+# Source0-md5: 940208e737c87d31a90eaae43d0efd65
 Patch0:                %{name}-perl.patch
 Patch1:                %{name}-python_install.patch
 Patch2:                %{name}-php.patch
 Patch3:                %{name}-fpic.patch
-Patch4:                %{name}-format-security.patch
 Patch5:                %{name}-grass.patch
-Patch6:                %{name}-sse.patch
 Patch7:                %{name}-link.patch
 Patch8:                %{name}-fyba.patch
 Patch9:                %{name}-dds.patch
-Patch10:       %{name}-gif.patch
 Patch11:       %{name}-armadillo.patch
-Patch12:       %{name}-oci.patch
-Patch13:       %{name}-rasdaman.patch
+Patch12:       %{name}-rasdaman.patch
+Patch13:       %{name}-pluginsdir.patch
+Patch14:       %{name}-uchar.patch
+Patch15:       libx32.patch
 URL:           http://www.gdal.org/
 %{?with_php:BuildRequires:     %{php_name}-devel}
 %{?with_opencl:BuildRequires:  OpenCL-devel >= 1.0}
@@ -75,7 +75,7 @@ URL:          http://www.gdal.org/
 BuildRequires: autoconf >= 2.52
 BuildRequires: automake
 BuildRequires: cfitsio-devel
-%{?with_dds:BuildRequires:     crnlib-devel}
+%{?with_crnlib:BuildRequires:  crnlib-devel}
 BuildRequires: curl-devel
 BuildRequires: doxygen >= 1.4.2
 %{?with_epsilon:BuildRequires: epsilon-compressor-devel}
@@ -92,7 +92,8 @@ BuildRequires:        jasper-devel
 %{?with_java:BuildRequires:    jdk}
 %{?with_java:BuildRequires:    jpackage-utils}
 BuildRequires: json-c-devel >= 0.11
-BuildRequires: libcsf-devel
+%{?with_kea:BuildRequires:     kealib-devel}
+BuildRequires: libcsf-devel >= 2.0-0.041111.6
 BuildRequires: libdap-devel >= 3.10
 BuildRequires: libgeotiff-devel >= 1.2.1
 %{?with_gta:BuildRequires:     libgta-devel}
@@ -171,7 +172,7 @@ Requires:   %{name} = %{version}-%{release}
 %{?with_opencl:Requires:       OpenCL-devel >= 1.0}
 %{?with_armadillo:Requires:    armadillo-devel}
 Requires:      cfitsio-devel
-%{?with_dds:Requires:  crnlib-devel}
+%{?with_crnlib:Requires:       crnlib-devel}
 Requires:      curl-devel
 %{?with_epsilon:Requires:      epsilon-compressor-devel}
 %{?with_fyba:Requires: fyba-devel}
@@ -183,6 +184,7 @@ Requires:   hdf-devel >= 4.0
 Requires:      hdf5-devel
 Requires:      jasper-devel
 Requires:      json-c-devel >= 0.11
+%{?with_kea:Requires:  kealib-devel}
 Requires:      libcsf-devel
 Requires:      libdap-devel >= 3.10
 Requires:      libgeotiff-devel >= 1.2.1
@@ -286,16 +288,15 @@ osr.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
-%patch4 -p1
 %patch5 -p1
-%patch6 -p1
 %patch7 -p1
 %patch8 -p1
 %patch9 -p1
-%patch10 -p1
 %patch11 -p1
 %patch12 -p1
 %patch13 -p1
+%patch14 -p1
+%patch15 -p1
 
 # need to regenerate (old ones don't support perl 5.10 or php 5.5)
 %{__rm} swig/{perl,php}/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
@@ -325,10 +326,22 @@ sed -i -e 's#^mandir=.*##g' configure.in
 %{__sed} -i -e 's,DODS_INC="-I.*,DODS_INC="$(pkg-config --cflags libdap)",' configure.in
 
 %build
+%ifarch %{x8664}
+jvm_arch=amd64
+%endif
+%ifarch %{ix86}
+jvm_arch=i386
+%endif
+%ifarch x32
+jvm_arch=x32
+%endif
+
 %{__libtoolize}
 %{__aclocal} -I m4
 %{__autoconf}
+%{__autoheader}
 %configure \
+       --includedir=%{_includedir}/gdal \
        --datadir=%{_datadir}/gdal \
        --with-dods-root=/usr \
        %{?with_armadillo:--with-armadillo} \
@@ -339,7 +352,8 @@ sed -i -e 's#^mandir=.*##g' configure.in
        --with-hide-internal-symbols \
        %{?with_java:--with-java=%{java_home}} \
        --with-liblzma \
-       %{?with_java:--with-mdb --with-jvm-lib-add-rpath} \
+       %{!?with_kea:--without-kea} \
+       %{?with_java:--with-mdb --with-jvm-lib-add-rpath --with-jvm-lib=%{java_home}/jre/lib/$jvm_arch/server} \
        %{?with_mysql:--with-mysql} \
        %{?with_oci:--with-oci --with-oci-include=/usr/include/oracle/client --with-oci-lib=%{_libdir}} \
        %{?with_opencl:--with-opencl} \
@@ -383,7 +397,6 @@ rm -rf $RPM_BUILD_ROOT
 
 rm -rf _html
 cp -a html _html
-cp -a ogr/html _html/ogr
 
 %if %{with php}
 # missing in make install
@@ -471,7 +484,8 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/rgb2pct.py
 %attr(755,root,root) %{_bindir}/testepsg
 %attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libgdal.so.1
+%attr(755,root,root) %ghost %{_libdir}/libgdal.so.20
+%dir %{_libdir}/gdalplugins
 %{_datadir}/gdal
 %{_mandir}/man1/gdal2tiles.1*
 %{_mandir}/man1/gdal_calc.1*
@@ -515,16 +529,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/libgdal.so
 %{_libdir}/libgdal.la
 %{_pkgconfigdir}/gdal.pc
-%{_includedir}/cpl_*.h
-%{_includedir}/cplkeywordparser.h
-%{_includedir}/gdal*.h
-%{_includedir}/gvgcpfit.h
-%{_includedir}/memdataset.h
-%{_includedir}/ogr_*.h
-%{_includedir}/ogrsf_frmts.h
-%{_includedir}/rawdataset.h
-%{_includedir}/thinplatespline.h
-%{_includedir}/vrtdataset.h
+%{_includedir}/gdal
 %{_mandir}/man1/gdal-config.1*
 
 %files static
@@ -541,17 +546,14 @@ rm -rf $RPM_BUILD_ROOT
 %{perl_vendorarch}/Geo/OSR.pm
 %dir %{perl_vendorarch}/auto/Geo
 %dir %{perl_vendorarch}/auto/Geo/GDAL
-%{perl_vendorarch}/auto/Geo/GDAL/GDAL.bs
 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/GDAL.so
 %dir %{perl_vendorarch}/auto/Geo/GDAL/Const
-%{perl_vendorarch}/auto/Geo/GDAL/Const/Const.bs
 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.so
 %dir %{perl_vendorarch}/auto/Geo/OGR
-%{perl_vendorarch}/auto/Geo/OGR/OGR.bs
 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OGR/OGR.so
 %dir %{perl_vendorarch}/auto/Geo/OSR
-%{perl_vendorarch}/auto/Geo/OSR/OSR.bs
 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OSR/OSR.so
+%{_mandir}/man3/Geo::GDAL.3pm*
 
 %if %{with php}
 %files -n %{php_name}-gdal
This page took 0.031974 seconds and 4 git commands to generate.