]> git.pld-linux.org Git - packages/gdal.git/blobdiff - gdal.spec
- release 2 (by relup.sh)
[packages/gdal.git] / gdal.spec
index a9ae74d6fe3e52eefbfe706e695d1a208898c054..b26c736224a4b38ab81ffe4b74094773e06e42d1 100644 (file)
--- a/gdal.spec
+++ b/gdal.spec
@@ -2,13 +2,10 @@
 # - be reasonable about devel dependencies - you do not need all of them to
 #   use gdal (probably a gdal module or driver shall not imply devel
 #   dependency)
-# - rasdaman (--with-rasdaman; http://rasdaman.eecs.jacobs-university.de/trac/rasdaman/wiki/Download)
 # - libjpeg12 (needs patching to use system one, --with-jpeg12 is not sufficient as of 1.9.2)
 # - libkml (1.3.0 needed, not released yet)
 # - wait for newer pcidsk, switch to external again
 # - csharp, java
-# - DDS (--with-dds, BR [lib]crunch: http://code.google.com/p/crunch/)
-# - SOSI (--with-sosi, BR: libfyba libfygm libfyut: https://github.com/kartverket/fyba)
 # - additional, proprietary(?) formats support:
 #   - FMEObjects (http://www.safe.com/support/support-resources/fme-downloads/)
 #   - ESRI FileGDBAPI (http://resources.arcgis.com/content/geodatabases/10.0/file-gdb-api)
@@ -16,7 +13,6 @@
 #   - Kakadu/JPEG2000 (http://www.kakadusoftware.com/)
 #   - MrSID (http://www.lizardtech.com/developer/)
 #   - MSG/EUMETSAT (http://www.eumetsat.int/Home/Main/DataAccess/SupportSoftwareTools/index.htm)
-#   - Oracle/OCI >= 10.0.1 (for georaster); Oracle/OCI >= 8.1.7 (as DB)
 #   - Ingres (--with-ingres=/path)
 #   - Informix DB (--with-idb)
 #   - DWGdirect (members only? http://www.opendwg.org/)
 #
 # Conditional build:
 %bcond_without armadillo       # Armadillo support for faster TPS transform
+%bcond_without crnlib          # DDS support via crunch/crnlib
 %bcond_without epsilon         # EPSILON wavelet compression support
-%bcond_with    grass           # GRASS support (note: dependency loop)
+%bcond_without fyba            # SOSI geodata support using FYBA
+%bcond_with    grass           # GRASS support (note: dependency loop; use gdal-grass.spec instead)
 %bcond_without gta             # GTA format support
 %bcond_without mysql           # MySQL DB support
 %bcond_with    oci             # ORACLE OCI DB and Georaster support
 %bcond_without openjpeg        # OpenJPEG 2 (JPEG2000) support
 %bcond_with    podofo          # PDF support via podofo instead of poppler
 %bcond_without poppler         # PDF support via poppler
+%bcond_without rasdaman        # Rasdaman support
 %bcond_without spatialite      # SpatiaLite support
 %bcond_without xerces          # Xerces support
 %bcond_without java            # Java and MDB support
 %bcond_without php             # PHP binding
-%bcond_without ruby            # Ruby binding
+%bcond_with    ruby            # Ruby binding
 
 %if %{with podofo}
 %undefine      with_poppler
 %endif
+%if 0%{!?php_name:1}
 %define                php_name        php55
+%endif
 Summary:       Geospatial Data Abstraction Library
 Summary(pl.UTF-8):     Biblioteka abstrakcji danych dotyczÄ…cych powierzchni Ziemi
 Name:          gdal
-Version:       1.11.0
-Release:       3
+Version:       2.0.1
+Release:       2
 License:       BSD-like
 Group:         Libraries
 Source0:       http://download.osgeo.org/gdal/%{version}/%{name}-%{version}.tar.xz
-# Source0-md5: 31f2c4a7230b40e5fdc3cf12a100f96b
+# Source0-md5: 27022cc4a3e0819ab02a69c2d0867437
 Patch0:                %{name}-perl.patch
 Patch1:                %{name}-python_install.patch
 Patch2:                %{name}-php.patch
 Patch3:                %{name}-fpic.patch
-Patch4:                %{name}-format-security.patch
 Patch5:                %{name}-grass.patch
-Patch6:                %{name}-sse.patch
 Patch7:                %{name}-link.patch
+Patch8:                %{name}-fyba.patch
+Patch9:                %{name}-dds.patch
+Patch11:       %{name}-armadillo.patch
+Patch12:       %{name}-rasdaman.patch
+Patch13:       %{name}-pluginsdir.patch
 URL:           http://www.gdal.org/
 %{?with_php:BuildRequires:     %{php_name}-devel}
 %{?with_opencl:BuildRequires:  OpenCL-devel >= 1.0}
@@ -68,22 +72,24 @@ URL:                http://www.gdal.org/
 BuildRequires: autoconf >= 2.52
 BuildRequires: automake
 BuildRequires: cfitsio-devel
+%{?with_crnlib:BuildRequires:  crnlib-devel}
 BuildRequires: curl-devel
 BuildRequires: doxygen >= 1.4.2
 %{?with_epsilon:BuildRequires: epsilon-compressor-devel}
 BuildRequires: expat-devel >= 1.95.0
+%{?with_fyba:BuildRequires:    fyba-devel}
 BuildRequires: freexl-devel >= 1.0
 BuildRequires: gcc >= 6:4.1
 BuildRequires: geos-devel >= 3.1.0
 BuildRequires: giflib-devel >= 4.0
-%{?with_grass:BuildRequires:   grass-devel >= 5.7}
+%{?with_grass:BuildRequires:   grass-devel >= 6.4}
 BuildRequires: hdf-devel >= 4.0
 BuildRequires: hdf5-devel
 BuildRequires: jasper-devel
 %{?with_java:BuildRequires:    jdk}
 %{?with_java:BuildRequires:    jpackage-utils}
 BuildRequires: json-c-devel >= 0.11
-BuildRequires: libcsf-devel
+BuildRequires: libcsf-devel >= 2.0-0.041111.6
 BuildRequires: libdap-devel >= 3.10
 BuildRequires: libgeotiff-devel >= 1.2.1
 %{?with_gta:BuildRequires:     libgta-devel}
@@ -114,6 +120,7 @@ BuildRequires:      proj-devel >= 4
 BuildRequires: python-devel >= 1:2.5
 BuildRequires: python-numpy-devel >= 1:1.0.0
 BuildRequires: python-setuptools
+%{?with_rasdaman:BuildRequires:        rasdaman-devel}
 BuildRequires: rpm-pythonprov
 %{?with_ruby:BuildRequires:    rpm-rubyprov}
 BuildRequires: rpmbuild(macros) >= 1.344
@@ -161,8 +168,10 @@ Requires:  %{name} = %{version}-%{release}
 %{?with_opencl:Requires:       OpenCL-devel >= 1.0}
 %{?with_armadillo:Requires:    armadillo-devel}
 Requires:      cfitsio-devel
+%{?with_crnlib:Requires:       crnlib-devel}
 Requires:      curl-devel
 %{?with_epsilon:Requires:      epsilon-compressor-devel}
+%{?with_fyba:Requires: fyba-devel}
 Requires:      expat-devel >= 1.95.0
 Requires:      freexl-devel >= 1.0
 Requires:      geos-devel >= 3.1.0
@@ -192,6 +201,7 @@ Requires:   ogdi-devel >= 3.1
 %{?with_poppler:Requires:      poppler-devel >= 0.24}
 Requires:      postgresql-devel
 Requires:      proj-devel >= 4
+%{?with_rasdaman:Requires:     rasdaman-devel}
 Requires:      sqlite3-devel >= 3.0.0
 %{?with_odbc:Requires: unixODBC-devel}
 %{?with_xerces:Requires:       xerces-c-devel >= 2.7.0}
@@ -273,10 +283,13 @@ osr.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
-%patch4 -p1
 %patch5 -p1
-%patch6 -p1
 %patch7 -p1
+%patch8 -p1
+%patch9 -p1
+%patch11 -p1
+%patch12 -p1
+%patch13 -p1
 
 # need to regenerate (old ones don't support perl 5.10 or php 5.5)
 %{__rm} swig/{perl,php}/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
@@ -306,21 +319,33 @@ sed -i -e 's#^mandir=.*##g' configure.in
 %{__sed} -i -e 's,DODS_INC="-I.*,DODS_INC="$(pkg-config --cflags libdap)",' configure.in
 
 %build
+%ifarch %{x8664}
+jvm_arch=amd64
+%endif
+%ifarch %{ix86}
+jvm_arch=i386
+%endif
+%ifarch x32
+jvm_arch=x32
+%endif
+
 %{__libtoolize}
 %{__aclocal} -I m4
 %{__autoconf}
-# disable grass/libgrass here, it can be built from separate gdal-grass package
+%{__autoheader}
 %configure \
+       --includedir=%{_includedir}/gdal \
        --datadir=%{_datadir}/gdal \
        --with-dods-root=/usr \
        %{?with_armadillo:--with-armadillo} \
+       %{?with_crnlib:--with-dds} \
        %{?with_epsilon:--with-epsilon} \
        %{?with_grass:--with-grass} \
        %{!?with_gta:--without-gta} \
        --with-hide-internal-symbols \
        %{?with_java:--with-java=%{java_home}} \
        --with-liblzma \
-       %{?with_java:--with-mdb --with-jvm-lib-add-rpath} \
+       %{?with_java:--with-mdb --with-jvm-lib-add-rpath --with-jvm-lib=%{java_home}/jre/lib/$jvm_arch/server} \
        %{?with_mysql:--with-mysql} \
        %{?with_oci:--with-oci --with-oci-include=/usr/include/oracle/client --with-oci-lib=%{_libdir}} \
        %{?with_opencl:--with-opencl} \
@@ -329,17 +354,19 @@ sed -i -e 's#^mandir=.*##g' configure.in
        %{?with_podofo:--with-podofo} \
        %{?with_poppler:--with-poppler} \
        --with-python \
+       %{?with_rasdaman:--with-rasdaman=%{_libdir}/rasdaman} \
        %{?with_ruby:--with-ruby} \
+       %{?with_fyba:--with-sosi} \
        %{?with_spatialite:--with-spatialite} \
        --with-sqlite3 \
        --with-webp \
        %{?with_xerces:--with-xerces} \
        --with-xerces-inc=/usr/include/xercesc \
        --with-xerces-lib="-lxerces-c" \
+       --with-autoload=%{_libdir}/gdalplugins \
        --without-libgrass
-#      --with-rasdaman
 #      --with-pcidsk=/usr (needs > 0.3)
-# csharp builds, but has no configure option
+# csharp builds, but has no configure option nor install target
 
 # regenerate where needed
 %{__make} -j1 -C swig/perl generate
@@ -347,7 +374,9 @@ sed -i -e 's#^mandir=.*##g' configure.in
 %{__make} -j1 -C swig/ruby generate
 %endif
 
-%{__make} -j1
+%{__make} -j1 \
+       %{?with_grass:GRASS_INCLUDE="-I/usr/include/grass64"} \
+       %{?with_fyba:SOSI_INC="-I/usr/include/fyba"}
 
 %{__make} -j1 docs
 
@@ -361,7 +390,6 @@ rm -rf $RPM_BUILD_ROOT
 
 rm -rf _html
 cp -a html _html
-cp -a ogr/html _html/ogr
 
 %if %{with php}
 # missing in make install
@@ -449,7 +477,8 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/rgb2pct.py
 %attr(755,root,root) %{_bindir}/testepsg
 %attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libgdal.so.1
+%attr(755,root,root) %ghost %{_libdir}/libgdal.so.20
+%dir %{_libdir}/gdalplugins
 %{_datadir}/gdal
 %{_mandir}/man1/gdal2tiles.1*
 %{_mandir}/man1/gdal_calc.1*
@@ -493,16 +522,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/libgdal.so
 %{_libdir}/libgdal.la
 %{_pkgconfigdir}/gdal.pc
-%{_includedir}/cpl_*.h
-%{_includedir}/cplkeywordparser.h
-%{_includedir}/gdal*.h
-%{_includedir}/gvgcpfit.h
-%{_includedir}/memdataset.h
-%{_includedir}/ogr_*.h
-%{_includedir}/ogrsf_frmts.h
-%{_includedir}/rawdataset.h
-%{_includedir}/thinplatespline.h
-%{_includedir}/vrtdataset.h
+%{_includedir}/gdal
 %{_mandir}/man1/gdal-config.1*
 
 %files static
@@ -519,17 +539,14 @@ rm -rf $RPM_BUILD_ROOT
 %{perl_vendorarch}/Geo/OSR.pm
 %dir %{perl_vendorarch}/auto/Geo
 %dir %{perl_vendorarch}/auto/Geo/GDAL
-%{perl_vendorarch}/auto/Geo/GDAL/GDAL.bs
 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/GDAL.so
 %dir %{perl_vendorarch}/auto/Geo/GDAL/Const
-%{perl_vendorarch}/auto/Geo/GDAL/Const/Const.bs
 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.so
 %dir %{perl_vendorarch}/auto/Geo/OGR
-%{perl_vendorarch}/auto/Geo/OGR/OGR.bs
 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OGR/OGR.so
 %dir %{perl_vendorarch}/auto/Geo/OSR
-%{perl_vendorarch}/auto/Geo/OSR/OSR.bs
 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OSR/OSR.so
+%{_mandir}/man3/Geo::GDAL.3pm*
 
 %if %{with php}
 %files -n %{php_name}-gdal
This page took 0.042538 seconds and 4 git commands to generate.