]> git.pld-linux.org Git - packages/gdal.git/blobdiff - gdal.spec
- release 2 (by relup.sh)
[packages/gdal.git] / gdal.spec
index 6d577be4b1bc2126f4675c532f93ea59b502265f..40449f9874ec08488ad065b435392b3a81ebc53b 100644 (file)
--- a/gdal.spec
+++ b/gdal.spec
-# TODO: csharp, java, mysql
+# TODO:
+# - be reasonable about devel dependencies - you do not need all of them to
+#   use gdal (probably a gdal module or driver shall not imply devel
+#   dependency)
+# - spatialite (--with-spatialite; libspatialite: http://www.gaia-gis.it/gaia-sins/)
+# - freexl (http://www.gaia-gis.it/FreeXL/)
+# - rasdaman (--with-rasdaman; http://rasdaman.eecs.jacobs-university.de/trac/rasdaman/wiki/Download)
+# - armadillo (--with-armadillo; http://arma.sourceforge.net/)
+# - openjpeg (unreleased post-1.5 or 2? needs opj_decode_tile_data symbol, not available in 1.3-1.5)
+# - libjpeg12 (needs patching to use system one)
+# - libkml (1.3.0 needed, not released yet)
+# - wait for newer pcidsk, switch to external again
+# - csharp, java, mysql
+# - additional, proprietary(?) formats support:
+#   - FMEObjects (http://www.safe.com/support/support-resources/fme-downloads/)
+#   - ESRI FileGDBAPI (http://resources.arcgis.com/content/geodatabases/10.0/file-gdb-api)
+#   - ECW (http://www.erdas.com/products/ecw/ERDASECWJPEG2000SDK/Details.aspx)
+#   - Kakadu/JPEG2000 (http://www.kakadusoftware.com/)
+#   - MrSID (http://www.lizardtech.com/developer/)
+#   - MSG/EUMETSAT (http://www.eumetsat.int/Home/Main/DataAccess/SupportSoftwareTools/index.htm)
+#   - Oracle/OCI >= 10.0.1 (for georaster); Oracle/OCI >= 8.1.7 (as DB)
+#   - Ingres (--with-ingres=/path)
+#   - Informix DB
+#   - DWGdirect (members only? http://www.opendwg.org/)
+#   - ESRI SDE (http://www.esri.com/software/arcgis/arcsde/index.html)
+#   - OpenCL (--with-opencl; no free Linux implementation yet?)
 #
 # Conditional build:
-%bcond_without odbc    # disable odbc support
+%bcond_without epsilon # EPSILON wavelet compression support
+%bcond_without gta     # GTA format support
+%bcond_without odbc    # disable ODBC DB support
+%bcond_with    podofo  # PDF support via podofo instead of poppler
+%bcond_without poppler # PDF support via poppler
 %bcond_without xerces  # disable xerces support
-%bcond_without ruby    # disable ruby support
+%bcond_without java    # disable Java and MDB support
+%bcond_without php     # disable PHP binding
+%bcond_without ruby    # disable ruby binding
 #
+%if %{with podofo}
+%undefine      with_poppler
+%endif
 Summary:       Geospatial Data Abstraction Library
 Summary(pl.UTF-8):     Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
 Name:          gdal
-Version:       1.7.3
-Release:       5
+Version:       1.9.1
+Release:       2
 License:       BSD-like
 Group:         Libraries
 Source0:       ftp://ftp.remotesensing.org/gdal/%{name}-%{version}.tar.gz
-# Source0-md5: c4673970bd2285032de9ae9bbd82754a
+# Source0-md5: c5cf09b92dac1f5775db056e165b34f5
 Patch0:                %{name}-perl.patch
-Patch1:                %{name}-ruby.patch
-Patch2:                %{name}-asneeded.patch
-Patch3:                %{name}-python_install.patch
-Patch4:                %{name}-libdap.patch
-Patch5:                %{name}-doxy.patch
+Patch1:                %{name}-python_install.patch
+Patch2:                gdal-1.9.1-poppler020.patch
+
+Patch4:                %{name}-php.patch
+Patch5:                %{name}-fpic.patch
 URL:           http://www.gdal.org/
 BuildRequires: autoconf >= 2.52
 BuildRequires: automake
 BuildRequires: cfitsio-devel
+BuildRequires: curl-devel
 BuildRequires: doxygen >= 1.4.2
+%{?with_epsilon:BuildRequires: epsilon-compressor-devel}
 BuildRequires: expat-devel >= 1.95.0
-BuildRequires: geos-devel >= 2.2
+BuildRequires: geos-devel >= 2.2.0
 BuildRequires: giflib-devel >= 4.0
 BuildRequires: hdf-devel >= 4.0
 BuildRequires: hdf5-devel
 BuildRequires: jasper-devel
+%{?with_java:BuildRequires:    jdk}
+%{?with_java:BuildRequires:    jpackage-utils}
 BuildRequires: libcsf-devel
 BuildRequires: libdap-devel >= 3.10
 BuildRequires: libgeotiff-devel >= 1.2.1
+%{?with_gta:BuildRequires:     libgta-devel}
 BuildRequires: libjpeg-devel >= 6b
+#BuildRequires:        libkml-devel >= 1.3.0
 BuildRequires: libpng-devel >= 2:1.2.8
 BuildRequires: libstdc++-devel
-BuildRequires: libtiff-devel >= 3.6.0
+BuildRequires: libtiff-devel >= 4.0
 BuildRequires: libtool
 BuildRequires: libuuid-devel
+BuildRequires: libwebp-devel
 BuildRequires: libxml2-devel
-BuildRequires: netcdf-devel
+BuildRequires: netcdf-devel >= 4
 BuildRequires: ogdi-devel >= 3.1
-BuildRequires: pcidsk-devel
+#BuildRequires:        pcidsk-devel > 0.3
 BuildRequires: perl-devel
-BuildRequires: postgresql-backend-devel
-BuildRequires: postgresql-devel
-BuildRequires: proj-devel
+%{?with_php:BuildRequires:     php-devel}
+%{?with_podofo:BuildRequires:  podofo-devel}
+%{?with_poppler:BuildRequires: poppler-devel}
+# ensure it's compiled with PQescapeStringConn support
+BuildRequires: postgresql-backend-devel >= 8.1.4
+BuildRequires: postgresql-devel >= 8.1.4
+BuildRequires: proj-devel >= 4
 BuildRequires: python-devel >= 1:2.5
 BuildRequires: python-numpy-devel >= 1:1.0.0
+BuildRequires: python-setuptools
 BuildRequires: rpm-pythonprov
+BuildRequires: rpmbuild(macros) >= 1.344
 %{?with_ruby:BuildRequires:    ruby-devel}
-BuildRequires: sqlite3-devel >= 3
+BuildRequires: sed >= 4.0
+BuildRequires: sqlite3-devel >= 3.0.0
 BuildRequires: swig-perl
 BuildRequires: swig-python >= 1.3
 %{?with_ruby:BuildRequires:    swig-ruby}
@@ -63,13 +111,14 @@ BuildRequires:     tetex-dvips
 BuildRequires: texlive-dvips
 BuildRequires: texlive-latex
 %endif
-%{?with_odbc:BuildRequires:    unixODBC-devel}
-%{?with_xerces:BuildRequires:  xerces-c-devel >= 2.2.0}
+%{?with_odbc:BuildRequires:    unixODBC-devel >= 2.2.15}
+%{?with_xerces:BuildRequires:  xerces-c-devel >= 2.7.0}
+BuildRequires: xz-devel
 BuildRequires: zlib-devel >= 1.1.4
-Requires:      geos >= 2.2
+Requires:      geos >= 2.2.0
 Requires:      libgeotiff >= 1.2.1
 Requires:      libpng >= 2:1.2.8
-Requires:      libtiff >= 3.6.0
+Requires:      libtiff >= 4.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -94,26 +143,37 @@ Summary(pl.UTF-8): Pliki nagłówkowe biblioteki GDAL
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 Requires:      cfitsio-devel
+Requires:      curl-devel
+%{?with_epsilon:Requires:      epsilon-compressor-devel}
 Requires:      expat-devel >= 1.95.0
-Requires:      geos-devel >= 2.2
-Requires:      giflib-devel
+Requires:      geos-devel >= 2.2.0
+Requires:      giflib-devel >= 4.0
 Requires:      hdf-devel >= 4.0
 Requires:      hdf5-devel
 Requires:      jasper-devel
 Requires:      libcsf-devel
 Requires:      libdap-devel >= 3.10
 Requires:      libgeotiff-devel >= 1.2.1
-Requires:      libjpeg-devel
+%{?with_gta:Requires:  libgta-devel}
+Requires:      libjpeg-devel >= 6b
 Requires:      libpng-devel >= 2:1.2.8
 Requires:      libstdc++-devel
-Requires:      libtiff-devel >= 3.6.0
-Requires:      netcdf-devel
+Requires:      libtiff-devel >= 4.0
+Requires:      libuuid-devel
+Requires:      libwebp-devel
+Requires:      libxml2-devel
+Requires:      netcdf-devel >= 4
 Requires:      ogdi-devel >= 3.1
-Requires:      pcidsk-devel
+#Requires:     pcidsk-devel > 0.3
+%{?with_podofo:Requires:       podofo-devel}
+%{?with_poppler:Requires:      poppler-devel}
 Requires:      postgresql-devel
-Requires:      sqlite3-devel >= 3
+Requires:      proj-devel >= 4
+Requires:      sqlite3-devel >= 3.0.0
 %{?with_odbc:Requires: unixODBC-devel}
 %{?with_xerces:Requires:       xerces-c-devel >= 2.7.0}
+Requires:      xz-devel
+Requires:      zlib-devel >= 1.1.4
 
 %description devel
 GDAL library header files.
@@ -145,6 +205,19 @@ Perl bindings for GDAL - Geo::GDAL, Geo::OGR and Geo::OSR modules.
 %description -n perl-gdal -l pl.UTF-8
 Wiązania Perla do pakietu GDAL - moduły Geo::GDAL, Geo::OGR, Geo::OSR.
 
+%package -n php-gdal
+Summary:       PHP bindings for GDAL library
+Summary(pl.UTF-8):     Wiązania PHP do biblioteki GDAL
+Group:         Development/Languages/PHP
+Requires:      %{name} = %{version}-%{release}
+%{?requires_php_extension}
+
+%description -n php-gdal
+PHP bindings for GDAL library
+
+%description -n php-gdal -l pl.UTF-8
+Wiązania PHP do biblioteki GDAL.
+
 %package -n python-gdal
 Summary:       GDAL Python module
 Summary(pl.UTF-8):     Moduł Pythona GDAL
@@ -176,23 +249,19 @@ osr.
 %setup -q
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
-%patch3 -p1
+%patch2 -p4
+
 %patch4 -p1
 %patch5 -p1
 
 # need to regenerate (old ones don't support perl 5.10)
 %{__rm} swig/perl/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
-# includes updated for Ruby 1.9
-%{__rm} swig/ruby/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
 
 %{__rm} -r man
 
-%build
-# $PYTHON_INCLUDES is set only with --with-ogpython, but we have --with-python,
-# and $PYTHON_INCLUDES is needed to detect numpy properly
-export PYTHON_INCLUDES=-I%{py_incdir}
+%{__sed} -i -e 's,DODS_INC="-I.*,DODS_INC="$(pkg-config --cflags libdap)",' configure.in
 
+%build
 %{__libtoolize}
 %{__aclocal} -I m4
 %{__autoconf}
@@ -200,19 +269,26 @@ export PYTHON_INCLUDES=-I%{py_incdir}
 %configure \
        --datadir=%{_datadir}/gdal \
        --with-dods-root=/usr \
+       %{?with_epsilon:--with-epsilon} \
+       %{!?with_gta:--without-gta} \
        --with-hide-internal-symbols \
-       --with-pcidsk=/usr \
+       %{?with_java:--with-java=%{java_home}} \
+       --with-liblzma \
+       %{?with_java:--with-mdb --with-jvm-lib-add-rpath} \
        --with-perl \
+       %{?with_php:--with-php} \
+       %{?with_podofo:--with-podofo} \
+       %{?with_poppler:--with-poppler} \
        --with-python \
        %{?with_ruby:--with-ruby} \
        --with-sqlite3 \
+       --with-webp \
        %{?with_xerces:--with-xerces} \
        --with-xerces-inc=/usr/include/xercesc \
        --with-xerces-lib="-lxerces-c" \
        --without-grass \
        --without-libgrass
-# --with-php needs Zend API update
-# java broken, no configure option
+#      --with-pcidsk=/usr (needs > 0.3)
 # csharp builds, but has no configure option
 
 # regenerate where needed
@@ -235,6 +311,22 @@ rm -rf _html
 cp -a html _html
 cp -a ogr/html _html/ogr
 
+%if %{with php}
+# missing in make install
+install -D swig/php/php_gdal.so $RPM_BUILD_ROOT%{php_extensiondir}/gdal.so
+install -D swig/php/php_gdalconst.so $RPM_BUILD_ROOT%{php_extensiondir}/gdalconst.so
+install -D swig/php/php_ogr.so $RPM_BUILD_ROOT%{php_extensiondir}/ogr.so
+install -D swig/php/php_osr.so $RPM_BUILD_ROOT%{php_extensiondir}/osr.so
+install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
+cat <<'EOF' >$RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/gdal.ini
+; Enable gdal extension module
+extension=gdal.so
+extension=gdalconst.so
+extension=ogr.so
+extension=osr.so
+EOF
+%endif
+
 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
 %py_postclean
@@ -246,14 +338,9 @@ cp -a ogr/html _html/ogr
 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OSR/.packlist
 
 # some doxygen trash
-%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Geo/GDAL.dox
-%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Geo/GDAL/Const.dox
-%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Geo/OGR.dox
-%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Geo/OSR.dox
-
-%if %{with ruby}
-%{__rm} $RPM_BUILD_ROOT%{ruby_sitearchdir}/gdal/*.la
-%endif
+%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Geo/{GDAL.dox,GDAL/Const.dox,OGR.dox,OSR.dox}
+%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Geo/check_dox.pl
+%{__rm} $RPM_BUILD_ROOT%{_bindir}/gdal_{fillnodata,sieve}.dox
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -271,6 +358,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/gdal2tiles.py
 %attr(755,root,root) %{_bindir}/gdal2xyz.py
 %attr(755,root,root) %{_bindir}/gdal_contour
+%attr(755,root,root) %{_bindir}/gdal_calc.py
 %attr(755,root,root) %{_bindir}/gdal_fillnodata.py
 %attr(755,root,root) %{_bindir}/gdal_grid
 %attr(755,root,root) %{_bindir}/gdal_merge.py
@@ -288,7 +376,9 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/gdalident.py
 %attr(755,root,root) %{_bindir}/gdalimport.py
 %attr(755,root,root) %{_bindir}/gdalinfo
+%attr(755,root,root) %{_bindir}/gdallocationinfo
 %attr(755,root,root) %{_bindir}/gdalmanage
+%attr(755,root,root) %{_bindir}/gdalsrsinfo
 %attr(755,root,root) %{_bindir}/gdaltindex
 %attr(755,root,root) %{_bindir}/gdaltransform
 %attr(755,root,root) %{_bindir}/gdalwarp
@@ -317,6 +407,8 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/gdalbuildvrt.1*
 %{_mandir}/man1/gdaldem.1*
 %{_mandir}/man1/gdalinfo.1*
+%{_mandir}/man1/gdallocationinfo.1*
+%{_mandir}/man1/gdalsrsinfo.1*
 %{_mandir}/man1/gdaltindex.1*
 %{_mandir}/man1/gdaltransform.1*
 %{_mandir}/man1/gdalwarp.1*
@@ -372,6 +464,16 @@ rm -rf $RPM_BUILD_ROOT
 %{perl_vendorarch}/auto/Geo/OSR/OSR.bs
 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OSR/OSR.so
 
+%if %{with php}
+%files -n php-gdal
+%defattr(644,root,root,755)
+%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/gdal.ini
+%attr(755,root,root) %{php_extensiondir}/gdal.so
+%attr(755,root,root) %{php_extensiondir}/gdalconst.so
+%attr(755,root,root) %{php_extensiondir}/ogr.so
+%attr(755,root,root) %{php_extensiondir}/osr.so
+%endif
+
 %files -n python-gdal
 %defattr(644,root,root,755)
 %{py_sitedir}/gdal.py[co]
This page took 0.03709 seconds and 4 git commands to generate.