]> git.pld-linux.org Git - packages/gdal.git/blobdiff - gdal.spec
- release 2 (by relup.sh)
[packages/gdal.git] / gdal.spec
index 6711898227c229948c0955cb113e78f767256384..40449f9874ec08488ad065b435392b3a81ebc53b 100644 (file)
--- a/gdal.spec
+++ b/gdal.spec
@@ -1,12 +1,12 @@
 # TODO:
-# - podofo (--with-podofo)
-# - epsilon (--with-epsilon; BR: epsilon-devel from Enlightenment)
-# - libgta (http://gta.nongnu.org/libgta.html)
+# - be reasonable about devel dependencies - you do not need all of them to
+#   use gdal (probably a gdal module or driver shall not imply devel
+#   dependency)
 # - spatialite (--with-spatialite; libspatialite: http://www.gaia-gis.it/gaia-sins/)
 # - freexl (http://www.gaia-gis.it/FreeXL/)
 # - rasdaman (--with-rasdaman; http://rasdaman.eecs.jacobs-university.de/trac/rasdaman/wiki/Download)
 # - armadillo (--with-armadillo; http://arma.sourceforge.net/)
-# - openjpeg (? 1.4? needs opj_decode_tile_data symbol)
+# - openjpeg (unreleased post-1.5 or 2? needs opj_decode_tile_data symbol, not available in 1.3-1.5)
 # - libjpeg12 (needs patching to use system one)
 # - libkml (1.3.0 needed, not released yet)
 # - wait for newer pcidsk, switch to external again
 #   - OpenCL (--with-opencl; no free Linux implementation yet?)
 #
 # Conditional build:
-%bcond_without odbc    # disable odbc support
+%bcond_without epsilon # EPSILON wavelet compression support
+%bcond_without gta     # GTA format support
+%bcond_without odbc    # disable ODBC DB support
+%bcond_with    podofo  # PDF support via podofo instead of poppler
+%bcond_without poppler # PDF support via poppler
 %bcond_without xerces  # disable xerces support
 %bcond_without java    # disable Java and MDB support
-%bcond_without php     # disable PHP bindind
+%bcond_without php     # disable PHP binding
 %bcond_without ruby    # disable ruby binding
 #
+%if %{with podofo}
+%undefine      with_poppler
+%endif
 Summary:       Geospatial Data Abstraction Library
 Summary(pl.UTF-8):     Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
 Name:          gdal
-Version:       1.9.0
-Release:       1
+Version:       1.9.1
+Release:       2
 License:       BSD-like
 Group:         Libraries
 Source0:       ftp://ftp.remotesensing.org/gdal/%{name}-%{version}.tar.gz
-# Source0-md5: 1853f3d8eb5232ae030abe007840cade
+# Source0-md5: c5cf09b92dac1f5775db056e165b34f5
 Patch0:                %{name}-perl.patch
 Patch1:                %{name}-python_install.patch
-Patch2:                %{name}-doxy.patch
-Patch3:                %{name}-sh.patch
+Patch2:                gdal-1.9.1-poppler020.patch
+
 Patch4:                %{name}-php.patch
+Patch5:                %{name}-fpic.patch
 URL:           http://www.gdal.org/
 BuildRequires: autoconf >= 2.52
 BuildRequires: automake
 BuildRequires: cfitsio-devel
 BuildRequires: curl-devel
 BuildRequires: doxygen >= 1.4.2
+%{?with_epsilon:BuildRequires: epsilon-compressor-devel}
 BuildRequires: expat-devel >= 1.95.0
 BuildRequires: geos-devel >= 2.2.0
 BuildRequires: giflib-devel >= 4.0
@@ -63,6 +72,7 @@ BuildRequires:        jasper-devel
 BuildRequires: libcsf-devel
 BuildRequires: libdap-devel >= 3.10
 BuildRequires: libgeotiff-devel >= 1.2.1
+%{?with_gta:BuildRequires:     libgta-devel}
 BuildRequires: libjpeg-devel >= 6b
 #BuildRequires:        libkml-devel >= 1.3.0
 BuildRequires: libpng-devel >= 2:1.2.8
@@ -77,7 +87,8 @@ BuildRequires:        ogdi-devel >= 3.1
 #BuildRequires:        pcidsk-devel > 0.3
 BuildRequires: perl-devel
 %{?with_php:BuildRequires:     php-devel}
-BuildRequires: poppler-devel
+%{?with_podofo:BuildRequires:  podofo-devel}
+%{?with_poppler:BuildRequires: poppler-devel}
 # ensure it's compiled with PQescapeStringConn support
 BuildRequires: postgresql-backend-devel >= 8.1.4
 BuildRequires: postgresql-devel >= 8.1.4
@@ -88,6 +99,7 @@ BuildRequires:        python-setuptools
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.344
 %{?with_ruby:BuildRequires:    ruby-devel}
+BuildRequires: sed >= 4.0
 BuildRequires: sqlite3-devel >= 3.0.0
 BuildRequires: swig-perl
 BuildRequires: swig-python >= 1.3
@@ -131,26 +143,37 @@ Summary(pl.UTF-8):        Pliki nagłówkowe biblioteki GDAL
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 Requires:      cfitsio-devel
+Requires:      curl-devel
+%{?with_epsilon:Requires:      epsilon-compressor-devel}
 Requires:      expat-devel >= 1.95.0
 Requires:      geos-devel >= 2.2.0
-Requires:      giflib-devel
+Requires:      giflib-devel >= 4.0
 Requires:      hdf-devel >= 4.0
 Requires:      hdf5-devel
 Requires:      jasper-devel
 Requires:      libcsf-devel
 Requires:      libdap-devel >= 3.10
 Requires:      libgeotiff-devel >= 1.2.1
-Requires:      libjpeg-devel
+%{?with_gta:Requires:  libgta-devel}
+Requires:      libjpeg-devel >= 6b
 Requires:      libpng-devel >= 2:1.2.8
 Requires:      libstdc++-devel
 Requires:      libtiff-devel >= 4.0
+Requires:      libuuid-devel
+Requires:      libwebp-devel
+Requires:      libxml2-devel
 Requires:      netcdf-devel >= 4
 Requires:      ogdi-devel >= 3.1
 #Requires:     pcidsk-devel > 0.3
+%{?with_podofo:Requires:       podofo-devel}
+%{?with_poppler:Requires:      poppler-devel}
 Requires:      postgresql-devel
+Requires:      proj-devel >= 4
 Requires:      sqlite3-devel >= 3.0.0
 %{?with_odbc:Requires: unixODBC-devel}
 %{?with_xerces:Requires:       xerces-c-devel >= 2.7.0}
+Requires:      xz-devel
+Requires:      zlib-devel >= 1.1.4
 
 %description devel
 GDAL library header files.
@@ -226,15 +249,18 @@ osr.
 %setup -q
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
-%patch3 -p1
+%patch2 -p4
+
 %patch4 -p1
+%patch5 -p1
 
 # need to regenerate (old ones don't support perl 5.10)
 %{__rm} swig/perl/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
 
 %{__rm} -r man
 
+%{__sed} -i -e 's,DODS_INC="-I.*,DODS_INC="$(pkg-config --cflags libdap)",' configure.in
+
 %build
 %{__libtoolize}
 %{__aclocal} -I m4
@@ -243,13 +269,16 @@ osr.
 %configure \
        --datadir=%{_datadir}/gdal \
        --with-dods-root=/usr \
+       %{?with_epsilon:--with-epsilon} \
+       %{!?with_gta:--without-gta} \
        --with-hide-internal-symbols \
        %{?with_java:--with-java=%{java_home}} \
        --with-liblzma \
-       %{?with_java:--with-mdb} \
+       %{?with_java:--with-mdb --with-jvm-lib-add-rpath} \
        --with-perl \
        %{?with_php:--with-php} \
-       --with-poppler \
+       %{?with_podofo:--with-podofo} \
+       %{?with_poppler:--with-poppler} \
        --with-python \
        %{?with_ruby:--with-ruby} \
        --with-sqlite3 \
This page took 0.088242 seconds and 4 git commands to generate.