]> git.pld-linux.org Git - packages/gdal.git/blobdiff - gdal.spec
- updated for 1.2.6
[packages/gdal.git] / gdal.spec
index 86ef4dd43ec8f05ae8dcacb9aa8583d50550f7ea..2493d82f08880cdb5df45542af0750065c16b3f9 100644 (file)
--- a/gdal.spec
+++ b/gdal.spec
@@ -2,38 +2,42 @@
 # TODO:
 # - consider using GRASS (or GDAL in GRASS? build trap possible)
 #
-%include       /usr/lib/rpm/macros.python
 Summary:       Geospatial Data Abstraction Library
 Summary(pl):   Biblioteka abstrakcji danych dotycz±cych powierzchni Ziemi
 Name:          gdal
-Version:       1.1.9
-Release:       1
+Version:       1.2.5
+Release:       2
 License:       BSD-like
 Group:         Libraries
 Source0:       ftp://ftp.remotesensing.org/pub/gdal/%{name}-%{version}.tar.gz
-# Source0-md5: 2183e206affc7bf25e0d33459ccb8572
+# Source0-md5: 2e3e651be6b4f42486e99ef39c17ffb1
 Patch0:                %{name}-pgsql.patch
 Patch1:                %{name}-DESTDIR.patch
-Patch2:                %{name}-soname.patch
-Patch3:                %{name}-xerces.patch
+Patch2:                %{name}-sh.patch
 URL:           http://www.remotesensing.org/gdal/
 BuildRequires: autoconf
 BuildRequires: cfitsio-devel
 BuildRequires: doxygen
+BuildRequires: geos-devel >= 2.0
 BuildRequires: hdf-devel >= 4.0
 BuildRequires: jasper-devel
-BuildRequires: libgeotiff-devel
+BuildRequires: libgeotiff-devel >= 1.2.1
 BuildRequires: libjpeg-devel >= 6b
 BuildRequires: libpng-devel >= 1.0.6
+BuildRequires: libstdc++-devel
 BuildRequires: libtiff-devel >= 3.6.0
 BuildRequires: libungif-devel >= 4.0
+BuildRequires: netcdf-devel
 BuildRequires: ogdi-devel >= 3.1
 BuildRequires: postgresql-devel
 BuildRequires: postgresql-backend-devel
 BuildRequires: python-devel
-BuildRequires: rpm-pythonprov
+BuildRequires: unixODBC-devel
 BuildRequires: xerces-c-devel >= 2.2.0
 BuildRequires: zlib-devel >= 1.1.4
+Requires:      geos >= 2.0
+Requires:      libgeotiff >= 1.2.1
+Requires:      libtiff >= 3.6.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -43,12 +47,12 @@ single abstract data model to the calling application for all
 supported formats. The related OGR library (which lives within the
 GDAL source tree) provides a similar capability for simple features
 vector data.
-           
+
 %description -l pl
 GDAL to biblioteka konwertuj±ca miêdzy formatami rastrowych danych
 dotycz±cych powierzchni Ziemi, udostêpniona na licencji Open Source.
 Jako biblioteka udostêpnia aplikacjom jeden abstrakcyjny model danych
-do wszystkich obs³ugiwanych formatów. Powi±zana z nia biblioteka OGR
+do wszystkich obs³ugiwanych formatów. Powi±zana z ni± biblioteka OGR
 (której ¼ród³a s± do³±czone do drzewa ¼róde³ GDAL) daje podobne
 mo¿liwo¶ci dla danych wektorowych.
 
@@ -56,7 +60,22 @@ mo
 Summary:       GDAL library header files
 Summary(pl):   Pliki nag³ówkowe biblioteki GDAL
 Group:         Development/Libraries
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{version}-%{release}
+Requires:      cfitsio-devel
+Requires:      geos-devel >= 2.0
+Requires:      hdf-devel >= 4.0
+Requires:      jasper-devel
+Requires:      libgeotiff-devel >= 1.2.1
+Requires:      libjpeg-devel
+Requires:      libpng-devel >= 1.0.6
+Requires:      libstdc++-devel
+Requires:      libtiff-devel >= 3.6.0
+Requires:      libungif-devel
+Requires:      netcdf-devel
+Requires:      ogdi-devel >= 3.1
+Requires:      postgresql-devel
+Requires:      unixODBC-devel
+Requires:      xerces-c-devel >= 2.2.0
 
 %description devel
 GDAL library header files.
@@ -68,7 +87,7 @@ Pliki nag
 Summary:       GDAL static libraries
 Summary(pl):   Statyczne biblioteki GDAL
 Group:         Development/Libraries
-Requires:      %{name}-devel = %{version}
+Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
 GDAL static libraries.
@@ -80,7 +99,8 @@ Statyczne biblioteki GDAL.
 Summary:       GDAL Python module
 Summary(pl):   Modu³ Pythona GDAL
 Group:         Libraries/Python
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{version}-%{release}
+%pyrequires_eq python-libs
 
 %description -n python-gdal
 GDAL Python module.
@@ -93,11 +113,14 @@ Modu
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
-%patch3 -p1
+
+%{__perl} -pi -e "s@lib/python@%{_lib}/python@" aclocal.m4
 
 %build
 %{__autoconf}
 %configure \
+       --datadir=%{_datadir}/gdal \
+       --with-pymoddir=%{py_sitedir} \
        --with-xerces \
        --with-xerces-inc=/usr/include/xercesc \
        --with-xerces-lib="-lxerces-c" \
@@ -115,6 +138,8 @@ rm -rf $RPM_BUILD_ROOT
 
 mv -f ogr/html html/org
 
+rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{la,a}
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -125,14 +150,20 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc ChangeLog NEWS
 %attr(755,root,root) %{_bindir}/*
-%attr(755,root,root) %{_libdir}/libgdal.*.so
+%exclude %{_bindir}/gdal-config
+%attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
 %{_datadir}/gdal
+%{_mandir}/man1/*
+%exclude %{_mandir}/man1/gdal-config.1*
 
 %files devel
 %defattr(644,root,root,755)
 %doc html/*
+%attr(755,root,root) %{_bindir}/gdal-config
 %attr(755,root,root) %{_libdir}/libgdal.so
+%{_libdir}/libgdal.la
 %{_includedir}/*.h
+%{_mandir}/man1/gdal-config.1*
 
 %files static
 %defattr(644,root,root,755)
This page took 0.063254 seconds and 4 git commands to generate.