]> git.pld-linux.org Git - packages/gdal.git/blob - gdal.spec
- rel 1; builds
[packages/gdal.git] / gdal.spec
1 # TODO:
2 # - be reasonable about devel dependencies - you do not need all of them to
3 #   use gdal (probably a gdal module or driver shall not imply devel
4 #   dependency)
5 # - rasdaman (--with-rasdaman; http://rasdaman.eecs.jacobs-university.de/trac/rasdaman/wiki/Download)
6 # - libjpeg12 (needs patching to use system one, --with-jpeg12 is not sufficient as of 1.9.2)
7 # - libkml (1.3.0 needed, not released yet)
8 # - wait for newer pcidsk, switch to external again
9 # - csharp, java
10 # - additional, proprietary(?) formats support:
11 #   - FMEObjects (http://www.safe.com/support/support-resources/fme-downloads/)
12 #   - ESRI FileGDBAPI (http://resources.arcgis.com/content/geodatabases/10.0/file-gdb-api)
13 #   - ECW (http://www.erdas.com/products/ecw/ERDASECWJPEG2000SDK/Details.aspx)
14 #   - Kakadu/JPEG2000 (http://www.kakadusoftware.com/)
15 #   - MrSID (http://www.lizardtech.com/developer/)
16 #   - MSG/EUMETSAT (http://www.eumetsat.int/Home/Main/DataAccess/SupportSoftwareTools/index.htm)
17 #   - Oracle/OCI >= 10.0.1 (for georaster); Oracle/OCI >= 8.1.7 (as DB)
18 #   - Ingres (--with-ingres=/path)
19 #   - Informix DB
20 #   - DWGdirect (members only? http://www.opendwg.org/)
21 #   - ESRI SDE (http://www.esri.com/software/arcgis/arcsde/index.html)
22 #
23 # Conditional build:
24 %bcond_without  armadillo       # Armadillo support for faster TPS transform
25 %bcond_without  epsilon         # EPSILON wavelet compression support
26 %bcond_without  gta             # GTA format support
27 %bcond_without  mysql           # MySQL DB support
28 %bcond_without  odbc            # ODBC DB support
29 %bcond_without  opencl          # OpenCL (GPU) support
30 %bcond_without  openjpeg        # OpenJPEG 2 (JPEG2000) support
31 %bcond_with     podofo          # PDF support via podofo instead of poppler
32 %bcond_without  poppler         # PDF support via poppler
33 %bcond_without  spatialite      # SpatiaLite support
34 %bcond_without  xerces          # Xerces support
35 %bcond_without  java            # Java and MDB support
36 %bcond_without  php             # PHP binding
37 %bcond_without  ruby            # Ruby binding
38
39 %if %{with podofo}
40 %undefine       with_poppler
41 %endif
42 Summary:        Geospatial Data Abstraction Library
43 Summary(pl.UTF-8):      Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
44 Name:           gdal
45 Version:        1.10.1
46 Release:        1
47 License:        BSD-like
48 Group:          Libraries
49 Source0:        http://download.osgeo.org/gdal/%{version}/%{name}-%{version}.tar.xz
50 # Source0-md5:  f354c614aea76e5630e4edbf06e5c292
51 Patch0:         %{name}-perl.patch
52 Patch1:         %{name}-python_install.patch
53 Patch2:         %{name}-php.patch
54 Patch3:         %{name}-fpic.patch
55 Patch4:         %{name}-format-security.patch
56 Patch5:         gdal-bug-5284.patch
57 URL:            http://www.gdal.org/
58 %{?with_opencl:BuildRequires:   OpenCL-devel >= 1.0}
59 %{?with_armadillo:BuildRequires:        armadillo-devel}
60 BuildRequires:  autoconf >= 2.52
61 BuildRequires:  automake
62 BuildRequires:  cfitsio-devel
63 BuildRequires:  curl-devel
64 BuildRequires:  doxygen >= 1.4.2
65 %{?with_epsilon:BuildRequires:  epsilon-compressor-devel}
66 BuildRequires:  expat-devel >= 1.95.0
67 BuildRequires:  freexl-devel >= 1.0
68 BuildRequires:  geos-devel >= 2.2.0
69 BuildRequires:  giflib-devel >= 4.0
70 BuildRequires:  hdf-devel >= 4.0
71 BuildRequires:  hdf5-devel
72 BuildRequires:  jasper-devel
73 %{?with_java:BuildRequires:     jdk}
74 %{?with_java:BuildRequires:     jpackage-utils}
75 BuildRequires:  libcsf-devel
76 BuildRequires:  libdap-devel >= 3.10
77 BuildRequires:  libgeotiff-devel >= 1.2.1
78 %{?with_gta:BuildRequires:      libgta-devel}
79 BuildRequires:  libjpeg-devel >= 6b
80 #BuildRequires: libkml-devel >= 1.3.0
81 BuildRequires:  libpng-devel >= 2:1.2.8
82 %{?with_spatialite:BuildRequires:       libspatialite-devel}
83 BuildRequires:  libstdc++-devel
84 BuildRequires:  libtiff-devel >= 4.0
85 BuildRequires:  libtool
86 BuildRequires:  libuuid-devel
87 BuildRequires:  libwebp-devel
88 BuildRequires:  libxml2-devel
89 %{?with_mysql:BuildRequires:    mysql-devel}
90 BuildRequires:  netcdf-devel >= 4.1
91 BuildRequires:  ogdi-devel >= 3.1
92 %{?with_openjpeg:BuildRequires: openjpeg2-devel >= 2.0.0-2}
93 #BuildRequires: pcidsk-devel > 0.3
94 BuildRequires:  perl-devel
95 %{?with_php:BuildRequires:      php-devel}
96 %{?with_podofo:BuildRequires:   podofo-devel}
97 %{?with_poppler:BuildRequires:  poppler-devel >= 0.24}
98 # ensure it's compiled with PQescapeStringConn support
99 BuildRequires:  postgresql-backend-devel >= 8.1.4
100 BuildRequires:  postgresql-devel >= 8.1.4
101 BuildRequires:  proj-devel >= 4
102 BuildRequires:  python-devel >= 1:2.5
103 BuildRequires:  python-numpy-devel >= 1:1.0.0
104 BuildRequires:  python-setuptools
105 BuildRequires:  rpm-pythonprov
106 %{?with_ruby:BuildRequires:     rpm-rubyprov}
107 BuildRequires:  rpmbuild(macros) >= 1.344
108 %{?with_ruby:BuildRequires:     ruby-devel}
109 BuildRequires:  sed >= 4.0
110 BuildRequires:  sqlite3-devel >= 3.0.0
111 BuildRequires:  swig-perl
112 BuildRequires:  swig-python >= 1.3
113 %{?with_ruby:BuildRequires:     swig-ruby}
114 BuildRequires:  texlive-dvips
115 BuildRequires:  texlive-latex
116 %{?with_odbc:BuildRequires:     unixODBC-devel >= 2.2.15}
117 %{?with_xerces:BuildRequires:   xerces-c-devel >= 2.7.0}
118 BuildRequires:  xz-devel
119 BuildRequires:  zlib-devel >= 1.1.4
120 Requires:       freexl >= 1.0
121 Requires:       geos >= 2.2.0
122 Requires:       libgeotiff >= 1.2.1
123 Requires:       libpng >= 2:1.2.8
124 Requires:       libtiff >= 4.0
125 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
126
127 %description
128 GDAL is a translator library for raster geospatial data formats that
129 is released under an Open Source license. As a library, it presents a
130 single abstract data model to the calling application for all
131 supported formats. The related OGR library (which lives within the
132 GDAL source tree) provides a similar capability for simple features
133 vector data.
134
135 %description -l pl.UTF-8
136 GDAL to biblioteka konwertująca między formatami rastrowych danych
137 dotyczących powierzchni Ziemi, udostępniona na licencji Open Source.
138 Jako biblioteka udostępnia aplikacjom jeden abstrakcyjny model danych
139 do wszystkich obsługiwanych formatów. Powiązana z nią biblioteka OGR
140 (której źródła są dołączone do drzewa źródeł GDAL) daje podobne
141 możliwości dla danych wektorowych.
142
143 %package devel
144 Summary:        GDAL library header files
145 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GDAL
146 Group:          Development/Libraries
147 Requires:       %{name} = %{version}-%{release}
148 %{?with_opencl:Requires:        OpenCL-devel >= 1.0}
149 %{?with_armadillo:Requires:     armadillo-devel}
150 Requires:       cfitsio-devel
151 Requires:       curl-devel
152 %{?with_epsilon:Requires:       epsilon-compressor-devel}
153 Requires:       expat-devel >= 1.95.0
154 Requires:       freexl-devel >= 1.0
155 Requires:       geos-devel >= 2.2.0
156 Requires:       giflib-devel >= 4.0
157 Requires:       hdf-devel >= 4.0
158 Requires:       hdf5-devel
159 Requires:       jasper-devel
160 Requires:       libcsf-devel
161 Requires:       libdap-devel >= 3.10
162 Requires:       libgeotiff-devel >= 1.2.1
163 %{?with_gta:Requires:   libgta-devel}
164 Requires:       libjpeg-devel >= 6b
165 Requires:       libpng-devel >= 2:1.2.8
166 %{?with_spatialite:Requires:    libspatialite-devel}
167 Requires:       libstdc++-devel
168 Requires:       libtiff-devel >= 4.0
169 Requires:       libuuid-devel
170 Requires:       libwebp-devel
171 Requires:       libxml2-devel
172 %{?with_mysql:Requires: mysql-devel}
173 Requires:       netcdf-devel >= 4
174 Requires:       ogdi-devel >= 3.1
175 %{?with_openjpeg:Requires:      openjpeg2-devel >= 2.0.0-2}
176 #Requires:      pcidsk-devel > 0.3
177 %{?with_podofo:Requires:        podofo-devel}
178 %{?with_poppler:Requires:       poppler-devel >= 0.24}
179 Requires:       postgresql-devel
180 Requires:       proj-devel >= 4
181 Requires:       sqlite3-devel >= 3.0.0
182 %{?with_odbc:Requires:  unixODBC-devel}
183 %{?with_xerces:Requires:        xerces-c-devel >= 2.7.0}
184 Requires:       xz-devel
185 Requires:       zlib-devel >= 1.1.4
186
187 %description devel
188 GDAL library header files.
189
190 %description devel -l pl.UTF-8
191 Pliki nagłówkowe biblioteki GDAL.
192
193 %package static
194 Summary:        GDAL static libraries
195 Summary(pl.UTF-8):      Statyczne biblioteki GDAL
196 Group:          Development/Libraries
197 Requires:       %{name}-devel = %{version}-%{release}
198
199 %description static
200 GDAL static libraries.
201
202 %description static -l pl.UTF-8
203 Statyczne biblioteki GDAL.
204
205 %package -n perl-gdal
206 Summary:        Perl bindings for GDAL
207 Summary(pl.UTF-8):      Wiązania Perla do pakietu GDAL
208 Group:          Development/Languages/Perl
209 Requires:       %{name} = %{version}-%{release}
210
211 %description -n perl-gdal
212 Perl bindings for GDAL - Geo::GDAL, Geo::OGR and Geo::OSR modules.
213
214 %description -n perl-gdal -l pl.UTF-8
215 Wiązania Perla do pakietu GDAL - moduły Geo::GDAL, Geo::OGR, Geo::OSR.
216
217 %package -n php-gdal
218 Summary:        PHP bindings for GDAL library
219 Summary(pl.UTF-8):      Wiązania PHP do biblioteki GDAL
220 Group:          Development/Languages/PHP
221 Requires:       %{name} = %{version}-%{release}
222 %{?requires_php_extension}
223
224 %description -n php-gdal
225 PHP bindings for GDAL library
226
227 %description -n php-gdal -l pl.UTF-8
228 Wiązania PHP do biblioteki GDAL.
229
230 %package -n python-gdal
231 Summary:        GDAL Python module
232 Summary(pl.UTF-8):      Moduł Pythona GDAL
233 Group:          Libraries/Python
234 Requires:       %{name} = %{version}-%{release}
235 Requires:       python-libs
236
237 %description -n python-gdal
238 GDAL Python module.
239
240 %description -n python-gdal -l pl.UTF-8
241 Moduł Pythona GDAL.
242
243 %package -n ruby-gdal
244 Summary:        Ruby bindings for GDAL
245 Summary(pl.UTF-8):      Wiązania języka Ruby do pakietu GDAL
246 Group:          Development/Languages
247 Requires:       %{name} = %{version}-%{release}
248
249 %description -n ruby-gdal
250 Ruby bindings for GDAL - gdal, gdalconst, ogr and osr modules.
251
252 %description -n ruby-gdal -l pl.UTF-8
253 Wiązania języka Ruby do pakietu GDAL - moduły gdal, gdalconst, ogr i
254 osr.
255
256 %prep
257 %setup -q
258 %{__aclocal}
259 %{__autoconf}
260 %patch0 -p1
261 %patch1 -p1
262 %patch2 -p1
263 %patch3 -p1
264 %patch4 -p1
265 %patch5 -p3
266
267 # need to regenerate (old ones don't support perl 5.10)
268 %{__rm} swig/perl/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
269
270 # Build with fPIC to allow Ruby bindings
271 # Xcompiler should normally achieve that -- http://trac.osgeo.org/gdal/ticket/3978
272 # http://trac.osgeo.org/gdal/ticket/1994
273 sed -i 's|\$(CFLAGS)|$(CFLAGS) -fPIC|g' swig/ruby/RubyMakefile.mk
274 # Install Ruby bindings to distribution specific directory
275 sed -i 's|RUBY_EXTENSIONS_DIR :=.*|RUBY_EXTENSIONS_DIR := %{ruby_vendorarchdir}|' swig/ruby/RubyMakefile.mk
276
277 # Install Ruby bindings into the proper place
278 sed -i -e 's|^$(INSTALL_DIR):|$(DESTDIR)$(INSTALL_DIR):|' swig/ruby/RubyMakefile.mk
279 sed -i -e 's|^install: $(INSTALL_DIR)|install: $(DESTDIR)$(INSTALL_DIR)|' swig/ruby/RubyMakefile.mk
280
281 # our man path
282 sed -i -e 's#^mandir=.*##g' configure.in
283
284 %{__rm} -r man
285
286 %{__sed} -i -e 's,DODS_INC="-I.*,DODS_INC="$(pkg-config --cflags libdap)",' configure.in
287
288 %build
289 %{__libtoolize}
290 %{__aclocal} -I m4
291 %{__autoconf}
292 # disable grass/libgrass here, it can be built from separate gdal-grass package
293 %configure \
294         --datadir=%{_datadir}/gdal \
295         --with-dods-root=/usr \
296         %{?with_armadillo:--with-armadillo} \
297         %{?with_epsilon:--with-epsilon} \
298         %{!?with_gta:--without-gta} \
299         --with-hide-internal-symbols \
300         %{?with_java:--with-java=%{java_home}} \
301         --with-liblzma \
302         %{?with_java:--with-mdb --with-jvm-lib-add-rpath} \
303         %{?with_mysql:--with-mysql} \
304         %{?with_opencl:--with-opencl} \
305         --with-perl \
306         %{?with_php:--with-php} \
307         %{?with_podofo:--with-podofo} \
308         %{?with_poppler:--with-poppler} \
309         --with-python \
310         %{?with_ruby:--with-ruby} \
311         %{?with_spatialite:--with-spatialite} \
312         --with-sqlite3 \
313         --with-webp \
314         %{?with_xerces:--with-xerces} \
315         --with-xerces-inc=/usr/include/xercesc \
316         --with-xerces-lib="-lxerces-c" \
317         --without-grass \
318         --without-libgrass
319 #       --with-rasdaman
320 #       --with-pcidsk=/usr (needs > 0.3)
321 # csharp builds, but has no configure option
322
323 # regenerate where needed
324 %{__make} -j1 -C swig/perl generate
325 %if %{with ruby}
326 %{__make} -j1 -C swig/ruby generate
327 %endif
328
329 %{__make} -j1
330
331 %{__make} -j1 docs
332
333 %{__make} -j1 man
334
335 %install
336 rm -rf $RPM_BUILD_ROOT
337
338 %{__make} -j1 install install-man \
339         DESTDIR=$RPM_BUILD_ROOT
340
341 rm -rf _html
342 cp -a html _html
343 cp -a ogr/html _html/ogr
344
345 %if %{with php}
346 # missing in make install
347 install -D swig/php/php_gdal.so $RPM_BUILD_ROOT%{php_extensiondir}/gdal.so
348 install -D swig/php/php_gdalconst.so $RPM_BUILD_ROOT%{php_extensiondir}/gdalconst.so
349 install -D swig/php/php_ogr.so $RPM_BUILD_ROOT%{php_extensiondir}/ogr.so
350 install -D swig/php/php_osr.so $RPM_BUILD_ROOT%{php_extensiondir}/osr.so
351 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
352 cat <<'EOF' >$RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/gdal.ini
353 ; Enable gdal extension module
354 extension=gdal.so
355 extension=gdalconst.so
356 extension=ogr.so
357 extension=osr.so
358 EOF
359 %endif
360
361 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
362 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
363 %py_postclean
364
365 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
366 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/.packlist
367 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/Const/.packlist
368 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OGR/.packlist
369 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OSR/.packlist
370
371 # some doxygen trash
372 %{__rm} $RPM_BUILD_ROOT%{_bindir}/gdalmove.dox
373 %{__rm} $RPM_BUILD_ROOT%{_bindir}/gdal_{edit,fillnodata,polygonize,proximity,sieve}.dox
374
375 %clean
376 rm -rf $RPM_BUILD_ROOT
377
378 %post   -p /sbin/ldconfig
379 %postun -p /sbin/ldconfig
380
381 %files
382 %defattr(644,root,root,755)
383 %doc NEWS PROVENANCE.TXT
384 %attr(755,root,root) %{_bindir}/epsg_tr.py
385 %attr(755,root,root) %{_bindir}/esri2wkt.py
386 %attr(755,root,root) %{_bindir}/gcps2vec.py
387 %attr(755,root,root) %{_bindir}/gcps2wld.py
388 %attr(755,root,root) %{_bindir}/gdal2tiles.py
389 %attr(755,root,root) %{_bindir}/gdal2xyz.py
390 %attr(755,root,root) %{_bindir}/gdal_auth.py
391 %attr(755,root,root) %{_bindir}/gdal_contour
392 %attr(755,root,root) %{_bindir}/gdal_calc.py
393 %attr(755,root,root) %{_bindir}/gdal_edit.py
394 %attr(755,root,root) %{_bindir}/gdal_fillnodata.py
395 %attr(755,root,root) %{_bindir}/gdal_grid
396 %attr(755,root,root) %{_bindir}/gdal_merge.py
397 %attr(755,root,root) %{_bindir}/gdal_polygonize.py
398 %attr(755,root,root) %{_bindir}/gdal_proximity.py
399 %attr(755,root,root) %{_bindir}/gdal_rasterize
400 %attr(755,root,root) %{_bindir}/gdal_retile.py
401 %attr(755,root,root) %{_bindir}/gdal_sieve.py
402 %attr(755,root,root) %{_bindir}/gdal_translate
403 %attr(755,root,root) %{_bindir}/gdaladdo
404 %attr(755,root,root) %{_bindir}/gdalbuildvrt
405 %attr(755,root,root) %{_bindir}/gdalchksum.py
406 %attr(755,root,root) %{_bindir}/gdaldem
407 %attr(755,root,root) %{_bindir}/gdalenhance
408 %attr(755,root,root) %{_bindir}/gdalident.py
409 %attr(755,root,root) %{_bindir}/gdalimport.py
410 %attr(755,root,root) %{_bindir}/gdalinfo
411 %attr(755,root,root) %{_bindir}/gdallocationinfo
412 %attr(755,root,root) %{_bindir}/gdalmanage
413 %attr(755,root,root) %{_bindir}/gdalmove.py
414 %attr(755,root,root) %{_bindir}/gdalserver
415 %attr(755,root,root) %{_bindir}/gdalsrsinfo
416 %attr(755,root,root) %{_bindir}/gdaltindex
417 %attr(755,root,root) %{_bindir}/gdaltransform
418 %attr(755,root,root) %{_bindir}/gdalwarp
419 %attr(755,root,root) %{_bindir}/mkgraticule.py
420 %attr(755,root,root) %{_bindir}/nearblack
421 %attr(755,root,root) %{_bindir}/ogr2ogr
422 %attr(755,root,root) %{_bindir}/ogrinfo
423 %attr(755,root,root) %{_bindir}/ogrtindex
424 %attr(755,root,root) %{_bindir}/pct2rgb.py
425 %attr(755,root,root) %{_bindir}/rgb2pct.py
426 %attr(755,root,root) %{_bindir}/testepsg
427 %attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
428 %attr(755,root,root) %ghost %{_libdir}/libgdal.so.1
429 %{_datadir}/gdal
430 %{_mandir}/man1/gdal2tiles.1*
431 %{_mandir}/man1/gdal_contour.1*
432 %{_mandir}/man1/gdal_edit.1*
433 %{_mandir}/man1/gdal_fillnodata.1*
434 %{_mandir}/man1/gdal_grid.1*
435 %{_mandir}/man1/gdal_merge.1*
436 %{_mandir}/man1/gdal_polygonize.1*
437 %{_mandir}/man1/gdal_proximity.1*
438 %{_mandir}/man1/gdal_rasterize.1*
439 %{_mandir}/man1/gdal_retile.1*
440 %{_mandir}/man1/gdal_sieve.1*
441 %{_mandir}/man1/gdal_translate.1*
442 %{_mandir}/man1/gdal_utilities.1*
443 %{_mandir}/man1/gdaladdo.1*
444 %{_mandir}/man1/gdalbuildvrt.1*
445 %{_mandir}/man1/gdaldem.1*
446 %{_mandir}/man1/gdalinfo.1*
447 %{_mandir}/man1/gdallocationinfo.1*
448 %{_mandir}/man1/gdalmanage.1*
449 %{_mandir}/man1/gdalmove.1*
450 %{_mandir}/man1/gdalsrsinfo.1*
451 %{_mandir}/man1/gdaltindex.1*
452 %{_mandir}/man1/gdaltransform.1*
453 %{_mandir}/man1/gdalwarp.1*
454 %{_mandir}/man1/nearblack.1*
455 %{_mandir}/man1/ogr2ogr.1*
456 %{_mandir}/man1/ogr_utilities.1*
457 %{_mandir}/man1/ogrinfo.1*
458 %{_mandir}/man1/ogrtindex.1*
459 %{_mandir}/man1/pct2rgb.1*
460 %{_mandir}/man1/rgb2pct.1*
461
462 %files devel
463 %defattr(644,root,root,755)
464 %doc _html/*
465 %attr(755,root,root) %{_bindir}/gdal-config
466 %attr(755,root,root) %{_libdir}/libgdal.so
467 %{_libdir}/libgdal.la
468 %{_includedir}/cpl_*.h
469 %{_includedir}/cplkeywordparser.h
470 %{_includedir}/gdal*.h
471 %{_includedir}/gvgcpfit.h
472 %{_includedir}/memdataset.h
473 %{_includedir}/ogr_*.h
474 %{_includedir}/ogrsf_frmts.h
475 %{_includedir}/rawdataset.h
476 %{_includedir}/thinplatespline.h
477 %{_includedir}/vrtdataset.h
478 %{_mandir}/man1/gdal-config.1*
479
480 %files static
481 %defattr(644,root,root,755)
482 %{_libdir}/libgdal.a
483
484 %files -n perl-gdal
485 %defattr(644,root,root,755)
486 %dir %{perl_vendorarch}/Geo
487 %{perl_vendorarch}/Geo/GDAL.pm
488 %dir %{perl_vendorarch}/Geo/GDAL
489 %{perl_vendorarch}/Geo/GDAL/Const.pm
490 %{perl_vendorarch}/Geo/OGR.pm
491 %{perl_vendorarch}/Geo/OSR.pm
492 %dir %{perl_vendorarch}/auto/Geo
493 %dir %{perl_vendorarch}/auto/Geo/GDAL
494 %{perl_vendorarch}/auto/Geo/GDAL/GDAL.bs
495 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/GDAL.so
496 %dir %{perl_vendorarch}/auto/Geo/GDAL/Const
497 %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.bs
498 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.so
499 %dir %{perl_vendorarch}/auto/Geo/OGR
500 %{perl_vendorarch}/auto/Geo/OGR/OGR.bs
501 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OGR/OGR.so
502 %dir %{perl_vendorarch}/auto/Geo/OSR
503 %{perl_vendorarch}/auto/Geo/OSR/OSR.bs
504 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OSR/OSR.so
505
506 %if %{with php}
507 %files -n php-gdal
508 %defattr(644,root,root,755)
509 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/gdal.ini
510 %attr(755,root,root) %{php_extensiondir}/gdal.so
511 %attr(755,root,root) %{php_extensiondir}/gdalconst.so
512 %attr(755,root,root) %{php_extensiondir}/ogr.so
513 %attr(755,root,root) %{php_extensiondir}/osr.so
514 %endif
515
516 %files -n python-gdal
517 %defattr(644,root,root,755)
518 %{py_sitedir}/gdal.py[co]
519 %{py_sitedir}/gdalconst.py[co]
520 %{py_sitedir}/gdalnumeric.py[co]
521 %{py_sitedir}/ogr.py[co]
522 %{py_sitedir}/osr.py[co]
523 %{py_sitedir}/GDAL-*.egg-info
524 %dir %{py_sitedir}/osgeo
525 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal.so
526 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal_array.so
527 %attr(755,root,root) %{py_sitedir}/osgeo/_gdalconst.so
528 %attr(755,root,root) %{py_sitedir}/osgeo/_ogr.so
529 %attr(755,root,root) %{py_sitedir}/osgeo/_osr.so
530 %{py_sitedir}/osgeo/*.py[co]
531
532 %if %{with ruby}
533 %files -n ruby-gdal
534 %defattr(644,root,root,755)
535 %dir %{ruby_vendorarchdir}/gdal
536 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/gdal.so
537 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/gdalconst.so
538 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/ogr.so
539 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/osr.so
540 %endif
This page took 0.118905 seconds and 4 git commands to generate.