]> git.pld-linux.org Git - packages/gdal.git/blob - gdal.spec
- updated to 1.9.2
[packages/gdal.git] / gdal.spec
1 # TODO:
2 # - be reasonable about devel dependencies - you do not need all of them to
3 #   use gdal (probably a gdal module or driver shall not imply devel
4 #   dependency)
5 # - rasdaman (--with-rasdaman; http://rasdaman.eecs.jacobs-university.de/trac/rasdaman/wiki/Download)
6 # - armadillo (--with-armadillo; http://arma.sourceforge.net/)
7 # - openjpeg (unreleased post-1.5 or 2? needs opj_decode_tile_data symbol, not available in 1.3-1.5)
8 # - libjpeg12 (check if still needs patching to use system one, maybe --with-jpeg12 is sufficied now)
9 # - libkml (1.3.0 needed, not released yet)
10 # - wait for newer pcidsk, switch to external again
11 # - csharp, java, mysql
12 # - additional, proprietary(?) formats support:
13 #   - FMEObjects (http://www.safe.com/support/support-resources/fme-downloads/)
14 #   - ESRI FileGDBAPI (http://resources.arcgis.com/content/geodatabases/10.0/file-gdb-api)
15 #   - ECW (http://www.erdas.com/products/ecw/ERDASECWJPEG2000SDK/Details.aspx)
16 #   - Kakadu/JPEG2000 (http://www.kakadusoftware.com/)
17 #   - MrSID (http://www.lizardtech.com/developer/)
18 #   - MSG/EUMETSAT (http://www.eumetsat.int/Home/Main/DataAccess/SupportSoftwareTools/index.htm)
19 #   - Oracle/OCI >= 10.0.1 (for georaster); Oracle/OCI >= 8.1.7 (as DB)
20 #   - Ingres (--with-ingres=/path)
21 #   - Informix DB
22 #   - DWGdirect (members only? http://www.opendwg.org/)
23 #   - ESRI SDE (http://www.esri.com/software/arcgis/arcsde/index.html)
24 #   - OpenCL (--with-opencl; no free Linux implementation yet?)
25 #
26 # Conditional build:
27 %bcond_without  epsilon         # EPSILON wavelet compression support
28 %bcond_without  gta             # GTA format support
29 %bcond_without  odbc            # disable ODBC DB support
30 %bcond_with     podofo          # PDF support via podofo instead of poppler
31 %bcond_without  poppler         # PDF support via poppler
32 %bcond_without  spatialite      # SpatiaLite support
33 %bcond_without  xerces          # disable xerces support
34 %bcond_without  java            # disable Java and MDB support
35 %bcond_without  php             # disable PHP binding
36 %bcond_without  ruby            # disable ruby binding
37 #
38 %if %{with podofo}
39 %undefine       with_poppler
40 %endif
41 Summary:        Geospatial Data Abstraction Library
42 Summary(pl.UTF-8):      Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
43 Name:           gdal
44 Version:        1.9.2
45 Release:        1
46 License:        BSD-like
47 Group:          Libraries
48 Source0:        ftp://ftp.remotesensing.org/gdal/%{name}-%{version}.tar.gz
49 # Source0-md5:  3f39db89f4710269b3a8bf94178e07aa
50 Patch0:         %{name}-perl.patch
51 Patch1:         %{name}-python_install.patch
52 Patch2:         %{name}-php.patch
53 Patch3:         %{name}-fpic.patch
54 URL:            http://www.gdal.org/
55 BuildRequires:  autoconf >= 2.52
56 BuildRequires:  automake
57 BuildRequires:  cfitsio-devel
58 BuildRequires:  curl-devel
59 BuildRequires:  doxygen >= 1.4.2
60 %{?with_epsilon:BuildRequires:  epsilon-compressor-devel}
61 BuildRequires:  expat-devel >= 1.95.0
62 BuildRequires:  freexl-devel >= 1.0
63 BuildRequires:  geos-devel >= 2.2.0
64 BuildRequires:  giflib-devel >= 4.0
65 BuildRequires:  hdf-devel >= 4.0
66 BuildRequires:  hdf5-devel
67 BuildRequires:  jasper-devel
68 %{?with_java:BuildRequires:     jdk}
69 %{?with_java:BuildRequires:     jpackage-utils}
70 BuildRequires:  libcsf-devel
71 BuildRequires:  libdap-devel >= 3.10
72 BuildRequires:  libgeotiff-devel >= 1.2.1
73 %{?with_gta:BuildRequires:      libgta-devel}
74 BuildRequires:  libjpeg-devel >= 6b
75 #BuildRequires: libkml-devel >= 1.3.0
76 BuildRequires:  libpng-devel >= 2:1.2.8
77 %{?with_spatialite:BuildRequires:       libspatialite-devel}
78 BuildRequires:  libstdc++-devel
79 BuildRequires:  libtiff-devel >= 4.0
80 BuildRequires:  libtool
81 BuildRequires:  libuuid-devel
82 BuildRequires:  libwebp-devel
83 BuildRequires:  libxml2-devel
84 BuildRequires:  netcdf-devel >= 4.1
85 BuildRequires:  ogdi-devel >= 3.1
86 #BuildRequires: pcidsk-devel > 0.3
87 BuildRequires:  perl-devel
88 %{?with_php:BuildRequires:      php-devel}
89 %{?with_podofo:BuildRequires:   podofo-devel}
90 %{?with_poppler:BuildRequires:  poppler-devel}
91 # ensure it's compiled with PQescapeStringConn support
92 BuildRequires:  postgresql-backend-devel >= 8.1.4
93 BuildRequires:  postgresql-devel >= 8.1.4
94 BuildRequires:  proj-devel >= 4
95 BuildRequires:  python-devel >= 1:2.5
96 BuildRequires:  python-numpy-devel >= 1:1.0.0
97 BuildRequires:  python-setuptools
98 BuildRequires:  rpm-pythonprov
99 BuildRequires:  rpmbuild(macros) >= 1.344
100 %{?with_ruby:BuildRequires:     ruby-devel}
101 BuildRequires:  sed >= 4.0
102 BuildRequires:  sqlite3-devel >= 3.0.0
103 BuildRequires:  swig-perl
104 BuildRequires:  swig-python >= 1.3
105 %{?with_ruby:BuildRequires:     swig-ruby}
106 BuildRequires:  texlive-dvips
107 BuildRequires:  texlive-latex
108 %{?with_odbc:BuildRequires:     unixODBC-devel >= 2.2.15}
109 %{?with_xerces:BuildRequires:   xerces-c-devel >= 2.7.0}
110 BuildRequires:  xz-devel
111 BuildRequires:  zlib-devel >= 1.1.4
112 Requires:       freexl >= 1.0
113 Requires:       geos >= 2.2.0
114 Requires:       libgeotiff >= 1.2.1
115 Requires:       libpng >= 2:1.2.8
116 Requires:       libtiff >= 4.0
117 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
118
119 %description
120 GDAL is a translator library for raster geospatial data formats that
121 is released under an Open Source license. As a library, it presents a
122 single abstract data model to the calling application for all
123 supported formats. The related OGR library (which lives within the
124 GDAL source tree) provides a similar capability for simple features
125 vector data.
126
127 %description -l pl.UTF-8
128 GDAL to biblioteka konwertująca między formatami rastrowych danych
129 dotyczących powierzchni Ziemi, udostępniona na licencji Open Source.
130 Jako biblioteka udostępnia aplikacjom jeden abstrakcyjny model danych
131 do wszystkich obsługiwanych formatów. Powiązana z nią biblioteka OGR
132 (której źródła są dołączone do drzewa źródeł GDAL) daje podobne
133 możliwości dla danych wektorowych.
134
135 %package devel
136 Summary:        GDAL library header files
137 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GDAL
138 Group:          Development/Libraries
139 Requires:       %{name} = %{version}-%{release}
140 Requires:       cfitsio-devel
141 Requires:       curl-devel
142 %{?with_epsilon:Requires:       epsilon-compressor-devel}
143 Requires:       expat-devel >= 1.95.0
144 Requires:       freexl-devel >= 1.0
145 Requires:       geos-devel >= 2.2.0
146 Requires:       giflib-devel >= 4.0
147 Requires:       hdf-devel >= 4.0
148 Requires:       hdf5-devel
149 Requires:       jasper-devel
150 Requires:       libcsf-devel
151 Requires:       libdap-devel >= 3.10
152 Requires:       libgeotiff-devel >= 1.2.1
153 %{?with_gta:Requires:   libgta-devel}
154 Requires:       libjpeg-devel >= 6b
155 Requires:       libpng-devel >= 2:1.2.8
156 %{?with_spatialite:Requires:    libspatialite-devel}
157 Requires:       libstdc++-devel
158 Requires:       libtiff-devel >= 4.0
159 Requires:       libuuid-devel
160 Requires:       libwebp-devel
161 Requires:       libxml2-devel
162 Requires:       netcdf-devel >= 4
163 Requires:       ogdi-devel >= 3.1
164 #Requires:      pcidsk-devel > 0.3
165 %{?with_podofo:Requires:        podofo-devel}
166 %{?with_poppler:Requires:       poppler-devel}
167 Requires:       postgresql-devel
168 Requires:       proj-devel >= 4
169 Requires:       sqlite3-devel >= 3.0.0
170 %{?with_odbc:Requires:  unixODBC-devel}
171 %{?with_xerces:Requires:        xerces-c-devel >= 2.7.0}
172 Requires:       xz-devel
173 Requires:       zlib-devel >= 1.1.4
174
175 %description devel
176 GDAL library header files.
177
178 %description devel -l pl.UTF-8
179 Pliki nagłówkowe biblioteki GDAL.
180
181 %package static
182 Summary:        GDAL static libraries
183 Summary(pl.UTF-8):      Statyczne biblioteki GDAL
184 Group:          Development/Libraries
185 Requires:       %{name}-devel = %{version}-%{release}
186
187 %description static
188 GDAL static libraries.
189
190 %description static -l pl.UTF-8
191 Statyczne biblioteki GDAL.
192
193 %package -n perl-gdal
194 Summary:        Perl bindings for GDAL
195 Summary(pl.UTF-8):      Wiązania Perla do pakietu GDAL
196 Group:          Development/Languages/Perl
197 Requires:       %{name} = %{version}-%{release}
198
199 %description -n perl-gdal
200 Perl bindings for GDAL - Geo::GDAL, Geo::OGR and Geo::OSR modules.
201
202 %description -n perl-gdal -l pl.UTF-8
203 Wiązania Perla do pakietu GDAL - moduły Geo::GDAL, Geo::OGR, Geo::OSR.
204
205 %package -n php-gdal
206 Summary:        PHP bindings for GDAL library
207 Summary(pl.UTF-8):      Wiązania PHP do biblioteki GDAL
208 Group:          Development/Languages/PHP
209 Requires:       %{name} = %{version}-%{release}
210 %{?requires_php_extension}
211
212 %description -n php-gdal
213 PHP bindings for GDAL library
214
215 %description -n php-gdal -l pl.UTF-8
216 Wiązania PHP do biblioteki GDAL.
217
218 %package -n python-gdal
219 Summary:        GDAL Python module
220 Summary(pl.UTF-8):      Moduł Pythona GDAL
221 Group:          Libraries/Python
222 Requires:       %{name} = %{version}-%{release}
223 %pyrequires_eq  python-libs
224
225 %description -n python-gdal
226 GDAL Python module.
227
228 %description -n python-gdal -l pl.UTF-8
229 Moduł Pythona GDAL.
230
231 %package -n ruby-gdal
232 Summary:        Ruby bindings for GDAL
233 Summary(pl.UTF-8):      Wiązania języka Ruby do pakietu GDAL
234 Group:          Development/Languages
235 Requires:       %{name} = %{version}-%{release}
236 %{?ruby_mod_ver_requires_eq}
237
238 %description -n ruby-gdal
239 Ruby bindings for GDAL - gdal, gdalconst, ogr and osr modules.
240
241 %description -n ruby-gdal -l pl.UTF-8
242 Wiązania języka Ruby do pakietu GDAL - moduły gdal, gdalconst, ogr i
243 osr.
244
245 %prep
246 %setup -q
247 %patch0 -p1
248 %patch1 -p1
249 %patch2 -p1
250 %patch3 -p1
251
252 # need to regenerate (old ones don't support perl 5.10)
253 %{__rm} swig/perl/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
254
255 %{__rm} -r man
256
257 %{__sed} -i -e 's,DODS_INC="-I.*,DODS_INC="$(pkg-config --cflags libdap)",' configure.in
258
259 %build
260 %{__libtoolize}
261 %{__aclocal} -I m4
262 %{__autoconf}
263 # disable grass/libgrass here, it can be built from separate gdal-grass package
264 %configure \
265         --datadir=%{_datadir}/gdal \
266         --with-dods-root=/usr \
267         %{?with_epsilon:--with-epsilon} \
268         %{!?with_gta:--without-gta} \
269         --with-hide-internal-symbols \
270         %{?with_java:--with-java=%{java_home}} \
271         --with-liblzma \
272         %{?with_java:--with-mdb --with-jvm-lib-add-rpath} \
273         --with-perl \
274         %{?with_php:--with-php} \
275         %{?with_podofo:--with-podofo} \
276         %{?with_poppler:--with-poppler} \
277         --with-python \
278         %{?with_ruby:--with-ruby} \
279         %{?with_spatialite:--with-spatialite} \
280         --with-sqlite3 \
281         --with-webp \
282         %{?with_xerces:--with-xerces} \
283         --with-xerces-inc=/usr/include/xercesc \
284         --with-xerces-lib="-lxerces-c" \
285         --without-grass \
286         --without-libgrass
287 #       --with-pcidsk=/usr (needs > 0.3)
288 # csharp builds, but has no configure option
289
290 # regenerate where needed
291 %{__make} -j1 -C swig/perl generate
292 %{?with_ruby:%{__make} -j1 -C swig/ruby generate}
293
294 %{__make} -j1
295
296 %{__make} -j1 docs
297
298 %{__make} -j1 man
299
300 %install
301 rm -rf $RPM_BUILD_ROOT
302
303 %{__make} -j1 install install-man \
304         DESTDIR=$RPM_BUILD_ROOT
305
306 rm -rf _html
307 cp -a html _html
308 cp -a ogr/html _html/ogr
309
310 %if %{with php}
311 # missing in make install
312 install -D swig/php/php_gdal.so $RPM_BUILD_ROOT%{php_extensiondir}/gdal.so
313 install -D swig/php/php_gdalconst.so $RPM_BUILD_ROOT%{php_extensiondir}/gdalconst.so
314 install -D swig/php/php_ogr.so $RPM_BUILD_ROOT%{php_extensiondir}/ogr.so
315 install -D swig/php/php_osr.so $RPM_BUILD_ROOT%{php_extensiondir}/osr.so
316 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
317 cat <<'EOF' >$RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/gdal.ini
318 ; Enable gdal extension module
319 extension=gdal.so
320 extension=gdalconst.so
321 extension=ogr.so
322 extension=osr.so
323 EOF
324 %endif
325
326 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
327 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
328 %py_postclean
329
330 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
331 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/.packlist
332 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/Const/.packlist
333 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OGR/.packlist
334 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OSR/.packlist
335
336 # some doxygen trash
337 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Geo/{GDAL.dox,GDAL/Const.dox,OGR.dox,OSR.dox}
338 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Geo/check_dox.pl
339 %{__rm} $RPM_BUILD_ROOT%{_bindir}/gdal_{fillnodata,sieve}.dox
340
341 %clean
342 rm -rf $RPM_BUILD_ROOT
343
344 %post   -p /sbin/ldconfig
345 %postun -p /sbin/ldconfig
346
347 %files
348 %defattr(644,root,root,755)
349 %doc NEWS PROVENANCE.TXT
350 %attr(755,root,root) %{_bindir}/epsg_tr.py
351 %attr(755,root,root) %{_bindir}/esri2wkt.py
352 %attr(755,root,root) %{_bindir}/gcps2vec.py
353 %attr(755,root,root) %{_bindir}/gcps2wld.py
354 %attr(755,root,root) %{_bindir}/gdal2tiles.py
355 %attr(755,root,root) %{_bindir}/gdal2xyz.py
356 %attr(755,root,root) %{_bindir}/gdal_contour
357 %attr(755,root,root) %{_bindir}/gdal_calc.py
358 %attr(755,root,root) %{_bindir}/gdal_fillnodata.py
359 %attr(755,root,root) %{_bindir}/gdal_grid
360 %attr(755,root,root) %{_bindir}/gdal_merge.py
361 %attr(755,root,root) %{_bindir}/gdal_polygonize.py
362 %attr(755,root,root) %{_bindir}/gdal_proximity.py
363 %attr(755,root,root) %{_bindir}/gdal_rasterize
364 %attr(755,root,root) %{_bindir}/gdal_retile.py
365 %attr(755,root,root) %{_bindir}/gdal_sieve.py
366 %attr(755,root,root) %{_bindir}/gdal_translate
367 %attr(755,root,root) %{_bindir}/gdaladdo
368 %attr(755,root,root) %{_bindir}/gdalbuildvrt
369 %attr(755,root,root) %{_bindir}/gdalchksum.py
370 %attr(755,root,root) %{_bindir}/gdaldem
371 %attr(755,root,root) %{_bindir}/gdalenhance
372 %attr(755,root,root) %{_bindir}/gdalident.py
373 %attr(755,root,root) %{_bindir}/gdalimport.py
374 %attr(755,root,root) %{_bindir}/gdalinfo
375 %attr(755,root,root) %{_bindir}/gdallocationinfo
376 %attr(755,root,root) %{_bindir}/gdalmanage
377 %attr(755,root,root) %{_bindir}/gdalsrsinfo
378 %attr(755,root,root) %{_bindir}/gdaltindex
379 %attr(755,root,root) %{_bindir}/gdaltransform
380 %attr(755,root,root) %{_bindir}/gdalwarp
381 %attr(755,root,root) %{_bindir}/mkgraticule.py
382 %attr(755,root,root) %{_bindir}/nearblack
383 %attr(755,root,root) %{_bindir}/ogr2ogr
384 %attr(755,root,root) %{_bindir}/ogrinfo
385 %attr(755,root,root) %{_bindir}/ogrtindex
386 %attr(755,root,root) %{_bindir}/pct2rgb.py
387 %attr(755,root,root) %{_bindir}/rgb2pct.py
388 %attr(755,root,root) %{_bindir}/testepsg
389 %attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
390 %attr(755,root,root) %ghost %{_libdir}/libgdal.so.1
391 %{_datadir}/gdal
392 %{_mandir}/man1/gdal2tiles.1*
393 %{_mandir}/man1/gdal_contour.1*
394 %{_mandir}/man1/gdal_fillnodata.1*
395 %{_mandir}/man1/gdal_grid.1*
396 %{_mandir}/man1/gdal_merge.1*
397 %{_mandir}/man1/gdal_rasterize.1*
398 %{_mandir}/man1/gdal_retile.1*
399 %{_mandir}/man1/gdal_sieve.1*
400 %{_mandir}/man1/gdal_translate.1*
401 %{_mandir}/man1/gdal_utilities.1*
402 %{_mandir}/man1/gdaladdo.1*
403 %{_mandir}/man1/gdalbuildvrt.1*
404 %{_mandir}/man1/gdaldem.1*
405 %{_mandir}/man1/gdalinfo.1*
406 %{_mandir}/man1/gdallocationinfo.1*
407 %{_mandir}/man1/gdalsrsinfo.1*
408 %{_mandir}/man1/gdaltindex.1*
409 %{_mandir}/man1/gdaltransform.1*
410 %{_mandir}/man1/gdalwarp.1*
411 %{_mandir}/man1/nearblack.1*
412 %{_mandir}/man1/ogr2ogr.1*
413 %{_mandir}/man1/ogr_utilities.1*
414 %{_mandir}/man1/ogrinfo.1*
415 %{_mandir}/man1/ogrtindex.1*
416 %{_mandir}/man1/pct2rgb.1*
417 %{_mandir}/man1/rgb2pct.1*
418
419 %files devel
420 %defattr(644,root,root,755)
421 %doc _html/*
422 %attr(755,root,root) %{_bindir}/gdal-config
423 %attr(755,root,root) %{_libdir}/libgdal.so
424 %{_libdir}/libgdal.la
425 %{_includedir}/cpl_*.h
426 %{_includedir}/cplkeywordparser.h
427 %{_includedir}/gdal*.h
428 %{_includedir}/gvgcpfit.h
429 %{_includedir}/memdataset.h
430 %{_includedir}/ogr_*.h
431 %{_includedir}/ogrsf_frmts.h
432 %{_includedir}/rawdataset.h
433 %{_includedir}/thinplatespline.h
434 %{_includedir}/vrtdataset.h
435 %{_mandir}/man1/gdal-config.1*
436
437 %files static
438 %defattr(644,root,root,755)
439 %{_libdir}/libgdal.a
440
441 %files -n perl-gdal
442 %defattr(644,root,root,755)
443 %dir %{perl_vendorarch}/Geo
444 %{perl_vendorarch}/Geo/GDAL.pm
445 %dir %{perl_vendorarch}/Geo/GDAL
446 %{perl_vendorarch}/Geo/GDAL/Const.pm
447 %{perl_vendorarch}/Geo/OGR.pm
448 %{perl_vendorarch}/Geo/OSR.pm
449 %dir %{perl_vendorarch}/auto/Geo
450 %dir %{perl_vendorarch}/auto/Geo/GDAL
451 %{perl_vendorarch}/auto/Geo/GDAL/GDAL.bs
452 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/GDAL.so
453 %dir %{perl_vendorarch}/auto/Geo/GDAL/Const
454 %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.bs
455 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.so
456 %dir %{perl_vendorarch}/auto/Geo/OGR
457 %{perl_vendorarch}/auto/Geo/OGR/OGR.bs
458 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OGR/OGR.so
459 %dir %{perl_vendorarch}/auto/Geo/OSR
460 %{perl_vendorarch}/auto/Geo/OSR/OSR.bs
461 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OSR/OSR.so
462
463 %if %{with php}
464 %files -n php-gdal
465 %defattr(644,root,root,755)
466 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/gdal.ini
467 %attr(755,root,root) %{php_extensiondir}/gdal.so
468 %attr(755,root,root) %{php_extensiondir}/gdalconst.so
469 %attr(755,root,root) %{php_extensiondir}/ogr.so
470 %attr(755,root,root) %{php_extensiondir}/osr.so
471 %endif
472
473 %files -n python-gdal
474 %defattr(644,root,root,755)
475 %{py_sitedir}/gdal.py[co]
476 %{py_sitedir}/gdalconst.py[co]
477 %{py_sitedir}/gdalnumeric.py[co]
478 %{py_sitedir}/ogr.py[co]
479 %{py_sitedir}/osr.py[co]
480 %{py_sitedir}/GDAL-*.egg-info
481 %dir %{py_sitedir}/osgeo
482 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal.so
483 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal_array.so
484 %attr(755,root,root) %{py_sitedir}/osgeo/_gdalconst.so
485 %attr(755,root,root) %{py_sitedir}/osgeo/_ogr.so
486 %attr(755,root,root) %{py_sitedir}/osgeo/_osr.so
487 %{py_sitedir}/osgeo/*.py[co]
488
489 %if %{with ruby}
490 %files -n ruby-gdal
491 %defattr(644,root,root,755)
492 %dir %{ruby_sitearchdir}/gdal
493 %attr(755,root,root) %{ruby_sitearchdir}/gdal/gdal.so
494 %attr(755,root,root) %{ruby_sitearchdir}/gdal/gdalconst.so
495 %attr(755,root,root) %{ruby_sitearchdir}/gdal/ogr.so
496 %attr(755,root,root) %{ruby_sitearchdir}/gdal/osr.so
497 %endif
This page took 0.063657 seconds and 4 git commands to generate.