]> git.pld-linux.org Git - packages/gdal.git/blob - gdal.spec
- release 2 (by relup.sh)
[packages/gdal.git] / gdal.spec
1 # TODO:
2 # - be reasonable about devel dependencies - you do not need all of them to
3 #   use gdal (probably a gdal module or driver shall not imply devel
4 #   dependency)
5 # - libjpeg12 (needs patching to use system one, --with-jpeg12 is not sufficient as of 1.9.2)
6 # - libkml (1.3.0 needed, not released yet)
7 # - wait for newer pcidsk, switch to external again
8 # - csharp, java
9 # - additional, proprietary(?) formats support:
10 #   - FMEObjects (http://www.safe.com/support/support-resources/fme-downloads/)
11 #   - ESRI FileGDBAPI (http://resources.arcgis.com/content/geodatabases/10.0/file-gdb-api)
12 #   - ECW (http://www.erdas.com/products/ecw/ERDASECWJPEG2000SDK/Details.aspx)
13 #   - Kakadu/JPEG2000 (http://www.kakadusoftware.com/)
14 #   - MrSID (http://www.lizardtech.com/developer/)
15 #   - MSG/EUMETSAT (http://www.eumetsat.int/Home/Main/DataAccess/SupportSoftwareTools/index.htm)
16 #   - Ingres (--with-ingres=/path)
17 #   - Informix DB (--with-idb)
18 #   - DWGdirect (members only? http://www.opendwg.org/)
19 #   - ESRI SDE (http://www.esri.com/software/arcgis/arcsde/index.html)
20 #
21 # Conditional build:
22 %bcond_without  armadillo       # Armadillo support for faster TPS transform
23 %bcond_without  crnlib          # DDS support via crunch/crnlib
24 %bcond_without  epsilon         # EPSILON wavelet compression support
25 %bcond_without  fyba            # SOSI geodata support using FYBA
26 %bcond_with     grass           # GRASS support (note: dependency loop; use gdal-grass.spec instead)
27 %bcond_without  gta             # GTA format support
28 %bcond_without  mysql           # MySQL DB support
29 %bcond_with     oci             # ORACLE OCI DB and Georaster support
30 %bcond_without  odbc            # ODBC DB support
31 %bcond_without  opencl          # OpenCL (GPU) support
32 %bcond_without  openjpeg        # OpenJPEG 2 (JPEG2000) support
33 %bcond_with     podofo          # PDF support via podofo instead of poppler
34 %bcond_without  poppler         # PDF support via poppler
35 %bcond_without  rasdaman        # Rasdaman support
36 %bcond_without  spatialite      # SpatiaLite support
37 %bcond_without  xerces          # Xerces support
38 %bcond_without  java            # Java and MDB support
39 %bcond_without  php             # PHP binding
40 %bcond_with     ruby            # Ruby binding
41
42 %if %{with podofo}
43 %undefine       with_poppler
44 %endif
45 %if 0%{!?php_name:1}
46 %define         php_name        php55
47 %endif
48 Summary:        Geospatial Data Abstraction Library
49 Summary(pl.UTF-8):      Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
50 Name:           gdal
51 Version:        2.0.1
52 Release:        2
53 License:        BSD-like
54 Group:          Libraries
55 Source0:        http://download.osgeo.org/gdal/%{version}/%{name}-%{version}.tar.xz
56 # Source0-md5:  27022cc4a3e0819ab02a69c2d0867437
57 Patch0:         %{name}-perl.patch
58 Patch1:         %{name}-python_install.patch
59 Patch2:         %{name}-php.patch
60 Patch3:         %{name}-fpic.patch
61 Patch5:         %{name}-grass.patch
62 Patch7:         %{name}-link.patch
63 Patch8:         %{name}-fyba.patch
64 Patch9:         %{name}-dds.patch
65 Patch11:        %{name}-armadillo.patch
66 Patch12:        %{name}-rasdaman.patch
67 Patch13:        %{name}-pluginsdir.patch
68 URL:            http://www.gdal.org/
69 %{?with_php:BuildRequires:      %{php_name}-devel}
70 %{?with_opencl:BuildRequires:   OpenCL-devel >= 1.0}
71 %{?with_armadillo:BuildRequires:        armadillo-devel}
72 BuildRequires:  autoconf >= 2.52
73 BuildRequires:  automake
74 BuildRequires:  cfitsio-devel
75 %{?with_crnlib:BuildRequires:   crnlib-devel}
76 BuildRequires:  curl-devel
77 BuildRequires:  doxygen >= 1.4.2
78 %{?with_epsilon:BuildRequires:  epsilon-compressor-devel}
79 BuildRequires:  expat-devel >= 1.95.0
80 %{?with_fyba:BuildRequires:     fyba-devel}
81 BuildRequires:  freexl-devel >= 1.0
82 BuildRequires:  gcc >= 6:4.1
83 BuildRequires:  geos-devel >= 3.1.0
84 BuildRequires:  giflib-devel >= 4.0
85 %{?with_grass:BuildRequires:    grass-devel >= 6.4}
86 BuildRequires:  hdf-devel >= 4.0
87 BuildRequires:  hdf5-devel
88 BuildRequires:  jasper-devel
89 %{?with_java:BuildRequires:     jdk}
90 %{?with_java:BuildRequires:     jpackage-utils}
91 BuildRequires:  json-c-devel >= 0.11
92 BuildRequires:  libcsf-devel >= 2.0-0.041111.6
93 BuildRequires:  libdap-devel >= 3.10
94 BuildRequires:  libgeotiff-devel >= 1.2.1
95 %{?with_gta:BuildRequires:      libgta-devel}
96 BuildRequires:  libjpeg-devel >= 6b
97 #BuildRequires: libkml-devel >= 1.3.0
98 BuildRequires:  libpng-devel >= 2:1.2.8
99 %{?with_spatialite:BuildRequires:       libspatialite-devel}
100 BuildRequires:  libstdc++-devel
101 BuildRequires:  libtiff-devel >= 4.0
102 BuildRequires:  libtool
103 BuildRequires:  libuuid-devel
104 BuildRequires:  libwebp-devel
105 BuildRequires:  libxml2-devel >= 2
106 %{?with_mysql:BuildRequires:    mysql-devel}
107 BuildRequires:  netcdf-devel >= 4.1
108 BuildRequires:  ogdi-devel >= 3.1
109 %{?with_openjpeg:BuildRequires: openjpeg2-devel >= 2.0.0-2}
110 # 8.1.7 for DB support, 10.0.1 for georaster
111 %{?with_oci:BuildRequires:      oracle-instantclient-devel >= 10.0.1}
112 #BuildRequires: pcidsk-devel > 0.3
113 BuildRequires:  perl-devel
114 %{?with_podofo:BuildRequires:   podofo-devel}
115 %{?with_poppler:BuildRequires:  poppler-devel >= 0.24}
116 # ensure it's compiled with PQescapeStringConn support
117 BuildRequires:  postgresql-backend-devel >= 8.1.4
118 BuildRequires:  postgresql-devel >= 8.1.4
119 BuildRequires:  proj-devel >= 4
120 BuildRequires:  python-devel >= 1:2.5
121 BuildRequires:  python-numpy-devel >= 1:1.0.0
122 BuildRequires:  python-setuptools
123 %{?with_rasdaman:BuildRequires: rasdaman-devel}
124 BuildRequires:  rpm-pythonprov
125 %{?with_ruby:BuildRequires:     rpm-rubyprov}
126 BuildRequires:  rpmbuild(macros) >= 1.344
127 %{?with_ruby:BuildRequires:     ruby-devel}
128 BuildRequires:  sed >= 4.0
129 BuildRequires:  sqlite3-devel >= 3.0.0
130 BuildRequires:  swig-perl
131 BuildRequires:  swig-php >= 2.0.12-2
132 BuildRequires:  swig-python >= 1.3
133 %{?with_ruby:BuildRequires:     swig-ruby}
134 BuildRequires:  texlive-dvips
135 BuildRequires:  texlive-latex
136 %{?with_odbc:BuildRequires:     unixODBC-devel >= 2.2.15}
137 %{?with_xerces:BuildRequires:   xerces-c-devel >= 2.7.0}
138 BuildRequires:  xz-devel
139 BuildRequires:  zlib-devel >= 1.1.4
140 Requires:       freexl >= 1.0
141 Requires:       geos >= 3.1.0
142 Requires:       libgeotiff >= 1.2.1
143 Requires:       libpng >= 2:1.2.8
144 Requires:       libtiff >= 4.0
145 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
146
147 %description
148 GDAL is a translator library for raster geospatial data formats that
149 is released under an Open Source license. As a library, it presents a
150 single abstract data model to the calling application for all
151 supported formats. The related OGR library (which lives within the
152 GDAL source tree) provides a similar capability for simple features
153 vector data.
154
155 %description -l pl.UTF-8
156 GDAL to biblioteka konwertująca między formatami rastrowych danych
157 dotyczących powierzchni Ziemi, udostępniona na licencji Open Source.
158 Jako biblioteka udostępnia aplikacjom jeden abstrakcyjny model danych
159 do wszystkich obsługiwanych formatów. Powiązana z nią biblioteka OGR
160 (której źródła są dołączone do drzewa źródeł GDAL) daje podobne
161 możliwości dla danych wektorowych.
162
163 %package devel
164 Summary:        GDAL library header files
165 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GDAL
166 Group:          Development/Libraries
167 Requires:       %{name} = %{version}-%{release}
168 %{?with_opencl:Requires:        OpenCL-devel >= 1.0}
169 %{?with_armadillo:Requires:     armadillo-devel}
170 Requires:       cfitsio-devel
171 %{?with_crnlib:Requires:        crnlib-devel}
172 Requires:       curl-devel
173 %{?with_epsilon:Requires:       epsilon-compressor-devel}
174 %{?with_fyba:Requires:  fyba-devel}
175 Requires:       expat-devel >= 1.95.0
176 Requires:       freexl-devel >= 1.0
177 Requires:       geos-devel >= 3.1.0
178 Requires:       giflib-devel >= 4.0
179 Requires:       hdf-devel >= 4.0
180 Requires:       hdf5-devel
181 Requires:       jasper-devel
182 Requires:       json-c-devel >= 0.11
183 Requires:       libcsf-devel
184 Requires:       libdap-devel >= 3.10
185 Requires:       libgeotiff-devel >= 1.2.1
186 %{?with_gta:Requires:   libgta-devel}
187 Requires:       libjpeg-devel >= 6b
188 Requires:       libpng-devel >= 2:1.2.8
189 %{?with_spatialite:Requires:    libspatialite-devel}
190 Requires:       libstdc++-devel
191 Requires:       libtiff-devel >= 4.0
192 Requires:       libuuid-devel
193 Requires:       libwebp-devel
194 Requires:       libxml2-devel >= 2
195 %{?with_mysql:Requires: mysql-devel}
196 Requires:       netcdf-devel >= 4
197 Requires:       ogdi-devel >= 3.1
198 %{?with_openjpeg:Requires:      openjpeg2-devel >= 2.0.0-2}
199 #Requires:      pcidsk-devel > 0.3
200 %{?with_podofo:Requires:        podofo-devel}
201 %{?with_poppler:Requires:       poppler-devel >= 0.24}
202 Requires:       postgresql-devel
203 Requires:       proj-devel >= 4
204 %{?with_rasdaman:Requires:      rasdaman-devel}
205 Requires:       sqlite3-devel >= 3.0.0
206 %{?with_odbc:Requires:  unixODBC-devel}
207 %{?with_xerces:Requires:        xerces-c-devel >= 2.7.0}
208 Requires:       xz-devel
209 Requires:       zlib-devel >= 1.1.4
210
211 %description devel
212 GDAL library header files.
213
214 %description devel -l pl.UTF-8
215 Pliki nagłówkowe biblioteki GDAL.
216
217 %package static
218 Summary:        GDAL static libraries
219 Summary(pl.UTF-8):      Statyczne biblioteki GDAL
220 Group:          Development/Libraries
221 Requires:       %{name}-devel = %{version}-%{release}
222
223 %description static
224 GDAL static libraries.
225
226 %description static -l pl.UTF-8
227 Statyczne biblioteki GDAL.
228
229 %package -n perl-gdal
230 Summary:        Perl bindings for GDAL
231 Summary(pl.UTF-8):      Wiązania Perla do pakietu GDAL
232 Group:          Development/Languages/Perl
233 Requires:       %{name} = %{version}-%{release}
234
235 %description -n perl-gdal
236 Perl bindings for GDAL - Geo::GDAL, Geo::OGR and Geo::OSR modules.
237
238 %description -n perl-gdal -l pl.UTF-8
239 Wiązania Perla do pakietu GDAL - moduły Geo::GDAL, Geo::OGR, Geo::OSR.
240
241 %package -n %{php_name}-gdal
242 Summary:        PHP bindings for GDAL library
243 Summary(pl.UTF-8):      Wiązania PHP do biblioteki GDAL
244 Group:          Development/Languages/PHP
245 Requires:       %{name} = %{version}-%{release}
246 %{?requires_php_extension}
247
248 %description -n %{php_name}-gdal
249 PHP bindings for GDAL library
250
251 %description -n %{php_name}-gdal -l pl.UTF-8
252 Wiązania PHP do biblioteki GDAL.
253
254 %package -n python-gdal
255 Summary:        GDAL Python module
256 Summary(pl.UTF-8):      Moduł Pythona GDAL
257 Group:          Libraries/Python
258 Requires:       %{name} = %{version}-%{release}
259 Requires:       python-libs
260
261 %description -n python-gdal
262 GDAL Python module.
263
264 %description -n python-gdal -l pl.UTF-8
265 Moduł Pythona GDAL.
266
267 %package -n ruby-gdal
268 Summary:        Ruby bindings for GDAL
269 Summary(pl.UTF-8):      Wiązania języka Ruby do pakietu GDAL
270 Group:          Development/Languages
271 Requires:       %{name} = %{version}-%{release}
272
273 %description -n ruby-gdal
274 Ruby bindings for GDAL - gdal, gdalconst, ogr and osr modules.
275
276 %description -n ruby-gdal -l pl.UTF-8
277 Wiązania języka Ruby do pakietu GDAL - moduły gdal, gdalconst, ogr i
278 osr.
279
280 %prep
281 %setup -q
282 %patch0 -p1
283 %patch1 -p1
284 %patch2 -p1
285 %patch3 -p1
286 %patch5 -p1
287 %patch7 -p1
288 %patch8 -p1
289 %patch9 -p1
290 %patch11 -p1
291 %patch12 -p1
292 %patch13 -p1
293
294 # need to regenerate (old ones don't support perl 5.10 or php 5.5)
295 %{__rm} swig/{perl,php}/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
296
297 %{__sed} -i \
298         -e 's/^CC=gcc/CC=%{__cc}/' \
299         -e 's/^CXX=g++/CXX=%{__cxx}/' \
300         -e 's/^CFLAGS=-fpic/CFLAGS=%{rpmcflags} -fPIC/' \
301         -e 's/^LDFLAGS=-shared/LDFLAGS=%{rpmldflags} -shared/' \
302         swig/php/GNUmakefile
303 # Build with fPIC to allow Ruby bindings
304 # Xcompiler should normally achieve that -- http://trac.osgeo.org/gdal/ticket/3978
305 # http://trac.osgeo.org/gdal/ticket/1994
306 sed -i 's|\$(CFLAGS)|$(CFLAGS) -fPIC|g' swig/ruby/RubyMakefile.mk
307 # Install Ruby bindings to distribution specific directory
308 sed -i 's|RUBY_EXTENSIONS_DIR :=.*|RUBY_EXTENSIONS_DIR := %{ruby_vendorarchdir}|' swig/ruby/RubyMakefile.mk
309
310 # Install Ruby bindings into the proper place
311 sed -i -e 's|^$(INSTALL_DIR):|$(DESTDIR)$(INSTALL_DIR):|' swig/ruby/RubyMakefile.mk
312 sed -i -e 's|^install: $(INSTALL_DIR)|install: $(DESTDIR)$(INSTALL_DIR)|' swig/ruby/RubyMakefile.mk
313
314 # our man path
315 sed -i -e 's#^mandir=.*##g' configure.in
316
317 %{__rm} -r man
318
319 %{__sed} -i -e 's,DODS_INC="-I.*,DODS_INC="$(pkg-config --cflags libdap)",' configure.in
320
321 %build
322 %ifarch %{x8664}
323 jvm_arch=amd64
324 %endif
325 %ifarch %{ix86}
326 jvm_arch=i386
327 %endif
328 %ifarch x32
329 jvm_arch=x32
330 %endif
331
332 %{__libtoolize}
333 %{__aclocal} -I m4
334 %{__autoconf}
335 %{__autoheader}
336 %configure \
337         --includedir=%{_includedir}/gdal \
338         --datadir=%{_datadir}/gdal \
339         --with-dods-root=/usr \
340         %{?with_armadillo:--with-armadillo} \
341         %{?with_crnlib:--with-dds} \
342         %{?with_epsilon:--with-epsilon} \
343         %{?with_grass:--with-grass} \
344         %{!?with_gta:--without-gta} \
345         --with-hide-internal-symbols \
346         %{?with_java:--with-java=%{java_home}} \
347         --with-liblzma \
348         %{?with_java:--with-mdb --with-jvm-lib-add-rpath --with-jvm-lib=%{java_home}/jre/lib/$jvm_arch/server} \
349         %{?with_mysql:--with-mysql} \
350         %{?with_oci:--with-oci --with-oci-include=/usr/include/oracle/client --with-oci-lib=%{_libdir}} \
351         %{?with_opencl:--with-opencl} \
352         --with-perl \
353         %{?with_php:--with-php} \
354         %{?with_podofo:--with-podofo} \
355         %{?with_poppler:--with-poppler} \
356         --with-python \
357         %{?with_rasdaman:--with-rasdaman=%{_libdir}/rasdaman} \
358         %{?with_ruby:--with-ruby} \
359         %{?with_fyba:--with-sosi} \
360         %{?with_spatialite:--with-spatialite} \
361         --with-sqlite3 \
362         --with-webp \
363         %{?with_xerces:--with-xerces} \
364         --with-xerces-inc=/usr/include/xercesc \
365         --with-xerces-lib="-lxerces-c" \
366         --with-autoload=%{_libdir}/gdalplugins \
367         --without-libgrass
368 #       --with-pcidsk=/usr (needs > 0.3)
369 # csharp builds, but has no configure option nor install target
370
371 # regenerate where needed
372 %{__make} -j1 -C swig/perl generate
373 %if %{with ruby}
374 %{__make} -j1 -C swig/ruby generate
375 %endif
376
377 %{__make} -j1 \
378         %{?with_grass:GRASS_INCLUDE="-I/usr/include/grass64"} \
379         %{?with_fyba:SOSI_INC="-I/usr/include/fyba"}
380
381 %{__make} -j1 docs
382
383 %{__make} -j1 man
384
385 %install
386 rm -rf $RPM_BUILD_ROOT
387
388 %{__make} -j1 install install-man \
389         DESTDIR=$RPM_BUILD_ROOT
390
391 rm -rf _html
392 cp -a html _html
393
394 %if %{with php}
395 # missing in make install
396 install -d $RPM_BUILD_ROOT%{php_extensiondir}
397 install -p swig/php/php_gdal.so $RPM_BUILD_ROOT%{php_extensiondir}/gdal.so
398 install -p swig/php/php_gdalconst.so $RPM_BUILD_ROOT%{php_extensiondir}/gdalconst.so
399 install -p swig/php/php_ogr.so $RPM_BUILD_ROOT%{php_extensiondir}/ogr.so
400 install -p swig/php/php_osr.so $RPM_BUILD_ROOT%{php_extensiondir}/osr.so
401 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
402 cat <<'EOF' >$RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/gdal.ini
403 ; Enable gdal extension modules
404 extension=gdal.so
405 extension=gdalconst.so
406 extension=ogr.so
407 extension=osr.so
408 EOF
409 %endif
410
411 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
412 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
413 %py_postclean
414
415 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
416 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/.packlist
417 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/Const/.packlist
418 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OGR/.packlist
419 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OSR/.packlist
420
421 # some doxygen trash
422 %{__rm} $RPM_BUILD_ROOT%{_bindir}/gdal{compare,move}.dox
423 %{__rm} $RPM_BUILD_ROOT%{_bindir}/gdal_{calc,edit,fillnodata,polygonize,proximity,sieve}.dox
424
425 %clean
426 rm -rf $RPM_BUILD_ROOT
427
428 %post   -p /sbin/ldconfig
429 %postun -p /sbin/ldconfig
430
431 %files
432 %defattr(644,root,root,755)
433 %doc NEWS PROVENANCE.TXT
434 %attr(755,root,root) %{_bindir}/epsg_tr.py
435 %attr(755,root,root) %{_bindir}/esri2wkt.py
436 %attr(755,root,root) %{_bindir}/gcps2vec.py
437 %attr(755,root,root) %{_bindir}/gcps2wld.py
438 %attr(755,root,root) %{_bindir}/gdal2tiles.py
439 %attr(755,root,root) %{_bindir}/gdal2xyz.py
440 %attr(755,root,root) %{_bindir}/gdal_auth.py
441 %attr(755,root,root) %{_bindir}/gdal_contour
442 %attr(755,root,root) %{_bindir}/gdal_calc.py
443 %attr(755,root,root) %{_bindir}/gdal_edit.py
444 %attr(755,root,root) %{_bindir}/gdal_fillnodata.py
445 %attr(755,root,root) %{_bindir}/gdal_grid
446 %attr(755,root,root) %{_bindir}/gdal_merge.py
447 %attr(755,root,root) %{_bindir}/gdal_polygonize.py
448 %attr(755,root,root) %{_bindir}/gdal_proximity.py
449 %attr(755,root,root) %{_bindir}/gdal_rasterize
450 %attr(755,root,root) %{_bindir}/gdal_retile.py
451 %attr(755,root,root) %{_bindir}/gdal_sieve.py
452 %attr(755,root,root) %{_bindir}/gdal_translate
453 %attr(755,root,root) %{_bindir}/gdaladdo
454 %attr(755,root,root) %{_bindir}/gdalbuildvrt
455 %attr(755,root,root) %{_bindir}/gdalchksum.py
456 %attr(755,root,root) %{_bindir}/gdalcompare.py
457 %attr(755,root,root) %{_bindir}/gdaldem
458 %attr(755,root,root) %{_bindir}/gdalenhance
459 %attr(755,root,root) %{_bindir}/gdalident.py
460 %attr(755,root,root) %{_bindir}/gdalimport.py
461 %attr(755,root,root) %{_bindir}/gdalinfo
462 %attr(755,root,root) %{_bindir}/gdallocationinfo
463 %attr(755,root,root) %{_bindir}/gdalmanage
464 %attr(755,root,root) %{_bindir}/gdalmove.py
465 %attr(755,root,root) %{_bindir}/gdalserver
466 %attr(755,root,root) %{_bindir}/gdalsrsinfo
467 %attr(755,root,root) %{_bindir}/gdaltindex
468 %attr(755,root,root) %{_bindir}/gdaltransform
469 %attr(755,root,root) %{_bindir}/gdalwarp
470 %attr(755,root,root) %{_bindir}/mkgraticule.py
471 %attr(755,root,root) %{_bindir}/nearblack
472 %attr(755,root,root) %{_bindir}/ogr2ogr
473 %attr(755,root,root) %{_bindir}/ogrinfo
474 %attr(755,root,root) %{_bindir}/ogrlineref
475 %attr(755,root,root) %{_bindir}/ogrtindex
476 %attr(755,root,root) %{_bindir}/pct2rgb.py
477 %attr(755,root,root) %{_bindir}/rgb2pct.py
478 %attr(755,root,root) %{_bindir}/testepsg
479 %attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
480 %attr(755,root,root) %ghost %{_libdir}/libgdal.so.20
481 %dir %{_libdir}/gdalplugins
482 %{_datadir}/gdal
483 %{_mandir}/man1/gdal2tiles.1*
484 %{_mandir}/man1/gdal_calc.1*
485 %{_mandir}/man1/gdal_contour.1*
486 %{_mandir}/man1/gdal_edit.1*
487 %{_mandir}/man1/gdal_fillnodata.1*
488 %{_mandir}/man1/gdal_grid.1*
489 %{_mandir}/man1/gdal_merge.1*
490 %{_mandir}/man1/gdal_polygonize.1*
491 %{_mandir}/man1/gdal_proximity.1*
492 %{_mandir}/man1/gdal_rasterize.1*
493 %{_mandir}/man1/gdal_retile.1*
494 %{_mandir}/man1/gdal_sieve.1*
495 %{_mandir}/man1/gdal_translate.1*
496 %{_mandir}/man1/gdal_utilities.1*
497 %{_mandir}/man1/gdaladdo.1*
498 %{_mandir}/man1/gdalbuildvrt.1*
499 %{_mandir}/man1/gdalcompare.1*
500 %{_mandir}/man1/gdaldem.1*
501 %{_mandir}/man1/gdalinfo.1*
502 %{_mandir}/man1/gdallocationinfo.1*
503 %{_mandir}/man1/gdalmanage.1*
504 %{_mandir}/man1/gdalmove.1*
505 %{_mandir}/man1/gdalsrsinfo.1*
506 %{_mandir}/man1/gdaltindex.1*
507 %{_mandir}/man1/gdaltransform.1*
508 %{_mandir}/man1/gdalwarp.1*
509 %{_mandir}/man1/nearblack.1*
510 %{_mandir}/man1/ogr2ogr.1*
511 %{_mandir}/man1/ogr_utilities.1*
512 %{_mandir}/man1/ogrinfo.1*
513 %{_mandir}/man1/ogrlineref.1*
514 %{_mandir}/man1/ogrtindex.1*
515 %{_mandir}/man1/pct2rgb.1*
516 %{_mandir}/man1/rgb2pct.1*
517
518 %files devel
519 %defattr(644,root,root,755)
520 %doc _html/*
521 %attr(755,root,root) %{_bindir}/gdal-config
522 %attr(755,root,root) %{_libdir}/libgdal.so
523 %{_libdir}/libgdal.la
524 %{_pkgconfigdir}/gdal.pc
525 %{_includedir}/gdal
526 %{_mandir}/man1/gdal-config.1*
527
528 %files static
529 %defattr(644,root,root,755)
530 %{_libdir}/libgdal.a
531
532 %files -n perl-gdal
533 %defattr(644,root,root,755)
534 %dir %{perl_vendorarch}/Geo
535 %{perl_vendorarch}/Geo/GDAL.pm
536 %dir %{perl_vendorarch}/Geo/GDAL
537 %{perl_vendorarch}/Geo/GDAL/Const.pm
538 %{perl_vendorarch}/Geo/OGR.pm
539 %{perl_vendorarch}/Geo/OSR.pm
540 %dir %{perl_vendorarch}/auto/Geo
541 %dir %{perl_vendorarch}/auto/Geo/GDAL
542 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/GDAL.so
543 %dir %{perl_vendorarch}/auto/Geo/GDAL/Const
544 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.so
545 %dir %{perl_vendorarch}/auto/Geo/OGR
546 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OGR/OGR.so
547 %dir %{perl_vendorarch}/auto/Geo/OSR
548 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OSR/OSR.so
549 %{_mandir}/man3/Geo::GDAL.3pm*
550
551 %if %{with php}
552 %files -n %{php_name}-gdal
553 %defattr(644,root,root,755)
554 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/gdal.ini
555 %attr(755,root,root) %{php_extensiondir}/gdal.so
556 %attr(755,root,root) %{php_extensiondir}/gdalconst.so
557 %attr(755,root,root) %{php_extensiondir}/ogr.so
558 %attr(755,root,root) %{php_extensiondir}/osr.so
559 %endif
560
561 %files -n python-gdal
562 %defattr(644,root,root,755)
563 %{py_sitedir}/gdal.py[co]
564 %{py_sitedir}/gdalconst.py[co]
565 %{py_sitedir}/gdalnumeric.py[co]
566 %{py_sitedir}/ogr.py[co]
567 %{py_sitedir}/osr.py[co]
568 %{py_sitedir}/GDAL-*.egg-info
569 %dir %{py_sitedir}/osgeo
570 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal.so
571 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal_array.so
572 %attr(755,root,root) %{py_sitedir}/osgeo/_gdalconst.so
573 %attr(755,root,root) %{py_sitedir}/osgeo/_ogr.so
574 %attr(755,root,root) %{py_sitedir}/osgeo/_osr.so
575 %{py_sitedir}/osgeo/*.py[co]
576
577 %if %{with ruby}
578 %files -n ruby-gdal
579 %defattr(644,root,root,755)
580 %dir %{ruby_vendorarchdir}/gdal
581 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/gdal.so
582 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/gdalconst.so
583 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/ogr.so
584 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/osr.so
585 %endif
This page took 0.083095 seconds and 4 git commands to generate.