]> git.pld-linux.org Git - packages/gdal.git/blob - gdal.spec
- updated to 1.11.1
[packages/gdal.git] / gdal.spec
1 # TODO:
2 # - be reasonable about devel dependencies - you do not need all of them to
3 #   use gdal (probably a gdal module or driver shall not imply devel
4 #   dependency)
5 # - libjpeg12 (needs patching to use system one, --with-jpeg12 is not sufficient as of 1.9.2)
6 # - libkml (1.3.0 needed, not released yet)
7 # - wait for newer pcidsk, switch to external again
8 # - csharp, java
9 # - additional, proprietary(?) formats support:
10 #   - FMEObjects (http://www.safe.com/support/support-resources/fme-downloads/)
11 #   - ESRI FileGDBAPI (http://resources.arcgis.com/content/geodatabases/10.0/file-gdb-api)
12 #   - ECW (http://www.erdas.com/products/ecw/ERDASECWJPEG2000SDK/Details.aspx)
13 #   - Kakadu/JPEG2000 (http://www.kakadusoftware.com/)
14 #   - MrSID (http://www.lizardtech.com/developer/)
15 #   - MSG/EUMETSAT (http://www.eumetsat.int/Home/Main/DataAccess/SupportSoftwareTools/index.htm)
16 #   - Ingres (--with-ingres=/path)
17 #   - Informix DB (--with-idb)
18 #   - DWGdirect (members only? http://www.opendwg.org/)
19 #   - ESRI SDE (http://www.esri.com/software/arcgis/arcsde/index.html)
20 #
21 # Conditional build:
22 %bcond_without  armadillo       # Armadillo support for faster TPS transform
23 %bcond_without  crnlib          # DDS support via crunch/crnlib
24 %bcond_without  epsilon         # EPSILON wavelet compression support
25 %bcond_without  fyba            # SOSI geodata support using FYBA
26 %bcond_with     grass           # GRASS support (note: dependency loop)
27 %bcond_without  gta             # GTA format support
28 %bcond_without  mysql           # MySQL DB support
29 %bcond_with     oci             # ORACLE OCI DB and Georaster support
30 %bcond_without  odbc            # ODBC DB support
31 %bcond_without  opencl          # OpenCL (GPU) support
32 %bcond_without  openjpeg        # OpenJPEG 2 (JPEG2000) support
33 %bcond_with     podofo          # PDF support via podofo instead of poppler
34 %bcond_without  poppler         # PDF support via poppler
35 %bcond_without  rasdaman        # Rasdaman support
36 %bcond_without  spatialite      # SpatiaLite support
37 %bcond_without  xerces          # Xerces support
38 %bcond_without  java            # Java and MDB support
39 %bcond_without  php             # PHP binding
40 %bcond_without  ruby            # Ruby binding
41
42 %if %{with podofo}
43 %undefine       with_poppler
44 %endif
45 %if 0%{!?php_name:1}
46 %define         php_name        php55
47 %endif
48 Summary:        Geospatial Data Abstraction Library
49 Summary(pl.UTF-8):      Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
50 Name:           gdal
51 Version:        1.11.1
52 Release:        1
53 License:        BSD-like
54 Group:          Libraries
55 Source0:        http://download.osgeo.org/gdal/%{version}/%{name}-%{version}.tar.xz
56 # Source0-md5:  2e126d7c6605691d38f3e71b945f5c73
57 Patch0:         %{name}-perl.patch
58 Patch1:         %{name}-python_install.patch
59 Patch2:         %{name}-php.patch
60 Patch3:         %{name}-fpic.patch
61 Patch4:         %{name}-format-security.patch
62 Patch5:         %{name}-grass.patch
63 Patch6:         %{name}-sse.patch
64 Patch7:         %{name}-link.patch
65 Patch8:         %{name}-fyba.patch
66 Patch9:         %{name}-dds.patch
67 Patch11:        %{name}-armadillo.patch
68 Patch12:        %{name}-oci.patch
69 Patch13:        %{name}-rasdaman.patch
70 URL:            http://www.gdal.org/
71 %{?with_php:BuildRequires:      %{php_name}-devel}
72 %{?with_opencl:BuildRequires:   OpenCL-devel >= 1.0}
73 %{?with_armadillo:BuildRequires:        armadillo-devel}
74 BuildRequires:  autoconf >= 2.52
75 BuildRequires:  automake
76 BuildRequires:  cfitsio-devel
77 %{?with_crnlib:BuildRequires:   crnlib-devel}
78 BuildRequires:  curl-devel
79 BuildRequires:  doxygen >= 1.4.2
80 %{?with_epsilon:BuildRequires:  epsilon-compressor-devel}
81 BuildRequires:  expat-devel >= 1.95.0
82 %{?with_fyba:BuildRequires:     fyba-devel}
83 BuildRequires:  freexl-devel >= 1.0
84 BuildRequires:  gcc >= 6:4.1
85 BuildRequires:  geos-devel >= 3.1.0
86 BuildRequires:  giflib-devel >= 4.0
87 %{?with_grass:BuildRequires:    grass-devel >= 6.4}
88 BuildRequires:  hdf-devel >= 4.0
89 BuildRequires:  hdf5-devel
90 BuildRequires:  jasper-devel
91 %{?with_java:BuildRequires:     jdk}
92 %{?with_java:BuildRequires:     jpackage-utils}
93 BuildRequires:  json-c-devel >= 0.11
94 BuildRequires:  libcsf-devel
95 BuildRequires:  libdap-devel >= 3.10
96 BuildRequires:  libgeotiff-devel >= 1.2.1
97 %{?with_gta:BuildRequires:      libgta-devel}
98 BuildRequires:  libjpeg-devel >= 6b
99 #BuildRequires: libkml-devel >= 1.3.0
100 BuildRequires:  libpng-devel >= 2:1.2.8
101 %{?with_spatialite:BuildRequires:       libspatialite-devel}
102 BuildRequires:  libstdc++-devel
103 BuildRequires:  libtiff-devel >= 4.0
104 BuildRequires:  libtool
105 BuildRequires:  libuuid-devel
106 BuildRequires:  libwebp-devel
107 BuildRequires:  libxml2-devel >= 2
108 %{?with_mysql:BuildRequires:    mysql-devel}
109 BuildRequires:  netcdf-devel >= 4.1
110 BuildRequires:  ogdi-devel >= 3.1
111 %{?with_openjpeg:BuildRequires: openjpeg2-devel >= 2.0.0-2}
112 # 8.1.7 for DB support, 10.0.1 for georaster
113 %{?with_oci:BuildRequires:      oracle-instantclient-devel >= 10.0.1}
114 #BuildRequires: pcidsk-devel > 0.3
115 BuildRequires:  perl-devel
116 %{?with_podofo:BuildRequires:   podofo-devel}
117 %{?with_poppler:BuildRequires:  poppler-devel >= 0.24}
118 # ensure it's compiled with PQescapeStringConn support
119 BuildRequires:  postgresql-backend-devel >= 8.1.4
120 BuildRequires:  postgresql-devel >= 8.1.4
121 BuildRequires:  proj-devel >= 4
122 BuildRequires:  python-devel >= 1:2.5
123 BuildRequires:  python-numpy-devel >= 1:1.0.0
124 BuildRequires:  python-setuptools
125 %{?with_rasdaman:BuildRequires: rasdaman-devel}
126 BuildRequires:  rpm-pythonprov
127 %{?with_ruby:BuildRequires:     rpm-rubyprov}
128 BuildRequires:  rpmbuild(macros) >= 1.344
129 %{?with_ruby:BuildRequires:     ruby-devel}
130 BuildRequires:  sed >= 4.0
131 BuildRequires:  sqlite3-devel >= 3.0.0
132 BuildRequires:  swig-perl
133 BuildRequires:  swig-php >= 2.0.12-2
134 BuildRequires:  swig-python >= 1.3
135 %{?with_ruby:BuildRequires:     swig-ruby}
136 BuildRequires:  texlive-dvips
137 BuildRequires:  texlive-latex
138 %{?with_odbc:BuildRequires:     unixODBC-devel >= 2.2.15}
139 %{?with_xerces:BuildRequires:   xerces-c-devel >= 2.7.0}
140 BuildRequires:  xz-devel
141 BuildRequires:  zlib-devel >= 1.1.4
142 Requires:       freexl >= 1.0
143 Requires:       geos >= 3.1.0
144 Requires:       libgeotiff >= 1.2.1
145 Requires:       libpng >= 2:1.2.8
146 Requires:       libtiff >= 4.0
147 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
148
149 %description
150 GDAL is a translator library for raster geospatial data formats that
151 is released under an Open Source license. As a library, it presents a
152 single abstract data model to the calling application for all
153 supported formats. The related OGR library (which lives within the
154 GDAL source tree) provides a similar capability for simple features
155 vector data.
156
157 %description -l pl.UTF-8
158 GDAL to biblioteka konwertująca między formatami rastrowych danych
159 dotyczących powierzchni Ziemi, udostępniona na licencji Open Source.
160 Jako biblioteka udostępnia aplikacjom jeden abstrakcyjny model danych
161 do wszystkich obsługiwanych formatów. Powiązana z nią biblioteka OGR
162 (której źródła są dołączone do drzewa źródeł GDAL) daje podobne
163 możliwości dla danych wektorowych.
164
165 %package devel
166 Summary:        GDAL library header files
167 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GDAL
168 Group:          Development/Libraries
169 Requires:       %{name} = %{version}-%{release}
170 %{?with_opencl:Requires:        OpenCL-devel >= 1.0}
171 %{?with_armadillo:Requires:     armadillo-devel}
172 Requires:       cfitsio-devel
173 %{?with_crnlib:Requires:        crnlib-devel}
174 Requires:       curl-devel
175 %{?with_epsilon:Requires:       epsilon-compressor-devel}
176 %{?with_fyba:Requires:  fyba-devel}
177 Requires:       expat-devel >= 1.95.0
178 Requires:       freexl-devel >= 1.0
179 Requires:       geos-devel >= 3.1.0
180 Requires:       giflib-devel >= 4.0
181 Requires:       hdf-devel >= 4.0
182 Requires:       hdf5-devel
183 Requires:       jasper-devel
184 Requires:       json-c-devel >= 0.11
185 Requires:       libcsf-devel
186 Requires:       libdap-devel >= 3.10
187 Requires:       libgeotiff-devel >= 1.2.1
188 %{?with_gta:Requires:   libgta-devel}
189 Requires:       libjpeg-devel >= 6b
190 Requires:       libpng-devel >= 2:1.2.8
191 %{?with_spatialite:Requires:    libspatialite-devel}
192 Requires:       libstdc++-devel
193 Requires:       libtiff-devel >= 4.0
194 Requires:       libuuid-devel
195 Requires:       libwebp-devel
196 Requires:       libxml2-devel >= 2
197 %{?with_mysql:Requires: mysql-devel}
198 Requires:       netcdf-devel >= 4
199 Requires:       ogdi-devel >= 3.1
200 %{?with_openjpeg:Requires:      openjpeg2-devel >= 2.0.0-2}
201 #Requires:      pcidsk-devel > 0.3
202 %{?with_podofo:Requires:        podofo-devel}
203 %{?with_poppler:Requires:       poppler-devel >= 0.24}
204 Requires:       postgresql-devel
205 Requires:       proj-devel >= 4
206 %{?with_rasdaman:Requires:      rasdaman-devel}
207 Requires:       sqlite3-devel >= 3.0.0
208 %{?with_odbc:Requires:  unixODBC-devel}
209 %{?with_xerces:Requires:        xerces-c-devel >= 2.7.0}
210 Requires:       xz-devel
211 Requires:       zlib-devel >= 1.1.4
212
213 %description devel
214 GDAL library header files.
215
216 %description devel -l pl.UTF-8
217 Pliki nagłówkowe biblioteki GDAL.
218
219 %package static
220 Summary:        GDAL static libraries
221 Summary(pl.UTF-8):      Statyczne biblioteki GDAL
222 Group:          Development/Libraries
223 Requires:       %{name}-devel = %{version}-%{release}
224
225 %description static
226 GDAL static libraries.
227
228 %description static -l pl.UTF-8
229 Statyczne biblioteki GDAL.
230
231 %package -n perl-gdal
232 Summary:        Perl bindings for GDAL
233 Summary(pl.UTF-8):      Wiązania Perla do pakietu GDAL
234 Group:          Development/Languages/Perl
235 Requires:       %{name} = %{version}-%{release}
236
237 %description -n perl-gdal
238 Perl bindings for GDAL - Geo::GDAL, Geo::OGR and Geo::OSR modules.
239
240 %description -n perl-gdal -l pl.UTF-8
241 Wiązania Perla do pakietu GDAL - moduły Geo::GDAL, Geo::OGR, Geo::OSR.
242
243 %package -n %{php_name}-gdal
244 Summary:        PHP bindings for GDAL library
245 Summary(pl.UTF-8):      Wiązania PHP do biblioteki GDAL
246 Group:          Development/Languages/PHP
247 Requires:       %{name} = %{version}-%{release}
248 %{?requires_php_extension}
249
250 %description -n %{php_name}-gdal
251 PHP bindings for GDAL library
252
253 %description -n %{php_name}-gdal -l pl.UTF-8
254 Wiązania PHP do biblioteki GDAL.
255
256 %package -n python-gdal
257 Summary:        GDAL Python module
258 Summary(pl.UTF-8):      Moduł Pythona GDAL
259 Group:          Libraries/Python
260 Requires:       %{name} = %{version}-%{release}
261 Requires:       python-libs
262
263 %description -n python-gdal
264 GDAL Python module.
265
266 %description -n python-gdal -l pl.UTF-8
267 Moduł Pythona GDAL.
268
269 %package -n ruby-gdal
270 Summary:        Ruby bindings for GDAL
271 Summary(pl.UTF-8):      Wiązania języka Ruby do pakietu GDAL
272 Group:          Development/Languages
273 Requires:       %{name} = %{version}-%{release}
274
275 %description -n ruby-gdal
276 Ruby bindings for GDAL - gdal, gdalconst, ogr and osr modules.
277
278 %description -n ruby-gdal -l pl.UTF-8
279 Wiązania języka Ruby do pakietu GDAL - moduły gdal, gdalconst, ogr i
280 osr.
281
282 %prep
283 %setup -q
284 %patch0 -p1
285 %patch1 -p1
286 %patch2 -p1
287 %patch3 -p1
288 %patch4 -p1
289 %patch5 -p1
290 %patch6 -p1
291 %patch7 -p1
292 %patch8 -p1
293 %patch9 -p1
294 %patch11 -p1
295 %patch12 -p1
296 %patch13 -p1
297
298 # need to regenerate (old ones don't support perl 5.10 or php 5.5)
299 %{__rm} swig/{perl,php}/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
300
301 %{__sed} -i \
302         -e 's/^CC=gcc/CC=%{__cc}/' \
303         -e 's/^CXX=g++/CXX=%{__cxx}/' \
304         -e 's/^CFLAGS=-fpic/CFLAGS=%{rpmcflags} -fPIC/' \
305         -e 's/^LDFLAGS=-shared/LDFLAGS=%{rpmldflags} -shared/' \
306         swig/php/GNUmakefile
307 # Build with fPIC to allow Ruby bindings
308 # Xcompiler should normally achieve that -- http://trac.osgeo.org/gdal/ticket/3978
309 # http://trac.osgeo.org/gdal/ticket/1994
310 sed -i 's|\$(CFLAGS)|$(CFLAGS) -fPIC|g' swig/ruby/RubyMakefile.mk
311 # Install Ruby bindings to distribution specific directory
312 sed -i 's|RUBY_EXTENSIONS_DIR :=.*|RUBY_EXTENSIONS_DIR := %{ruby_vendorarchdir}|' swig/ruby/RubyMakefile.mk
313
314 # Install Ruby bindings into the proper place
315 sed -i -e 's|^$(INSTALL_DIR):|$(DESTDIR)$(INSTALL_DIR):|' swig/ruby/RubyMakefile.mk
316 sed -i -e 's|^install: $(INSTALL_DIR)|install: $(DESTDIR)$(INSTALL_DIR)|' swig/ruby/RubyMakefile.mk
317
318 # our man path
319 sed -i -e 's#^mandir=.*##g' configure.in
320
321 %{__rm} -r man
322
323 %{__sed} -i -e 's,DODS_INC="-I.*,DODS_INC="$(pkg-config --cflags libdap)",' configure.in
324
325 %build
326 %{__libtoolize}
327 %{__aclocal} -I m4
328 %{__autoconf}
329 %configure \
330         --includedir=%{_includedir}/gdal \
331         --datadir=%{_datadir}/gdal \
332         --with-dods-root=/usr \
333         %{?with_armadillo:--with-armadillo} \
334         %{?with_crnlib:--with-dds} \
335         %{?with_epsilon:--with-epsilon} \
336         %{?with_grass:--with-grass} \
337         %{!?with_gta:--without-gta} \
338         --with-hide-internal-symbols \
339         %{?with_java:--with-java=%{java_home}} \
340         --with-liblzma \
341         %{?with_java:--with-mdb --with-jvm-lib-add-rpath} \
342         %{?with_mysql:--with-mysql} \
343         %{?with_oci:--with-oci --with-oci-include=/usr/include/oracle/client --with-oci-lib=%{_libdir}} \
344         %{?with_opencl:--with-opencl} \
345         --with-perl \
346         %{?with_php:--with-php} \
347         %{?with_podofo:--with-podofo} \
348         %{?with_poppler:--with-poppler} \
349         --with-python \
350         %{?with_rasdaman:--with-rasdaman=%{_libdir}/rasdaman} \
351         %{?with_ruby:--with-ruby} \
352         %{?with_fyba:--with-sosi} \
353         %{?with_spatialite:--with-spatialite} \
354         --with-sqlite3 \
355         --with-webp \
356         %{?with_xerces:--with-xerces} \
357         --with-xerces-inc=/usr/include/xercesc \
358         --with-xerces-lib="-lxerces-c" \
359         --without-libgrass
360 #       --with-pcidsk=/usr (needs > 0.3)
361 # csharp builds, but has no configure option nor install target
362
363 # regenerate where needed
364 %{__make} -j1 -C swig/perl generate
365 %if %{with ruby}
366 %{__make} -j1 -C swig/ruby generate
367 %endif
368
369 %{__make} -j1 \
370         %{?with_grass:GRASS_INCLUDE="-I/usr/include/grass64"} \
371         %{?with_fyba:SOSI_INC="-I/usr/include/fyba"}
372
373 %{__make} -j1 docs
374
375 %{__make} -j1 man
376
377 %install
378 rm -rf $RPM_BUILD_ROOT
379
380 %{__make} -j1 install install-man \
381         DESTDIR=$RPM_BUILD_ROOT
382
383 rm -rf _html
384 cp -a html _html
385 cp -a ogr/html _html/ogr
386
387 %if %{with php}
388 # missing in make install
389 install -d $RPM_BUILD_ROOT%{php_extensiondir}
390 install -p swig/php/php_gdal.so $RPM_BUILD_ROOT%{php_extensiondir}/gdal.so
391 install -p swig/php/php_gdalconst.so $RPM_BUILD_ROOT%{php_extensiondir}/gdalconst.so
392 install -p swig/php/php_ogr.so $RPM_BUILD_ROOT%{php_extensiondir}/ogr.so
393 install -p swig/php/php_osr.so $RPM_BUILD_ROOT%{php_extensiondir}/osr.so
394 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
395 cat <<'EOF' >$RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/gdal.ini
396 ; Enable gdal extension modules
397 extension=gdal.so
398 extension=gdalconst.so
399 extension=ogr.so
400 extension=osr.so
401 EOF
402 %endif
403
404 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
405 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
406 %py_postclean
407
408 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
409 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/.packlist
410 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/Const/.packlist
411 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OGR/.packlist
412 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OSR/.packlist
413
414 # some doxygen trash
415 %{__rm} $RPM_BUILD_ROOT%{_bindir}/gdal{compare,move}.dox
416 %{__rm} $RPM_BUILD_ROOT%{_bindir}/gdal_{calc,edit,fillnodata,polygonize,proximity,sieve}.dox
417
418 %clean
419 rm -rf $RPM_BUILD_ROOT
420
421 %post   -p /sbin/ldconfig
422 %postun -p /sbin/ldconfig
423
424 %files
425 %defattr(644,root,root,755)
426 %doc NEWS PROVENANCE.TXT
427 %attr(755,root,root) %{_bindir}/epsg_tr.py
428 %attr(755,root,root) %{_bindir}/esri2wkt.py
429 %attr(755,root,root) %{_bindir}/gcps2vec.py
430 %attr(755,root,root) %{_bindir}/gcps2wld.py
431 %attr(755,root,root) %{_bindir}/gdal2tiles.py
432 %attr(755,root,root) %{_bindir}/gdal2xyz.py
433 %attr(755,root,root) %{_bindir}/gdal_auth.py
434 %attr(755,root,root) %{_bindir}/gdal_contour
435 %attr(755,root,root) %{_bindir}/gdal_calc.py
436 %attr(755,root,root) %{_bindir}/gdal_edit.py
437 %attr(755,root,root) %{_bindir}/gdal_fillnodata.py
438 %attr(755,root,root) %{_bindir}/gdal_grid
439 %attr(755,root,root) %{_bindir}/gdal_merge.py
440 %attr(755,root,root) %{_bindir}/gdal_polygonize.py
441 %attr(755,root,root) %{_bindir}/gdal_proximity.py
442 %attr(755,root,root) %{_bindir}/gdal_rasterize
443 %attr(755,root,root) %{_bindir}/gdal_retile.py
444 %attr(755,root,root) %{_bindir}/gdal_sieve.py
445 %attr(755,root,root) %{_bindir}/gdal_translate
446 %attr(755,root,root) %{_bindir}/gdaladdo
447 %attr(755,root,root) %{_bindir}/gdalbuildvrt
448 %attr(755,root,root) %{_bindir}/gdalchksum.py
449 %attr(755,root,root) %{_bindir}/gdalcompare.py
450 %attr(755,root,root) %{_bindir}/gdaldem
451 %attr(755,root,root) %{_bindir}/gdalenhance
452 %attr(755,root,root) %{_bindir}/gdalident.py
453 %attr(755,root,root) %{_bindir}/gdalimport.py
454 %attr(755,root,root) %{_bindir}/gdalinfo
455 %attr(755,root,root) %{_bindir}/gdallocationinfo
456 %attr(755,root,root) %{_bindir}/gdalmanage
457 %attr(755,root,root) %{_bindir}/gdalmove.py
458 %attr(755,root,root) %{_bindir}/gdalserver
459 %attr(755,root,root) %{_bindir}/gdalsrsinfo
460 %attr(755,root,root) %{_bindir}/gdaltindex
461 %attr(755,root,root) %{_bindir}/gdaltransform
462 %attr(755,root,root) %{_bindir}/gdalwarp
463 %attr(755,root,root) %{_bindir}/mkgraticule.py
464 %attr(755,root,root) %{_bindir}/nearblack
465 %attr(755,root,root) %{_bindir}/ogr2ogr
466 %attr(755,root,root) %{_bindir}/ogrinfo
467 %attr(755,root,root) %{_bindir}/ogrlineref
468 %attr(755,root,root) %{_bindir}/ogrtindex
469 %attr(755,root,root) %{_bindir}/pct2rgb.py
470 %attr(755,root,root) %{_bindir}/rgb2pct.py
471 %attr(755,root,root) %{_bindir}/testepsg
472 %attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
473 %attr(755,root,root) %ghost %{_libdir}/libgdal.so.1
474 %{_datadir}/gdal
475 %{_mandir}/man1/gdal2tiles.1*
476 %{_mandir}/man1/gdal_calc.1*
477 %{_mandir}/man1/gdal_contour.1*
478 %{_mandir}/man1/gdal_edit.1*
479 %{_mandir}/man1/gdal_fillnodata.1*
480 %{_mandir}/man1/gdal_grid.1*
481 %{_mandir}/man1/gdal_merge.1*
482 %{_mandir}/man1/gdal_polygonize.1*
483 %{_mandir}/man1/gdal_proximity.1*
484 %{_mandir}/man1/gdal_rasterize.1*
485 %{_mandir}/man1/gdal_retile.1*
486 %{_mandir}/man1/gdal_sieve.1*
487 %{_mandir}/man1/gdal_translate.1*
488 %{_mandir}/man1/gdal_utilities.1*
489 %{_mandir}/man1/gdaladdo.1*
490 %{_mandir}/man1/gdalbuildvrt.1*
491 %{_mandir}/man1/gdalcompare.1*
492 %{_mandir}/man1/gdaldem.1*
493 %{_mandir}/man1/gdalinfo.1*
494 %{_mandir}/man1/gdallocationinfo.1*
495 %{_mandir}/man1/gdalmanage.1*
496 %{_mandir}/man1/gdalmove.1*
497 %{_mandir}/man1/gdalsrsinfo.1*
498 %{_mandir}/man1/gdaltindex.1*
499 %{_mandir}/man1/gdaltransform.1*
500 %{_mandir}/man1/gdalwarp.1*
501 %{_mandir}/man1/nearblack.1*
502 %{_mandir}/man1/ogr2ogr.1*
503 %{_mandir}/man1/ogr_utilities.1*
504 %{_mandir}/man1/ogrinfo.1*
505 %{_mandir}/man1/ogrlineref.1*
506 %{_mandir}/man1/ogrtindex.1*
507 %{_mandir}/man1/pct2rgb.1*
508 %{_mandir}/man1/rgb2pct.1*
509
510 %files devel
511 %defattr(644,root,root,755)
512 %doc _html/*
513 %attr(755,root,root) %{_bindir}/gdal-config
514 %attr(755,root,root) %{_libdir}/libgdal.so
515 %{_libdir}/libgdal.la
516 %{_pkgconfigdir}/gdal.pc
517 %{_includedir}/gdal
518 %{_mandir}/man1/gdal-config.1*
519
520 %files static
521 %defattr(644,root,root,755)
522 %{_libdir}/libgdal.a
523
524 %files -n perl-gdal
525 %defattr(644,root,root,755)
526 %dir %{perl_vendorarch}/Geo
527 %{perl_vendorarch}/Geo/GDAL.pm
528 %dir %{perl_vendorarch}/Geo/GDAL
529 %{perl_vendorarch}/Geo/GDAL/Const.pm
530 %{perl_vendorarch}/Geo/OGR.pm
531 %{perl_vendorarch}/Geo/OSR.pm
532 %dir %{perl_vendorarch}/auto/Geo
533 %dir %{perl_vendorarch}/auto/Geo/GDAL
534 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/GDAL.so
535 %dir %{perl_vendorarch}/auto/Geo/GDAL/Const
536 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.so
537 %dir %{perl_vendorarch}/auto/Geo/OGR
538 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OGR/OGR.so
539 %dir %{perl_vendorarch}/auto/Geo/OSR
540 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OSR/OSR.so
541
542 %if %{with php}
543 %files -n %{php_name}-gdal
544 %defattr(644,root,root,755)
545 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/gdal.ini
546 %attr(755,root,root) %{php_extensiondir}/gdal.so
547 %attr(755,root,root) %{php_extensiondir}/gdalconst.so
548 %attr(755,root,root) %{php_extensiondir}/ogr.so
549 %attr(755,root,root) %{php_extensiondir}/osr.so
550 %endif
551
552 %files -n python-gdal
553 %defattr(644,root,root,755)
554 %{py_sitedir}/gdal.py[co]
555 %{py_sitedir}/gdalconst.py[co]
556 %{py_sitedir}/gdalnumeric.py[co]
557 %{py_sitedir}/ogr.py[co]
558 %{py_sitedir}/osr.py[co]
559 %{py_sitedir}/GDAL-*.egg-info
560 %dir %{py_sitedir}/osgeo
561 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal.so
562 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal_array.so
563 %attr(755,root,root) %{py_sitedir}/osgeo/_gdalconst.so
564 %attr(755,root,root) %{py_sitedir}/osgeo/_ogr.so
565 %attr(755,root,root) %{py_sitedir}/osgeo/_osr.so
566 %{py_sitedir}/osgeo/*.py[co]
567
568 %if %{with ruby}
569 %files -n ruby-gdal
570 %defattr(644,root,root,755)
571 %dir %{ruby_vendorarchdir}/gdal
572 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/gdal.so
573 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/gdalconst.so
574 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/ogr.so
575 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/osr.so
576 %endif
This page took 0.087607 seconds and 4 git commands to generate.