]> git.pld-linux.org Git - packages/gdal.git/blob - gdal.spec
- enabled libcsf,libdap,sqlite3
[packages/gdal.git] / gdal.spec
1 #
2 # TODO:
3 # - consider using GRASS (or GDAL in GRASS? build trap possible)
4 #
5 Summary:        Geospatial Data Abstraction Library
6 Summary(pl):    Biblioteka abstrakcji danych dotycz±cych powierzchni Ziemi
7 Name:           gdal
8 Version:        1.3.0
9 Release:        1
10 License:        BSD-like
11 Group:          Libraries
12 Source0:        ftp://ftp.remotesensing.org/pub/gdal/%{name}-%{version}.tar.gz
13 # Source0-md5:  fbf4e137c9d0f64f5a70273e555bf777
14 Patch0:         %{name}-pgsql.patch
15 Patch1:         %{name}-DESTDIR.patch
16 Patch2:         %{name}-dods.patch
17 URL:            http://www.remotesensing.org/gdal/
18 BuildRequires:  autoconf
19 BuildRequires:  cfitsio-devel
20 BuildRequires:  doxygen
21 BuildRequires:  geos-devel >= 2.0
22 BuildRequires:  hdf-devel >= 4.0
23 BuildRequires:  jasper-devel
24 BuildRequires:  libcsf-devel
25 BuildRequires:  libdap-devel >= 3.5
26 BuildRequires:  libgeotiff-devel >= 1.2.1
27 BuildRequires:  libjpeg-devel >= 6b
28 BuildRequires:  libpng-devel >= 2:1.2.8
29 BuildRequires:  libstdc++-devel
30 BuildRequires:  libtiff-devel >= 3.6.0
31 BuildRequires:  libungif-devel >= 4.0
32 BuildRequires:  netcdf-devel
33 BuildRequires:  ogdi-devel >= 3.1
34 BuildRequires:  postgresql-devel
35 BuildRequires:  postgresql-backend-devel
36 BuildRequires:  python-devel
37 BuildRequires:  sqlite3-devel >= 3
38 BuildRequires:  unixODBC-devel
39 BuildRequires:  xerces-c-devel >= 2.2.0
40 BuildRequires:  zlib-devel >= 1.1.4
41 Requires:       geos >= 2.0
42 Requires:       libgeotiff >= 1.2.1
43 Requires:       libpng >= 2:1.2.8
44 Requires:       libtiff >= 3.6.0
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 GDAL is a translator library for raster geospatial data formats that
49 is released under an Open Source license. As a library, it presents a
50 single abstract data model to the calling application for all
51 supported formats. The related OGR library (which lives within the
52 GDAL source tree) provides a similar capability for simple features
53 vector data.
54
55 %description -l pl
56 GDAL to biblioteka konwertuj±ca miêdzy formatami rastrowych danych
57 dotycz±cych powierzchni Ziemi, udostêpniona na licencji Open Source.
58 Jako biblioteka udostêpnia aplikacjom jeden abstrakcyjny model danych
59 do wszystkich obs³ugiwanych formatów. Powi±zana z ni± biblioteka OGR
60 (której ¼ród³a s± do³±czone do drzewa ¼róde³ GDAL) daje podobne
61 mo¿liwo¶ci dla danych wektorowych.
62
63 %package devel
64 Summary:        GDAL library header files
65 Summary(pl):    Pliki nag³ówkowe biblioteki GDAL
66 Group:          Development/Libraries
67 Requires:       %{name} = %{version}-%{release}
68 Requires:       cfitsio-devel
69 Requires:       geos-devel >= 2.0
70 Requires:       hdf-devel >= 4.0
71 Requires:       jasper-devel
72 Requires:       libcsf-devel
73 Requires:       libdap-devel >= 3.5
74 Requires:       libgeotiff-devel >= 1.2.1
75 Requires:       libjpeg-devel
76 Requires:       libpng-devel >= 2:1.2.8
77 Requires:       libstdc++-devel
78 Requires:       libtiff-devel >= 3.6.0
79 Requires:       libungif-devel
80 Requires:       netcdf-devel
81 Requires:       ogdi-devel >= 3.1
82 Requires:       postgresql-devel
83 Requires:       sqlite3-devel >= 3
84 Requires:       unixODBC-devel
85 Requires:       xerces-c-devel >= 2.2.0
86
87 %description devel
88 GDAL library header files.
89
90 %description devel -l pl
91 Pliki nag³ówkowe biblioteki GDAL.
92
93 %package static
94 Summary:        GDAL static libraries
95 Summary(pl):    Statyczne biblioteki GDAL
96 Group:          Development/Libraries
97 Requires:       %{name}-devel = %{version}-%{release}
98
99 %description static
100 GDAL static libraries.
101
102 %description static -l pl
103 Statyczne biblioteki GDAL.
104
105 %package -n python-gdal
106 Summary:        GDAL Python module
107 Summary(pl):    Modu³ Pythona GDAL
108 Group:          Libraries/Python
109 Requires:       %{name} = %{version}-%{release}
110 %pyrequires_eq  python-libs
111
112 %description -n python-gdal
113 GDAL Python module.
114
115 %description -n python-gdal -l pl
116 Modu³ Pythona GDAL.
117
118 %prep
119 %setup -q
120 %patch0 -p1
121 %patch1 -p1
122 %patch2 -p1
123
124 %{__perl} -pi -e "s@lib/python@%{_lib}/python@" aclocal.m4
125
126 %build
127 %{__autoconf}
128 %configure \
129         --datadir=%{_datadir}/gdal \
130         --with-dods-root=/usr \
131         --with-pymoddir=%{py_sitedir} \
132         --with-sqlite \
133         --with-xerces \
134         --with-xerces-inc=/usr/include/xercesc \
135         --with-xerces-lib="-lxerces-c" \
136         --without-grass
137
138 %{__make}
139
140 %{__make} docs
141
142 %install
143 rm -rf $RPM_BUILD_ROOT
144
145 %{__make} install \
146         DESTDIR=$RPM_BUILD_ROOT
147
148 mv -f ogr/html html/org
149
150 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{la,a}
151
152 %clean
153 rm -rf $RPM_BUILD_ROOT
154
155 %post   -p /sbin/ldconfig
156 %postun -p /sbin/ldconfig
157
158 %files
159 %defattr(644,root,root,755)
160 %doc ChangeLog NEWS
161 %attr(755,root,root) %{_bindir}/*
162 %exclude %{_bindir}/gdal-config
163 %attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
164 %{_datadir}/gdal
165 %{_mandir}/man1/*
166 %exclude %{_mandir}/man1/gdal-config.1*
167
168 %files devel
169 %defattr(644,root,root,755)
170 %doc html/*
171 %attr(755,root,root) %{_bindir}/gdal-config
172 %attr(755,root,root) %{_libdir}/libgdal.so
173 %{_libdir}/libgdal.la
174 %{_includedir}/*.h
175 %{_mandir}/man1/gdal-config.1*
176
177 %files static
178 %defattr(644,root,root,755)
179 %{_libdir}/*.a
180
181 %files -n python-gdal
182 %defattr(644,root,root,755)
183 %attr(755,root,root) %{py_sitedir}/_gdalmodule.so
184 %{py_sitedir}/*.py
This page took 0.051105 seconds and 4 git commands to generate.