]> git.pld-linux.org Git - packages/gdal.git/blob - gdal.spec
- updated to 1.2.5, added sh patch
[packages/gdal.git] / gdal.spec
1 #
2 # TODO:
3 # - consider using GRASS (or GDAL in GRASS? build trap possible)
4 #
5 Summary:        Geospatial Data Abstraction Library
6 Summary(pl):    Biblioteka abstrakcji danych dotycz±cych powierzchni Ziemi
7 Name:           gdal
8 Version:        1.2.5
9 Release:        1
10 License:        BSD-like
11 Group:          Libraries
12 Source0:        ftp://ftp.remotesensing.org/pub/gdal/%{name}-%{version}.tar.gz
13 # Source0-md5:  2e3e651be6b4f42486e99ef39c17ffb1
14 Patch0:         %{name}-pgsql.patch
15 Patch1:         %{name}-DESTDIR.patch
16 Patch2:         %{name}-sh.patch
17 URL:            http://www.remotesensing.org/gdal/
18 BuildRequires:  autoconf
19 BuildRequires:  cfitsio-devel
20 BuildRequires:  doxygen
21 BuildRequires:  geos-devel >= 2.0
22 BuildRequires:  hdf-devel >= 4.0
23 BuildRequires:  jasper-devel
24 BuildRequires:  libgeotiff-devel >= 1.2.1
25 BuildRequires:  libjpeg-devel >= 6b
26 BuildRequires:  libpng-devel >= 1.0.6
27 BuildRequires:  libstdc++-devel
28 BuildRequires:  libtiff-devel >= 3.6.0
29 BuildRequires:  libungif-devel >= 4.0
30 BuildRequires:  netcdf-devel
31 BuildRequires:  ogdi-devel >= 3.1
32 BuildRequires:  postgresql-devel
33 BuildRequires:  postgresql-backend-devel
34 BuildRequires:  python-devel
35 BuildRequires:  rpm-pythonprov
36 BuildRequires:  unixODBC-devel
37 BuildRequires:  xerces-c-devel >= 2.2.0
38 BuildRequires:  zlib-devel >= 1.1.4
39 Requires:       geos >= 2.0
40 Requires:       libgeotiff >= 1.2.1
41 Requires:       libtiff >= 3.6.0
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 GDAL is a translator library for raster geospatial data formats that
46 is released under an Open Source license. As a library, it presents a
47 single abstract data model to the calling application for all
48 supported formats. The related OGR library (which lives within the
49 GDAL source tree) provides a similar capability for simple features
50 vector data.
51
52 %description -l pl
53 GDAL to biblioteka konwertuj±ca miêdzy formatami rastrowych danych
54 dotycz±cych powierzchni Ziemi, udostêpniona na licencji Open Source.
55 Jako biblioteka udostêpnia aplikacjom jeden abstrakcyjny model danych
56 do wszystkich obs³ugiwanych formatów. Powi±zana z ni± biblioteka OGR
57 (której ¼ród³a s± do³±czone do drzewa ¼róde³ GDAL) daje podobne
58 mo¿liwo¶ci dla danych wektorowych.
59
60 %package devel
61 Summary:        GDAL library header files
62 Summary(pl):    Pliki nag³ówkowe biblioteki GDAL
63 Group:          Development/Libraries
64 Requires:       %{name} = %{version}-%{release}
65 Requires:       cfitsio-devel
66 Requires:       geos-devel >= 2.0
67 Requires:       hdf-devel >= 4.0
68 Requires:       jasper-devel
69 Requires:       libgeotiff-devel >= 1.2.1
70 Requires:       libjpeg-devel
71 Requires:       libpng-devel >= 1.0.6
72 Requires:       libstdc++-devel
73 Requires:       libtiff-devel >= 3.6.0
74 Requires:       libungif-devel
75 Requires:       netcdf-devel
76 Requires:       ogdi-devel >= 3.1
77 Requires:       postgresql-devel
78 Requires:       unixODBC-devel
79 Requires:       xerces-c-devel >= 2.2.0
80
81 %description devel
82 GDAL library header files.
83
84 %description devel -l pl
85 Pliki nag³ówkowe biblioteki GDAL.
86
87 %package static
88 Summary:        GDAL static libraries
89 Summary(pl):    Statyczne biblioteki GDAL
90 Group:          Development/Libraries
91 Requires:       %{name}-devel = %{version}-%{release}
92
93 %description static
94 GDAL static libraries.
95
96 %description static -l pl
97 Statyczne biblioteki GDAL.
98
99 %package -n python-gdal
100 Summary:        GDAL Python module
101 Summary(pl):    Modu³ Pythona GDAL
102 Group:          Libraries/Python
103 Requires:       %{name} = %{version}-%{release}
104 %pyrequires_eq  python-libs
105
106 %description -n python-gdal
107 GDAL Python module.
108
109 %description -n python-gdal -l pl
110 Modu³ Pythona GDAL.
111
112 %prep
113 %setup -q
114 %patch0 -p1
115 %patch1 -p1
116 %patch2 -p1
117
118 %{__perl} -pi -e "s@lib/python@%{_lib}/python@" aclocal.m4
119
120 %build
121 %{__autoconf}
122 %configure \
123         --datadir=%{_datadir}/gdal \
124         --with-pymoddir=%{py_sitedir} \
125         --with-xerces \
126         --with-xerces-inc=/usr/include/xercesc \
127         --with-xerces-lib="-lxerces-c" \
128         --without-grass
129
130 %{__make}
131
132 %{__make} docs
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136
137 %{__make} install \
138         DESTDIR=$RPM_BUILD_ROOT
139
140 mv -f ogr/html html/org
141
142 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{la,a}
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %post   -p /sbin/ldconfig
148 %postun -p /sbin/ldconfig
149
150 %files
151 %defattr(644,root,root,755)
152 %doc ChangeLog NEWS
153 %attr(755,root,root) %{_bindir}/*
154 %exclude %{_bindir}/gdal-config
155 %attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
156 %{_datadir}/gdal
157 %{_mandir}/man1/*
158 %exclude %{_mandir}/man1/gdal-config.1*
159
160 %files devel
161 %defattr(644,root,root,755)
162 %doc html/*
163 %attr(755,root,root) %{_bindir}/gdal-config
164 %attr(755,root,root) %{_libdir}/libgdal.so
165 %{_libdir}/libgdal.la
166 %{_includedir}/*.h
167 %{_mandir}/man1/gdal-config.1*
168
169 %files static
170 %defattr(644,root,root,755)
171 %{_libdir}/*.a
172
173 %files -n python-gdal
174 %defattr(644,root,root,755)
175 %attr(755,root,root) %{py_sitedir}/_gdalmodule.so
176 %{py_sitedir}/*.py
This page took 0.044768 seconds and 4 git commands to generate.