]> git.pld-linux.org Git - packages/gdal.git/blob - gdal.spec
- converted to UTF-8
[packages/gdal.git] / gdal.spec
1 #
2 # Conditional build:
3 %bcond_without  odbc    # disable odbc support
4 %bcond_without  xerces  # disable xerces support
5 #
6 Summary:        Geospatial Data Abstraction Library
7 Summary(pl.UTF-8):   Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
8 Name:           gdal
9 Version:        1.3.2
10 Release:        3
11 License:        BSD-like
12 Group:          Libraries
13 Source0:        ftp://ftp.gdal.org/gdal/%{name}-%{version}.tar.gz
14 # Source0-md5:  67ed02dcea21e93f5e123bb0d322898a
15 Patch0:         %{name}-pgsql.patch
16 Patch1:         %{name}-DESTDIR.patch
17 Patch2:         %{name}-dods.patch
18 Patch3:         %{name}-gcc4.patch
19 Patch4:         %{name}-ac.patch
20 URL:            http://www.gdal.org/
21 BuildRequires:  autoconf
22 BuildRequires:  cfitsio-devel
23 BuildRequires:  doxygen
24 BuildRequires:  geos-devel >= 2.0
25 BuildRequires:  giflib-devel >= 4.0
26 BuildRequires:  hdf-devel >= 4.0
27 BuildRequires:  jasper-devel
28 BuildRequires:  libcsf-devel
29 BuildRequires:  libdap-devel >= 3.5
30 BuildRequires:  libgeotiff-devel >= 1.2.1
31 BuildRequires:  libjpeg-devel >= 6b
32 BuildRequires:  libpng-devel >= 2:1.2.8
33 BuildRequires:  libstdc++-devel
34 BuildRequires:  libtiff-devel >= 3.6.0
35 BuildRequires:  netcdf-devel
36 BuildRequires:  ogdi-devel >= 3.1
37 BuildRequires:  postgresql-devel
38 BuildRequires:  postgresql-backend-devel
39 BuildRequires:  python-devel
40 BuildRequires:  sqlite3-devel >= 3
41 %{?with_odbc:BuildRequires:     unixODBC-devel}
42 %{?with_xerces:BuildRequires:   xerces-c-devel >= 2.2.0}
43 BuildRequires:  zlib-devel >= 1.1.4
44 Requires:       geos >= 2.0
45 Requires:       libgeotiff >= 1.2.1
46 Requires:       libpng >= 2:1.2.8
47 Requires:       libtiff >= 3.6.0
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %description
51 GDAL is a translator library for raster geospatial data formats that
52 is released under an Open Source license. As a library, it presents a
53 single abstract data model to the calling application for all
54 supported formats. The related OGR library (which lives within the
55 GDAL source tree) provides a similar capability for simple features
56 vector data.
57
58 %description -l pl.UTF-8
59 GDAL to biblioteka konwertująca między formatami rastrowych danych
60 dotyczących powierzchni Ziemi, udostępniona na licencji Open Source.
61 Jako biblioteka udostępnia aplikacjom jeden abstrakcyjny model danych
62 do wszystkich obsługiwanych formatów. Powiązana z nią biblioteka OGR
63 (której źródła są dołączone do drzewa źródeł GDAL) daje podobne
64 możliwości dla danych wektorowych.
65
66 %package devel
67 Summary:        GDAL library header files
68 Summary(pl.UTF-8):   Pliki nagłówkowe biblioteki GDAL
69 Group:          Development/Libraries
70 Requires:       %{name} = %{version}-%{release}
71 Requires:       cfitsio-devel
72 Requires:       geos-devel >= 2.0
73 Requires:       giflib-devel
74 Requires:       hdf-devel >= 4.0
75 Requires:       jasper-devel
76 Requires:       libcsf-devel
77 Requires:       libdap-devel >= 3.5
78 Requires:       libgeotiff-devel >= 1.2.1
79 Requires:       libjpeg-devel
80 Requires:       libpng-devel >= 2:1.2.8
81 Requires:       libstdc++-devel
82 Requires:       libtiff-devel >= 3.6.0
83 Requires:       netcdf-devel
84 Requires:       ogdi-devel >= 3.1
85 Requires:       postgresql-devel
86 Requires:       sqlite3-devel >= 3
87 %{?with_odbc:Requires:  unixODBC-devel}
88 %{?with_xerces:Requires:        xerces-c-devel >= 2.2.0}
89
90 %description devel
91 GDAL library header files.
92
93 %description devel -l pl.UTF-8
94 Pliki nagłówkowe biblioteki GDAL.
95
96 %package static
97 Summary:        GDAL static libraries
98 Summary(pl.UTF-8):   Statyczne biblioteki GDAL
99 Group:          Development/Libraries
100 Requires:       %{name}-devel = %{version}-%{release}
101
102 %description static
103 GDAL static libraries.
104
105 %description static -l pl.UTF-8
106 Statyczne biblioteki GDAL.
107
108 %package -n python-gdal
109 Summary:        GDAL Python module
110 Summary(pl.UTF-8):   Moduł Pythona GDAL
111 Group:          Libraries/Python
112 Requires:       %{name} = %{version}-%{release}
113 %pyrequires_eq  python-libs
114
115 %description -n python-gdal
116 GDAL Python module.
117
118 %description -n python-gdal -l pl.UTF-8
119 Moduł Pythona GDAL.
120
121 %prep
122 %setup -q
123 %patch0 -p1
124 %patch1 -p1
125 %patch2 -p1
126 %patch3 -p1
127 %patch4 -p1
128
129 %build
130 # disable grass/libgrass here, it can be built from separate gdal-grass package
131 %{__autoconf}
132 %configure \
133         --datadir=%{_datadir}/gdal \
134         --with-dods-root=/usr \
135         --with-pymoddir=%{py_sitedir} \
136         --with-sqlite \
137         %{?with_xerces:--with-xerces} \
138         --with-xerces-inc=/usr/include/xercesc \
139         --with-xerces-lib="-lxerces-c" \
140         --without-grass \
141         --without-libgrass
142
143 %{__make}
144
145 %{__make} docs
146
147 %install
148 rm -rf $RPM_BUILD_ROOT
149
150 %{__make} install \
151         DESTDIR=$RPM_BUILD_ROOT
152
153 mv -f ogr/html html/org
154
155 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
156 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
157 %py_postclean
158 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{la,a}
159
160 %clean
161 rm -rf $RPM_BUILD_ROOT
162
163 %post   -p /sbin/ldconfig
164 %postun -p /sbin/ldconfig
165
166 %files
167 %defattr(644,root,root,755)
168 %doc NEWS PROVENANCE.TXT
169 %attr(755,root,root) %{_bindir}/*
170 %exclude %{_bindir}/gdal-config
171 %attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
172 %{_datadir}/gdal
173 %{_mandir}/man1/*
174 %exclude %{_mandir}/man1/gdal-config.1*
175
176 %files devel
177 %defattr(644,root,root,755)
178 %doc html/*
179 %attr(755,root,root) %{_bindir}/gdal-config
180 %attr(755,root,root) %{_libdir}/libgdal.so
181 %{_libdir}/libgdal.la
182 %{_includedir}/*.h
183 %{_mandir}/man1/gdal-config.1*
184
185 %files static
186 %defattr(644,root,root,755)
187 %{_libdir}/libgdal.a
188
189 %files -n python-gdal
190 %defattr(644,root,root,755)
191 %attr(755,root,root) %{py_sitedir}/_gdalmodule.so
192 %{py_sitedir}/*.py[co]
This page took 0.044681 seconds and 4 git commands to generate.