]> git.pld-linux.org Git - packages/gdal.git/blob - gdal.spec
- fix libdap includedir
[packages/gdal.git] / gdal.spec
1 #
2 # TODO:
3 # - consider using GRASS (or GDAL in GRASS? build trap possible)
4 #
5 Summary:        Geospatial Data Abstraction Library
6 Summary(pl):    Biblioteka abstrakcji danych dotycz±cych powierzchni Ziemi
7 Name:           gdal
8 Version:        1.3.0
9 Release:        1
10 License:        BSD-like
11 Group:          Libraries
12 Source0:        ftp://ftp.remotesensing.org/pub/gdal/%{name}-%{version}.tar.gz
13 # Source0-md5:  fbf4e137c9d0f64f5a70273e555bf777
14 Patch0:         %{name}-pgsql.patch
15 Patch1:         %{name}-DESTDIR.patch
16 URL:            http://www.remotesensing.org/gdal/
17 BuildRequires:  autoconf
18 BuildRequires:  cfitsio-devel
19 BuildRequires:  doxygen
20 BuildRequires:  geos-devel >= 2.0
21 BuildRequires:  hdf-devel >= 4.0
22 BuildRequires:  jasper-devel
23 BuildRequires:  libgeotiff-devel >= 1.2.1
24 BuildRequires:  libjpeg-devel >= 6b
25 BuildRequires:  libpng-devel >= 2:1.2.8
26 BuildRequires:  libstdc++-devel
27 BuildRequires:  libtiff-devel >= 3.6.0
28 BuildRequires:  libungif-devel >= 4.0
29 BuildRequires:  netcdf-devel
30 BuildRequires:  ogdi-devel >= 3.1
31 BuildRequires:  postgresql-devel
32 BuildRequires:  postgresql-backend-devel
33 BuildRequires:  python-devel
34 BuildRequires:  unixODBC-devel
35 BuildRequires:  xerces-c-devel >= 2.2.0
36 BuildRequires:  zlib-devel >= 1.1.4
37 Requires:       geos >= 2.0
38 Requires:       libgeotiff >= 1.2.1
39 Requires:       libpng >= 2:1.2.8
40 Requires:       libtiff >= 3.6.0
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 GDAL is a translator library for raster geospatial data formats that
45 is released under an Open Source license. As a library, it presents a
46 single abstract data model to the calling application for all
47 supported formats. The related OGR library (which lives within the
48 GDAL source tree) provides a similar capability for simple features
49 vector data.
50
51 %description -l pl
52 GDAL to biblioteka konwertuj±ca miêdzy formatami rastrowych danych
53 dotycz±cych powierzchni Ziemi, udostêpniona na licencji Open Source.
54 Jako biblioteka udostêpnia aplikacjom jeden abstrakcyjny model danych
55 do wszystkich obs³ugiwanych formatów. Powi±zana z ni± biblioteka OGR
56 (której ¼ród³a s± do³±czone do drzewa ¼róde³ GDAL) daje podobne
57 mo¿liwo¶ci dla danych wektorowych.
58
59 %package devel
60 Summary:        GDAL library header files
61 Summary(pl):    Pliki nag³ówkowe biblioteki GDAL
62 Group:          Development/Libraries
63 Requires:       %{name} = %{version}-%{release}
64 Requires:       cfitsio-devel
65 Requires:       geos-devel >= 2.0
66 Requires:       hdf-devel >= 4.0
67 Requires:       jasper-devel
68 Requires:       libgeotiff-devel >= 1.2.1
69 Requires:       libjpeg-devel
70 Requires:       libpng-devel >= 2:1.2.8
71 Requires:       libstdc++-devel
72 Requires:       libtiff-devel >= 3.6.0
73 Requires:       libungif-devel
74 Requires:       netcdf-devel
75 Requires:       ogdi-devel >= 3.1
76 Requires:       postgresql-devel
77 Requires:       unixODBC-devel
78 Requires:       xerces-c-devel >= 2.2.0
79
80 %description devel
81 GDAL library header files.
82
83 %description devel -l pl
84 Pliki nag³ówkowe biblioteki GDAL.
85
86 %package static
87 Summary:        GDAL static libraries
88 Summary(pl):    Statyczne biblioteki GDAL
89 Group:          Development/Libraries
90 Requires:       %{name}-devel = %{version}-%{release}
91
92 %description static
93 GDAL static libraries.
94
95 %description static -l pl
96 Statyczne biblioteki GDAL.
97
98 %package -n python-gdal
99 Summary:        GDAL Python module
100 Summary(pl):    Modu³ Pythona GDAL
101 Group:          Libraries/Python
102 Requires:       %{name} = %{version}-%{release}
103 %pyrequires_eq  python-libs
104
105 %description -n python-gdal
106 GDAL Python module.
107
108 %description -n python-gdal -l pl
109 Modu³ Pythona GDAL.
110
111 %prep
112 %setup -q
113 %patch0 -p1
114 %patch1 -p1
115
116 %{__perl} -pi -e "s@lib/python@%{_lib}/python@" aclocal.m4
117
118 %build
119 %{__autoconf}
120 %configure \
121         --datadir=%{_datadir}/gdal \
122         --with-pymoddir=%{py_sitedir} \
123         --with-xerces \
124         --with-xerces-inc=/usr/include/xercesc \
125         --with-xerces-lib="-lxerces-c" \
126         --without-grass
127
128 %{__make}
129
130 %{__make} docs
131
132 %install
133 rm -rf $RPM_BUILD_ROOT
134
135 %{__make} install \
136         DESTDIR=$RPM_BUILD_ROOT
137
138 mv -f ogr/html html/org
139
140 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{la,a}
141
142 %clean
143 rm -rf $RPM_BUILD_ROOT
144
145 %post   -p /sbin/ldconfig
146 %postun -p /sbin/ldconfig
147
148 %files
149 %defattr(644,root,root,755)
150 %doc ChangeLog NEWS
151 %attr(755,root,root) %{_bindir}/*
152 %exclude %{_bindir}/gdal-config
153 %attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
154 %{_datadir}/gdal
155 %{_mandir}/man1/*
156 %exclude %{_mandir}/man1/gdal-config.1*
157
158 %files devel
159 %defattr(644,root,root,755)
160 %doc html/*
161 %attr(755,root,root) %{_bindir}/gdal-config
162 %attr(755,root,root) %{_libdir}/libgdal.so
163 %{_libdir}/libgdal.la
164 %{_includedir}/*.h
165 %{_mandir}/man1/gdal-config.1*
166
167 %files static
168 %defattr(644,root,root,755)
169 %{_libdir}/*.a
170
171 %files -n python-gdal
172 %defattr(644,root,root,755)
173 %attr(755,root,root) %{py_sitedir}/_gdalmodule.so
174 %{py_sitedir}/*.py
This page took 0.057676 seconds and 4 git commands to generate.