]> git.pld-linux.org Git - packages/gdal.git/blob - gdal.spec
- tab
[packages/gdal.git] / gdal.spec
1 #
2 # Conditional build:
3 %bcond_without  odbc    # disable odbc support
4 %bcond_without  xerces  # disable xerces support
5 #
6 Summary:        Geospatial Data Abstraction Library
7 Summary(pl.UTF-8):      Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
8 Name:           gdal
9 Version:        1.4.1
10 Release:        0.1
11 License:        BSD-like
12 Group:          Libraries
13 #Source0:       http://download.osgeo.org/gdal/%{name}-%{version}.tar.gz
14 Source0:        ftp://ftp.gdal.org/gdal/%{name}-%{version}.tar.gz
15 # Source0-md5:  688cf651c6f6efc2851b12f2e9c2e0d1
16 Patch0:         %{name}-dods.patch
17 Patch1:         %{name}-ac.patch
18 URL:            http://www.gdal.org/
19 BuildRequires:  autoconf
20 BuildRequires:  cfitsio-devel
21 BuildRequires:  doxygen
22 BuildRequires:  geos-devel >= 2.0
23 BuildRequires:  giflib-devel >= 4.0
24 BuildRequires:  hdf-devel >= 4.0
25 BuildRequires:  jasper-devel
26 BuildRequires:  libcsf-devel
27 BuildRequires:  libdap-devel >= 3.5
28 BuildRequires:  libgeotiff-devel >= 1.2.1
29 BuildRequires:  libjpeg-devel >= 6b
30 BuildRequires:  libpng-devel >= 2:1.2.8
31 BuildRequires:  libstdc++-devel
32 BuildRequires:  libtiff-devel >= 3.6.0
33 BuildRequires:  netcdf-devel
34 BuildRequires:  ogdi-devel >= 3.1
35 BuildRequires:  postgresql-devel
36 BuildRequires:  postgresql-backend-devel
37 BuildRequires:  python-devel
38 BuildRequires:  sqlite3-devel >= 3
39 %{?with_odbc:BuildRequires:     unixODBC-devel}
40 %{?with_xerces:BuildRequires:   xerces-c-devel >= 2.2.0}
41 BuildRequires:  zlib-devel >= 1.1.4
42 Requires:       geos >= 2.0
43 Requires:       libgeotiff >= 1.2.1
44 Requires:       libpng >= 2:1.2.8
45 Requires:       libtiff >= 3.6.0
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 GDAL is a translator library for raster geospatial data formats that
50 is released under an Open Source license. As a library, it presents a
51 single abstract data model to the calling application for all
52 supported formats. The related OGR library (which lives within the
53 GDAL source tree) provides a similar capability for simple features
54 vector data.
55
56 %description -l pl.UTF-8
57 GDAL to biblioteka konwertująca między formatami rastrowych danych
58 dotyczących powierzchni Ziemi, udostępniona na licencji Open Source.
59 Jako biblioteka udostępnia aplikacjom jeden abstrakcyjny model danych
60 do wszystkich obsługiwanych formatów. Powiązana z nią biblioteka OGR
61 (której źródła są dołączone do drzewa źródeł GDAL) daje podobne
62 możliwości dla danych wektorowych.
63
64 %package devel
65 Summary:        GDAL library header files
66 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GDAL
67 Group:          Development/Libraries
68 Requires:       %{name} = %{version}-%{release}
69 Requires:       cfitsio-devel
70 Requires:       geos-devel >= 2.0
71 Requires:       giflib-devel
72 Requires:       hdf-devel >= 4.0
73 Requires:       jasper-devel
74 Requires:       libcsf-devel
75 Requires:       libdap-devel >= 3.5
76 Requires:       libgeotiff-devel >= 1.2.1
77 Requires:       libjpeg-devel
78 Requires:       libpng-devel >= 2:1.2.8
79 Requires:       libstdc++-devel
80 Requires:       libtiff-devel >= 3.6.0
81 Requires:       netcdf-devel
82 Requires:       ogdi-devel >= 3.1
83 Requires:       postgresql-devel
84 Requires:       sqlite3-devel >= 3
85 %{?with_odbc:Requires:  unixODBC-devel}
86 %{?with_xerces:Requires:        xerces-c-devel >= 2.2.0}
87
88 %description devel
89 GDAL library header files.
90
91 %description devel -l pl.UTF-8
92 Pliki nagłówkowe biblioteki GDAL.
93
94 %package static
95 Summary:        GDAL static libraries
96 Summary(pl.UTF-8):      Statyczne biblioteki GDAL
97 Group:          Development/Libraries
98 Requires:       %{name}-devel = %{version}-%{release}
99
100 %description static
101 GDAL static libraries.
102
103 %description static -l pl.UTF-8
104 Statyczne biblioteki GDAL.
105
106 %package -n python-gdal
107 Summary:        GDAL Python module
108 Summary(pl.UTF-8):      Moduł Pythona GDAL
109 Group:          Libraries/Python
110 Requires:       %{name} = %{version}-%{release}
111 %pyrequires_eq  python-libs
112
113 %description -n python-gdal
114 GDAL Python module.
115
116 %description -n python-gdal -l pl.UTF-8
117 Moduł Pythona GDAL.
118
119 %prep
120 %setup -q
121 %patch0 -p1
122 %patch1 -p1
123
124 %build
125 # disable grass/libgrass here, it can be built from separate gdal-grass package
126 %{__autoconf}
127 %configure \
128         --datadir=%{_datadir}/gdal \
129         --with-dods-root=/usr \
130         --with-pymoddir=%{py_sitedir} \
131         --with-sqlite \
132         %{?with_xerces:--with-xerces} \
133         --with-xerces-inc=/usr/include/xercesc \
134         --with-xerces-lib="-lxerces-c" \
135         --without-grass \
136         --without-libgrass
137
138 %{__make}
139
140 %{__make} docs
141
142 %install
143 rm -rf $RPM_BUILD_ROOT
144
145 %{__make} install \
146         DESTDIR=$RPM_BUILD_ROOT
147
148 mv -f ogr/html html/org
149
150 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
151 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
152 %py_postclean
153 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{la,a}
154
155 %clean
156 rm -rf $RPM_BUILD_ROOT
157
158 %post   -p /sbin/ldconfig
159 %postun -p /sbin/ldconfig
160
161 %files
162 %defattr(644,root,root,755)
163 %doc NEWS PROVENANCE.TXT
164 %attr(755,root,root) %{_bindir}/*
165 %exclude %{_bindir}/gdal-config
166 %attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
167 %{_datadir}/gdal
168 %{_mandir}/man1/*
169 %exclude %{_mandir}/man1/gdal-config.1*
170
171 %files devel
172 %defattr(644,root,root,755)
173 %doc html/*
174 %attr(755,root,root) %{_bindir}/gdal-config
175 %attr(755,root,root) %{_libdir}/libgdal.so
176 %{_libdir}/libgdal.la
177 %{_includedir}/*.h
178 %{_mandir}/man1/gdal-config.1*
179
180 %files static
181 %defattr(644,root,root,755)
182 %{_libdir}/libgdal.a
183
184 %files -n python-gdal
185 %defattr(644,root,root,755)
186 %attr(755,root,root) %{py_sitedir}/_gdalmodule.so
187 %{py_sitedir}/*.py[co]
This page took 0.038333 seconds and 4 git commands to generate.