]> git.pld-linux.org Git - packages/gdal.git/blob - gdal.spec
- use source mirror to fetch sources, for now
[packages/gdal.git] / gdal.spec
1 #
2 # Conditional build:
3 %bcond_without  odbc    # disable odbc support
4 %bcond_without  xerces  # disable xerces support
5 #
6 Summary:        Geospatial Data Abstraction Library
7 Summary(pl.UTF-8):      Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
8 Name:           gdal
9 Version:        1.4.1
10 Release:        0.1
11 License:        BSD-like
12 Group:          Libraries
13 Source0:        http://download.osgeo.org/gdal/%{name}-%{version}.tar.gz
14 # Source0-md5:  688cf651c6f6efc2851b12f2e9c2e0d1
15 Patch0:         %{name}-dods.patch
16 Patch1:         %{name}-ac.patch
17 URL:            http://www.gdal.org/
18 BuildRequires:  autoconf
19 BuildRequires:  cfitsio-devel
20 BuildRequires:  doxygen
21 BuildRequires:  geos-devel >= 2.0
22 BuildRequires:  giflib-devel >= 4.0
23 BuildRequires:  hdf-devel >= 4.0
24 BuildRequires:  jasper-devel
25 BuildRequires:  libcsf-devel
26 BuildRequires:  libdap-devel >= 3.5
27 BuildRequires:  libgeotiff-devel >= 1.2.1
28 BuildRequires:  libjpeg-devel >= 6b
29 BuildRequires:  libpng-devel >= 2:1.2.8
30 BuildRequires:  libstdc++-devel
31 BuildRequires:  libtiff-devel >= 3.6.0
32 BuildRequires:  netcdf-devel
33 BuildRequires:  ogdi-devel >= 3.1
34 BuildRequires:  postgresql-devel
35 BuildRequires:  postgresql-backend-devel
36 BuildRequires:  python-devel
37 BuildRequires:  sqlite3-devel >= 3
38 %{?with_odbc:BuildRequires:     unixODBC-devel}
39 %{?with_xerces:BuildRequires:   xerces-c-devel >= 2.2.0}
40 BuildRequires:  zlib-devel >= 1.1.4
41 Requires:       geos >= 2.0
42 Requires:       libgeotiff >= 1.2.1
43 Requires:       libpng >= 2:1.2.8
44 Requires:       libtiff >= 3.6.0
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 GDAL is a translator library for raster geospatial data formats that
49 is released under an Open Source license. As a library, it presents a
50 single abstract data model to the calling application for all
51 supported formats. The related OGR library (which lives within the
52 GDAL source tree) provides a similar capability for simple features
53 vector data.
54
55 %description -l pl.UTF-8
56 GDAL to biblioteka konwertująca między formatami rastrowych danych
57 dotyczących powierzchni Ziemi, udostępniona na licencji Open Source.
58 Jako biblioteka udostępnia aplikacjom jeden abstrakcyjny model danych
59 do wszystkich obsługiwanych formatów. Powiązana z nią biblioteka OGR
60 (której źródła są dołączone do drzewa źródeł GDAL) daje podobne
61 możliwości dla danych wektorowych.
62
63 %package devel
64 Summary:        GDAL library header files
65 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GDAL
66 Group:          Development/Libraries
67 Requires:       %{name} = %{version}-%{release}
68 Requires:       cfitsio-devel
69 Requires:       geos-devel >= 2.0
70 Requires:       giflib-devel
71 Requires:       hdf-devel >= 4.0
72 Requires:       jasper-devel
73 Requires:       libcsf-devel
74 Requires:       libdap-devel >= 3.5
75 Requires:       libgeotiff-devel >= 1.2.1
76 Requires:       libjpeg-devel
77 Requires:       libpng-devel >= 2:1.2.8
78 Requires:       libstdc++-devel
79 Requires:       libtiff-devel >= 3.6.0
80 Requires:       netcdf-devel
81 Requires:       ogdi-devel >= 3.1
82 Requires:       postgresql-devel
83 Requires:       sqlite3-devel >= 3
84 %{?with_odbc:Requires:  unixODBC-devel}
85 %{?with_xerces:Requires:        xerces-c-devel >= 2.2.0}
86
87 %description devel
88 GDAL library header files.
89
90 %description devel -l pl.UTF-8
91 Pliki nagłówkowe biblioteki GDAL.
92
93 %package static
94 Summary:        GDAL static libraries
95 Summary(pl.UTF-8):      Statyczne biblioteki GDAL
96 Group:          Development/Libraries
97 Requires:       %{name}-devel = %{version}-%{release}
98
99 %description static
100 GDAL static libraries.
101
102 %description static -l pl.UTF-8
103 Statyczne biblioteki GDAL.
104
105 %package -n python-gdal
106 Summary:        GDAL Python module
107 Summary(pl.UTF-8):      Moduł Pythona GDAL
108 Group:          Libraries/Python
109 Requires:       %{name} = %{version}-%{release}
110 %pyrequires_eq  python-libs
111
112 %description -n python-gdal
113 GDAL Python module.
114
115 %description -n python-gdal -l pl.UTF-8
116 Moduł Pythona GDAL.
117
118 %prep
119 %setup -q
120 %patch0 -p1
121 %patch1 -p1
122
123 %build
124 # disable grass/libgrass here, it can be built from separate gdal-grass package
125 %{__autoconf}
126 %configure \
127         --datadir=%{_datadir}/gdal \
128         --with-dods-root=/usr \
129         --with-pymoddir=%{py_sitedir} \
130         --with-sqlite \
131         %{?with_xerces:--with-xerces} \
132         --with-xerces-inc=/usr/include/xercesc \
133         --with-xerces-lib="-lxerces-c" \
134         --without-grass \
135         --without-libgrass
136
137 %{__make}
138
139 %{__make} docs
140
141 %install
142 rm -rf $RPM_BUILD_ROOT
143
144 %{__make} install \
145         DESTDIR=$RPM_BUILD_ROOT
146
147 mv -f ogr/html html/org
148
149 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
150 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
151 %py_postclean
152 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{la,a}
153
154 %clean
155 rm -rf $RPM_BUILD_ROOT
156
157 %post   -p /sbin/ldconfig
158 %postun -p /sbin/ldconfig
159
160 %files
161 %defattr(644,root,root,755)
162 %doc NEWS PROVENANCE.TXT
163 %attr(755,root,root) %{_bindir}/*
164 %exclude %{_bindir}/gdal-config
165 %attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
166 %{_datadir}/gdal
167 %{_mandir}/man1/*
168 %exclude %{_mandir}/man1/gdal-config.1*
169
170 %files devel
171 %defattr(644,root,root,755)
172 %doc html/*
173 %attr(755,root,root) %{_bindir}/gdal-config
174 %attr(755,root,root) %{_libdir}/libgdal.so
175 %{_libdir}/libgdal.la
176 %{_includedir}/*.h
177 %{_mandir}/man1/gdal-config.1*
178
179 %files static
180 %defattr(644,root,root,755)
181 %{_libdir}/libgdal.a
182
183 %files -n python-gdal
184 %defattr(644,root,root,755)
185 %attr(755,root,root) %{py_sitedir}/_gdalmodule.so
186 %{py_sitedir}/*.py[co]
This page took 0.143454 seconds and 4 git commands to generate.