]> git.pld-linux.org Git - packages/gdal.git/blob - gdal.spec
- release 12 (by relup.sh)
[packages/gdal.git] / gdal.spec
1 # TODO:
2 # - be reasonable about devel dependencies - you do not need all of them to
3 #   use gdal (probably a gdal module or driver shall not imply devel
4 #   dependency)
5 # - rasdaman (--with-rasdaman; http://rasdaman.eecs.jacobs-university.de/trac/rasdaman/wiki/Download)
6 # - libjpeg12 (needs patching to use system one, --with-jpeg12 is not sufficient as of 1.9.2)
7 # - libkml (1.3.0 needed, not released yet)
8 # - wait for newer pcidsk, switch to external again
9 # - csharp, java
10 # - additional, proprietary(?) formats support:
11 #   - FMEObjects (http://www.safe.com/support/support-resources/fme-downloads/)
12 #   - ESRI FileGDBAPI (http://resources.arcgis.com/content/geodatabases/10.0/file-gdb-api)
13 #   - ECW (http://www.erdas.com/products/ecw/ERDASECWJPEG2000SDK/Details.aspx)
14 #   - Kakadu/JPEG2000 (http://www.kakadusoftware.com/)
15 #   - MrSID (http://www.lizardtech.com/developer/)
16 #   - MSG/EUMETSAT (http://www.eumetsat.int/Home/Main/DataAccess/SupportSoftwareTools/index.htm)
17 #   - Oracle/OCI >= 10.0.1 (for georaster); Oracle/OCI >= 8.1.7 (as DB)
18 #   - Ingres (--with-ingres=/path)
19 #   - Informix DB
20 #   - DWGdirect (members only? http://www.opendwg.org/)
21 #   - ESRI SDE (http://www.esri.com/software/arcgis/arcsde/index.html)
22 #
23 # Conditional build:
24 %bcond_without  armadillo       # Armadillo support for faster TPS transform
25 %bcond_without  epsilon         # EPSILON wavelet compression support
26 %bcond_without  gta             # GTA format support
27 %bcond_without  mysql           # MySQL DB support
28 %bcond_without  odbc            # ODBC DB support
29 %bcond_without  opencl          # OpenCL (GPU) support
30 %bcond_without  openjpeg        # OpenJPEG 2 (JPEG2000) support
31 %bcond_with     podofo          # PDF support via podofo instead of poppler
32 %bcond_without  poppler         # PDF support via poppler
33 %bcond_without  spatialite      # SpatiaLite support
34 %bcond_without  xerces          # Xerces support
35 %bcond_without  java            # Java and MDB support
36 %bcond_without  php             # PHP binding
37 %bcond_without  ruby            # Ruby binding
38
39 %if %{with podofo}
40 %undefine       with_poppler
41 %endif
42 Summary:        Geospatial Data Abstraction Library
43 Summary(pl.UTF-8):      Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
44 Name:           gdal
45 Version:        1.9.2
46 Release:        12
47 License:        BSD-like
48 Group:          Libraries
49 Source0:        ftp://ftp.remotesensing.org/gdal/%{name}-%{version}.tar.gz
50 # Source0-md5:  3f39db89f4710269b3a8bf94178e07aa
51 Patch0:         %{name}-perl.patch
52 Patch1:         %{name}-python_install.patch
53 Patch2:         %{name}-php.patch
54 Patch3:         %{name}-fpic.patch
55 Patch4:         %{name}-format-security.patch
56 Patch5:         %{name}-openjpeg2.patch
57 Patch6:         %{name}-hdf4-eos.patch
58 URL:            http://www.gdal.org/
59 %{?with_opencl:BuildRequires:   OpenCL-devel >= 1.0}
60 %{?with_armadillo:BuildRequires:        armadillo-devel}
61 BuildRequires:  autoconf >= 2.52
62 BuildRequires:  automake
63 BuildRequires:  cfitsio-devel
64 BuildRequires:  curl-devel
65 BuildRequires:  doxygen >= 1.4.2
66 %{?with_epsilon:BuildRequires:  epsilon-compressor-devel}
67 BuildRequires:  expat-devel >= 1.95.0
68 BuildRequires:  freexl-devel >= 1.0
69 BuildRequires:  geos-devel >= 2.2.0
70 BuildRequires:  giflib-devel >= 4.0
71 BuildRequires:  hdf-devel >= 4.0
72 BuildRequires:  hdf5-devel
73 BuildRequires:  jasper-devel
74 %{?with_java:BuildRequires:     jdk}
75 %{?with_java:BuildRequires:     jpackage-utils}
76 BuildRequires:  libcsf-devel
77 BuildRequires:  libdap-devel >= 3.10
78 BuildRequires:  libgeotiff-devel >= 1.2.1
79 %{?with_gta:BuildRequires:      libgta-devel}
80 BuildRequires:  libjpeg-devel >= 6b
81 #BuildRequires: libkml-devel >= 1.3.0
82 BuildRequires:  libpng-devel >= 2:1.2.8
83 %{?with_spatialite:BuildRequires:       libspatialite-devel}
84 BuildRequires:  libstdc++-devel
85 BuildRequires:  libtiff-devel >= 4.0
86 BuildRequires:  libtool
87 BuildRequires:  libuuid-devel
88 BuildRequires:  libwebp-devel
89 BuildRequires:  libxml2-devel
90 %{?with_mysql:BuildRequires:    mysql-devel}
91 BuildRequires:  netcdf-devel >= 4.1
92 BuildRequires:  ogdi-devel >= 3.1
93 %{?with_openjpeg:BuildRequires: openjpeg2-devel >= 2.0.0-2}
94 #BuildRequires: pcidsk-devel > 0.3
95 BuildRequires:  perl-devel
96 %{?with_php:BuildRequires:      php-devel}
97 %{?with_podofo:BuildRequires:   podofo-devel}
98 %{?with_poppler:BuildRequires:  poppler-devel}
99 # ensure it's compiled with PQescapeStringConn support
100 BuildRequires:  postgresql-backend-devel >= 8.1.4
101 BuildRequires:  postgresql-devel >= 8.1.4
102 BuildRequires:  proj-devel >= 4
103 BuildRequires:  python-devel >= 1:2.5
104 BuildRequires:  python-numpy-devel >= 1:1.0.0
105 BuildRequires:  python-setuptools
106 BuildRequires:  rpm-pythonprov
107 %{?with_ruby:BuildRequires:     rpm-rubyprov}
108 BuildRequires:  rpmbuild(macros) >= 1.344
109 %{?with_ruby:BuildRequires:     ruby-devel}
110 BuildRequires:  sed >= 4.0
111 BuildRequires:  sqlite3-devel >= 3.0.0
112 BuildRequires:  swig-perl
113 BuildRequires:  swig-python >= 1.3
114 %{?with_ruby:BuildRequires:     swig-ruby}
115 BuildRequires:  texlive-dvips
116 BuildRequires:  texlive-latex
117 %{?with_odbc:BuildRequires:     unixODBC-devel >= 2.2.15}
118 %{?with_xerces:BuildRequires:   xerces-c-devel >= 2.7.0}
119 BuildRequires:  xz-devel
120 BuildRequires:  zlib-devel >= 1.1.4
121 Requires:       freexl >= 1.0
122 Requires:       geos >= 2.2.0
123 Requires:       libgeotiff >= 1.2.1
124 Requires:       libpng >= 2:1.2.8
125 Requires:       libtiff >= 4.0
126 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
127
128 %description
129 GDAL is a translator library for raster geospatial data formats that
130 is released under an Open Source license. As a library, it presents a
131 single abstract data model to the calling application for all
132 supported formats. The related OGR library (which lives within the
133 GDAL source tree) provides a similar capability for simple features
134 vector data.
135
136 %description -l pl.UTF-8
137 GDAL to biblioteka konwertująca między formatami rastrowych danych
138 dotyczących powierzchni Ziemi, udostępniona na licencji Open Source.
139 Jako biblioteka udostępnia aplikacjom jeden abstrakcyjny model danych
140 do wszystkich obsługiwanych formatów. Powiązana z nią biblioteka OGR
141 (której źródła są dołączone do drzewa źródeł GDAL) daje podobne
142 możliwości dla danych wektorowych.
143
144 %package devel
145 Summary:        GDAL library header files
146 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GDAL
147 Group:          Development/Libraries
148 Requires:       %{name} = %{version}-%{release}
149 %{?with_opencl:Requires:        OpenCL-devel >= 1.0}
150 %{?with_armadillo:Requires:     armadillo-devel}
151 Requires:       cfitsio-devel
152 Requires:       curl-devel
153 %{?with_epsilon:Requires:       epsilon-compressor-devel}
154 Requires:       expat-devel >= 1.95.0
155 Requires:       freexl-devel >= 1.0
156 Requires:       geos-devel >= 2.2.0
157 Requires:       giflib-devel >= 4.0
158 Requires:       hdf-devel >= 4.0
159 Requires:       hdf5-devel
160 Requires:       jasper-devel
161 Requires:       libcsf-devel
162 Requires:       libdap-devel >= 3.10
163 Requires:       libgeotiff-devel >= 1.2.1
164 %{?with_gta:Requires:   libgta-devel}
165 Requires:       libjpeg-devel >= 6b
166 Requires:       libpng-devel >= 2:1.2.8
167 %{?with_spatialite:Requires:    libspatialite-devel}
168 Requires:       libstdc++-devel
169 Requires:       libtiff-devel >= 4.0
170 Requires:       libuuid-devel
171 Requires:       libwebp-devel
172 Requires:       libxml2-devel
173 %{?with_mysql:Requires: mysql-devel}
174 Requires:       netcdf-devel >= 4
175 Requires:       ogdi-devel >= 3.1
176 %{?with_openjpeg:Requires:      openjpeg2-devel >= 2.0.0-2}
177 #Requires:      pcidsk-devel > 0.3
178 %{?with_podofo:Requires:        podofo-devel}
179 %{?with_poppler:Requires:       poppler-devel}
180 Requires:       postgresql-devel
181 Requires:       proj-devel >= 4
182 Requires:       sqlite3-devel >= 3.0.0
183 %{?with_odbc:Requires:  unixODBC-devel}
184 %{?with_xerces:Requires:        xerces-c-devel >= 2.7.0}
185 Requires:       xz-devel
186 Requires:       zlib-devel >= 1.1.4
187
188 %description devel
189 GDAL library header files.
190
191 %description devel -l pl.UTF-8
192 Pliki nagłówkowe biblioteki GDAL.
193
194 %package static
195 Summary:        GDAL static libraries
196 Summary(pl.UTF-8):      Statyczne biblioteki GDAL
197 Group:          Development/Libraries
198 Requires:       %{name}-devel = %{version}-%{release}
199
200 %description static
201 GDAL static libraries.
202
203 %description static -l pl.UTF-8
204 Statyczne biblioteki GDAL.
205
206 %package -n perl-gdal
207 Summary:        Perl bindings for GDAL
208 Summary(pl.UTF-8):      Wiązania Perla do pakietu GDAL
209 Group:          Development/Languages/Perl
210 Requires:       %{name} = %{version}-%{release}
211
212 %description -n perl-gdal
213 Perl bindings for GDAL - Geo::GDAL, Geo::OGR and Geo::OSR modules.
214
215 %description -n perl-gdal -l pl.UTF-8
216 Wiązania Perla do pakietu GDAL - moduły Geo::GDAL, Geo::OGR, Geo::OSR.
217
218 %package -n php-gdal
219 Summary:        PHP bindings for GDAL library
220 Summary(pl.UTF-8):      Wiązania PHP do biblioteki GDAL
221 Group:          Development/Languages/PHP
222 Requires:       %{name} = %{version}-%{release}
223 %{?requires_php_extension}
224
225 %description -n php-gdal
226 PHP bindings for GDAL library
227
228 %description -n php-gdal -l pl.UTF-8
229 Wiązania PHP do biblioteki GDAL.
230
231 %package -n python-gdal
232 Summary:        GDAL Python module
233 Summary(pl.UTF-8):      Moduł Pythona GDAL
234 Group:          Libraries/Python
235 Requires:       %{name} = %{version}-%{release}
236 Requires:       python-libs
237
238 %description -n python-gdal
239 GDAL Python module.
240
241 %description -n python-gdal -l pl.UTF-8
242 Moduł Pythona GDAL.
243
244 %package -n ruby-gdal
245 Summary:        Ruby bindings for GDAL
246 Summary(pl.UTF-8):      Wiązania języka Ruby do pakietu GDAL
247 Group:          Development/Languages
248 Requires:       %{name} = %{version}-%{release}
249
250 %description -n ruby-gdal
251 Ruby bindings for GDAL - gdal, gdalconst, ogr and osr modules.
252
253 %description -n ruby-gdal -l pl.UTF-8
254 Wiązania języka Ruby do pakietu GDAL - moduły gdal, gdalconst, ogr i
255 osr.
256
257 %prep
258 %setup -q
259 %patch0 -p1
260 %patch1 -p1
261 %patch2 -p1
262 %patch3 -p1
263 %patch4 -p1
264 %patch5 -p1
265 %patch6 -p1
266
267 # need to regenerate (old ones don't support perl 5.10)
268 %{__rm} swig/perl/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
269
270 # Build with fPIC to allow Ruby bindings
271 # Xcompiler should normally achieve that -- http://trac.osgeo.org/gdal/ticket/3978
272 # http://trac.osgeo.org/gdal/ticket/1994
273 sed -i 's|\$(CFLAGS)|$(CFLAGS) -fPIC|g' swig/ruby/RubyMakefile.mk
274 # Install Ruby bindings to distribution specific directory
275 sed -i 's|RUBY_EXTENSIONS_DIR :=.*|RUBY_EXTENSIONS_DIR := %{ruby_vendorarchdir}|' swig/ruby/RubyMakefile.mk
276
277 # Install Ruby bindings into the proper place
278 sed -i -e 's|^$(INSTALL_DIR):|$(DESTDIR)$(INSTALL_DIR):|' swig/ruby/RubyMakefile.mk
279 sed -i -e 's|^install: $(INSTALL_DIR)|install: $(DESTDIR)$(INSTALL_DIR)|' swig/ruby/RubyMakefile.mk
280
281 %{__rm} -r man
282
283 %{__sed} -i -e 's,DODS_INC="-I.*,DODS_INC="$(pkg-config --cflags libdap)",' configure.in
284
285 %build
286 %{__libtoolize}
287 %{__aclocal} -I m4
288 %{__autoconf}
289 # disable grass/libgrass here, it can be built from separate gdal-grass package
290 %configure \
291         --datadir=%{_datadir}/gdal \
292         --with-dods-root=/usr \
293         %{?with_armadillo:--with-armadillo} \
294         %{?with_epsilon:--with-epsilon} \
295         %{!?with_gta:--without-gta} \
296         --with-hide-internal-symbols \
297         %{?with_java:--with-java=%{java_home}} \
298         --with-liblzma \
299         %{?with_java:--with-mdb --with-jvm-lib-add-rpath} \
300         %{?with_mysql:--with-mysql} \
301         %{?with_opencl:--with-opencl} \
302         --with-perl \
303         %{?with_php:--with-php} \
304         %{?with_podofo:--with-podofo} \
305         %{?with_poppler:--with-poppler} \
306         --with-python \
307         %{?with_ruby:--with-ruby} \
308         %{?with_spatialite:--with-spatialite} \
309         --with-sqlite3 \
310         --with-webp \
311         %{?with_xerces:--with-xerces} \
312         --with-xerces-inc=/usr/include/xercesc \
313         --with-xerces-lib="-lxerces-c" \
314         --without-grass \
315         --without-libgrass
316 #       --with-rasdaman
317 #       --with-pcidsk=/usr (needs > 0.3)
318 # csharp builds, but has no configure option
319
320 # regenerate where needed
321 %{__make} -j1 -C swig/perl generate
322 %if %{with ruby}
323 %{__make} -j1 -C swig/ruby generate
324 %endif
325
326 %{__make} -j1
327
328 %{__make} -j1 docs
329
330 %{__make} -j1 man
331
332 %install
333 rm -rf $RPM_BUILD_ROOT
334
335 %{__make} -j1 install install-man \
336         DESTDIR=$RPM_BUILD_ROOT
337
338 rm -rf _html
339 cp -a html _html
340 cp -a ogr/html _html/ogr
341
342 %if %{with php}
343 # missing in make install
344 install -D swig/php/php_gdal.so $RPM_BUILD_ROOT%{php_extensiondir}/gdal.so
345 install -D swig/php/php_gdalconst.so $RPM_BUILD_ROOT%{php_extensiondir}/gdalconst.so
346 install -D swig/php/php_ogr.so $RPM_BUILD_ROOT%{php_extensiondir}/ogr.so
347 install -D swig/php/php_osr.so $RPM_BUILD_ROOT%{php_extensiondir}/osr.so
348 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
349 cat <<'EOF' >$RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/gdal.ini
350 ; Enable gdal extension module
351 extension=gdal.so
352 extension=gdalconst.so
353 extension=ogr.so
354 extension=osr.so
355 EOF
356 %endif
357
358 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
359 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
360 %py_postclean
361
362 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
363 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/.packlist
364 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/Const/.packlist
365 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OGR/.packlist
366 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OSR/.packlist
367
368 # some doxygen trash
369 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Geo/{GDAL.dox,GDAL/Const.dox,OGR.dox,OSR.dox}
370 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Geo/check_dox.pl
371 %{__rm} $RPM_BUILD_ROOT%{_bindir}/gdal_{fillnodata,sieve}.dox
372
373 %clean
374 rm -rf $RPM_BUILD_ROOT
375
376 %post   -p /sbin/ldconfig
377 %postun -p /sbin/ldconfig
378
379 %files
380 %defattr(644,root,root,755)
381 %doc NEWS PROVENANCE.TXT
382 %attr(755,root,root) %{_bindir}/epsg_tr.py
383 %attr(755,root,root) %{_bindir}/esri2wkt.py
384 %attr(755,root,root) %{_bindir}/gcps2vec.py
385 %attr(755,root,root) %{_bindir}/gcps2wld.py
386 %attr(755,root,root) %{_bindir}/gdal2tiles.py
387 %attr(755,root,root) %{_bindir}/gdal2xyz.py
388 %attr(755,root,root) %{_bindir}/gdal_contour
389 %attr(755,root,root) %{_bindir}/gdal_calc.py
390 %attr(755,root,root) %{_bindir}/gdal_fillnodata.py
391 %attr(755,root,root) %{_bindir}/gdal_grid
392 %attr(755,root,root) %{_bindir}/gdal_merge.py
393 %attr(755,root,root) %{_bindir}/gdal_polygonize.py
394 %attr(755,root,root) %{_bindir}/gdal_proximity.py
395 %attr(755,root,root) %{_bindir}/gdal_rasterize
396 %attr(755,root,root) %{_bindir}/gdal_retile.py
397 %attr(755,root,root) %{_bindir}/gdal_sieve.py
398 %attr(755,root,root) %{_bindir}/gdal_translate
399 %attr(755,root,root) %{_bindir}/gdaladdo
400 %attr(755,root,root) %{_bindir}/gdalbuildvrt
401 %attr(755,root,root) %{_bindir}/gdalchksum.py
402 %attr(755,root,root) %{_bindir}/gdaldem
403 %attr(755,root,root) %{_bindir}/gdalenhance
404 %attr(755,root,root) %{_bindir}/gdalident.py
405 %attr(755,root,root) %{_bindir}/gdalimport.py
406 %attr(755,root,root) %{_bindir}/gdalinfo
407 %attr(755,root,root) %{_bindir}/gdallocationinfo
408 %attr(755,root,root) %{_bindir}/gdalmanage
409 %attr(755,root,root) %{_bindir}/gdalsrsinfo
410 %attr(755,root,root) %{_bindir}/gdaltindex
411 %attr(755,root,root) %{_bindir}/gdaltransform
412 %attr(755,root,root) %{_bindir}/gdalwarp
413 %attr(755,root,root) %{_bindir}/mkgraticule.py
414 %attr(755,root,root) %{_bindir}/nearblack
415 %attr(755,root,root) %{_bindir}/ogr2ogr
416 %attr(755,root,root) %{_bindir}/ogrinfo
417 %attr(755,root,root) %{_bindir}/ogrtindex
418 %attr(755,root,root) %{_bindir}/pct2rgb.py
419 %attr(755,root,root) %{_bindir}/rgb2pct.py
420 %attr(755,root,root) %{_bindir}/testepsg
421 %attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
422 %attr(755,root,root) %ghost %{_libdir}/libgdal.so.1
423 %{_datadir}/gdal
424 %{_mandir}/man1/gdal2tiles.1*
425 %{_mandir}/man1/gdal_contour.1*
426 %{_mandir}/man1/gdal_fillnodata.1*
427 %{_mandir}/man1/gdal_grid.1*
428 %{_mandir}/man1/gdal_merge.1*
429 %{_mandir}/man1/gdal_rasterize.1*
430 %{_mandir}/man1/gdal_retile.1*
431 %{_mandir}/man1/gdal_sieve.1*
432 %{_mandir}/man1/gdal_translate.1*
433 %{_mandir}/man1/gdal_utilities.1*
434 %{_mandir}/man1/gdaladdo.1*
435 %{_mandir}/man1/gdalbuildvrt.1*
436 %{_mandir}/man1/gdaldem.1*
437 %{_mandir}/man1/gdalinfo.1*
438 %{_mandir}/man1/gdallocationinfo.1*
439 %{_mandir}/man1/gdalsrsinfo.1*
440 %{_mandir}/man1/gdaltindex.1*
441 %{_mandir}/man1/gdaltransform.1*
442 %{_mandir}/man1/gdalwarp.1*
443 %{_mandir}/man1/nearblack.1*
444 %{_mandir}/man1/ogr2ogr.1*
445 %{_mandir}/man1/ogr_utilities.1*
446 %{_mandir}/man1/ogrinfo.1*
447 %{_mandir}/man1/ogrtindex.1*
448 %{_mandir}/man1/pct2rgb.1*
449 %{_mandir}/man1/rgb2pct.1*
450
451 %files devel
452 %defattr(644,root,root,755)
453 %doc _html/*
454 %attr(755,root,root) %{_bindir}/gdal-config
455 %attr(755,root,root) %{_libdir}/libgdal.so
456 %{_libdir}/libgdal.la
457 %{_includedir}/cpl_*.h
458 %{_includedir}/cplkeywordparser.h
459 %{_includedir}/gdal*.h
460 %{_includedir}/gvgcpfit.h
461 %{_includedir}/memdataset.h
462 %{_includedir}/ogr_*.h
463 %{_includedir}/ogrsf_frmts.h
464 %{_includedir}/rawdataset.h
465 %{_includedir}/thinplatespline.h
466 %{_includedir}/vrtdataset.h
467 %{_mandir}/man1/gdal-config.1*
468
469 %files static
470 %defattr(644,root,root,755)
471 %{_libdir}/libgdal.a
472
473 %files -n perl-gdal
474 %defattr(644,root,root,755)
475 %dir %{perl_vendorarch}/Geo
476 %{perl_vendorarch}/Geo/GDAL.pm
477 %dir %{perl_vendorarch}/Geo/GDAL
478 %{perl_vendorarch}/Geo/GDAL/Const.pm
479 %{perl_vendorarch}/Geo/OGR.pm
480 %{perl_vendorarch}/Geo/OSR.pm
481 %dir %{perl_vendorarch}/auto/Geo
482 %dir %{perl_vendorarch}/auto/Geo/GDAL
483 %{perl_vendorarch}/auto/Geo/GDAL/GDAL.bs
484 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/GDAL.so
485 %dir %{perl_vendorarch}/auto/Geo/GDAL/Const
486 %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.bs
487 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.so
488 %dir %{perl_vendorarch}/auto/Geo/OGR
489 %{perl_vendorarch}/auto/Geo/OGR/OGR.bs
490 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OGR/OGR.so
491 %dir %{perl_vendorarch}/auto/Geo/OSR
492 %{perl_vendorarch}/auto/Geo/OSR/OSR.bs
493 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OSR/OSR.so
494
495 %if %{with php}
496 %files -n php-gdal
497 %defattr(644,root,root,755)
498 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/gdal.ini
499 %attr(755,root,root) %{php_extensiondir}/gdal.so
500 %attr(755,root,root) %{php_extensiondir}/gdalconst.so
501 %attr(755,root,root) %{php_extensiondir}/ogr.so
502 %attr(755,root,root) %{php_extensiondir}/osr.so
503 %endif
504
505 %files -n python-gdal
506 %defattr(644,root,root,755)
507 %{py_sitedir}/gdal.py[co]
508 %{py_sitedir}/gdalconst.py[co]
509 %{py_sitedir}/gdalnumeric.py[co]
510 %{py_sitedir}/ogr.py[co]
511 %{py_sitedir}/osr.py[co]
512 %{py_sitedir}/GDAL-*.egg-info
513 %dir %{py_sitedir}/osgeo
514 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal.so
515 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal_array.so
516 %attr(755,root,root) %{py_sitedir}/osgeo/_gdalconst.so
517 %attr(755,root,root) %{py_sitedir}/osgeo/_ogr.so
518 %attr(755,root,root) %{py_sitedir}/osgeo/_osr.so
519 %{py_sitedir}/osgeo/*.py[co]
520
521 %if %{with ruby}
522 %files -n ruby-gdal
523 %defattr(644,root,root,755)
524 %dir %{ruby_vendorarchdir}/gdal
525 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/gdal.so
526 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/gdalconst.so
527 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/ogr.so
528 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/osr.so
529 %endif
This page took 0.108927 seconds and 4 git commands to generate.