]> git.pld-linux.org Git - packages/gdal.git/blob - gdal.spec
- updated to 1.11.0
[packages/gdal.git] / gdal.spec
1 # TODO:
2 # - be reasonable about devel dependencies - you do not need all of them to
3 #   use gdal (probably a gdal module or driver shall not imply devel
4 #   dependency)
5 # - rasdaman (--with-rasdaman; http://rasdaman.eecs.jacobs-university.de/trac/rasdaman/wiki/Download)
6 # - libjpeg12 (needs patching to use system one, --with-jpeg12 is not sufficient as of 1.9.2)
7 # - libkml (1.3.0 needed, not released yet)
8 # - wait for newer pcidsk, switch to external again
9 # - csharp, java
10 # - DDS (--with-dds, BR [lib]crunch: http://code.google.com/p/crunch/)
11 # - SOSI (--with-sosi, BR: libfyba libfygm libfyut: https://github.com/kartverket/fyba)
12 # - additional, proprietary(?) formats support:
13 #   - FMEObjects (http://www.safe.com/support/support-resources/fme-downloads/)
14 #   - ESRI FileGDBAPI (http://resources.arcgis.com/content/geodatabases/10.0/file-gdb-api)
15 #   - ECW (http://www.erdas.com/products/ecw/ERDASECWJPEG2000SDK/Details.aspx)
16 #   - Kakadu/JPEG2000 (http://www.kakadusoftware.com/)
17 #   - MrSID (http://www.lizardtech.com/developer/)
18 #   - MSG/EUMETSAT (http://www.eumetsat.int/Home/Main/DataAccess/SupportSoftwareTools/index.htm)
19 #   - Oracle/OCI >= 10.0.1 (for georaster); Oracle/OCI >= 8.1.7 (as DB)
20 #   - Ingres (--with-ingres=/path)
21 #   - Informix DB (--with-idb)
22 #   - DWGdirect (members only? http://www.opendwg.org/)
23 #   - ESRI SDE (http://www.esri.com/software/arcgis/arcsde/index.html)
24 #
25 # Conditional build:
26 %bcond_without  armadillo       # Armadillo support for faster TPS transform
27 %bcond_without  epsilon         # EPSILON wavelet compression support
28 %bcond_with     grass           # GRASS support (note: dependency loop)
29 %bcond_without  gta             # GTA format support
30 %bcond_without  mysql           # MySQL DB support
31 %bcond_with     oci             # ORACLE OCI DB and Georaster support
32 %bcond_without  odbc            # ODBC DB support
33 %bcond_without  opencl          # OpenCL (GPU) support
34 %bcond_without  openjpeg        # OpenJPEG 2 (JPEG2000) support
35 %bcond_with     podofo          # PDF support via podofo instead of poppler
36 %bcond_without  poppler         # PDF support via poppler
37 %bcond_without  spatialite      # SpatiaLite support
38 %bcond_without  xerces          # Xerces support
39 %bcond_without  java            # Java and MDB support
40 %bcond_without  php             # PHP binding
41 %bcond_without  ruby            # Ruby binding
42
43 %if %{with podofo}
44 %undefine       with_poppler
45 %endif
46 Summary:        Geospatial Data Abstraction Library
47 Summary(pl.UTF-8):      Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
48 Name:           gdal
49 Version:        1.11.0
50 Release:        1
51 License:        BSD-like
52 Group:          Libraries
53 Source0:        http://download.osgeo.org/gdal/%{version}/%{name}-%{version}.tar.xz
54 # Source0-md5:  31f2c4a7230b40e5fdc3cf12a100f96b
55 Patch0:         %{name}-perl.patch
56 Patch1:         %{name}-python_install.patch
57 Patch2:         %{name}-php.patch
58 Patch3:         %{name}-fpic.patch
59 Patch4:         %{name}-format-security.patch
60 Patch5:         %{name}-grass.patch
61 Patch6:         %{name}-sse.patch
62 Patch7:         %{name}-link.patch
63 URL:            http://www.gdal.org/
64 %{?with_opencl:BuildRequires:   OpenCL-devel >= 1.0}
65 %{?with_armadillo:BuildRequires:        armadillo-devel}
66 BuildRequires:  autoconf >= 2.52
67 BuildRequires:  automake
68 BuildRequires:  cfitsio-devel
69 BuildRequires:  curl-devel
70 BuildRequires:  doxygen >= 1.4.2
71 %{?with_epsilon:BuildRequires:  epsilon-compressor-devel}
72 BuildRequires:  expat-devel >= 1.95.0
73 BuildRequires:  freexl-devel >= 1.0
74 BuildRequires:  gcc >= 6:4.1
75 BuildRequires:  geos-devel >= 3.1.0
76 BuildRequires:  giflib-devel >= 4.0
77 %{?with_grass:BuildRequires:    grass-devel >= 5.7}
78 BuildRequires:  hdf-devel >= 4.0
79 BuildRequires:  hdf5-devel
80 BuildRequires:  jasper-devel
81 %{?with_java:BuildRequires:     jdk}
82 %{?with_java:BuildRequires:     jpackage-utils}
83 BuildRequires:  json-c-devel >= 0.11
84 BuildRequires:  libcsf-devel
85 BuildRequires:  libdap-devel >= 3.10
86 BuildRequires:  libgeotiff-devel >= 1.2.1
87 %{?with_gta:BuildRequires:      libgta-devel}
88 BuildRequires:  libjpeg-devel >= 6b
89 #BuildRequires: libkml-devel >= 1.3.0
90 BuildRequires:  libpng-devel >= 2:1.2.8
91 %{?with_spatialite:BuildRequires:       libspatialite-devel}
92 BuildRequires:  libstdc++-devel
93 BuildRequires:  libtiff-devel >= 4.0
94 BuildRequires:  libtool
95 BuildRequires:  libuuid-devel
96 BuildRequires:  libwebp-devel
97 BuildRequires:  libxml2-devel >= 2
98 %{?with_mysql:BuildRequires:    mysql-devel}
99 BuildRequires:  netcdf-devel >= 4.1
100 BuildRequires:  ogdi-devel >= 3.1
101 %{?with_openjpeg:BuildRequires: openjpeg2-devel >= 2.0.0-2}
102 # 8.1.7 for DB support, 10.0.1 for georaster
103 %{?with_oci:BuildRequires:      oracle-instantclient-devel >= 10.0.1}
104 #BuildRequires: pcidsk-devel > 0.3
105 BuildRequires:  perl-devel
106 %{?with_php:BuildRequires:      php-devel}
107 %{?with_podofo:BuildRequires:   podofo-devel}
108 %{?with_poppler:BuildRequires:  poppler-devel >= 0.24}
109 # ensure it's compiled with PQescapeStringConn support
110 BuildRequires:  postgresql-backend-devel >= 8.1.4
111 BuildRequires:  postgresql-devel >= 8.1.4
112 BuildRequires:  proj-devel >= 4
113 BuildRequires:  python-devel >= 1:2.5
114 BuildRequires:  python-numpy-devel >= 1:1.0.0
115 BuildRequires:  python-setuptools
116 BuildRequires:  rpm-pythonprov
117 %{?with_ruby:BuildRequires:     rpm-rubyprov}
118 BuildRequires:  rpmbuild(macros) >= 1.344
119 %{?with_ruby:BuildRequires:     ruby-devel}
120 BuildRequires:  sed >= 4.0
121 BuildRequires:  sqlite3-devel >= 3.0.0
122 BuildRequires:  swig-perl
123 BuildRequires:  swig-php >= 2.0.12-2
124 BuildRequires:  swig-python >= 1.3
125 %{?with_ruby:BuildRequires:     swig-ruby}
126 BuildRequires:  texlive-dvips
127 BuildRequires:  texlive-latex
128 %{?with_odbc:BuildRequires:     unixODBC-devel >= 2.2.15}
129 %{?with_xerces:BuildRequires:   xerces-c-devel >= 2.7.0}
130 BuildRequires:  xz-devel
131 BuildRequires:  zlib-devel >= 1.1.4
132 Requires:       freexl >= 1.0
133 Requires:       geos >= 3.1.0
134 Requires:       libgeotiff >= 1.2.1
135 Requires:       libpng >= 2:1.2.8
136 Requires:       libtiff >= 4.0
137 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
138
139 %description
140 GDAL is a translator library for raster geospatial data formats that
141 is released under an Open Source license. As a library, it presents a
142 single abstract data model to the calling application for all
143 supported formats. The related OGR library (which lives within the
144 GDAL source tree) provides a similar capability for simple features
145 vector data.
146
147 %description -l pl.UTF-8
148 GDAL to biblioteka konwertująca między formatami rastrowych danych
149 dotyczących powierzchni Ziemi, udostępniona na licencji Open Source.
150 Jako biblioteka udostępnia aplikacjom jeden abstrakcyjny model danych
151 do wszystkich obsługiwanych formatów. Powiązana z nią biblioteka OGR
152 (której źródła są dołączone do drzewa źródeł GDAL) daje podobne
153 możliwości dla danych wektorowych.
154
155 %package devel
156 Summary:        GDAL library header files
157 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GDAL
158 Group:          Development/Libraries
159 Requires:       %{name} = %{version}-%{release}
160 %{?with_opencl:Requires:        OpenCL-devel >= 1.0}
161 %{?with_armadillo:Requires:     armadillo-devel}
162 Requires:       cfitsio-devel
163 Requires:       curl-devel
164 %{?with_epsilon:Requires:       epsilon-compressor-devel}
165 Requires:       expat-devel >= 1.95.0
166 Requires:       freexl-devel >= 1.0
167 Requires:       geos-devel >= 3.1.0
168 Requires:       giflib-devel >= 4.0
169 Requires:       hdf-devel >= 4.0
170 Requires:       hdf5-devel
171 Requires:       jasper-devel
172 Requires:       json-c-devel >= 0.11
173 Requires:       libcsf-devel
174 Requires:       libdap-devel >= 3.10
175 Requires:       libgeotiff-devel >= 1.2.1
176 %{?with_gta:Requires:   libgta-devel}
177 Requires:       libjpeg-devel >= 6b
178 Requires:       libpng-devel >= 2:1.2.8
179 %{?with_spatialite:Requires:    libspatialite-devel}
180 Requires:       libstdc++-devel
181 Requires:       libtiff-devel >= 4.0
182 Requires:       libuuid-devel
183 Requires:       libwebp-devel
184 Requires:       libxml2-devel >= 2
185 %{?with_mysql:Requires: mysql-devel}
186 Requires:       netcdf-devel >= 4
187 Requires:       ogdi-devel >= 3.1
188 %{?with_openjpeg:Requires:      openjpeg2-devel >= 2.0.0-2}
189 #Requires:      pcidsk-devel > 0.3
190 %{?with_podofo:Requires:        podofo-devel}
191 %{?with_poppler:Requires:       poppler-devel >= 0.24}
192 Requires:       postgresql-devel
193 Requires:       proj-devel >= 4
194 Requires:       sqlite3-devel >= 3.0.0
195 %{?with_odbc:Requires:  unixODBC-devel}
196 %{?with_xerces:Requires:        xerces-c-devel >= 2.7.0}
197 Requires:       xz-devel
198 Requires:       zlib-devel >= 1.1.4
199
200 %description devel
201 GDAL library header files.
202
203 %description devel -l pl.UTF-8
204 Pliki nagłówkowe biblioteki GDAL.
205
206 %package static
207 Summary:        GDAL static libraries
208 Summary(pl.UTF-8):      Statyczne biblioteki GDAL
209 Group:          Development/Libraries
210 Requires:       %{name}-devel = %{version}-%{release}
211
212 %description static
213 GDAL static libraries.
214
215 %description static -l pl.UTF-8
216 Statyczne biblioteki GDAL.
217
218 %package -n perl-gdal
219 Summary:        Perl bindings for GDAL
220 Summary(pl.UTF-8):      Wiązania Perla do pakietu GDAL
221 Group:          Development/Languages/Perl
222 Requires:       %{name} = %{version}-%{release}
223
224 %description -n perl-gdal
225 Perl bindings for GDAL - Geo::GDAL, Geo::OGR and Geo::OSR modules.
226
227 %description -n perl-gdal -l pl.UTF-8
228 Wiązania Perla do pakietu GDAL - moduły Geo::GDAL, Geo::OGR, Geo::OSR.
229
230 %package -n php-gdal
231 Summary:        PHP bindings for GDAL library
232 Summary(pl.UTF-8):      Wiązania PHP do biblioteki GDAL
233 Group:          Development/Languages/PHP
234 Requires:       %{name} = %{version}-%{release}
235 %{?requires_php_extension}
236
237 %description -n php-gdal
238 PHP bindings for GDAL library
239
240 %description -n php-gdal -l pl.UTF-8
241 Wiązania PHP do biblioteki GDAL.
242
243 %package -n python-gdal
244 Summary:        GDAL Python module
245 Summary(pl.UTF-8):      Moduł Pythona GDAL
246 Group:          Libraries/Python
247 Requires:       %{name} = %{version}-%{release}
248 Requires:       python-libs
249
250 %description -n python-gdal
251 GDAL Python module.
252
253 %description -n python-gdal -l pl.UTF-8
254 Moduł Pythona GDAL.
255
256 %package -n ruby-gdal
257 Summary:        Ruby bindings for GDAL
258 Summary(pl.UTF-8):      Wiązania języka Ruby do pakietu GDAL
259 Group:          Development/Languages
260 Requires:       %{name} = %{version}-%{release}
261
262 %description -n ruby-gdal
263 Ruby bindings for GDAL - gdal, gdalconst, ogr and osr modules.
264
265 %description -n ruby-gdal -l pl.UTF-8
266 Wiązania języka Ruby do pakietu GDAL - moduły gdal, gdalconst, ogr i
267 osr.
268
269 %prep
270 %setup -q
271 %patch0 -p1
272 %patch1 -p1
273 %patch2 -p1
274 %patch3 -p1
275 %patch4 -p1
276 %patch5 -p1
277 %patch6 -p1
278 %patch7 -p1
279
280 # need to regenerate (old ones don't support perl 5.10 or php 5.5)
281 %{__rm} swig/{perl,php}/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
282
283 %{__sed} -i \
284         -e 's/^CC=gcc/CC=%{__cc}/' \
285         -e 's/^CXX=g++/CXX=%{__cxx}/' \
286         -e 's/^CFLAGS=-fpic/CFLAGS=%{rpmcflags} -fPIC/' \
287         -e 's/^LDFLAGS=-shared/LDFLAGS=%{rpmldflags} -shared/' \
288         swig/php/GNUmakefile
289 # Build with fPIC to allow Ruby bindings
290 # Xcompiler should normally achieve that -- http://trac.osgeo.org/gdal/ticket/3978
291 # http://trac.osgeo.org/gdal/ticket/1994
292 sed -i 's|\$(CFLAGS)|$(CFLAGS) -fPIC|g' swig/ruby/RubyMakefile.mk
293 # Install Ruby bindings to distribution specific directory
294 sed -i 's|RUBY_EXTENSIONS_DIR :=.*|RUBY_EXTENSIONS_DIR := %{ruby_vendorarchdir}|' swig/ruby/RubyMakefile.mk
295
296 # Install Ruby bindings into the proper place
297 sed -i -e 's|^$(INSTALL_DIR):|$(DESTDIR)$(INSTALL_DIR):|' swig/ruby/RubyMakefile.mk
298 sed -i -e 's|^install: $(INSTALL_DIR)|install: $(DESTDIR)$(INSTALL_DIR)|' swig/ruby/RubyMakefile.mk
299
300 # our man path
301 sed -i -e 's#^mandir=.*##g' configure.in
302
303 %{__rm} -r man
304
305 %{__sed} -i -e 's,DODS_INC="-I.*,DODS_INC="$(pkg-config --cflags libdap)",' configure.in
306
307 %build
308 %{__libtoolize}
309 %{__aclocal} -I m4
310 %{__autoconf}
311 # disable grass/libgrass here, it can be built from separate gdal-grass package
312 %configure \
313         --datadir=%{_datadir}/gdal \
314         --with-dods-root=/usr \
315         %{?with_armadillo:--with-armadillo} \
316         %{?with_epsilon:--with-epsilon} \
317         %{?with_grass:--with-grass} \
318         %{!?with_gta:--without-gta} \
319         --with-hide-internal-symbols \
320         %{?with_java:--with-java=%{java_home}} \
321         --with-liblzma \
322         %{?with_java:--with-mdb --with-jvm-lib-add-rpath} \
323         %{?with_mysql:--with-mysql} \
324         %{?with_oci:--with-oci --with-oci-include=/usr/include/oracle/client --with-oci-lib=%{_libdir}} \
325         %{?with_opencl:--with-opencl} \
326         --with-perl \
327         %{?with_php:--with-php} \
328         %{?with_podofo:--with-podofo} \
329         %{?with_poppler:--with-poppler} \
330         --with-python \
331         %{?with_ruby:--with-ruby} \
332         %{?with_spatialite:--with-spatialite} \
333         --with-sqlite3 \
334         --with-webp \
335         %{?with_xerces:--with-xerces} \
336         --with-xerces-inc=/usr/include/xercesc \
337         --with-xerces-lib="-lxerces-c" \
338         --without-libgrass
339 #       --with-rasdaman
340 #       --with-pcidsk=/usr (needs > 0.3)
341 # csharp builds, but has no configure option
342
343 # regenerate where needed
344 %{__make} -j1 -C swig/perl generate
345 %if %{with ruby}
346 %{__make} -j1 -C swig/ruby generate
347 %endif
348
349 %{__make} -j1
350
351 %{__make} -j1 docs
352
353 %{__make} -j1 man
354
355 %install
356 rm -rf $RPM_BUILD_ROOT
357
358 %{__make} -j1 install install-man \
359         DESTDIR=$RPM_BUILD_ROOT
360
361 rm -rf _html
362 cp -a html _html
363 cp -a ogr/html _html/ogr
364
365 %if %{with php}
366 # missing in make install
367 install -D swig/php/php_gdal.so $RPM_BUILD_ROOT%{php_extensiondir}/gdal.so
368 install -D swig/php/php_gdalconst.so $RPM_BUILD_ROOT%{php_extensiondir}/gdalconst.so
369 install -D swig/php/php_ogr.so $RPM_BUILD_ROOT%{php_extensiondir}/ogr.so
370 install -D swig/php/php_osr.so $RPM_BUILD_ROOT%{php_extensiondir}/osr.so
371 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
372 cat <<'EOF' >$RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/gdal.ini
373 ; Enable gdal extension module
374 extension=gdal.so
375 extension=gdalconst.so
376 extension=ogr.so
377 extension=osr.so
378 EOF
379 %endif
380
381 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
382 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
383 %py_postclean
384
385 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
386 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/.packlist
387 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/Const/.packlist
388 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OGR/.packlist
389 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OSR/.packlist
390
391 # some doxygen trash
392 %{__rm} $RPM_BUILD_ROOT%{_bindir}/gdal{compare,move}.dox
393 %{__rm} $RPM_BUILD_ROOT%{_bindir}/gdal_{calc,edit,fillnodata,polygonize,proximity,sieve}.dox
394
395 %clean
396 rm -rf $RPM_BUILD_ROOT
397
398 %post   -p /sbin/ldconfig
399 %postun -p /sbin/ldconfig
400
401 %files
402 %defattr(644,root,root,755)
403 %doc NEWS PROVENANCE.TXT
404 %attr(755,root,root) %{_bindir}/epsg_tr.py
405 %attr(755,root,root) %{_bindir}/esri2wkt.py
406 %attr(755,root,root) %{_bindir}/gcps2vec.py
407 %attr(755,root,root) %{_bindir}/gcps2wld.py
408 %attr(755,root,root) %{_bindir}/gdal2tiles.py
409 %attr(755,root,root) %{_bindir}/gdal2xyz.py
410 %attr(755,root,root) %{_bindir}/gdal_auth.py
411 %attr(755,root,root) %{_bindir}/gdal_contour
412 %attr(755,root,root) %{_bindir}/gdal_calc.py
413 %attr(755,root,root) %{_bindir}/gdal_edit.py
414 %attr(755,root,root) %{_bindir}/gdal_fillnodata.py
415 %attr(755,root,root) %{_bindir}/gdal_grid
416 %attr(755,root,root) %{_bindir}/gdal_merge.py
417 %attr(755,root,root) %{_bindir}/gdal_polygonize.py
418 %attr(755,root,root) %{_bindir}/gdal_proximity.py
419 %attr(755,root,root) %{_bindir}/gdal_rasterize
420 %attr(755,root,root) %{_bindir}/gdal_retile.py
421 %attr(755,root,root) %{_bindir}/gdal_sieve.py
422 %attr(755,root,root) %{_bindir}/gdal_translate
423 %attr(755,root,root) %{_bindir}/gdaladdo
424 %attr(755,root,root) %{_bindir}/gdalbuildvrt
425 %attr(755,root,root) %{_bindir}/gdalchksum.py
426 %attr(755,root,root) %{_bindir}/gdalcompare.py
427 %attr(755,root,root) %{_bindir}/gdaldem
428 %attr(755,root,root) %{_bindir}/gdalenhance
429 %attr(755,root,root) %{_bindir}/gdalident.py
430 %attr(755,root,root) %{_bindir}/gdalimport.py
431 %attr(755,root,root) %{_bindir}/gdalinfo
432 %attr(755,root,root) %{_bindir}/gdallocationinfo
433 %attr(755,root,root) %{_bindir}/gdalmanage
434 %attr(755,root,root) %{_bindir}/gdalmove.py
435 %attr(755,root,root) %{_bindir}/gdalserver
436 %attr(755,root,root) %{_bindir}/gdalsrsinfo
437 %attr(755,root,root) %{_bindir}/gdaltindex
438 %attr(755,root,root) %{_bindir}/gdaltransform
439 %attr(755,root,root) %{_bindir}/gdalwarp
440 %attr(755,root,root) %{_bindir}/mkgraticule.py
441 %attr(755,root,root) %{_bindir}/nearblack
442 %attr(755,root,root) %{_bindir}/ogr2ogr
443 %attr(755,root,root) %{_bindir}/ogrinfo
444 %attr(755,root,root) %{_bindir}/ogrlineref
445 %attr(755,root,root) %{_bindir}/ogrtindex
446 %attr(755,root,root) %{_bindir}/pct2rgb.py
447 %attr(755,root,root) %{_bindir}/rgb2pct.py
448 %attr(755,root,root) %{_bindir}/testepsg
449 %attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
450 %attr(755,root,root) %ghost %{_libdir}/libgdal.so.1
451 %{_datadir}/gdal
452 %{_mandir}/man1/gdal2tiles.1*
453 %{_mandir}/man1/gdal_calc.1*
454 %{_mandir}/man1/gdal_contour.1*
455 %{_mandir}/man1/gdal_edit.1*
456 %{_mandir}/man1/gdal_fillnodata.1*
457 %{_mandir}/man1/gdal_grid.1*
458 %{_mandir}/man1/gdal_merge.1*
459 %{_mandir}/man1/gdal_polygonize.1*
460 %{_mandir}/man1/gdal_proximity.1*
461 %{_mandir}/man1/gdal_rasterize.1*
462 %{_mandir}/man1/gdal_retile.1*
463 %{_mandir}/man1/gdal_sieve.1*
464 %{_mandir}/man1/gdal_translate.1*
465 %{_mandir}/man1/gdal_utilities.1*
466 %{_mandir}/man1/gdaladdo.1*
467 %{_mandir}/man1/gdalbuildvrt.1*
468 %{_mandir}/man1/gdalcompare.1*
469 %{_mandir}/man1/gdaldem.1*
470 %{_mandir}/man1/gdalinfo.1*
471 %{_mandir}/man1/gdallocationinfo.1*
472 %{_mandir}/man1/gdalmanage.1*
473 %{_mandir}/man1/gdalmove.1*
474 %{_mandir}/man1/gdalsrsinfo.1*
475 %{_mandir}/man1/gdaltindex.1*
476 %{_mandir}/man1/gdaltransform.1*
477 %{_mandir}/man1/gdalwarp.1*
478 %{_mandir}/man1/nearblack.1*
479 %{_mandir}/man1/ogr2ogr.1*
480 %{_mandir}/man1/ogr_utilities.1*
481 %{_mandir}/man1/ogrinfo.1*
482 %{_mandir}/man1/ogrlineref.1*
483 %{_mandir}/man1/ogrtindex.1*
484 %{_mandir}/man1/pct2rgb.1*
485 %{_mandir}/man1/rgb2pct.1*
486
487 %files devel
488 %defattr(644,root,root,755)
489 %doc _html/*
490 %attr(755,root,root) %{_bindir}/gdal-config
491 %attr(755,root,root) %{_libdir}/libgdal.so
492 %{_libdir}/libgdal.la
493 %{_pkgconfigdir}/gdal.pc
494 %{_includedir}/cpl_*.h
495 %{_includedir}/cplkeywordparser.h
496 %{_includedir}/gdal*.h
497 %{_includedir}/gvgcpfit.h
498 %{_includedir}/memdataset.h
499 %{_includedir}/ogr_*.h
500 %{_includedir}/ogrsf_frmts.h
501 %{_includedir}/rawdataset.h
502 %{_includedir}/thinplatespline.h
503 %{_includedir}/vrtdataset.h
504 %{_mandir}/man1/gdal-config.1*
505
506 %files static
507 %defattr(644,root,root,755)
508 %{_libdir}/libgdal.a
509
510 %files -n perl-gdal
511 %defattr(644,root,root,755)
512 %dir %{perl_vendorarch}/Geo
513 %{perl_vendorarch}/Geo/GDAL.pm
514 %dir %{perl_vendorarch}/Geo/GDAL
515 %{perl_vendorarch}/Geo/GDAL/Const.pm
516 %{perl_vendorarch}/Geo/OGR.pm
517 %{perl_vendorarch}/Geo/OSR.pm
518 %dir %{perl_vendorarch}/auto/Geo
519 %dir %{perl_vendorarch}/auto/Geo/GDAL
520 %{perl_vendorarch}/auto/Geo/GDAL/GDAL.bs
521 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/GDAL.so
522 %dir %{perl_vendorarch}/auto/Geo/GDAL/Const
523 %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.bs
524 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.so
525 %dir %{perl_vendorarch}/auto/Geo/OGR
526 %{perl_vendorarch}/auto/Geo/OGR/OGR.bs
527 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OGR/OGR.so
528 %dir %{perl_vendorarch}/auto/Geo/OSR
529 %{perl_vendorarch}/auto/Geo/OSR/OSR.bs
530 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OSR/OSR.so
531
532 %if %{with php}
533 %files -n php-gdal
534 %defattr(644,root,root,755)
535 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/gdal.ini
536 %attr(755,root,root) %{php_extensiondir}/gdal.so
537 %attr(755,root,root) %{php_extensiondir}/gdalconst.so
538 %attr(755,root,root) %{php_extensiondir}/ogr.so
539 %attr(755,root,root) %{php_extensiondir}/osr.so
540 %endif
541
542 %files -n python-gdal
543 %defattr(644,root,root,755)
544 %{py_sitedir}/gdal.py[co]
545 %{py_sitedir}/gdalconst.py[co]
546 %{py_sitedir}/gdalnumeric.py[co]
547 %{py_sitedir}/ogr.py[co]
548 %{py_sitedir}/osr.py[co]
549 %{py_sitedir}/GDAL-*.egg-info
550 %dir %{py_sitedir}/osgeo
551 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal.so
552 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal_array.so
553 %attr(755,root,root) %{py_sitedir}/osgeo/_gdalconst.so
554 %attr(755,root,root) %{py_sitedir}/osgeo/_ogr.so
555 %attr(755,root,root) %{py_sitedir}/osgeo/_osr.so
556 %{py_sitedir}/osgeo/*.py[co]
557
558 %if %{with ruby}
559 %files -n ruby-gdal
560 %defattr(644,root,root,755)
561 %dir %{ruby_vendorarchdir}/gdal
562 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/gdal.so
563 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/gdalconst.so
564 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/ogr.so
565 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/osr.so
566 %endif
This page took 0.061779 seconds and 4 git commands to generate.