]> git.pld-linux.org Git - packages/gdal.git/blob - gdal.spec
- added poppler patch (fixes build with poppler 0.24+)
[packages/gdal.git] / gdal.spec
1 # TODO:
2 # - be reasonable about devel dependencies - you do not need all of them to
3 #   use gdal (probably a gdal module or driver shall not imply devel
4 #   dependency)
5 # - rasdaman (--with-rasdaman; http://rasdaman.eecs.jacobs-university.de/trac/rasdaman/wiki/Download)
6 # - libjpeg12 (needs patching to use system one, --with-jpeg12 is not sufficient as of 1.9.2)
7 # - libkml (1.3.0 needed, not released yet)
8 # - wait for newer pcidsk, switch to external again
9 # - csharp, java
10 # - additional, proprietary(?) formats support:
11 #   - FMEObjects (http://www.safe.com/support/support-resources/fme-downloads/)
12 #   - ESRI FileGDBAPI (http://resources.arcgis.com/content/geodatabases/10.0/file-gdb-api)
13 #   - ECW (http://www.erdas.com/products/ecw/ERDASECWJPEG2000SDK/Details.aspx)
14 #   - Kakadu/JPEG2000 (http://www.kakadusoftware.com/)
15 #   - MrSID (http://www.lizardtech.com/developer/)
16 #   - MSG/EUMETSAT (http://www.eumetsat.int/Home/Main/DataAccess/SupportSoftwareTools/index.htm)
17 #   - Oracle/OCI >= 10.0.1 (for georaster); Oracle/OCI >= 8.1.7 (as DB)
18 #   - Ingres (--with-ingres=/path)
19 #   - Informix DB
20 #   - DWGdirect (members only? http://www.opendwg.org/)
21 #   - ESRI SDE (http://www.esri.com/software/arcgis/arcsde/index.html)
22 #
23 # Conditional build:
24 %bcond_without  armadillo       # Armadillo support for faster TPS transform
25 %bcond_without  epsilon         # EPSILON wavelet compression support
26 %bcond_without  gta             # GTA format support
27 %bcond_without  mysql           # MySQL DB support
28 %bcond_without  odbc            # ODBC DB support
29 %bcond_without  opencl          # OpenCL (GPU) support
30 %bcond_without  openjpeg        # OpenJPEG 2 (JPEG2000) support
31 %bcond_with     podofo          # PDF support via podofo instead of poppler
32 %bcond_without  poppler         # PDF support via poppler
33 %bcond_without  spatialite      # SpatiaLite support
34 %bcond_without  xerces          # Xerces support
35 %bcond_without  java            # Java and MDB support
36 %bcond_without  php             # PHP binding
37 %bcond_without  ruby            # Ruby binding
38
39 %if %{with podofo}
40 %undefine       with_poppler
41 %endif
42 Summary:        Geospatial Data Abstraction Library
43 Summary(pl.UTF-8):      Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
44 Name:           gdal
45 Version:        1.9.2
46 Release:        12
47 License:        BSD-like
48 Group:          Libraries
49 Source0:        ftp://ftp.remotesensing.org/gdal/%{name}-%{version}.tar.gz
50 # Source0-md5:  3f39db89f4710269b3a8bf94178e07aa
51 Patch0:         %{name}-perl.patch
52 Patch1:         %{name}-python_install.patch
53 Patch2:         %{name}-php.patch
54 Patch3:         %{name}-fpic.patch
55 Patch4:         %{name}-format-security.patch
56 Patch5:         %{name}-openjpeg2.patch
57 Patch6:         %{name}-hdf4-eos.patch
58 Patch7:         %{name}-poppler.patch
59 URL:            http://www.gdal.org/
60 %{?with_opencl:BuildRequires:   OpenCL-devel >= 1.0}
61 %{?with_armadillo:BuildRequires:        armadillo-devel}
62 BuildRequires:  autoconf >= 2.52
63 BuildRequires:  automake
64 BuildRequires:  cfitsio-devel
65 BuildRequires:  curl-devel
66 BuildRequires:  doxygen >= 1.4.2
67 %{?with_epsilon:BuildRequires:  epsilon-compressor-devel}
68 BuildRequires:  expat-devel >= 1.95.0
69 BuildRequires:  freexl-devel >= 1.0
70 BuildRequires:  geos-devel >= 2.2.0
71 BuildRequires:  giflib-devel >= 4.0
72 BuildRequires:  hdf-devel >= 4.0
73 BuildRequires:  hdf5-devel
74 BuildRequires:  jasper-devel
75 %{?with_java:BuildRequires:     jdk}
76 %{?with_java:BuildRequires:     jpackage-utils}
77 BuildRequires:  libcsf-devel
78 BuildRequires:  libdap-devel >= 3.10
79 BuildRequires:  libgeotiff-devel >= 1.2.1
80 %{?with_gta:BuildRequires:      libgta-devel}
81 BuildRequires:  libjpeg-devel >= 6b
82 #BuildRequires: libkml-devel >= 1.3.0
83 BuildRequires:  libpng-devel >= 2:1.2.8
84 %{?with_spatialite:BuildRequires:       libspatialite-devel}
85 BuildRequires:  libstdc++-devel
86 BuildRequires:  libtiff-devel >= 4.0
87 BuildRequires:  libtool
88 BuildRequires:  libuuid-devel
89 BuildRequires:  libwebp-devel
90 BuildRequires:  libxml2-devel
91 %{?with_mysql:BuildRequires:    mysql-devel}
92 BuildRequires:  netcdf-devel >= 4.1
93 BuildRequires:  ogdi-devel >= 3.1
94 %{?with_openjpeg:BuildRequires: openjpeg2-devel >= 2.0.0-2}
95 #BuildRequires: pcidsk-devel > 0.3
96 BuildRequires:  perl-devel
97 %{?with_php:BuildRequires:      php-devel}
98 %{?with_podofo:BuildRequires:   podofo-devel}
99 %{?with_poppler:BuildRequires:  poppler-devel >= 0.24}
100 # ensure it's compiled with PQescapeStringConn support
101 BuildRequires:  postgresql-backend-devel >= 8.1.4
102 BuildRequires:  postgresql-devel >= 8.1.4
103 BuildRequires:  proj-devel >= 4
104 BuildRequires:  python-devel >= 1:2.5
105 BuildRequires:  python-numpy-devel >= 1:1.0.0
106 BuildRequires:  python-setuptools
107 BuildRequires:  rpm-pythonprov
108 %{?with_ruby:BuildRequires:     rpm-rubyprov}
109 BuildRequires:  rpmbuild(macros) >= 1.344
110 %{?with_ruby:BuildRequires:     ruby-devel}
111 BuildRequires:  sed >= 4.0
112 BuildRequires:  sqlite3-devel >= 3.0.0
113 BuildRequires:  swig-perl
114 BuildRequires:  swig-python >= 1.3
115 %{?with_ruby:BuildRequires:     swig-ruby}
116 BuildRequires:  texlive-dvips
117 BuildRequires:  texlive-latex
118 %{?with_odbc:BuildRequires:     unixODBC-devel >= 2.2.15}
119 %{?with_xerces:BuildRequires:   xerces-c-devel >= 2.7.0}
120 BuildRequires:  xz-devel
121 BuildRequires:  zlib-devel >= 1.1.4
122 Requires:       freexl >= 1.0
123 Requires:       geos >= 2.2.0
124 Requires:       libgeotiff >= 1.2.1
125 Requires:       libpng >= 2:1.2.8
126 Requires:       libtiff >= 4.0
127 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
128
129 %description
130 GDAL is a translator library for raster geospatial data formats that
131 is released under an Open Source license. As a library, it presents a
132 single abstract data model to the calling application for all
133 supported formats. The related OGR library (which lives within the
134 GDAL source tree) provides a similar capability for simple features
135 vector data.
136
137 %description -l pl.UTF-8
138 GDAL to biblioteka konwertująca między formatami rastrowych danych
139 dotyczących powierzchni Ziemi, udostępniona na licencji Open Source.
140 Jako biblioteka udostępnia aplikacjom jeden abstrakcyjny model danych
141 do wszystkich obsługiwanych formatów. Powiązana z nią biblioteka OGR
142 (której źródła są dołączone do drzewa źródeł GDAL) daje podobne
143 możliwości dla danych wektorowych.
144
145 %package devel
146 Summary:        GDAL library header files
147 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GDAL
148 Group:          Development/Libraries
149 Requires:       %{name} = %{version}-%{release}
150 %{?with_opencl:Requires:        OpenCL-devel >= 1.0}
151 %{?with_armadillo:Requires:     armadillo-devel}
152 Requires:       cfitsio-devel
153 Requires:       curl-devel
154 %{?with_epsilon:Requires:       epsilon-compressor-devel}
155 Requires:       expat-devel >= 1.95.0
156 Requires:       freexl-devel >= 1.0
157 Requires:       geos-devel >= 2.2.0
158 Requires:       giflib-devel >= 4.0
159 Requires:       hdf-devel >= 4.0
160 Requires:       hdf5-devel
161 Requires:       jasper-devel
162 Requires:       libcsf-devel
163 Requires:       libdap-devel >= 3.10
164 Requires:       libgeotiff-devel >= 1.2.1
165 %{?with_gta:Requires:   libgta-devel}
166 Requires:       libjpeg-devel >= 6b
167 Requires:       libpng-devel >= 2:1.2.8
168 %{?with_spatialite:Requires:    libspatialite-devel}
169 Requires:       libstdc++-devel
170 Requires:       libtiff-devel >= 4.0
171 Requires:       libuuid-devel
172 Requires:       libwebp-devel
173 Requires:       libxml2-devel
174 %{?with_mysql:Requires: mysql-devel}
175 Requires:       netcdf-devel >= 4
176 Requires:       ogdi-devel >= 3.1
177 %{?with_openjpeg:Requires:      openjpeg2-devel >= 2.0.0-2}
178 #Requires:      pcidsk-devel > 0.3
179 %{?with_podofo:Requires:        podofo-devel}
180 %{?with_poppler:Requires:       poppler-devel >= 0.24}
181 Requires:       postgresql-devel
182 Requires:       proj-devel >= 4
183 Requires:       sqlite3-devel >= 3.0.0
184 %{?with_odbc:Requires:  unixODBC-devel}
185 %{?with_xerces:Requires:        xerces-c-devel >= 2.7.0}
186 Requires:       xz-devel
187 Requires:       zlib-devel >= 1.1.4
188
189 %description devel
190 GDAL library header files.
191
192 %description devel -l pl.UTF-8
193 Pliki nagłówkowe biblioteki GDAL.
194
195 %package static
196 Summary:        GDAL static libraries
197 Summary(pl.UTF-8):      Statyczne biblioteki GDAL
198 Group:          Development/Libraries
199 Requires:       %{name}-devel = %{version}-%{release}
200
201 %description static
202 GDAL static libraries.
203
204 %description static -l pl.UTF-8
205 Statyczne biblioteki GDAL.
206
207 %package -n perl-gdal
208 Summary:        Perl bindings for GDAL
209 Summary(pl.UTF-8):      Wiązania Perla do pakietu GDAL
210 Group:          Development/Languages/Perl
211 Requires:       %{name} = %{version}-%{release}
212
213 %description -n perl-gdal
214 Perl bindings for GDAL - Geo::GDAL, Geo::OGR and Geo::OSR modules.
215
216 %description -n perl-gdal -l pl.UTF-8
217 Wiązania Perla do pakietu GDAL - moduły Geo::GDAL, Geo::OGR, Geo::OSR.
218
219 %package -n php-gdal
220 Summary:        PHP bindings for GDAL library
221 Summary(pl.UTF-8):      Wiązania PHP do biblioteki GDAL
222 Group:          Development/Languages/PHP
223 Requires:       %{name} = %{version}-%{release}
224 %{?requires_php_extension}
225
226 %description -n php-gdal
227 PHP bindings for GDAL library
228
229 %description -n php-gdal -l pl.UTF-8
230 Wiązania PHP do biblioteki GDAL.
231
232 %package -n python-gdal
233 Summary:        GDAL Python module
234 Summary(pl.UTF-8):      Moduł Pythona GDAL
235 Group:          Libraries/Python
236 Requires:       %{name} = %{version}-%{release}
237 Requires:       python-libs
238
239 %description -n python-gdal
240 GDAL Python module.
241
242 %description -n python-gdal -l pl.UTF-8
243 Moduł Pythona GDAL.
244
245 %package -n ruby-gdal
246 Summary:        Ruby bindings for GDAL
247 Summary(pl.UTF-8):      Wiązania języka Ruby do pakietu GDAL
248 Group:          Development/Languages
249 Requires:       %{name} = %{version}-%{release}
250
251 %description -n ruby-gdal
252 Ruby bindings for GDAL - gdal, gdalconst, ogr and osr modules.
253
254 %description -n ruby-gdal -l pl.UTF-8
255 Wiązania języka Ruby do pakietu GDAL - moduły gdal, gdalconst, ogr i
256 osr.
257
258 %prep
259 %setup -q
260 %patch0 -p1
261 %patch1 -p1
262 %patch2 -p1
263 %patch3 -p1
264 %patch4 -p1
265 %patch5 -p1
266 %patch6 -p1
267 %patch7 -p1
268
269 # need to regenerate (old ones don't support perl 5.10)
270 %{__rm} swig/perl/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
271
272 # Build with fPIC to allow Ruby bindings
273 # Xcompiler should normally achieve that -- http://trac.osgeo.org/gdal/ticket/3978
274 # http://trac.osgeo.org/gdal/ticket/1994
275 sed -i 's|\$(CFLAGS)|$(CFLAGS) -fPIC|g' swig/ruby/RubyMakefile.mk
276 # Install Ruby bindings to distribution specific directory
277 sed -i 's|RUBY_EXTENSIONS_DIR :=.*|RUBY_EXTENSIONS_DIR := %{ruby_vendorarchdir}|' swig/ruby/RubyMakefile.mk
278
279 # Install Ruby bindings into the proper place
280 sed -i -e 's|^$(INSTALL_DIR):|$(DESTDIR)$(INSTALL_DIR):|' swig/ruby/RubyMakefile.mk
281 sed -i -e 's|^install: $(INSTALL_DIR)|install: $(DESTDIR)$(INSTALL_DIR)|' swig/ruby/RubyMakefile.mk
282
283 %{__rm} -r man
284
285 %{__sed} -i -e 's,DODS_INC="-I.*,DODS_INC="$(pkg-config --cflags libdap)",' configure.in
286
287 %build
288 %{__libtoolize}
289 %{__aclocal} -I m4
290 %{__autoconf}
291 # disable grass/libgrass here, it can be built from separate gdal-grass package
292 %configure \
293         --datadir=%{_datadir}/gdal \
294         --with-dods-root=/usr \
295         %{?with_armadillo:--with-armadillo} \
296         %{?with_epsilon:--with-epsilon} \
297         %{!?with_gta:--without-gta} \
298         --with-hide-internal-symbols \
299         %{?with_java:--with-java=%{java_home}} \
300         --with-liblzma \
301         %{?with_java:--with-mdb --with-jvm-lib-add-rpath} \
302         %{?with_mysql:--with-mysql} \
303         %{?with_opencl:--with-opencl} \
304         --with-perl \
305         %{?with_php:--with-php} \
306         %{?with_podofo:--with-podofo} \
307         %{?with_poppler:--with-poppler} \
308         --with-python \
309         %{?with_ruby:--with-ruby} \
310         %{?with_spatialite:--with-spatialite} \
311         --with-sqlite3 \
312         --with-webp \
313         %{?with_xerces:--with-xerces} \
314         --with-xerces-inc=/usr/include/xercesc \
315         --with-xerces-lib="-lxerces-c" \
316         --without-grass \
317         --without-libgrass
318 #       --with-rasdaman
319 #       --with-pcidsk=/usr (needs > 0.3)
320 # csharp builds, but has no configure option
321
322 # regenerate where needed
323 %{__make} -j1 -C swig/perl generate
324 %if %{with ruby}
325 %{__make} -j1 -C swig/ruby generate
326 %endif
327
328 %{__make} -j1
329
330 %{__make} -j1 docs
331
332 %{__make} -j1 man
333
334 %install
335 rm -rf $RPM_BUILD_ROOT
336
337 %{__make} -j1 install install-man \
338         DESTDIR=$RPM_BUILD_ROOT
339
340 rm -rf _html
341 cp -a html _html
342 cp -a ogr/html _html/ogr
343
344 %if %{with php}
345 # missing in make install
346 install -D swig/php/php_gdal.so $RPM_BUILD_ROOT%{php_extensiondir}/gdal.so
347 install -D swig/php/php_gdalconst.so $RPM_BUILD_ROOT%{php_extensiondir}/gdalconst.so
348 install -D swig/php/php_ogr.so $RPM_BUILD_ROOT%{php_extensiondir}/ogr.so
349 install -D swig/php/php_osr.so $RPM_BUILD_ROOT%{php_extensiondir}/osr.so
350 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
351 cat <<'EOF' >$RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/gdal.ini
352 ; Enable gdal extension module
353 extension=gdal.so
354 extension=gdalconst.so
355 extension=ogr.so
356 extension=osr.so
357 EOF
358 %endif
359
360 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
361 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
362 %py_postclean
363
364 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
365 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/.packlist
366 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/Const/.packlist
367 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OGR/.packlist
368 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OSR/.packlist
369
370 # some doxygen trash
371 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Geo/{GDAL.dox,GDAL/Const.dox,OGR.dox,OSR.dox}
372 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Geo/check_dox.pl
373 %{__rm} $RPM_BUILD_ROOT%{_bindir}/gdal_{fillnodata,sieve}.dox
374
375 %clean
376 rm -rf $RPM_BUILD_ROOT
377
378 %post   -p /sbin/ldconfig
379 %postun -p /sbin/ldconfig
380
381 %files
382 %defattr(644,root,root,755)
383 %doc NEWS PROVENANCE.TXT
384 %attr(755,root,root) %{_bindir}/epsg_tr.py
385 %attr(755,root,root) %{_bindir}/esri2wkt.py
386 %attr(755,root,root) %{_bindir}/gcps2vec.py
387 %attr(755,root,root) %{_bindir}/gcps2wld.py
388 %attr(755,root,root) %{_bindir}/gdal2tiles.py
389 %attr(755,root,root) %{_bindir}/gdal2xyz.py
390 %attr(755,root,root) %{_bindir}/gdal_contour
391 %attr(755,root,root) %{_bindir}/gdal_calc.py
392 %attr(755,root,root) %{_bindir}/gdal_fillnodata.py
393 %attr(755,root,root) %{_bindir}/gdal_grid
394 %attr(755,root,root) %{_bindir}/gdal_merge.py
395 %attr(755,root,root) %{_bindir}/gdal_polygonize.py
396 %attr(755,root,root) %{_bindir}/gdal_proximity.py
397 %attr(755,root,root) %{_bindir}/gdal_rasterize
398 %attr(755,root,root) %{_bindir}/gdal_retile.py
399 %attr(755,root,root) %{_bindir}/gdal_sieve.py
400 %attr(755,root,root) %{_bindir}/gdal_translate
401 %attr(755,root,root) %{_bindir}/gdaladdo
402 %attr(755,root,root) %{_bindir}/gdalbuildvrt
403 %attr(755,root,root) %{_bindir}/gdalchksum.py
404 %attr(755,root,root) %{_bindir}/gdaldem
405 %attr(755,root,root) %{_bindir}/gdalenhance
406 %attr(755,root,root) %{_bindir}/gdalident.py
407 %attr(755,root,root) %{_bindir}/gdalimport.py
408 %attr(755,root,root) %{_bindir}/gdalinfo
409 %attr(755,root,root) %{_bindir}/gdallocationinfo
410 %attr(755,root,root) %{_bindir}/gdalmanage
411 %attr(755,root,root) %{_bindir}/gdalsrsinfo
412 %attr(755,root,root) %{_bindir}/gdaltindex
413 %attr(755,root,root) %{_bindir}/gdaltransform
414 %attr(755,root,root) %{_bindir}/gdalwarp
415 %attr(755,root,root) %{_bindir}/mkgraticule.py
416 %attr(755,root,root) %{_bindir}/nearblack
417 %attr(755,root,root) %{_bindir}/ogr2ogr
418 %attr(755,root,root) %{_bindir}/ogrinfo
419 %attr(755,root,root) %{_bindir}/ogrtindex
420 %attr(755,root,root) %{_bindir}/pct2rgb.py
421 %attr(755,root,root) %{_bindir}/rgb2pct.py
422 %attr(755,root,root) %{_bindir}/testepsg
423 %attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
424 %attr(755,root,root) %ghost %{_libdir}/libgdal.so.1
425 %{_datadir}/gdal
426 %{_mandir}/man1/gdal2tiles.1*
427 %{_mandir}/man1/gdal_contour.1*
428 %{_mandir}/man1/gdal_fillnodata.1*
429 %{_mandir}/man1/gdal_grid.1*
430 %{_mandir}/man1/gdal_merge.1*
431 %{_mandir}/man1/gdal_rasterize.1*
432 %{_mandir}/man1/gdal_retile.1*
433 %{_mandir}/man1/gdal_sieve.1*
434 %{_mandir}/man1/gdal_translate.1*
435 %{_mandir}/man1/gdal_utilities.1*
436 %{_mandir}/man1/gdaladdo.1*
437 %{_mandir}/man1/gdalbuildvrt.1*
438 %{_mandir}/man1/gdaldem.1*
439 %{_mandir}/man1/gdalinfo.1*
440 %{_mandir}/man1/gdallocationinfo.1*
441 %{_mandir}/man1/gdalsrsinfo.1*
442 %{_mandir}/man1/gdaltindex.1*
443 %{_mandir}/man1/gdaltransform.1*
444 %{_mandir}/man1/gdalwarp.1*
445 %{_mandir}/man1/nearblack.1*
446 %{_mandir}/man1/ogr2ogr.1*
447 %{_mandir}/man1/ogr_utilities.1*
448 %{_mandir}/man1/ogrinfo.1*
449 %{_mandir}/man1/ogrtindex.1*
450 %{_mandir}/man1/pct2rgb.1*
451 %{_mandir}/man1/rgb2pct.1*
452
453 %files devel
454 %defattr(644,root,root,755)
455 %doc _html/*
456 %attr(755,root,root) %{_bindir}/gdal-config
457 %attr(755,root,root) %{_libdir}/libgdal.so
458 %{_libdir}/libgdal.la
459 %{_includedir}/cpl_*.h
460 %{_includedir}/cplkeywordparser.h
461 %{_includedir}/gdal*.h
462 %{_includedir}/gvgcpfit.h
463 %{_includedir}/memdataset.h
464 %{_includedir}/ogr_*.h
465 %{_includedir}/ogrsf_frmts.h
466 %{_includedir}/rawdataset.h
467 %{_includedir}/thinplatespline.h
468 %{_includedir}/vrtdataset.h
469 %{_mandir}/man1/gdal-config.1*
470
471 %files static
472 %defattr(644,root,root,755)
473 %{_libdir}/libgdal.a
474
475 %files -n perl-gdal
476 %defattr(644,root,root,755)
477 %dir %{perl_vendorarch}/Geo
478 %{perl_vendorarch}/Geo/GDAL.pm
479 %dir %{perl_vendorarch}/Geo/GDAL
480 %{perl_vendorarch}/Geo/GDAL/Const.pm
481 %{perl_vendorarch}/Geo/OGR.pm
482 %{perl_vendorarch}/Geo/OSR.pm
483 %dir %{perl_vendorarch}/auto/Geo
484 %dir %{perl_vendorarch}/auto/Geo/GDAL
485 %{perl_vendorarch}/auto/Geo/GDAL/GDAL.bs
486 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/GDAL.so
487 %dir %{perl_vendorarch}/auto/Geo/GDAL/Const
488 %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.bs
489 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.so
490 %dir %{perl_vendorarch}/auto/Geo/OGR
491 %{perl_vendorarch}/auto/Geo/OGR/OGR.bs
492 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OGR/OGR.so
493 %dir %{perl_vendorarch}/auto/Geo/OSR
494 %{perl_vendorarch}/auto/Geo/OSR/OSR.bs
495 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OSR/OSR.so
496
497 %if %{with php}
498 %files -n php-gdal
499 %defattr(644,root,root,755)
500 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/gdal.ini
501 %attr(755,root,root) %{php_extensiondir}/gdal.so
502 %attr(755,root,root) %{php_extensiondir}/gdalconst.so
503 %attr(755,root,root) %{php_extensiondir}/ogr.so
504 %attr(755,root,root) %{php_extensiondir}/osr.so
505 %endif
506
507 %files -n python-gdal
508 %defattr(644,root,root,755)
509 %{py_sitedir}/gdal.py[co]
510 %{py_sitedir}/gdalconst.py[co]
511 %{py_sitedir}/gdalnumeric.py[co]
512 %{py_sitedir}/ogr.py[co]
513 %{py_sitedir}/osr.py[co]
514 %{py_sitedir}/GDAL-*.egg-info
515 %dir %{py_sitedir}/osgeo
516 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal.so
517 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal_array.so
518 %attr(755,root,root) %{py_sitedir}/osgeo/_gdalconst.so
519 %attr(755,root,root) %{py_sitedir}/osgeo/_ogr.so
520 %attr(755,root,root) %{py_sitedir}/osgeo/_osr.so
521 %{py_sitedir}/osgeo/*.py[co]
522
523 %if %{with ruby}
524 %files -n ruby-gdal
525 %defattr(644,root,root,755)
526 %dir %{ruby_vendorarchdir}/gdal
527 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/gdal.so
528 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/gdalconst.so
529 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/ogr.so
530 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/osr.so
531 %endif
This page took 0.063005 seconds and 4 git commands to generate.