]> git.pld-linux.org Git - packages/gdal.git/blob - gdal.spec
ebbff85ffe38c321a9e66681a1cc20c47475359a
[packages/gdal.git] / gdal.spec
1 # TODO:
2 # - be reasonable about devel dependencies - you do not need all of them to
3 #   use gdal (probably a gdal module or driver shall not imply devel
4 #   dependency)
5 # - libjpeg12 (needs patching to use system one, --with-jpeg12 is not sufficient as of 1.9.2)
6 # - libkml (1.3.0 needed, not released yet)
7 # - wait for newer pcidsk, switch to external again
8 # - csharp, java
9 # - additional, proprietary(?) formats support:
10 #   - FMEObjects (http://www.safe.com/support/support-resources/fme-downloads/)
11 #   - ESRI FileGDBAPI (http://resources.arcgis.com/content/geodatabases/10.0/file-gdb-api)
12 #   - ECW (http://www.erdas.com/products/ecw/ERDASECWJPEG2000SDK/Details.aspx)
13 #   - Kakadu/JPEG2000 (http://www.kakadusoftware.com/)
14 #   - MrSID (http://www.lizardtech.com/developer/)
15 #   - MSG/EUMETSAT (http://www.eumetsat.int/Home/Main/DataAccess/SupportSoftwareTools/index.htm)
16 #   - Ingres (--with-ingres=/path)
17 #   - Informix DB (--with-idb)
18 #   - DWGdirect (members only? http://www.opendwg.org/)
19 #   - ESRI SDE (http://www.esri.com/software/arcgis/arcsde/index.html)
20 #
21 # Conditional build:
22 %bcond_without  armadillo       # Armadillo support for faster TPS transform
23 %bcond_without  crnlib          # DDS support via crunch/crnlib
24 %bcond_without  epsilon         # EPSILON wavelet compression support
25 %bcond_without  fyba            # SOSI geodata support using FYBA
26 %bcond_with     grass           # GRASS support (note: dependency loop; use gdal-grass.spec instead)
27 %bcond_without  gta             # GTA format support
28 %bcond_without  kea             # KEA format support
29 %bcond_without  mysql           # MySQL DB support
30 %bcond_with     oci             # ORACLE OCI DB and Georaster support
31 %bcond_without  odbc            # ODBC DB support
32 %bcond_without  opencl          # OpenCL (GPU) support
33 %bcond_without  openjpeg        # OpenJPEG 2 (JPEG2000) support
34 %bcond_with     podofo          # PDF support via podofo instead of poppler
35 %bcond_without  poppler         # PDF support via poppler
36 %bcond_without  rasdaman        # Rasdaman support
37 %bcond_without  spatialite      # SpatiaLite support
38 %bcond_without  xerces          # Xerces support
39 %bcond_without  java            # Java and MDB support
40 %bcond_with     php             # PHP binding [PHP 7 not supported by swig 3.0.x]
41 %bcond_with     ruby            # Ruby binding [not available as of 2.0.2]
42
43 %if %{with podofo}
44 %undefine       with_poppler
45 %endif
46 %if 0%{!?php_name:1}
47 %define         php_name        php55
48 %endif
49 Summary:        Geospatial Data Abstraction Library
50 Summary(pl.UTF-8):      Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
51 Name:           gdal
52 Version:        2.0.2
53 Release:        16
54 License:        BSD-like
55 Group:          Libraries
56 Source0:        http://download.osgeo.org/gdal/%{version}/%{name}-%{version}.tar.xz
57 # Source0-md5:  940208e737c87d31a90eaae43d0efd65
58 Patch0:         %{name}-perl.patch
59 Patch1:         %{name}-python_install.patch
60 Patch2:         %{name}-php.patch
61 Patch3:         %{name}-fpic.patch
62 Patch5:         %{name}-grass.patch
63 Patch7:         %{name}-link.patch
64 Patch8:         %{name}-fyba.patch
65 Patch9:         %{name}-dds.patch
66 Patch11:        %{name}-armadillo.patch
67 Patch12:        %{name}-rasdaman.patch
68 Patch13:        %{name}-pluginsdir.patch
69 Patch14:        %{name}-uchar.patch
70 Patch15:        libx32.patch
71 URL:            http://www.gdal.org/
72 %{?with_php:BuildRequires:      %{php_name}-devel}
73 %{?with_opencl:BuildRequires:   OpenCL-devel >= 1.0}
74 %{?with_armadillo:BuildRequires:        armadillo-devel}
75 BuildRequires:  autoconf >= 2.52
76 BuildRequires:  automake
77 BuildRequires:  cfitsio-devel
78 %{?with_crnlib:BuildRequires:   crnlib-devel}
79 BuildRequires:  curl-devel
80 BuildRequires:  doxygen >= 1.4.2
81 %{?with_epsilon:BuildRequires:  epsilon-compressor-devel}
82 BuildRequires:  expat-devel >= 1.95.0
83 %{?with_fyba:BuildRequires:     fyba-devel}
84 BuildRequires:  freexl-devel >= 1.0
85 BuildRequires:  gcc >= 6:4.1
86 BuildRequires:  geos-devel >= 3.1.0
87 BuildRequires:  giflib-devel >= 4.0
88 %{?with_grass:BuildRequires:    grass-devel >= 6.4}
89 BuildRequires:  hdf-devel >= 4.0
90 BuildRequires:  hdf5-devel
91 BuildRequires:  jasper-devel
92 %{?with_java:BuildRequires:     jdk}
93 %{?with_java:BuildRequires:     jpackage-utils}
94 BuildRequires:  json-c-devel >= 0.11
95 %{?with_kea:BuildRequires:      kealib-devel}
96 BuildRequires:  libcsf-devel >= 2.0-0.041111.6
97 BuildRequires:  libdap-devel >= 3.10
98 BuildRequires:  libgeotiff-devel >= 1.2.1
99 %{?with_gta:BuildRequires:      libgta-devel}
100 BuildRequires:  libjpeg-devel >= 6b
101 #BuildRequires: libkml-devel >= 1.3.0
102 BuildRequires:  libpng-devel >= 2:1.2.8
103 %{?with_spatialite:BuildRequires:       libspatialite-devel}
104 BuildRequires:  libstdc++-devel
105 BuildRequires:  libtiff-devel >= 4.0
106 BuildRequires:  libtool
107 BuildRequires:  libuuid-devel
108 BuildRequires:  libwebp-devel
109 BuildRequires:  libxml2-devel >= 2
110 %{?with_mysql:BuildRequires:    mysql-devel}
111 BuildRequires:  netcdf-devel >= 4.1
112 BuildRequires:  ogdi-devel >= 3.1
113 %{?with_openjpeg:BuildRequires: openjpeg2-devel >= 2.0.0-2}
114 # 8.1.7 for DB support, 10.0.1 for georaster
115 %{?with_oci:BuildRequires:      oracle-instantclient-devel >= 10.0.1}
116 #BuildRequires: pcidsk-devel > 0.3
117 BuildRequires:  perl-devel
118 %{?with_podofo:BuildRequires:   podofo-devel}
119 %{?with_poppler:BuildRequires:  poppler-devel >= 0.24}
120 # ensure it's compiled with PQescapeStringConn support
121 BuildRequires:  postgresql-backend-devel >= 8.1.4
122 BuildRequires:  postgresql-devel >= 8.1.4
123 BuildRequires:  proj-devel >= 4
124 BuildRequires:  python-devel >= 1:2.5
125 BuildRequires:  python-numpy-devel >= 1:1.0.0
126 BuildRequires:  python-setuptools
127 %{?with_rasdaman:BuildRequires: rasdaman-devel}
128 BuildRequires:  rpm-pythonprov
129 %{?with_ruby:BuildRequires:     rpm-rubyprov}
130 BuildRequires:  rpmbuild(macros) >= 1.344
131 %{?with_ruby:BuildRequires:     ruby-devel}
132 BuildRequires:  sed >= 4.0
133 BuildRequires:  sqlite3-devel >= 3.0.0
134 BuildRequires:  swig-perl
135 BuildRequires:  swig-php >= 2.0.12-2
136 BuildRequires:  swig-python >= 1.3
137 %{?with_ruby:BuildRequires:     swig-ruby}
138 BuildRequires:  texlive-dvips
139 BuildRequires:  texlive-latex
140 %{?with_odbc:BuildRequires:     unixODBC-devel >= 2.2.15}
141 %{?with_xerces:BuildRequires:   xerces-c-devel >= 2.7.0}
142 BuildRequires:  xz-devel
143 BuildRequires:  zlib-devel >= 1.1.4
144 Requires:       freexl >= 1.0
145 Requires:       geos >= 3.1.0
146 Requires:       libgeotiff >= 1.2.1
147 Requires:       libpng >= 2:1.2.8
148 Requires:       libtiff >= 4.0
149 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
150
151 %description
152 GDAL is a translator library for raster geospatial data formats that
153 is released under an Open Source license. As a library, it presents a
154 single abstract data model to the calling application for all
155 supported formats. The related OGR library (which lives within the
156 GDAL source tree) provides a similar capability for simple features
157 vector data.
158
159 %description -l pl.UTF-8
160 GDAL to biblioteka konwertująca między formatami rastrowych danych
161 dotyczących powierzchni Ziemi, udostępniona na licencji Open Source.
162 Jako biblioteka udostępnia aplikacjom jeden abstrakcyjny model danych
163 do wszystkich obsługiwanych formatów. Powiązana z nią biblioteka OGR
164 (której źródła są dołączone do drzewa źródeł GDAL) daje podobne
165 możliwości dla danych wektorowych.
166
167 %package devel
168 Summary:        GDAL library header files
169 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GDAL
170 Group:          Development/Libraries
171 Requires:       %{name} = %{version}-%{release}
172 %{?with_opencl:Requires:        OpenCL-devel >= 1.0}
173 %{?with_armadillo:Requires:     armadillo-devel}
174 Requires:       cfitsio-devel
175 %{?with_crnlib:Requires:        crnlib-devel}
176 Requires:       curl-devel
177 %{?with_epsilon:Requires:       epsilon-compressor-devel}
178 %{?with_fyba:Requires:  fyba-devel}
179 Requires:       expat-devel >= 1.95.0
180 Requires:       freexl-devel >= 1.0
181 Requires:       geos-devel >= 3.1.0
182 Requires:       giflib-devel >= 4.0
183 Requires:       hdf-devel >= 4.0
184 Requires:       hdf5-devel
185 Requires:       jasper-devel
186 Requires:       json-c-devel >= 0.11
187 %{?with_kea:Requires:   kealib-devel}
188 Requires:       libcsf-devel
189 Requires:       libdap-devel >= 3.10
190 Requires:       libgeotiff-devel >= 1.2.1
191 %{?with_gta:Requires:   libgta-devel}
192 Requires:       libjpeg-devel >= 6b
193 Requires:       libpng-devel >= 2:1.2.8
194 %{?with_spatialite:Requires:    libspatialite-devel}
195 Requires:       libstdc++-devel
196 Requires:       libtiff-devel >= 4.0
197 Requires:       libuuid-devel
198 Requires:       libwebp-devel
199 Requires:       libxml2-devel >= 2
200 %{?with_mysql:Requires: mysql-devel}
201 Requires:       netcdf-devel >= 4
202 Requires:       ogdi-devel >= 3.1
203 %{?with_openjpeg:Requires:      openjpeg2-devel >= 2.0.0-2}
204 #Requires:      pcidsk-devel > 0.3
205 %{?with_podofo:Requires:        podofo-devel}
206 %{?with_poppler:Requires:       poppler-devel >= 0.24}
207 Requires:       postgresql-devel
208 Requires:       proj-devel >= 4
209 %{?with_rasdaman:Requires:      rasdaman-devel}
210 Requires:       sqlite3-devel >= 3.0.0
211 %{?with_odbc:Requires:  unixODBC-devel}
212 %{?with_xerces:Requires:        xerces-c-devel >= 2.7.0}
213 Requires:       xz-devel
214 Requires:       zlib-devel >= 1.1.4
215
216 %description devel
217 GDAL library header files.
218
219 %description devel -l pl.UTF-8
220 Pliki nagłówkowe biblioteki GDAL.
221
222 %package static
223 Summary:        GDAL static libraries
224 Summary(pl.UTF-8):      Statyczne biblioteki GDAL
225 Group:          Development/Libraries
226 Requires:       %{name}-devel = %{version}-%{release}
227
228 %description static
229 GDAL static libraries.
230
231 %description static -l pl.UTF-8
232 Statyczne biblioteki GDAL.
233
234 %package -n perl-gdal
235 Summary:        Perl bindings for GDAL
236 Summary(pl.UTF-8):      Wiązania Perla do pakietu GDAL
237 Group:          Development/Languages/Perl
238 Requires:       %{name} = %{version}-%{release}
239
240 %description -n perl-gdal
241 Perl bindings for GDAL - Geo::GDAL, Geo::OGR and Geo::OSR modules.
242
243 %description -n perl-gdal -l pl.UTF-8
244 Wiązania Perla do pakietu GDAL - moduły Geo::GDAL, Geo::OGR, Geo::OSR.
245
246 %package -n %{php_name}-gdal
247 Summary:        PHP bindings for GDAL library
248 Summary(pl.UTF-8):      Wiązania PHP do biblioteki GDAL
249 Group:          Development/Languages/PHP
250 Requires:       %{name} = %{version}-%{release}
251 %{?requires_php_extension}
252
253 %description -n %{php_name}-gdal
254 PHP bindings for GDAL library
255
256 %description -n %{php_name}-gdal -l pl.UTF-8
257 Wiązania PHP do biblioteki GDAL.
258
259 %package -n python-gdal
260 Summary:        GDAL Python module
261 Summary(pl.UTF-8):      Moduł Pythona GDAL
262 Group:          Libraries/Python
263 Requires:       %{name} = %{version}-%{release}
264 Requires:       python-libs
265
266 %description -n python-gdal
267 GDAL Python module.
268
269 %description -n python-gdal -l pl.UTF-8
270 Moduł Pythona GDAL.
271
272 %package -n ruby-gdal
273 Summary:        Ruby bindings for GDAL
274 Summary(pl.UTF-8):      Wiązania języka Ruby do pakietu GDAL
275 Group:          Development/Languages
276 Requires:       %{name} = %{version}-%{release}
277
278 %description -n ruby-gdal
279 Ruby bindings for GDAL - gdal, gdalconst, ogr and osr modules.
280
281 %description -n ruby-gdal -l pl.UTF-8
282 Wiązania języka Ruby do pakietu GDAL - moduły gdal, gdalconst, ogr i
283 osr.
284
285 %prep
286 %setup -q
287 %patch0 -p1
288 %patch1 -p1
289 %patch2 -p1
290 %patch3 -p1
291 %patch5 -p1
292 %patch7 -p1
293 %patch8 -p1
294 %patch9 -p1
295 %patch11 -p1
296 %patch12 -p1
297 %patch13 -p1
298 %patch14 -p1
299 %patch15 -p1
300
301 # need to regenerate (old ones don't support perl 5.10 or php 5.5)
302 %{__rm} swig/{perl,php}/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
303
304 %{__sed} -i \
305         -e 's/^CC=gcc/CC=%{__cc}/' \
306         -e 's/^CXX=g++/CXX=%{__cxx}/' \
307         -e 's/^CFLAGS=-fpic/CFLAGS=%{rpmcflags} -fPIC/' \
308         -e 's/^LDFLAGS=-shared/LDFLAGS=%{rpmldflags} -shared/' \
309         swig/php/GNUmakefile
310 # Build with fPIC to allow Ruby bindings
311 # Xcompiler should normally achieve that -- http://trac.osgeo.org/gdal/ticket/3978
312 # http://trac.osgeo.org/gdal/ticket/1994
313 sed -i 's|\$(CFLAGS)|$(CFLAGS) -fPIC|g' swig/ruby/RubyMakefile.mk
314 # Install Ruby bindings to distribution specific directory
315 sed -i 's|RUBY_EXTENSIONS_DIR :=.*|RUBY_EXTENSIONS_DIR := %{ruby_vendorarchdir}|' swig/ruby/RubyMakefile.mk
316
317 # Install Ruby bindings into the proper place
318 sed -i -e 's|^$(INSTALL_DIR):|$(DESTDIR)$(INSTALL_DIR):|' swig/ruby/RubyMakefile.mk
319 sed -i -e 's|^install: $(INSTALL_DIR)|install: $(DESTDIR)$(INSTALL_DIR)|' swig/ruby/RubyMakefile.mk
320
321 # our man path
322 sed -i -e 's#^mandir=.*##g' configure.in
323
324 %{__rm} -r man
325
326 %{__sed} -i -e 's,DODS_INC="-I.*,DODS_INC="$(pkg-config --cflags libdap)",' configure.in
327
328 %build
329 %ifarch %{x8664}
330 jvm_arch=amd64
331 %endif
332 %ifarch %{ix86}
333 jvm_arch=i386
334 %endif
335 %ifarch x32
336 jvm_arch=x32
337 %endif
338
339 %{__libtoolize}
340 %{__aclocal} -I m4
341 %{__autoconf}
342 %{__autoheader}
343 %configure \
344         --includedir=%{_includedir}/gdal \
345         --datadir=%{_datadir}/gdal \
346         --with-dods-root=/usr \
347         %{?with_armadillo:--with-armadillo} \
348         %{?with_crnlib:--with-dds} \
349         %{?with_epsilon:--with-epsilon} \
350         %{?with_grass:--with-grass} \
351         %{!?with_gta:--without-gta} \
352         --with-hide-internal-symbols \
353         %{?with_java:--with-java=%{java_home}} \
354         --with-liblzma \
355         %{!?with_kea:--without-kea} \
356         %{?with_java:--with-mdb --with-jvm-lib-add-rpath --with-jvm-lib=%{java_home}/jre/lib/$jvm_arch/server} \
357         %{?with_mysql:--with-mysql} \
358         %{?with_oci:--with-oci --with-oci-include=/usr/include/oracle/client --with-oci-lib=%{_libdir}} \
359         %{?with_opencl:--with-opencl} \
360         --with-perl \
361         %{?with_php:--with-php} \
362         %{?with_podofo:--with-podofo} \
363         %{?with_poppler:--with-poppler} \
364         --with-python \
365         %{?with_rasdaman:--with-rasdaman=%{_libdir}/rasdaman} \
366         %{?with_ruby:--with-ruby} \
367         %{?with_fyba:--with-sosi} \
368         %{?with_spatialite:--with-spatialite} \
369         --with-sqlite3 \
370         --with-webp \
371         %{?with_xerces:--with-xerces} \
372         --with-xerces-inc=/usr/include/xercesc \
373         --with-xerces-lib="-lxerces-c" \
374         --without-libgrass
375 #       --with-pcidsk=/usr (needs > 0.3)
376 # csharp builds, but has no configure option nor install target
377
378 # regenerate where needed
379 %{__make} -j1 -C swig/perl generate
380 %if %{with ruby}
381 %{__make} -j1 -C swig/ruby generate
382 %endif
383
384 %{__make} -j1 \
385         %{?with_grass:GRASS_INCLUDE="-I/usr/include/grass64"} \
386         %{?with_fyba:SOSI_INC="-I/usr/include/fyba"}
387
388 %{__make} -j1 docs
389
390 %{__make} -j1 man
391
392 %install
393 rm -rf $RPM_BUILD_ROOT
394
395 %{__make} -j1 install install-man \
396         DESTDIR=$RPM_BUILD_ROOT
397
398 rm -rf _html
399 cp -a html _html
400
401 %if %{with php}
402 # missing in make install
403 install -d $RPM_BUILD_ROOT%{php_extensiondir}
404 install -p swig/php/php_gdal.so $RPM_BUILD_ROOT%{php_extensiondir}/gdal.so
405 install -p swig/php/php_gdalconst.so $RPM_BUILD_ROOT%{php_extensiondir}/gdalconst.so
406 install -p swig/php/php_ogr.so $RPM_BUILD_ROOT%{php_extensiondir}/ogr.so
407 install -p swig/php/php_osr.so $RPM_BUILD_ROOT%{php_extensiondir}/osr.so
408 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
409 cat <<'EOF' >$RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/gdal.ini
410 ; Enable gdal extension modules
411 extension=gdal.so
412 extension=gdalconst.so
413 extension=ogr.so
414 extension=osr.so
415 EOF
416 %endif
417
418 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
419 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
420 %py_postclean
421
422 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
423 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/.packlist
424 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/Const/.packlist
425 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OGR/.packlist
426 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OSR/.packlist
427
428 # some doxygen trash
429 %{__rm} $RPM_BUILD_ROOT%{_bindir}/gdal{compare,move}.dox
430 %{__rm} $RPM_BUILD_ROOT%{_bindir}/gdal_{calc,edit,fillnodata,polygonize,proximity,sieve}.dox
431
432 %clean
433 rm -rf $RPM_BUILD_ROOT
434
435 %post   -p /sbin/ldconfig
436 %postun -p /sbin/ldconfig
437
438 %files
439 %defattr(644,root,root,755)
440 %doc NEWS PROVENANCE.TXT
441 %attr(755,root,root) %{_bindir}/epsg_tr.py
442 %attr(755,root,root) %{_bindir}/esri2wkt.py
443 %attr(755,root,root) %{_bindir}/gcps2vec.py
444 %attr(755,root,root) %{_bindir}/gcps2wld.py
445 %attr(755,root,root) %{_bindir}/gdal2tiles.py
446 %attr(755,root,root) %{_bindir}/gdal2xyz.py
447 %attr(755,root,root) %{_bindir}/gdal_auth.py
448 %attr(755,root,root) %{_bindir}/gdal_contour
449 %attr(755,root,root) %{_bindir}/gdal_calc.py
450 %attr(755,root,root) %{_bindir}/gdal_edit.py
451 %attr(755,root,root) %{_bindir}/gdal_fillnodata.py
452 %attr(755,root,root) %{_bindir}/gdal_grid
453 %attr(755,root,root) %{_bindir}/gdal_merge.py
454 %attr(755,root,root) %{_bindir}/gdal_polygonize.py
455 %attr(755,root,root) %{_bindir}/gdal_proximity.py
456 %attr(755,root,root) %{_bindir}/gdal_rasterize
457 %attr(755,root,root) %{_bindir}/gdal_retile.py
458 %attr(755,root,root) %{_bindir}/gdal_sieve.py
459 %attr(755,root,root) %{_bindir}/gdal_translate
460 %attr(755,root,root) %{_bindir}/gdaladdo
461 %attr(755,root,root) %{_bindir}/gdalbuildvrt
462 %attr(755,root,root) %{_bindir}/gdalchksum.py
463 %attr(755,root,root) %{_bindir}/gdalcompare.py
464 %attr(755,root,root) %{_bindir}/gdaldem
465 %attr(755,root,root) %{_bindir}/gdalenhance
466 %attr(755,root,root) %{_bindir}/gdalident.py
467 %attr(755,root,root) %{_bindir}/gdalimport.py
468 %attr(755,root,root) %{_bindir}/gdalinfo
469 %attr(755,root,root) %{_bindir}/gdallocationinfo
470 %attr(755,root,root) %{_bindir}/gdalmanage
471 %attr(755,root,root) %{_bindir}/gdalmove.py
472 %attr(755,root,root) %{_bindir}/gdalserver
473 %attr(755,root,root) %{_bindir}/gdalsrsinfo
474 %attr(755,root,root) %{_bindir}/gdaltindex
475 %attr(755,root,root) %{_bindir}/gdaltransform
476 %attr(755,root,root) %{_bindir}/gdalwarp
477 %attr(755,root,root) %{_bindir}/mkgraticule.py
478 %attr(755,root,root) %{_bindir}/nearblack
479 %attr(755,root,root) %{_bindir}/ogr2ogr
480 %attr(755,root,root) %{_bindir}/ogrinfo
481 %attr(755,root,root) %{_bindir}/ogrlineref
482 %attr(755,root,root) %{_bindir}/ogrtindex
483 %attr(755,root,root) %{_bindir}/pct2rgb.py
484 %attr(755,root,root) %{_bindir}/rgb2pct.py
485 %attr(755,root,root) %{_bindir}/testepsg
486 %attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
487 %attr(755,root,root) %ghost %{_libdir}/libgdal.so.20
488 %dir %{_libdir}/gdalplugins
489 %{_datadir}/gdal
490 %{_mandir}/man1/gdal2tiles.1*
491 %{_mandir}/man1/gdal_calc.1*
492 %{_mandir}/man1/gdal_contour.1*
493 %{_mandir}/man1/gdal_edit.1*
494 %{_mandir}/man1/gdal_fillnodata.1*
495 %{_mandir}/man1/gdal_grid.1*
496 %{_mandir}/man1/gdal_merge.1*
497 %{_mandir}/man1/gdal_polygonize.1*
498 %{_mandir}/man1/gdal_proximity.1*
499 %{_mandir}/man1/gdal_rasterize.1*
500 %{_mandir}/man1/gdal_retile.1*
501 %{_mandir}/man1/gdal_sieve.1*
502 %{_mandir}/man1/gdal_translate.1*
503 %{_mandir}/man1/gdal_utilities.1*
504 %{_mandir}/man1/gdaladdo.1*
505 %{_mandir}/man1/gdalbuildvrt.1*
506 %{_mandir}/man1/gdalcompare.1*
507 %{_mandir}/man1/gdaldem.1*
508 %{_mandir}/man1/gdalinfo.1*
509 %{_mandir}/man1/gdallocationinfo.1*
510 %{_mandir}/man1/gdalmanage.1*
511 %{_mandir}/man1/gdalmove.1*
512 %{_mandir}/man1/gdalsrsinfo.1*
513 %{_mandir}/man1/gdaltindex.1*
514 %{_mandir}/man1/gdaltransform.1*
515 %{_mandir}/man1/gdalwarp.1*
516 %{_mandir}/man1/nearblack.1*
517 %{_mandir}/man1/ogr2ogr.1*
518 %{_mandir}/man1/ogr_utilities.1*
519 %{_mandir}/man1/ogrinfo.1*
520 %{_mandir}/man1/ogrlineref.1*
521 %{_mandir}/man1/ogrtindex.1*
522 %{_mandir}/man1/pct2rgb.1*
523 %{_mandir}/man1/rgb2pct.1*
524
525 %files devel
526 %defattr(644,root,root,755)
527 %doc _html/*
528 %attr(755,root,root) %{_bindir}/gdal-config
529 %attr(755,root,root) %{_libdir}/libgdal.so
530 %{_libdir}/libgdal.la
531 %{_pkgconfigdir}/gdal.pc
532 %{_includedir}/gdal
533 %{_mandir}/man1/gdal-config.1*
534
535 %files static
536 %defattr(644,root,root,755)
537 %{_libdir}/libgdal.a
538
539 %files -n perl-gdal
540 %defattr(644,root,root,755)
541 %dir %{perl_vendorarch}/Geo
542 %{perl_vendorarch}/Geo/GDAL.pm
543 %dir %{perl_vendorarch}/Geo/GDAL
544 %{perl_vendorarch}/Geo/GDAL/Const.pm
545 %{perl_vendorarch}/Geo/OGR.pm
546 %{perl_vendorarch}/Geo/OSR.pm
547 %dir %{perl_vendorarch}/auto/Geo
548 %dir %{perl_vendorarch}/auto/Geo/GDAL
549 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/GDAL.so
550 %dir %{perl_vendorarch}/auto/Geo/GDAL/Const
551 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.so
552 %dir %{perl_vendorarch}/auto/Geo/OGR
553 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OGR/OGR.so
554 %dir %{perl_vendorarch}/auto/Geo/OSR
555 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OSR/OSR.so
556 %{_mandir}/man3/Geo::GDAL.3pm*
557
558 %if %{with php}
559 %files -n %{php_name}-gdal
560 %defattr(644,root,root,755)
561 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/gdal.ini
562 %attr(755,root,root) %{php_extensiondir}/gdal.so
563 %attr(755,root,root) %{php_extensiondir}/gdalconst.so
564 %attr(755,root,root) %{php_extensiondir}/ogr.so
565 %attr(755,root,root) %{php_extensiondir}/osr.so
566 %endif
567
568 %files -n python-gdal
569 %defattr(644,root,root,755)
570 %{py_sitedir}/gdal.py[co]
571 %{py_sitedir}/gdalconst.py[co]
572 %{py_sitedir}/gdalnumeric.py[co]
573 %{py_sitedir}/ogr.py[co]
574 %{py_sitedir}/osr.py[co]
575 %{py_sitedir}/GDAL-*.egg-info
576 %dir %{py_sitedir}/osgeo
577 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal.so
578 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal_array.so
579 %attr(755,root,root) %{py_sitedir}/osgeo/_gdalconst.so
580 %attr(755,root,root) %{py_sitedir}/osgeo/_ogr.so
581 %attr(755,root,root) %{py_sitedir}/osgeo/_osr.so
582 %{py_sitedir}/osgeo/*.py[co]
583
584 %if %{with ruby}
585 %files -n ruby-gdal
586 %defattr(644,root,root,755)
587 %dir %{ruby_vendorarchdir}/gdal
588 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/gdal.so
589 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/gdalconst.so
590 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/ogr.so
591 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/osr.so
592 %endif
This page took 0.078779 seconds and 2 git commands to generate.