]> git.pld-linux.org Git - packages/gdal.git/blob - gdal.spec
cdd37e6165925922b33cd61659857814dcfa6f9c
[packages/gdal.git] / gdal.spec
1 # TODO:
2 # - be reasonable about devel dependencies - you do not need all of them to
3 #   use gdal (probably a gdal module or driver shall not imply devel
4 #   dependency)
5 # - libjpeg12 (needs patching to use system one, --with-jpeg12 is not sufficient as of 1.9.2)
6 # - libkml (1.3.0 needed, not released yet)
7 # - wait for newer pcidsk, switch to external again
8 # - csharp, java
9 # - additional, proprietary(?) formats support:
10 #   - FMEObjects (http://www.safe.com/support/support-resources/fme-downloads/)
11 #   - ESRI FileGDBAPI (http://resources.arcgis.com/content/geodatabases/10.0/file-gdb-api)
12 #   - ECW (http://www.erdas.com/products/ecw/ERDASECWJPEG2000SDK/Details.aspx)
13 #   - Kakadu/JPEG2000 (http://www.kakadusoftware.com/)
14 #   - MrSID (http://www.lizardtech.com/developer/)
15 #   - MSG/EUMETSAT (http://www.eumetsat.int/Home/Main/DataAccess/SupportSoftwareTools/index.htm)
16 #   - Ingres (--with-ingres=/path)
17 #   - Informix DB (--with-idb)
18 #   - DWGdirect (members only? http://www.opendwg.org/)
19 #   - ESRI SDE (http://www.esri.com/software/arcgis/arcsde/index.html)
20 #
21 # Conditional build:
22 %bcond_without  armadillo       # Armadillo support for faster TPS transform
23 %bcond_without  crnlib          # DDS support via crunch/crnlib
24 %bcond_without  epsilon         # EPSILON wavelet compression support
25 %bcond_without  fyba            # SOSI geodata support using FYBA
26 %bcond_with     grass           # GRASS support (note: dependency loop; use gdal-grass.spec instead)
27 %bcond_without  gta             # GTA format support
28 %bcond_without  kea             # KEA format support
29 %bcond_without  mysql           # MySQL DB support
30 %bcond_with     oci             # ORACLE OCI DB and Georaster support
31 %bcond_without  odbc            # ODBC DB support
32 %bcond_without  opencl          # OpenCL (GPU) support
33 %bcond_without  openjpeg        # OpenJPEG 2 (JPEG2000) support
34 %bcond_with     podofo          # PDF support via podofo instead of poppler
35 %bcond_without  poppler         # PDF support via poppler
36 %bcond_without  rasdaman        # Rasdaman support
37 %bcond_without  spatialite      # SpatiaLite support
38 %bcond_without  xerces          # Xerces support
39 %bcond_without  java            # Java and MDB support
40 %bcond_with     php             # PHP binding [PHP 7 not supported by swig 3.0.x]
41 %bcond_with     ruby            # Ruby binding [not available as of 2.0.2]
42
43 %if %{with podofo}
44 %undefine       with_poppler
45 %endif
46 %if 0%{!?php_name:1}
47 %define         php_name        php55
48 %endif
49 Summary:        Geospatial Data Abstraction Library
50 Summary(pl.UTF-8):      Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
51 Name:           gdal
52 Version:        2.0.2
53 Release:        8
54 License:        BSD-like
55 Group:          Libraries
56 Source0:        http://download.osgeo.org/gdal/%{version}/%{name}-%{version}.tar.xz
57 # Source0-md5:  940208e737c87d31a90eaae43d0efd65
58 Patch0:         %{name}-perl.patch
59 Patch1:         %{name}-python_install.patch
60 Patch2:         %{name}-php.patch
61 Patch3:         %{name}-fpic.patch
62 Patch5:         %{name}-grass.patch
63 Patch7:         %{name}-link.patch
64 Patch8:         %{name}-fyba.patch
65 Patch9:         %{name}-dds.patch
66 Patch11:        %{name}-armadillo.patch
67 Patch12:        %{name}-rasdaman.patch
68 Patch13:        %{name}-pluginsdir.patch
69 URL:            http://www.gdal.org/
70 %{?with_php:BuildRequires:      %{php_name}-devel}
71 %{?with_opencl:BuildRequires:   OpenCL-devel >= 1.0}
72 %{?with_armadillo:BuildRequires:        armadillo-devel}
73 BuildRequires:  autoconf >= 2.52
74 BuildRequires:  automake
75 BuildRequires:  cfitsio-devel
76 %{?with_crnlib:BuildRequires:   crnlib-devel}
77 BuildRequires:  curl-devel
78 BuildRequires:  doxygen >= 1.4.2
79 %{?with_epsilon:BuildRequires:  epsilon-compressor-devel}
80 BuildRequires:  expat-devel >= 1.95.0
81 %{?with_fyba:BuildRequires:     fyba-devel}
82 BuildRequires:  freexl-devel >= 1.0
83 BuildRequires:  gcc >= 6:4.1
84 BuildRequires:  geos-devel >= 3.1.0
85 BuildRequires:  giflib-devel >= 4.0
86 %{?with_grass:BuildRequires:    grass-devel >= 6.4}
87 BuildRequires:  hdf-devel >= 4.0
88 BuildRequires:  hdf5-devel
89 BuildRequires:  jasper-devel
90 %{?with_java:BuildRequires:     jdk}
91 %{?with_java:BuildRequires:     jpackage-utils}
92 BuildRequires:  json-c-devel >= 0.11
93 %{?with_kea:BuildRequires:      kealib-devel}
94 BuildRequires:  libcsf-devel >= 2.0-0.041111.6
95 BuildRequires:  libdap-devel >= 3.10
96 BuildRequires:  libgeotiff-devel >= 1.2.1
97 %{?with_gta:BuildRequires:      libgta-devel}
98 BuildRequires:  libjpeg-devel >= 6b
99 #BuildRequires: libkml-devel >= 1.3.0
100 BuildRequires:  libpng-devel >= 2:1.2.8
101 %{?with_spatialite:BuildRequires:       libspatialite-devel}
102 BuildRequires:  libstdc++-devel
103 BuildRequires:  libtiff-devel >= 4.0
104 BuildRequires:  libtool
105 BuildRequires:  libuuid-devel
106 BuildRequires:  libwebp-devel
107 BuildRequires:  libxml2-devel >= 2
108 %{?with_mysql:BuildRequires:    mysql-devel}
109 BuildRequires:  netcdf-devel >= 4.1
110 BuildRequires:  ogdi-devel >= 3.1
111 %{?with_openjpeg:BuildRequires: openjpeg2-devel >= 2.0.0-2}
112 # 8.1.7 for DB support, 10.0.1 for georaster
113 %{?with_oci:BuildRequires:      oracle-instantclient-devel >= 10.0.1}
114 #BuildRequires: pcidsk-devel > 0.3
115 BuildRequires:  perl-devel
116 %{?with_podofo:BuildRequires:   podofo-devel}
117 %{?with_poppler:BuildRequires:  poppler-devel >= 0.24}
118 # ensure it's compiled with PQescapeStringConn support
119 BuildRequires:  postgresql-backend-devel >= 8.1.4
120 BuildRequires:  postgresql-devel >= 8.1.4
121 BuildRequires:  proj-devel >= 4
122 BuildRequires:  python-devel >= 1:2.5
123 BuildRequires:  python-numpy-devel >= 1:1.0.0
124 BuildRequires:  python-setuptools
125 %{?with_rasdaman:BuildRequires: rasdaman-devel}
126 BuildRequires:  rpm-pythonprov
127 %{?with_ruby:BuildRequires:     rpm-rubyprov}
128 BuildRequires:  rpmbuild(macros) >= 1.344
129 %{?with_ruby:BuildRequires:     ruby-devel}
130 BuildRequires:  sed >= 4.0
131 BuildRequires:  sqlite3-devel >= 3.0.0
132 BuildRequires:  swig-perl
133 BuildRequires:  swig-php >= 2.0.12-2
134 BuildRequires:  swig-python >= 1.3
135 %{?with_ruby:BuildRequires:     swig-ruby}
136 BuildRequires:  texlive-dvips
137 BuildRequires:  texlive-latex
138 %{?with_odbc:BuildRequires:     unixODBC-devel >= 2.2.15}
139 %{?with_xerces:BuildRequires:   xerces-c-devel >= 2.7.0}
140 BuildRequires:  xz-devel
141 BuildRequires:  zlib-devel >= 1.1.4
142 Requires:       freexl >= 1.0
143 Requires:       geos >= 3.1.0
144 Requires:       libgeotiff >= 1.2.1
145 Requires:       libpng >= 2:1.2.8
146 Requires:       libtiff >= 4.0
147 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
148
149 %description
150 GDAL is a translator library for raster geospatial data formats that
151 is released under an Open Source license. As a library, it presents a
152 single abstract data model to the calling application for all
153 supported formats. The related OGR library (which lives within the
154 GDAL source tree) provides a similar capability for simple features
155 vector data.
156
157 %description -l pl.UTF-8
158 GDAL to biblioteka konwertująca między formatami rastrowych danych
159 dotyczących powierzchni Ziemi, udostępniona na licencji Open Source.
160 Jako biblioteka udostępnia aplikacjom jeden abstrakcyjny model danych
161 do wszystkich obsługiwanych formatów. Powiązana z nią biblioteka OGR
162 (której źródła są dołączone do drzewa źródeł GDAL) daje podobne
163 możliwości dla danych wektorowych.
164
165 %package devel
166 Summary:        GDAL library header files
167 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GDAL
168 Group:          Development/Libraries
169 Requires:       %{name} = %{version}-%{release}
170 %{?with_opencl:Requires:        OpenCL-devel >= 1.0}
171 %{?with_armadillo:Requires:     armadillo-devel}
172 Requires:       cfitsio-devel
173 %{?with_crnlib:Requires:        crnlib-devel}
174 Requires:       curl-devel
175 %{?with_epsilon:Requires:       epsilon-compressor-devel}
176 %{?with_fyba:Requires:  fyba-devel}
177 Requires:       expat-devel >= 1.95.0
178 Requires:       freexl-devel >= 1.0
179 Requires:       geos-devel >= 3.1.0
180 Requires:       giflib-devel >= 4.0
181 Requires:       hdf-devel >= 4.0
182 Requires:       hdf5-devel
183 Requires:       jasper-devel
184 Requires:       json-c-devel >= 0.11
185 %{?with_kea:Requires:   kealib-devel}
186 Requires:       libcsf-devel
187 Requires:       libdap-devel >= 3.10
188 Requires:       libgeotiff-devel >= 1.2.1
189 %{?with_gta:Requires:   libgta-devel}
190 Requires:       libjpeg-devel >= 6b
191 Requires:       libpng-devel >= 2:1.2.8
192 %{?with_spatialite:Requires:    libspatialite-devel}
193 Requires:       libstdc++-devel
194 Requires:       libtiff-devel >= 4.0
195 Requires:       libuuid-devel
196 Requires:       libwebp-devel
197 Requires:       libxml2-devel >= 2
198 %{?with_mysql:Requires: mysql-devel}
199 Requires:       netcdf-devel >= 4
200 Requires:       ogdi-devel >= 3.1
201 %{?with_openjpeg:Requires:      openjpeg2-devel >= 2.0.0-2}
202 #Requires:      pcidsk-devel > 0.3
203 %{?with_podofo:Requires:        podofo-devel}
204 %{?with_poppler:Requires:       poppler-devel >= 0.24}
205 Requires:       postgresql-devel
206 Requires:       proj-devel >= 4
207 %{?with_rasdaman:Requires:      rasdaman-devel}
208 Requires:       sqlite3-devel >= 3.0.0
209 %{?with_odbc:Requires:  unixODBC-devel}
210 %{?with_xerces:Requires:        xerces-c-devel >= 2.7.0}
211 Requires:       xz-devel
212 Requires:       zlib-devel >= 1.1.4
213
214 %description devel
215 GDAL library header files.
216
217 %description devel -l pl.UTF-8
218 Pliki nagłówkowe biblioteki GDAL.
219
220 %package static
221 Summary:        GDAL static libraries
222 Summary(pl.UTF-8):      Statyczne biblioteki GDAL
223 Group:          Development/Libraries
224 Requires:       %{name}-devel = %{version}-%{release}
225
226 %description static
227 GDAL static libraries.
228
229 %description static -l pl.UTF-8
230 Statyczne biblioteki GDAL.
231
232 %package -n perl-gdal
233 Summary:        Perl bindings for GDAL
234 Summary(pl.UTF-8):      Wiązania Perla do pakietu GDAL
235 Group:          Development/Languages/Perl
236 Requires:       %{name} = %{version}-%{release}
237
238 %description -n perl-gdal
239 Perl bindings for GDAL - Geo::GDAL, Geo::OGR and Geo::OSR modules.
240
241 %description -n perl-gdal -l pl.UTF-8
242 Wiązania Perla do pakietu GDAL - moduły Geo::GDAL, Geo::OGR, Geo::OSR.
243
244 %package -n %{php_name}-gdal
245 Summary:        PHP bindings for GDAL library
246 Summary(pl.UTF-8):      Wiązania PHP do biblioteki GDAL
247 Group:          Development/Languages/PHP
248 Requires:       %{name} = %{version}-%{release}
249 %{?requires_php_extension}
250
251 %description -n %{php_name}-gdal
252 PHP bindings for GDAL library
253
254 %description -n %{php_name}-gdal -l pl.UTF-8
255 Wiązania PHP do biblioteki GDAL.
256
257 %package -n python-gdal
258 Summary:        GDAL Python module
259 Summary(pl.UTF-8):      Moduł Pythona GDAL
260 Group:          Libraries/Python
261 Requires:       %{name} = %{version}-%{release}
262 Requires:       python-libs
263
264 %description -n python-gdal
265 GDAL Python module.
266
267 %description -n python-gdal -l pl.UTF-8
268 Moduł Pythona GDAL.
269
270 %package -n ruby-gdal
271 Summary:        Ruby bindings for GDAL
272 Summary(pl.UTF-8):      Wiązania języka Ruby do pakietu GDAL
273 Group:          Development/Languages
274 Requires:       %{name} = %{version}-%{release}
275
276 %description -n ruby-gdal
277 Ruby bindings for GDAL - gdal, gdalconst, ogr and osr modules.
278
279 %description -n ruby-gdal -l pl.UTF-8
280 Wiązania języka Ruby do pakietu GDAL - moduły gdal, gdalconst, ogr i
281 osr.
282
283 %prep
284 %setup -q
285 %patch0 -p1
286 %patch1 -p1
287 %patch2 -p1
288 %patch3 -p1
289 %patch5 -p1
290 %patch7 -p1
291 %patch8 -p1
292 %patch9 -p1
293 %patch11 -p1
294 %patch12 -p1
295 %patch13 -p1
296
297 # need to regenerate (old ones don't support perl 5.10 or php 5.5)
298 %{__rm} swig/{perl,php}/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
299
300 %{__sed} -i \
301         -e 's/^CC=gcc/CC=%{__cc}/' \
302         -e 's/^CXX=g++/CXX=%{__cxx}/' \
303         -e 's/^CFLAGS=-fpic/CFLAGS=%{rpmcflags} -fPIC/' \
304         -e 's/^LDFLAGS=-shared/LDFLAGS=%{rpmldflags} -shared/' \
305         swig/php/GNUmakefile
306 # Build with fPIC to allow Ruby bindings
307 # Xcompiler should normally achieve that -- http://trac.osgeo.org/gdal/ticket/3978
308 # http://trac.osgeo.org/gdal/ticket/1994
309 sed -i 's|\$(CFLAGS)|$(CFLAGS) -fPIC|g' swig/ruby/RubyMakefile.mk
310 # Install Ruby bindings to distribution specific directory
311 sed -i 's|RUBY_EXTENSIONS_DIR :=.*|RUBY_EXTENSIONS_DIR := %{ruby_vendorarchdir}|' swig/ruby/RubyMakefile.mk
312
313 # Install Ruby bindings into the proper place
314 sed -i -e 's|^$(INSTALL_DIR):|$(DESTDIR)$(INSTALL_DIR):|' swig/ruby/RubyMakefile.mk
315 sed -i -e 's|^install: $(INSTALL_DIR)|install: $(DESTDIR)$(INSTALL_DIR)|' swig/ruby/RubyMakefile.mk
316
317 # our man path
318 sed -i -e 's#^mandir=.*##g' configure.in
319
320 %{__rm} -r man
321
322 %{__sed} -i -e 's,DODS_INC="-I.*,DODS_INC="$(pkg-config --cflags libdap)",' configure.in
323
324 %build
325 %ifarch %{x8664}
326 jvm_arch=amd64
327 %endif
328 %ifarch %{ix86}
329 jvm_arch=i386
330 %endif
331 %ifarch x32
332 jvm_arch=x32
333 %endif
334
335 %{__libtoolize}
336 %{__aclocal} -I m4
337 %{__autoconf}
338 %{__autoheader}
339 %configure \
340         --includedir=%{_includedir}/gdal \
341         --datadir=%{_datadir}/gdal \
342         --with-dods-root=/usr \
343         %{?with_armadillo:--with-armadillo} \
344         %{?with_crnlib:--with-dds} \
345         %{?with_epsilon:--with-epsilon} \
346         %{?with_grass:--with-grass} \
347         %{!?with_gta:--without-gta} \
348         --with-hide-internal-symbols \
349         %{?with_java:--with-java=%{java_home}} \
350         --with-liblzma \
351         %{!?with_kea:--without-kea} \
352         %{?with_java:--with-mdb --with-jvm-lib-add-rpath --with-jvm-lib=%{java_home}/jre/lib/$jvm_arch/server} \
353         %{?with_mysql:--with-mysql} \
354         %{?with_oci:--with-oci --with-oci-include=/usr/include/oracle/client --with-oci-lib=%{_libdir}} \
355         %{?with_opencl:--with-opencl} \
356         --with-perl \
357         %{?with_php:--with-php} \
358         %{?with_podofo:--with-podofo} \
359         %{?with_poppler:--with-poppler} \
360         --with-python \
361         %{?with_rasdaman:--with-rasdaman=%{_libdir}/rasdaman} \
362         %{?with_ruby:--with-ruby} \
363         %{?with_fyba:--with-sosi} \
364         %{?with_spatialite:--with-spatialite} \
365         --with-sqlite3 \
366         --with-webp \
367         %{?with_xerces:--with-xerces} \
368         --with-xerces-inc=/usr/include/xercesc \
369         --with-xerces-lib="-lxerces-c" \
370         --without-libgrass
371 #       --with-pcidsk=/usr (needs > 0.3)
372 # csharp builds, but has no configure option nor install target
373
374 # regenerate where needed
375 %{__make} -j1 -C swig/perl generate
376 %if %{with ruby}
377 %{__make} -j1 -C swig/ruby generate
378 %endif
379
380 %{__make} -j1 \
381         %{?with_grass:GRASS_INCLUDE="-I/usr/include/grass64"} \
382         %{?with_fyba:SOSI_INC="-I/usr/include/fyba"}
383
384 %{__make} -j1 docs
385
386 %{__make} -j1 man
387
388 %install
389 rm -rf $RPM_BUILD_ROOT
390
391 %{__make} -j1 install install-man \
392         DESTDIR=$RPM_BUILD_ROOT
393
394 rm -rf _html
395 cp -a html _html
396
397 %if %{with php}
398 # missing in make install
399 install -d $RPM_BUILD_ROOT%{php_extensiondir}
400 install -p swig/php/php_gdal.so $RPM_BUILD_ROOT%{php_extensiondir}/gdal.so
401 install -p swig/php/php_gdalconst.so $RPM_BUILD_ROOT%{php_extensiondir}/gdalconst.so
402 install -p swig/php/php_ogr.so $RPM_BUILD_ROOT%{php_extensiondir}/ogr.so
403 install -p swig/php/php_osr.so $RPM_BUILD_ROOT%{php_extensiondir}/osr.so
404 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
405 cat <<'EOF' >$RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/gdal.ini
406 ; Enable gdal extension modules
407 extension=gdal.so
408 extension=gdalconst.so
409 extension=ogr.so
410 extension=osr.so
411 EOF
412 %endif
413
414 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
415 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
416 %py_postclean
417
418 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
419 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/.packlist
420 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/Const/.packlist
421 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OGR/.packlist
422 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OSR/.packlist
423
424 # some doxygen trash
425 %{__rm} $RPM_BUILD_ROOT%{_bindir}/gdal{compare,move}.dox
426 %{__rm} $RPM_BUILD_ROOT%{_bindir}/gdal_{calc,edit,fillnodata,polygonize,proximity,sieve}.dox
427
428 %clean
429 rm -rf $RPM_BUILD_ROOT
430
431 %post   -p /sbin/ldconfig
432 %postun -p /sbin/ldconfig
433
434 %files
435 %defattr(644,root,root,755)
436 %doc NEWS PROVENANCE.TXT
437 %attr(755,root,root) %{_bindir}/epsg_tr.py
438 %attr(755,root,root) %{_bindir}/esri2wkt.py
439 %attr(755,root,root) %{_bindir}/gcps2vec.py
440 %attr(755,root,root) %{_bindir}/gcps2wld.py
441 %attr(755,root,root) %{_bindir}/gdal2tiles.py
442 %attr(755,root,root) %{_bindir}/gdal2xyz.py
443 %attr(755,root,root) %{_bindir}/gdal_auth.py
444 %attr(755,root,root) %{_bindir}/gdal_contour
445 %attr(755,root,root) %{_bindir}/gdal_calc.py
446 %attr(755,root,root) %{_bindir}/gdal_edit.py
447 %attr(755,root,root) %{_bindir}/gdal_fillnodata.py
448 %attr(755,root,root) %{_bindir}/gdal_grid
449 %attr(755,root,root) %{_bindir}/gdal_merge.py
450 %attr(755,root,root) %{_bindir}/gdal_polygonize.py
451 %attr(755,root,root) %{_bindir}/gdal_proximity.py
452 %attr(755,root,root) %{_bindir}/gdal_rasterize
453 %attr(755,root,root) %{_bindir}/gdal_retile.py
454 %attr(755,root,root) %{_bindir}/gdal_sieve.py
455 %attr(755,root,root) %{_bindir}/gdal_translate
456 %attr(755,root,root) %{_bindir}/gdaladdo
457 %attr(755,root,root) %{_bindir}/gdalbuildvrt
458 %attr(755,root,root) %{_bindir}/gdalchksum.py
459 %attr(755,root,root) %{_bindir}/gdalcompare.py
460 %attr(755,root,root) %{_bindir}/gdaldem
461 %attr(755,root,root) %{_bindir}/gdalenhance
462 %attr(755,root,root) %{_bindir}/gdalident.py
463 %attr(755,root,root) %{_bindir}/gdalimport.py
464 %attr(755,root,root) %{_bindir}/gdalinfo
465 %attr(755,root,root) %{_bindir}/gdallocationinfo
466 %attr(755,root,root) %{_bindir}/gdalmanage
467 %attr(755,root,root) %{_bindir}/gdalmove.py
468 %attr(755,root,root) %{_bindir}/gdalserver
469 %attr(755,root,root) %{_bindir}/gdalsrsinfo
470 %attr(755,root,root) %{_bindir}/gdaltindex
471 %attr(755,root,root) %{_bindir}/gdaltransform
472 %attr(755,root,root) %{_bindir}/gdalwarp
473 %attr(755,root,root) %{_bindir}/mkgraticule.py
474 %attr(755,root,root) %{_bindir}/nearblack
475 %attr(755,root,root) %{_bindir}/ogr2ogr
476 %attr(755,root,root) %{_bindir}/ogrinfo
477 %attr(755,root,root) %{_bindir}/ogrlineref
478 %attr(755,root,root) %{_bindir}/ogrtindex
479 %attr(755,root,root) %{_bindir}/pct2rgb.py
480 %attr(755,root,root) %{_bindir}/rgb2pct.py
481 %attr(755,root,root) %{_bindir}/testepsg
482 %attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
483 %attr(755,root,root) %ghost %{_libdir}/libgdal.so.20
484 %dir %{_libdir}/gdalplugins
485 %{_datadir}/gdal
486 %{_mandir}/man1/gdal2tiles.1*
487 %{_mandir}/man1/gdal_calc.1*
488 %{_mandir}/man1/gdal_contour.1*
489 %{_mandir}/man1/gdal_edit.1*
490 %{_mandir}/man1/gdal_fillnodata.1*
491 %{_mandir}/man1/gdal_grid.1*
492 %{_mandir}/man1/gdal_merge.1*
493 %{_mandir}/man1/gdal_polygonize.1*
494 %{_mandir}/man1/gdal_proximity.1*
495 %{_mandir}/man1/gdal_rasterize.1*
496 %{_mandir}/man1/gdal_retile.1*
497 %{_mandir}/man1/gdal_sieve.1*
498 %{_mandir}/man1/gdal_translate.1*
499 %{_mandir}/man1/gdal_utilities.1*
500 %{_mandir}/man1/gdaladdo.1*
501 %{_mandir}/man1/gdalbuildvrt.1*
502 %{_mandir}/man1/gdalcompare.1*
503 %{_mandir}/man1/gdaldem.1*
504 %{_mandir}/man1/gdalinfo.1*
505 %{_mandir}/man1/gdallocationinfo.1*
506 %{_mandir}/man1/gdalmanage.1*
507 %{_mandir}/man1/gdalmove.1*
508 %{_mandir}/man1/gdalsrsinfo.1*
509 %{_mandir}/man1/gdaltindex.1*
510 %{_mandir}/man1/gdaltransform.1*
511 %{_mandir}/man1/gdalwarp.1*
512 %{_mandir}/man1/nearblack.1*
513 %{_mandir}/man1/ogr2ogr.1*
514 %{_mandir}/man1/ogr_utilities.1*
515 %{_mandir}/man1/ogrinfo.1*
516 %{_mandir}/man1/ogrlineref.1*
517 %{_mandir}/man1/ogrtindex.1*
518 %{_mandir}/man1/pct2rgb.1*
519 %{_mandir}/man1/rgb2pct.1*
520
521 %files devel
522 %defattr(644,root,root,755)
523 %doc _html/*
524 %attr(755,root,root) %{_bindir}/gdal-config
525 %attr(755,root,root) %{_libdir}/libgdal.so
526 %{_libdir}/libgdal.la
527 %{_pkgconfigdir}/gdal.pc
528 %{_includedir}/gdal
529 %{_mandir}/man1/gdal-config.1*
530
531 %files static
532 %defattr(644,root,root,755)
533 %{_libdir}/libgdal.a
534
535 %files -n perl-gdal
536 %defattr(644,root,root,755)
537 %dir %{perl_vendorarch}/Geo
538 %{perl_vendorarch}/Geo/GDAL.pm
539 %dir %{perl_vendorarch}/Geo/GDAL
540 %{perl_vendorarch}/Geo/GDAL/Const.pm
541 %{perl_vendorarch}/Geo/OGR.pm
542 %{perl_vendorarch}/Geo/OSR.pm
543 %dir %{perl_vendorarch}/auto/Geo
544 %dir %{perl_vendorarch}/auto/Geo/GDAL
545 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/GDAL.so
546 %dir %{perl_vendorarch}/auto/Geo/GDAL/Const
547 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.so
548 %dir %{perl_vendorarch}/auto/Geo/OGR
549 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OGR/OGR.so
550 %dir %{perl_vendorarch}/auto/Geo/OSR
551 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OSR/OSR.so
552 %{_mandir}/man3/Geo::GDAL.3pm*
553
554 %if %{with php}
555 %files -n %{php_name}-gdal
556 %defattr(644,root,root,755)
557 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/gdal.ini
558 %attr(755,root,root) %{php_extensiondir}/gdal.so
559 %attr(755,root,root) %{php_extensiondir}/gdalconst.so
560 %attr(755,root,root) %{php_extensiondir}/ogr.so
561 %attr(755,root,root) %{php_extensiondir}/osr.so
562 %endif
563
564 %files -n python-gdal
565 %defattr(644,root,root,755)
566 %{py_sitedir}/gdal.py[co]
567 %{py_sitedir}/gdalconst.py[co]
568 %{py_sitedir}/gdalnumeric.py[co]
569 %{py_sitedir}/ogr.py[co]
570 %{py_sitedir}/osr.py[co]
571 %{py_sitedir}/GDAL-*.egg-info
572 %dir %{py_sitedir}/osgeo
573 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal.so
574 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal_array.so
575 %attr(755,root,root) %{py_sitedir}/osgeo/_gdalconst.so
576 %attr(755,root,root) %{py_sitedir}/osgeo/_ogr.so
577 %attr(755,root,root) %{py_sitedir}/osgeo/_osr.so
578 %{py_sitedir}/osgeo/*.py[co]
579
580 %if %{with ruby}
581 %files -n ruby-gdal
582 %defattr(644,root,root,755)
583 %dir %{ruby_vendorarchdir}/gdal
584 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/gdal.so
585 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/gdalconst.so
586 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/ogr.so
587 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/osr.so
588 %endif
This page took 0.10635 seconds and 2 git commands to generate.