]> git.pld-linux.org Git - packages/gdal.git/blob - gdal.spec
- updated openjpeg comment
[packages/gdal.git] / gdal.spec
1 # TODO:
2 # - podofo (--with-podofo)
3 # - epsilon (--with-epsilon; BR: epsilon-devel from Enlightenment)
4 # - libgta (http://gta.nongnu.org/libgta.html)
5 # - spatialite (--with-spatialite; libspatialite: http://www.gaia-gis.it/gaia-sins/)
6 # - freexl (http://www.gaia-gis.it/FreeXL/)
7 # - rasdaman (--with-rasdaman; http://rasdaman.eecs.jacobs-university.de/trac/rasdaman/wiki/Download)
8 # - armadillo (--with-armadillo; http://arma.sourceforge.net/)
9 # - openjpeg (unreleased 1.5 or 2? needs opj_decode_tile_data symbol, not available in 1.3-1.4)
10 # - libjpeg12 (needs patching to use system one)
11 # - libkml (1.3.0 needed, not released yet)
12 # - wait for newer pcidsk, switch to external again
13 # - csharp, java, mysql
14 # - additional, proprietary(?) formats support:
15 #   - FMEObjects (http://www.safe.com/support/support-resources/fme-downloads/)
16 #   - ESRI FileGDBAPI (http://resources.arcgis.com/content/geodatabases/10.0/file-gdb-api)
17 #   - ECW (http://www.erdas.com/products/ecw/ERDASECWJPEG2000SDK/Details.aspx)
18 #   - Kakadu/JPEG2000 (http://www.kakadusoftware.com/)
19 #   - MrSID (http://www.lizardtech.com/developer/)
20 #   - MSG/EUMETSAT (http://www.eumetsat.int/Home/Main/DataAccess/SupportSoftwareTools/index.htm)
21 #   - Oracle/OCI >= 10.0.1 (for georaster); Oracle/OCI >= 8.1.7 (as DB)
22 #   - Ingres (--with-ingres=/path)
23 #   - Informix DB
24 #   - DWGdirect (members only? http://www.opendwg.org/)
25 #   - ESRI SDE (http://www.esri.com/software/arcgis/arcsde/index.html)
26 #   - OpenCL (--with-opencl; no free Linux implementation yet?)
27 #
28 # Conditional build:
29 %bcond_without  odbc    # disable odbc support
30 %bcond_without  xerces  # disable xerces support
31 %bcond_without  java    # disable Java and MDB support
32 %bcond_without  php     # disable PHP bindind
33 %bcond_without  ruby    # disable ruby binding
34 #
35 Summary:        Geospatial Data Abstraction Library
36 Summary(pl.UTF-8):      Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
37 Name:           gdal
38 Version:        1.9.0
39 Release:        1
40 License:        BSD-like
41 Group:          Libraries
42 Source0:        ftp://ftp.remotesensing.org/gdal/%{name}-%{version}.tar.gz
43 # Source0-md5:  1853f3d8eb5232ae030abe007840cade
44 Patch0:         %{name}-perl.patch
45 Patch1:         %{name}-python_install.patch
46 Patch2:         %{name}-doxy.patch
47 Patch3:         %{name}-sh.patch
48 Patch4:         %{name}-php.patch
49 URL:            http://www.gdal.org/
50 BuildRequires:  autoconf >= 2.52
51 BuildRequires:  automake
52 BuildRequires:  cfitsio-devel
53 BuildRequires:  curl-devel
54 BuildRequires:  doxygen >= 1.4.2
55 BuildRequires:  expat-devel >= 1.95.0
56 BuildRequires:  geos-devel >= 2.2.0
57 BuildRequires:  giflib-devel >= 4.0
58 BuildRequires:  hdf-devel >= 4.0
59 BuildRequires:  hdf5-devel
60 BuildRequires:  jasper-devel
61 %{?with_java:BuildRequires:     jdk}
62 %{?with_java:BuildRequires:     jpackage-utils}
63 BuildRequires:  libcsf-devel
64 BuildRequires:  libdap-devel >= 3.10
65 BuildRequires:  libgeotiff-devel >= 1.2.1
66 BuildRequires:  libjpeg-devel >= 6b
67 #BuildRequires: libkml-devel >= 1.3.0
68 BuildRequires:  libpng-devel >= 2:1.2.8
69 BuildRequires:  libstdc++-devel
70 BuildRequires:  libtiff-devel >= 4.0
71 BuildRequires:  libtool
72 BuildRequires:  libuuid-devel
73 BuildRequires:  libwebp-devel
74 BuildRequires:  libxml2-devel
75 BuildRequires:  netcdf-devel >= 4
76 BuildRequires:  ogdi-devel >= 3.1
77 #BuildRequires: pcidsk-devel > 0.3
78 BuildRequires:  perl-devel
79 %{?with_php:BuildRequires:      php-devel}
80 BuildRequires:  poppler-devel
81 # ensure it's compiled with PQescapeStringConn support
82 BuildRequires:  postgresql-backend-devel >= 8.1.4
83 BuildRequires:  postgresql-devel >= 8.1.4
84 BuildRequires:  proj-devel >= 4
85 BuildRequires:  python-devel >= 1:2.5
86 BuildRequires:  python-numpy-devel >= 1:1.0.0
87 BuildRequires:  python-setuptools
88 BuildRequires:  rpm-pythonprov
89 BuildRequires:  rpmbuild(macros) >= 1.344
90 %{?with_ruby:BuildRequires:     ruby-devel}
91 BuildRequires:  sqlite3-devel >= 3.0.0
92 BuildRequires:  swig-perl
93 BuildRequires:  swig-python >= 1.3
94 %{?with_ruby:BuildRequires:     swig-ruby}
95 %if "%{pld_release}" == "ti"
96 BuildRequires:  tetex-format-latex
97 BuildRequires:  tetex-dvips
98 %else
99 BuildRequires:  texlive-dvips
100 BuildRequires:  texlive-latex
101 %endif
102 %{?with_odbc:BuildRequires:     unixODBC-devel >= 2.2.15}
103 %{?with_xerces:BuildRequires:   xerces-c-devel >= 2.7.0}
104 BuildRequires:  xz-devel
105 BuildRequires:  zlib-devel >= 1.1.4
106 Requires:       geos >= 2.2.0
107 Requires:       libgeotiff >= 1.2.1
108 Requires:       libpng >= 2:1.2.8
109 Requires:       libtiff >= 4.0
110 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
111
112 %description
113 GDAL is a translator library for raster geospatial data formats that
114 is released under an Open Source license. As a library, it presents a
115 single abstract data model to the calling application for all
116 supported formats. The related OGR library (which lives within the
117 GDAL source tree) provides a similar capability for simple features
118 vector data.
119
120 %description -l pl.UTF-8
121 GDAL to biblioteka konwertująca między formatami rastrowych danych
122 dotyczących powierzchni Ziemi, udostępniona na licencji Open Source.
123 Jako biblioteka udostępnia aplikacjom jeden abstrakcyjny model danych
124 do wszystkich obsługiwanych formatów. Powiązana z nią biblioteka OGR
125 (której źródła są dołączone do drzewa źródeł GDAL) daje podobne
126 możliwości dla danych wektorowych.
127
128 %package devel
129 Summary:        GDAL library header files
130 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GDAL
131 Group:          Development/Libraries
132 Requires:       %{name} = %{version}-%{release}
133 Requires:       cfitsio-devel
134 Requires:       expat-devel >= 1.95.0
135 Requires:       geos-devel >= 2.2.0
136 Requires:       giflib-devel
137 Requires:       hdf-devel >= 4.0
138 Requires:       hdf5-devel
139 Requires:       jasper-devel
140 Requires:       libcsf-devel
141 Requires:       libdap-devel >= 3.10
142 Requires:       libgeotiff-devel >= 1.2.1
143 Requires:       libjpeg-devel
144 Requires:       libpng-devel >= 2:1.2.8
145 Requires:       libstdc++-devel
146 Requires:       libtiff-devel >= 4.0
147 Requires:       netcdf-devel >= 4
148 Requires:       ogdi-devel >= 3.1
149 #Requires:      pcidsk-devel > 0.3
150 Requires:       postgresql-devel
151 Requires:       sqlite3-devel >= 3.0.0
152 %{?with_odbc:Requires:  unixODBC-devel}
153 %{?with_xerces:Requires:        xerces-c-devel >= 2.7.0}
154
155 %description devel
156 GDAL library header files.
157
158 %description devel -l pl.UTF-8
159 Pliki nagłówkowe biblioteki GDAL.
160
161 %package static
162 Summary:        GDAL static libraries
163 Summary(pl.UTF-8):      Statyczne biblioteki GDAL
164 Group:          Development/Libraries
165 Requires:       %{name}-devel = %{version}-%{release}
166
167 %description static
168 GDAL static libraries.
169
170 %description static -l pl.UTF-8
171 Statyczne biblioteki GDAL.
172
173 %package -n perl-gdal
174 Summary:        Perl bindings for GDAL
175 Summary(pl.UTF-8):      Wiązania Perla do pakietu GDAL
176 Group:          Development/Languages/Perl
177 Requires:       %{name} = %{version}-%{release}
178
179 %description -n perl-gdal
180 Perl bindings for GDAL - Geo::GDAL, Geo::OGR and Geo::OSR modules.
181
182 %description -n perl-gdal -l pl.UTF-8
183 Wiązania Perla do pakietu GDAL - moduły Geo::GDAL, Geo::OGR, Geo::OSR.
184
185 %package -n php-gdal
186 Summary:        PHP bindings for GDAL library
187 Summary(pl.UTF-8):      Wiązania PHP do biblioteki GDAL
188 Group:          Development/Languages/PHP
189 Requires:       %{name} = %{version}-%{release}
190 %{?requires_php_extension}
191
192 %description -n php-gdal
193 PHP bindings for GDAL library
194
195 %description -n php-gdal -l pl.UTF-8
196 Wiązania PHP do biblioteki GDAL.
197
198 %package -n python-gdal
199 Summary:        GDAL Python module
200 Summary(pl.UTF-8):      Moduł Pythona GDAL
201 Group:          Libraries/Python
202 Requires:       %{name} = %{version}-%{release}
203 %pyrequires_eq  python-libs
204
205 %description -n python-gdal
206 GDAL Python module.
207
208 %description -n python-gdal -l pl.UTF-8
209 Moduł Pythona GDAL.
210
211 %package -n ruby-gdal
212 Summary:        Ruby bindings for GDAL
213 Summary(pl.UTF-8):      Wiązania języka Ruby do pakietu GDAL
214 Group:          Development/Languages
215 Requires:       %{name} = %{version}-%{release}
216 %{?ruby_mod_ver_requires_eq}
217
218 %description -n ruby-gdal
219 Ruby bindings for GDAL - gdal, gdalconst, ogr and osr modules.
220
221 %description -n ruby-gdal -l pl.UTF-8
222 Wiązania języka Ruby do pakietu GDAL - moduły gdal, gdalconst, ogr i
223 osr.
224
225 %prep
226 %setup -q
227 %patch0 -p1
228 %patch1 -p1
229 %patch2 -p1
230 %patch3 -p1
231 %patch4 -p1
232
233 # need to regenerate (old ones don't support perl 5.10)
234 %{__rm} swig/perl/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
235
236 %{__rm} -r man
237
238 %build
239 %{__libtoolize}
240 %{__aclocal} -I m4
241 %{__autoconf}
242 # disable grass/libgrass here, it can be built from separate gdal-grass package
243 %configure \
244         --datadir=%{_datadir}/gdal \
245         --with-dods-root=/usr \
246         --with-hide-internal-symbols \
247         %{?with_java:--with-java=%{java_home}} \
248         --with-liblzma \
249         %{?with_java:--with-mdb} \
250         --with-perl \
251         %{?with_php:--with-php} \
252         --with-poppler \
253         --with-python \
254         %{?with_ruby:--with-ruby} \
255         --with-sqlite3 \
256         --with-webp \
257         %{?with_xerces:--with-xerces} \
258         --with-xerces-inc=/usr/include/xercesc \
259         --with-xerces-lib="-lxerces-c" \
260         --without-grass \
261         --without-libgrass
262 #       --with-pcidsk=/usr (needs > 0.3)
263 # csharp builds, but has no configure option
264
265 # regenerate where needed
266 %{__make} -j1 -C swig/perl generate
267 %{?with_ruby:%{__make} -j1 -C swig/ruby generate}
268
269 %{__make} -j1
270
271 %{__make} -j1 docs
272
273 %{__make} -j1 man
274
275 %install
276 rm -rf $RPM_BUILD_ROOT
277
278 %{__make} -j1 install install-man \
279         DESTDIR=$RPM_BUILD_ROOT
280
281 rm -rf _html
282 cp -a html _html
283 cp -a ogr/html _html/ogr
284
285 %if %{with php}
286 # missing in make install
287 install -D swig/php/php_gdal.so $RPM_BUILD_ROOT%{php_extensiondir}/gdal.so
288 install -D swig/php/php_gdalconst.so $RPM_BUILD_ROOT%{php_extensiondir}/gdalconst.so
289 install -D swig/php/php_ogr.so $RPM_BUILD_ROOT%{php_extensiondir}/ogr.so
290 install -D swig/php/php_osr.so $RPM_BUILD_ROOT%{php_extensiondir}/osr.so
291 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
292 cat <<'EOF' >$RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/gdal.ini
293 ; Enable gdal extension module
294 extension=gdal.so
295 extension=gdalconst.so
296 extension=ogr.so
297 extension=osr.so
298 EOF
299 %endif
300
301 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
302 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
303 %py_postclean
304
305 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
306 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/.packlist
307 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/Const/.packlist
308 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OGR/.packlist
309 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OSR/.packlist
310
311 # some doxygen trash
312 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Geo/{GDAL.dox,GDAL/Const.dox,OGR.dox,OSR.dox}
313 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Geo/check_dox.pl
314 %{__rm} $RPM_BUILD_ROOT%{_bindir}/gdal_{fillnodata,sieve}.dox
315
316 %clean
317 rm -rf $RPM_BUILD_ROOT
318
319 %post   -p /sbin/ldconfig
320 %postun -p /sbin/ldconfig
321
322 %files
323 %defattr(644,root,root,755)
324 %doc NEWS PROVENANCE.TXT
325 %attr(755,root,root) %{_bindir}/epsg_tr.py
326 %attr(755,root,root) %{_bindir}/esri2wkt.py
327 %attr(755,root,root) %{_bindir}/gcps2vec.py
328 %attr(755,root,root) %{_bindir}/gcps2wld.py
329 %attr(755,root,root) %{_bindir}/gdal2tiles.py
330 %attr(755,root,root) %{_bindir}/gdal2xyz.py
331 %attr(755,root,root) %{_bindir}/gdal_contour
332 %attr(755,root,root) %{_bindir}/gdal_calc.py
333 %attr(755,root,root) %{_bindir}/gdal_fillnodata.py
334 %attr(755,root,root) %{_bindir}/gdal_grid
335 %attr(755,root,root) %{_bindir}/gdal_merge.py
336 %attr(755,root,root) %{_bindir}/gdal_polygonize.py
337 %attr(755,root,root) %{_bindir}/gdal_proximity.py
338 %attr(755,root,root) %{_bindir}/gdal_rasterize
339 %attr(755,root,root) %{_bindir}/gdal_retile.py
340 %attr(755,root,root) %{_bindir}/gdal_sieve.py
341 %attr(755,root,root) %{_bindir}/gdal_translate
342 %attr(755,root,root) %{_bindir}/gdaladdo
343 %attr(755,root,root) %{_bindir}/gdalbuildvrt
344 %attr(755,root,root) %{_bindir}/gdalchksum.py
345 %attr(755,root,root) %{_bindir}/gdaldem
346 %attr(755,root,root) %{_bindir}/gdalenhance
347 %attr(755,root,root) %{_bindir}/gdalident.py
348 %attr(755,root,root) %{_bindir}/gdalimport.py
349 %attr(755,root,root) %{_bindir}/gdalinfo
350 %attr(755,root,root) %{_bindir}/gdallocationinfo
351 %attr(755,root,root) %{_bindir}/gdalmanage
352 %attr(755,root,root) %{_bindir}/gdalsrsinfo
353 %attr(755,root,root) %{_bindir}/gdaltindex
354 %attr(755,root,root) %{_bindir}/gdaltransform
355 %attr(755,root,root) %{_bindir}/gdalwarp
356 %attr(755,root,root) %{_bindir}/mkgraticule.py
357 %attr(755,root,root) %{_bindir}/nearblack
358 %attr(755,root,root) %{_bindir}/ogr2ogr
359 %attr(755,root,root) %{_bindir}/ogrinfo
360 %attr(755,root,root) %{_bindir}/ogrtindex
361 %attr(755,root,root) %{_bindir}/pct2rgb.py
362 %attr(755,root,root) %{_bindir}/rgb2pct.py
363 %attr(755,root,root) %{_bindir}/testepsg
364 %attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
365 %attr(755,root,root) %ghost %{_libdir}/libgdal.so.1
366 %{_datadir}/gdal
367 %{_mandir}/man1/gdal2tiles.1*
368 %{_mandir}/man1/gdal_contour.1*
369 %{_mandir}/man1/gdal_fillnodata.1*
370 %{_mandir}/man1/gdal_grid.1*
371 %{_mandir}/man1/gdal_merge.1*
372 %{_mandir}/man1/gdal_rasterize.1*
373 %{_mandir}/man1/gdal_retile.1*
374 %{_mandir}/man1/gdal_sieve.1*
375 %{_mandir}/man1/gdal_translate.1*
376 %{_mandir}/man1/gdal_utilities.1*
377 %{_mandir}/man1/gdaladdo.1*
378 %{_mandir}/man1/gdalbuildvrt.1*
379 %{_mandir}/man1/gdaldem.1*
380 %{_mandir}/man1/gdalinfo.1*
381 %{_mandir}/man1/gdallocationinfo.1*
382 %{_mandir}/man1/gdalsrsinfo.1*
383 %{_mandir}/man1/gdaltindex.1*
384 %{_mandir}/man1/gdaltransform.1*
385 %{_mandir}/man1/gdalwarp.1*
386 %{_mandir}/man1/nearblack.1*
387 %{_mandir}/man1/ogr2ogr.1*
388 %{_mandir}/man1/ogr_utilities.1*
389 %{_mandir}/man1/ogrinfo.1*
390 %{_mandir}/man1/ogrtindex.1*
391 %{_mandir}/man1/pct2rgb.1*
392 %{_mandir}/man1/rgb2pct.1*
393
394 %files devel
395 %defattr(644,root,root,755)
396 %doc _html/*
397 %attr(755,root,root) %{_bindir}/gdal-config
398 %attr(755,root,root) %{_libdir}/libgdal.so
399 %{_libdir}/libgdal.la
400 %{_includedir}/cpl_*.h
401 %{_includedir}/cplkeywordparser.h
402 %{_includedir}/gdal*.h
403 %{_includedir}/gvgcpfit.h
404 %{_includedir}/memdataset.h
405 %{_includedir}/ogr_*.h
406 %{_includedir}/ogrsf_frmts.h
407 %{_includedir}/rawdataset.h
408 %{_includedir}/thinplatespline.h
409 %{_includedir}/vrtdataset.h
410 %{_mandir}/man1/gdal-config.1*
411
412 %files static
413 %defattr(644,root,root,755)
414 %{_libdir}/libgdal.a
415
416 %files -n perl-gdal
417 %defattr(644,root,root,755)
418 %dir %{perl_vendorarch}/Geo
419 %{perl_vendorarch}/Geo/GDAL.pm
420 %dir %{perl_vendorarch}/Geo/GDAL
421 %{perl_vendorarch}/Geo/GDAL/Const.pm
422 %{perl_vendorarch}/Geo/OGR.pm
423 %{perl_vendorarch}/Geo/OSR.pm
424 %dir %{perl_vendorarch}/auto/Geo
425 %dir %{perl_vendorarch}/auto/Geo/GDAL
426 %{perl_vendorarch}/auto/Geo/GDAL/GDAL.bs
427 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/GDAL.so
428 %dir %{perl_vendorarch}/auto/Geo/GDAL/Const
429 %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.bs
430 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.so
431 %dir %{perl_vendorarch}/auto/Geo/OGR
432 %{perl_vendorarch}/auto/Geo/OGR/OGR.bs
433 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OGR/OGR.so
434 %dir %{perl_vendorarch}/auto/Geo/OSR
435 %{perl_vendorarch}/auto/Geo/OSR/OSR.bs
436 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OSR/OSR.so
437
438 %if %{with php}
439 %files -n php-gdal
440 %defattr(644,root,root,755)
441 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/gdal.ini
442 %attr(755,root,root) %{php_extensiondir}/gdal.so
443 %attr(755,root,root) %{php_extensiondir}/gdalconst.so
444 %attr(755,root,root) %{php_extensiondir}/ogr.so
445 %attr(755,root,root) %{php_extensiondir}/osr.so
446 %endif
447
448 %files -n python-gdal
449 %defattr(644,root,root,755)
450 %{py_sitedir}/gdal.py[co]
451 %{py_sitedir}/gdalconst.py[co]
452 %{py_sitedir}/gdalnumeric.py[co]
453 %{py_sitedir}/ogr.py[co]
454 %{py_sitedir}/osr.py[co]
455 %{py_sitedir}/GDAL-*.egg-info
456 %dir %{py_sitedir}/osgeo
457 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal.so
458 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal_array.so
459 %attr(755,root,root) %{py_sitedir}/osgeo/_gdalconst.so
460 %attr(755,root,root) %{py_sitedir}/osgeo/_ogr.so
461 %attr(755,root,root) %{py_sitedir}/osgeo/_osr.so
462 %{py_sitedir}/osgeo/*.py[co]
463
464 %if %{with ruby}
465 %files -n ruby-gdal
466 %defattr(644,root,root,755)
467 %dir %{ruby_sitearchdir}/gdal
468 %attr(755,root,root) %{ruby_sitearchdir}/gdal/gdal.so
469 %attr(755,root,root) %{ruby_sitearchdir}/gdal/gdalconst.so
470 %attr(755,root,root) %{ruby_sitearchdir}/gdal/ogr.so
471 %attr(755,root,root) %{ruby_sitearchdir}/gdal/osr.so
472 %endif
This page took 0.056267 seconds and 3 git commands to generate.