]> git.pld-linux.org Git - packages/gdal.git/blob - gdal.spec
- release 9
[packages/gdal.git] / gdal.spec
1 # TODO: csharp, java, mysql
2 #
3 # Conditional build:
4 %bcond_without  odbc    # disable odbc support
5 %bcond_without  xerces  # disable xerces support
6 %bcond_without  ruby    # disable ruby support
7 #
8 Summary:        Geospatial Data Abstraction Library
9 Summary(pl.UTF-8):      Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
10 Name:           gdal
11 Version:        1.7.3
12 Release:        9
13 License:        BSD-like
14 Group:          Libraries
15 Source0:        ftp://ftp.remotesensing.org/gdal/%{name}-%{version}.tar.gz
16 # Source0-md5:  c4673970bd2285032de9ae9bbd82754a
17 Patch0:         %{name}-perl.patch
18 Patch1:         %{name}-ruby.patch
19 Patch2:         %{name}-asneeded.patch
20 Patch3:         %{name}-python_install.patch
21 Patch4:         %{name}-libdap.patch
22 Patch5:         %{name}-doxy.patch
23 URL:            http://www.gdal.org/
24 BuildRequires:  autoconf >= 2.52
25 BuildRequires:  automake
26 BuildRequires:  cfitsio-devel
27 BuildRequires:  doxygen >= 1.4.2
28 BuildRequires:  expat-devel >= 1.95.0
29 BuildRequires:  geos-devel >= 2.2
30 BuildRequires:  giflib-devel >= 4.0
31 BuildRequires:  hdf-devel >= 4.0
32 BuildRequires:  hdf5-devel
33 BuildRequires:  jasper-devel
34 BuildRequires:  libcsf-devel
35 BuildRequires:  libdap-devel >= 3.10
36 BuildRequires:  libgeotiff-devel >= 1.2.1
37 BuildRequires:  libjpeg-devel >= 6b
38 BuildRequires:  libpng-devel >= 2:1.2.8
39 BuildRequires:  libstdc++-devel
40 BuildRequires:  libtiff-devel >= 3.6.0
41 BuildRequires:  libtool
42 BuildRequires:  libuuid-devel
43 BuildRequires:  libxml2-devel
44 BuildRequires:  netcdf-devel
45 BuildRequires:  ogdi-devel >= 3.1
46 BuildRequires:  pcidsk-devel
47 BuildRequires:  perl-devel
48 BuildRequires:  postgresql-backend-devel
49 BuildRequires:  postgresql-devel
50 BuildRequires:  proj-devel
51 BuildRequires:  python-devel >= 1:2.5
52 BuildRequires:  python-numpy-devel >= 1:1.0.0
53 BuildRequires:  rpm-pythonprov
54 %{?with_ruby:BuildRequires:     ruby-devel}
55 BuildRequires:  sqlite3-devel >= 3
56 BuildRequires:  swig-perl
57 BuildRequires:  swig-python >= 1.3
58 %{?with_ruby:BuildRequires:     swig-ruby}
59 %if "%{pld_release}" == "ti"
60 BuildRequires:  tetex-format-latex
61 BuildRequires:  tetex-dvips
62 %else
63 BuildRequires:  texlive-dvips
64 BuildRequires:  texlive-latex
65 %endif
66 %{?with_odbc:BuildRequires:     unixODBC-devel >= 2.2.15}
67 %{?with_xerces:BuildRequires:   xerces-c-devel >= 2.2.0}
68 BuildRequires:  zlib-devel >= 1.1.4
69 Requires:       geos >= 2.2
70 Requires:       libgeotiff >= 1.2.1
71 Requires:       libpng >= 2:1.2.8
72 Requires:       libtiff >= 3.6.0
73 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
74
75 %description
76 GDAL is a translator library for raster geospatial data formats that
77 is released under an Open Source license. As a library, it presents a
78 single abstract data model to the calling application for all
79 supported formats. The related OGR library (which lives within the
80 GDAL source tree) provides a similar capability for simple features
81 vector data.
82
83 %description -l pl.UTF-8
84 GDAL to biblioteka konwertująca między formatami rastrowych danych
85 dotyczących powierzchni Ziemi, udostępniona na licencji Open Source.
86 Jako biblioteka udostępnia aplikacjom jeden abstrakcyjny model danych
87 do wszystkich obsługiwanych formatów. Powiązana z nią biblioteka OGR
88 (której źródła są dołączone do drzewa źródeł GDAL) daje podobne
89 możliwości dla danych wektorowych.
90
91 %package devel
92 Summary:        GDAL library header files
93 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GDAL
94 Group:          Development/Libraries
95 Requires:       %{name} = %{version}-%{release}
96 Requires:       cfitsio-devel
97 Requires:       expat-devel >= 1.95.0
98 Requires:       geos-devel >= 2.2
99 Requires:       giflib-devel
100 Requires:       hdf-devel >= 4.0
101 Requires:       hdf5-devel
102 Requires:       jasper-devel
103 Requires:       libcsf-devel
104 Requires:       libdap-devel >= 3.10
105 Requires:       libgeotiff-devel >= 1.2.1
106 Requires:       libjpeg-devel
107 Requires:       libpng-devel >= 2:1.2.8
108 Requires:       libstdc++-devel
109 Requires:       libtiff-devel >= 3.6.0
110 Requires:       netcdf-devel
111 Requires:       ogdi-devel >= 3.1
112 Requires:       pcidsk-devel
113 Requires:       postgresql-devel
114 Requires:       sqlite3-devel >= 3
115 %{?with_odbc:Requires:  unixODBC-devel}
116 %{?with_xerces:Requires:        xerces-c-devel >= 2.7.0}
117
118 %description devel
119 GDAL library header files.
120
121 %description devel -l pl.UTF-8
122 Pliki nagłówkowe biblioteki GDAL.
123
124 %package static
125 Summary:        GDAL static libraries
126 Summary(pl.UTF-8):      Statyczne biblioteki GDAL
127 Group:          Development/Libraries
128 Requires:       %{name}-devel = %{version}-%{release}
129
130 %description static
131 GDAL static libraries.
132
133 %description static -l pl.UTF-8
134 Statyczne biblioteki GDAL.
135
136 %package -n perl-gdal
137 Summary:        Perl bindings for GDAL
138 Summary(pl.UTF-8):      Wiązania Perla do pakietu GDAL
139 Group:          Development/Languages/Perl
140 Requires:       %{name} = %{version}-%{release}
141
142 %description -n perl-gdal
143 Perl bindings for GDAL - Geo::GDAL, Geo::OGR and Geo::OSR modules.
144
145 %description -n perl-gdal -l pl.UTF-8
146 Wiązania Perla do pakietu GDAL - moduły Geo::GDAL, Geo::OGR, Geo::OSR.
147
148 %package -n python-gdal
149 Summary:        GDAL Python module
150 Summary(pl.UTF-8):      Moduł Pythona GDAL
151 Group:          Libraries/Python
152 Requires:       %{name} = %{version}-%{release}
153 %pyrequires_eq  python-libs
154
155 %description -n python-gdal
156 GDAL Python module.
157
158 %description -n python-gdal -l pl.UTF-8
159 Moduł Pythona GDAL.
160
161 %package -n ruby-gdal
162 Summary:        Ruby bindings for GDAL
163 Summary(pl.UTF-8):      Wiązania języka Ruby do pakietu GDAL
164 Group:          Development/Languages
165 Requires:       %{name} = %{version}-%{release}
166 %{?ruby_mod_ver_requires_eq}
167
168 %description -n ruby-gdal
169 Ruby bindings for GDAL - gdal, gdalconst, ogr and osr modules.
170
171 %description -n ruby-gdal -l pl.UTF-8
172 Wiązania języka Ruby do pakietu GDAL - moduły gdal, gdalconst, ogr i
173 osr.
174
175 %prep
176 %setup -q
177 %patch0 -p1
178 %patch1 -p1
179 %patch2 -p1
180 %patch3 -p1
181 %patch4 -p1
182 %patch5 -p1
183
184 # need to regenerate (old ones don't support perl 5.10)
185 %{__rm} swig/perl/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
186 # includes updated for Ruby 1.9
187 %{__rm} swig/ruby/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
188
189 %{__rm} -r man
190
191 %build
192 # $PYTHON_INCLUDES is set only with --with-ogpython, but we have --with-python,
193 # and $PYTHON_INCLUDES is needed to detect numpy properly
194 export PYTHON_INCLUDES=-I%{py_incdir}
195
196 %{__libtoolize}
197 %{__aclocal} -I m4
198 %{__autoconf}
199 # disable grass/libgrass here, it can be built from separate gdal-grass package
200 %configure \
201         --datadir=%{_datadir}/gdal \
202         --with-dods-root=/usr \
203         --with-hide-internal-symbols \
204         --with-pcidsk=/usr \
205         --with-perl \
206         --with-python \
207         %{?with_ruby:--with-ruby} \
208         --with-sqlite3 \
209         %{?with_xerces:--with-xerces} \
210         --with-xerces-inc=/usr/include/xercesc \
211         --with-xerces-lib="-lxerces-c" \
212         --without-grass \
213         --without-libgrass
214 # --with-php needs Zend API update
215 # java broken, no configure option
216 # csharp builds, but has no configure option
217
218 # regenerate where needed
219 %{__make} -j1 -C swig/perl generate
220 %{?with_ruby:%{__make} -j1 -C swig/ruby generate}
221
222 %{__make} -j1
223
224 %{__make} -j1 docs
225
226 %{__make} -j1 man
227
228 %install
229 rm -rf $RPM_BUILD_ROOT
230
231 %{__make} -j1 install install-man \
232         DESTDIR=$RPM_BUILD_ROOT
233
234 rm -rf _html
235 cp -a html _html
236 cp -a ogr/html _html/ogr
237
238 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
239 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
240 %py_postclean
241
242 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
243 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/.packlist
244 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/Const/.packlist
245 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OGR/.packlist
246 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OSR/.packlist
247
248 # some doxygen trash
249 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Geo/GDAL.dox
250 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Geo/GDAL/Const.dox
251 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Geo/OGR.dox
252 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Geo/OSR.dox
253
254 %if %{with ruby}
255 %{__rm} $RPM_BUILD_ROOT%{ruby_sitearchdir}/gdal/*.la
256 %endif
257
258 %clean
259 rm -rf $RPM_BUILD_ROOT
260
261 %post   -p /sbin/ldconfig
262 %postun -p /sbin/ldconfig
263
264 %files
265 %defattr(644,root,root,755)
266 %doc NEWS PROVENANCE.TXT
267 %attr(755,root,root) %{_bindir}/epsg_tr.py
268 %attr(755,root,root) %{_bindir}/esri2wkt.py
269 %attr(755,root,root) %{_bindir}/gcps2vec.py
270 %attr(755,root,root) %{_bindir}/gcps2wld.py
271 %attr(755,root,root) %{_bindir}/gdal2tiles.py
272 %attr(755,root,root) %{_bindir}/gdal2xyz.py
273 %attr(755,root,root) %{_bindir}/gdal_contour
274 %attr(755,root,root) %{_bindir}/gdal_fillnodata.py
275 %attr(755,root,root) %{_bindir}/gdal_grid
276 %attr(755,root,root) %{_bindir}/gdal_merge.py
277 %attr(755,root,root) %{_bindir}/gdal_polygonize.py
278 %attr(755,root,root) %{_bindir}/gdal_proximity.py
279 %attr(755,root,root) %{_bindir}/gdal_rasterize
280 %attr(755,root,root) %{_bindir}/gdal_retile.py
281 %attr(755,root,root) %{_bindir}/gdal_sieve.py
282 %attr(755,root,root) %{_bindir}/gdal_translate
283 %attr(755,root,root) %{_bindir}/gdaladdo
284 %attr(755,root,root) %{_bindir}/gdalbuildvrt
285 %attr(755,root,root) %{_bindir}/gdalchksum.py
286 %attr(755,root,root) %{_bindir}/gdaldem
287 %attr(755,root,root) %{_bindir}/gdalenhance
288 %attr(755,root,root) %{_bindir}/gdalident.py
289 %attr(755,root,root) %{_bindir}/gdalimport.py
290 %attr(755,root,root) %{_bindir}/gdalinfo
291 %attr(755,root,root) %{_bindir}/gdalmanage
292 %attr(755,root,root) %{_bindir}/gdaltindex
293 %attr(755,root,root) %{_bindir}/gdaltransform
294 %attr(755,root,root) %{_bindir}/gdalwarp
295 %attr(755,root,root) %{_bindir}/mkgraticule.py
296 %attr(755,root,root) %{_bindir}/nearblack
297 %attr(755,root,root) %{_bindir}/ogr2ogr
298 %attr(755,root,root) %{_bindir}/ogrinfo
299 %attr(755,root,root) %{_bindir}/ogrtindex
300 %attr(755,root,root) %{_bindir}/pct2rgb.py
301 %attr(755,root,root) %{_bindir}/rgb2pct.py
302 %attr(755,root,root) %{_bindir}/testepsg
303 %attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
304 %attr(755,root,root) %ghost %{_libdir}/libgdal.so.1
305 %{_datadir}/gdal
306 %{_mandir}/man1/gdal2tiles.1*
307 %{_mandir}/man1/gdal_contour.1*
308 %{_mandir}/man1/gdal_fillnodata.1*
309 %{_mandir}/man1/gdal_grid.1*
310 %{_mandir}/man1/gdal_merge.1*
311 %{_mandir}/man1/gdal_rasterize.1*
312 %{_mandir}/man1/gdal_retile.1*
313 %{_mandir}/man1/gdal_sieve.1*
314 %{_mandir}/man1/gdal_translate.1*
315 %{_mandir}/man1/gdal_utilities.1*
316 %{_mandir}/man1/gdaladdo.1*
317 %{_mandir}/man1/gdalbuildvrt.1*
318 %{_mandir}/man1/gdaldem.1*
319 %{_mandir}/man1/gdalinfo.1*
320 %{_mandir}/man1/gdaltindex.1*
321 %{_mandir}/man1/gdaltransform.1*
322 %{_mandir}/man1/gdalwarp.1*
323 %{_mandir}/man1/nearblack.1*
324 %{_mandir}/man1/ogr2ogr.1*
325 %{_mandir}/man1/ogr_utilities.1*
326 %{_mandir}/man1/ogrinfo.1*
327 %{_mandir}/man1/ogrtindex.1*
328 %{_mandir}/man1/pct2rgb.1*
329 %{_mandir}/man1/rgb2pct.1*
330
331 %files devel
332 %defattr(644,root,root,755)
333 %doc _html/*
334 %attr(755,root,root) %{_bindir}/gdal-config
335 %attr(755,root,root) %{_libdir}/libgdal.so
336 %{_libdir}/libgdal.la
337 %{_includedir}/cpl_*.h
338 %{_includedir}/cplkeywordparser.h
339 %{_includedir}/gdal*.h
340 %{_includedir}/gvgcpfit.h
341 %{_includedir}/memdataset.h
342 %{_includedir}/ogr_*.h
343 %{_includedir}/ogrsf_frmts.h
344 %{_includedir}/rawdataset.h
345 %{_includedir}/thinplatespline.h
346 %{_includedir}/vrtdataset.h
347 %{_mandir}/man1/gdal-config.1*
348
349 %files static
350 %defattr(644,root,root,755)
351 %{_libdir}/libgdal.a
352
353 %files -n perl-gdal
354 %defattr(644,root,root,755)
355 %dir %{perl_vendorarch}/Geo
356 %{perl_vendorarch}/Geo/GDAL.pm
357 %dir %{perl_vendorarch}/Geo/GDAL
358 %{perl_vendorarch}/Geo/GDAL/Const.pm
359 %{perl_vendorarch}/Geo/OGR.pm
360 %{perl_vendorarch}/Geo/OSR.pm
361 %dir %{perl_vendorarch}/auto/Geo
362 %dir %{perl_vendorarch}/auto/Geo/GDAL
363 %{perl_vendorarch}/auto/Geo/GDAL/GDAL.bs
364 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/GDAL.so
365 %dir %{perl_vendorarch}/auto/Geo/GDAL/Const
366 %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.bs
367 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.so
368 %dir %{perl_vendorarch}/auto/Geo/OGR
369 %{perl_vendorarch}/auto/Geo/OGR/OGR.bs
370 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OGR/OGR.so
371 %dir %{perl_vendorarch}/auto/Geo/OSR
372 %{perl_vendorarch}/auto/Geo/OSR/OSR.bs
373 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OSR/OSR.so
374
375 %files -n python-gdal
376 %defattr(644,root,root,755)
377 %{py_sitedir}/gdal.py[co]
378 %{py_sitedir}/gdalconst.py[co]
379 %{py_sitedir}/gdalnumeric.py[co]
380 %{py_sitedir}/ogr.py[co]
381 %{py_sitedir}/osr.py[co]
382 %{py_sitedir}/GDAL-*.egg-info
383 %dir %{py_sitedir}/osgeo
384 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal.so
385 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal_array.so
386 %attr(755,root,root) %{py_sitedir}/osgeo/_gdalconst.so
387 %attr(755,root,root) %{py_sitedir}/osgeo/_ogr.so
388 %attr(755,root,root) %{py_sitedir}/osgeo/_osr.so
389 %{py_sitedir}/osgeo/*.py[co]
390
391 %if %{with ruby}
392 %files -n ruby-gdal
393 %defattr(644,root,root,755)
394 %dir %{ruby_sitearchdir}/gdal
395 %attr(755,root,root) %{ruby_sitearchdir}/gdal/gdal.so
396 %attr(755,root,root) %{ruby_sitearchdir}/gdal/gdalconst.so
397 %attr(755,root,root) %{ruby_sitearchdir}/gdal/ogr.so
398 %attr(755,root,root) %{ruby_sitearchdir}/gdal/osr.so
399 %endif
This page took 0.052322 seconds and 3 git commands to generate.