]> git.pld-linux.org Git - packages/gdal.git/blob - gdal.spec
- updated to 1.2.3, removed obsolete gcc patch
[packages/gdal.git] / gdal.spec
1 #
2 # TODO:
3 # - consider using GRASS (or GDAL in GRASS? build trap possible)
4 #
5 Summary:        Geospatial Data Abstraction Library
6 Summary(pl):    Biblioteka abstrakcji danych dotycz±cych powierzchni Ziemi
7 Name:           gdal
8 Version:        1.2.3
9 Release:        1
10 License:        BSD-like
11 Group:          Libraries
12 Source0:        ftp://ftp.remotesensing.org/pub/gdal/%{name}-%{version}.tar.gz
13 # Source0-md5:  6fe5b737e3ab323a34dea7578cc7fc9b
14 Patch0:         %{name}-pgsql.patch
15 Patch1:         %{name}-DESTDIR.patch
16 URL:            http://www.remotesensing.org/gdal/
17 BuildRequires:  autoconf
18 BuildRequires:  cfitsio-devel
19 BuildRequires:  doxygen
20 BuildRequires:  hdf-devel >= 4.0
21 BuildRequires:  jasper-devel
22 BuildRequires:  libgeotiff-devel >= 1.2.1
23 BuildRequires:  libjpeg-devel >= 6b
24 BuildRequires:  libpng-devel >= 1.0.6
25 BuildRequires:  libstdc++-devel
26 BuildRequires:  libtiff-devel >= 3.6.0
27 BuildRequires:  libungif-devel >= 4.0
28 BuildRequires:  netcdf-devel
29 BuildRequires:  ogdi-devel >= 3.1
30 BuildRequires:  postgresql-devel
31 BuildRequires:  postgresql-backend-devel
32 BuildRequires:  python-devel
33 BuildRequires:  rpm-pythonprov
34 BuildRequires:  unixODBC-devel
35 BuildRequires:  xerces-c-devel >= 2.2.0
36 BuildRequires:  zlib-devel >= 1.1.4
37 Requires:       libgeotiff >= 1.2.1
38 Requires:       libtiff >= 3.6.0
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 GDAL is a translator library for raster geospatial data formats that
43 is released under an Open Source license. As a library, it presents a
44 single abstract data model to the calling application for all
45 supported formats. The related OGR library (which lives within the
46 GDAL source tree) provides a similar capability for simple features
47 vector data.
48
49 %description -l pl
50 GDAL to biblioteka konwertuj±ca miêdzy formatami rastrowych danych
51 dotycz±cych powierzchni Ziemi, udostêpniona na licencji Open Source.
52 Jako biblioteka udostêpnia aplikacjom jeden abstrakcyjny model danych
53 do wszystkich obs³ugiwanych formatów. Powi±zana z ni± biblioteka OGR
54 (której ¼ród³a s± do³±czone do drzewa ¼róde³ GDAL) daje podobne
55 mo¿liwo¶ci dla danych wektorowych.
56
57 %package devel
58 Summary:        GDAL library header files
59 Summary(pl):    Pliki nag³ówkowe biblioteki GDAL
60 Group:          Development/Libraries
61 Requires:       %{name} = %{version}-%{release}
62 Requires:       cfitsio-devel
63 Requires:       hdf-devel >= 4.0
64 Requires:       jasper-devel
65 Requires:       libgeotiff-devel >= 1.2.1
66 Requires:       libjpeg-devel
67 Requires:       libpng-devel >= 1.0.6
68 Requires:       libstdc++-devel
69 Requires:       libtiff-devel >= 3.6.0
70 Requires:       libungif-devel
71 Requires:       netcdf-devel
72 Requires:       ogdi-devel >= 3.1
73 Requires:       postgresql-devel
74 Requires:       unixODBC-devel
75 Requires:       xerces-c-devel >= 2.2.0
76
77 %description devel
78 GDAL library header files.
79
80 %description devel -l pl
81 Pliki nag³ówkowe biblioteki GDAL.
82
83 %package static
84 Summary:        GDAL static libraries
85 Summary(pl):    Statyczne biblioteki GDAL
86 Group:          Development/Libraries
87 Requires:       %{name}-devel = %{version}-%{release}
88
89 %description static
90 GDAL static libraries.
91
92 %description static -l pl
93 Statyczne biblioteki GDAL.
94
95 %package -n python-gdal
96 Summary:        GDAL Python module
97 Summary(pl):    Modu³ Pythona GDAL
98 Group:          Libraries/Python
99 Requires:       %{name} = %{version}-%{release}
100
101 %description -n python-gdal
102 GDAL Python module.
103
104 %description -n python-gdal -l pl
105 Modu³ Pythona GDAL.
106
107 %prep
108 %setup -q
109 %patch0 -p1
110 %patch1 -p1
111
112 %{__perl} -pi -e "s@lib/python@%{_lib}/python@" aclocal.m4
113
114 %build
115 %{__autoconf}
116 %configure \
117         --datadir=%{_datadir}/gdal \
118         --with-pymoddir=%{py_sitedir} \
119         --with-xerces \
120         --with-xerces-inc=/usr/include/xercesc \
121         --with-xerces-lib="-lxerces-c" \
122         --without-grass
123
124 %{__make}
125
126 %{__make} docs
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130
131 %{__make} install \
132         DESTDIR=$RPM_BUILD_ROOT
133
134 mv -f ogr/html html/org
135
136 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{la,a}
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %post   -p /sbin/ldconfig
142 %postun -p /sbin/ldconfig
143
144 %files
145 %defattr(644,root,root,755)
146 %doc ChangeLog NEWS
147 %attr(755,root,root) %{_bindir}/*
148 %exclude %{_bindir}/gdal-config
149 %attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
150 %{_datadir}/gdal
151 %{_mandir}/man1/*
152 %exclude %{_mandir}/man1/gdal-config.1*
153
154 %files devel
155 %defattr(644,root,root,755)
156 %doc html/*
157 %attr(755,root,root) %{_bindir}/gdal-config
158 %attr(755,root,root) %{_libdir}/libgdal.so
159 %{_libdir}/libgdal.la
160 %{_includedir}/*.h
161 %{_mandir}/man1/gdal-config.1*
162
163 %files static
164 %defattr(644,root,root,755)
165 %{_libdir}/*.a
166
167 %files -n python-gdal
168 %defattr(644,root,root,755)
169 %attr(755,root,root) %{py_sitedir}/_gdalmodule.so
170 %{py_sitedir}/*.py
This page took 0.03625 seconds and 3 git commands to generate.