]> git.pld-linux.org Git - packages/gdal.git/blob - gdal.spec
4daa99f550083d77c90ee0a45ee487afb2f09b1e
[packages/gdal.git] / gdal.spec
1 # TODO:
2 # - be reasonable about devel dependencies - you do not need all of them to
3 #   use gdal (probably a gdal module or driver shall not imply devel
4 #   dependency)
5 # - libjpeg12 (needs patching to use system one, --with-jpeg12 is not sufficient as of 1.9.2)
6 # - libkml (1.3.0 needed, not released yet)
7 # - wait for newer pcidsk, switch to external again
8 # - csharp, java
9 # - additional, proprietary(?) formats support:
10 #   - FMEObjects (http://www.safe.com/support/support-resources/fme-downloads/)
11 #   - ESRI FileGDBAPI (http://resources.arcgis.com/content/geodatabases/10.0/file-gdb-api)
12 #   - ECW (http://www.erdas.com/products/ecw/ERDASECWJPEG2000SDK/Details.aspx)
13 #   - Kakadu/JPEG2000 (http://www.kakadusoftware.com/)
14 #   - MrSID (http://www.lizardtech.com/developer/)
15 #   - MSG/EUMETSAT (http://www.eumetsat.int/Home/Main/DataAccess/SupportSoftwareTools/index.htm)
16 #   - Ingres (--with-ingres=/path)
17 #   - Informix DB (--with-idb)
18 #   - DWGdirect (members only? http://www.opendwg.org/)
19 #   - ESRI SDE (http://www.esri.com/software/arcgis/arcsde/index.html)
20 #
21 # Conditional build:
22 %bcond_without  armadillo       # Armadillo support for faster TPS transform
23 %bcond_without  crnlib          # DDS support via crunch/crnlib
24 %bcond_without  epsilon         # EPSILON wavelet compression support
25 %bcond_without  fyba            # SOSI geodata support using FYBA
26 %bcond_with     grass           # GRASS support (note: dependency loop; use gdal-grass.spec instead)
27 %bcond_without  gta             # GTA format support
28 %bcond_without  kea             # KEA format support
29 %bcond_without  mysql           # MySQL DB support
30 %bcond_with     oci             # ORACLE OCI DB and Georaster support
31 %bcond_without  odbc            # ODBC DB support
32 %bcond_without  opencl          # OpenCL (GPU) support
33 %bcond_without  openjpeg        # OpenJPEG 2 (JPEG2000) support
34 %bcond_with     podofo          # PDF support via podofo instead of poppler
35 %bcond_without  poppler         # PDF support via poppler
36 %bcond_without  rasdaman        # Rasdaman support
37 %bcond_without  spatialite      # SpatiaLite support
38 %bcond_without  xerces          # Xerces support
39 %bcond_without  java            # Java and MDB support
40 %bcond_with     php             # PHP binding [PHP 7 not supported by swig 3.0.x]
41 %bcond_with     ruby            # Ruby binding [not available as of 2.0.2]
42
43 %if %{with podofo}
44 %undefine       with_poppler
45 %endif
46 %if 0%{!?php_name:1}
47 %define         php_name        php55
48 %endif
49 Summary:        Geospatial Data Abstraction Library
50 Summary(pl.UTF-8):      Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
51 Name:           gdal
52 Version:        2.2.4
53 Release:        0.1
54 License:        BSD-like
55 Group:          Libraries
56 Source0:        http://download.osgeo.org/gdal/%{version}/%{name}-%{version}.tar.xz
57 # Source0-md5:  51b1df61dbdf81473689fab3075e7a5e
58 Patch0:         %{name}-perl.patch
59 Patch2:         %{name}-php.patch
60 Patch3:         %{name}-fpic.patch
61 Patch9:         %{name}-dds.patch
62 Patch11:        %{name}-armadillo.patch
63 Patch12:        %{name}-rasdaman.patch
64 Patch13:        %{name}-pluginsdir.patch
65 Patch15:        libx32.patch
66 URL:            http://www.gdal.org/
67 %{?with_php:BuildRequires:      %{php_name}-devel}
68 %{?with_opencl:BuildRequires:   OpenCL-devel >= 1.0}
69 %{?with_armadillo:BuildRequires:        armadillo-devel}
70 BuildRequires:  autoconf >= 2.52
71 BuildRequires:  automake
72 BuildRequires:  cfitsio-devel
73 %{?with_crnlib:BuildRequires:   crnlib-devel}
74 BuildRequires:  curl-devel
75 BuildRequires:  doxygen >= 1.4.2
76 %{?with_epsilon:BuildRequires:  epsilon-compressor-devel}
77 BuildRequires:  expat-devel >= 1.95.0
78 %{?with_fyba:BuildRequires:     fyba-devel}
79 BuildRequires:  freexl-devel >= 1.0
80 BuildRequires:  gcc >= 6:4.1
81 BuildRequires:  geos-devel >= 3.1.0
82 BuildRequires:  giflib-devel >= 4.0
83 %{?with_grass:BuildRequires:    grass-devel >= 6.4}
84 BuildRequires:  hdf-devel >= 4.0
85 BuildRequires:  hdf5-devel
86 BuildRequires:  jasper-devel
87 %{?with_java:BuildRequires:     jdk}
88 %{?with_java:BuildRequires:     jpackage-utils}
89 BuildRequires:  json-c-devel >= 0.11
90 %{?with_kea:BuildRequires:      kealib-devel}
91 BuildRequires:  libcsf-devel >= 2.0-0.041111.6
92 BuildRequires:  libdap-devel >= 3.10
93 BuildRequires:  libgeotiff-devel >= 1.2.1
94 %{?with_gta:BuildRequires:      libgta-devel}
95 BuildRequires:  libjpeg-devel >= 6b
96 #BuildRequires: libkml-devel >= 1.3.0
97 BuildRequires:  libpng-devel >= 2:1.2.8
98 %{?with_spatialite:BuildRequires:       libspatialite-devel}
99 BuildRequires:  libstdc++-devel
100 BuildRequires:  libtiff-devel >= 4.0
101 BuildRequires:  libtool
102 BuildRequires:  libuuid-devel
103 BuildRequires:  libwebp-devel
104 BuildRequires:  libxml2-devel >= 2
105 %{?with_mysql:BuildRequires:    /usr/bin/mysql_config}
106 BuildRequires:  netcdf-devel >= 4.1
107 BuildRequires:  ogdi-devel >= 3.1
108 %{?with_openjpeg:BuildRequires: openjpeg2-devel >= 2.0.0-2}
109 # 8.1.7 for DB support, 10.0.1 for georaster
110 %{?with_oci:BuildRequires:      oracle-instantclient-devel >= 10.0.1}
111 #BuildRequires: pcidsk-devel > 0.3
112 BuildRequires:  perl-devel
113 %{?with_podofo:BuildRequires:   podofo-devel}
114 %{?with_poppler:BuildRequires:  poppler-devel >= 0.24}
115 # ensure it's compiled with PQescapeStringConn support
116 BuildRequires:  postgresql-backend-devel >= 8.1.4
117 BuildRequires:  postgresql-devel >= 8.1.4
118 BuildRequires:  proj-devel >= 4
119 BuildRequires:  python-devel >= 1:2.5
120 BuildRequires:  python-numpy-devel >= 1:1.0.0
121 BuildRequires:  python-setuptools
122 %{?with_rasdaman:BuildRequires: rasdaman-devel}
123 BuildRequires:  rpm-pythonprov
124 %{?with_ruby:BuildRequires:     rpm-rubyprov}
125 BuildRequires:  rpmbuild(macros) >= 1.344
126 %{?with_ruby:BuildRequires:     ruby-devel}
127 BuildRequires:  sed >= 4.0
128 BuildRequires:  sqlite3-devel >= 3.0.0
129 BuildRequires:  swig-perl
130 BuildRequires:  swig-php >= 2.0.12-2
131 BuildRequires:  swig-python >= 1.3
132 %{?with_ruby:BuildRequires:     swig-ruby}
133 BuildRequires:  texlive-dvips
134 BuildRequires:  texlive-latex
135 %{?with_odbc:BuildRequires:     unixODBC-devel >= 2.2.15}
136 %{?with_xerces:BuildRequires:   xerces-c-devel >= 2.7.0}
137 BuildRequires:  xz-devel
138 BuildRequires:  zlib-devel >= 1.1.4
139 Requires:       freexl >= 1.0
140 Requires:       geos >= 3.1.0
141 Requires:       libgeotiff >= 1.2.1
142 Requires:       libpng >= 2:1.2.8
143 Requires:       libtiff >= 4.0
144 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
145
146 %description
147 GDAL is a translator library for raster geospatial data formats that
148 is released under an Open Source license. As a library, it presents a
149 single abstract data model to the calling application for all
150 supported formats. The related OGR library (which lives within the
151 GDAL source tree) provides a similar capability for simple features
152 vector data.
153
154 %description -l pl.UTF-8
155 GDAL to biblioteka konwertująca między formatami rastrowych danych
156 dotyczących powierzchni Ziemi, udostępniona na licencji Open Source.
157 Jako biblioteka udostępnia aplikacjom jeden abstrakcyjny model danych
158 do wszystkich obsługiwanych formatów. Powiązana z nią biblioteka OGR
159 (której źródła są dołączone do drzewa źródeł GDAL) daje podobne
160 możliwości dla danych wektorowych.
161
162 %package devel
163 Summary:        GDAL library header files
164 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GDAL
165 Group:          Development/Libraries
166 Requires:       %{name} = %{version}-%{release}
167 %{?with_opencl:Requires:        OpenCL-devel >= 1.0}
168 %{?with_armadillo:Requires:     armadillo-devel}
169 Requires:       cfitsio-devel
170 %{?with_crnlib:Requires:        crnlib-devel}
171 Requires:       curl-devel
172 %{?with_epsilon:Requires:       epsilon-compressor-devel}
173 %{?with_fyba:Requires:  fyba-devel}
174 Requires:       expat-devel >= 1.95.0
175 Requires:       freexl-devel >= 1.0
176 Requires:       geos-devel >= 3.1.0
177 Requires:       giflib-devel >= 4.0
178 Requires:       hdf-devel >= 4.0
179 Requires:       hdf5-devel
180 Requires:       jasper-devel
181 Requires:       json-c-devel >= 0.11
182 %{?with_kea:Requires:   kealib-devel}
183 Requires:       libcsf-devel
184 Requires:       libdap-devel >= 3.10
185 Requires:       libgeotiff-devel >= 1.2.1
186 %{?with_gta:Requires:   libgta-devel}
187 Requires:       libjpeg-devel >= 6b
188 Requires:       libpng-devel >= 2:1.2.8
189 %{?with_spatialite:Requires:    libspatialite-devel}
190 Requires:       libstdc++-devel
191 Requires:       libtiff-devel >= 4.0
192 Requires:       libuuid-devel
193 Requires:       libwebp-devel
194 Requires:       libxml2-devel >= 2
195 %{?with_mysql:Requires: /usr/bin/mysql_config}
196 Requires:       netcdf-devel >= 4
197 Requires:       ogdi-devel >= 3.1
198 %{?with_openjpeg:Requires:      openjpeg2-devel >= 2.0.0-2}
199 #Requires:      pcidsk-devel > 0.3
200 %{?with_podofo:Requires:        podofo-devel}
201 %{?with_poppler:Requires:       poppler-devel >= 0.24}
202 Requires:       postgresql-devel
203 Requires:       proj-devel >= 4
204 %{?with_rasdaman:Requires:      rasdaman-devel}
205 Requires:       sqlite3-devel >= 3.0.0
206 %{?with_odbc:Requires:  unixODBC-devel}
207 %{?with_xerces:Requires:        xerces-c-devel >= 2.7.0}
208 Requires:       xz-devel
209 Requires:       zlib-devel >= 1.1.4
210
211 %description devel
212 GDAL library header files.
213
214 %description devel -l pl.UTF-8
215 Pliki nagłówkowe biblioteki GDAL.
216
217 %package static
218 Summary:        GDAL static libraries
219 Summary(pl.UTF-8):      Statyczne biblioteki GDAL
220 Group:          Development/Libraries
221 Requires:       %{name}-devel = %{version}-%{release}
222
223 %description static
224 GDAL static libraries.
225
226 %description static -l pl.UTF-8
227 Statyczne biblioteki GDAL.
228
229 %package -n perl-gdal
230 Summary:        Perl bindings for GDAL
231 Summary(pl.UTF-8):      Wiązania Perla do pakietu GDAL
232 Group:          Development/Languages/Perl
233 Requires:       %{name} = %{version}-%{release}
234
235 %description -n perl-gdal
236 Perl bindings for GDAL - Geo::GDAL, Geo::OGR and Geo::OSR modules.
237
238 %description -n perl-gdal -l pl.UTF-8
239 Wiązania Perla do pakietu GDAL - moduły Geo::GDAL, Geo::OGR, Geo::OSR.
240
241 %package -n %{php_name}-gdal
242 Summary:        PHP bindings for GDAL library
243 Summary(pl.UTF-8):      Wiązania PHP do biblioteki GDAL
244 Group:          Development/Languages/PHP
245 Requires:       %{name} = %{version}-%{release}
246 %{?requires_php_extension}
247
248 %description -n %{php_name}-gdal
249 PHP bindings for GDAL library
250
251 %description -n %{php_name}-gdal -l pl.UTF-8
252 Wiązania PHP do biblioteki GDAL.
253
254 %package -n python-gdal
255 Summary:        GDAL Python module
256 Summary(pl.UTF-8):      Moduł Pythona GDAL
257 Group:          Libraries/Python
258 Requires:       %{name} = %{version}-%{release}
259 Requires:       python-libs
260
261 %description -n python-gdal
262 GDAL Python module.
263
264 %description -n python-gdal -l pl.UTF-8
265 Moduł Pythona GDAL.
266
267 %package -n ruby-gdal
268 Summary:        Ruby bindings for GDAL
269 Summary(pl.UTF-8):      Wiązania języka Ruby do pakietu GDAL
270 Group:          Development/Languages
271 Requires:       %{name} = %{version}-%{release}
272
273 %description -n ruby-gdal
274 Ruby bindings for GDAL - gdal, gdalconst, ogr and osr modules.
275
276 %description -n ruby-gdal -l pl.UTF-8
277 Wiązania języka Ruby do pakietu GDAL - moduły gdal, gdalconst, ogr i
278 osr.
279
280 %prep
281 %setup -q
282 %patch0 -p1
283 %patch2 -p1
284 %patch3 -p1
285 %patch9 -p1
286 %patch11 -p1
287 %patch12 -p1
288 #%patch13 -p1
289 %patch15 -p1
290
291 # need to regenerate (old ones don't support perl 5.10 or php 5.5)
292 %{__rm} swig/{perl,php}/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
293
294 %{__sed} -i \
295         -e 's/^CC=gcc/CC=%{__cc}/' \
296         -e 's/^CXX=g++/CXX=%{__cxx}/' \
297         -e 's/^CFLAGS=-fpic/CFLAGS=%{rpmcflags} -fPIC/' \
298         -e 's/^LDFLAGS=-shared/LDFLAGS=%{rpmldflags} -shared/' \
299         swig/php/GNUmakefile
300 # Build with fPIC to allow Ruby bindings
301 # Xcompiler should normally achieve that -- http://trac.osgeo.org/gdal/ticket/3978
302 # http://trac.osgeo.org/gdal/ticket/1994
303 sed -i 's|\$(CFLAGS)|$(CFLAGS) -fPIC|g' swig/ruby/RubyMakefile.mk
304 # Install Ruby bindings to distribution specific directory
305 sed -i 's|RUBY_EXTENSIONS_DIR :=.*|RUBY_EXTENSIONS_DIR := %{ruby_vendorarchdir}|' swig/ruby/RubyMakefile.mk
306
307 # Install Ruby bindings into the proper place
308 sed -i -e 's|^$(INSTALL_DIR):|$(DESTDIR)$(INSTALL_DIR):|' swig/ruby/RubyMakefile.mk
309 sed -i -e 's|^install: $(INSTALL_DIR)|install: $(DESTDIR)$(INSTALL_DIR)|' swig/ruby/RubyMakefile.mk
310
311 # our man path
312 sed -i -e 's#^mandir=.*##g' configure.ac
313
314 %{__rm} -r man
315
316 %{__sed} -i -e 's,DODS_INC="-I.*,DODS_INC="$(pkg-config --cflags libdap)",' configure.ac
317
318 %build
319 %ifarch %{x8664}
320 jvm_arch=amd64
321 %endif
322 %ifarch %{ix86}
323 jvm_arch=i386
324 %endif
325 %ifarch x32
326 jvm_arch=x32
327 %endif
328
329 %{__libtoolize}
330 %{__aclocal} -I m4
331 %{__autoconf}
332 %{__autoheader}
333 %configure \
334         --includedir=%{_includedir}/gdal \
335         --datadir=%{_datadir}/gdal \
336         --with-dods-root=/usr \
337         %{?with_armadillo:--with-armadillo} \
338         %{?with_crnlib:--with-dds=/usr} \
339         %{?with_epsilon:--with-epsilon} \
340         %{?with_grass:--with-grass} \
341         %{!?with_gta:--without-gta} \
342         --with-hide-internal-symbols \
343         %{?with_java:--with-java=%{java_home}} \
344         --with-liblzma \
345         %{!?with_kea:--without-kea} \
346         %{?with_java:--with-mdb --with-jvm-lib-add-rpath --with-jvm-lib=%{java_home}/jre/lib/$jvm_arch/server} \
347         %{?with_mysql:--with-mysql} \
348         %{?with_oci:--with-oci --with-oci-include=/usr/include/oracle/client --with-oci-lib=%{_libdir}} \
349         %{?with_opencl:--with-opencl} \
350         --with-perl \
351         %{?with_php:--with-php} \
352         %{?with_podofo:--with-podofo} \
353         %{?with_poppler:--with-poppler} \
354         --with-python \
355         %{?with_rasdaman:--with-rasdaman=%{_libdir}/rasdaman} \
356         %{?with_ruby:--with-ruby} \
357         %{?with_fyba:--with-sosi} \
358         %{?with_spatialite:--with-spatialite} \
359         --with-sqlite3 \
360         --with-webp \
361         %{?with_xerces:--with-xerces} \
362         --with-xerces-inc=/usr/include/xercesc \
363         --with-xerces-lib="-lxerces-c" \
364         --without-libgrass
365 #       --with-pcidsk=/usr (needs > 0.3)
366 # csharp builds, but has no configure option nor install target
367
368 # regenerate where needed
369 %{__make} -j1 -C swig/perl generate
370 %if %{with ruby}
371 %{__make} -j1 -C swig/ruby generate
372 %endif
373
374 %{__make} -j1 \
375         %{?with_grass:GRASS_INCLUDE="-I/usr/include/grass64"} \
376         %{?with_fyba:SOSI_INC="-I/usr/include/fyba"}
377
378 %{__make} -j1 docs
379
380 %{__make} -j1 man
381
382 %install
383 rm -rf $RPM_BUILD_ROOT
384
385 %{__make} -j1 install install-man \
386         DESTDIR=$RPM_BUILD_ROOT
387
388 rm -rf _html
389 cp -a html _html
390
391 %if %{with php}
392 # missing in make install
393 install -d $RPM_BUILD_ROOT%{php_extensiondir}
394 install -p swig/php/php_gdal.so $RPM_BUILD_ROOT%{php_extensiondir}/gdal.so
395 install -p swig/php/php_gdalconst.so $RPM_BUILD_ROOT%{php_extensiondir}/gdalconst.so
396 install -p swig/php/php_ogr.so $RPM_BUILD_ROOT%{php_extensiondir}/ogr.so
397 install -p swig/php/php_osr.so $RPM_BUILD_ROOT%{php_extensiondir}/osr.so
398 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
399 cat <<'EOF' >$RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/gdal.ini
400 ; Enable gdal extension modules
401 extension=gdal.so
402 extension=gdalconst.so
403 extension=ogr.so
404 extension=osr.so
405 EOF
406 %endif
407
408 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
409 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
410 %py_postclean
411
412 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
413 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/.packlist
414 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/Const/.packlist
415 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OGR/.packlist
416 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OSR/.packlist
417
418 # some doxygen trash
419 %{__rm} $RPM_BUILD_ROOT%{_bindir}/gdal{compare,move}.dox
420 %{__rm} $RPM_BUILD_ROOT%{_bindir}/gdal_{calc,edit,fillnodata,polygonize,proximity,sieve}.dox
421
422 %clean
423 rm -rf $RPM_BUILD_ROOT
424
425 %post   -p /sbin/ldconfig
426 %postun -p /sbin/ldconfig
427
428 %files
429 %defattr(644,root,root,755)
430 %doc NEWS PROVENANCE.TXT
431 %attr(755,root,root) %{_bindir}/epsg_tr.py
432 %attr(755,root,root) %{_bindir}/esri2wkt.py
433 %attr(755,root,root) %{_bindir}/gcps2vec.py
434 %attr(755,root,root) %{_bindir}/gcps2wld.py
435 %attr(755,root,root) %{_bindir}/gdal2tiles.py
436 %attr(755,root,root) %{_bindir}/gdal2xyz.py
437 %attr(755,root,root) %{_bindir}/gdal_auth.py
438 %attr(755,root,root) %{_bindir}/gdal_contour
439 %attr(755,root,root) %{_bindir}/gdal_calc.py
440 %attr(755,root,root) %{_bindir}/gdal_edit.py
441 %attr(755,root,root) %{_bindir}/gdal_fillnodata.py
442 %attr(755,root,root) %{_bindir}/gdal_grid
443 %attr(755,root,root) %{_bindir}/gdal_merge.py
444 %attr(755,root,root) %{_bindir}/gdal_polygonize.py
445 %attr(755,root,root) %{_bindir}/gdal_proximity.py
446 %attr(755,root,root) %{_bindir}/gdal_rasterize
447 %attr(755,root,root) %{_bindir}/gdal_retile.py
448 %attr(755,root,root) %{_bindir}/gdal_sieve.py
449 %attr(755,root,root) %{_bindir}/gdal_translate
450 %attr(755,root,root) %{_bindir}/gdaladdo
451 %attr(755,root,root) %{_bindir}/gdalbuildvrt
452 %attr(755,root,root) %{_bindir}/gdalchksum.py
453 %attr(755,root,root) %{_bindir}/gdalcompare.py
454 %attr(755,root,root) %{_bindir}/gdaldem
455 %attr(755,root,root) %{_bindir}/gdalenhance
456 %attr(755,root,root) %{_bindir}/gdalident.py
457 %attr(755,root,root) %{_bindir}/gdalimport.py
458 %attr(755,root,root) %{_bindir}/gdalinfo
459 %attr(755,root,root) %{_bindir}/gdallocationinfo
460 %attr(755,root,root) %{_bindir}/gdalmanage
461 %attr(755,root,root) %{_bindir}/gdalmove.py
462 %attr(755,root,root) %{_bindir}/gdalserver
463 %attr(755,root,root) %{_bindir}/gdalsrsinfo
464 %attr(755,root,root) %{_bindir}/gdaltindex
465 %attr(755,root,root) %{_bindir}/gdaltransform
466 %attr(755,root,root) %{_bindir}/gdalwarp
467 %attr(755,root,root) %{_bindir}/mkgraticule.py
468 %attr(755,root,root) %{_bindir}/nearblack
469 %attr(755,root,root) %{_bindir}/ogr2ogr
470 %attr(755,root,root) %{_bindir}/ogrinfo
471 %attr(755,root,root) %{_bindir}/ogrlineref
472 %attr(755,root,root) %{_bindir}/ogrtindex
473 %attr(755,root,root) %{_bindir}/pct2rgb.py
474 %attr(755,root,root) %{_bindir}/rgb2pct.py
475 %attr(755,root,root) %{_bindir}/testepsg
476 %attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
477 %attr(755,root,root) %ghost %{_libdir}/libgdal.so.20
478 %dir %{_libdir}/gdalplugins
479 %{_datadir}/gdal
480 %{_mandir}/man1/gdal2tiles.1*
481 %{_mandir}/man1/gdal_calc.1*
482 %{_mandir}/man1/gdal_contour.1*
483 %{_mandir}/man1/gdal_edit.1*
484 %{_mandir}/man1/gdal_fillnodata.1*
485 %{_mandir}/man1/gdal_grid.1*
486 %{_mandir}/man1/gdal_merge.1*
487 %{_mandir}/man1/gdal_polygonize.1*
488 %{_mandir}/man1/gdal_proximity.1*
489 %{_mandir}/man1/gdal_rasterize.1*
490 %{_mandir}/man1/gdal_retile.1*
491 %{_mandir}/man1/gdal_sieve.1*
492 %{_mandir}/man1/gdal_translate.1*
493 %{_mandir}/man1/gdal_utilities.1*
494 %{_mandir}/man1/gdaladdo.1*
495 %{_mandir}/man1/gdalbuildvrt.1*
496 %{_mandir}/man1/gdalcompare.1*
497 %{_mandir}/man1/gdaldem.1*
498 %{_mandir}/man1/gdalinfo.1*
499 %{_mandir}/man1/gdallocationinfo.1*
500 %{_mandir}/man1/gdalmanage.1*
501 %{_mandir}/man1/gdalmove.1*
502 %{_mandir}/man1/gdalsrsinfo.1*
503 %{_mandir}/man1/gdaltindex.1*
504 %{_mandir}/man1/gdaltransform.1*
505 %{_mandir}/man1/gdalwarp.1*
506 %{_mandir}/man1/nearblack.1*
507 %{_mandir}/man1/ogr2ogr.1*
508 %{_mandir}/man1/ogr_utilities.1*
509 %{_mandir}/man1/ogrinfo.1*
510 %{_mandir}/man1/ogrlineref.1*
511 %{_mandir}/man1/ogrtindex.1*
512 %{_mandir}/man1/pct2rgb.1*
513 %{_mandir}/man1/rgb2pct.1*
514
515 %files devel
516 %defattr(644,root,root,755)
517 %doc _html/*
518 %attr(755,root,root) %{_bindir}/gdal-config
519 %attr(755,root,root) %{_libdir}/libgdal.so
520 %{_libdir}/libgdal.la
521 %{_pkgconfigdir}/gdal.pc
522 %{_includedir}/gdal
523 %{_mandir}/man1/gdal-config.1*
524
525 %files static
526 %defattr(644,root,root,755)
527 %{_libdir}/libgdal.a
528
529 %files -n perl-gdal
530 %defattr(644,root,root,755)
531 %dir %{perl_vendorarch}/Geo
532 %{perl_vendorarch}/Geo/GDAL.pm
533 %dir %{perl_vendorarch}/Geo/GDAL
534 %{perl_vendorarch}/Geo/GDAL/Const.pm
535 %{perl_vendorarch}/Geo/OGR.pm
536 %{perl_vendorarch}/Geo/OSR.pm
537 %dir %{perl_vendorarch}/auto/Geo
538 %dir %{perl_vendorarch}/auto/Geo/GDAL
539 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/GDAL.so
540 %dir %{perl_vendorarch}/auto/Geo/GDAL/Const
541 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.so
542 %dir %{perl_vendorarch}/auto/Geo/OGR
543 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OGR/OGR.so
544 %dir %{perl_vendorarch}/auto/Geo/OSR
545 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OSR/OSR.so
546 %{_mandir}/man3/Geo::GDAL.3pm*
547
548 %if %{with php}
549 %files -n %{php_name}-gdal
550 %defattr(644,root,root,755)
551 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/gdal.ini
552 %attr(755,root,root) %{php_extensiondir}/gdal.so
553 %attr(755,root,root) %{php_extensiondir}/gdalconst.so
554 %attr(755,root,root) %{php_extensiondir}/ogr.so
555 %attr(755,root,root) %{php_extensiondir}/osr.so
556 %endif
557
558 %files -n python-gdal
559 %defattr(644,root,root,755)
560 %{py_sitedir}/gdal.py[co]
561 %{py_sitedir}/gdalconst.py[co]
562 %{py_sitedir}/gdalnumeric.py[co]
563 %{py_sitedir}/ogr.py[co]
564 %{py_sitedir}/osr.py[co]
565 %{py_sitedir}/GDAL-*.egg-info
566 %dir %{py_sitedir}/osgeo
567 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal.so
568 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal_array.so
569 %attr(755,root,root) %{py_sitedir}/osgeo/_gdalconst.so
570 %attr(755,root,root) %{py_sitedir}/osgeo/_ogr.so
571 %attr(755,root,root) %{py_sitedir}/osgeo/_osr.so
572 %{py_sitedir}/osgeo/*.py[co]
573
574 %if %{with ruby}
575 %files -n ruby-gdal
576 %defattr(644,root,root,755)
577 %dir %{ruby_vendorarchdir}/gdal
578 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/gdal.so
579 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/gdalconst.so
580 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/ogr.so
581 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/osr.so
582 %endif
This page took 0.052598 seconds and 2 git commands to generate.