]> git.pld-linux.org Git - packages/gdal.git/blob - gdal.spec
- added pluginsdir patch (fix gdalplugins dir location for lib64/libx32 ABIs)
[packages/gdal.git] / gdal.spec
1 # TODO:
2 # - be reasonable about devel dependencies - you do not need all of them to
3 #   use gdal (probably a gdal module or driver shall not imply devel
4 #   dependency)
5 # - libjpeg12 (needs patching to use system one, --with-jpeg12 is not sufficient as of 1.9.2)
6 # - libkml (1.3.0 needed, not released yet)
7 # - wait for newer pcidsk, switch to external again
8 # - csharp, java
9 # - additional, proprietary(?) formats support:
10 #   - FMEObjects (http://www.safe.com/support/support-resources/fme-downloads/)
11 #   - ESRI FileGDBAPI (http://resources.arcgis.com/content/geodatabases/10.0/file-gdb-api)
12 #   - ECW (http://www.erdas.com/products/ecw/ERDASECWJPEG2000SDK/Details.aspx)
13 #   - Kakadu/JPEG2000 (http://www.kakadusoftware.com/)
14 #   - MrSID (http://www.lizardtech.com/developer/)
15 #   - MSG/EUMETSAT (http://www.eumetsat.int/Home/Main/DataAccess/SupportSoftwareTools/index.htm)
16 #   - Ingres (--with-ingres=/path)
17 #   - Informix DB (--with-idb)
18 #   - DWGdirect (members only? http://www.opendwg.org/)
19 #   - ESRI SDE (http://www.esri.com/software/arcgis/arcsde/index.html)
20 #
21 # Conditional build:
22 %bcond_without  armadillo       # Armadillo support for faster TPS transform
23 %bcond_without  crnlib          # DDS support via crunch/crnlib
24 %bcond_without  epsilon         # EPSILON wavelet compression support
25 %bcond_without  fyba            # SOSI geodata support using FYBA
26 %bcond_with     grass           # GRASS support (note: dependency loop; use gdal-grass.spec instead)
27 %bcond_without  gta             # GTA format support
28 %bcond_without  mysql           # MySQL DB support
29 %bcond_with     oci             # ORACLE OCI DB and Georaster support
30 %bcond_without  odbc            # ODBC DB support
31 %bcond_without  opencl          # OpenCL (GPU) support
32 %bcond_without  openjpeg        # OpenJPEG 2 (JPEG2000) support
33 %bcond_with     podofo          # PDF support via podofo instead of poppler
34 %bcond_without  poppler         # PDF support via poppler
35 %bcond_without  rasdaman        # Rasdaman support
36 %bcond_without  spatialite      # SpatiaLite support
37 %bcond_without  xerces          # Xerces support
38 %bcond_without  java            # Java and MDB support
39 %bcond_without  php             # PHP binding
40 %bcond_without  ruby            # Ruby binding
41
42 %if %{with podofo}
43 %undefine       with_poppler
44 %endif
45 %if 0%{!?php_name:1}
46 %define         php_name        php55
47 %endif
48 Summary:        Geospatial Data Abstraction Library
49 Summary(pl.UTF-8):      Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
50 Name:           gdal
51 Version:        1.11.2
52 Release:        1
53 License:        BSD-like
54 Group:          Libraries
55 Source0:        http://download.osgeo.org/gdal/%{version}/%{name}-%{version}.tar.xz
56 # Source0-md5:  90221810dd9ca656ee23d434d4266ef6
57 Patch0:         %{name}-perl.patch
58 Patch1:         %{name}-python_install.patch
59 Patch2:         %{name}-php.patch
60 Patch3:         %{name}-fpic.patch
61 Patch4:         %{name}-format-security.patch
62 Patch5:         %{name}-grass.patch
63 Patch6:         %{name}-sse.patch
64 Patch7:         %{name}-link.patch
65 Patch8:         %{name}-fyba.patch
66 Patch9:         %{name}-dds.patch
67 Patch11:        %{name}-armadillo.patch
68 Patch12:        %{name}-rasdaman.patch
69 Patch13:        %{name}-pluginsdir.patch
70 URL:            http://www.gdal.org/
71 %{?with_php:BuildRequires:      %{php_name}-devel}
72 %{?with_opencl:BuildRequires:   OpenCL-devel >= 1.0}
73 %{?with_armadillo:BuildRequires:        armadillo-devel}
74 BuildRequires:  autoconf >= 2.52
75 BuildRequires:  automake
76 BuildRequires:  cfitsio-devel
77 %{?with_crnlib:BuildRequires:   crnlib-devel}
78 BuildRequires:  curl-devel
79 BuildRequires:  doxygen >= 1.4.2
80 %{?with_epsilon:BuildRequires:  epsilon-compressor-devel}
81 BuildRequires:  expat-devel >= 1.95.0
82 %{?with_fyba:BuildRequires:     fyba-devel}
83 BuildRequires:  freexl-devel >= 1.0
84 BuildRequires:  gcc >= 6:4.1
85 BuildRequires:  geos-devel >= 3.1.0
86 BuildRequires:  giflib-devel >= 4.0
87 %{?with_grass:BuildRequires:    grass-devel >= 6.4}
88 BuildRequires:  hdf-devel >= 4.0
89 BuildRequires:  hdf5-devel
90 BuildRequires:  jasper-devel
91 %{?with_java:BuildRequires:     jdk}
92 %{?with_java:BuildRequires:     jpackage-utils}
93 BuildRequires:  json-c-devel >= 0.11
94 BuildRequires:  libcsf-devel
95 BuildRequires:  libdap-devel >= 3.10
96 BuildRequires:  libgeotiff-devel >= 1.2.1
97 %{?with_gta:BuildRequires:      libgta-devel}
98 BuildRequires:  libjpeg-devel >= 6b
99 #BuildRequires: libkml-devel >= 1.3.0
100 BuildRequires:  libpng-devel >= 2:1.2.8
101 %{?with_spatialite:BuildRequires:       libspatialite-devel}
102 BuildRequires:  libstdc++-devel
103 BuildRequires:  libtiff-devel >= 4.0
104 BuildRequires:  libtool
105 BuildRequires:  libuuid-devel
106 BuildRequires:  libwebp-devel
107 BuildRequires:  libxml2-devel >= 2
108 %{?with_mysql:BuildRequires:    mysql-devel}
109 BuildRequires:  netcdf-devel >= 4.1
110 BuildRequires:  ogdi-devel >= 3.1
111 %{?with_openjpeg:BuildRequires: openjpeg2-devel >= 2.0.0-2}
112 # 8.1.7 for DB support, 10.0.1 for georaster
113 %{?with_oci:BuildRequires:      oracle-instantclient-devel >= 10.0.1}
114 #BuildRequires: pcidsk-devel > 0.3
115 BuildRequires:  perl-devel
116 %{?with_podofo:BuildRequires:   podofo-devel}
117 %{?with_poppler:BuildRequires:  poppler-devel >= 0.24}
118 # ensure it's compiled with PQescapeStringConn support
119 BuildRequires:  postgresql-backend-devel >= 8.1.4
120 BuildRequires:  postgresql-devel >= 8.1.4
121 BuildRequires:  proj-devel >= 4
122 BuildRequires:  python-devel >= 1:2.5
123 BuildRequires:  python-numpy-devel >= 1:1.0.0
124 BuildRequires:  python-setuptools
125 %{?with_rasdaman:BuildRequires: rasdaman-devel}
126 BuildRequires:  rpm-pythonprov
127 %{?with_ruby:BuildRequires:     rpm-rubyprov}
128 BuildRequires:  rpmbuild(macros) >= 1.344
129 %{?with_ruby:BuildRequires:     ruby-devel}
130 BuildRequires:  sed >= 4.0
131 BuildRequires:  sqlite3-devel >= 3.0.0
132 BuildRequires:  swig-perl
133 BuildRequires:  swig-php >= 2.0.12-2
134 BuildRequires:  swig-python >= 1.3
135 %{?with_ruby:BuildRequires:     swig-ruby}
136 BuildRequires:  texlive-dvips
137 BuildRequires:  texlive-latex
138 %{?with_odbc:BuildRequires:     unixODBC-devel >= 2.2.15}
139 %{?with_xerces:BuildRequires:   xerces-c-devel >= 2.7.0}
140 BuildRequires:  xz-devel
141 BuildRequires:  zlib-devel >= 1.1.4
142 Requires:       freexl >= 1.0
143 Requires:       geos >= 3.1.0
144 Requires:       libgeotiff >= 1.2.1
145 Requires:       libpng >= 2:1.2.8
146 Requires:       libtiff >= 4.0
147 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
148
149 %description
150 GDAL is a translator library for raster geospatial data formats that
151 is released under an Open Source license. As a library, it presents a
152 single abstract data model to the calling application for all
153 supported formats. The related OGR library (which lives within the
154 GDAL source tree) provides a similar capability for simple features
155 vector data.
156
157 %description -l pl.UTF-8
158 GDAL to biblioteka konwertująca między formatami rastrowych danych
159 dotyczących powierzchni Ziemi, udostępniona na licencji Open Source.
160 Jako biblioteka udostępnia aplikacjom jeden abstrakcyjny model danych
161 do wszystkich obsługiwanych formatów. Powiązana z nią biblioteka OGR
162 (której źródła są dołączone do drzewa źródeł GDAL) daje podobne
163 możliwości dla danych wektorowych.
164
165 %package devel
166 Summary:        GDAL library header files
167 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GDAL
168 Group:          Development/Libraries
169 Requires:       %{name} = %{version}-%{release}
170 %{?with_opencl:Requires:        OpenCL-devel >= 1.0}
171 %{?with_armadillo:Requires:     armadillo-devel}
172 Requires:       cfitsio-devel
173 %{?with_crnlib:Requires:        crnlib-devel}
174 Requires:       curl-devel
175 %{?with_epsilon:Requires:       epsilon-compressor-devel}
176 %{?with_fyba:Requires:  fyba-devel}
177 Requires:       expat-devel >= 1.95.0
178 Requires:       freexl-devel >= 1.0
179 Requires:       geos-devel >= 3.1.0
180 Requires:       giflib-devel >= 4.0
181 Requires:       hdf-devel >= 4.0
182 Requires:       hdf5-devel
183 Requires:       jasper-devel
184 Requires:       json-c-devel >= 0.11
185 Requires:       libcsf-devel
186 Requires:       libdap-devel >= 3.10
187 Requires:       libgeotiff-devel >= 1.2.1
188 %{?with_gta:Requires:   libgta-devel}
189 Requires:       libjpeg-devel >= 6b
190 Requires:       libpng-devel >= 2:1.2.8
191 %{?with_spatialite:Requires:    libspatialite-devel}
192 Requires:       libstdc++-devel
193 Requires:       libtiff-devel >= 4.0
194 Requires:       libuuid-devel
195 Requires:       libwebp-devel
196 Requires:       libxml2-devel >= 2
197 %{?with_mysql:Requires: mysql-devel}
198 Requires:       netcdf-devel >= 4
199 Requires:       ogdi-devel >= 3.1
200 %{?with_openjpeg:Requires:      openjpeg2-devel >= 2.0.0-2}
201 #Requires:      pcidsk-devel > 0.3
202 %{?with_podofo:Requires:        podofo-devel}
203 %{?with_poppler:Requires:       poppler-devel >= 0.24}
204 Requires:       postgresql-devel
205 Requires:       proj-devel >= 4
206 %{?with_rasdaman:Requires:      rasdaman-devel}
207 Requires:       sqlite3-devel >= 3.0.0
208 %{?with_odbc:Requires:  unixODBC-devel}
209 %{?with_xerces:Requires:        xerces-c-devel >= 2.7.0}
210 Requires:       xz-devel
211 Requires:       zlib-devel >= 1.1.4
212
213 %description devel
214 GDAL library header files.
215
216 %description devel -l pl.UTF-8
217 Pliki nagłówkowe biblioteki GDAL.
218
219 %package static
220 Summary:        GDAL static libraries
221 Summary(pl.UTF-8):      Statyczne biblioteki GDAL
222 Group:          Development/Libraries
223 Requires:       %{name}-devel = %{version}-%{release}
224
225 %description static
226 GDAL static libraries.
227
228 %description static -l pl.UTF-8
229 Statyczne biblioteki GDAL.
230
231 %package -n perl-gdal
232 Summary:        Perl bindings for GDAL
233 Summary(pl.UTF-8):      Wiązania Perla do pakietu GDAL
234 Group:          Development/Languages/Perl
235 Requires:       %{name} = %{version}-%{release}
236
237 %description -n perl-gdal
238 Perl bindings for GDAL - Geo::GDAL, Geo::OGR and Geo::OSR modules.
239
240 %description -n perl-gdal -l pl.UTF-8
241 Wiązania Perla do pakietu GDAL - moduły Geo::GDAL, Geo::OGR, Geo::OSR.
242
243 %package -n %{php_name}-gdal
244 Summary:        PHP bindings for GDAL library
245 Summary(pl.UTF-8):      Wiązania PHP do biblioteki GDAL
246 Group:          Development/Languages/PHP
247 Requires:       %{name} = %{version}-%{release}
248 %{?requires_php_extension}
249
250 %description -n %{php_name}-gdal
251 PHP bindings for GDAL library
252
253 %description -n %{php_name}-gdal -l pl.UTF-8
254 Wiązania PHP do biblioteki GDAL.
255
256 %package -n python-gdal
257 Summary:        GDAL Python module
258 Summary(pl.UTF-8):      Moduł Pythona GDAL
259 Group:          Libraries/Python
260 Requires:       %{name} = %{version}-%{release}
261 Requires:       python-libs
262
263 %description -n python-gdal
264 GDAL Python module.
265
266 %description -n python-gdal -l pl.UTF-8
267 Moduł Pythona GDAL.
268
269 %package -n ruby-gdal
270 Summary:        Ruby bindings for GDAL
271 Summary(pl.UTF-8):      Wiązania języka Ruby do pakietu GDAL
272 Group:          Development/Languages
273 Requires:       %{name} = %{version}-%{release}
274
275 %description -n ruby-gdal
276 Ruby bindings for GDAL - gdal, gdalconst, ogr and osr modules.
277
278 %description -n ruby-gdal -l pl.UTF-8
279 Wiązania języka Ruby do pakietu GDAL - moduły gdal, gdalconst, ogr i
280 osr.
281
282 %prep
283 %setup -q
284 %patch0 -p1
285 %patch1 -p1
286 %patch2 -p1
287 %patch3 -p1
288 %patch4 -p1
289 %patch5 -p1
290 %patch6 -p1
291 %patch7 -p1
292 %patch8 -p1
293 %patch9 -p1
294 %patch11 -p1
295 %patch12 -p1
296 %patch13 -p1
297
298 # need to regenerate (old ones don't support perl 5.10 or php 5.5)
299 %{__rm} swig/{perl,php}/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
300
301 %{__sed} -i \
302         -e 's/^CC=gcc/CC=%{__cc}/' \
303         -e 's/^CXX=g++/CXX=%{__cxx}/' \
304         -e 's/^CFLAGS=-fpic/CFLAGS=%{rpmcflags} -fPIC/' \
305         -e 's/^LDFLAGS=-shared/LDFLAGS=%{rpmldflags} -shared/' \
306         swig/php/GNUmakefile
307 # Build with fPIC to allow Ruby bindings
308 # Xcompiler should normally achieve that -- http://trac.osgeo.org/gdal/ticket/3978
309 # http://trac.osgeo.org/gdal/ticket/1994
310 sed -i 's|\$(CFLAGS)|$(CFLAGS) -fPIC|g' swig/ruby/RubyMakefile.mk
311 # Install Ruby bindings to distribution specific directory
312 sed -i 's|RUBY_EXTENSIONS_DIR :=.*|RUBY_EXTENSIONS_DIR := %{ruby_vendorarchdir}|' swig/ruby/RubyMakefile.mk
313
314 # Install Ruby bindings into the proper place
315 sed -i -e 's|^$(INSTALL_DIR):|$(DESTDIR)$(INSTALL_DIR):|' swig/ruby/RubyMakefile.mk
316 sed -i -e 's|^install: $(INSTALL_DIR)|install: $(DESTDIR)$(INSTALL_DIR)|' swig/ruby/RubyMakefile.mk
317
318 # our man path
319 sed -i -e 's#^mandir=.*##g' configure.in
320
321 %{__rm} -r man
322
323 %{__sed} -i -e 's,DODS_INC="-I.*,DODS_INC="$(pkg-config --cflags libdap)",' configure.in
324
325 %build
326 %{__libtoolize}
327 %{__aclocal} -I m4
328 %{__autoconf}
329 %{__autoheader}
330 %configure \
331         --includedir=%{_includedir}/gdal \
332         --datadir=%{_datadir}/gdal \
333         --with-dods-root=/usr \
334         %{?with_armadillo:--with-armadillo} \
335         %{?with_crnlib:--with-dds} \
336         %{?with_epsilon:--with-epsilon} \
337         %{?with_grass:--with-grass} \
338         %{!?with_gta:--without-gta} \
339         --with-hide-internal-symbols \
340         %{?with_java:--with-java=%{java_home}} \
341         --with-liblzma \
342         %{?with_java:--with-mdb --with-jvm-lib-add-rpath} \
343         %{?with_mysql:--with-mysql} \
344         %{?with_oci:--with-oci --with-oci-include=/usr/include/oracle/client --with-oci-lib=%{_libdir}} \
345         %{?with_opencl:--with-opencl} \
346         --with-perl \
347         %{?with_php:--with-php} \
348         %{?with_podofo:--with-podofo} \
349         %{?with_poppler:--with-poppler} \
350         --with-python \
351         %{?with_rasdaman:--with-rasdaman=%{_libdir}/rasdaman} \
352         %{?with_ruby:--with-ruby} \
353         %{?with_fyba:--with-sosi} \
354         %{?with_spatialite:--with-spatialite} \
355         --with-sqlite3 \
356         --with-webp \
357         %{?with_xerces:--with-xerces} \
358         --with-xerces-inc=/usr/include/xercesc \
359         --with-xerces-lib="-lxerces-c" \
360         --without-libgrass
361 #       --with-pcidsk=/usr (needs > 0.3)
362 # csharp builds, but has no configure option nor install target
363
364 # regenerate where needed
365 %{__make} -j1 -C swig/perl generate
366 %if %{with ruby}
367 %{__make} -j1 -C swig/ruby generate
368 %endif
369
370 %{__make} -j1 \
371         %{?with_grass:GRASS_INCLUDE="-I/usr/include/grass64"} \
372         %{?with_fyba:SOSI_INC="-I/usr/include/fyba"}
373
374 %{__make} -j1 docs
375
376 %{__make} -j1 man
377
378 %install
379 rm -rf $RPM_BUILD_ROOT
380
381 %{__make} -j1 install install-man \
382         DESTDIR=$RPM_BUILD_ROOT
383
384 rm -rf _html
385 cp -a html _html
386 cp -a ogr/html _html/ogr
387
388 %if %{with php}
389 # missing in make install
390 install -d $RPM_BUILD_ROOT%{php_extensiondir}
391 install -p swig/php/php_gdal.so $RPM_BUILD_ROOT%{php_extensiondir}/gdal.so
392 install -p swig/php/php_gdalconst.so $RPM_BUILD_ROOT%{php_extensiondir}/gdalconst.so
393 install -p swig/php/php_ogr.so $RPM_BUILD_ROOT%{php_extensiondir}/ogr.so
394 install -p swig/php/php_osr.so $RPM_BUILD_ROOT%{php_extensiondir}/osr.so
395 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
396 cat <<'EOF' >$RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/gdal.ini
397 ; Enable gdal extension modules
398 extension=gdal.so
399 extension=gdalconst.so
400 extension=ogr.so
401 extension=osr.so
402 EOF
403 %endif
404
405 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
406 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
407 %py_postclean
408
409 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
410 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/.packlist
411 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/Const/.packlist
412 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OGR/.packlist
413 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OSR/.packlist
414
415 # some doxygen trash
416 %{__rm} $RPM_BUILD_ROOT%{_bindir}/gdal{compare,move}.dox
417 %{__rm} $RPM_BUILD_ROOT%{_bindir}/gdal_{calc,edit,fillnodata,polygonize,proximity,sieve}.dox
418
419 %clean
420 rm -rf $RPM_BUILD_ROOT
421
422 %post   -p /sbin/ldconfig
423 %postun -p /sbin/ldconfig
424
425 %files
426 %defattr(644,root,root,755)
427 %doc NEWS PROVENANCE.TXT
428 %attr(755,root,root) %{_bindir}/epsg_tr.py
429 %attr(755,root,root) %{_bindir}/esri2wkt.py
430 %attr(755,root,root) %{_bindir}/gcps2vec.py
431 %attr(755,root,root) %{_bindir}/gcps2wld.py
432 %attr(755,root,root) %{_bindir}/gdal2tiles.py
433 %attr(755,root,root) %{_bindir}/gdal2xyz.py
434 %attr(755,root,root) %{_bindir}/gdal_auth.py
435 %attr(755,root,root) %{_bindir}/gdal_contour
436 %attr(755,root,root) %{_bindir}/gdal_calc.py
437 %attr(755,root,root) %{_bindir}/gdal_edit.py
438 %attr(755,root,root) %{_bindir}/gdal_fillnodata.py
439 %attr(755,root,root) %{_bindir}/gdal_grid
440 %attr(755,root,root) %{_bindir}/gdal_merge.py
441 %attr(755,root,root) %{_bindir}/gdal_polygonize.py
442 %attr(755,root,root) %{_bindir}/gdal_proximity.py
443 %attr(755,root,root) %{_bindir}/gdal_rasterize
444 %attr(755,root,root) %{_bindir}/gdal_retile.py
445 %attr(755,root,root) %{_bindir}/gdal_sieve.py
446 %attr(755,root,root) %{_bindir}/gdal_translate
447 %attr(755,root,root) %{_bindir}/gdaladdo
448 %attr(755,root,root) %{_bindir}/gdalbuildvrt
449 %attr(755,root,root) %{_bindir}/gdalchksum.py
450 %attr(755,root,root) %{_bindir}/gdalcompare.py
451 %attr(755,root,root) %{_bindir}/gdaldem
452 %attr(755,root,root) %{_bindir}/gdalenhance
453 %attr(755,root,root) %{_bindir}/gdalident.py
454 %attr(755,root,root) %{_bindir}/gdalimport.py
455 %attr(755,root,root) %{_bindir}/gdalinfo
456 %attr(755,root,root) %{_bindir}/gdallocationinfo
457 %attr(755,root,root) %{_bindir}/gdalmanage
458 %attr(755,root,root) %{_bindir}/gdalmove.py
459 %attr(755,root,root) %{_bindir}/gdalserver
460 %attr(755,root,root) %{_bindir}/gdalsrsinfo
461 %attr(755,root,root) %{_bindir}/gdaltindex
462 %attr(755,root,root) %{_bindir}/gdaltransform
463 %attr(755,root,root) %{_bindir}/gdalwarp
464 %attr(755,root,root) %{_bindir}/mkgraticule.py
465 %attr(755,root,root) %{_bindir}/nearblack
466 %attr(755,root,root) %{_bindir}/ogr2ogr
467 %attr(755,root,root) %{_bindir}/ogrinfo
468 %attr(755,root,root) %{_bindir}/ogrlineref
469 %attr(755,root,root) %{_bindir}/ogrtindex
470 %attr(755,root,root) %{_bindir}/pct2rgb.py
471 %attr(755,root,root) %{_bindir}/rgb2pct.py
472 %attr(755,root,root) %{_bindir}/testepsg
473 %attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
474 %attr(755,root,root) %ghost %{_libdir}/libgdal.so.1
475 %dir %{_libdir}/gdalplugins
476 %{_datadir}/gdal
477 %{_mandir}/man1/gdal2tiles.1*
478 %{_mandir}/man1/gdal_calc.1*
479 %{_mandir}/man1/gdal_contour.1*
480 %{_mandir}/man1/gdal_edit.1*
481 %{_mandir}/man1/gdal_fillnodata.1*
482 %{_mandir}/man1/gdal_grid.1*
483 %{_mandir}/man1/gdal_merge.1*
484 %{_mandir}/man1/gdal_polygonize.1*
485 %{_mandir}/man1/gdal_proximity.1*
486 %{_mandir}/man1/gdal_rasterize.1*
487 %{_mandir}/man1/gdal_retile.1*
488 %{_mandir}/man1/gdal_sieve.1*
489 %{_mandir}/man1/gdal_translate.1*
490 %{_mandir}/man1/gdal_utilities.1*
491 %{_mandir}/man1/gdaladdo.1*
492 %{_mandir}/man1/gdalbuildvrt.1*
493 %{_mandir}/man1/gdalcompare.1*
494 %{_mandir}/man1/gdaldem.1*
495 %{_mandir}/man1/gdalinfo.1*
496 %{_mandir}/man1/gdallocationinfo.1*
497 %{_mandir}/man1/gdalmanage.1*
498 %{_mandir}/man1/gdalmove.1*
499 %{_mandir}/man1/gdalsrsinfo.1*
500 %{_mandir}/man1/gdaltindex.1*
501 %{_mandir}/man1/gdaltransform.1*
502 %{_mandir}/man1/gdalwarp.1*
503 %{_mandir}/man1/nearblack.1*
504 %{_mandir}/man1/ogr2ogr.1*
505 %{_mandir}/man1/ogr_utilities.1*
506 %{_mandir}/man1/ogrinfo.1*
507 %{_mandir}/man1/ogrlineref.1*
508 %{_mandir}/man1/ogrtindex.1*
509 %{_mandir}/man1/pct2rgb.1*
510 %{_mandir}/man1/rgb2pct.1*
511
512 %files devel
513 %defattr(644,root,root,755)
514 %doc _html/*
515 %attr(755,root,root) %{_bindir}/gdal-config
516 %attr(755,root,root) %{_libdir}/libgdal.so
517 %{_libdir}/libgdal.la
518 %{_pkgconfigdir}/gdal.pc
519 %{_includedir}/gdal
520 %{_mandir}/man1/gdal-config.1*
521
522 %files static
523 %defattr(644,root,root,755)
524 %{_libdir}/libgdal.a
525
526 %files -n perl-gdal
527 %defattr(644,root,root,755)
528 %dir %{perl_vendorarch}/Geo
529 %{perl_vendorarch}/Geo/GDAL.pm
530 %dir %{perl_vendorarch}/Geo/GDAL
531 %{perl_vendorarch}/Geo/GDAL/Const.pm
532 %{perl_vendorarch}/Geo/OGR.pm
533 %{perl_vendorarch}/Geo/OSR.pm
534 %dir %{perl_vendorarch}/auto/Geo
535 %dir %{perl_vendorarch}/auto/Geo/GDAL
536 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/GDAL.so
537 %dir %{perl_vendorarch}/auto/Geo/GDAL/Const
538 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.so
539 %dir %{perl_vendorarch}/auto/Geo/OGR
540 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OGR/OGR.so
541 %dir %{perl_vendorarch}/auto/Geo/OSR
542 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OSR/OSR.so
543
544 %if %{with php}
545 %files -n %{php_name}-gdal
546 %defattr(644,root,root,755)
547 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/gdal.ini
548 %attr(755,root,root) %{php_extensiondir}/gdal.so
549 %attr(755,root,root) %{php_extensiondir}/gdalconst.so
550 %attr(755,root,root) %{php_extensiondir}/ogr.so
551 %attr(755,root,root) %{php_extensiondir}/osr.so
552 %endif
553
554 %files -n python-gdal
555 %defattr(644,root,root,755)
556 %{py_sitedir}/gdal.py[co]
557 %{py_sitedir}/gdalconst.py[co]
558 %{py_sitedir}/gdalnumeric.py[co]
559 %{py_sitedir}/ogr.py[co]
560 %{py_sitedir}/osr.py[co]
561 %{py_sitedir}/GDAL-*.egg-info
562 %dir %{py_sitedir}/osgeo
563 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal.so
564 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal_array.so
565 %attr(755,root,root) %{py_sitedir}/osgeo/_gdalconst.so
566 %attr(755,root,root) %{py_sitedir}/osgeo/_ogr.so
567 %attr(755,root,root) %{py_sitedir}/osgeo/_osr.so
568 %{py_sitedir}/osgeo/*.py[co]
569
570 %if %{with ruby}
571 %files -n ruby-gdal
572 %defattr(644,root,root,755)
573 %dir %{ruby_vendorarchdir}/gdal
574 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/gdal.so
575 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/gdalconst.so
576 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/ogr.so
577 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/osr.so
578 %endif
This page took 0.081714 seconds and 3 git commands to generate.