]> git.pld-linux.org Git - packages/gdal.git/blob - gdal.spec
- added freexl and spatialite support
[packages/gdal.git] / gdal.spec
1 # TODO:
2 # - be reasonable about devel dependencies - you do not need all of them to
3 #   use gdal (probably a gdal module or driver shall not imply devel
4 #   dependency)
5 # - rasdaman (--with-rasdaman; http://rasdaman.eecs.jacobs-university.de/trac/rasdaman/wiki/Download)
6 # - armadillo (--with-armadillo; http://arma.sourceforge.net/)
7 # - openjpeg (unreleased post-1.5 or 2? needs opj_decode_tile_data symbol, not available in 1.3-1.5)
8 # - libjpeg12 (needs patching to use system one)
9 # - libkml (1.3.0 needed, not released yet)
10 # - wait for newer pcidsk, switch to external again
11 # - csharp, java, mysql
12 # - additional, proprietary(?) formats support:
13 #   - FMEObjects (http://www.safe.com/support/support-resources/fme-downloads/)
14 #   - ESRI FileGDBAPI (http://resources.arcgis.com/content/geodatabases/10.0/file-gdb-api)
15 #   - ECW (http://www.erdas.com/products/ecw/ERDASECWJPEG2000SDK/Details.aspx)
16 #   - Kakadu/JPEG2000 (http://www.kakadusoftware.com/)
17 #   - MrSID (http://www.lizardtech.com/developer/)
18 #   - MSG/EUMETSAT (http://www.eumetsat.int/Home/Main/DataAccess/SupportSoftwareTools/index.htm)
19 #   - Oracle/OCI >= 10.0.1 (for georaster); Oracle/OCI >= 8.1.7 (as DB)
20 #   - Ingres (--with-ingres=/path)
21 #   - Informix DB
22 #   - DWGdirect (members only? http://www.opendwg.org/)
23 #   - ESRI SDE (http://www.esri.com/software/arcgis/arcsde/index.html)
24 #   - OpenCL (--with-opencl; no free Linux implementation yet?)
25 #
26 # Conditional build:
27 %bcond_without  epsilon         # EPSILON wavelet compression support
28 %bcond_without  gta             # GTA format support
29 %bcond_without  odbc            # disable ODBC DB support
30 %bcond_with     podofo          # PDF support via podofo instead of poppler
31 %bcond_without  poppler         # PDF support via poppler
32 %bcond_without  spatialite      # SpatiaLite support
33 %bcond_without  xerces          # disable xerces support
34 %bcond_without  java            # disable Java and MDB support
35 %bcond_without  php             # disable PHP binding
36 %bcond_without  ruby            # disable ruby binding
37 #
38 %if %{with podofo}
39 %undefine       with_poppler
40 %endif
41 Summary:        Geospatial Data Abstraction Library
42 Summary(pl.UTF-8):      Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
43 Name:           gdal
44 Version:        1.9.1
45 Release:        6
46 License:        BSD-like
47 Group:          Libraries
48 Source0:        ftp://ftp.remotesensing.org/gdal/%{name}-%{version}.tar.gz
49 # Source0-md5:  c5cf09b92dac1f5775db056e165b34f5
50 Patch0:         %{name}-perl.patch
51 Patch1:         %{name}-python_install.patch
52 Patch2:         gdal-1.9.1-poppler020.patch
53
54 Patch4:         %{name}-php.patch
55 Patch5:         %{name}-fpic.patch
56 URL:            http://www.gdal.org/
57 BuildRequires:  autoconf >= 2.52
58 BuildRequires:  automake
59 BuildRequires:  cfitsio-devel
60 BuildRequires:  curl-devel
61 BuildRequires:  doxygen >= 1.4.2
62 %{?with_epsilon:BuildRequires:  epsilon-compressor-devel}
63 BuildRequires:  expat-devel >= 1.95.0
64 BuildRequires:  freexl-devel >= 1.0
65 BuildRequires:  geos-devel >= 2.2.0
66 BuildRequires:  giflib-devel >= 4.0
67 BuildRequires:  hdf-devel >= 4.0
68 BuildRequires:  hdf5-devel
69 BuildRequires:  jasper-devel
70 %{?with_java:BuildRequires:     jdk}
71 %{?with_java:BuildRequires:     jpackage-utils}
72 BuildRequires:  libcsf-devel
73 BuildRequires:  libdap-devel >= 3.10
74 BuildRequires:  libgeotiff-devel >= 1.2.1
75 %{?with_gta:BuildRequires:      libgta-devel}
76 BuildRequires:  libjpeg-devel >= 6b
77 #BuildRequires: libkml-devel >= 1.3.0
78 BuildRequires:  libpng-devel >= 2:1.2.8
79 %{?with_spatialite:BuildRequires:       libspatialite-devel}
80 BuildRequires:  libstdc++-devel
81 BuildRequires:  libtiff-devel >= 4.0
82 BuildRequires:  libtool
83 BuildRequires:  libuuid-devel
84 BuildRequires:  libwebp-devel
85 BuildRequires:  libxml2-devel
86 BuildRequires:  netcdf-devel >= 4.1
87 BuildRequires:  ogdi-devel >= 3.1
88 #BuildRequires: pcidsk-devel > 0.3
89 BuildRequires:  perl-devel
90 %{?with_php:BuildRequires:      php-devel}
91 %{?with_podofo:BuildRequires:   podofo-devel}
92 %{?with_poppler:BuildRequires:  poppler-devel}
93 # ensure it's compiled with PQescapeStringConn support
94 BuildRequires:  postgresql-backend-devel >= 8.1.4
95 BuildRequires:  postgresql-devel >= 8.1.4
96 BuildRequires:  proj-devel >= 4
97 BuildRequires:  python-devel >= 1:2.5
98 BuildRequires:  python-numpy-devel >= 1:1.0.0
99 BuildRequires:  python-setuptools
100 BuildRequires:  rpm-pythonprov
101 BuildRequires:  rpmbuild(macros) >= 1.344
102 %{?with_ruby:BuildRequires:     ruby-devel}
103 BuildRequires:  sed >= 4.0
104 BuildRequires:  sqlite3-devel >= 3.0.0
105 BuildRequires:  swig-perl
106 BuildRequires:  swig-python >= 1.3
107 %{?with_ruby:BuildRequires:     swig-ruby}
108 BuildRequires:  texlive-dvips
109 BuildRequires:  texlive-latex
110 %{?with_odbc:BuildRequires:     unixODBC-devel >= 2.2.15}
111 %{?with_xerces:BuildRequires:   xerces-c-devel >= 2.7.0}
112 BuildRequires:  xz-devel
113 BuildRequires:  zlib-devel >= 1.1.4
114 Requires:       freexl >= 1.0
115 Requires:       geos >= 2.2.0
116 Requires:       libgeotiff >= 1.2.1
117 Requires:       libpng >= 2:1.2.8
118 Requires:       libtiff >= 4.0
119 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
120
121 %description
122 GDAL is a translator library for raster geospatial data formats that
123 is released under an Open Source license. As a library, it presents a
124 single abstract data model to the calling application for all
125 supported formats. The related OGR library (which lives within the
126 GDAL source tree) provides a similar capability for simple features
127 vector data.
128
129 %description -l pl.UTF-8
130 GDAL to biblioteka konwertująca między formatami rastrowych danych
131 dotyczących powierzchni Ziemi, udostępniona na licencji Open Source.
132 Jako biblioteka udostępnia aplikacjom jeden abstrakcyjny model danych
133 do wszystkich obsługiwanych formatów. Powiązana z nią biblioteka OGR
134 (której źródła są dołączone do drzewa źródeł GDAL) daje podobne
135 możliwości dla danych wektorowych.
136
137 %package devel
138 Summary:        GDAL library header files
139 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GDAL
140 Group:          Development/Libraries
141 Requires:       %{name} = %{version}-%{release}
142 Requires:       cfitsio-devel
143 Requires:       curl-devel
144 %{?with_epsilon:Requires:       epsilon-compressor-devel}
145 Requires:       expat-devel >= 1.95.0
146 Requires:       freexl-devel >= 1.0
147 Requires:       geos-devel >= 2.2.0
148 Requires:       giflib-devel >= 4.0
149 Requires:       hdf-devel >= 4.0
150 Requires:       hdf5-devel
151 Requires:       jasper-devel
152 Requires:       libcsf-devel
153 Requires:       libdap-devel >= 3.10
154 Requires:       libgeotiff-devel >= 1.2.1
155 %{?with_gta:Requires:   libgta-devel}
156 Requires:       libjpeg-devel >= 6b
157 Requires:       libpng-devel >= 2:1.2.8
158 %{?with_spatialite:Requires:    libspatialite-devel}
159 Requires:       libstdc++-devel
160 Requires:       libtiff-devel >= 4.0
161 Requires:       libuuid-devel
162 Requires:       libwebp-devel
163 Requires:       libxml2-devel
164 Requires:       netcdf-devel >= 4
165 Requires:       ogdi-devel >= 3.1
166 #Requires:      pcidsk-devel > 0.3
167 %{?with_podofo:Requires:        podofo-devel}
168 %{?with_poppler:Requires:       poppler-devel}
169 Requires:       postgresql-devel
170 Requires:       proj-devel >= 4
171 Requires:       sqlite3-devel >= 3.0.0
172 %{?with_odbc:Requires:  unixODBC-devel}
173 %{?with_xerces:Requires:        xerces-c-devel >= 2.7.0}
174 Requires:       xz-devel
175 Requires:       zlib-devel >= 1.1.4
176
177 %description devel
178 GDAL library header files.
179
180 %description devel -l pl.UTF-8
181 Pliki nagłówkowe biblioteki GDAL.
182
183 %package static
184 Summary:        GDAL static libraries
185 Summary(pl.UTF-8):      Statyczne biblioteki GDAL
186 Group:          Development/Libraries
187 Requires:       %{name}-devel = %{version}-%{release}
188
189 %description static
190 GDAL static libraries.
191
192 %description static -l pl.UTF-8
193 Statyczne biblioteki GDAL.
194
195 %package -n perl-gdal
196 Summary:        Perl bindings for GDAL
197 Summary(pl.UTF-8):      Wiązania Perla do pakietu GDAL
198 Group:          Development/Languages/Perl
199 Requires:       %{name} = %{version}-%{release}
200
201 %description -n perl-gdal
202 Perl bindings for GDAL - Geo::GDAL, Geo::OGR and Geo::OSR modules.
203
204 %description -n perl-gdal -l pl.UTF-8
205 Wiązania Perla do pakietu GDAL - moduły Geo::GDAL, Geo::OGR, Geo::OSR.
206
207 %package -n php-gdal
208 Summary:        PHP bindings for GDAL library
209 Summary(pl.UTF-8):      Wiązania PHP do biblioteki GDAL
210 Group:          Development/Languages/PHP
211 Requires:       %{name} = %{version}-%{release}
212 %{?requires_php_extension}
213
214 %description -n php-gdal
215 PHP bindings for GDAL library
216
217 %description -n php-gdal -l pl.UTF-8
218 Wiązania PHP do biblioteki GDAL.
219
220 %package -n python-gdal
221 Summary:        GDAL Python module
222 Summary(pl.UTF-8):      Moduł Pythona GDAL
223 Group:          Libraries/Python
224 Requires:       %{name} = %{version}-%{release}
225 %pyrequires_eq  python-libs
226
227 %description -n python-gdal
228 GDAL Python module.
229
230 %description -n python-gdal -l pl.UTF-8
231 Moduł Pythona GDAL.
232
233 %package -n ruby-gdal
234 Summary:        Ruby bindings for GDAL
235 Summary(pl.UTF-8):      Wiązania języka Ruby do pakietu GDAL
236 Group:          Development/Languages
237 Requires:       %{name} = %{version}-%{release}
238 %{?ruby_mod_ver_requires_eq}
239
240 %description -n ruby-gdal
241 Ruby bindings for GDAL - gdal, gdalconst, ogr and osr modules.
242
243 %description -n ruby-gdal -l pl.UTF-8
244 Wiązania języka Ruby do pakietu GDAL - moduły gdal, gdalconst, ogr i
245 osr.
246
247 %prep
248 %setup -q
249 %patch0 -p1
250 %patch1 -p1
251 %patch2 -p4
252
253 %patch4 -p1
254 %patch5 -p1
255
256 # need to regenerate (old ones don't support perl 5.10)
257 %{__rm} swig/perl/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
258
259 %{__rm} -r man
260
261 %{__sed} -i -e 's,DODS_INC="-I.*,DODS_INC="$(pkg-config --cflags libdap)",' configure.in
262
263 %build
264 %{__libtoolize}
265 %{__aclocal} -I m4
266 %{__autoconf}
267 # disable grass/libgrass here, it can be built from separate gdal-grass package
268 %configure \
269         --datadir=%{_datadir}/gdal \
270         --with-dods-root=/usr \
271         %{?with_epsilon:--with-epsilon} \
272         %{!?with_gta:--without-gta} \
273         --with-hide-internal-symbols \
274         %{?with_java:--with-java=%{java_home}} \
275         --with-liblzma \
276         %{?with_java:--with-mdb --with-jvm-lib-add-rpath} \
277         --with-perl \
278         %{?with_php:--with-php} \
279         %{?with_podofo:--with-podofo} \
280         %{?with_poppler:--with-poppler} \
281         --with-python \
282         %{?with_ruby:--with-ruby} \
283         %{?with_spatialite:--with-spatialite} \
284         --with-sqlite3 \
285         --with-webp \
286         %{?with_xerces:--with-xerces} \
287         --with-xerces-inc=/usr/include/xercesc \
288         --with-xerces-lib="-lxerces-c" \
289         --without-grass \
290         --without-libgrass
291 #       --with-pcidsk=/usr (needs > 0.3)
292 # csharp builds, but has no configure option
293
294 # regenerate where needed
295 %{__make} -j1 -C swig/perl generate
296 %{?with_ruby:%{__make} -j1 -C swig/ruby generate}
297
298 %{__make} -j1
299
300 %{__make} -j1 docs
301
302 %{__make} -j1 man
303
304 %install
305 rm -rf $RPM_BUILD_ROOT
306
307 %{__make} -j1 install install-man \
308         DESTDIR=$RPM_BUILD_ROOT
309
310 rm -rf _html
311 cp -a html _html
312 cp -a ogr/html _html/ogr
313
314 %if %{with php}
315 # missing in make install
316 install -D swig/php/php_gdal.so $RPM_BUILD_ROOT%{php_extensiondir}/gdal.so
317 install -D swig/php/php_gdalconst.so $RPM_BUILD_ROOT%{php_extensiondir}/gdalconst.so
318 install -D swig/php/php_ogr.so $RPM_BUILD_ROOT%{php_extensiondir}/ogr.so
319 install -D swig/php/php_osr.so $RPM_BUILD_ROOT%{php_extensiondir}/osr.so
320 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
321 cat <<'EOF' >$RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/gdal.ini
322 ; Enable gdal extension module
323 extension=gdal.so
324 extension=gdalconst.so
325 extension=ogr.so
326 extension=osr.so
327 EOF
328 %endif
329
330 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
331 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
332 %py_postclean
333
334 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
335 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/.packlist
336 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/Const/.packlist
337 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OGR/.packlist
338 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OSR/.packlist
339
340 # some doxygen trash
341 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Geo/{GDAL.dox,GDAL/Const.dox,OGR.dox,OSR.dox}
342 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Geo/check_dox.pl
343 %{__rm} $RPM_BUILD_ROOT%{_bindir}/gdal_{fillnodata,sieve}.dox
344
345 %clean
346 rm -rf $RPM_BUILD_ROOT
347
348 %post   -p /sbin/ldconfig
349 %postun -p /sbin/ldconfig
350
351 %files
352 %defattr(644,root,root,755)
353 %doc NEWS PROVENANCE.TXT
354 %attr(755,root,root) %{_bindir}/epsg_tr.py
355 %attr(755,root,root) %{_bindir}/esri2wkt.py
356 %attr(755,root,root) %{_bindir}/gcps2vec.py
357 %attr(755,root,root) %{_bindir}/gcps2wld.py
358 %attr(755,root,root) %{_bindir}/gdal2tiles.py
359 %attr(755,root,root) %{_bindir}/gdal2xyz.py
360 %attr(755,root,root) %{_bindir}/gdal_contour
361 %attr(755,root,root) %{_bindir}/gdal_calc.py
362 %attr(755,root,root) %{_bindir}/gdal_fillnodata.py
363 %attr(755,root,root) %{_bindir}/gdal_grid
364 %attr(755,root,root) %{_bindir}/gdal_merge.py
365 %attr(755,root,root) %{_bindir}/gdal_polygonize.py
366 %attr(755,root,root) %{_bindir}/gdal_proximity.py
367 %attr(755,root,root) %{_bindir}/gdal_rasterize
368 %attr(755,root,root) %{_bindir}/gdal_retile.py
369 %attr(755,root,root) %{_bindir}/gdal_sieve.py
370 %attr(755,root,root) %{_bindir}/gdal_translate
371 %attr(755,root,root) %{_bindir}/gdaladdo
372 %attr(755,root,root) %{_bindir}/gdalbuildvrt
373 %attr(755,root,root) %{_bindir}/gdalchksum.py
374 %attr(755,root,root) %{_bindir}/gdaldem
375 %attr(755,root,root) %{_bindir}/gdalenhance
376 %attr(755,root,root) %{_bindir}/gdalident.py
377 %attr(755,root,root) %{_bindir}/gdalimport.py
378 %attr(755,root,root) %{_bindir}/gdalinfo
379 %attr(755,root,root) %{_bindir}/gdallocationinfo
380 %attr(755,root,root) %{_bindir}/gdalmanage
381 %attr(755,root,root) %{_bindir}/gdalsrsinfo
382 %attr(755,root,root) %{_bindir}/gdaltindex
383 %attr(755,root,root) %{_bindir}/gdaltransform
384 %attr(755,root,root) %{_bindir}/gdalwarp
385 %attr(755,root,root) %{_bindir}/mkgraticule.py
386 %attr(755,root,root) %{_bindir}/nearblack
387 %attr(755,root,root) %{_bindir}/ogr2ogr
388 %attr(755,root,root) %{_bindir}/ogrinfo
389 %attr(755,root,root) %{_bindir}/ogrtindex
390 %attr(755,root,root) %{_bindir}/pct2rgb.py
391 %attr(755,root,root) %{_bindir}/rgb2pct.py
392 %attr(755,root,root) %{_bindir}/testepsg
393 %attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
394 %attr(755,root,root) %ghost %{_libdir}/libgdal.so.1
395 %{_datadir}/gdal
396 %{_mandir}/man1/gdal2tiles.1*
397 %{_mandir}/man1/gdal_contour.1*
398 %{_mandir}/man1/gdal_fillnodata.1*
399 %{_mandir}/man1/gdal_grid.1*
400 %{_mandir}/man1/gdal_merge.1*
401 %{_mandir}/man1/gdal_rasterize.1*
402 %{_mandir}/man1/gdal_retile.1*
403 %{_mandir}/man1/gdal_sieve.1*
404 %{_mandir}/man1/gdal_translate.1*
405 %{_mandir}/man1/gdal_utilities.1*
406 %{_mandir}/man1/gdaladdo.1*
407 %{_mandir}/man1/gdalbuildvrt.1*
408 %{_mandir}/man1/gdaldem.1*
409 %{_mandir}/man1/gdalinfo.1*
410 %{_mandir}/man1/gdallocationinfo.1*
411 %{_mandir}/man1/gdalsrsinfo.1*
412 %{_mandir}/man1/gdaltindex.1*
413 %{_mandir}/man1/gdaltransform.1*
414 %{_mandir}/man1/gdalwarp.1*
415 %{_mandir}/man1/nearblack.1*
416 %{_mandir}/man1/ogr2ogr.1*
417 %{_mandir}/man1/ogr_utilities.1*
418 %{_mandir}/man1/ogrinfo.1*
419 %{_mandir}/man1/ogrtindex.1*
420 %{_mandir}/man1/pct2rgb.1*
421 %{_mandir}/man1/rgb2pct.1*
422
423 %files devel
424 %defattr(644,root,root,755)
425 %doc _html/*
426 %attr(755,root,root) %{_bindir}/gdal-config
427 %attr(755,root,root) %{_libdir}/libgdal.so
428 %{_libdir}/libgdal.la
429 %{_includedir}/cpl_*.h
430 %{_includedir}/cplkeywordparser.h
431 %{_includedir}/gdal*.h
432 %{_includedir}/gvgcpfit.h
433 %{_includedir}/memdataset.h
434 %{_includedir}/ogr_*.h
435 %{_includedir}/ogrsf_frmts.h
436 %{_includedir}/rawdataset.h
437 %{_includedir}/thinplatespline.h
438 %{_includedir}/vrtdataset.h
439 %{_mandir}/man1/gdal-config.1*
440
441 %files static
442 %defattr(644,root,root,755)
443 %{_libdir}/libgdal.a
444
445 %files -n perl-gdal
446 %defattr(644,root,root,755)
447 %dir %{perl_vendorarch}/Geo
448 %{perl_vendorarch}/Geo/GDAL.pm
449 %dir %{perl_vendorarch}/Geo/GDAL
450 %{perl_vendorarch}/Geo/GDAL/Const.pm
451 %{perl_vendorarch}/Geo/OGR.pm
452 %{perl_vendorarch}/Geo/OSR.pm
453 %dir %{perl_vendorarch}/auto/Geo
454 %dir %{perl_vendorarch}/auto/Geo/GDAL
455 %{perl_vendorarch}/auto/Geo/GDAL/GDAL.bs
456 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/GDAL.so
457 %dir %{perl_vendorarch}/auto/Geo/GDAL/Const
458 %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.bs
459 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.so
460 %dir %{perl_vendorarch}/auto/Geo/OGR
461 %{perl_vendorarch}/auto/Geo/OGR/OGR.bs
462 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OGR/OGR.so
463 %dir %{perl_vendorarch}/auto/Geo/OSR
464 %{perl_vendorarch}/auto/Geo/OSR/OSR.bs
465 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OSR/OSR.so
466
467 %if %{with php}
468 %files -n php-gdal
469 %defattr(644,root,root,755)
470 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/gdal.ini
471 %attr(755,root,root) %{php_extensiondir}/gdal.so
472 %attr(755,root,root) %{php_extensiondir}/gdalconst.so
473 %attr(755,root,root) %{php_extensiondir}/ogr.so
474 %attr(755,root,root) %{php_extensiondir}/osr.so
475 %endif
476
477 %files -n python-gdal
478 %defattr(644,root,root,755)
479 %{py_sitedir}/gdal.py[co]
480 %{py_sitedir}/gdalconst.py[co]
481 %{py_sitedir}/gdalnumeric.py[co]
482 %{py_sitedir}/ogr.py[co]
483 %{py_sitedir}/osr.py[co]
484 %{py_sitedir}/GDAL-*.egg-info
485 %dir %{py_sitedir}/osgeo
486 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal.so
487 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal_array.so
488 %attr(755,root,root) %{py_sitedir}/osgeo/_gdalconst.so
489 %attr(755,root,root) %{py_sitedir}/osgeo/_ogr.so
490 %attr(755,root,root) %{py_sitedir}/osgeo/_osr.so
491 %{py_sitedir}/osgeo/*.py[co]
492
493 %if %{with ruby}
494 %files -n ruby-gdal
495 %defattr(644,root,root,755)
496 %dir %{ruby_sitearchdir}/gdal
497 %attr(755,root,root) %{ruby_sitearchdir}/gdal/gdal.so
498 %attr(755,root,root) %{ruby_sitearchdir}/gdal/gdalconst.so
499 %attr(755,root,root) %{ruby_sitearchdir}/gdal/ogr.so
500 %attr(755,root,root) %{ruby_sitearchdir}/gdal/osr.so
501 %endif
This page took 0.060779 seconds and 3 git commands to generate.