]> git.pld-linux.org Git - packages/gdal.git/blob - gdal.spec
- updated for 1.2.6
[packages/gdal.git] / gdal.spec
1 #
2 # TODO:
3 # - consider using GRASS (or GDAL in GRASS? build trap possible)
4 #
5 Summary:        Geospatial Data Abstraction Library
6 Summary(pl):    Biblioteka abstrakcji danych dotycz±cych powierzchni Ziemi
7 Name:           gdal
8 Version:        1.2.5
9 Release:        2
10 License:        BSD-like
11 Group:          Libraries
12 Source0:        ftp://ftp.remotesensing.org/pub/gdal/%{name}-%{version}.tar.gz
13 # Source0-md5:  2e3e651be6b4f42486e99ef39c17ffb1
14 Patch0:         %{name}-pgsql.patch
15 Patch1:         %{name}-DESTDIR.patch
16 Patch2:         %{name}-sh.patch
17 URL:            http://www.remotesensing.org/gdal/
18 BuildRequires:  autoconf
19 BuildRequires:  cfitsio-devel
20 BuildRequires:  doxygen
21 BuildRequires:  geos-devel >= 2.0
22 BuildRequires:  hdf-devel >= 4.0
23 BuildRequires:  jasper-devel
24 BuildRequires:  libgeotiff-devel >= 1.2.1
25 BuildRequires:  libjpeg-devel >= 6b
26 BuildRequires:  libpng-devel >= 1.0.6
27 BuildRequires:  libstdc++-devel
28 BuildRequires:  libtiff-devel >= 3.6.0
29 BuildRequires:  libungif-devel >= 4.0
30 BuildRequires:  netcdf-devel
31 BuildRequires:  ogdi-devel >= 3.1
32 BuildRequires:  postgresql-devel
33 BuildRequires:  postgresql-backend-devel
34 BuildRequires:  python-devel
35 BuildRequires:  unixODBC-devel
36 BuildRequires:  xerces-c-devel >= 2.2.0
37 BuildRequires:  zlib-devel >= 1.1.4
38 Requires:       geos >= 2.0
39 Requires:       libgeotiff >= 1.2.1
40 Requires:       libtiff >= 3.6.0
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 GDAL is a translator library for raster geospatial data formats that
45 is released under an Open Source license. As a library, it presents a
46 single abstract data model to the calling application for all
47 supported formats. The related OGR library (which lives within the
48 GDAL source tree) provides a similar capability for simple features
49 vector data.
50
51 %description -l pl
52 GDAL to biblioteka konwertuj±ca miêdzy formatami rastrowych danych
53 dotycz±cych powierzchni Ziemi, udostêpniona na licencji Open Source.
54 Jako biblioteka udostêpnia aplikacjom jeden abstrakcyjny model danych
55 do wszystkich obs³ugiwanych formatów. Powi±zana z ni± biblioteka OGR
56 (której ¼ród³a s± do³±czone do drzewa ¼róde³ GDAL) daje podobne
57 mo¿liwo¶ci dla danych wektorowych.
58
59 %package devel
60 Summary:        GDAL library header files
61 Summary(pl):    Pliki nag³ówkowe biblioteki GDAL
62 Group:          Development/Libraries
63 Requires:       %{name} = %{version}-%{release}
64 Requires:       cfitsio-devel
65 Requires:       geos-devel >= 2.0
66 Requires:       hdf-devel >= 4.0
67 Requires:       jasper-devel
68 Requires:       libgeotiff-devel >= 1.2.1
69 Requires:       libjpeg-devel
70 Requires:       libpng-devel >= 1.0.6
71 Requires:       libstdc++-devel
72 Requires:       libtiff-devel >= 3.6.0
73 Requires:       libungif-devel
74 Requires:       netcdf-devel
75 Requires:       ogdi-devel >= 3.1
76 Requires:       postgresql-devel
77 Requires:       unixODBC-devel
78 Requires:       xerces-c-devel >= 2.2.0
79
80 %description devel
81 GDAL library header files.
82
83 %description devel -l pl
84 Pliki nag³ówkowe biblioteki GDAL.
85
86 %package static
87 Summary:        GDAL static libraries
88 Summary(pl):    Statyczne biblioteki GDAL
89 Group:          Development/Libraries
90 Requires:       %{name}-devel = %{version}-%{release}
91
92 %description static
93 GDAL static libraries.
94
95 %description static -l pl
96 Statyczne biblioteki GDAL.
97
98 %package -n python-gdal
99 Summary:        GDAL Python module
100 Summary(pl):    Modu³ Pythona GDAL
101 Group:          Libraries/Python
102 Requires:       %{name} = %{version}-%{release}
103 %pyrequires_eq  python-libs
104
105 %description -n python-gdal
106 GDAL Python module.
107
108 %description -n python-gdal -l pl
109 Modu³ Pythona GDAL.
110
111 %prep
112 %setup -q
113 %patch0 -p1
114 %patch1 -p1
115 %patch2 -p1
116
117 %{__perl} -pi -e "s@lib/python@%{_lib}/python@" aclocal.m4
118
119 %build
120 %{__autoconf}
121 %configure \
122         --datadir=%{_datadir}/gdal \
123         --with-pymoddir=%{py_sitedir} \
124         --with-xerces \
125         --with-xerces-inc=/usr/include/xercesc \
126         --with-xerces-lib="-lxerces-c" \
127         --without-grass
128
129 %{__make}
130
131 %{__make} docs
132
133 %install
134 rm -rf $RPM_BUILD_ROOT
135
136 %{__make} install \
137         DESTDIR=$RPM_BUILD_ROOT
138
139 mv -f ogr/html html/org
140
141 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{la,a}
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %post   -p /sbin/ldconfig
147 %postun -p /sbin/ldconfig
148
149 %files
150 %defattr(644,root,root,755)
151 %doc ChangeLog NEWS
152 %attr(755,root,root) %{_bindir}/*
153 %exclude %{_bindir}/gdal-config
154 %attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
155 %{_datadir}/gdal
156 %{_mandir}/man1/*
157 %exclude %{_mandir}/man1/gdal-config.1*
158
159 %files devel
160 %defattr(644,root,root,755)
161 %doc html/*
162 %attr(755,root,root) %{_bindir}/gdal-config
163 %attr(755,root,root) %{_libdir}/libgdal.so
164 %{_libdir}/libgdal.la
165 %{_includedir}/*.h
166 %{_mandir}/man1/gdal-config.1*
167
168 %files static
169 %defattr(644,root,root,755)
170 %{_libdir}/*.a
171
172 %files -n python-gdal
173 %defattr(644,root,root,755)
174 %attr(755,root,root) %{py_sitedir}/_gdalmodule.so
175 %{py_sitedir}/*.py
This page took 0.080899 seconds and 3 git commands to generate.