]> git.pld-linux.org Git - packages/gdal.git/blob - gdal.spec
- rebuild with perl 5.28.0
[packages/gdal.git] / gdal.spec
1 # TODO:
2 # - be reasonable about devel dependencies - you do not need all of them to
3 #   use gdal (probably a gdal module or driver shall not imply devel
4 #   dependency)
5 # - libjpeg12 (needs patching to use system one, --with-jpeg12 is not sufficient as of 1.9.2)
6 # - libkml (1.3.0 needed, not released yet)
7 # - wait for newer pcidsk, switch to external again
8 # - csharp, java
9 # - additional, proprietary(?) formats support:
10 #   - FMEObjects (http://www.safe.com/support/support-resources/fme-downloads/)
11 #   - ESRI FileGDBAPI (http://resources.arcgis.com/content/geodatabases/10.0/file-gdb-api)
12 #   - ECW (http://www.erdas.com/products/ecw/ERDASECWJPEG2000SDK/Details.aspx)
13 #   - Kakadu/JPEG2000 (http://www.kakadusoftware.com/)
14 #   - MrSID (http://www.lizardtech.com/developer/)
15 #   - MSG/EUMETSAT (http://www.eumetsat.int/Home/Main/DataAccess/SupportSoftwareTools/index.htm)
16 #   - Ingres (--with-ingres=/path)
17 #   - Informix DB (--with-idb)
18 #   - DWGdirect (members only? http://www.opendwg.org/)
19 #   - ESRI SDE (http://www.esri.com/software/arcgis/arcsde/index.html)
20 #
21 # Conditional build:
22 %bcond_without  armadillo       # Armadillo support for faster TPS transform
23 %bcond_without  crnlib          # DDS support via crunch/crnlib
24 %bcond_without  epsilon         # EPSILON wavelet compression support
25 %bcond_without  fyba            # SOSI geodata support using FYBA
26 %bcond_with     grass           # GRASS support (note: dependency loop; use gdal-grass.spec instead)
27 %bcond_without  gta             # GTA format support
28 %bcond_without  kea             # KEA format support
29 %bcond_without  mysql           # MySQL DB support
30 %bcond_with     oci             # ORACLE OCI DB and Georaster support
31 %bcond_without  odbc            # ODBC DB support
32 %bcond_without  opencl          # OpenCL (GPU) support
33 %bcond_without  openjpeg        # OpenJPEG 2 (JPEG2000) support
34 %bcond_with     podofo          # PDF support via podofo instead of poppler
35 %bcond_without  poppler         # PDF support via poppler
36 %bcond_without  rasdaman        # Rasdaman support
37 %bcond_without  spatialite      # SpatiaLite support
38 %bcond_without  xerces          # Xerces support
39 %bcond_without  java            # Java and MDB support
40 %bcond_with     php             # PHP binding [PHP 7 not supported by swig 3.0.x]
41 %bcond_with     ruby            # Ruby binding [not available as of 2.0.2]
42
43 %if %{with podofo}
44 %undefine       with_poppler
45 %endif
46 %if 0%{!?php_name:1}
47 %define         php_name        php55
48 %endif
49 Summary:        Geospatial Data Abstraction Library
50 Summary(pl.UTF-8):      Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
51 Name:           gdal
52 Version:        2.2.4
53 Release:        5
54 License:        BSD-like
55 Group:          Libraries
56 Source0:        http://download.osgeo.org/gdal/%{version}/%{name}-%{version}.tar.xz
57 # Source0-md5:  51b1df61dbdf81473689fab3075e7a5e
58 Patch0:         %{name}-perl.patch
59 Patch1:         %{name}-poppler.patch
60 Patch2:         %{name}-php.patch
61 Patch3:         %{name}-fpic.patch
62 Patch9:         %{name}-dds.patch
63 Patch11:        %{name}-armadillo.patch
64 Patch12:        %{name}-rasdaman.patch
65 Patch13:        %{name}-pluginsdir.patch
66 Patch15:        libx32.patch
67 URL:            http://www.gdal.org/
68 %{?with_php:BuildRequires:      %{php_name}-devel}
69 %{?with_opencl:BuildRequires:   OpenCL-devel >= 1.0}
70 %{?with_armadillo:BuildRequires:        armadillo-devel}
71 BuildRequires:  autoconf >= 2.52
72 BuildRequires:  automake
73 BuildRequires:  cfitsio-devel
74 %{?with_crnlib:BuildRequires:   crnlib-devel}
75 BuildRequires:  curl-devel
76 BuildRequires:  doxygen >= 1.4.2
77 %{?with_epsilon:BuildRequires:  epsilon-compressor-devel}
78 BuildRequires:  expat-devel >= 1.95.0
79 %{?with_fyba:BuildRequires:     fyba-devel}
80 BuildRequires:  freexl-devel >= 1.0
81 BuildRequires:  gcc >= 6:4.1
82 BuildRequires:  geos-devel >= 3.1.0
83 BuildRequires:  giflib-devel >= 4.0
84 %{?with_grass:BuildRequires:    grass-devel >= 6.4}
85 BuildRequires:  hdf-devel >= 4.0
86 BuildRequires:  hdf5-devel
87 BuildRequires:  jasper-devel
88 %{?with_java:BuildRequires:     jdk}
89 %{?with_java:BuildRequires:     jpackage-utils}
90 BuildRequires:  json-c-devel >= 0.11
91 %{?with_kea:BuildRequires:      kealib-devel}
92 BuildRequires:  libcsf-devel >= 2.0-0.041111.6
93 BuildRequires:  libdap-devel >= 3.10
94 BuildRequires:  libgeotiff-devel >= 1.2.1
95 %{?with_gta:BuildRequires:      libgta-devel}
96 BuildRequires:  libjpeg-devel >= 6b
97 #BuildRequires: libkml-devel >= 1.3.0
98 BuildRequires:  libpng-devel >= 2:1.2.8
99 %{?with_spatialite:BuildRequires:       libspatialite-devel}
100 BuildRequires:  libstdc++-devel
101 BuildRequires:  libtiff-devel >= 4.0
102 BuildRequires:  libtool
103 BuildRequires:  libuuid-devel
104 BuildRequires:  libwebp-devel
105 BuildRequires:  libxml2-devel >= 2
106 %{?with_mysql:BuildRequires:    /usr/bin/mysql_config}
107 BuildRequires:  netcdf-devel >= 4.1
108 BuildRequires:  ogdi-devel >= 3.1
109 %{?with_openjpeg:BuildRequires: openjpeg2-devel >= 2.0.0-2}
110 # 8.1.7 for DB support, 10.0.1 for georaster
111 %{?with_oci:BuildRequires:      oracle-instantclient-devel >= 10.0.1}
112 #BuildRequires: pcidsk-devel > 0.3
113 BuildRequires:  perl-devel
114 %{?with_podofo:BuildRequires:   podofo-devel}
115 %{?with_poppler:BuildRequires:  poppler-devel >= 0.24}
116 # ensure it's compiled with PQescapeStringConn support
117 BuildRequires:  postgresql-backend-devel >= 8.1.4
118 BuildRequires:  postgresql-devel >= 8.1.4
119 BuildRequires:  proj-devel >= 4
120 BuildRequires:  python-devel >= 1:2.5
121 BuildRequires:  python-numpy-devel >= 1:1.0.0
122 BuildRequires:  python-setuptools
123 %{?with_rasdaman:BuildRequires: rasdaman-devel}
124 BuildRequires:  rpm-pythonprov
125 %{?with_ruby:BuildRequires:     rpm-rubyprov}
126 BuildRequires:  rpmbuild(macros) >= 1.344
127 %{?with_ruby:BuildRequires:     ruby-devel}
128 BuildRequires:  sed >= 4.0
129 BuildRequires:  sqlite3-devel >= 3.0.0
130 BuildRequires:  swig-perl
131 BuildRequires:  swig-php >= 2.0.12-2
132 BuildRequires:  swig-python >= 1.3
133 %{?with_ruby:BuildRequires:     swig-ruby}
134 BuildRequires:  texlive-dvips
135 BuildRequires:  texlive-latex
136 %{?with_odbc:BuildRequires:     unixODBC-devel >= 2.2.15}
137 %{?with_xerces:BuildRequires:   xerces-c-devel >= 2.7.0}
138 BuildRequires:  xz-devel
139 BuildRequires:  zlib-devel >= 1.1.4
140 Requires:       freexl >= 1.0
141 Requires:       geos >= 3.1.0
142 Requires:       libgeotiff >= 1.2.1
143 Requires:       libpng >= 2:1.2.8
144 Requires:       libtiff >= 4.0
145 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
146
147 %description
148 GDAL is a translator library for raster geospatial data formats that
149 is released under an Open Source license. As a library, it presents a
150 single abstract data model to the calling application for all
151 supported formats. The related OGR library (which lives within the
152 GDAL source tree) provides a similar capability for simple features
153 vector data.
154
155 %description -l pl.UTF-8
156 GDAL to biblioteka konwertująca między formatami rastrowych danych
157 dotyczących powierzchni Ziemi, udostępniona na licencji Open Source.
158 Jako biblioteka udostępnia aplikacjom jeden abstrakcyjny model danych
159 do wszystkich obsługiwanych formatów. Powiązana z nią biblioteka OGR
160 (której źródła są dołączone do drzewa źródeł GDAL) daje podobne
161 możliwości dla danych wektorowych.
162
163 %package devel
164 Summary:        GDAL library header files
165 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GDAL
166 Group:          Development/Libraries
167 Requires:       %{name} = %{version}-%{release}
168 %{?with_opencl:Requires:        OpenCL-devel >= 1.0}
169 %{?with_armadillo:Requires:     armadillo-devel}
170 Requires:       cfitsio-devel
171 %{?with_crnlib:Requires:        crnlib-devel}
172 Requires:       curl-devel
173 %{?with_epsilon:Requires:       epsilon-compressor-devel}
174 %{?with_fyba:Requires:  fyba-devel}
175 Requires:       expat-devel >= 1.95.0
176 Requires:       freexl-devel >= 1.0
177 Requires:       geos-devel >= 3.1.0
178 Requires:       giflib-devel >= 4.0
179 Requires:       hdf-devel >= 4.0
180 Requires:       hdf5-devel
181 Requires:       jasper-devel
182 Requires:       json-c-devel >= 0.11
183 %{?with_kea:Requires:   kealib-devel}
184 Requires:       libcsf-devel
185 Requires:       libdap-devel >= 3.10
186 Requires:       libgeotiff-devel >= 1.2.1
187 %{?with_gta:Requires:   libgta-devel}
188 Requires:       libjpeg-devel >= 6b
189 Requires:       libpng-devel >= 2:1.2.8
190 %{?with_spatialite:Requires:    libspatialite-devel}
191 Requires:       libstdc++-devel
192 Requires:       libtiff-devel >= 4.0
193 Requires:       libuuid-devel
194 Requires:       libwebp-devel
195 Requires:       libxml2-devel >= 2
196 %{?with_mysql:Requires: /usr/bin/mysql_config}
197 Requires:       netcdf-devel >= 4
198 Requires:       ogdi-devel >= 3.1
199 %{?with_openjpeg:Requires:      openjpeg2-devel >= 2.0.0-2}
200 #Requires:      pcidsk-devel > 0.3
201 %{?with_podofo:Requires:        podofo-devel}
202 %{?with_poppler:Requires:       poppler-devel >= 0.24}
203 Requires:       postgresql-devel
204 Requires:       proj-devel >= 4
205 %{?with_rasdaman:Requires:      rasdaman-devel}
206 Requires:       sqlite3-devel >= 3.0.0
207 %{?with_odbc:Requires:  unixODBC-devel}
208 %{?with_xerces:Requires:        xerces-c-devel >= 2.7.0}
209 Requires:       xz-devel
210 Requires:       zlib-devel >= 1.1.4
211
212 %description devel
213 GDAL library header files.
214
215 %description devel -l pl.UTF-8
216 Pliki nagłówkowe biblioteki GDAL.
217
218 %package static
219 Summary:        GDAL static libraries
220 Summary(pl.UTF-8):      Statyczne biblioteki GDAL
221 Group:          Development/Libraries
222 Requires:       %{name}-devel = %{version}-%{release}
223
224 %description static
225 GDAL static libraries.
226
227 %description static -l pl.UTF-8
228 Statyczne biblioteki GDAL.
229
230 %package -n perl-gdal
231 Summary:        Perl bindings for GDAL
232 Summary(pl.UTF-8):      Wiązania Perla do pakietu GDAL
233 Group:          Development/Languages/Perl
234 Requires:       %{name} = %{version}-%{release}
235
236 %description -n perl-gdal
237 Perl bindings for GDAL - Geo::GDAL, Geo::OGR and Geo::OSR modules.
238
239 %description -n perl-gdal -l pl.UTF-8
240 Wiązania Perla do pakietu GDAL - moduły Geo::GDAL, Geo::OGR, Geo::OSR.
241
242 %package -n %{php_name}-gdal
243 Summary:        PHP bindings for GDAL library
244 Summary(pl.UTF-8):      Wiązania PHP do biblioteki GDAL
245 Group:          Development/Languages/PHP
246 Requires:       %{name} = %{version}-%{release}
247 %{?requires_php_extension}
248
249 %description -n %{php_name}-gdal
250 PHP bindings for GDAL library
251
252 %description -n %{php_name}-gdal -l pl.UTF-8
253 Wiązania PHP do biblioteki GDAL.
254
255 %package -n python-gdal
256 Summary:        GDAL Python module
257 Summary(pl.UTF-8):      Moduł Pythona GDAL
258 Group:          Libraries/Python
259 Requires:       %{name} = %{version}-%{release}
260 Requires:       python-libs
261
262 %description -n python-gdal
263 GDAL Python module.
264
265 %description -n python-gdal -l pl.UTF-8
266 Moduł Pythona GDAL.
267
268 %package -n ruby-gdal
269 Summary:        Ruby bindings for GDAL
270 Summary(pl.UTF-8):      Wiązania języka Ruby do pakietu GDAL
271 Group:          Development/Languages
272 Requires:       %{name} = %{version}-%{release}
273
274 %description -n ruby-gdal
275 Ruby bindings for GDAL - gdal, gdalconst, ogr and osr modules.
276
277 %description -n ruby-gdal -l pl.UTF-8
278 Wiązania języka Ruby do pakietu GDAL - moduły gdal, gdalconst, ogr i
279 osr.
280
281 %prep
282 %setup -q
283 %patch0 -p1
284 %patch1 -p2
285 %patch2 -p1
286 %patch3 -p1
287 %patch9 -p1
288 %patch11 -p1
289 %patch12 -p1
290 %patch13 -p1
291 %patch15 -p1
292
293 # need to regenerate (old ones don't support perl 5.10 or php 5.5)
294 %{__rm} swig/{perl,php}/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
295
296 %{__sed} -i \
297         -e 's/^CC=gcc/CC=%{__cc}/' \
298         -e 's/^CXX=g++/CXX=%{__cxx}/' \
299         -e 's/^CFLAGS=-fpic/CFLAGS=%{rpmcflags} -fPIC/' \
300         -e 's/^LDFLAGS=-shared/LDFLAGS=%{rpmldflags} -shared/' \
301         swig/php/GNUmakefile
302 # Build with fPIC to allow Ruby bindings
303 # Xcompiler should normally achieve that -- http://trac.osgeo.org/gdal/ticket/3978
304 # http://trac.osgeo.org/gdal/ticket/1994
305 sed -i 's|\$(CFLAGS)|$(CFLAGS) -fPIC|g' swig/ruby/RubyMakefile.mk
306 # Install Ruby bindings to distribution specific directory
307 sed -i 's|RUBY_EXTENSIONS_DIR :=.*|RUBY_EXTENSIONS_DIR := %{ruby_vendorarchdir}|' swig/ruby/RubyMakefile.mk
308
309 # Install Ruby bindings into the proper place
310 sed -i -e 's|^$(INSTALL_DIR):|$(DESTDIR)$(INSTALL_DIR):|' swig/ruby/RubyMakefile.mk
311 sed -i -e 's|^install: $(INSTALL_DIR)|install: $(DESTDIR)$(INSTALL_DIR)|' swig/ruby/RubyMakefile.mk
312
313 # our man path
314 sed -i -e 's#^mandir=.*##g' configure.ac
315
316 %{__rm} -r man
317
318 %{__sed} -i -e 's,DODS_INC="-I.*,DODS_INC="$(pkg-config --cflags libdap)",' configure.ac
319
320 %build
321 %ifarch %{x8664}
322 jvm_arch=amd64
323 %endif
324 %ifarch %{ix86}
325 jvm_arch=i386
326 %endif
327 %ifarch x32
328 jvm_arch=x32
329 %endif
330
331 %{__libtoolize}
332 %{__aclocal} -I m4
333 %{__autoconf}
334 %{__autoheader}
335 %configure \
336         --includedir=%{_includedir}/gdal \
337         --datadir=%{_datadir}/gdal \
338         --with-dods-root=/usr \
339         %{?with_armadillo:--with-armadillo} \
340         %{?with_crnlib:--with-dds} \
341         %{?with_epsilon:--with-epsilon} \
342         %{?with_grass:--with-grass} \
343         %{!?with_gta:--without-gta} \
344         --with-hide-internal-symbols \
345         %{?with_java:--with-java=%{java_home}} \
346         --with-liblzma \
347         %{!?with_kea:--without-kea} \
348         %{?with_java:--with-mdb --with-jvm-lib-add-rpath --with-jvm-lib=%{java_home}/jre/lib/$jvm_arch/server} \
349         %{?with_mysql:--with-mysql} \
350         %{?with_oci:--with-oci --with-oci-include=/usr/include/oracle/client --with-oci-lib=%{_libdir}} \
351         %{?with_opencl:--with-opencl} \
352         --with-perl \
353         %{?with_php:--with-php} \
354         %{?with_podofo:--with-podofo} \
355         %{?with_poppler:--with-poppler} \
356         --with-python \
357         %{?with_rasdaman:--with-rasdaman=%{_libdir}/rasdaman} \
358         %{?with_ruby:--with-ruby} \
359         %{?with_fyba:--with-sosi} \
360         %{?with_spatialite:--with-spatialite} \
361         --with-sqlite3 \
362         --with-webp \
363         %{?with_xerces:--with-xerces} \
364         --with-xerces-inc=/usr/include/xercesc \
365         --with-xerces-lib="-lxerces-c" \
366         --without-libgrass
367 #       --with-pcidsk=/usr (needs > 0.3)
368 # csharp builds, but has no configure option nor install target
369
370 # regenerate where needed
371 %{__make} -j1 -C swig/perl generate
372 %if %{with ruby}
373 %{__make} -j1 -C swig/ruby generate
374 %endif
375
376 %{__make} -j1 \
377         %{?with_grass:GRASS_INCLUDE="-I/usr/include/grass64"} \
378         %{?with_fyba:SOSI_INC="-I/usr/include/fyba"}
379
380 %{__make} -j1 docs
381
382 %{__make} -j1 man
383
384 %install
385 rm -rf $RPM_BUILD_ROOT
386
387 %{__make} -j1 install install-man \
388         DESTDIR=$RPM_BUILD_ROOT
389
390 rm -rf _html
391 cp -a html _html
392
393 %if %{with php}
394 # missing in make install
395 install -d $RPM_BUILD_ROOT%{php_extensiondir}
396 install -p swig/php/php_gdal.so $RPM_BUILD_ROOT%{php_extensiondir}/gdal.so
397 install -p swig/php/php_gdalconst.so $RPM_BUILD_ROOT%{php_extensiondir}/gdalconst.so
398 install -p swig/php/php_ogr.so $RPM_BUILD_ROOT%{php_extensiondir}/ogr.so
399 install -p swig/php/php_osr.so $RPM_BUILD_ROOT%{php_extensiondir}/osr.so
400 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
401 cat <<'EOF' >$RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/gdal.ini
402 ; Enable gdal extension modules
403 extension=gdal.so
404 extension=gdalconst.so
405 extension=ogr.so
406 extension=osr.so
407 EOF
408 %endif
409
410 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
411 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
412 %py_postclean
413
414 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
415 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/.packlist
416 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/Const/.packlist
417 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OGR/.packlist
418 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OSR/.packlist
419
420 %clean
421 rm -rf $RPM_BUILD_ROOT
422
423 %post   -p /sbin/ldconfig
424 %postun -p /sbin/ldconfig
425
426 %files
427 %defattr(644,root,root,755)
428 %doc NEWS PROVENANCE.TXT
429 %attr(755,root,root) %{_bindir}/epsg_tr.py
430 %attr(755,root,root) %{_bindir}/esri2wkt.py
431 %attr(755,root,root) %{_bindir}/gcps2vec.py
432 %attr(755,root,root) %{_bindir}/gcps2wld.py
433 %attr(755,root,root) %{_bindir}/gdal2tiles.py
434 %attr(755,root,root) %{_bindir}/gdal2xyz.py
435 %attr(755,root,root) %{_bindir}/gdaladdo
436 %attr(755,root,root) %{_bindir}/gdal_auth.py
437 %attr(755,root,root) %{_bindir}/gdalbuildvrt
438 %attr(755,root,root) %{_bindir}/gdal_calc.py
439 %attr(755,root,root) %{_bindir}/gdalchksum.py
440 %attr(755,root,root) %{_bindir}/gdalcompare.py
441 %attr(755,root,root) %{_bindir}/gdal_contour
442 %attr(755,root,root) %{_bindir}/gdaldem
443 %attr(755,root,root) %{_bindir}/gdal_edit.py
444 %attr(755,root,root) %{_bindir}/gdalenhance
445 %attr(755,root,root) %{_bindir}/gdal_fillnodata.py
446 %attr(755,root,root) %{_bindir}/gdal_grid
447 %attr(755,root,root) %{_bindir}/gdalident.py
448 %attr(755,root,root) %{_bindir}/gdalimport.py
449 %attr(755,root,root) %{_bindir}/gdalinfo
450 %attr(755,root,root) %{_bindir}/gdallocationinfo
451 %attr(755,root,root) %{_bindir}/gdalmanage
452 %attr(755,root,root) %{_bindir}/gdal_merge.py
453 %attr(755,root,root) %{_bindir}/gdalmove.py
454 %attr(755,root,root) %{_bindir}/gdal_pansharpen.py
455 %attr(755,root,root) %{_bindir}/gdal_polygonize.py
456 %attr(755,root,root) %{_bindir}/gdal_proximity.py
457 %attr(755,root,root) %{_bindir}/gdal_rasterize
458 %attr(755,root,root) %{_bindir}/gdal_retile.py
459 %attr(755,root,root) %{_bindir}/gdalserver
460 %attr(755,root,root) %{_bindir}/gdal_sieve.py
461 %attr(755,root,root) %{_bindir}/gdalsrsinfo
462 %attr(755,root,root) %{_bindir}/gdaltindex
463 %attr(755,root,root) %{_bindir}/gdaltransform
464 %attr(755,root,root) %{_bindir}/gdal_translate
465 %attr(755,root,root) %{_bindir}/gdalwarp
466 %attr(755,root,root) %{_bindir}/gnmanalyse
467 %attr(755,root,root) %{_bindir}/gnmmanage
468 %attr(755,root,root) %{_bindir}/mkgraticule.py
469 %attr(755,root,root) %{_bindir}/nearblack
470 %attr(755,root,root) %{_bindir}/ogr2ogr
471 %attr(755,root,root) %{_bindir}/ogrinfo
472 %attr(755,root,root) %{_bindir}/ogrlineref
473 %attr(755,root,root) %{_bindir}/ogrmerge.py
474 %attr(755,root,root) %{_bindir}/ogrtindex
475 %attr(755,root,root) %{_bindir}/pct2rgb.py
476 %attr(755,root,root) %{_bindir}/rgb2pct.py
477 %attr(755,root,root) %{_bindir}/testepsg
478 %attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
479 %attr(755,root,root) %ghost %{_libdir}/libgdal.so.20
480 %dir %{_libdir}/gdalplugins
481 %{_datadir}/gdal
482 %{_mandir}/man1/gdal2tiles.1*
483 %{_mandir}/man1/gdal_calc.1*
484 %{_mandir}/man1/gdal_contour.1*
485 %{_mandir}/man1/gdal_edit.1*
486 %{_mandir}/man1/gdal_fillnodata.1*
487 %{_mandir}/man1/gdal_grid.1*
488 %{_mandir}/man1/gdal_merge.1*
489 %{_mandir}/man1/gdal_polygonize.1*
490 %{_mandir}/man1/gdal_proximity.1*
491 %{_mandir}/man1/gdal_rasterize.1*
492 %{_mandir}/man1/gdal_retile.1*
493 %{_mandir}/man1/gdal_sieve.1*
494 %{_mandir}/man1/gdal_translate.1*
495 %{_mandir}/man1/gdal_utilities.1*
496 %{_mandir}/man1/gdaladdo.1*
497 %{_mandir}/man1/gdalbuildvrt.1*
498 %{_mandir}/man1/gdalcompare.1*
499 %{_mandir}/man1/gdaldem.1*
500 %{_mandir}/man1/gdalinfo.1*
501 %{_mandir}/man1/gdallocationinfo.1*
502 %{_mandir}/man1/gdalmanage.1*
503 %{_mandir}/man1/gdalmove.1*
504 %{_mandir}/man1/gdalsrsinfo.1*
505 %{_mandir}/man1/gdaltindex.1*
506 %{_mandir}/man1/gdaltransform.1*
507 %{_mandir}/man1/gdalwarp.1*
508 %{_mandir}/man1/nearblack.1*
509 %{_mandir}/man1/ogr2ogr.1*
510 %{_mandir}/man1/ogr_utilities.1*
511 %{_mandir}/man1/ogrinfo.1*
512 %{_mandir}/man1/ogrlineref.1*
513 %{_mandir}/man1/ogrtindex.1*
514 %{_mandir}/man1/pct2rgb.1*
515 %{_mandir}/man1/rgb2pct.1*
516 %{_mandir}/man1/gdal_pansharpen.1*
517 %{_mandir}/man1/gnm_utilities.1*
518 %{_mandir}/man1/gnmanalyse.1*
519 %{_mandir}/man1/gnmmanage.1*
520 %{_mandir}/man1/ogrmerge.1*
521
522 %files devel
523 %defattr(644,root,root,755)
524 %doc _html/*
525 %attr(755,root,root) %{_bindir}/gdal-config
526 %attr(755,root,root) %{_libdir}/libgdal.so
527 %{_libdir}/libgdal.la
528 %{_pkgconfigdir}/gdal.pc
529 %{_includedir}/gdal
530 %{_mandir}/man1/gdal-config.1*
531
532 %files static
533 %defattr(644,root,root,755)
534 %{_libdir}/libgdal.a
535
536 %files -n perl-gdal
537 %defattr(644,root,root,755)
538 %dir %{perl_vendorarch}/Geo
539 %{perl_vendorarch}/Geo/GDAL.pm
540 %dir %{perl_vendorarch}/Geo/GDAL
541 %{perl_vendorarch}/Geo/GDAL/Const.pm
542 %{perl_vendorarch}/Geo/OGR.pm
543 %{perl_vendorarch}/Geo/OSR.pm
544 %dir %{perl_vendorarch}/auto/Geo
545 %dir %{perl_vendorarch}/auto/Geo/GDAL
546 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/GDAL.so
547 %dir %{perl_vendorarch}/auto/Geo/GDAL/Const
548 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.so
549 %dir %{perl_vendorarch}/auto/Geo/GNM
550 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GNM/GNM.so
551 %dir %{perl_vendorarch}/auto/Geo/OGR
552 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OGR/OGR.so
553 %dir %{perl_vendorarch}/auto/Geo/OSR
554 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OSR/OSR.so
555 %{_mandir}/man3/Geo::GDAL.3pm*
556 %{perl_vendorarch}/Geo/GNM.pm
557
558 %if %{with php}
559 %files -n %{php_name}-gdal
560 %defattr(644,root,root,755)
561 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/gdal.ini
562 %attr(755,root,root) %{php_extensiondir}/gdal.so
563 %attr(755,root,root) %{php_extensiondir}/gdalconst.so
564 %attr(755,root,root) %{php_extensiondir}/ogr.so
565 %attr(755,root,root) %{php_extensiondir}/osr.so
566 %endif
567
568 %files -n python-gdal
569 %defattr(644,root,root,755)
570 %{py_sitedir}/gdal.py[co]
571 %{py_sitedir}/gdalconst.py[co]
572 %{py_sitedir}/gdalnumeric.py[co]
573 %{py_sitedir}/gnm.py[co]
574 %{py_sitedir}/ogr.py[co]
575 %{py_sitedir}/osr.py[co]
576 %{py_sitedir}/GDAL-*.egg-info
577 %dir %{py_sitedir}/osgeo
578 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal.so
579 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal_array.so
580 %attr(755,root,root) %{py_sitedir}/osgeo/_gdalconst.so
581 %attr(755,root,root) %{py_sitedir}/osgeo/_gnm.so
582 %attr(755,root,root) %{py_sitedir}/osgeo/_ogr.so
583 %attr(755,root,root) %{py_sitedir}/osgeo/_osr.so
584 %{py_sitedir}/osgeo/*.py[co]
585
586 %if %{with ruby}
587 %files -n ruby-gdal
588 %defattr(644,root,root,755)
589 %dir %{ruby_vendorarchdir}/gdal
590 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/gdal.so
591 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/gdalconst.so
592 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/ogr.so
593 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/osr.so
594 %endif
This page took 0.068213 seconds and 3 git commands to generate.