]> git.pld-linux.org Git - packages/gdal.git/blame - gdal.spec
build with php55
[packages/gdal.git] / gdal.spec
CommitLineData
954ec354 1# TODO:
8b360036 2# - be reasonable about devel dependencies - you do not need all of them to
cfcb08ee 3# use gdal (probably a gdal module or driver shall not imply devel
4# dependency)
9b4989ae 5# - rasdaman (--with-rasdaman; http://rasdaman.eecs.jacobs-university.de/trac/rasdaman/wiki/Download)
d3d190a4 6# - libjpeg12 (needs patching to use system one, --with-jpeg12 is not sufficient as of 1.9.2)
9b4989ae 7# - libkml (1.3.0 needed, not released yet)
954ec354 8# - wait for newer pcidsk, switch to external again
d3d190a4 9# - csharp, java
0316feee
JB
10# - DDS (--with-dds, BR [lib]crunch: http://code.google.com/p/crunch/)
11# - SOSI (--with-sosi, BR: libfyba libfygm libfyut: https://github.com/kartverket/fyba)
9b4989ae
JB
12# - additional, proprietary(?) formats support:
13# - FMEObjects (http://www.safe.com/support/support-resources/fme-downloads/)
14# - ESRI FileGDBAPI (http://resources.arcgis.com/content/geodatabases/10.0/file-gdb-api)
15# - ECW (http://www.erdas.com/products/ecw/ERDASECWJPEG2000SDK/Details.aspx)
16# - Kakadu/JPEG2000 (http://www.kakadusoftware.com/)
17# - MrSID (http://www.lizardtech.com/developer/)
18# - MSG/EUMETSAT (http://www.eumetsat.int/Home/Main/DataAccess/SupportSoftwareTools/index.htm)
19# - Oracle/OCI >= 10.0.1 (for georaster); Oracle/OCI >= 8.1.7 (as DB)
20# - Ingres (--with-ingres=/path)
0316feee 21# - Informix DB (--with-idb)
9b4989ae
JB
22# - DWGdirect (members only? http://www.opendwg.org/)
23# - ESRI SDE (http://www.esri.com/software/arcgis/arcsde/index.html)
655672e5 24#
25# Conditional build:
d3d190a4 26%bcond_without armadillo # Armadillo support for faster TPS transform
4537079d 27%bcond_without epsilon # EPSILON wavelet compression support
0316feee 28%bcond_with grass # GRASS support (note: dependency loop)
4537079d 29%bcond_without gta # GTA format support
d3d190a4 30%bcond_without mysql # MySQL DB support
0316feee 31%bcond_with oci # ORACLE OCI DB and Georaster support
d3d190a4
JB
32%bcond_without odbc # ODBC DB support
33%bcond_without opencl # OpenCL (GPU) support
c9c08280 34%bcond_without openjpeg # OpenJPEG 2 (JPEG2000) support
4537079d
JB
35%bcond_with podofo # PDF support via podofo instead of poppler
36%bcond_without poppler # PDF support via poppler
37%bcond_without spatialite # SpatiaLite support
d3d190a4
JB
38%bcond_without xerces # Xerces support
39%bcond_without java # Java and MDB support
0316feee 40%bcond_without php # PHP binding
315a1c4a
ER
41%bcond_without ruby # Ruby binding
42
fac7da6f
JB
43%if %{with podofo}
44%undefine with_poppler
45%endif
ead243f9 46%define php_name php55
faf5649c 47Summary: Geospatial Data Abstraction Library
a28c1bee 48Summary(pl.UTF-8): Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
faf5649c 49Name: gdal
0316feee 50Version: 1.11.0
ead243f9 51Release: 3
faf5649c
JB
52License: BSD-like
53Group: Libraries
84501866 54Source0: http://download.osgeo.org/gdal/%{version}/%{name}-%{version}.tar.xz
0316feee 55# Source0-md5: 31f2c4a7230b40e5fdc3cf12a100f96b
f5a12c65 56Patch0: %{name}-perl.patch
9b4989ae 57Patch1: %{name}-python_install.patch
f1b5abea
JB
58Patch2: %{name}-php.patch
59Patch3: %{name}-fpic.patch
75b2e515 60Patch4: %{name}-format-security.patch
0316feee
JB
61Patch5: %{name}-grass.patch
62Patch6: %{name}-sse.patch
63Patch7: %{name}-link.patch
9b5c0fd4 64URL: http://www.gdal.org/
ead243f9 65%{?with_php:BuildRequires: %{php_name}-devel}
d3d190a4
JB
66%{?with_opencl:BuildRequires: OpenCL-devel >= 1.0}
67%{?with_armadillo:BuildRequires: armadillo-devel}
69051332
JB
68BuildRequires: autoconf >= 2.52
69BuildRequires: automake
6b59fa88 70BuildRequires: cfitsio-devel
9b4989ae 71BuildRequires: curl-devel
9d161bc4 72BuildRequires: doxygen >= 1.4.2
209aac6b 73%{?with_epsilon:BuildRequires: epsilon-compressor-devel}
69051332 74BuildRequires: expat-devel >= 1.95.0
4537079d 75BuildRequires: freexl-devel >= 1.0
0316feee
JB
76BuildRequires: gcc >= 6:4.1
77BuildRequires: geos-devel >= 3.1.0
b459f4d7 78BuildRequires: giflib-devel >= 4.0
0316feee 79%{?with_grass:BuildRequires: grass-devel >= 5.7}
6b59fa88 80BuildRequires: hdf-devel >= 4.0
69051332 81BuildRequires: hdf5-devel
6b59fa88 82BuildRequires: jasper-devel
9b4989ae
JB
83%{?with_java:BuildRequires: jdk}
84%{?with_java:BuildRequires: jpackage-utils}
0316feee 85BuildRequires: json-c-devel >= 0.11
d4d7a2c6 86BuildRequires: libcsf-devel
4058fbc3 87BuildRequires: libdap-devel >= 3.10
b3cbf6a3 88BuildRequires: libgeotiff-devel >= 1.2.1
b88bb9ef 89%{?with_gta:BuildRequires: libgta-devel}
6b59fa88 90BuildRequires: libjpeg-devel >= 6b
9b4989ae 91#BuildRequires: libkml-devel >= 1.3.0
e354fe40 92BuildRequires: libpng-devel >= 2:1.2.8
4537079d 93%{?with_spatialite:BuildRequires: libspatialite-devel}
b3cbf6a3 94BuildRequires: libstdc++-devel
954ec354 95BuildRequires: libtiff-devel >= 4.0
69051332 96BuildRequires: libtool
e2b089e1 97BuildRequires: libuuid-devel
9b4989ae 98BuildRequires: libwebp-devel
0316feee 99BuildRequires: libxml2-devel >= 2
d3d190a4 100%{?with_mysql:BuildRequires: mysql-devel}
80114ba8 101BuildRequires: netcdf-devel >= 4.1
6b59fa88 102BuildRequires: ogdi-devel >= 3.1
c9c08280 103%{?with_openjpeg:BuildRequires: openjpeg2-devel >= 2.0.0-2}
0316feee
JB
104# 8.1.7 for DB support, 10.0.1 for georaster
105%{?with_oci:BuildRequires: oracle-instantclient-devel >= 10.0.1}
954ec354 106#BuildRequires: pcidsk-devel > 0.3
a0ffd9c4 107BuildRequires: perl-devel
fac7da6f 108%{?with_podofo:BuildRequires: podofo-devel}
0077f857 109%{?with_poppler:BuildRequires: poppler-devel >= 0.24}
9b4989ae
JB
110# ensure it's compiled with PQescapeStringConn support
111BuildRequires: postgresql-backend-devel >= 8.1.4
112BuildRequires: postgresql-devel >= 8.1.4
113BuildRequires: proj-devel >= 4
9a2dbbce 114BuildRequires: python-devel >= 1:2.5
017b03bb 115BuildRequires: python-numpy-devel >= 1:1.0.0
9b4989ae 116BuildRequires: python-setuptools
479cb83c 117BuildRequires: rpm-pythonprov
315a1c4a 118%{?with_ruby:BuildRequires: rpm-rubyprov}
9b4989ae 119BuildRequires: rpmbuild(macros) >= 1.344
4aafe7c0 120%{?with_ruby:BuildRequires: ruby-devel}
b88bb9ef 121BuildRequires: sed >= 4.0
9b4989ae 122BuildRequires: sqlite3-devel >= 3.0.0
479cb83c 123BuildRequires: swig-perl
0316feee 124BuildRequires: swig-php >= 2.0.12-2
9a2dbbce 125BuildRequires: swig-python >= 1.3
017b03bb 126%{?with_ruby:BuildRequires: swig-ruby}
479cb83c 127BuildRequires: texlive-dvips
128BuildRequires: texlive-latex
9831286f 129%{?with_odbc:BuildRequires: unixODBC-devel >= 2.2.15}
9b4989ae
JB
130%{?with_xerces:BuildRequires: xerces-c-devel >= 2.7.0}
131BuildRequires: xz-devel
faf5649c 132BuildRequires: zlib-devel >= 1.1.4
4537079d 133Requires: freexl >= 1.0
0316feee 134Requires: geos >= 3.1.0
b3cbf6a3 135Requires: libgeotiff >= 1.2.1
e354fe40 136Requires: libpng >= 2:1.2.8
954ec354 137Requires: libtiff >= 4.0
faf5649c
JB
138BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
139
140%description
141GDAL is a translator library for raster geospatial data formats that
142is released under an Open Source license. As a library, it presents a
143single abstract data model to the calling application for all
144supported formats. The related OGR library (which lives within the
145GDAL source tree) provides a similar capability for simple features
146vector data.
f05c79e8 147
d34f2ec8
JR
148%description -l pl.UTF-8
149GDAL to biblioteka konwertująca między formatami rastrowych danych
150dotyczących powierzchni Ziemi, udostępniona na licencji Open Source.
151Jako biblioteka udostępnia aplikacjom jeden abstrakcyjny model danych
152do wszystkich obsługiwanych formatów. Powiązana z nią biblioteka OGR
153(której źródła są dołączone do drzewa źródeł GDAL) daje podobne
154możliwości dla danych wektorowych.
faf5649c 155
6b59fa88
JB
156%package devel
157Summary: GDAL library header files
a28c1bee 158Summary(pl.UTF-8): Pliki nagłówkowe biblioteki GDAL
6b59fa88 159Group: Development/Libraries
1673a634 160Requires: %{name} = %{version}-%{release}
d3d190a4
JB
161%{?with_opencl:Requires: OpenCL-devel >= 1.0}
162%{?with_armadillo:Requires: armadillo-devel}
b3cbf6a3 163Requires: cfitsio-devel
209aac6b
JB
164Requires: curl-devel
165%{?with_epsilon:Requires: epsilon-compressor-devel}
69051332 166Requires: expat-devel >= 1.95.0
4537079d 167Requires: freexl-devel >= 1.0
0316feee 168Requires: geos-devel >= 3.1.0
209aac6b 169Requires: giflib-devel >= 4.0
b3cbf6a3 170Requires: hdf-devel >= 4.0
69051332 171Requires: hdf5-devel
b3cbf6a3 172Requires: jasper-devel
0316feee 173Requires: json-c-devel >= 0.11
d4d7a2c6 174Requires: libcsf-devel
4058fbc3 175Requires: libdap-devel >= 3.10
b3cbf6a3 176Requires: libgeotiff-devel >= 1.2.1
209aac6b
JB
177%{?with_gta:Requires: libgta-devel}
178Requires: libjpeg-devel >= 6b
e354fe40 179Requires: libpng-devel >= 2:1.2.8
4537079d 180%{?with_spatialite:Requires: libspatialite-devel}
b3cbf6a3 181Requires: libstdc++-devel
954ec354 182Requires: libtiff-devel >= 4.0
209aac6b
JB
183Requires: libuuid-devel
184Requires: libwebp-devel
0316feee 185Requires: libxml2-devel >= 2
d3d190a4 186%{?with_mysql:Requires: mysql-devel}
9b4989ae 187Requires: netcdf-devel >= 4
b3cbf6a3 188Requires: ogdi-devel >= 3.1
c9c08280 189%{?with_openjpeg:Requires: openjpeg2-devel >= 2.0.0-2}
954ec354 190#Requires: pcidsk-devel > 0.3
209aac6b 191%{?with_podofo:Requires: podofo-devel}
0077f857 192%{?with_poppler:Requires: poppler-devel >= 0.24}
b3cbf6a3 193Requires: postgresql-devel
209aac6b 194Requires: proj-devel >= 4
9b4989ae 195Requires: sqlite3-devel >= 3.0.0
655672e5 196%{?with_odbc:Requires: unixODBC-devel}
69051332 197%{?with_xerces:Requires: xerces-c-devel >= 2.7.0}
209aac6b
JB
198Requires: xz-devel
199Requires: zlib-devel >= 1.1.4
6b59fa88
JB
200
201%description devel
202GDAL library header files.
203
d34f2ec8
JR
204%description devel -l pl.UTF-8
205Pliki nagłówkowe biblioteki GDAL.
6b59fa88
JB
206
207%package static
208Summary: GDAL static libraries
a28c1bee 209Summary(pl.UTF-8): Statyczne biblioteki GDAL
6b59fa88 210Group: Development/Libraries
1673a634 211Requires: %{name}-devel = %{version}-%{release}
6b59fa88
JB
212
213%description static
214GDAL static libraries.
215
d34f2ec8 216%description static -l pl.UTF-8
6b59fa88
JB
217Statyczne biblioteki GDAL.
218
a0ffd9c4
JB
219%package -n perl-gdal
220Summary: Perl bindings for GDAL
221Summary(pl.UTF-8): Wiązania Perla do pakietu GDAL
222Group: Development/Languages/Perl
223Requires: %{name} = %{version}-%{release}
224
225%description -n perl-gdal
226Perl bindings for GDAL - Geo::GDAL, Geo::OGR and Geo::OSR modules.
227
228%description -n perl-gdal -l pl.UTF-8
017b03bb 229Wiązania Perla do pakietu GDAL - moduły Geo::GDAL, Geo::OGR, Geo::OSR.
a0ffd9c4 230
ead243f9 231%package -n %{php_name}-gdal
9b4989ae
JB
232Summary: PHP bindings for GDAL library
233Summary(pl.UTF-8): Wiązania PHP do biblioteki GDAL
234Group: Development/Languages/PHP
235Requires: %{name} = %{version}-%{release}
236%{?requires_php_extension}
237
ead243f9 238%description -n %{php_name}-gdal
9b4989ae
JB
239PHP bindings for GDAL library
240
ead243f9 241%description -n %{php_name}-gdal -l pl.UTF-8
9b4989ae
JB
242Wiązania PHP do biblioteki GDAL.
243
6b59fa88
JB
244%package -n python-gdal
245Summary: GDAL Python module
a28c1bee 246Summary(pl.UTF-8): Moduł Pythona GDAL
6b59fa88 247Group: Libraries/Python
1673a634 248Requires: %{name} = %{version}-%{release}
315a1c4a 249Requires: python-libs
6b59fa88
JB
250
251%description -n python-gdal
252GDAL Python module.
253
d34f2ec8
JR
254%description -n python-gdal -l pl.UTF-8
255Moduł Pythona GDAL.
6b59fa88 256
a0ffd9c4
JB
257%package -n ruby-gdal
258Summary: Ruby bindings for GDAL
259Summary(pl.UTF-8): Wiązania języka Ruby do pakietu GDAL
260Group: Development/Languages
261Requires: %{name} = %{version}-%{release}
a0ffd9c4
JB
262
263%description -n ruby-gdal
264Ruby bindings for GDAL - gdal, gdalconst, ogr and osr modules.
265
266%description -n ruby-gdal -l pl.UTF-8
017b03bb
ER
267Wiązania języka Ruby do pakietu GDAL - moduły gdal, gdalconst, ogr i
268osr.
a0ffd9c4 269
faf5649c
JB
270%prep
271%setup -q
272%patch0 -p1
273%patch1 -p1
f1b5abea
JB
274%patch2 -p1
275%patch3 -p1
c9c08280 276%patch4 -p1
0316feee
JB
277%patch5 -p1
278%patch6 -p1
279%patch7 -p1
280
281# need to regenerate (old ones don't support perl 5.10 or php 5.5)
282%{__rm} swig/{perl,php}/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
283
284%{__sed} -i \
285 -e 's/^CC=gcc/CC=%{__cc}/' \
286 -e 's/^CXX=g++/CXX=%{__cxx}/' \
287 -e 's/^CFLAGS=-fpic/CFLAGS=%{rpmcflags} -fPIC/' \
288 -e 's/^LDFLAGS=-shared/LDFLAGS=%{rpmldflags} -shared/' \
289 swig/php/GNUmakefile
315a1c4a
ER
290# Build with fPIC to allow Ruby bindings
291# Xcompiler should normally achieve that -- http://trac.osgeo.org/gdal/ticket/3978
292# http://trac.osgeo.org/gdal/ticket/1994
293sed -i 's|\$(CFLAGS)|$(CFLAGS) -fPIC|g' swig/ruby/RubyMakefile.mk
294# Install Ruby bindings to distribution specific directory
295sed -i 's|RUBY_EXTENSIONS_DIR :=.*|RUBY_EXTENSIONS_DIR := %{ruby_vendorarchdir}|' swig/ruby/RubyMakefile.mk
296
297# Install Ruby bindings into the proper place
298sed -i -e 's|^$(INSTALL_DIR):|$(DESTDIR)$(INSTALL_DIR):|' swig/ruby/RubyMakefile.mk
299sed -i -e 's|^install: $(INSTALL_DIR)|install: $(DESTDIR)$(INSTALL_DIR)|' swig/ruby/RubyMakefile.mk
300
f4952e6f
AM
301# our man path
302sed -i -e 's#^mandir=.*##g' configure.in
303
4058fbc3 304%{__rm} -r man
4ed54fac 305
b88bb9ef
JB
306%{__sed} -i -e 's,DODS_INC="-I.*,DODS_INC="$(pkg-config --cflags libdap)",' configure.in
307
faf5649c 308%build
69051332 309%{__libtoolize}
69051332 310%{__aclocal} -I m4
faf5649c 311%{__autoconf}
69051332 312# disable grass/libgrass here, it can be built from separate gdal-grass package
6b59fa88 313%configure \
5014b82a 314 --datadir=%{_datadir}/gdal \
d4d7a2c6 315 --with-dods-root=/usr \
d3d190a4 316 %{?with_armadillo:--with-armadillo} \
209aac6b 317 %{?with_epsilon:--with-epsilon} \
0316feee 318 %{?with_grass:--with-grass} \
b88bb9ef 319 %{!?with_gta:--without-gta} \
69051332 320 --with-hide-internal-symbols \
9b4989ae
JB
321 %{?with_java:--with-java=%{java_home}} \
322 --with-liblzma \
209aac6b 323 %{?with_java:--with-mdb --with-jvm-lib-add-rpath} \
d3d190a4 324 %{?with_mysql:--with-mysql} \
0316feee 325 %{?with_oci:--with-oci --with-oci-include=/usr/include/oracle/client --with-oci-lib=%{_libdir}} \
d3d190a4 326 %{?with_opencl:--with-opencl} \
a0ffd9c4 327 --with-perl \
9b4989ae 328 %{?with_php:--with-php} \
fac7da6f
JB
329 %{?with_podofo:--with-podofo} \
330 %{?with_poppler:--with-poppler} \
69051332 331 --with-python \
4aafe7c0 332 %{?with_ruby:--with-ruby} \
4537079d 333 %{?with_spatialite:--with-spatialite} \
69051332 334 --with-sqlite3 \
9b4989ae 335 --with-webp \
655672e5 336 %{?with_xerces:--with-xerces} \
6b59fa88 337 --with-xerces-inc=/usr/include/xercesc \
80faacbe 338 --with-xerces-lib="-lxerces-c" \
69051332 339 --without-libgrass
d3d190a4 340# --with-rasdaman
954ec354 341# --with-pcidsk=/usr (needs > 0.3)
69051332 342# csharp builds, but has no configure option
faf5649c 343
69051332 344# regenerate where needed
825dc3dc 345%{__make} -j1 -C swig/perl generate
3df9ed7f 346%if %{with ruby}
02b013b1 347%{__make} -j1 -C swig/ruby generate
3df9ed7f 348%endif
69051332 349
825dc3dc 350%{__make} -j1
a0ffd9c4 351
825dc3dc 352%{__make} -j1 docs
3a591acf 353
f5a12c65
JK
354%{__make} -j1 man
355
faf5649c
JB
356%install
357rm -rf $RPM_BUILD_ROOT
faf5649c 358
825dc3dc 359%{__make} -j1 install install-man \
3a591acf
JB
360 DESTDIR=$RPM_BUILD_ROOT
361
388b39cb
ER
362rm -rf _html
363cp -a html _html
364cp -a ogr/html _html/ogr
faf5649c 365
9b4989ae
JB
366%if %{with php}
367# missing in make install
ead243f9
ER
368install -d $RPM_BUILD_ROOT%{php_extensiondir}
369install -p swig/php/php_gdal.so $RPM_BUILD_ROOT%{php_extensiondir}/gdal.so
370install -p swig/php/php_gdalconst.so $RPM_BUILD_ROOT%{php_extensiondir}/gdalconst.so
371install -p swig/php/php_ogr.so $RPM_BUILD_ROOT%{php_extensiondir}/ogr.so
372install -p swig/php/php_osr.so $RPM_BUILD_ROOT%{php_extensiondir}/osr.so
9b4989ae
JB
373install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
374cat <<'EOF' >$RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/gdal.ini
ead243f9 375; Enable gdal extension modules
9b4989ae
JB
376extension=gdal.so
377extension=gdalconst.so
378extension=ogr.so
379extension=osr.so
380EOF
381%endif
382
374370d5
JB
383%py_comp $RPM_BUILD_ROOT%{py_sitedir}
384%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
385%py_postclean
5014b82a 386
017b03bb
ER
387%{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
388%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/.packlist
389%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/Const/.packlist
390%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OGR/.packlist
391%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OSR/.packlist
392
393# some doxygen trash
0316feee
JB
394%{__rm} $RPM_BUILD_ROOT%{_bindir}/gdal{compare,move}.dox
395%{__rm} $RPM_BUILD_ROOT%{_bindir}/gdal_{calc,edit,fillnodata,polygonize,proximity,sieve}.dox
017b03bb 396
faf5649c
JB
397%clean
398rm -rf $RPM_BUILD_ROOT
399
6b59fa88
JB
400%post -p /sbin/ldconfig
401%postun -p /sbin/ldconfig
402
faf5649c
JB
403%files
404%defattr(644,root,root,755)
c0a384ef 405%doc NEWS PROVENANCE.TXT
4058fbc3
JB
406%attr(755,root,root) %{_bindir}/epsg_tr.py
407%attr(755,root,root) %{_bindir}/esri2wkt.py
408%attr(755,root,root) %{_bindir}/gcps2vec.py
409%attr(755,root,root) %{_bindir}/gcps2wld.py
410%attr(755,root,root) %{_bindir}/gdal2tiles.py
411%attr(755,root,root) %{_bindir}/gdal2xyz.py
f4952e6f 412%attr(755,root,root) %{_bindir}/gdal_auth.py
4058fbc3 413%attr(755,root,root) %{_bindir}/gdal_contour
954ec354 414%attr(755,root,root) %{_bindir}/gdal_calc.py
f4952e6f 415%attr(755,root,root) %{_bindir}/gdal_edit.py
4058fbc3
JB
416%attr(755,root,root) %{_bindir}/gdal_fillnodata.py
417%attr(755,root,root) %{_bindir}/gdal_grid
418%attr(755,root,root) %{_bindir}/gdal_merge.py
419%attr(755,root,root) %{_bindir}/gdal_polygonize.py
420%attr(755,root,root) %{_bindir}/gdal_proximity.py
421%attr(755,root,root) %{_bindir}/gdal_rasterize
422%attr(755,root,root) %{_bindir}/gdal_retile.py
423%attr(755,root,root) %{_bindir}/gdal_sieve.py
424%attr(755,root,root) %{_bindir}/gdal_translate
425%attr(755,root,root) %{_bindir}/gdaladdo
426%attr(755,root,root) %{_bindir}/gdalbuildvrt
427%attr(755,root,root) %{_bindir}/gdalchksum.py
0316feee 428%attr(755,root,root) %{_bindir}/gdalcompare.py
4058fbc3
JB
429%attr(755,root,root) %{_bindir}/gdaldem
430%attr(755,root,root) %{_bindir}/gdalenhance
431%attr(755,root,root) %{_bindir}/gdalident.py
432%attr(755,root,root) %{_bindir}/gdalimport.py
433%attr(755,root,root) %{_bindir}/gdalinfo
954ec354 434%attr(755,root,root) %{_bindir}/gdallocationinfo
4058fbc3 435%attr(755,root,root) %{_bindir}/gdalmanage
f4952e6f
AM
436%attr(755,root,root) %{_bindir}/gdalmove.py
437%attr(755,root,root) %{_bindir}/gdalserver
9b4989ae 438%attr(755,root,root) %{_bindir}/gdalsrsinfo
4058fbc3
JB
439%attr(755,root,root) %{_bindir}/gdaltindex
440%attr(755,root,root) %{_bindir}/gdaltransform
441%attr(755,root,root) %{_bindir}/gdalwarp
442%attr(755,root,root) %{_bindir}/mkgraticule.py
443%attr(755,root,root) %{_bindir}/nearblack
444%attr(755,root,root) %{_bindir}/ogr2ogr
445%attr(755,root,root) %{_bindir}/ogrinfo
0316feee 446%attr(755,root,root) %{_bindir}/ogrlineref
4058fbc3
JB
447%attr(755,root,root) %{_bindir}/ogrtindex
448%attr(755,root,root) %{_bindir}/pct2rgb.py
449%attr(755,root,root) %{_bindir}/rgb2pct.py
450%attr(755,root,root) %{_bindir}/testepsg
5014b82a 451%attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
017b03bb 452%attr(755,root,root) %ghost %{_libdir}/libgdal.so.1
6b59fa88 453%{_datadir}/gdal
4058fbc3 454%{_mandir}/man1/gdal2tiles.1*
0316feee 455%{_mandir}/man1/gdal_calc.1*
4058fbc3 456%{_mandir}/man1/gdal_contour.1*
f4952e6f 457%{_mandir}/man1/gdal_edit.1*
4058fbc3
JB
458%{_mandir}/man1/gdal_fillnodata.1*
459%{_mandir}/man1/gdal_grid.1*
460%{_mandir}/man1/gdal_merge.1*
f4952e6f
AM
461%{_mandir}/man1/gdal_polygonize.1*
462%{_mandir}/man1/gdal_proximity.1*
4058fbc3
JB
463%{_mandir}/man1/gdal_rasterize.1*
464%{_mandir}/man1/gdal_retile.1*
465%{_mandir}/man1/gdal_sieve.1*
466%{_mandir}/man1/gdal_translate.1*
467%{_mandir}/man1/gdal_utilities.1*
468%{_mandir}/man1/gdaladdo.1*
469%{_mandir}/man1/gdalbuildvrt.1*
0316feee 470%{_mandir}/man1/gdalcompare.1*
4058fbc3
JB
471%{_mandir}/man1/gdaldem.1*
472%{_mandir}/man1/gdalinfo.1*
954ec354 473%{_mandir}/man1/gdallocationinfo.1*
f4952e6f
AM
474%{_mandir}/man1/gdalmanage.1*
475%{_mandir}/man1/gdalmove.1*
9b4989ae 476%{_mandir}/man1/gdalsrsinfo.1*
4058fbc3
JB
477%{_mandir}/man1/gdaltindex.1*
478%{_mandir}/man1/gdaltransform.1*
479%{_mandir}/man1/gdalwarp.1*
480%{_mandir}/man1/nearblack.1*
481%{_mandir}/man1/ogr2ogr.1*
482%{_mandir}/man1/ogr_utilities.1*
483%{_mandir}/man1/ogrinfo.1*
0316feee 484%{_mandir}/man1/ogrlineref.1*
4058fbc3
JB
485%{_mandir}/man1/ogrtindex.1*
486%{_mandir}/man1/pct2rgb.1*
487%{_mandir}/man1/rgb2pct.1*
6b59fa88
JB
488
489%files devel
490%defattr(644,root,root,755)
388b39cb 491%doc _html/*
5014b82a 492%attr(755,root,root) %{_bindir}/gdal-config
6b59fa88 493%attr(755,root,root) %{_libdir}/libgdal.so
5014b82a 494%{_libdir}/libgdal.la
0316feee 495%{_pkgconfigdir}/gdal.pc
4058fbc3
JB
496%{_includedir}/cpl_*.h
497%{_includedir}/cplkeywordparser.h
498%{_includedir}/gdal*.h
499%{_includedir}/gvgcpfit.h
500%{_includedir}/memdataset.h
501%{_includedir}/ogr_*.h
502%{_includedir}/ogrsf_frmts.h
503%{_includedir}/rawdataset.h
504%{_includedir}/thinplatespline.h
505%{_includedir}/vrtdataset.h
5014b82a 506%{_mandir}/man1/gdal-config.1*
6b59fa88
JB
507
508%files static
509%defattr(644,root,root,755)
9b5c0fd4 510%{_libdir}/libgdal.a
6b59fa88 511
a0ffd9c4
JB
512%files -n perl-gdal
513%defattr(644,root,root,755)
514%dir %{perl_vendorarch}/Geo
515%{perl_vendorarch}/Geo/GDAL.pm
516%dir %{perl_vendorarch}/Geo/GDAL
517%{perl_vendorarch}/Geo/GDAL/Const.pm
518%{perl_vendorarch}/Geo/OGR.pm
519%{perl_vendorarch}/Geo/OSR.pm
520%dir %{perl_vendorarch}/auto/Geo
521%dir %{perl_vendorarch}/auto/Geo/GDAL
522%{perl_vendorarch}/auto/Geo/GDAL/GDAL.bs
523%attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/GDAL.so
524%dir %{perl_vendorarch}/auto/Geo/GDAL/Const
525%{perl_vendorarch}/auto/Geo/GDAL/Const/Const.bs
526%attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.so
527%dir %{perl_vendorarch}/auto/Geo/OGR
528%{perl_vendorarch}/auto/Geo/OGR/OGR.bs
529%attr(755,root,root) %{perl_vendorarch}/auto/Geo/OGR/OGR.so
530%dir %{perl_vendorarch}/auto/Geo/OSR
531%{perl_vendorarch}/auto/Geo/OSR/OSR.bs
532%attr(755,root,root) %{perl_vendorarch}/auto/Geo/OSR/OSR.so
533
9b4989ae 534%if %{with php}
ead243f9 535%files -n %{php_name}-gdal
9b4989ae
JB
536%defattr(644,root,root,755)
537%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/gdal.ini
538%attr(755,root,root) %{php_extensiondir}/gdal.so
539%attr(755,root,root) %{php_extensiondir}/gdalconst.so
540%attr(755,root,root) %{php_extensiondir}/ogr.so
541%attr(755,root,root) %{php_extensiondir}/osr.so
542%endif
543
6b59fa88
JB
544%files -n python-gdal
545%defattr(644,root,root,755)
9a2dbbce
JB
546%{py_sitedir}/gdal.py[co]
547%{py_sitedir}/gdalconst.py[co]
548%{py_sitedir}/gdalnumeric.py[co]
9a2dbbce
JB
549%{py_sitedir}/ogr.py[co]
550%{py_sitedir}/osr.py[co]
69051332
JB
551%{py_sitedir}/GDAL-*.egg-info
552%dir %{py_sitedir}/osgeo
553%attr(755,root,root) %{py_sitedir}/osgeo/_gdal.so
554%attr(755,root,root) %{py_sitedir}/osgeo/_gdal_array.so
555%attr(755,root,root) %{py_sitedir}/osgeo/_gdalconst.so
556%attr(755,root,root) %{py_sitedir}/osgeo/_ogr.so
557%attr(755,root,root) %{py_sitedir}/osgeo/_osr.so
558%{py_sitedir}/osgeo/*.py[co]
a0ffd9c4 559
4aafe7c0 560%if %{with ruby}
a0ffd9c4
JB
561%files -n ruby-gdal
562%defattr(644,root,root,755)
315a1c4a
ER
563%dir %{ruby_vendorarchdir}/gdal
564%attr(755,root,root) %{ruby_vendorarchdir}/gdal/gdal.so
565%attr(755,root,root) %{ruby_vendorarchdir}/gdal/gdalconst.so
566%attr(755,root,root) %{ruby_vendorarchdir}/gdal/ogr.so
567%attr(755,root,root) %{ruby_vendorarchdir}/gdal/osr.so
4aafe7c0 568%endif
This page took 0.185395 seconds and 4 git commands to generate.