]> git.pld-linux.org Git - packages/gdal.git/blame - gdal.spec
- shebang fixes
[packages/gdal.git] / gdal.spec
CommitLineData
954ec354 1# TODO:
8b360036 2# - be reasonable about devel dependencies - you do not need all of them to
cfcb08ee 3# use gdal (probably a gdal module or driver shall not imply devel
4# dependency)
c64d9529
JB
5# - MongoCXX (mongo/client/dbclient.h, -lmongoclient -lboost_system -lboost_thread -lboost_regex)
6# - rasterlite2
7# - sfcgal >= 1.2.2
d3d190a4 8# - libjpeg12 (needs patching to use system one, --with-jpeg12 is not sufficient as of 1.9.2)
9b4989ae 9# - libkml (1.3.0 needed, not released yet)
954ec354 10# - wait for newer pcidsk, switch to external again
d3d190a4 11# - csharp, java
9b4989ae
JB
12# - additional, proprietary(?) formats support:
13# - FMEObjects (http://www.safe.com/support/support-resources/fme-downloads/)
14# - ESRI FileGDBAPI (http://resources.arcgis.com/content/geodatabases/10.0/file-gdb-api)
15# - ECW (http://www.erdas.com/products/ecw/ERDASECWJPEG2000SDK/Details.aspx)
16# - Kakadu/JPEG2000 (http://www.kakadusoftware.com/)
17# - MrSID (http://www.lizardtech.com/developer/)
c64d9529 18# - LuraTech JP2Lura
9b4989ae 19# - MSG/EUMETSAT (http://www.eumetsat.int/Home/Main/DataAccess/SupportSoftwareTools/index.htm)
9b4989ae 20# - Ingres (--with-ingres=/path)
0316feee 21# - Informix DB (--with-idb)
9b4989ae
JB
22# - DWGdirect (members only? http://www.opendwg.org/)
23# - ESRI SDE (http://www.esri.com/software/arcgis/arcsde/index.html)
c64d9529 24# - Teigha DWG/DGN (https://www.opendesign.com/products/drawings?)
655672e5 25#
26# Conditional build:
d3d190a4 27%bcond_without armadillo # Armadillo support for faster TPS transform
779b0eec 28%bcond_without crnlib # DDS support via crunch/crnlib
4537079d 29%bcond_without epsilon # EPSILON wavelet compression support
779b0eec 30%bcond_without fyba # SOSI geodata support using FYBA
0a5f35eb 31%bcond_with grass # GRASS support (note: dependency loop; use gdal-grass.spec instead)
4537079d 32%bcond_without gta # GTA format support
77dfc6fa 33%bcond_without kea # KEA format support
d3d190a4 34%bcond_without mysql # MySQL DB support
0316feee 35%bcond_with oci # ORACLE OCI DB and Georaster support
d3d190a4
JB
36%bcond_without odbc # ODBC DB support
37%bcond_without opencl # OpenCL (GPU) support
c9c08280 38%bcond_without openjpeg # OpenJPEG 2 (JPEG2000) support
4537079d
JB
39%bcond_with podofo # PDF support via podofo instead of poppler
40%bcond_without poppler # PDF support via poppler
16d32926 41%bcond_with rasdaman # Rasdaman support
45593023 42%bcond_with spatialite # SpatiaLite support
d3d190a4
JB
43%bcond_without xerces # Xerces support
44%bcond_without java # Java and MDB support
315a1c4a 45
fac7da6f
JB
46%if %{with podofo}
47%undefine with_poppler
48%endif
faf5649c 49Summary: Geospatial Data Abstraction Library
a28c1bee 50Summary(pl.UTF-8): Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
faf5649c 51Name: gdal
a707ba6a 52Version: 3.0.1
7c13b21a 53Release: 6
faf5649c
JB
54License: BSD-like
55Group: Libraries
a707ba6a
JR
56Source0: https://github.com/OSGeo/gdal/releases/download/v%{version}/%{name}-%{version}.tar.gz
57# Source0-md5: 2b397c041e6b0b10ec7c49fd76e9fa99
f5a12c65 58Patch0: %{name}-perl.patch
957f985a
JR
59Patch1: %{name}-pc.patch
60Patch2: %{name}-dds.patch
61Patch3: %{name}-rasdaman.patch
62Patch4: %{name}-pluginsdir.patch
63Patch5: libx32.patch
64Patch6: poppler-0.82.patch
99dd8e93 65Patch7: decl.patch
9b5c0fd4 66URL: http://www.gdal.org/
c64d9529
JB
67# 1.x or 2.x supported
68BuildRequires: CharLS-devel
d3d190a4
JB
69%{?with_opencl:BuildRequires: OpenCL-devel >= 1.0}
70%{?with_armadillo:BuildRequires: armadillo-devel}
69051332
JB
71BuildRequires: autoconf >= 2.52
72BuildRequires: automake
6b59fa88 73BuildRequires: cfitsio-devel
6a3158ac 74%{?with_crnlib:BuildRequires: crnlib-devel}
c64d9529 75BuildRequires: cryptopp-devel
9b4989ae 76BuildRequires: curl-devel
9d161bc4 77BuildRequires: doxygen >= 1.4.2
209aac6b 78%{?with_epsilon:BuildRequires: epsilon-compressor-devel}
69051332 79BuildRequires: expat-devel >= 1.95.0
779b0eec 80%{?with_fyba:BuildRequires: fyba-devel}
4537079d 81BuildRequires: freexl-devel >= 1.0
0316feee
JB
82BuildRequires: gcc >= 6:4.1
83BuildRequires: geos-devel >= 3.1.0
b459f4d7 84BuildRequires: giflib-devel >= 4.0
779b0eec 85%{?with_grass:BuildRequires: grass-devel >= 6.4}
c64d9529 86BuildRequires: hdf-devel >= 4.2.5
69051332 87BuildRequires: hdf5-devel
6b59fa88 88BuildRequires: jasper-devel
9b4989ae
JB
89%{?with_java:BuildRequires: jdk}
90%{?with_java:BuildRequires: jpackage-utils}
0316feee 91BuildRequires: json-c-devel >= 0.11
77dfc6fa 92%{?with_kea:BuildRequires: kealib-devel}
8fd908ab 93BuildRequires: libcsf-devel >= 2.0-0.041111.6
4058fbc3 94BuildRequires: libdap-devel >= 3.10
b3cbf6a3 95BuildRequires: libgeotiff-devel >= 1.2.1
b88bb9ef 96%{?with_gta:BuildRequires: libgta-devel}
6b59fa88 97BuildRequires: libjpeg-devel >= 6b
9b4989ae 98#BuildRequires: libkml-devel >= 1.3.0
e354fe40 99BuildRequires: libpng-devel >= 2:1.2.8
4537079d 100%{?with_spatialite:BuildRequires: libspatialite-devel}
b3cbf6a3 101BuildRequires: libstdc++-devel
954ec354 102BuildRequires: libtiff-devel >= 4.0
957f985a 103BuildRequires: libtirpc-devel
69051332 104BuildRequires: libtool
e2b089e1 105BuildRequires: libuuid-devel
9b4989ae 106BuildRequires: libwebp-devel
0316feee 107BuildRequires: libxml2-devel >= 2
c64d9529 108#%{?with_mysql:BuildRequires: mysql-devel >= 4}
952dc496 109%{?with_mysql:BuildRequires: /usr/bin/mysql_config}
80114ba8 110BuildRequires: netcdf-devel >= 4.1
6b59fa88 111BuildRequires: ogdi-devel >= 3.1
c64d9529 112%{?with_openjpeg:BuildRequires: openjpeg2-devel >= 2.1.0}
0316feee
JB
113# 8.1.7 for DB support, 10.0.1 for georaster
114%{?with_oci:BuildRequires: oracle-instantclient-devel >= 10.0.1}
954ec354 115#BuildRequires: pcidsk-devel > 0.3
c64d9529 116BuildRequires: pcre-devel
a0ffd9c4 117BuildRequires: perl-devel
c64d9529 118BuildRequires: pkgconfig >= 1:0.21
fac7da6f 119%{?with_podofo:BuildRequires: podofo-devel}
0077f857 120%{?with_poppler:BuildRequires: poppler-devel >= 0.24}
9b4989ae
JB
121# ensure it's compiled with PQescapeStringConn support
122BuildRequires: postgresql-backend-devel >= 8.1.4
123BuildRequires: postgresql-devel >= 8.1.4
124BuildRequires: proj-devel >= 4
9a2dbbce 125BuildRequires: python-devel >= 1:2.5
017b03bb 126BuildRequires: python-numpy-devel >= 1:1.0.0
9b4989ae 127BuildRequires: python-setuptools
c64d9529 128BuildRequires: qhull-devel >= 2012
779b0eec 129%{?with_rasdaman:BuildRequires: rasdaman-devel}
479cb83c 130BuildRequires: rpm-pythonprov
9b4989ae 131BuildRequires: rpmbuild(macros) >= 1.344
b88bb9ef 132BuildRequires: sed >= 4.0
9b4989ae 133BuildRequires: sqlite3-devel >= 3.0.0
479cb83c 134BuildRequires: swig-perl
9a2dbbce 135BuildRequires: swig-python >= 1.3
479cb83c 136BuildRequires: texlive-dvips
137BuildRequires: texlive-latex
9831286f 138%{?with_odbc:BuildRequires: unixODBC-devel >= 2.2.15}
c64d9529 139%{?with_xerces:BuildRequires: xerces-c-devel >= 3.1.0}
9b4989ae 140BuildRequires: xz-devel
faf5649c 141BuildRequires: zlib-devel >= 1.1.4
c64d9529
JB
142# for ZSTD compression in TIFF
143BuildRequires: zstd-devel
4537079d 144Requires: freexl >= 1.0
0316feee 145Requires: geos >= 3.1.0
c64d9529 146Requires: hdf >= 4.2.5
b3cbf6a3 147Requires: libgeotiff >= 1.2.1
e354fe40 148Requires: libpng >= 2:1.2.8
954ec354 149Requires: libtiff >= 4.0
c64d9529
JB
150%{?with_openjpeg:Requires: openjpeg2 >= 2.1.0}
151Requires: qhull >= 2012
152%{?with_xerces:Requires: xerces-c >= 3.1.0}
faf5649c
JB
153BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
154
155%description
156GDAL is a translator library for raster geospatial data formats that
157is released under an Open Source license. As a library, it presents a
158single abstract data model to the calling application for all
159supported formats. The related OGR library (which lives within the
160GDAL source tree) provides a similar capability for simple features
161vector data.
f05c79e8 162
d34f2ec8
JR
163%description -l pl.UTF-8
164GDAL to biblioteka konwertująca między formatami rastrowych danych
165dotyczących powierzchni Ziemi, udostępniona na licencji Open Source.
166Jako biblioteka udostępnia aplikacjom jeden abstrakcyjny model danych
167do wszystkich obsługiwanych formatów. Powiązana z nią biblioteka OGR
168(której źródła są dołączone do drzewa źródeł GDAL) daje podobne
169możliwości dla danych wektorowych.
faf5649c 170
6b59fa88
JB
171%package devel
172Summary: GDAL library header files
a28c1bee 173Summary(pl.UTF-8): Pliki nagłówkowe biblioteki GDAL
6b59fa88 174Group: Development/Libraries
1673a634 175Requires: %{name} = %{version}-%{release}
c64d9529 176Requires: CharLS-devel
d3d190a4
JB
177%{?with_opencl:Requires: OpenCL-devel >= 1.0}
178%{?with_armadillo:Requires: armadillo-devel}
b3cbf6a3 179Requires: cfitsio-devel
6a3158ac 180%{?with_crnlib:Requires: crnlib-devel}
c64d9529 181Requires: cryptopp-devel
209aac6b
JB
182Requires: curl-devel
183%{?with_epsilon:Requires: epsilon-compressor-devel}
779b0eec 184%{?with_fyba:Requires: fyba-devel}
69051332 185Requires: expat-devel >= 1.95.0
4537079d 186Requires: freexl-devel >= 1.0
0316feee 187Requires: geos-devel >= 3.1.0
209aac6b 188Requires: giflib-devel >= 4.0
c64d9529 189Requires: hdf-devel >= 4.2.5
69051332 190Requires: hdf5-devel
b3cbf6a3 191Requires: jasper-devel
0316feee 192Requires: json-c-devel >= 0.11
77dfc6fa 193%{?with_kea:Requires: kealib-devel}
d4d7a2c6 194Requires: libcsf-devel
4058fbc3 195Requires: libdap-devel >= 3.10
b3cbf6a3 196Requires: libgeotiff-devel >= 1.2.1
209aac6b
JB
197%{?with_gta:Requires: libgta-devel}
198Requires: libjpeg-devel >= 6b
e354fe40 199Requires: libpng-devel >= 2:1.2.8
4537079d 200%{?with_spatialite:Requires: libspatialite-devel}
b3cbf6a3 201Requires: libstdc++-devel
954ec354 202Requires: libtiff-devel >= 4.0
209aac6b
JB
203Requires: libuuid-devel
204Requires: libwebp-devel
0316feee 205Requires: libxml2-devel >= 2
952dc496 206%{?with_mysql:Requires: /usr/bin/mysql_config}
9b4989ae 207Requires: netcdf-devel >= 4
b3cbf6a3 208Requires: ogdi-devel >= 3.1
c64d9529 209%{?with_openjpeg:Requires: openjpeg2-devel >= 2.1.0}
954ec354 210#Requires: pcidsk-devel > 0.3
c64d9529 211Requires: pcre-devel
209aac6b 212%{?with_podofo:Requires: podofo-devel}
0077f857 213%{?with_poppler:Requires: poppler-devel >= 0.24}
b3cbf6a3 214Requires: postgresql-devel
209aac6b 215Requires: proj-devel >= 4
c64d9529 216Requires: qhull-devel >= 2012
779b0eec 217%{?with_rasdaman:Requires: rasdaman-devel}
9b4989ae 218Requires: sqlite3-devel >= 3.0.0
655672e5 219%{?with_odbc:Requires: unixODBC-devel}
c64d9529 220%{?with_xerces:Requires: xerces-c-devel >= 3.1.0}
209aac6b
JB
221Requires: xz-devel
222Requires: zlib-devel >= 1.1.4
c64d9529 223Requires: zstd-devel
6b59fa88
JB
224
225%description devel
226GDAL library header files.
227
d34f2ec8
JR
228%description devel -l pl.UTF-8
229Pliki nagłówkowe biblioteki GDAL.
6b59fa88
JB
230
231%package static
232Summary: GDAL static libraries
a28c1bee 233Summary(pl.UTF-8): Statyczne biblioteki GDAL
6b59fa88 234Group: Development/Libraries
1673a634 235Requires: %{name}-devel = %{version}-%{release}
6b59fa88
JB
236
237%description static
238GDAL static libraries.
239
d34f2ec8 240%description static -l pl.UTF-8
6b59fa88
JB
241Statyczne biblioteki GDAL.
242
a0ffd9c4
JB
243%package -n perl-gdal
244Summary: Perl bindings for GDAL
245Summary(pl.UTF-8): Wiązania Perla do pakietu GDAL
246Group: Development/Languages/Perl
247Requires: %{name} = %{version}-%{release}
248
249%description -n perl-gdal
250Perl bindings for GDAL - Geo::GDAL, Geo::OGR and Geo::OSR modules.
251
252%description -n perl-gdal -l pl.UTF-8
017b03bb 253Wiązania Perla do pakietu GDAL - moduły Geo::GDAL, Geo::OGR, Geo::OSR.
a0ffd9c4 254
6b59fa88
JB
255%package -n python-gdal
256Summary: GDAL Python module
a28c1bee 257Summary(pl.UTF-8): Moduł Pythona GDAL
6b59fa88 258Group: Libraries/Python
1673a634 259Requires: %{name} = %{version}-%{release}
315a1c4a 260Requires: python-libs
6b59fa88
JB
261
262%description -n python-gdal
263GDAL Python module.
264
d34f2ec8
JR
265%description -n python-gdal -l pl.UTF-8
266Moduł Pythona GDAL.
6b59fa88 267
faf5649c
JB
268%prep
269%setup -q
270%patch0 -p1
957f985a 271%patch1 -p1
f1b5abea 272%patch2 -p1
957f985a
JR
273%patch3 -p1
274%patch4 -p1
275%patch5 -p1
f905262c 276%patch6 -p2
99dd8e93 277%patch7 -p1
0316feee 278
c64d9529
JB
279# need to regenerate (old ones don't support perl 5.10)
280%{__rm} swig/perl/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
315a1c4a 281
f4952e6f 282# our man path
be8ee7be 283sed -i -e 's#^mandir=.*##g' configure.ac
f4952e6f 284
4058fbc3 285%{__rm} -r man
4ed54fac 286
be8ee7be 287%{__sed} -i -e 's,DODS_INC="-I.*,DODS_INC="$(pkg-config --cflags libdap)",' configure.ac
b88bb9ef 288
7c13b21a
JR
289sed -E -i -e '1s,#!\s*/usr/bin/env\s+python2(\s|$),#!%{__python}\1,' \
290 -e '1s,#!\s*/usr/bin/env\s+python(\s|$),#!%{__python}\1,' \
291 -e '1s,#!\s*/usr/bin/python(\s|$),#!%{__python}\1,' \
292 swig/python/scripts/epsg_tr.py \
293 swig/python/scripts/esri2wkt.py \
294 swig/python/scripts/gcps2vec.py \
295 swig/python/scripts/gcps2wld.py \
296 swig/python/scripts/gdal2tiles.py \
297 swig/python/scripts/gdal2xyz.py \
298 swig/python/scripts/gdal_auth.py \
299 swig/python/scripts/gdal_calc.py \
300 swig/python/scripts/gdal_edit.py \
301 swig/python/scripts/gdal_fillnodata.py \
302 swig/python/scripts/gdal_merge.py \
303 swig/python/scripts/gdal_pansharpen.py \
304 swig/python/scripts/gdal_polygonize.py \
305 swig/python/scripts/gdal_proximity.py \
306 swig/python/scripts/gdal_retile.py \
307 swig/python/scripts/gdal_sieve.py \
308 swig/python/scripts/gdalchksum.py \
309 swig/python/scripts/gdalcompare.py \
310 swig/python/scripts/gdalident.py \
311 swig/python/scripts/gdalimport.py \
312 swig/python/scripts/gdalmove.py \
313 swig/python/scripts/mkgraticule.py \
314 swig/python/scripts/ogrmerge.py \
315 swig/python/scripts/pct2rgb.py \
316 swig/python/scripts/rgb2pct.py
317
faf5649c 318%build
e6e33a1a
JR
319%ifarch %{x8664}
320jvm_arch=amd64
321%endif
322%ifarch %{ix86}
323jvm_arch=i386
324%endif
325%ifarch x32
326jvm_arch=x32
327%endif
328
69051332 329%{__libtoolize}
69051332 330%{__aclocal} -I m4
faf5649c 331%{__autoconf}
0a5f35eb 332%{__autoheader}
6b59fa88 333%configure \
e582c3b1 334 --includedir=%{_includedir}/gdal \
5014b82a 335 --datadir=%{_datadir}/gdal \
d4d7a2c6 336 --with-dods-root=/usr \
d3d190a4 337 %{?with_armadillo:--with-armadillo} \
6f52dc7d 338 %{?with_crnlib:--with-dds} \
209aac6b 339 %{?with_epsilon:--with-epsilon} \
0316feee 340 %{?with_grass:--with-grass} \
b88bb9ef 341 %{!?with_gta:--without-gta} \
69051332 342 --with-hide-internal-symbols \
9b4989ae
JB
343 %{?with_java:--with-java=%{java_home}} \
344 --with-liblzma \
77dfc6fa 345 %{!?with_kea:--without-kea} \
fffcf251 346 %{?with_java:--with-mdb --with-jvm-lib-add-rpath --with-jvm-lib=%{java_home}/jre/lib/$jvm_arch/server} \
d3d190a4 347 %{?with_mysql:--with-mysql} \
0316feee 348 %{?with_oci:--with-oci --with-oci-include=/usr/include/oracle/client --with-oci-lib=%{_libdir}} \
d3d190a4 349 %{?with_opencl:--with-opencl} \
a0ffd9c4 350 --with-perl \
fac7da6f
JB
351 %{?with_podofo:--with-podofo} \
352 %{?with_poppler:--with-poppler} \
69051332 353 --with-python \
779b0eec 354 %{?with_rasdaman:--with-rasdaman=%{_libdir}/rasdaman} \
779b0eec 355 %{?with_fyba:--with-sosi} \
4537079d 356 %{?with_spatialite:--with-spatialite} \
69051332 357 --with-sqlite3 \
9b4989ae 358 --with-webp \
655672e5 359 %{?with_xerces:--with-xerces} \
c64d9529 360 --with-xerces-inc=/usr/include \
80faacbe 361 --with-xerces-lib="-lxerces-c" \
69051332 362 --without-libgrass
954ec354 363# --with-pcidsk=/usr (needs > 0.3)
779b0eec 364# csharp builds, but has no configure option nor install target
faf5649c 365
69051332 366# regenerate where needed
825dc3dc 367%{__make} -j1 -C swig/perl generate
69051332 368
45593023 369%{__make} \
779b0eec
JB
370 %{?with_grass:GRASS_INCLUDE="-I/usr/include/grass64"} \
371 %{?with_fyba:SOSI_INC="-I/usr/include/fyba"}
a0ffd9c4 372
825dc3dc 373%{__make} -j1 docs
3a591acf 374
f5a12c65
JK
375%{__make} -j1 man
376
faf5649c
JB
377%install
378rm -rf $RPM_BUILD_ROOT
faf5649c 379
825dc3dc 380%{__make} -j1 install install-man \
3a591acf
JB
381 DESTDIR=$RPM_BUILD_ROOT
382
c64d9529
JB
383# TODO: remove libgdal.la when gdal.pc gets maintained Requires.private/Libs.private list
384
388b39cb
ER
385rm -rf _html
386cp -a html _html
faf5649c 387
374370d5
JB
388%py_comp $RPM_BUILD_ROOT%{py_sitedir}
389%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
390%py_postclean
5014b82a 391
017b03bb
ER
392%{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
393%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/.packlist
394%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/Const/.packlist
395%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OGR/.packlist
396%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OSR/.packlist
397
faf5649c
JB
398%clean
399rm -rf $RPM_BUILD_ROOT
400
6b59fa88
JB
401%post -p /sbin/ldconfig
402%postun -p /sbin/ldconfig
403
faf5649c
JB
404%files
405%defattr(644,root,root,755)
c0a384ef 406%doc NEWS PROVENANCE.TXT
4058fbc3
JB
407%attr(755,root,root) %{_bindir}/epsg_tr.py
408%attr(755,root,root) %{_bindir}/esri2wkt.py
409%attr(755,root,root) %{_bindir}/gcps2vec.py
410%attr(755,root,root) %{_bindir}/gcps2wld.py
411%attr(755,root,root) %{_bindir}/gdal2tiles.py
412%attr(755,root,root) %{_bindir}/gdal2xyz.py
4058fbc3 413%attr(755,root,root) %{_bindir}/gdaladdo
6f52dc7d 414%attr(755,root,root) %{_bindir}/gdal_auth.py
4058fbc3 415%attr(755,root,root) %{_bindir}/gdalbuildvrt
6f52dc7d 416%attr(755,root,root) %{_bindir}/gdal_calc.py
4058fbc3 417%attr(755,root,root) %{_bindir}/gdalchksum.py
0316feee 418%attr(755,root,root) %{_bindir}/gdalcompare.py
6f52dc7d 419%attr(755,root,root) %{_bindir}/gdal_contour
4058fbc3 420%attr(755,root,root) %{_bindir}/gdaldem
6f52dc7d 421%attr(755,root,root) %{_bindir}/gdal_edit.py
4058fbc3 422%attr(755,root,root) %{_bindir}/gdalenhance
6f52dc7d
JR
423%attr(755,root,root) %{_bindir}/gdal_fillnodata.py
424%attr(755,root,root) %{_bindir}/gdal_grid
4058fbc3
JB
425%attr(755,root,root) %{_bindir}/gdalident.py
426%attr(755,root,root) %{_bindir}/gdalimport.py
427%attr(755,root,root) %{_bindir}/gdalinfo
954ec354 428%attr(755,root,root) %{_bindir}/gdallocationinfo
4058fbc3 429%attr(755,root,root) %{_bindir}/gdalmanage
6f52dc7d 430%attr(755,root,root) %{_bindir}/gdal_merge.py
f4952e6f 431%attr(755,root,root) %{_bindir}/gdalmove.py
6f52dc7d
JR
432%attr(755,root,root) %{_bindir}/gdal_pansharpen.py
433%attr(755,root,root) %{_bindir}/gdal_polygonize.py
434%attr(755,root,root) %{_bindir}/gdal_proximity.py
435%attr(755,root,root) %{_bindir}/gdal_rasterize
436%attr(755,root,root) %{_bindir}/gdal_retile.py
f4952e6f 437%attr(755,root,root) %{_bindir}/gdalserver
6f52dc7d 438%attr(755,root,root) %{_bindir}/gdal_sieve.py
9b4989ae 439%attr(755,root,root) %{_bindir}/gdalsrsinfo
4058fbc3
JB
440%attr(755,root,root) %{_bindir}/gdaltindex
441%attr(755,root,root) %{_bindir}/gdaltransform
6f52dc7d 442%attr(755,root,root) %{_bindir}/gdal_translate
4058fbc3 443%attr(755,root,root) %{_bindir}/gdalwarp
6f52dc7d
JR
444%attr(755,root,root) %{_bindir}/gnmanalyse
445%attr(755,root,root) %{_bindir}/gnmmanage
4058fbc3
JB
446%attr(755,root,root) %{_bindir}/mkgraticule.py
447%attr(755,root,root) %{_bindir}/nearblack
448%attr(755,root,root) %{_bindir}/ogr2ogr
449%attr(755,root,root) %{_bindir}/ogrinfo
0316feee 450%attr(755,root,root) %{_bindir}/ogrlineref
6f52dc7d 451%attr(755,root,root) %{_bindir}/ogrmerge.py
4058fbc3
JB
452%attr(755,root,root) %{_bindir}/ogrtindex
453%attr(755,root,root) %{_bindir}/pct2rgb.py
454%attr(755,root,root) %{_bindir}/rgb2pct.py
455%attr(755,root,root) %{_bindir}/testepsg
5014b82a 456%attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
a707ba6a 457%attr(755,root,root) %ghost %{_libdir}/libgdal.so.26
0a5f35eb 458%dir %{_libdir}/gdalplugins
6b59fa88 459%{_datadir}/gdal
4058fbc3 460%{_mandir}/man1/gdal2tiles.1*
0316feee 461%{_mandir}/man1/gdal_calc.1*
4058fbc3 462%{_mandir}/man1/gdal_contour.1*
f4952e6f 463%{_mandir}/man1/gdal_edit.1*
4058fbc3
JB
464%{_mandir}/man1/gdal_fillnodata.1*
465%{_mandir}/man1/gdal_grid.1*
466%{_mandir}/man1/gdal_merge.1*
f4952e6f
AM
467%{_mandir}/man1/gdal_polygonize.1*
468%{_mandir}/man1/gdal_proximity.1*
4058fbc3
JB
469%{_mandir}/man1/gdal_rasterize.1*
470%{_mandir}/man1/gdal_retile.1*
471%{_mandir}/man1/gdal_sieve.1*
472%{_mandir}/man1/gdal_translate.1*
473%{_mandir}/man1/gdal_utilities.1*
474%{_mandir}/man1/gdaladdo.1*
475%{_mandir}/man1/gdalbuildvrt.1*
0316feee 476%{_mandir}/man1/gdalcompare.1*
4058fbc3
JB
477%{_mandir}/man1/gdaldem.1*
478%{_mandir}/man1/gdalinfo.1*
954ec354 479%{_mandir}/man1/gdallocationinfo.1*
f4952e6f
AM
480%{_mandir}/man1/gdalmanage.1*
481%{_mandir}/man1/gdalmove.1*
9b4989ae 482%{_mandir}/man1/gdalsrsinfo.1*
4058fbc3
JB
483%{_mandir}/man1/gdaltindex.1*
484%{_mandir}/man1/gdaltransform.1*
485%{_mandir}/man1/gdalwarp.1*
486%{_mandir}/man1/nearblack.1*
487%{_mandir}/man1/ogr2ogr.1*
488%{_mandir}/man1/ogr_utilities.1*
489%{_mandir}/man1/ogrinfo.1*
0316feee 490%{_mandir}/man1/ogrlineref.1*
4058fbc3
JB
491%{_mandir}/man1/ogrtindex.1*
492%{_mandir}/man1/pct2rgb.1*
493%{_mandir}/man1/rgb2pct.1*
6f52dc7d
JR
494%{_mandir}/man1/gdal_pansharpen.1*
495%{_mandir}/man1/gnm_utilities.1*
496%{_mandir}/man1/gnmanalyse.1*
497%{_mandir}/man1/gnmmanage.1*
498%{_mandir}/man1/ogrmerge.1*
6b59fa88
JB
499
500%files devel
501%defattr(644,root,root,755)
388b39cb 502%doc _html/*
5014b82a 503%attr(755,root,root) %{_bindir}/gdal-config
6b59fa88 504%attr(755,root,root) %{_libdir}/libgdal.so
5014b82a 505%{_libdir}/libgdal.la
0316feee 506%{_pkgconfigdir}/gdal.pc
e582c3b1 507%{_includedir}/gdal
5014b82a 508%{_mandir}/man1/gdal-config.1*
6b59fa88
JB
509
510%files static
511%defattr(644,root,root,755)
9b5c0fd4 512%{_libdir}/libgdal.a
6b59fa88 513
a0ffd9c4
JB
514%files -n perl-gdal
515%defattr(644,root,root,755)
516%dir %{perl_vendorarch}/Geo
517%{perl_vendorarch}/Geo/GDAL.pm
518%dir %{perl_vendorarch}/Geo/GDAL
519%{perl_vendorarch}/Geo/GDAL/Const.pm
520%{perl_vendorarch}/Geo/OGR.pm
521%{perl_vendorarch}/Geo/OSR.pm
522%dir %{perl_vendorarch}/auto/Geo
523%dir %{perl_vendorarch}/auto/Geo/GDAL
a0ffd9c4
JB
524%attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/GDAL.so
525%dir %{perl_vendorarch}/auto/Geo/GDAL/Const
a0ffd9c4 526%attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.so
6f52dc7d
JR
527%dir %{perl_vendorarch}/auto/Geo/GNM
528%attr(755,root,root) %{perl_vendorarch}/auto/Geo/GNM/GNM.so
a0ffd9c4 529%dir %{perl_vendorarch}/auto/Geo/OGR
a0ffd9c4
JB
530%attr(755,root,root) %{perl_vendorarch}/auto/Geo/OGR/OGR.so
531%dir %{perl_vendorarch}/auto/Geo/OSR
a0ffd9c4 532%attr(755,root,root) %{perl_vendorarch}/auto/Geo/OSR/OSR.so
38239d5e 533%{_mandir}/man3/Geo::GDAL.3pm*
6f52dc7d 534%{perl_vendorarch}/Geo/GNM.pm
a0ffd9c4 535
6b59fa88
JB
536%files -n python-gdal
537%defattr(644,root,root,755)
9a2dbbce
JB
538%{py_sitedir}/gdal.py[co]
539%{py_sitedir}/gdalconst.py[co]
540%{py_sitedir}/gdalnumeric.py[co]
9a2dbbce
JB
541%{py_sitedir}/ogr.py[co]
542%{py_sitedir}/osr.py[co]
69051332
JB
543%{py_sitedir}/GDAL-*.egg-info
544%dir %{py_sitedir}/osgeo
545%attr(755,root,root) %{py_sitedir}/osgeo/_gdal.so
546%attr(755,root,root) %{py_sitedir}/osgeo/_gdal_array.so
547%attr(755,root,root) %{py_sitedir}/osgeo/_gdalconst.so
6f52dc7d 548%attr(755,root,root) %{py_sitedir}/osgeo/_gnm.so
69051332
JB
549%attr(755,root,root) %{py_sitedir}/osgeo/_ogr.so
550%attr(755,root,root) %{py_sitedir}/osgeo/_osr.so
551%{py_sitedir}/osgeo/*.py[co]
This page took 0.143281 seconds and 4 git commands to generate.