]> git.pld-linux.org Git - packages/gdal.git/blame - gdal.spec
- rebuild with poppler 0.65.0
[packages/gdal.git] / gdal.spec
CommitLineData
954ec354 1# TODO:
8b360036 2# - be reasonable about devel dependencies - you do not need all of them to
cfcb08ee 3# use gdal (probably a gdal module or driver shall not imply devel
4# dependency)
d3d190a4 5# - libjpeg12 (needs patching to use system one, --with-jpeg12 is not sufficient as of 1.9.2)
9b4989ae 6# - libkml (1.3.0 needed, not released yet)
954ec354 7# - wait for newer pcidsk, switch to external again
d3d190a4 8# - csharp, java
9b4989ae
JB
9# - additional, proprietary(?) formats support:
10# - FMEObjects (http://www.safe.com/support/support-resources/fme-downloads/)
11# - ESRI FileGDBAPI (http://resources.arcgis.com/content/geodatabases/10.0/file-gdb-api)
12# - ECW (http://www.erdas.com/products/ecw/ERDASECWJPEG2000SDK/Details.aspx)
13# - Kakadu/JPEG2000 (http://www.kakadusoftware.com/)
14# - MrSID (http://www.lizardtech.com/developer/)
15# - MSG/EUMETSAT (http://www.eumetsat.int/Home/Main/DataAccess/SupportSoftwareTools/index.htm)
9b4989ae 16# - Ingres (--with-ingres=/path)
0316feee 17# - Informix DB (--with-idb)
9b4989ae
JB
18# - DWGdirect (members only? http://www.opendwg.org/)
19# - ESRI SDE (http://www.esri.com/software/arcgis/arcsde/index.html)
655672e5 20#
21# Conditional build:
d3d190a4 22%bcond_without armadillo # Armadillo support for faster TPS transform
779b0eec 23%bcond_without crnlib # DDS support via crunch/crnlib
4537079d 24%bcond_without epsilon # EPSILON wavelet compression support
779b0eec 25%bcond_without fyba # SOSI geodata support using FYBA
0a5f35eb 26%bcond_with grass # GRASS support (note: dependency loop; use gdal-grass.spec instead)
4537079d 27%bcond_without gta # GTA format support
77dfc6fa 28%bcond_without kea # KEA format support
d3d190a4 29%bcond_without mysql # MySQL DB support
0316feee 30%bcond_with oci # ORACLE OCI DB and Georaster support
d3d190a4
JB
31%bcond_without odbc # ODBC DB support
32%bcond_without opencl # OpenCL (GPU) support
c9c08280 33%bcond_without openjpeg # OpenJPEG 2 (JPEG2000) support
4537079d
JB
34%bcond_with podofo # PDF support via podofo instead of poppler
35%bcond_without poppler # PDF support via poppler
779b0eec 36%bcond_without rasdaman # Rasdaman support
4537079d 37%bcond_without spatialite # SpatiaLite support
d3d190a4
JB
38%bcond_without xerces # Xerces support
39%bcond_without java # Java and MDB support
47ddf890 40%bcond_with php # PHP binding [PHP 7 not supported by swig 3.0.x]
77dfc6fa 41%bcond_with ruby # Ruby binding [not available as of 2.0.2]
315a1c4a 42
fac7da6f
JB
43%if %{with podofo}
44%undefine with_poppler
45%endif
66daf0b1 46%if 0%{!?php_name:1}
ead243f9 47%define php_name php55
66daf0b1 48%endif
faf5649c 49Summary: Geospatial Data Abstraction Library
a28c1bee 50Summary(pl.UTF-8): Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
faf5649c 51Name: gdal
be8ee7be 52Version: 2.2.4
2fc87fc9 53Release: 3
faf5649c
JB
54License: BSD-like
55Group: Libraries
84501866 56Source0: http://download.osgeo.org/gdal/%{version}/%{name}-%{version}.tar.xz
be8ee7be 57# Source0-md5: 51b1df61dbdf81473689fab3075e7a5e
f5a12c65 58Patch0: %{name}-perl.patch
ee43bca4 59Patch1: %{name}-poppler.patch
f1b5abea
JB
60Patch2: %{name}-php.patch
61Patch3: %{name}-fpic.patch
779b0eec 62Patch9: %{name}-dds.patch
779b0eec 63Patch11: %{name}-armadillo.patch
ce035715 64Patch12: %{name}-rasdaman.patch
0a5f35eb 65Patch13: %{name}-pluginsdir.patch
f9aa527b 66Patch15: libx32.patch
9b5c0fd4 67URL: http://www.gdal.org/
ead243f9 68%{?with_php:BuildRequires: %{php_name}-devel}
d3d190a4
JB
69%{?with_opencl:BuildRequires: OpenCL-devel >= 1.0}
70%{?with_armadillo:BuildRequires: armadillo-devel}
69051332
JB
71BuildRequires: autoconf >= 2.52
72BuildRequires: automake
6b59fa88 73BuildRequires: cfitsio-devel
6a3158ac 74%{?with_crnlib:BuildRequires: crnlib-devel}
9b4989ae 75BuildRequires: curl-devel
9d161bc4 76BuildRequires: doxygen >= 1.4.2
209aac6b 77%{?with_epsilon:BuildRequires: epsilon-compressor-devel}
69051332 78BuildRequires: expat-devel >= 1.95.0
779b0eec 79%{?with_fyba:BuildRequires: fyba-devel}
4537079d 80BuildRequires: freexl-devel >= 1.0
0316feee
JB
81BuildRequires: gcc >= 6:4.1
82BuildRequires: geos-devel >= 3.1.0
b459f4d7 83BuildRequires: giflib-devel >= 4.0
779b0eec 84%{?with_grass:BuildRequires: grass-devel >= 6.4}
6b59fa88 85BuildRequires: hdf-devel >= 4.0
69051332 86BuildRequires: hdf5-devel
6b59fa88 87BuildRequires: jasper-devel
9b4989ae
JB
88%{?with_java:BuildRequires: jdk}
89%{?with_java:BuildRequires: jpackage-utils}
0316feee 90BuildRequires: json-c-devel >= 0.11
77dfc6fa 91%{?with_kea:BuildRequires: kealib-devel}
8fd908ab 92BuildRequires: libcsf-devel >= 2.0-0.041111.6
4058fbc3 93BuildRequires: libdap-devel >= 3.10
b3cbf6a3 94BuildRequires: libgeotiff-devel >= 1.2.1
b88bb9ef 95%{?with_gta:BuildRequires: libgta-devel}
6b59fa88 96BuildRequires: libjpeg-devel >= 6b
9b4989ae 97#BuildRequires: libkml-devel >= 1.3.0
e354fe40 98BuildRequires: libpng-devel >= 2:1.2.8
4537079d 99%{?with_spatialite:BuildRequires: libspatialite-devel}
b3cbf6a3 100BuildRequires: libstdc++-devel
954ec354 101BuildRequires: libtiff-devel >= 4.0
69051332 102BuildRequires: libtool
e2b089e1 103BuildRequires: libuuid-devel
9b4989ae 104BuildRequires: libwebp-devel
0316feee 105BuildRequires: libxml2-devel >= 2
952dc496 106%{?with_mysql:BuildRequires: /usr/bin/mysql_config}
80114ba8 107BuildRequires: netcdf-devel >= 4.1
6b59fa88 108BuildRequires: ogdi-devel >= 3.1
c9c08280 109%{?with_openjpeg:BuildRequires: openjpeg2-devel >= 2.0.0-2}
0316feee
JB
110# 8.1.7 for DB support, 10.0.1 for georaster
111%{?with_oci:BuildRequires: oracle-instantclient-devel >= 10.0.1}
954ec354 112#BuildRequires: pcidsk-devel > 0.3
a0ffd9c4 113BuildRequires: perl-devel
fac7da6f 114%{?with_podofo:BuildRequires: podofo-devel}
0077f857 115%{?with_poppler:BuildRequires: poppler-devel >= 0.24}
9b4989ae
JB
116# ensure it's compiled with PQescapeStringConn support
117BuildRequires: postgresql-backend-devel >= 8.1.4
118BuildRequires: postgresql-devel >= 8.1.4
119BuildRequires: proj-devel >= 4
9a2dbbce 120BuildRequires: python-devel >= 1:2.5
017b03bb 121BuildRequires: python-numpy-devel >= 1:1.0.0
9b4989ae 122BuildRequires: python-setuptools
779b0eec 123%{?with_rasdaman:BuildRequires: rasdaman-devel}
479cb83c 124BuildRequires: rpm-pythonprov
315a1c4a 125%{?with_ruby:BuildRequires: rpm-rubyprov}
9b4989ae 126BuildRequires: rpmbuild(macros) >= 1.344
4aafe7c0 127%{?with_ruby:BuildRequires: ruby-devel}
b88bb9ef 128BuildRequires: sed >= 4.0
9b4989ae 129BuildRequires: sqlite3-devel >= 3.0.0
479cb83c 130BuildRequires: swig-perl
0316feee 131BuildRequires: swig-php >= 2.0.12-2
9a2dbbce 132BuildRequires: swig-python >= 1.3
017b03bb 133%{?with_ruby:BuildRequires: swig-ruby}
479cb83c 134BuildRequires: texlive-dvips
135BuildRequires: texlive-latex
9831286f 136%{?with_odbc:BuildRequires: unixODBC-devel >= 2.2.15}
9b4989ae
JB
137%{?with_xerces:BuildRequires: xerces-c-devel >= 2.7.0}
138BuildRequires: xz-devel
faf5649c 139BuildRequires: zlib-devel >= 1.1.4
4537079d 140Requires: freexl >= 1.0
0316feee 141Requires: geos >= 3.1.0
b3cbf6a3 142Requires: libgeotiff >= 1.2.1
e354fe40 143Requires: libpng >= 2:1.2.8
954ec354 144Requires: libtiff >= 4.0
faf5649c
JB
145BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
146
147%description
148GDAL is a translator library for raster geospatial data formats that
149is released under an Open Source license. As a library, it presents a
150single abstract data model to the calling application for all
151supported formats. The related OGR library (which lives within the
152GDAL source tree) provides a similar capability for simple features
153vector data.
f05c79e8 154
d34f2ec8
JR
155%description -l pl.UTF-8
156GDAL to biblioteka konwertująca między formatami rastrowych danych
157dotyczących powierzchni Ziemi, udostępniona na licencji Open Source.
158Jako biblioteka udostępnia aplikacjom jeden abstrakcyjny model danych
159do wszystkich obsługiwanych formatów. Powiązana z nią biblioteka OGR
160(której źródła są dołączone do drzewa źródeł GDAL) daje podobne
161możliwości dla danych wektorowych.
faf5649c 162
6b59fa88
JB
163%package devel
164Summary: GDAL library header files
a28c1bee 165Summary(pl.UTF-8): Pliki nagłówkowe biblioteki GDAL
6b59fa88 166Group: Development/Libraries
1673a634 167Requires: %{name} = %{version}-%{release}
d3d190a4
JB
168%{?with_opencl:Requires: OpenCL-devel >= 1.0}
169%{?with_armadillo:Requires: armadillo-devel}
b3cbf6a3 170Requires: cfitsio-devel
6a3158ac 171%{?with_crnlib:Requires: crnlib-devel}
209aac6b
JB
172Requires: curl-devel
173%{?with_epsilon:Requires: epsilon-compressor-devel}
779b0eec 174%{?with_fyba:Requires: fyba-devel}
69051332 175Requires: expat-devel >= 1.95.0
4537079d 176Requires: freexl-devel >= 1.0
0316feee 177Requires: geos-devel >= 3.1.0
209aac6b 178Requires: giflib-devel >= 4.0
b3cbf6a3 179Requires: hdf-devel >= 4.0
69051332 180Requires: hdf5-devel
b3cbf6a3 181Requires: jasper-devel
0316feee 182Requires: json-c-devel >= 0.11
77dfc6fa 183%{?with_kea:Requires: kealib-devel}
d4d7a2c6 184Requires: libcsf-devel
4058fbc3 185Requires: libdap-devel >= 3.10
b3cbf6a3 186Requires: libgeotiff-devel >= 1.2.1
209aac6b
JB
187%{?with_gta:Requires: libgta-devel}
188Requires: libjpeg-devel >= 6b
e354fe40 189Requires: libpng-devel >= 2:1.2.8
4537079d 190%{?with_spatialite:Requires: libspatialite-devel}
b3cbf6a3 191Requires: libstdc++-devel
954ec354 192Requires: libtiff-devel >= 4.0
209aac6b
JB
193Requires: libuuid-devel
194Requires: libwebp-devel
0316feee 195Requires: libxml2-devel >= 2
952dc496 196%{?with_mysql:Requires: /usr/bin/mysql_config}
9b4989ae 197Requires: netcdf-devel >= 4
b3cbf6a3 198Requires: ogdi-devel >= 3.1
c9c08280 199%{?with_openjpeg:Requires: openjpeg2-devel >= 2.0.0-2}
954ec354 200#Requires: pcidsk-devel > 0.3
209aac6b 201%{?with_podofo:Requires: podofo-devel}
0077f857 202%{?with_poppler:Requires: poppler-devel >= 0.24}
b3cbf6a3 203Requires: postgresql-devel
209aac6b 204Requires: proj-devel >= 4
779b0eec 205%{?with_rasdaman:Requires: rasdaman-devel}
9b4989ae 206Requires: sqlite3-devel >= 3.0.0
655672e5 207%{?with_odbc:Requires: unixODBC-devel}
69051332 208%{?with_xerces:Requires: xerces-c-devel >= 2.7.0}
209aac6b
JB
209Requires: xz-devel
210Requires: zlib-devel >= 1.1.4
6b59fa88
JB
211
212%description devel
213GDAL library header files.
214
d34f2ec8
JR
215%description devel -l pl.UTF-8
216Pliki nagłówkowe biblioteki GDAL.
6b59fa88
JB
217
218%package static
219Summary: GDAL static libraries
a28c1bee 220Summary(pl.UTF-8): Statyczne biblioteki GDAL
6b59fa88 221Group: Development/Libraries
1673a634 222Requires: %{name}-devel = %{version}-%{release}
6b59fa88
JB
223
224%description static
225GDAL static libraries.
226
d34f2ec8 227%description static -l pl.UTF-8
6b59fa88
JB
228Statyczne biblioteki GDAL.
229
a0ffd9c4
JB
230%package -n perl-gdal
231Summary: Perl bindings for GDAL
232Summary(pl.UTF-8): Wiązania Perla do pakietu GDAL
233Group: Development/Languages/Perl
234Requires: %{name} = %{version}-%{release}
235
236%description -n perl-gdal
237Perl bindings for GDAL - Geo::GDAL, Geo::OGR and Geo::OSR modules.
238
239%description -n perl-gdal -l pl.UTF-8
017b03bb 240Wiązania Perla do pakietu GDAL - moduły Geo::GDAL, Geo::OGR, Geo::OSR.
a0ffd9c4 241
ead243f9 242%package -n %{php_name}-gdal
9b4989ae
JB
243Summary: PHP bindings for GDAL library
244Summary(pl.UTF-8): Wiązania PHP do biblioteki GDAL
245Group: Development/Languages/PHP
246Requires: %{name} = %{version}-%{release}
247%{?requires_php_extension}
248
ead243f9 249%description -n %{php_name}-gdal
9b4989ae
JB
250PHP bindings for GDAL library
251
ead243f9 252%description -n %{php_name}-gdal -l pl.UTF-8
9b4989ae
JB
253Wiązania PHP do biblioteki GDAL.
254
6b59fa88
JB
255%package -n python-gdal
256Summary: GDAL Python module
a28c1bee 257Summary(pl.UTF-8): Moduł Pythona GDAL
6b59fa88 258Group: Libraries/Python
1673a634 259Requires: %{name} = %{version}-%{release}
315a1c4a 260Requires: python-libs
6b59fa88
JB
261
262%description -n python-gdal
263GDAL Python module.
264
d34f2ec8
JR
265%description -n python-gdal -l pl.UTF-8
266Moduł Pythona GDAL.
6b59fa88 267
a0ffd9c4
JB
268%package -n ruby-gdal
269Summary: Ruby bindings for GDAL
270Summary(pl.UTF-8): Wiązania języka Ruby do pakietu GDAL
271Group: Development/Languages
272Requires: %{name} = %{version}-%{release}
a0ffd9c4
JB
273
274%description -n ruby-gdal
275Ruby bindings for GDAL - gdal, gdalconst, ogr and osr modules.
276
277%description -n ruby-gdal -l pl.UTF-8
017b03bb
ER
278Wiązania języka Ruby do pakietu GDAL - moduły gdal, gdalconst, ogr i
279osr.
a0ffd9c4 280
faf5649c
JB
281%prep
282%setup -q
283%patch0 -p1
ee43bca4 284%patch1 -p2
f1b5abea
JB
285%patch2 -p1
286%patch3 -p1
743c2d9c
JR
287%patch9 -p1
288%patch11 -p1
289%patch12 -p1
6f52dc7d 290%patch13 -p1
f9aa527b 291%patch15 -p1
0316feee
JB
292
293# need to regenerate (old ones don't support perl 5.10 or php 5.5)
294%{__rm} swig/{perl,php}/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
295
296%{__sed} -i \
297 -e 's/^CC=gcc/CC=%{__cc}/' \
298 -e 's/^CXX=g++/CXX=%{__cxx}/' \
299 -e 's/^CFLAGS=-fpic/CFLAGS=%{rpmcflags} -fPIC/' \
300 -e 's/^LDFLAGS=-shared/LDFLAGS=%{rpmldflags} -shared/' \
301 swig/php/GNUmakefile
315a1c4a
ER
302# Build with fPIC to allow Ruby bindings
303# Xcompiler should normally achieve that -- http://trac.osgeo.org/gdal/ticket/3978
304# http://trac.osgeo.org/gdal/ticket/1994
305sed -i 's|\$(CFLAGS)|$(CFLAGS) -fPIC|g' swig/ruby/RubyMakefile.mk
306# Install Ruby bindings to distribution specific directory
307sed -i 's|RUBY_EXTENSIONS_DIR :=.*|RUBY_EXTENSIONS_DIR := %{ruby_vendorarchdir}|' swig/ruby/RubyMakefile.mk
308
309# Install Ruby bindings into the proper place
310sed -i -e 's|^$(INSTALL_DIR):|$(DESTDIR)$(INSTALL_DIR):|' swig/ruby/RubyMakefile.mk
311sed -i -e 's|^install: $(INSTALL_DIR)|install: $(DESTDIR)$(INSTALL_DIR)|' swig/ruby/RubyMakefile.mk
312
f4952e6f 313# our man path
be8ee7be 314sed -i -e 's#^mandir=.*##g' configure.ac
f4952e6f 315
4058fbc3 316%{__rm} -r man
4ed54fac 317
be8ee7be 318%{__sed} -i -e 's,DODS_INC="-I.*,DODS_INC="$(pkg-config --cflags libdap)",' configure.ac
b88bb9ef 319
faf5649c 320%build
e6e33a1a
JR
321%ifarch %{x8664}
322jvm_arch=amd64
323%endif
324%ifarch %{ix86}
325jvm_arch=i386
326%endif
327%ifarch x32
328jvm_arch=x32
329%endif
330
69051332 331%{__libtoolize}
69051332 332%{__aclocal} -I m4
faf5649c 333%{__autoconf}
0a5f35eb 334%{__autoheader}
6b59fa88 335%configure \
e582c3b1 336 --includedir=%{_includedir}/gdal \
5014b82a 337 --datadir=%{_datadir}/gdal \
d4d7a2c6 338 --with-dods-root=/usr \
d3d190a4 339 %{?with_armadillo:--with-armadillo} \
6f52dc7d 340 %{?with_crnlib:--with-dds} \
209aac6b 341 %{?with_epsilon:--with-epsilon} \
0316feee 342 %{?with_grass:--with-grass} \
b88bb9ef 343 %{!?with_gta:--without-gta} \
69051332 344 --with-hide-internal-symbols \
9b4989ae
JB
345 %{?with_java:--with-java=%{java_home}} \
346 --with-liblzma \
77dfc6fa 347 %{!?with_kea:--without-kea} \
fffcf251 348 %{?with_java:--with-mdb --with-jvm-lib-add-rpath --with-jvm-lib=%{java_home}/jre/lib/$jvm_arch/server} \
d3d190a4 349 %{?with_mysql:--with-mysql} \
0316feee 350 %{?with_oci:--with-oci --with-oci-include=/usr/include/oracle/client --with-oci-lib=%{_libdir}} \
d3d190a4 351 %{?with_opencl:--with-opencl} \
a0ffd9c4 352 --with-perl \
9b4989ae 353 %{?with_php:--with-php} \
fac7da6f
JB
354 %{?with_podofo:--with-podofo} \
355 %{?with_poppler:--with-poppler} \
69051332 356 --with-python \
779b0eec 357 %{?with_rasdaman:--with-rasdaman=%{_libdir}/rasdaman} \
4aafe7c0 358 %{?with_ruby:--with-ruby} \
779b0eec 359 %{?with_fyba:--with-sosi} \
4537079d 360 %{?with_spatialite:--with-spatialite} \
69051332 361 --with-sqlite3 \
9b4989ae 362 --with-webp \
655672e5 363 %{?with_xerces:--with-xerces} \
6b59fa88 364 --with-xerces-inc=/usr/include/xercesc \
80faacbe 365 --with-xerces-lib="-lxerces-c" \
69051332 366 --without-libgrass
954ec354 367# --with-pcidsk=/usr (needs > 0.3)
779b0eec 368# csharp builds, but has no configure option nor install target
faf5649c 369
69051332 370# regenerate where needed
825dc3dc 371%{__make} -j1 -C swig/perl generate
3df9ed7f 372%if %{with ruby}
02b013b1 373%{__make} -j1 -C swig/ruby generate
3df9ed7f 374%endif
69051332 375
779b0eec
JB
376%{__make} -j1 \
377 %{?with_grass:GRASS_INCLUDE="-I/usr/include/grass64"} \
378 %{?with_fyba:SOSI_INC="-I/usr/include/fyba"}
a0ffd9c4 379
825dc3dc 380%{__make} -j1 docs
3a591acf 381
f5a12c65
JK
382%{__make} -j1 man
383
faf5649c
JB
384%install
385rm -rf $RPM_BUILD_ROOT
faf5649c 386
825dc3dc 387%{__make} -j1 install install-man \
3a591acf
JB
388 DESTDIR=$RPM_BUILD_ROOT
389
388b39cb
ER
390rm -rf _html
391cp -a html _html
faf5649c 392
9b4989ae
JB
393%if %{with php}
394# missing in make install
ead243f9
ER
395install -d $RPM_BUILD_ROOT%{php_extensiondir}
396install -p swig/php/php_gdal.so $RPM_BUILD_ROOT%{php_extensiondir}/gdal.so
397install -p swig/php/php_gdalconst.so $RPM_BUILD_ROOT%{php_extensiondir}/gdalconst.so
398install -p swig/php/php_ogr.so $RPM_BUILD_ROOT%{php_extensiondir}/ogr.so
399install -p swig/php/php_osr.so $RPM_BUILD_ROOT%{php_extensiondir}/osr.so
9b4989ae
JB
400install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
401cat <<'EOF' >$RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/gdal.ini
ead243f9 402; Enable gdal extension modules
9b4989ae
JB
403extension=gdal.so
404extension=gdalconst.so
405extension=ogr.so
406extension=osr.so
407EOF
408%endif
409
374370d5
JB
410%py_comp $RPM_BUILD_ROOT%{py_sitedir}
411%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
412%py_postclean
5014b82a 413
017b03bb
ER
414%{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
415%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/.packlist
416%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/Const/.packlist
417%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OGR/.packlist
418%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OSR/.packlist
419
faf5649c
JB
420%clean
421rm -rf $RPM_BUILD_ROOT
422
6b59fa88
JB
423%post -p /sbin/ldconfig
424%postun -p /sbin/ldconfig
425
faf5649c
JB
426%files
427%defattr(644,root,root,755)
c0a384ef 428%doc NEWS PROVENANCE.TXT
4058fbc3
JB
429%attr(755,root,root) %{_bindir}/epsg_tr.py
430%attr(755,root,root) %{_bindir}/esri2wkt.py
431%attr(755,root,root) %{_bindir}/gcps2vec.py
432%attr(755,root,root) %{_bindir}/gcps2wld.py
433%attr(755,root,root) %{_bindir}/gdal2tiles.py
434%attr(755,root,root) %{_bindir}/gdal2xyz.py
4058fbc3 435%attr(755,root,root) %{_bindir}/gdaladdo
6f52dc7d 436%attr(755,root,root) %{_bindir}/gdal_auth.py
4058fbc3 437%attr(755,root,root) %{_bindir}/gdalbuildvrt
6f52dc7d 438%attr(755,root,root) %{_bindir}/gdal_calc.py
4058fbc3 439%attr(755,root,root) %{_bindir}/gdalchksum.py
0316feee 440%attr(755,root,root) %{_bindir}/gdalcompare.py
6f52dc7d 441%attr(755,root,root) %{_bindir}/gdal_contour
4058fbc3 442%attr(755,root,root) %{_bindir}/gdaldem
6f52dc7d 443%attr(755,root,root) %{_bindir}/gdal_edit.py
4058fbc3 444%attr(755,root,root) %{_bindir}/gdalenhance
6f52dc7d
JR
445%attr(755,root,root) %{_bindir}/gdal_fillnodata.py
446%attr(755,root,root) %{_bindir}/gdal_grid
4058fbc3
JB
447%attr(755,root,root) %{_bindir}/gdalident.py
448%attr(755,root,root) %{_bindir}/gdalimport.py
449%attr(755,root,root) %{_bindir}/gdalinfo
954ec354 450%attr(755,root,root) %{_bindir}/gdallocationinfo
4058fbc3 451%attr(755,root,root) %{_bindir}/gdalmanage
6f52dc7d 452%attr(755,root,root) %{_bindir}/gdal_merge.py
f4952e6f 453%attr(755,root,root) %{_bindir}/gdalmove.py
6f52dc7d
JR
454%attr(755,root,root) %{_bindir}/gdal_pansharpen.py
455%attr(755,root,root) %{_bindir}/gdal_polygonize.py
456%attr(755,root,root) %{_bindir}/gdal_proximity.py
457%attr(755,root,root) %{_bindir}/gdal_rasterize
458%attr(755,root,root) %{_bindir}/gdal_retile.py
f4952e6f 459%attr(755,root,root) %{_bindir}/gdalserver
6f52dc7d 460%attr(755,root,root) %{_bindir}/gdal_sieve.py
9b4989ae 461%attr(755,root,root) %{_bindir}/gdalsrsinfo
4058fbc3
JB
462%attr(755,root,root) %{_bindir}/gdaltindex
463%attr(755,root,root) %{_bindir}/gdaltransform
6f52dc7d 464%attr(755,root,root) %{_bindir}/gdal_translate
4058fbc3 465%attr(755,root,root) %{_bindir}/gdalwarp
6f52dc7d
JR
466%attr(755,root,root) %{_bindir}/gnmanalyse
467%attr(755,root,root) %{_bindir}/gnmmanage
4058fbc3
JB
468%attr(755,root,root) %{_bindir}/mkgraticule.py
469%attr(755,root,root) %{_bindir}/nearblack
470%attr(755,root,root) %{_bindir}/ogr2ogr
471%attr(755,root,root) %{_bindir}/ogrinfo
0316feee 472%attr(755,root,root) %{_bindir}/ogrlineref
6f52dc7d 473%attr(755,root,root) %{_bindir}/ogrmerge.py
4058fbc3
JB
474%attr(755,root,root) %{_bindir}/ogrtindex
475%attr(755,root,root) %{_bindir}/pct2rgb.py
476%attr(755,root,root) %{_bindir}/rgb2pct.py
477%attr(755,root,root) %{_bindir}/testepsg
5014b82a 478%attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
38239d5e 479%attr(755,root,root) %ghost %{_libdir}/libgdal.so.20
0a5f35eb 480%dir %{_libdir}/gdalplugins
6b59fa88 481%{_datadir}/gdal
4058fbc3 482%{_mandir}/man1/gdal2tiles.1*
0316feee 483%{_mandir}/man1/gdal_calc.1*
4058fbc3 484%{_mandir}/man1/gdal_contour.1*
f4952e6f 485%{_mandir}/man1/gdal_edit.1*
4058fbc3
JB
486%{_mandir}/man1/gdal_fillnodata.1*
487%{_mandir}/man1/gdal_grid.1*
488%{_mandir}/man1/gdal_merge.1*
f4952e6f
AM
489%{_mandir}/man1/gdal_polygonize.1*
490%{_mandir}/man1/gdal_proximity.1*
4058fbc3
JB
491%{_mandir}/man1/gdal_rasterize.1*
492%{_mandir}/man1/gdal_retile.1*
493%{_mandir}/man1/gdal_sieve.1*
494%{_mandir}/man1/gdal_translate.1*
495%{_mandir}/man1/gdal_utilities.1*
496%{_mandir}/man1/gdaladdo.1*
497%{_mandir}/man1/gdalbuildvrt.1*
0316feee 498%{_mandir}/man1/gdalcompare.1*
4058fbc3
JB
499%{_mandir}/man1/gdaldem.1*
500%{_mandir}/man1/gdalinfo.1*
954ec354 501%{_mandir}/man1/gdallocationinfo.1*
f4952e6f
AM
502%{_mandir}/man1/gdalmanage.1*
503%{_mandir}/man1/gdalmove.1*
9b4989ae 504%{_mandir}/man1/gdalsrsinfo.1*
4058fbc3
JB
505%{_mandir}/man1/gdaltindex.1*
506%{_mandir}/man1/gdaltransform.1*
507%{_mandir}/man1/gdalwarp.1*
508%{_mandir}/man1/nearblack.1*
509%{_mandir}/man1/ogr2ogr.1*
510%{_mandir}/man1/ogr_utilities.1*
511%{_mandir}/man1/ogrinfo.1*
0316feee 512%{_mandir}/man1/ogrlineref.1*
4058fbc3
JB
513%{_mandir}/man1/ogrtindex.1*
514%{_mandir}/man1/pct2rgb.1*
515%{_mandir}/man1/rgb2pct.1*
6f52dc7d
JR
516%{_mandir}/man1/gdal_pansharpen.1*
517%{_mandir}/man1/gnm_utilities.1*
518%{_mandir}/man1/gnmanalyse.1*
519%{_mandir}/man1/gnmmanage.1*
520%{_mandir}/man1/ogrmerge.1*
6b59fa88
JB
521
522%files devel
523%defattr(644,root,root,755)
388b39cb 524%doc _html/*
5014b82a 525%attr(755,root,root) %{_bindir}/gdal-config
6b59fa88 526%attr(755,root,root) %{_libdir}/libgdal.so
5014b82a 527%{_libdir}/libgdal.la
0316feee 528%{_pkgconfigdir}/gdal.pc
e582c3b1 529%{_includedir}/gdal
5014b82a 530%{_mandir}/man1/gdal-config.1*
6b59fa88
JB
531
532%files static
533%defattr(644,root,root,755)
9b5c0fd4 534%{_libdir}/libgdal.a
6b59fa88 535
a0ffd9c4
JB
536%files -n perl-gdal
537%defattr(644,root,root,755)
538%dir %{perl_vendorarch}/Geo
539%{perl_vendorarch}/Geo/GDAL.pm
540%dir %{perl_vendorarch}/Geo/GDAL
541%{perl_vendorarch}/Geo/GDAL/Const.pm
542%{perl_vendorarch}/Geo/OGR.pm
543%{perl_vendorarch}/Geo/OSR.pm
544%dir %{perl_vendorarch}/auto/Geo
545%dir %{perl_vendorarch}/auto/Geo/GDAL
a0ffd9c4
JB
546%attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/GDAL.so
547%dir %{perl_vendorarch}/auto/Geo/GDAL/Const
a0ffd9c4 548%attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.so
6f52dc7d
JR
549%dir %{perl_vendorarch}/auto/Geo/GNM
550%attr(755,root,root) %{perl_vendorarch}/auto/Geo/GNM/GNM.so
a0ffd9c4 551%dir %{perl_vendorarch}/auto/Geo/OGR
a0ffd9c4
JB
552%attr(755,root,root) %{perl_vendorarch}/auto/Geo/OGR/OGR.so
553%dir %{perl_vendorarch}/auto/Geo/OSR
a0ffd9c4 554%attr(755,root,root) %{perl_vendorarch}/auto/Geo/OSR/OSR.so
38239d5e 555%{_mandir}/man3/Geo::GDAL.3pm*
6f52dc7d 556%{perl_vendorarch}/Geo/GNM.pm
a0ffd9c4 557
9b4989ae 558%if %{with php}
ead243f9 559%files -n %{php_name}-gdal
9b4989ae
JB
560%defattr(644,root,root,755)
561%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/gdal.ini
562%attr(755,root,root) %{php_extensiondir}/gdal.so
563%attr(755,root,root) %{php_extensiondir}/gdalconst.so
564%attr(755,root,root) %{php_extensiondir}/ogr.so
565%attr(755,root,root) %{php_extensiondir}/osr.so
566%endif
567
6b59fa88
JB
568%files -n python-gdal
569%defattr(644,root,root,755)
9a2dbbce
JB
570%{py_sitedir}/gdal.py[co]
571%{py_sitedir}/gdalconst.py[co]
572%{py_sitedir}/gdalnumeric.py[co]
6f52dc7d 573%{py_sitedir}/gnm.py[co]
9a2dbbce
JB
574%{py_sitedir}/ogr.py[co]
575%{py_sitedir}/osr.py[co]
69051332
JB
576%{py_sitedir}/GDAL-*.egg-info
577%dir %{py_sitedir}/osgeo
578%attr(755,root,root) %{py_sitedir}/osgeo/_gdal.so
579%attr(755,root,root) %{py_sitedir}/osgeo/_gdal_array.so
580%attr(755,root,root) %{py_sitedir}/osgeo/_gdalconst.so
6f52dc7d 581%attr(755,root,root) %{py_sitedir}/osgeo/_gnm.so
69051332
JB
582%attr(755,root,root) %{py_sitedir}/osgeo/_ogr.so
583%attr(755,root,root) %{py_sitedir}/osgeo/_osr.so
584%{py_sitedir}/osgeo/*.py[co]
a0ffd9c4 585
4aafe7c0 586%if %{with ruby}
a0ffd9c4
JB
587%files -n ruby-gdal
588%defattr(644,root,root,755)
315a1c4a
ER
589%dir %{ruby_vendorarchdir}/gdal
590%attr(755,root,root) %{ruby_vendorarchdir}/gdal/gdal.so
591%attr(755,root,root) %{ruby_vendorarchdir}/gdal/gdalconst.so
592%attr(755,root,root) %{ruby_vendorarchdir}/gdal/ogr.so
593%attr(755,root,root) %{ruby_vendorarchdir}/gdal/osr.so
4aafe7c0 594%endif
This page took 0.224329 seconds and 4 git commands to generate.