]> git.pld-linux.org Git - packages/gdal.git/blame - gdal.spec
- release 12 (by relup.sh)
[packages/gdal.git] / gdal.spec
CommitLineData
954ec354 1# TODO:
8b360036 2# - be reasonable about devel dependencies - you do not need all of them to
cfcb08ee 3# use gdal (probably a gdal module or driver shall not imply devel
4# dependency)
d3d190a4 5# - libjpeg12 (needs patching to use system one, --with-jpeg12 is not sufficient as of 1.9.2)
9b4989ae 6# - libkml (1.3.0 needed, not released yet)
954ec354 7# - wait for newer pcidsk, switch to external again
d3d190a4 8# - csharp, java
9b4989ae
JB
9# - additional, proprietary(?) formats support:
10# - FMEObjects (http://www.safe.com/support/support-resources/fme-downloads/)
11# - ESRI FileGDBAPI (http://resources.arcgis.com/content/geodatabases/10.0/file-gdb-api)
12# - ECW (http://www.erdas.com/products/ecw/ERDASECWJPEG2000SDK/Details.aspx)
13# - Kakadu/JPEG2000 (http://www.kakadusoftware.com/)
14# - MrSID (http://www.lizardtech.com/developer/)
15# - MSG/EUMETSAT (http://www.eumetsat.int/Home/Main/DataAccess/SupportSoftwareTools/index.htm)
9b4989ae 16# - Ingres (--with-ingres=/path)
0316feee 17# - Informix DB (--with-idb)
9b4989ae
JB
18# - DWGdirect (members only? http://www.opendwg.org/)
19# - ESRI SDE (http://www.esri.com/software/arcgis/arcsde/index.html)
655672e5 20#
21# Conditional build:
d3d190a4 22%bcond_without armadillo # Armadillo support for faster TPS transform
779b0eec 23%bcond_without crnlib # DDS support via crunch/crnlib
4537079d 24%bcond_without epsilon # EPSILON wavelet compression support
779b0eec 25%bcond_without fyba # SOSI geodata support using FYBA
0a5f35eb 26%bcond_with grass # GRASS support (note: dependency loop; use gdal-grass.spec instead)
4537079d 27%bcond_without gta # GTA format support
77dfc6fa 28%bcond_without kea # KEA format support
d3d190a4 29%bcond_without mysql # MySQL DB support
0316feee 30%bcond_with oci # ORACLE OCI DB and Georaster support
d3d190a4
JB
31%bcond_without odbc # ODBC DB support
32%bcond_without opencl # OpenCL (GPU) support
c9c08280 33%bcond_without openjpeg # OpenJPEG 2 (JPEG2000) support
4537079d
JB
34%bcond_with podofo # PDF support via podofo instead of poppler
35%bcond_without poppler # PDF support via poppler
779b0eec 36%bcond_without rasdaman # Rasdaman support
4537079d 37%bcond_without spatialite # SpatiaLite support
d3d190a4
JB
38%bcond_without xerces # Xerces support
39%bcond_without java # Java and MDB support
47ddf890 40%bcond_with php # PHP binding [PHP 7 not supported by swig 3.0.x]
77dfc6fa 41%bcond_with ruby # Ruby binding [not available as of 2.0.2]
315a1c4a 42
fac7da6f
JB
43%if %{with podofo}
44%undefine with_poppler
45%endif
66daf0b1 46%if 0%{!?php_name:1}
ead243f9 47%define php_name php55
66daf0b1 48%endif
faf5649c 49Summary: Geospatial Data Abstraction Library
a28c1bee 50Summary(pl.UTF-8): Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
faf5649c 51Name: gdal
77dfc6fa 52Version: 2.0.2
bfc95826 53Release: 12
faf5649c
JB
54License: BSD-like
55Group: Libraries
84501866 56Source0: http://download.osgeo.org/gdal/%{version}/%{name}-%{version}.tar.xz
77dfc6fa 57# Source0-md5: 940208e737c87d31a90eaae43d0efd65
f5a12c65 58Patch0: %{name}-perl.patch
9b4989ae 59Patch1: %{name}-python_install.patch
f1b5abea
JB
60Patch2: %{name}-php.patch
61Patch3: %{name}-fpic.patch
0316feee 62Patch5: %{name}-grass.patch
0316feee 63Patch7: %{name}-link.patch
779b0eec
JB
64Patch8: %{name}-fyba.patch
65Patch9: %{name}-dds.patch
779b0eec 66Patch11: %{name}-armadillo.patch
ce035715 67Patch12: %{name}-rasdaman.patch
0a5f35eb 68Patch13: %{name}-pluginsdir.patch
4ac72d8c 69Patch14: %{name}-uchar.patch
9b5c0fd4 70URL: http://www.gdal.org/
ead243f9 71%{?with_php:BuildRequires: %{php_name}-devel}
d3d190a4
JB
72%{?with_opencl:BuildRequires: OpenCL-devel >= 1.0}
73%{?with_armadillo:BuildRequires: armadillo-devel}
69051332
JB
74BuildRequires: autoconf >= 2.52
75BuildRequires: automake
6b59fa88 76BuildRequires: cfitsio-devel
6a3158ac 77%{?with_crnlib:BuildRequires: crnlib-devel}
9b4989ae 78BuildRequires: curl-devel
9d161bc4 79BuildRequires: doxygen >= 1.4.2
209aac6b 80%{?with_epsilon:BuildRequires: epsilon-compressor-devel}
69051332 81BuildRequires: expat-devel >= 1.95.0
779b0eec 82%{?with_fyba:BuildRequires: fyba-devel}
4537079d 83BuildRequires: freexl-devel >= 1.0
0316feee
JB
84BuildRequires: gcc >= 6:4.1
85BuildRequires: geos-devel >= 3.1.0
b459f4d7 86BuildRequires: giflib-devel >= 4.0
779b0eec 87%{?with_grass:BuildRequires: grass-devel >= 6.4}
6b59fa88 88BuildRequires: hdf-devel >= 4.0
69051332 89BuildRequires: hdf5-devel
6b59fa88 90BuildRequires: jasper-devel
9b4989ae
JB
91%{?with_java:BuildRequires: jdk}
92%{?with_java:BuildRequires: jpackage-utils}
0316feee 93BuildRequires: json-c-devel >= 0.11
77dfc6fa 94%{?with_kea:BuildRequires: kealib-devel}
8fd908ab 95BuildRequires: libcsf-devel >= 2.0-0.041111.6
4058fbc3 96BuildRequires: libdap-devel >= 3.10
b3cbf6a3 97BuildRequires: libgeotiff-devel >= 1.2.1
b88bb9ef 98%{?with_gta:BuildRequires: libgta-devel}
6b59fa88 99BuildRequires: libjpeg-devel >= 6b
9b4989ae 100#BuildRequires: libkml-devel >= 1.3.0
e354fe40 101BuildRequires: libpng-devel >= 2:1.2.8
4537079d 102%{?with_spatialite:BuildRequires: libspatialite-devel}
b3cbf6a3 103BuildRequires: libstdc++-devel
954ec354 104BuildRequires: libtiff-devel >= 4.0
69051332 105BuildRequires: libtool
e2b089e1 106BuildRequires: libuuid-devel
9b4989ae 107BuildRequires: libwebp-devel
0316feee 108BuildRequires: libxml2-devel >= 2
d3d190a4 109%{?with_mysql:BuildRequires: mysql-devel}
80114ba8 110BuildRequires: netcdf-devel >= 4.1
6b59fa88 111BuildRequires: ogdi-devel >= 3.1
c9c08280 112%{?with_openjpeg:BuildRequires: openjpeg2-devel >= 2.0.0-2}
0316feee
JB
113# 8.1.7 for DB support, 10.0.1 for georaster
114%{?with_oci:BuildRequires: oracle-instantclient-devel >= 10.0.1}
954ec354 115#BuildRequires: pcidsk-devel > 0.3
a0ffd9c4 116BuildRequires: perl-devel
fac7da6f 117%{?with_podofo:BuildRequires: podofo-devel}
0077f857 118%{?with_poppler:BuildRequires: poppler-devel >= 0.24}
9b4989ae
JB
119# ensure it's compiled with PQescapeStringConn support
120BuildRequires: postgresql-backend-devel >= 8.1.4
121BuildRequires: postgresql-devel >= 8.1.4
122BuildRequires: proj-devel >= 4
9a2dbbce 123BuildRequires: python-devel >= 1:2.5
017b03bb 124BuildRequires: python-numpy-devel >= 1:1.0.0
9b4989ae 125BuildRequires: python-setuptools
779b0eec 126%{?with_rasdaman:BuildRequires: rasdaman-devel}
479cb83c 127BuildRequires: rpm-pythonprov
315a1c4a 128%{?with_ruby:BuildRequires: rpm-rubyprov}
9b4989ae 129BuildRequires: rpmbuild(macros) >= 1.344
4aafe7c0 130%{?with_ruby:BuildRequires: ruby-devel}
b88bb9ef 131BuildRequires: sed >= 4.0
9b4989ae 132BuildRequires: sqlite3-devel >= 3.0.0
479cb83c 133BuildRequires: swig-perl
0316feee 134BuildRequires: swig-php >= 2.0.12-2
9a2dbbce 135BuildRequires: swig-python >= 1.3
017b03bb 136%{?with_ruby:BuildRequires: swig-ruby}
479cb83c 137BuildRequires: texlive-dvips
138BuildRequires: texlive-latex
9831286f 139%{?with_odbc:BuildRequires: unixODBC-devel >= 2.2.15}
9b4989ae
JB
140%{?with_xerces:BuildRequires: xerces-c-devel >= 2.7.0}
141BuildRequires: xz-devel
faf5649c 142BuildRequires: zlib-devel >= 1.1.4
4537079d 143Requires: freexl >= 1.0
0316feee 144Requires: geos >= 3.1.0
b3cbf6a3 145Requires: libgeotiff >= 1.2.1
e354fe40 146Requires: libpng >= 2:1.2.8
954ec354 147Requires: libtiff >= 4.0
faf5649c
JB
148BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
149
150%description
151GDAL is a translator library for raster geospatial data formats that
152is released under an Open Source license. As a library, it presents a
153single abstract data model to the calling application for all
154supported formats. The related OGR library (which lives within the
155GDAL source tree) provides a similar capability for simple features
156vector data.
f05c79e8 157
d34f2ec8
JR
158%description -l pl.UTF-8
159GDAL to biblioteka konwertująca między formatami rastrowych danych
160dotyczących powierzchni Ziemi, udostępniona na licencji Open Source.
161Jako biblioteka udostępnia aplikacjom jeden abstrakcyjny model danych
162do wszystkich obsługiwanych formatów. Powiązana z nią biblioteka OGR
163(której źródła są dołączone do drzewa źródeł GDAL) daje podobne
164możliwości dla danych wektorowych.
faf5649c 165
6b59fa88
JB
166%package devel
167Summary: GDAL library header files
a28c1bee 168Summary(pl.UTF-8): Pliki nagłówkowe biblioteki GDAL
6b59fa88 169Group: Development/Libraries
1673a634 170Requires: %{name} = %{version}-%{release}
d3d190a4
JB
171%{?with_opencl:Requires: OpenCL-devel >= 1.0}
172%{?with_armadillo:Requires: armadillo-devel}
b3cbf6a3 173Requires: cfitsio-devel
6a3158ac 174%{?with_crnlib:Requires: crnlib-devel}
209aac6b
JB
175Requires: curl-devel
176%{?with_epsilon:Requires: epsilon-compressor-devel}
779b0eec 177%{?with_fyba:Requires: fyba-devel}
69051332 178Requires: expat-devel >= 1.95.0
4537079d 179Requires: freexl-devel >= 1.0
0316feee 180Requires: geos-devel >= 3.1.0
209aac6b 181Requires: giflib-devel >= 4.0
b3cbf6a3 182Requires: hdf-devel >= 4.0
69051332 183Requires: hdf5-devel
b3cbf6a3 184Requires: jasper-devel
0316feee 185Requires: json-c-devel >= 0.11
77dfc6fa 186%{?with_kea:Requires: kealib-devel}
d4d7a2c6 187Requires: libcsf-devel
4058fbc3 188Requires: libdap-devel >= 3.10
b3cbf6a3 189Requires: libgeotiff-devel >= 1.2.1
209aac6b
JB
190%{?with_gta:Requires: libgta-devel}
191Requires: libjpeg-devel >= 6b
e354fe40 192Requires: libpng-devel >= 2:1.2.8
4537079d 193%{?with_spatialite:Requires: libspatialite-devel}
b3cbf6a3 194Requires: libstdc++-devel
954ec354 195Requires: libtiff-devel >= 4.0
209aac6b
JB
196Requires: libuuid-devel
197Requires: libwebp-devel
0316feee 198Requires: libxml2-devel >= 2
d3d190a4 199%{?with_mysql:Requires: mysql-devel}
9b4989ae 200Requires: netcdf-devel >= 4
b3cbf6a3 201Requires: ogdi-devel >= 3.1
c9c08280 202%{?with_openjpeg:Requires: openjpeg2-devel >= 2.0.0-2}
954ec354 203#Requires: pcidsk-devel > 0.3
209aac6b 204%{?with_podofo:Requires: podofo-devel}
0077f857 205%{?with_poppler:Requires: poppler-devel >= 0.24}
b3cbf6a3 206Requires: postgresql-devel
209aac6b 207Requires: proj-devel >= 4
779b0eec 208%{?with_rasdaman:Requires: rasdaman-devel}
9b4989ae 209Requires: sqlite3-devel >= 3.0.0
655672e5 210%{?with_odbc:Requires: unixODBC-devel}
69051332 211%{?with_xerces:Requires: xerces-c-devel >= 2.7.0}
209aac6b
JB
212Requires: xz-devel
213Requires: zlib-devel >= 1.1.4
6b59fa88
JB
214
215%description devel
216GDAL library header files.
217
d34f2ec8
JR
218%description devel -l pl.UTF-8
219Pliki nagłówkowe biblioteki GDAL.
6b59fa88
JB
220
221%package static
222Summary: GDAL static libraries
a28c1bee 223Summary(pl.UTF-8): Statyczne biblioteki GDAL
6b59fa88 224Group: Development/Libraries
1673a634 225Requires: %{name}-devel = %{version}-%{release}
6b59fa88
JB
226
227%description static
228GDAL static libraries.
229
d34f2ec8 230%description static -l pl.UTF-8
6b59fa88
JB
231Statyczne biblioteki GDAL.
232
a0ffd9c4
JB
233%package -n perl-gdal
234Summary: Perl bindings for GDAL
235Summary(pl.UTF-8): Wiązania Perla do pakietu GDAL
236Group: Development/Languages/Perl
237Requires: %{name} = %{version}-%{release}
238
239%description -n perl-gdal
240Perl bindings for GDAL - Geo::GDAL, Geo::OGR and Geo::OSR modules.
241
242%description -n perl-gdal -l pl.UTF-8
017b03bb 243Wiązania Perla do pakietu GDAL - moduły Geo::GDAL, Geo::OGR, Geo::OSR.
a0ffd9c4 244
ead243f9 245%package -n %{php_name}-gdal
9b4989ae
JB
246Summary: PHP bindings for GDAL library
247Summary(pl.UTF-8): Wiązania PHP do biblioteki GDAL
248Group: Development/Languages/PHP
249Requires: %{name} = %{version}-%{release}
250%{?requires_php_extension}
251
ead243f9 252%description -n %{php_name}-gdal
9b4989ae
JB
253PHP bindings for GDAL library
254
ead243f9 255%description -n %{php_name}-gdal -l pl.UTF-8
9b4989ae
JB
256Wiązania PHP do biblioteki GDAL.
257
6b59fa88
JB
258%package -n python-gdal
259Summary: GDAL Python module
a28c1bee 260Summary(pl.UTF-8): Moduł Pythona GDAL
6b59fa88 261Group: Libraries/Python
1673a634 262Requires: %{name} = %{version}-%{release}
315a1c4a 263Requires: python-libs
6b59fa88
JB
264
265%description -n python-gdal
266GDAL Python module.
267
d34f2ec8
JR
268%description -n python-gdal -l pl.UTF-8
269Moduł Pythona GDAL.
6b59fa88 270
a0ffd9c4
JB
271%package -n ruby-gdal
272Summary: Ruby bindings for GDAL
273Summary(pl.UTF-8): Wiązania języka Ruby do pakietu GDAL
274Group: Development/Languages
275Requires: %{name} = %{version}-%{release}
a0ffd9c4
JB
276
277%description -n ruby-gdal
278Ruby bindings for GDAL - gdal, gdalconst, ogr and osr modules.
279
280%description -n ruby-gdal -l pl.UTF-8
017b03bb
ER
281Wiązania języka Ruby do pakietu GDAL - moduły gdal, gdalconst, ogr i
282osr.
a0ffd9c4 283
faf5649c
JB
284%prep
285%setup -q
286%patch0 -p1
287%patch1 -p1
f1b5abea
JB
288%patch2 -p1
289%patch3 -p1
0316feee 290%patch5 -p1
0316feee 291%patch7 -p1
779b0eec
JB
292%patch8 -p1
293%patch9 -p1
779b0eec
JB
294%patch11 -p1
295%patch12 -p1
0a5f35eb 296%patch13 -p1
4ac72d8c 297%patch14 -p1
0316feee
JB
298
299# need to regenerate (old ones don't support perl 5.10 or php 5.5)
300%{__rm} swig/{perl,php}/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
301
302%{__sed} -i \
303 -e 's/^CC=gcc/CC=%{__cc}/' \
304 -e 's/^CXX=g++/CXX=%{__cxx}/' \
305 -e 's/^CFLAGS=-fpic/CFLAGS=%{rpmcflags} -fPIC/' \
306 -e 's/^LDFLAGS=-shared/LDFLAGS=%{rpmldflags} -shared/' \
307 swig/php/GNUmakefile
315a1c4a
ER
308# Build with fPIC to allow Ruby bindings
309# Xcompiler should normally achieve that -- http://trac.osgeo.org/gdal/ticket/3978
310# http://trac.osgeo.org/gdal/ticket/1994
311sed -i 's|\$(CFLAGS)|$(CFLAGS) -fPIC|g' swig/ruby/RubyMakefile.mk
312# Install Ruby bindings to distribution specific directory
313sed -i 's|RUBY_EXTENSIONS_DIR :=.*|RUBY_EXTENSIONS_DIR := %{ruby_vendorarchdir}|' swig/ruby/RubyMakefile.mk
314
315# Install Ruby bindings into the proper place
316sed -i -e 's|^$(INSTALL_DIR):|$(DESTDIR)$(INSTALL_DIR):|' swig/ruby/RubyMakefile.mk
317sed -i -e 's|^install: $(INSTALL_DIR)|install: $(DESTDIR)$(INSTALL_DIR)|' swig/ruby/RubyMakefile.mk
318
f4952e6f
AM
319# our man path
320sed -i -e 's#^mandir=.*##g' configure.in
321
4058fbc3 322%{__rm} -r man
4ed54fac 323
b88bb9ef
JB
324%{__sed} -i -e 's,DODS_INC="-I.*,DODS_INC="$(pkg-config --cflags libdap)",' configure.in
325
faf5649c 326%build
e6e33a1a
JR
327%ifarch %{x8664}
328jvm_arch=amd64
329%endif
330%ifarch %{ix86}
331jvm_arch=i386
332%endif
333%ifarch x32
334jvm_arch=x32
335%endif
336
69051332 337%{__libtoolize}
69051332 338%{__aclocal} -I m4
faf5649c 339%{__autoconf}
0a5f35eb 340%{__autoheader}
6b59fa88 341%configure \
e582c3b1 342 --includedir=%{_includedir}/gdal \
5014b82a 343 --datadir=%{_datadir}/gdal \
d4d7a2c6 344 --with-dods-root=/usr \
d3d190a4 345 %{?with_armadillo:--with-armadillo} \
779b0eec 346 %{?with_crnlib:--with-dds} \
209aac6b 347 %{?with_epsilon:--with-epsilon} \
0316feee 348 %{?with_grass:--with-grass} \
b88bb9ef 349 %{!?with_gta:--without-gta} \
69051332 350 --with-hide-internal-symbols \
9b4989ae
JB
351 %{?with_java:--with-java=%{java_home}} \
352 --with-liblzma \
77dfc6fa 353 %{!?with_kea:--without-kea} \
fffcf251 354 %{?with_java:--with-mdb --with-jvm-lib-add-rpath --with-jvm-lib=%{java_home}/jre/lib/$jvm_arch/server} \
d3d190a4 355 %{?with_mysql:--with-mysql} \
0316feee 356 %{?with_oci:--with-oci --with-oci-include=/usr/include/oracle/client --with-oci-lib=%{_libdir}} \
d3d190a4 357 %{?with_opencl:--with-opencl} \
a0ffd9c4 358 --with-perl \
9b4989ae 359 %{?with_php:--with-php} \
fac7da6f
JB
360 %{?with_podofo:--with-podofo} \
361 %{?with_poppler:--with-poppler} \
69051332 362 --with-python \
779b0eec 363 %{?with_rasdaman:--with-rasdaman=%{_libdir}/rasdaman} \
4aafe7c0 364 %{?with_ruby:--with-ruby} \
779b0eec 365 %{?with_fyba:--with-sosi} \
4537079d 366 %{?with_spatialite:--with-spatialite} \
69051332 367 --with-sqlite3 \
9b4989ae 368 --with-webp \
655672e5 369 %{?with_xerces:--with-xerces} \
6b59fa88 370 --with-xerces-inc=/usr/include/xercesc \
80faacbe 371 --with-xerces-lib="-lxerces-c" \
69051332 372 --without-libgrass
954ec354 373# --with-pcidsk=/usr (needs > 0.3)
779b0eec 374# csharp builds, but has no configure option nor install target
faf5649c 375
69051332 376# regenerate where needed
825dc3dc 377%{__make} -j1 -C swig/perl generate
3df9ed7f 378%if %{with ruby}
02b013b1 379%{__make} -j1 -C swig/ruby generate
3df9ed7f 380%endif
69051332 381
779b0eec
JB
382%{__make} -j1 \
383 %{?with_grass:GRASS_INCLUDE="-I/usr/include/grass64"} \
384 %{?with_fyba:SOSI_INC="-I/usr/include/fyba"}
a0ffd9c4 385
825dc3dc 386%{__make} -j1 docs
3a591acf 387
f5a12c65
JK
388%{__make} -j1 man
389
faf5649c
JB
390%install
391rm -rf $RPM_BUILD_ROOT
faf5649c 392
825dc3dc 393%{__make} -j1 install install-man \
3a591acf
JB
394 DESTDIR=$RPM_BUILD_ROOT
395
388b39cb
ER
396rm -rf _html
397cp -a html _html
faf5649c 398
9b4989ae
JB
399%if %{with php}
400# missing in make install
ead243f9
ER
401install -d $RPM_BUILD_ROOT%{php_extensiondir}
402install -p swig/php/php_gdal.so $RPM_BUILD_ROOT%{php_extensiondir}/gdal.so
403install -p swig/php/php_gdalconst.so $RPM_BUILD_ROOT%{php_extensiondir}/gdalconst.so
404install -p swig/php/php_ogr.so $RPM_BUILD_ROOT%{php_extensiondir}/ogr.so
405install -p swig/php/php_osr.so $RPM_BUILD_ROOT%{php_extensiondir}/osr.so
9b4989ae
JB
406install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
407cat <<'EOF' >$RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/gdal.ini
ead243f9 408; Enable gdal extension modules
9b4989ae
JB
409extension=gdal.so
410extension=gdalconst.so
411extension=ogr.so
412extension=osr.so
413EOF
414%endif
415
374370d5
JB
416%py_comp $RPM_BUILD_ROOT%{py_sitedir}
417%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
418%py_postclean
5014b82a 419
017b03bb
ER
420%{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
421%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/.packlist
422%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/Const/.packlist
423%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OGR/.packlist
424%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OSR/.packlist
425
426# some doxygen trash
0316feee
JB
427%{__rm} $RPM_BUILD_ROOT%{_bindir}/gdal{compare,move}.dox
428%{__rm} $RPM_BUILD_ROOT%{_bindir}/gdal_{calc,edit,fillnodata,polygonize,proximity,sieve}.dox
017b03bb 429
faf5649c
JB
430%clean
431rm -rf $RPM_BUILD_ROOT
432
6b59fa88
JB
433%post -p /sbin/ldconfig
434%postun -p /sbin/ldconfig
435
faf5649c
JB
436%files
437%defattr(644,root,root,755)
c0a384ef 438%doc NEWS PROVENANCE.TXT
4058fbc3
JB
439%attr(755,root,root) %{_bindir}/epsg_tr.py
440%attr(755,root,root) %{_bindir}/esri2wkt.py
441%attr(755,root,root) %{_bindir}/gcps2vec.py
442%attr(755,root,root) %{_bindir}/gcps2wld.py
443%attr(755,root,root) %{_bindir}/gdal2tiles.py
444%attr(755,root,root) %{_bindir}/gdal2xyz.py
f4952e6f 445%attr(755,root,root) %{_bindir}/gdal_auth.py
4058fbc3 446%attr(755,root,root) %{_bindir}/gdal_contour
954ec354 447%attr(755,root,root) %{_bindir}/gdal_calc.py
f4952e6f 448%attr(755,root,root) %{_bindir}/gdal_edit.py
4058fbc3
JB
449%attr(755,root,root) %{_bindir}/gdal_fillnodata.py
450%attr(755,root,root) %{_bindir}/gdal_grid
451%attr(755,root,root) %{_bindir}/gdal_merge.py
452%attr(755,root,root) %{_bindir}/gdal_polygonize.py
453%attr(755,root,root) %{_bindir}/gdal_proximity.py
454%attr(755,root,root) %{_bindir}/gdal_rasterize
455%attr(755,root,root) %{_bindir}/gdal_retile.py
456%attr(755,root,root) %{_bindir}/gdal_sieve.py
457%attr(755,root,root) %{_bindir}/gdal_translate
458%attr(755,root,root) %{_bindir}/gdaladdo
459%attr(755,root,root) %{_bindir}/gdalbuildvrt
460%attr(755,root,root) %{_bindir}/gdalchksum.py
0316feee 461%attr(755,root,root) %{_bindir}/gdalcompare.py
4058fbc3
JB
462%attr(755,root,root) %{_bindir}/gdaldem
463%attr(755,root,root) %{_bindir}/gdalenhance
464%attr(755,root,root) %{_bindir}/gdalident.py
465%attr(755,root,root) %{_bindir}/gdalimport.py
466%attr(755,root,root) %{_bindir}/gdalinfo
954ec354 467%attr(755,root,root) %{_bindir}/gdallocationinfo
4058fbc3 468%attr(755,root,root) %{_bindir}/gdalmanage
f4952e6f
AM
469%attr(755,root,root) %{_bindir}/gdalmove.py
470%attr(755,root,root) %{_bindir}/gdalserver
9b4989ae 471%attr(755,root,root) %{_bindir}/gdalsrsinfo
4058fbc3
JB
472%attr(755,root,root) %{_bindir}/gdaltindex
473%attr(755,root,root) %{_bindir}/gdaltransform
474%attr(755,root,root) %{_bindir}/gdalwarp
475%attr(755,root,root) %{_bindir}/mkgraticule.py
476%attr(755,root,root) %{_bindir}/nearblack
477%attr(755,root,root) %{_bindir}/ogr2ogr
478%attr(755,root,root) %{_bindir}/ogrinfo
0316feee 479%attr(755,root,root) %{_bindir}/ogrlineref
4058fbc3
JB
480%attr(755,root,root) %{_bindir}/ogrtindex
481%attr(755,root,root) %{_bindir}/pct2rgb.py
482%attr(755,root,root) %{_bindir}/rgb2pct.py
483%attr(755,root,root) %{_bindir}/testepsg
5014b82a 484%attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
38239d5e 485%attr(755,root,root) %ghost %{_libdir}/libgdal.so.20
0a5f35eb 486%dir %{_libdir}/gdalplugins
6b59fa88 487%{_datadir}/gdal
4058fbc3 488%{_mandir}/man1/gdal2tiles.1*
0316feee 489%{_mandir}/man1/gdal_calc.1*
4058fbc3 490%{_mandir}/man1/gdal_contour.1*
f4952e6f 491%{_mandir}/man1/gdal_edit.1*
4058fbc3
JB
492%{_mandir}/man1/gdal_fillnodata.1*
493%{_mandir}/man1/gdal_grid.1*
494%{_mandir}/man1/gdal_merge.1*
f4952e6f
AM
495%{_mandir}/man1/gdal_polygonize.1*
496%{_mandir}/man1/gdal_proximity.1*
4058fbc3
JB
497%{_mandir}/man1/gdal_rasterize.1*
498%{_mandir}/man1/gdal_retile.1*
499%{_mandir}/man1/gdal_sieve.1*
500%{_mandir}/man1/gdal_translate.1*
501%{_mandir}/man1/gdal_utilities.1*
502%{_mandir}/man1/gdaladdo.1*
503%{_mandir}/man1/gdalbuildvrt.1*
0316feee 504%{_mandir}/man1/gdalcompare.1*
4058fbc3
JB
505%{_mandir}/man1/gdaldem.1*
506%{_mandir}/man1/gdalinfo.1*
954ec354 507%{_mandir}/man1/gdallocationinfo.1*
f4952e6f
AM
508%{_mandir}/man1/gdalmanage.1*
509%{_mandir}/man1/gdalmove.1*
9b4989ae 510%{_mandir}/man1/gdalsrsinfo.1*
4058fbc3
JB
511%{_mandir}/man1/gdaltindex.1*
512%{_mandir}/man1/gdaltransform.1*
513%{_mandir}/man1/gdalwarp.1*
514%{_mandir}/man1/nearblack.1*
515%{_mandir}/man1/ogr2ogr.1*
516%{_mandir}/man1/ogr_utilities.1*
517%{_mandir}/man1/ogrinfo.1*
0316feee 518%{_mandir}/man1/ogrlineref.1*
4058fbc3
JB
519%{_mandir}/man1/ogrtindex.1*
520%{_mandir}/man1/pct2rgb.1*
521%{_mandir}/man1/rgb2pct.1*
6b59fa88
JB
522
523%files devel
524%defattr(644,root,root,755)
388b39cb 525%doc _html/*
5014b82a 526%attr(755,root,root) %{_bindir}/gdal-config
6b59fa88 527%attr(755,root,root) %{_libdir}/libgdal.so
5014b82a 528%{_libdir}/libgdal.la
0316feee 529%{_pkgconfigdir}/gdal.pc
e582c3b1 530%{_includedir}/gdal
5014b82a 531%{_mandir}/man1/gdal-config.1*
6b59fa88
JB
532
533%files static
534%defattr(644,root,root,755)
9b5c0fd4 535%{_libdir}/libgdal.a
6b59fa88 536
a0ffd9c4
JB
537%files -n perl-gdal
538%defattr(644,root,root,755)
539%dir %{perl_vendorarch}/Geo
540%{perl_vendorarch}/Geo/GDAL.pm
541%dir %{perl_vendorarch}/Geo/GDAL
542%{perl_vendorarch}/Geo/GDAL/Const.pm
543%{perl_vendorarch}/Geo/OGR.pm
544%{perl_vendorarch}/Geo/OSR.pm
545%dir %{perl_vendorarch}/auto/Geo
546%dir %{perl_vendorarch}/auto/Geo/GDAL
a0ffd9c4
JB
547%attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/GDAL.so
548%dir %{perl_vendorarch}/auto/Geo/GDAL/Const
a0ffd9c4
JB
549%attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.so
550%dir %{perl_vendorarch}/auto/Geo/OGR
a0ffd9c4
JB
551%attr(755,root,root) %{perl_vendorarch}/auto/Geo/OGR/OGR.so
552%dir %{perl_vendorarch}/auto/Geo/OSR
a0ffd9c4 553%attr(755,root,root) %{perl_vendorarch}/auto/Geo/OSR/OSR.so
38239d5e 554%{_mandir}/man3/Geo::GDAL.3pm*
a0ffd9c4 555
9b4989ae 556%if %{with php}
ead243f9 557%files -n %{php_name}-gdal
9b4989ae
JB
558%defattr(644,root,root,755)
559%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/gdal.ini
560%attr(755,root,root) %{php_extensiondir}/gdal.so
561%attr(755,root,root) %{php_extensiondir}/gdalconst.so
562%attr(755,root,root) %{php_extensiondir}/ogr.so
563%attr(755,root,root) %{php_extensiondir}/osr.so
564%endif
565
6b59fa88
JB
566%files -n python-gdal
567%defattr(644,root,root,755)
9a2dbbce
JB
568%{py_sitedir}/gdal.py[co]
569%{py_sitedir}/gdalconst.py[co]
570%{py_sitedir}/gdalnumeric.py[co]
9a2dbbce
JB
571%{py_sitedir}/ogr.py[co]
572%{py_sitedir}/osr.py[co]
69051332
JB
573%{py_sitedir}/GDAL-*.egg-info
574%dir %{py_sitedir}/osgeo
575%attr(755,root,root) %{py_sitedir}/osgeo/_gdal.so
576%attr(755,root,root) %{py_sitedir}/osgeo/_gdal_array.so
577%attr(755,root,root) %{py_sitedir}/osgeo/_gdalconst.so
578%attr(755,root,root) %{py_sitedir}/osgeo/_ogr.so
579%attr(755,root,root) %{py_sitedir}/osgeo/_osr.so
580%{py_sitedir}/osgeo/*.py[co]
a0ffd9c4 581
4aafe7c0 582%if %{with ruby}
a0ffd9c4
JB
583%files -n ruby-gdal
584%defattr(644,root,root,755)
315a1c4a
ER
585%dir %{ruby_vendorarchdir}/gdal
586%attr(755,root,root) %{ruby_vendorarchdir}/gdal/gdal.so
587%attr(755,root,root) %{ruby_vendorarchdir}/gdal/gdalconst.so
588%attr(755,root,root) %{ruby_vendorarchdir}/gdal/ogr.so
589%attr(755,root,root) %{ruby_vendorarchdir}/gdal/osr.so
4aafe7c0 590%endif
This page took 0.227031 seconds and 4 git commands to generate.