]> git.pld-linux.org Git - packages/gdal.git/blame - gdal.spec
- rebuild with poppler 0.46
[packages/gdal.git] / gdal.spec
CommitLineData
954ec354 1# TODO:
8b360036 2# - be reasonable about devel dependencies - you do not need all of them to
cfcb08ee 3# use gdal (probably a gdal module or driver shall not imply devel
4# dependency)
d3d190a4 5# - libjpeg12 (needs patching to use system one, --with-jpeg12 is not sufficient as of 1.9.2)
9b4989ae 6# - libkml (1.3.0 needed, not released yet)
954ec354 7# - wait for newer pcidsk, switch to external again
d3d190a4 8# - csharp, java
9b4989ae
JB
9# - additional, proprietary(?) formats support:
10# - FMEObjects (http://www.safe.com/support/support-resources/fme-downloads/)
11# - ESRI FileGDBAPI (http://resources.arcgis.com/content/geodatabases/10.0/file-gdb-api)
12# - ECW (http://www.erdas.com/products/ecw/ERDASECWJPEG2000SDK/Details.aspx)
13# - Kakadu/JPEG2000 (http://www.kakadusoftware.com/)
14# - MrSID (http://www.lizardtech.com/developer/)
15# - MSG/EUMETSAT (http://www.eumetsat.int/Home/Main/DataAccess/SupportSoftwareTools/index.htm)
9b4989ae 16# - Ingres (--with-ingres=/path)
0316feee 17# - Informix DB (--with-idb)
9b4989ae
JB
18# - DWGdirect (members only? http://www.opendwg.org/)
19# - ESRI SDE (http://www.esri.com/software/arcgis/arcsde/index.html)
655672e5 20#
21# Conditional build:
d3d190a4 22%bcond_without armadillo # Armadillo support for faster TPS transform
779b0eec 23%bcond_without crnlib # DDS support via crunch/crnlib
4537079d 24%bcond_without epsilon # EPSILON wavelet compression support
779b0eec 25%bcond_without fyba # SOSI geodata support using FYBA
0a5f35eb 26%bcond_with grass # GRASS support (note: dependency loop; use gdal-grass.spec instead)
4537079d 27%bcond_without gta # GTA format support
77dfc6fa 28%bcond_without kea # KEA format support
d3d190a4 29%bcond_without mysql # MySQL DB support
0316feee 30%bcond_with oci # ORACLE OCI DB and Georaster support
d3d190a4
JB
31%bcond_without odbc # ODBC DB support
32%bcond_without opencl # OpenCL (GPU) support
c9c08280 33%bcond_without openjpeg # OpenJPEG 2 (JPEG2000) support
4537079d
JB
34%bcond_with podofo # PDF support via podofo instead of poppler
35%bcond_without poppler # PDF support via poppler
779b0eec 36%bcond_without rasdaman # Rasdaman support
4537079d 37%bcond_without spatialite # SpatiaLite support
d3d190a4
JB
38%bcond_without xerces # Xerces support
39%bcond_without java # Java and MDB support
77dfc6fa
JB
40%bcond_without php # PHP binding [PHP 7 not supported by swig 3.0.x]
41%bcond_with ruby # Ruby binding [not available as of 2.0.2]
315a1c4a 42
fac7da6f
JB
43%if %{with podofo}
44%undefine with_poppler
45%endif
66daf0b1 46%if 0%{!?php_name:1}
ead243f9 47%define php_name php55
66daf0b1 48%endif
faf5649c 49Summary: Geospatial Data Abstraction Library
a28c1bee 50Summary(pl.UTF-8): Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
faf5649c 51Name: gdal
77dfc6fa 52Version: 2.0.2
6c4b000d 53Release: 5
faf5649c
JB
54License: BSD-like
55Group: Libraries
84501866 56Source0: http://download.osgeo.org/gdal/%{version}/%{name}-%{version}.tar.xz
77dfc6fa 57# Source0-md5: 940208e737c87d31a90eaae43d0efd65
f5a12c65 58Patch0: %{name}-perl.patch
9b4989ae 59Patch1: %{name}-python_install.patch
f1b5abea
JB
60Patch2: %{name}-php.patch
61Patch3: %{name}-fpic.patch
0316feee 62Patch5: %{name}-grass.patch
0316feee 63Patch7: %{name}-link.patch
779b0eec
JB
64Patch8: %{name}-fyba.patch
65Patch9: %{name}-dds.patch
779b0eec 66Patch11: %{name}-armadillo.patch
ce035715 67Patch12: %{name}-rasdaman.patch
0a5f35eb 68Patch13: %{name}-pluginsdir.patch
9b5c0fd4 69URL: http://www.gdal.org/
ead243f9 70%{?with_php:BuildRequires: %{php_name}-devel}
d3d190a4
JB
71%{?with_opencl:BuildRequires: OpenCL-devel >= 1.0}
72%{?with_armadillo:BuildRequires: armadillo-devel}
69051332
JB
73BuildRequires: autoconf >= 2.52
74BuildRequires: automake
6b59fa88 75BuildRequires: cfitsio-devel
6a3158ac 76%{?with_crnlib:BuildRequires: crnlib-devel}
9b4989ae 77BuildRequires: curl-devel
9d161bc4 78BuildRequires: doxygen >= 1.4.2
209aac6b 79%{?with_epsilon:BuildRequires: epsilon-compressor-devel}
69051332 80BuildRequires: expat-devel >= 1.95.0
779b0eec 81%{?with_fyba:BuildRequires: fyba-devel}
4537079d 82BuildRequires: freexl-devel >= 1.0
0316feee
JB
83BuildRequires: gcc >= 6:4.1
84BuildRequires: geos-devel >= 3.1.0
b459f4d7 85BuildRequires: giflib-devel >= 4.0
779b0eec 86%{?with_grass:BuildRequires: grass-devel >= 6.4}
6b59fa88 87BuildRequires: hdf-devel >= 4.0
69051332 88BuildRequires: hdf5-devel
6b59fa88 89BuildRequires: jasper-devel
9b4989ae
JB
90%{?with_java:BuildRequires: jdk}
91%{?with_java:BuildRequires: jpackage-utils}
0316feee 92BuildRequires: json-c-devel >= 0.11
77dfc6fa 93%{?with_kea:BuildRequires: kealib-devel}
8fd908ab 94BuildRequires: libcsf-devel >= 2.0-0.041111.6
4058fbc3 95BuildRequires: libdap-devel >= 3.10
b3cbf6a3 96BuildRequires: libgeotiff-devel >= 1.2.1
b88bb9ef 97%{?with_gta:BuildRequires: libgta-devel}
6b59fa88 98BuildRequires: libjpeg-devel >= 6b
9b4989ae 99#BuildRequires: libkml-devel >= 1.3.0
e354fe40 100BuildRequires: libpng-devel >= 2:1.2.8
4537079d 101%{?with_spatialite:BuildRequires: libspatialite-devel}
b3cbf6a3 102BuildRequires: libstdc++-devel
954ec354 103BuildRequires: libtiff-devel >= 4.0
69051332 104BuildRequires: libtool
e2b089e1 105BuildRequires: libuuid-devel
9b4989ae 106BuildRequires: libwebp-devel
0316feee 107BuildRequires: libxml2-devel >= 2
d3d190a4 108%{?with_mysql:BuildRequires: mysql-devel}
80114ba8 109BuildRequires: netcdf-devel >= 4.1
6b59fa88 110BuildRequires: ogdi-devel >= 3.1
c9c08280 111%{?with_openjpeg:BuildRequires: openjpeg2-devel >= 2.0.0-2}
0316feee
JB
112# 8.1.7 for DB support, 10.0.1 for georaster
113%{?with_oci:BuildRequires: oracle-instantclient-devel >= 10.0.1}
954ec354 114#BuildRequires: pcidsk-devel > 0.3
a0ffd9c4 115BuildRequires: perl-devel
fac7da6f 116%{?with_podofo:BuildRequires: podofo-devel}
0077f857 117%{?with_poppler:BuildRequires: poppler-devel >= 0.24}
9b4989ae
JB
118# ensure it's compiled with PQescapeStringConn support
119BuildRequires: postgresql-backend-devel >= 8.1.4
120BuildRequires: postgresql-devel >= 8.1.4
121BuildRequires: proj-devel >= 4
9a2dbbce 122BuildRequires: python-devel >= 1:2.5
017b03bb 123BuildRequires: python-numpy-devel >= 1:1.0.0
9b4989ae 124BuildRequires: python-setuptools
779b0eec 125%{?with_rasdaman:BuildRequires: rasdaman-devel}
479cb83c 126BuildRequires: rpm-pythonprov
315a1c4a 127%{?with_ruby:BuildRequires: rpm-rubyprov}
9b4989ae 128BuildRequires: rpmbuild(macros) >= 1.344
4aafe7c0 129%{?with_ruby:BuildRequires: ruby-devel}
b88bb9ef 130BuildRequires: sed >= 4.0
9b4989ae 131BuildRequires: sqlite3-devel >= 3.0.0
479cb83c 132BuildRequires: swig-perl
0316feee 133BuildRequires: swig-php >= 2.0.12-2
9a2dbbce 134BuildRequires: swig-python >= 1.3
017b03bb 135%{?with_ruby:BuildRequires: swig-ruby}
479cb83c 136BuildRequires: texlive-dvips
137BuildRequires: texlive-latex
9831286f 138%{?with_odbc:BuildRequires: unixODBC-devel >= 2.2.15}
9b4989ae
JB
139%{?with_xerces:BuildRequires: xerces-c-devel >= 2.7.0}
140BuildRequires: xz-devel
faf5649c 141BuildRequires: zlib-devel >= 1.1.4
4537079d 142Requires: freexl >= 1.0
0316feee 143Requires: geos >= 3.1.0
b3cbf6a3 144Requires: libgeotiff >= 1.2.1
e354fe40 145Requires: libpng >= 2:1.2.8
954ec354 146Requires: libtiff >= 4.0
faf5649c
JB
147BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
148
149%description
150GDAL is a translator library for raster geospatial data formats that
151is released under an Open Source license. As a library, it presents a
152single abstract data model to the calling application for all
153supported formats. The related OGR library (which lives within the
154GDAL source tree) provides a similar capability for simple features
155vector data.
f05c79e8 156
d34f2ec8
JR
157%description -l pl.UTF-8
158GDAL to biblioteka konwertująca między formatami rastrowych danych
159dotyczących powierzchni Ziemi, udostępniona na licencji Open Source.
160Jako biblioteka udostępnia aplikacjom jeden abstrakcyjny model danych
161do wszystkich obsługiwanych formatów. Powiązana z nią biblioteka OGR
162(której źródła są dołączone do drzewa źródeł GDAL) daje podobne
163możliwości dla danych wektorowych.
faf5649c 164
6b59fa88
JB
165%package devel
166Summary: GDAL library header files
a28c1bee 167Summary(pl.UTF-8): Pliki nagłówkowe biblioteki GDAL
6b59fa88 168Group: Development/Libraries
1673a634 169Requires: %{name} = %{version}-%{release}
d3d190a4
JB
170%{?with_opencl:Requires: OpenCL-devel >= 1.0}
171%{?with_armadillo:Requires: armadillo-devel}
b3cbf6a3 172Requires: cfitsio-devel
6a3158ac 173%{?with_crnlib:Requires: crnlib-devel}
209aac6b
JB
174Requires: curl-devel
175%{?with_epsilon:Requires: epsilon-compressor-devel}
779b0eec 176%{?with_fyba:Requires: fyba-devel}
69051332 177Requires: expat-devel >= 1.95.0
4537079d 178Requires: freexl-devel >= 1.0
0316feee 179Requires: geos-devel >= 3.1.0
209aac6b 180Requires: giflib-devel >= 4.0
b3cbf6a3 181Requires: hdf-devel >= 4.0
69051332 182Requires: hdf5-devel
b3cbf6a3 183Requires: jasper-devel
0316feee 184Requires: json-c-devel >= 0.11
77dfc6fa 185%{?with_kea:Requires: kealib-devel}
d4d7a2c6 186Requires: libcsf-devel
4058fbc3 187Requires: libdap-devel >= 3.10
b3cbf6a3 188Requires: libgeotiff-devel >= 1.2.1
209aac6b
JB
189%{?with_gta:Requires: libgta-devel}
190Requires: libjpeg-devel >= 6b
e354fe40 191Requires: libpng-devel >= 2:1.2.8
4537079d 192%{?with_spatialite:Requires: libspatialite-devel}
b3cbf6a3 193Requires: libstdc++-devel
954ec354 194Requires: libtiff-devel >= 4.0
209aac6b
JB
195Requires: libuuid-devel
196Requires: libwebp-devel
0316feee 197Requires: libxml2-devel >= 2
d3d190a4 198%{?with_mysql:Requires: mysql-devel}
9b4989ae 199Requires: netcdf-devel >= 4
b3cbf6a3 200Requires: ogdi-devel >= 3.1
c9c08280 201%{?with_openjpeg:Requires: openjpeg2-devel >= 2.0.0-2}
954ec354 202#Requires: pcidsk-devel > 0.3
209aac6b 203%{?with_podofo:Requires: podofo-devel}
0077f857 204%{?with_poppler:Requires: poppler-devel >= 0.24}
b3cbf6a3 205Requires: postgresql-devel
209aac6b 206Requires: proj-devel >= 4
779b0eec 207%{?with_rasdaman:Requires: rasdaman-devel}
9b4989ae 208Requires: sqlite3-devel >= 3.0.0
655672e5 209%{?with_odbc:Requires: unixODBC-devel}
69051332 210%{?with_xerces:Requires: xerces-c-devel >= 2.7.0}
209aac6b
JB
211Requires: xz-devel
212Requires: zlib-devel >= 1.1.4
6b59fa88
JB
213
214%description devel
215GDAL library header files.
216
d34f2ec8
JR
217%description devel -l pl.UTF-8
218Pliki nagłówkowe biblioteki GDAL.
6b59fa88
JB
219
220%package static
221Summary: GDAL static libraries
a28c1bee 222Summary(pl.UTF-8): Statyczne biblioteki GDAL
6b59fa88 223Group: Development/Libraries
1673a634 224Requires: %{name}-devel = %{version}-%{release}
6b59fa88
JB
225
226%description static
227GDAL static libraries.
228
d34f2ec8 229%description static -l pl.UTF-8
6b59fa88
JB
230Statyczne biblioteki GDAL.
231
a0ffd9c4
JB
232%package -n perl-gdal
233Summary: Perl bindings for GDAL
234Summary(pl.UTF-8): Wiązania Perla do pakietu GDAL
235Group: Development/Languages/Perl
236Requires: %{name} = %{version}-%{release}
237
238%description -n perl-gdal
239Perl bindings for GDAL - Geo::GDAL, Geo::OGR and Geo::OSR modules.
240
241%description -n perl-gdal -l pl.UTF-8
017b03bb 242Wiązania Perla do pakietu GDAL - moduły Geo::GDAL, Geo::OGR, Geo::OSR.
a0ffd9c4 243
ead243f9 244%package -n %{php_name}-gdal
9b4989ae
JB
245Summary: PHP bindings for GDAL library
246Summary(pl.UTF-8): Wiązania PHP do biblioteki GDAL
247Group: Development/Languages/PHP
248Requires: %{name} = %{version}-%{release}
249%{?requires_php_extension}
250
ead243f9 251%description -n %{php_name}-gdal
9b4989ae
JB
252PHP bindings for GDAL library
253
ead243f9 254%description -n %{php_name}-gdal -l pl.UTF-8
9b4989ae
JB
255Wiązania PHP do biblioteki GDAL.
256
6b59fa88
JB
257%package -n python-gdal
258Summary: GDAL Python module
a28c1bee 259Summary(pl.UTF-8): Moduł Pythona GDAL
6b59fa88 260Group: Libraries/Python
1673a634 261Requires: %{name} = %{version}-%{release}
315a1c4a 262Requires: python-libs
6b59fa88
JB
263
264%description -n python-gdal
265GDAL Python module.
266
d34f2ec8
JR
267%description -n python-gdal -l pl.UTF-8
268Moduł Pythona GDAL.
6b59fa88 269
a0ffd9c4
JB
270%package -n ruby-gdal
271Summary: Ruby bindings for GDAL
272Summary(pl.UTF-8): Wiązania języka Ruby do pakietu GDAL
273Group: Development/Languages
274Requires: %{name} = %{version}-%{release}
a0ffd9c4
JB
275
276%description -n ruby-gdal
277Ruby bindings for GDAL - gdal, gdalconst, ogr and osr modules.
278
279%description -n ruby-gdal -l pl.UTF-8
017b03bb
ER
280Wiązania języka Ruby do pakietu GDAL - moduły gdal, gdalconst, ogr i
281osr.
a0ffd9c4 282
faf5649c
JB
283%prep
284%setup -q
285%patch0 -p1
286%patch1 -p1
f1b5abea
JB
287%patch2 -p1
288%patch3 -p1
0316feee 289%patch5 -p1
0316feee 290%patch7 -p1
779b0eec
JB
291%patch8 -p1
292%patch9 -p1
779b0eec
JB
293%patch11 -p1
294%patch12 -p1
0a5f35eb 295%patch13 -p1
0316feee
JB
296
297# need to regenerate (old ones don't support perl 5.10 or php 5.5)
298%{__rm} swig/{perl,php}/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
299
300%{__sed} -i \
301 -e 's/^CC=gcc/CC=%{__cc}/' \
302 -e 's/^CXX=g++/CXX=%{__cxx}/' \
303 -e 's/^CFLAGS=-fpic/CFLAGS=%{rpmcflags} -fPIC/' \
304 -e 's/^LDFLAGS=-shared/LDFLAGS=%{rpmldflags} -shared/' \
305 swig/php/GNUmakefile
315a1c4a
ER
306# Build with fPIC to allow Ruby bindings
307# Xcompiler should normally achieve that -- http://trac.osgeo.org/gdal/ticket/3978
308# http://trac.osgeo.org/gdal/ticket/1994
309sed -i 's|\$(CFLAGS)|$(CFLAGS) -fPIC|g' swig/ruby/RubyMakefile.mk
310# Install Ruby bindings to distribution specific directory
311sed -i 's|RUBY_EXTENSIONS_DIR :=.*|RUBY_EXTENSIONS_DIR := %{ruby_vendorarchdir}|' swig/ruby/RubyMakefile.mk
312
313# Install Ruby bindings into the proper place
314sed -i -e 's|^$(INSTALL_DIR):|$(DESTDIR)$(INSTALL_DIR):|' swig/ruby/RubyMakefile.mk
315sed -i -e 's|^install: $(INSTALL_DIR)|install: $(DESTDIR)$(INSTALL_DIR)|' swig/ruby/RubyMakefile.mk
316
f4952e6f
AM
317# our man path
318sed -i -e 's#^mandir=.*##g' configure.in
319
4058fbc3 320%{__rm} -r man
4ed54fac 321
b88bb9ef
JB
322%{__sed} -i -e 's,DODS_INC="-I.*,DODS_INC="$(pkg-config --cflags libdap)",' configure.in
323
faf5649c 324%build
e6e33a1a
JR
325%ifarch %{x8664}
326jvm_arch=amd64
327%endif
328%ifarch %{ix86}
329jvm_arch=i386
330%endif
331%ifarch x32
332jvm_arch=x32
333%endif
334
69051332 335%{__libtoolize}
69051332 336%{__aclocal} -I m4
faf5649c 337%{__autoconf}
0a5f35eb 338%{__autoheader}
6b59fa88 339%configure \
e582c3b1 340 --includedir=%{_includedir}/gdal \
5014b82a 341 --datadir=%{_datadir}/gdal \
d4d7a2c6 342 --with-dods-root=/usr \
d3d190a4 343 %{?with_armadillo:--with-armadillo} \
779b0eec 344 %{?with_crnlib:--with-dds} \
209aac6b 345 %{?with_epsilon:--with-epsilon} \
0316feee 346 %{?with_grass:--with-grass} \
b88bb9ef 347 %{!?with_gta:--without-gta} \
69051332 348 --with-hide-internal-symbols \
9b4989ae
JB
349 %{?with_java:--with-java=%{java_home}} \
350 --with-liblzma \
77dfc6fa 351 %{!?with_kea:--without-kea} \
fffcf251 352 %{?with_java:--with-mdb --with-jvm-lib-add-rpath --with-jvm-lib=%{java_home}/jre/lib/$jvm_arch/server} \
d3d190a4 353 %{?with_mysql:--with-mysql} \
0316feee 354 %{?with_oci:--with-oci --with-oci-include=/usr/include/oracle/client --with-oci-lib=%{_libdir}} \
d3d190a4 355 %{?with_opencl:--with-opencl} \
a0ffd9c4 356 --with-perl \
9b4989ae 357 %{?with_php:--with-php} \
fac7da6f
JB
358 %{?with_podofo:--with-podofo} \
359 %{?with_poppler:--with-poppler} \
69051332 360 --with-python \
779b0eec 361 %{?with_rasdaman:--with-rasdaman=%{_libdir}/rasdaman} \
4aafe7c0 362 %{?with_ruby:--with-ruby} \
779b0eec 363 %{?with_fyba:--with-sosi} \
4537079d 364 %{?with_spatialite:--with-spatialite} \
69051332 365 --with-sqlite3 \
9b4989ae 366 --with-webp \
655672e5 367 %{?with_xerces:--with-xerces} \
6b59fa88 368 --with-xerces-inc=/usr/include/xercesc \
80faacbe 369 --with-xerces-lib="-lxerces-c" \
69051332 370 --without-libgrass
954ec354 371# --with-pcidsk=/usr (needs > 0.3)
779b0eec 372# csharp builds, but has no configure option nor install target
faf5649c 373
69051332 374# regenerate where needed
825dc3dc 375%{__make} -j1 -C swig/perl generate
3df9ed7f 376%if %{with ruby}
02b013b1 377%{__make} -j1 -C swig/ruby generate
3df9ed7f 378%endif
69051332 379
779b0eec
JB
380%{__make} -j1 \
381 %{?with_grass:GRASS_INCLUDE="-I/usr/include/grass64"} \
382 %{?with_fyba:SOSI_INC="-I/usr/include/fyba"}
a0ffd9c4 383
825dc3dc 384%{__make} -j1 docs
3a591acf 385
f5a12c65
JK
386%{__make} -j1 man
387
faf5649c
JB
388%install
389rm -rf $RPM_BUILD_ROOT
faf5649c 390
825dc3dc 391%{__make} -j1 install install-man \
3a591acf
JB
392 DESTDIR=$RPM_BUILD_ROOT
393
388b39cb
ER
394rm -rf _html
395cp -a html _html
faf5649c 396
9b4989ae
JB
397%if %{with php}
398# missing in make install
ead243f9
ER
399install -d $RPM_BUILD_ROOT%{php_extensiondir}
400install -p swig/php/php_gdal.so $RPM_BUILD_ROOT%{php_extensiondir}/gdal.so
401install -p swig/php/php_gdalconst.so $RPM_BUILD_ROOT%{php_extensiondir}/gdalconst.so
402install -p swig/php/php_ogr.so $RPM_BUILD_ROOT%{php_extensiondir}/ogr.so
403install -p swig/php/php_osr.so $RPM_BUILD_ROOT%{php_extensiondir}/osr.so
9b4989ae
JB
404install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
405cat <<'EOF' >$RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/gdal.ini
ead243f9 406; Enable gdal extension modules
9b4989ae
JB
407extension=gdal.so
408extension=gdalconst.so
409extension=ogr.so
410extension=osr.so
411EOF
412%endif
413
374370d5
JB
414%py_comp $RPM_BUILD_ROOT%{py_sitedir}
415%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
416%py_postclean
5014b82a 417
017b03bb
ER
418%{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
419%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/.packlist
420%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/Const/.packlist
421%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OGR/.packlist
422%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OSR/.packlist
423
424# some doxygen trash
0316feee
JB
425%{__rm} $RPM_BUILD_ROOT%{_bindir}/gdal{compare,move}.dox
426%{__rm} $RPM_BUILD_ROOT%{_bindir}/gdal_{calc,edit,fillnodata,polygonize,proximity,sieve}.dox
017b03bb 427
faf5649c
JB
428%clean
429rm -rf $RPM_BUILD_ROOT
430
6b59fa88
JB
431%post -p /sbin/ldconfig
432%postun -p /sbin/ldconfig
433
faf5649c
JB
434%files
435%defattr(644,root,root,755)
c0a384ef 436%doc NEWS PROVENANCE.TXT
4058fbc3
JB
437%attr(755,root,root) %{_bindir}/epsg_tr.py
438%attr(755,root,root) %{_bindir}/esri2wkt.py
439%attr(755,root,root) %{_bindir}/gcps2vec.py
440%attr(755,root,root) %{_bindir}/gcps2wld.py
441%attr(755,root,root) %{_bindir}/gdal2tiles.py
442%attr(755,root,root) %{_bindir}/gdal2xyz.py
f4952e6f 443%attr(755,root,root) %{_bindir}/gdal_auth.py
4058fbc3 444%attr(755,root,root) %{_bindir}/gdal_contour
954ec354 445%attr(755,root,root) %{_bindir}/gdal_calc.py
f4952e6f 446%attr(755,root,root) %{_bindir}/gdal_edit.py
4058fbc3
JB
447%attr(755,root,root) %{_bindir}/gdal_fillnodata.py
448%attr(755,root,root) %{_bindir}/gdal_grid
449%attr(755,root,root) %{_bindir}/gdal_merge.py
450%attr(755,root,root) %{_bindir}/gdal_polygonize.py
451%attr(755,root,root) %{_bindir}/gdal_proximity.py
452%attr(755,root,root) %{_bindir}/gdal_rasterize
453%attr(755,root,root) %{_bindir}/gdal_retile.py
454%attr(755,root,root) %{_bindir}/gdal_sieve.py
455%attr(755,root,root) %{_bindir}/gdal_translate
456%attr(755,root,root) %{_bindir}/gdaladdo
457%attr(755,root,root) %{_bindir}/gdalbuildvrt
458%attr(755,root,root) %{_bindir}/gdalchksum.py
0316feee 459%attr(755,root,root) %{_bindir}/gdalcompare.py
4058fbc3
JB
460%attr(755,root,root) %{_bindir}/gdaldem
461%attr(755,root,root) %{_bindir}/gdalenhance
462%attr(755,root,root) %{_bindir}/gdalident.py
463%attr(755,root,root) %{_bindir}/gdalimport.py
464%attr(755,root,root) %{_bindir}/gdalinfo
954ec354 465%attr(755,root,root) %{_bindir}/gdallocationinfo
4058fbc3 466%attr(755,root,root) %{_bindir}/gdalmanage
f4952e6f
AM
467%attr(755,root,root) %{_bindir}/gdalmove.py
468%attr(755,root,root) %{_bindir}/gdalserver
9b4989ae 469%attr(755,root,root) %{_bindir}/gdalsrsinfo
4058fbc3
JB
470%attr(755,root,root) %{_bindir}/gdaltindex
471%attr(755,root,root) %{_bindir}/gdaltransform
472%attr(755,root,root) %{_bindir}/gdalwarp
473%attr(755,root,root) %{_bindir}/mkgraticule.py
474%attr(755,root,root) %{_bindir}/nearblack
475%attr(755,root,root) %{_bindir}/ogr2ogr
476%attr(755,root,root) %{_bindir}/ogrinfo
0316feee 477%attr(755,root,root) %{_bindir}/ogrlineref
4058fbc3
JB
478%attr(755,root,root) %{_bindir}/ogrtindex
479%attr(755,root,root) %{_bindir}/pct2rgb.py
480%attr(755,root,root) %{_bindir}/rgb2pct.py
481%attr(755,root,root) %{_bindir}/testepsg
5014b82a 482%attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
38239d5e 483%attr(755,root,root) %ghost %{_libdir}/libgdal.so.20
0a5f35eb 484%dir %{_libdir}/gdalplugins
6b59fa88 485%{_datadir}/gdal
4058fbc3 486%{_mandir}/man1/gdal2tiles.1*
0316feee 487%{_mandir}/man1/gdal_calc.1*
4058fbc3 488%{_mandir}/man1/gdal_contour.1*
f4952e6f 489%{_mandir}/man1/gdal_edit.1*
4058fbc3
JB
490%{_mandir}/man1/gdal_fillnodata.1*
491%{_mandir}/man1/gdal_grid.1*
492%{_mandir}/man1/gdal_merge.1*
f4952e6f
AM
493%{_mandir}/man1/gdal_polygonize.1*
494%{_mandir}/man1/gdal_proximity.1*
4058fbc3
JB
495%{_mandir}/man1/gdal_rasterize.1*
496%{_mandir}/man1/gdal_retile.1*
497%{_mandir}/man1/gdal_sieve.1*
498%{_mandir}/man1/gdal_translate.1*
499%{_mandir}/man1/gdal_utilities.1*
500%{_mandir}/man1/gdaladdo.1*
501%{_mandir}/man1/gdalbuildvrt.1*
0316feee 502%{_mandir}/man1/gdalcompare.1*
4058fbc3
JB
503%{_mandir}/man1/gdaldem.1*
504%{_mandir}/man1/gdalinfo.1*
954ec354 505%{_mandir}/man1/gdallocationinfo.1*
f4952e6f
AM
506%{_mandir}/man1/gdalmanage.1*
507%{_mandir}/man1/gdalmove.1*
9b4989ae 508%{_mandir}/man1/gdalsrsinfo.1*
4058fbc3
JB
509%{_mandir}/man1/gdaltindex.1*
510%{_mandir}/man1/gdaltransform.1*
511%{_mandir}/man1/gdalwarp.1*
512%{_mandir}/man1/nearblack.1*
513%{_mandir}/man1/ogr2ogr.1*
514%{_mandir}/man1/ogr_utilities.1*
515%{_mandir}/man1/ogrinfo.1*
0316feee 516%{_mandir}/man1/ogrlineref.1*
4058fbc3
JB
517%{_mandir}/man1/ogrtindex.1*
518%{_mandir}/man1/pct2rgb.1*
519%{_mandir}/man1/rgb2pct.1*
6b59fa88
JB
520
521%files devel
522%defattr(644,root,root,755)
388b39cb 523%doc _html/*
5014b82a 524%attr(755,root,root) %{_bindir}/gdal-config
6b59fa88 525%attr(755,root,root) %{_libdir}/libgdal.so
5014b82a 526%{_libdir}/libgdal.la
0316feee 527%{_pkgconfigdir}/gdal.pc
e582c3b1 528%{_includedir}/gdal
5014b82a 529%{_mandir}/man1/gdal-config.1*
6b59fa88
JB
530
531%files static
532%defattr(644,root,root,755)
9b5c0fd4 533%{_libdir}/libgdal.a
6b59fa88 534
a0ffd9c4
JB
535%files -n perl-gdal
536%defattr(644,root,root,755)
537%dir %{perl_vendorarch}/Geo
538%{perl_vendorarch}/Geo/GDAL.pm
539%dir %{perl_vendorarch}/Geo/GDAL
540%{perl_vendorarch}/Geo/GDAL/Const.pm
541%{perl_vendorarch}/Geo/OGR.pm
542%{perl_vendorarch}/Geo/OSR.pm
543%dir %{perl_vendorarch}/auto/Geo
544%dir %{perl_vendorarch}/auto/Geo/GDAL
a0ffd9c4
JB
545%attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/GDAL.so
546%dir %{perl_vendorarch}/auto/Geo/GDAL/Const
a0ffd9c4
JB
547%attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.so
548%dir %{perl_vendorarch}/auto/Geo/OGR
a0ffd9c4
JB
549%attr(755,root,root) %{perl_vendorarch}/auto/Geo/OGR/OGR.so
550%dir %{perl_vendorarch}/auto/Geo/OSR
a0ffd9c4 551%attr(755,root,root) %{perl_vendorarch}/auto/Geo/OSR/OSR.so
38239d5e 552%{_mandir}/man3/Geo::GDAL.3pm*
a0ffd9c4 553
9b4989ae 554%if %{with php}
ead243f9 555%files -n %{php_name}-gdal
9b4989ae
JB
556%defattr(644,root,root,755)
557%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/gdal.ini
558%attr(755,root,root) %{php_extensiondir}/gdal.so
559%attr(755,root,root) %{php_extensiondir}/gdalconst.so
560%attr(755,root,root) %{php_extensiondir}/ogr.so
561%attr(755,root,root) %{php_extensiondir}/osr.so
562%endif
563
6b59fa88
JB
564%files -n python-gdal
565%defattr(644,root,root,755)
9a2dbbce
JB
566%{py_sitedir}/gdal.py[co]
567%{py_sitedir}/gdalconst.py[co]
568%{py_sitedir}/gdalnumeric.py[co]
9a2dbbce
JB
569%{py_sitedir}/ogr.py[co]
570%{py_sitedir}/osr.py[co]
69051332
JB
571%{py_sitedir}/GDAL-*.egg-info
572%dir %{py_sitedir}/osgeo
573%attr(755,root,root) %{py_sitedir}/osgeo/_gdal.so
574%attr(755,root,root) %{py_sitedir}/osgeo/_gdal_array.so
575%attr(755,root,root) %{py_sitedir}/osgeo/_gdalconst.so
576%attr(755,root,root) %{py_sitedir}/osgeo/_ogr.so
577%attr(755,root,root) %{py_sitedir}/osgeo/_osr.so
578%{py_sitedir}/osgeo/*.py[co]
a0ffd9c4 579
4aafe7c0 580%if %{with ruby}
a0ffd9c4
JB
581%files -n ruby-gdal
582%defattr(644,root,root,755)
315a1c4a
ER
583%dir %{ruby_vendorarchdir}/gdal
584%attr(755,root,root) %{ruby_vendorarchdir}/gdal/gdal.so
585%attr(755,root,root) %{ruby_vendorarchdir}/gdal/gdalconst.so
586%attr(755,root,root) %{ruby_vendorarchdir}/gdal/ogr.so
587%attr(755,root,root) %{ruby_vendorarchdir}/gdal/osr.so
4aafe7c0 588%endif
This page took 0.179883 seconds and 4 git commands to generate.