]> git.pld-linux.org Git - packages/gdal.git/blame - gdal.spec
- removed zero-sized .bs file
[packages/gdal.git] / gdal.spec
CommitLineData
954ec354 1# TODO:
8b360036 2# - be reasonable about devel dependencies - you do not need all of them to
cfcb08ee 3# use gdal (probably a gdal module or driver shall not imply devel
4# dependency)
d3d190a4 5# - libjpeg12 (needs patching to use system one, --with-jpeg12 is not sufficient as of 1.9.2)
9b4989ae 6# - libkml (1.3.0 needed, not released yet)
954ec354 7# - wait for newer pcidsk, switch to external again
d3d190a4 8# - csharp, java
9b4989ae
JB
9# - additional, proprietary(?) formats support:
10# - FMEObjects (http://www.safe.com/support/support-resources/fme-downloads/)
11# - ESRI FileGDBAPI (http://resources.arcgis.com/content/geodatabases/10.0/file-gdb-api)
12# - ECW (http://www.erdas.com/products/ecw/ERDASECWJPEG2000SDK/Details.aspx)
13# - Kakadu/JPEG2000 (http://www.kakadusoftware.com/)
14# - MrSID (http://www.lizardtech.com/developer/)
15# - MSG/EUMETSAT (http://www.eumetsat.int/Home/Main/DataAccess/SupportSoftwareTools/index.htm)
9b4989ae 16# - Ingres (--with-ingres=/path)
0316feee 17# - Informix DB (--with-idb)
9b4989ae
JB
18# - DWGdirect (members only? http://www.opendwg.org/)
19# - ESRI SDE (http://www.esri.com/software/arcgis/arcsde/index.html)
655672e5 20#
21# Conditional build:
d3d190a4 22%bcond_without armadillo # Armadillo support for faster TPS transform
779b0eec 23%bcond_without crnlib # DDS support via crunch/crnlib
4537079d 24%bcond_without epsilon # EPSILON wavelet compression support
779b0eec 25%bcond_without fyba # SOSI geodata support using FYBA
0316feee 26%bcond_with grass # GRASS support (note: dependency loop)
4537079d 27%bcond_without gta # GTA format support
d3d190a4 28%bcond_without mysql # MySQL DB support
0316feee 29%bcond_with oci # ORACLE OCI DB and Georaster support
d3d190a4
JB
30%bcond_without odbc # ODBC DB support
31%bcond_without opencl # OpenCL (GPU) support
c9c08280 32%bcond_without openjpeg # OpenJPEG 2 (JPEG2000) support
4537079d
JB
33%bcond_with podofo # PDF support via podofo instead of poppler
34%bcond_without poppler # PDF support via poppler
779b0eec 35%bcond_without rasdaman # Rasdaman support
4537079d 36%bcond_without spatialite # SpatiaLite support
d3d190a4
JB
37%bcond_without xerces # Xerces support
38%bcond_without java # Java and MDB support
0316feee 39%bcond_without php # PHP binding
315a1c4a
ER
40%bcond_without ruby # Ruby binding
41
fac7da6f
JB
42%if %{with podofo}
43%undefine with_poppler
44%endif
66daf0b1 45%if 0%{!?php_name:1}
ead243f9 46%define php_name php55
66daf0b1 47%endif
faf5649c 48Summary: Geospatial Data Abstraction Library
a28c1bee 49Summary(pl.UTF-8): Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
faf5649c 50Name: gdal
0316feee 51Version: 1.11.0
76bf9281 52Release: 4
faf5649c
JB
53License: BSD-like
54Group: Libraries
84501866 55Source0: http://download.osgeo.org/gdal/%{version}/%{name}-%{version}.tar.xz
0316feee 56# Source0-md5: 31f2c4a7230b40e5fdc3cf12a100f96b
f5a12c65 57Patch0: %{name}-perl.patch
9b4989ae 58Patch1: %{name}-python_install.patch
f1b5abea
JB
59Patch2: %{name}-php.patch
60Patch3: %{name}-fpic.patch
75b2e515 61Patch4: %{name}-format-security.patch
0316feee
JB
62Patch5: %{name}-grass.patch
63Patch6: %{name}-sse.patch
64Patch7: %{name}-link.patch
779b0eec
JB
65Patch8: %{name}-fyba.patch
66Patch9: %{name}-dds.patch
67Patch10: %{name}-gif.patch
68Patch11: %{name}-armadillo.patch
69Patch12: %{name}-oci.patch
70Patch13: %{name}-rasdaman.patch
9b5c0fd4 71URL: http://www.gdal.org/
ead243f9 72%{?with_php:BuildRequires: %{php_name}-devel}
d3d190a4
JB
73%{?with_opencl:BuildRequires: OpenCL-devel >= 1.0}
74%{?with_armadillo:BuildRequires: armadillo-devel}
69051332
JB
75BuildRequires: autoconf >= 2.52
76BuildRequires: automake
6b59fa88 77BuildRequires: cfitsio-devel
6a3158ac 78%{?with_crnlib:BuildRequires: crnlib-devel}
9b4989ae 79BuildRequires: curl-devel
9d161bc4 80BuildRequires: doxygen >= 1.4.2
209aac6b 81%{?with_epsilon:BuildRequires: epsilon-compressor-devel}
69051332 82BuildRequires: expat-devel >= 1.95.0
779b0eec 83%{?with_fyba:BuildRequires: fyba-devel}
4537079d 84BuildRequires: freexl-devel >= 1.0
0316feee
JB
85BuildRequires: gcc >= 6:4.1
86BuildRequires: geos-devel >= 3.1.0
b459f4d7 87BuildRequires: giflib-devel >= 4.0
779b0eec 88%{?with_grass:BuildRequires: grass-devel >= 6.4}
6b59fa88 89BuildRequires: hdf-devel >= 4.0
69051332 90BuildRequires: hdf5-devel
6b59fa88 91BuildRequires: jasper-devel
9b4989ae
JB
92%{?with_java:BuildRequires: jdk}
93%{?with_java:BuildRequires: jpackage-utils}
0316feee 94BuildRequires: json-c-devel >= 0.11
d4d7a2c6 95BuildRequires: libcsf-devel
4058fbc3 96BuildRequires: libdap-devel >= 3.10
b3cbf6a3 97BuildRequires: libgeotiff-devel >= 1.2.1
b88bb9ef 98%{?with_gta:BuildRequires: libgta-devel}
6b59fa88 99BuildRequires: libjpeg-devel >= 6b
9b4989ae 100#BuildRequires: libkml-devel >= 1.3.0
e354fe40 101BuildRequires: libpng-devel >= 2:1.2.8
4537079d 102%{?with_spatialite:BuildRequires: libspatialite-devel}
b3cbf6a3 103BuildRequires: libstdc++-devel
954ec354 104BuildRequires: libtiff-devel >= 4.0
69051332 105BuildRequires: libtool
e2b089e1 106BuildRequires: libuuid-devel
9b4989ae 107BuildRequires: libwebp-devel
0316feee 108BuildRequires: libxml2-devel >= 2
d3d190a4 109%{?with_mysql:BuildRequires: mysql-devel}
80114ba8 110BuildRequires: netcdf-devel >= 4.1
6b59fa88 111BuildRequires: ogdi-devel >= 3.1
c9c08280 112%{?with_openjpeg:BuildRequires: openjpeg2-devel >= 2.0.0-2}
0316feee
JB
113# 8.1.7 for DB support, 10.0.1 for georaster
114%{?with_oci:BuildRequires: oracle-instantclient-devel >= 10.0.1}
954ec354 115#BuildRequires: pcidsk-devel > 0.3
a0ffd9c4 116BuildRequires: perl-devel
fac7da6f 117%{?with_podofo:BuildRequires: podofo-devel}
0077f857 118%{?with_poppler:BuildRequires: poppler-devel >= 0.24}
9b4989ae
JB
119# ensure it's compiled with PQescapeStringConn support
120BuildRequires: postgresql-backend-devel >= 8.1.4
121BuildRequires: postgresql-devel >= 8.1.4
122BuildRequires: proj-devel >= 4
9a2dbbce 123BuildRequires: python-devel >= 1:2.5
017b03bb 124BuildRequires: python-numpy-devel >= 1:1.0.0
9b4989ae 125BuildRequires: python-setuptools
779b0eec 126%{?with_rasdaman:BuildRequires: rasdaman-devel}
479cb83c 127BuildRequires: rpm-pythonprov
315a1c4a 128%{?with_ruby:BuildRequires: rpm-rubyprov}
9b4989ae 129BuildRequires: rpmbuild(macros) >= 1.344
4aafe7c0 130%{?with_ruby:BuildRequires: ruby-devel}
b88bb9ef 131BuildRequires: sed >= 4.0
9b4989ae 132BuildRequires: sqlite3-devel >= 3.0.0
479cb83c 133BuildRequires: swig-perl
0316feee 134BuildRequires: swig-php >= 2.0.12-2
9a2dbbce 135BuildRequires: swig-python >= 1.3
017b03bb 136%{?with_ruby:BuildRequires: swig-ruby}
479cb83c 137BuildRequires: texlive-dvips
138BuildRequires: texlive-latex
9831286f 139%{?with_odbc:BuildRequires: unixODBC-devel >= 2.2.15}
9b4989ae
JB
140%{?with_xerces:BuildRequires: xerces-c-devel >= 2.7.0}
141BuildRequires: xz-devel
faf5649c 142BuildRequires: zlib-devel >= 1.1.4
4537079d 143Requires: freexl >= 1.0
0316feee 144Requires: geos >= 3.1.0
b3cbf6a3 145Requires: libgeotiff >= 1.2.1
e354fe40 146Requires: libpng >= 2:1.2.8
954ec354 147Requires: libtiff >= 4.0
faf5649c
JB
148BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
149
150%description
151GDAL is a translator library for raster geospatial data formats that
152is released under an Open Source license. As a library, it presents a
153single abstract data model to the calling application for all
154supported formats. The related OGR library (which lives within the
155GDAL source tree) provides a similar capability for simple features
156vector data.
f05c79e8 157
d34f2ec8
JR
158%description -l pl.UTF-8
159GDAL to biblioteka konwertująca między formatami rastrowych danych
160dotyczących powierzchni Ziemi, udostępniona na licencji Open Source.
161Jako biblioteka udostępnia aplikacjom jeden abstrakcyjny model danych
162do wszystkich obsługiwanych formatów. Powiązana z nią biblioteka OGR
163(której źródła są dołączone do drzewa źródeł GDAL) daje podobne
164możliwości dla danych wektorowych.
faf5649c 165
6b59fa88
JB
166%package devel
167Summary: GDAL library header files
a28c1bee 168Summary(pl.UTF-8): Pliki nagłówkowe biblioteki GDAL
6b59fa88 169Group: Development/Libraries
1673a634 170Requires: %{name} = %{version}-%{release}
d3d190a4
JB
171%{?with_opencl:Requires: OpenCL-devel >= 1.0}
172%{?with_armadillo:Requires: armadillo-devel}
b3cbf6a3 173Requires: cfitsio-devel
6a3158ac 174%{?with_crnlib:Requires: crnlib-devel}
209aac6b
JB
175Requires: curl-devel
176%{?with_epsilon:Requires: epsilon-compressor-devel}
779b0eec 177%{?with_fyba:Requires: fyba-devel}
69051332 178Requires: expat-devel >= 1.95.0
4537079d 179Requires: freexl-devel >= 1.0
0316feee 180Requires: geos-devel >= 3.1.0
209aac6b 181Requires: giflib-devel >= 4.0
b3cbf6a3 182Requires: hdf-devel >= 4.0
69051332 183Requires: hdf5-devel
b3cbf6a3 184Requires: jasper-devel
0316feee 185Requires: json-c-devel >= 0.11
d4d7a2c6 186Requires: libcsf-devel
4058fbc3 187Requires: libdap-devel >= 3.10
b3cbf6a3 188Requires: libgeotiff-devel >= 1.2.1
209aac6b
JB
189%{?with_gta:Requires: libgta-devel}
190Requires: libjpeg-devel >= 6b
e354fe40 191Requires: libpng-devel >= 2:1.2.8
4537079d 192%{?with_spatialite:Requires: libspatialite-devel}
b3cbf6a3 193Requires: libstdc++-devel
954ec354 194Requires: libtiff-devel >= 4.0
209aac6b
JB
195Requires: libuuid-devel
196Requires: libwebp-devel
0316feee 197Requires: libxml2-devel >= 2
d3d190a4 198%{?with_mysql:Requires: mysql-devel}
9b4989ae 199Requires: netcdf-devel >= 4
b3cbf6a3 200Requires: ogdi-devel >= 3.1
c9c08280 201%{?with_openjpeg:Requires: openjpeg2-devel >= 2.0.0-2}
954ec354 202#Requires: pcidsk-devel > 0.3
209aac6b 203%{?with_podofo:Requires: podofo-devel}
0077f857 204%{?with_poppler:Requires: poppler-devel >= 0.24}
b3cbf6a3 205Requires: postgresql-devel
209aac6b 206Requires: proj-devel >= 4
779b0eec 207%{?with_rasdaman:Requires: rasdaman-devel}
9b4989ae 208Requires: sqlite3-devel >= 3.0.0
655672e5 209%{?with_odbc:Requires: unixODBC-devel}
69051332 210%{?with_xerces:Requires: xerces-c-devel >= 2.7.0}
209aac6b
JB
211Requires: xz-devel
212Requires: zlib-devel >= 1.1.4
6b59fa88
JB
213
214%description devel
215GDAL library header files.
216
d34f2ec8
JR
217%description devel -l pl.UTF-8
218Pliki nagłówkowe biblioteki GDAL.
6b59fa88
JB
219
220%package static
221Summary: GDAL static libraries
a28c1bee 222Summary(pl.UTF-8): Statyczne biblioteki GDAL
6b59fa88 223Group: Development/Libraries
1673a634 224Requires: %{name}-devel = %{version}-%{release}
6b59fa88
JB
225
226%description static
227GDAL static libraries.
228
d34f2ec8 229%description static -l pl.UTF-8
6b59fa88
JB
230Statyczne biblioteki GDAL.
231
a0ffd9c4
JB
232%package -n perl-gdal
233Summary: Perl bindings for GDAL
234Summary(pl.UTF-8): Wiązania Perla do pakietu GDAL
235Group: Development/Languages/Perl
236Requires: %{name} = %{version}-%{release}
237
238%description -n perl-gdal
239Perl bindings for GDAL - Geo::GDAL, Geo::OGR and Geo::OSR modules.
240
241%description -n perl-gdal -l pl.UTF-8
017b03bb 242Wiązania Perla do pakietu GDAL - moduły Geo::GDAL, Geo::OGR, Geo::OSR.
a0ffd9c4 243
ead243f9 244%package -n %{php_name}-gdal
9b4989ae
JB
245Summary: PHP bindings for GDAL library
246Summary(pl.UTF-8): Wiązania PHP do biblioteki GDAL
247Group: Development/Languages/PHP
248Requires: %{name} = %{version}-%{release}
249%{?requires_php_extension}
250
ead243f9 251%description -n %{php_name}-gdal
9b4989ae
JB
252PHP bindings for GDAL library
253
ead243f9 254%description -n %{php_name}-gdal -l pl.UTF-8
9b4989ae
JB
255Wiązania PHP do biblioteki GDAL.
256
6b59fa88
JB
257%package -n python-gdal
258Summary: GDAL Python module
a28c1bee 259Summary(pl.UTF-8): Moduł Pythona GDAL
6b59fa88 260Group: Libraries/Python
1673a634 261Requires: %{name} = %{version}-%{release}
315a1c4a 262Requires: python-libs
6b59fa88
JB
263
264%description -n python-gdal
265GDAL Python module.
266
d34f2ec8
JR
267%description -n python-gdal -l pl.UTF-8
268Moduł Pythona GDAL.
6b59fa88 269
a0ffd9c4
JB
270%package -n ruby-gdal
271Summary: Ruby bindings for GDAL
272Summary(pl.UTF-8): Wiązania języka Ruby do pakietu GDAL
273Group: Development/Languages
274Requires: %{name} = %{version}-%{release}
a0ffd9c4
JB
275
276%description -n ruby-gdal
277Ruby bindings for GDAL - gdal, gdalconst, ogr and osr modules.
278
279%description -n ruby-gdal -l pl.UTF-8
017b03bb
ER
280Wiązania języka Ruby do pakietu GDAL - moduły gdal, gdalconst, ogr i
281osr.
a0ffd9c4 282
faf5649c
JB
283%prep
284%setup -q
285%patch0 -p1
286%patch1 -p1
f1b5abea
JB
287%patch2 -p1
288%patch3 -p1
c9c08280 289%patch4 -p1
0316feee
JB
290%patch5 -p1
291%patch6 -p1
292%patch7 -p1
779b0eec
JB
293%patch8 -p1
294%patch9 -p1
295%patch10 -p1
296%patch11 -p1
297%patch12 -p1
298%patch13 -p1
0316feee
JB
299
300# need to regenerate (old ones don't support perl 5.10 or php 5.5)
301%{__rm} swig/{perl,php}/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
302
303%{__sed} -i \
304 -e 's/^CC=gcc/CC=%{__cc}/' \
305 -e 's/^CXX=g++/CXX=%{__cxx}/' \
306 -e 's/^CFLAGS=-fpic/CFLAGS=%{rpmcflags} -fPIC/' \
307 -e 's/^LDFLAGS=-shared/LDFLAGS=%{rpmldflags} -shared/' \
308 swig/php/GNUmakefile
315a1c4a
ER
309# Build with fPIC to allow Ruby bindings
310# Xcompiler should normally achieve that -- http://trac.osgeo.org/gdal/ticket/3978
311# http://trac.osgeo.org/gdal/ticket/1994
312sed -i 's|\$(CFLAGS)|$(CFLAGS) -fPIC|g' swig/ruby/RubyMakefile.mk
313# Install Ruby bindings to distribution specific directory
314sed -i 's|RUBY_EXTENSIONS_DIR :=.*|RUBY_EXTENSIONS_DIR := %{ruby_vendorarchdir}|' swig/ruby/RubyMakefile.mk
315
316# Install Ruby bindings into the proper place
317sed -i -e 's|^$(INSTALL_DIR):|$(DESTDIR)$(INSTALL_DIR):|' swig/ruby/RubyMakefile.mk
318sed -i -e 's|^install: $(INSTALL_DIR)|install: $(DESTDIR)$(INSTALL_DIR)|' swig/ruby/RubyMakefile.mk
319
f4952e6f
AM
320# our man path
321sed -i -e 's#^mandir=.*##g' configure.in
322
4058fbc3 323%{__rm} -r man
4ed54fac 324
b88bb9ef
JB
325%{__sed} -i -e 's,DODS_INC="-I.*,DODS_INC="$(pkg-config --cflags libdap)",' configure.in
326
faf5649c 327%build
69051332 328%{__libtoolize}
69051332 329%{__aclocal} -I m4
faf5649c 330%{__autoconf}
6b59fa88 331%configure \
5014b82a 332 --datadir=%{_datadir}/gdal \
d4d7a2c6 333 --with-dods-root=/usr \
d3d190a4 334 %{?with_armadillo:--with-armadillo} \
779b0eec 335 %{?with_crnlib:--with-dds} \
209aac6b 336 %{?with_epsilon:--with-epsilon} \
0316feee 337 %{?with_grass:--with-grass} \
b88bb9ef 338 %{!?with_gta:--without-gta} \
69051332 339 --with-hide-internal-symbols \
9b4989ae
JB
340 %{?with_java:--with-java=%{java_home}} \
341 --with-liblzma \
209aac6b 342 %{?with_java:--with-mdb --with-jvm-lib-add-rpath} \
d3d190a4 343 %{?with_mysql:--with-mysql} \
0316feee 344 %{?with_oci:--with-oci --with-oci-include=/usr/include/oracle/client --with-oci-lib=%{_libdir}} \
d3d190a4 345 %{?with_opencl:--with-opencl} \
a0ffd9c4 346 --with-perl \
9b4989ae 347 %{?with_php:--with-php} \
fac7da6f
JB
348 %{?with_podofo:--with-podofo} \
349 %{?with_poppler:--with-poppler} \
69051332 350 --with-python \
779b0eec 351 %{?with_rasdaman:--with-rasdaman=%{_libdir}/rasdaman} \
4aafe7c0 352 %{?with_ruby:--with-ruby} \
779b0eec 353 %{?with_fyba:--with-sosi} \
4537079d 354 %{?with_spatialite:--with-spatialite} \
69051332 355 --with-sqlite3 \
9b4989ae 356 --with-webp \
655672e5 357 %{?with_xerces:--with-xerces} \
6b59fa88 358 --with-xerces-inc=/usr/include/xercesc \
80faacbe 359 --with-xerces-lib="-lxerces-c" \
69051332 360 --without-libgrass
954ec354 361# --with-pcidsk=/usr (needs > 0.3)
779b0eec 362# csharp builds, but has no configure option nor install target
faf5649c 363
69051332 364# regenerate where needed
825dc3dc 365%{__make} -j1 -C swig/perl generate
3df9ed7f 366%if %{with ruby}
02b013b1 367%{__make} -j1 -C swig/ruby generate
3df9ed7f 368%endif
69051332 369
779b0eec
JB
370%{__make} -j1 \
371 %{?with_grass:GRASS_INCLUDE="-I/usr/include/grass64"} \
372 %{?with_fyba:SOSI_INC="-I/usr/include/fyba"}
a0ffd9c4 373
825dc3dc 374%{__make} -j1 docs
3a591acf 375
f5a12c65
JK
376%{__make} -j1 man
377
faf5649c
JB
378%install
379rm -rf $RPM_BUILD_ROOT
faf5649c 380
825dc3dc 381%{__make} -j1 install install-man \
3a591acf
JB
382 DESTDIR=$RPM_BUILD_ROOT
383
388b39cb
ER
384rm -rf _html
385cp -a html _html
386cp -a ogr/html _html/ogr
faf5649c 387
9b4989ae
JB
388%if %{with php}
389# missing in make install
ead243f9
ER
390install -d $RPM_BUILD_ROOT%{php_extensiondir}
391install -p swig/php/php_gdal.so $RPM_BUILD_ROOT%{php_extensiondir}/gdal.so
392install -p swig/php/php_gdalconst.so $RPM_BUILD_ROOT%{php_extensiondir}/gdalconst.so
393install -p swig/php/php_ogr.so $RPM_BUILD_ROOT%{php_extensiondir}/ogr.so
394install -p swig/php/php_osr.so $RPM_BUILD_ROOT%{php_extensiondir}/osr.so
9b4989ae
JB
395install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
396cat <<'EOF' >$RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/gdal.ini
ead243f9 397; Enable gdal extension modules
9b4989ae
JB
398extension=gdal.so
399extension=gdalconst.so
400extension=ogr.so
401extension=osr.so
402EOF
403%endif
404
374370d5
JB
405%py_comp $RPM_BUILD_ROOT%{py_sitedir}
406%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
407%py_postclean
5014b82a 408
017b03bb
ER
409%{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
410%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/.packlist
411%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/Const/.packlist
412%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OGR/.packlist
413%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OSR/.packlist
414
415# some doxygen trash
0316feee
JB
416%{__rm} $RPM_BUILD_ROOT%{_bindir}/gdal{compare,move}.dox
417%{__rm} $RPM_BUILD_ROOT%{_bindir}/gdal_{calc,edit,fillnodata,polygonize,proximity,sieve}.dox
017b03bb 418
faf5649c
JB
419%clean
420rm -rf $RPM_BUILD_ROOT
421
6b59fa88
JB
422%post -p /sbin/ldconfig
423%postun -p /sbin/ldconfig
424
faf5649c
JB
425%files
426%defattr(644,root,root,755)
c0a384ef 427%doc NEWS PROVENANCE.TXT
4058fbc3
JB
428%attr(755,root,root) %{_bindir}/epsg_tr.py
429%attr(755,root,root) %{_bindir}/esri2wkt.py
430%attr(755,root,root) %{_bindir}/gcps2vec.py
431%attr(755,root,root) %{_bindir}/gcps2wld.py
432%attr(755,root,root) %{_bindir}/gdal2tiles.py
433%attr(755,root,root) %{_bindir}/gdal2xyz.py
f4952e6f 434%attr(755,root,root) %{_bindir}/gdal_auth.py
4058fbc3 435%attr(755,root,root) %{_bindir}/gdal_contour
954ec354 436%attr(755,root,root) %{_bindir}/gdal_calc.py
f4952e6f 437%attr(755,root,root) %{_bindir}/gdal_edit.py
4058fbc3
JB
438%attr(755,root,root) %{_bindir}/gdal_fillnodata.py
439%attr(755,root,root) %{_bindir}/gdal_grid
440%attr(755,root,root) %{_bindir}/gdal_merge.py
441%attr(755,root,root) %{_bindir}/gdal_polygonize.py
442%attr(755,root,root) %{_bindir}/gdal_proximity.py
443%attr(755,root,root) %{_bindir}/gdal_rasterize
444%attr(755,root,root) %{_bindir}/gdal_retile.py
445%attr(755,root,root) %{_bindir}/gdal_sieve.py
446%attr(755,root,root) %{_bindir}/gdal_translate
447%attr(755,root,root) %{_bindir}/gdaladdo
448%attr(755,root,root) %{_bindir}/gdalbuildvrt
449%attr(755,root,root) %{_bindir}/gdalchksum.py
0316feee 450%attr(755,root,root) %{_bindir}/gdalcompare.py
4058fbc3
JB
451%attr(755,root,root) %{_bindir}/gdaldem
452%attr(755,root,root) %{_bindir}/gdalenhance
453%attr(755,root,root) %{_bindir}/gdalident.py
454%attr(755,root,root) %{_bindir}/gdalimport.py
455%attr(755,root,root) %{_bindir}/gdalinfo
954ec354 456%attr(755,root,root) %{_bindir}/gdallocationinfo
4058fbc3 457%attr(755,root,root) %{_bindir}/gdalmanage
f4952e6f
AM
458%attr(755,root,root) %{_bindir}/gdalmove.py
459%attr(755,root,root) %{_bindir}/gdalserver
9b4989ae 460%attr(755,root,root) %{_bindir}/gdalsrsinfo
4058fbc3
JB
461%attr(755,root,root) %{_bindir}/gdaltindex
462%attr(755,root,root) %{_bindir}/gdaltransform
463%attr(755,root,root) %{_bindir}/gdalwarp
464%attr(755,root,root) %{_bindir}/mkgraticule.py
465%attr(755,root,root) %{_bindir}/nearblack
466%attr(755,root,root) %{_bindir}/ogr2ogr
467%attr(755,root,root) %{_bindir}/ogrinfo
0316feee 468%attr(755,root,root) %{_bindir}/ogrlineref
4058fbc3
JB
469%attr(755,root,root) %{_bindir}/ogrtindex
470%attr(755,root,root) %{_bindir}/pct2rgb.py
471%attr(755,root,root) %{_bindir}/rgb2pct.py
472%attr(755,root,root) %{_bindir}/testepsg
5014b82a 473%attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
017b03bb 474%attr(755,root,root) %ghost %{_libdir}/libgdal.so.1
6b59fa88 475%{_datadir}/gdal
4058fbc3 476%{_mandir}/man1/gdal2tiles.1*
0316feee 477%{_mandir}/man1/gdal_calc.1*
4058fbc3 478%{_mandir}/man1/gdal_contour.1*
f4952e6f 479%{_mandir}/man1/gdal_edit.1*
4058fbc3
JB
480%{_mandir}/man1/gdal_fillnodata.1*
481%{_mandir}/man1/gdal_grid.1*
482%{_mandir}/man1/gdal_merge.1*
f4952e6f
AM
483%{_mandir}/man1/gdal_polygonize.1*
484%{_mandir}/man1/gdal_proximity.1*
4058fbc3
JB
485%{_mandir}/man1/gdal_rasterize.1*
486%{_mandir}/man1/gdal_retile.1*
487%{_mandir}/man1/gdal_sieve.1*
488%{_mandir}/man1/gdal_translate.1*
489%{_mandir}/man1/gdal_utilities.1*
490%{_mandir}/man1/gdaladdo.1*
491%{_mandir}/man1/gdalbuildvrt.1*
0316feee 492%{_mandir}/man1/gdalcompare.1*
4058fbc3
JB
493%{_mandir}/man1/gdaldem.1*
494%{_mandir}/man1/gdalinfo.1*
954ec354 495%{_mandir}/man1/gdallocationinfo.1*
f4952e6f
AM
496%{_mandir}/man1/gdalmanage.1*
497%{_mandir}/man1/gdalmove.1*
9b4989ae 498%{_mandir}/man1/gdalsrsinfo.1*
4058fbc3
JB
499%{_mandir}/man1/gdaltindex.1*
500%{_mandir}/man1/gdaltransform.1*
501%{_mandir}/man1/gdalwarp.1*
502%{_mandir}/man1/nearblack.1*
503%{_mandir}/man1/ogr2ogr.1*
504%{_mandir}/man1/ogr_utilities.1*
505%{_mandir}/man1/ogrinfo.1*
0316feee 506%{_mandir}/man1/ogrlineref.1*
4058fbc3
JB
507%{_mandir}/man1/ogrtindex.1*
508%{_mandir}/man1/pct2rgb.1*
509%{_mandir}/man1/rgb2pct.1*
6b59fa88
JB
510
511%files devel
512%defattr(644,root,root,755)
388b39cb 513%doc _html/*
5014b82a 514%attr(755,root,root) %{_bindir}/gdal-config
6b59fa88 515%attr(755,root,root) %{_libdir}/libgdal.so
5014b82a 516%{_libdir}/libgdal.la
0316feee 517%{_pkgconfigdir}/gdal.pc
4058fbc3
JB
518%{_includedir}/cpl_*.h
519%{_includedir}/cplkeywordparser.h
520%{_includedir}/gdal*.h
521%{_includedir}/gvgcpfit.h
522%{_includedir}/memdataset.h
523%{_includedir}/ogr_*.h
524%{_includedir}/ogrsf_frmts.h
525%{_includedir}/rawdataset.h
526%{_includedir}/thinplatespline.h
527%{_includedir}/vrtdataset.h
5014b82a 528%{_mandir}/man1/gdal-config.1*
6b59fa88
JB
529
530%files static
531%defattr(644,root,root,755)
9b5c0fd4 532%{_libdir}/libgdal.a
6b59fa88 533
a0ffd9c4
JB
534%files -n perl-gdal
535%defattr(644,root,root,755)
536%dir %{perl_vendorarch}/Geo
537%{perl_vendorarch}/Geo/GDAL.pm
538%dir %{perl_vendorarch}/Geo/GDAL
539%{perl_vendorarch}/Geo/GDAL/Const.pm
540%{perl_vendorarch}/Geo/OGR.pm
541%{perl_vendorarch}/Geo/OSR.pm
542%dir %{perl_vendorarch}/auto/Geo
543%dir %{perl_vendorarch}/auto/Geo/GDAL
a0ffd9c4
JB
544%attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/GDAL.so
545%dir %{perl_vendorarch}/auto/Geo/GDAL/Const
a0ffd9c4
JB
546%attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.so
547%dir %{perl_vendorarch}/auto/Geo/OGR
a0ffd9c4
JB
548%attr(755,root,root) %{perl_vendorarch}/auto/Geo/OGR/OGR.so
549%dir %{perl_vendorarch}/auto/Geo/OSR
a0ffd9c4
JB
550%attr(755,root,root) %{perl_vendorarch}/auto/Geo/OSR/OSR.so
551
9b4989ae 552%if %{with php}
ead243f9 553%files -n %{php_name}-gdal
9b4989ae
JB
554%defattr(644,root,root,755)
555%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/gdal.ini
556%attr(755,root,root) %{php_extensiondir}/gdal.so
557%attr(755,root,root) %{php_extensiondir}/gdalconst.so
558%attr(755,root,root) %{php_extensiondir}/ogr.so
559%attr(755,root,root) %{php_extensiondir}/osr.so
560%endif
561
6b59fa88
JB
562%files -n python-gdal
563%defattr(644,root,root,755)
9a2dbbce
JB
564%{py_sitedir}/gdal.py[co]
565%{py_sitedir}/gdalconst.py[co]
566%{py_sitedir}/gdalnumeric.py[co]
9a2dbbce
JB
567%{py_sitedir}/ogr.py[co]
568%{py_sitedir}/osr.py[co]
69051332
JB
569%{py_sitedir}/GDAL-*.egg-info
570%dir %{py_sitedir}/osgeo
571%attr(755,root,root) %{py_sitedir}/osgeo/_gdal.so
572%attr(755,root,root) %{py_sitedir}/osgeo/_gdal_array.so
573%attr(755,root,root) %{py_sitedir}/osgeo/_gdalconst.so
574%attr(755,root,root) %{py_sitedir}/osgeo/_ogr.so
575%attr(755,root,root) %{py_sitedir}/osgeo/_osr.so
576%{py_sitedir}/osgeo/*.py[co]
a0ffd9c4 577
4aafe7c0 578%if %{with ruby}
a0ffd9c4
JB
579%files -n ruby-gdal
580%defattr(644,root,root,755)
315a1c4a
ER
581%dir %{ruby_vendorarchdir}/gdal
582%attr(755,root,root) %{ruby_vendorarchdir}/gdal/gdal.so
583%attr(755,root,root) %{ruby_vendorarchdir}/gdal/gdalconst.so
584%attr(755,root,root) %{ruby_vendorarchdir}/gdal/ogr.so
585%attr(755,root,root) %{ruby_vendorarchdir}/gdal/osr.so
4aafe7c0 586%endif
This page took 0.167474 seconds and 4 git commands to generate.