]> git.pld-linux.org Git - packages/gdal.git/blame - gdal.spec
- force percona-server-devel
[packages/gdal.git] / gdal.spec
CommitLineData
954ec354 1# TODO:
8b360036 2# - be reasonable about devel dependencies - you do not need all of them to
cfcb08ee 3# use gdal (probably a gdal module or driver shall not imply devel
4# dependency)
d3d190a4 5# - libjpeg12 (needs patching to use system one, --with-jpeg12 is not sufficient as of 1.9.2)
9b4989ae 6# - libkml (1.3.0 needed, not released yet)
954ec354 7# - wait for newer pcidsk, switch to external again
d3d190a4 8# - csharp, java
9b4989ae
JB
9# - additional, proprietary(?) formats support:
10# - FMEObjects (http://www.safe.com/support/support-resources/fme-downloads/)
11# - ESRI FileGDBAPI (http://resources.arcgis.com/content/geodatabases/10.0/file-gdb-api)
12# - ECW (http://www.erdas.com/products/ecw/ERDASECWJPEG2000SDK/Details.aspx)
13# - Kakadu/JPEG2000 (http://www.kakadusoftware.com/)
14# - MrSID (http://www.lizardtech.com/developer/)
15# - MSG/EUMETSAT (http://www.eumetsat.int/Home/Main/DataAccess/SupportSoftwareTools/index.htm)
9b4989ae 16# - Ingres (--with-ingres=/path)
0316feee 17# - Informix DB (--with-idb)
9b4989ae
JB
18# - DWGdirect (members only? http://www.opendwg.org/)
19# - ESRI SDE (http://www.esri.com/software/arcgis/arcsde/index.html)
655672e5 20#
21# Conditional build:
d3d190a4 22%bcond_without armadillo # Armadillo support for faster TPS transform
779b0eec 23%bcond_without crnlib # DDS support via crunch/crnlib
4537079d 24%bcond_without epsilon # EPSILON wavelet compression support
779b0eec 25%bcond_without fyba # SOSI geodata support using FYBA
0a5f35eb 26%bcond_with grass # GRASS support (note: dependency loop; use gdal-grass.spec instead)
4537079d 27%bcond_without gta # GTA format support
77dfc6fa 28%bcond_without kea # KEA format support
d3d190a4 29%bcond_without mysql # MySQL DB support
0316feee 30%bcond_with oci # ORACLE OCI DB and Georaster support
d3d190a4
JB
31%bcond_without odbc # ODBC DB support
32%bcond_without opencl # OpenCL (GPU) support
c9c08280 33%bcond_without openjpeg # OpenJPEG 2 (JPEG2000) support
4537079d
JB
34%bcond_with podofo # PDF support via podofo instead of poppler
35%bcond_without poppler # PDF support via poppler
779b0eec 36%bcond_without rasdaman # Rasdaman support
4537079d 37%bcond_without spatialite # SpatiaLite support
d3d190a4
JB
38%bcond_without xerces # Xerces support
39%bcond_without java # Java and MDB support
47ddf890 40%bcond_with php # PHP binding [PHP 7 not supported by swig 3.0.x]
77dfc6fa 41%bcond_with ruby # Ruby binding [not available as of 2.0.2]
315a1c4a 42
fac7da6f
JB
43%if %{with podofo}
44%undefine with_poppler
45%endif
66daf0b1 46%if 0%{!?php_name:1}
ead243f9 47%define php_name php55
66daf0b1 48%endif
faf5649c 49Summary: Geospatial Data Abstraction Library
a28c1bee 50Summary(pl.UTF-8): Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
faf5649c 51Name: gdal
77dfc6fa 52Version: 2.0.2
54b0e240 53Release: 17
faf5649c
JB
54License: BSD-like
55Group: Libraries
84501866 56Source0: http://download.osgeo.org/gdal/%{version}/%{name}-%{version}.tar.xz
77dfc6fa 57# Source0-md5: 940208e737c87d31a90eaae43d0efd65
f5a12c65 58Patch0: %{name}-perl.patch
9b4989ae 59Patch1: %{name}-python_install.patch
f1b5abea
JB
60Patch2: %{name}-php.patch
61Patch3: %{name}-fpic.patch
0316feee 62Patch5: %{name}-grass.patch
0316feee 63Patch7: %{name}-link.patch
779b0eec
JB
64Patch8: %{name}-fyba.patch
65Patch9: %{name}-dds.patch
779b0eec 66Patch11: %{name}-armadillo.patch
ce035715 67Patch12: %{name}-rasdaman.patch
0a5f35eb 68Patch13: %{name}-pluginsdir.patch
4ac72d8c 69Patch14: %{name}-uchar.patch
f9aa527b 70Patch15: libx32.patch
9b5c0fd4 71URL: http://www.gdal.org/
ead243f9 72%{?with_php:BuildRequires: %{php_name}-devel}
d3d190a4
JB
73%{?with_opencl:BuildRequires: OpenCL-devel >= 1.0}
74%{?with_armadillo:BuildRequires: armadillo-devel}
69051332
JB
75BuildRequires: autoconf >= 2.52
76BuildRequires: automake
6b59fa88 77BuildRequires: cfitsio-devel
6a3158ac 78%{?with_crnlib:BuildRequires: crnlib-devel}
9b4989ae 79BuildRequires: curl-devel
9d161bc4 80BuildRequires: doxygen >= 1.4.2
209aac6b 81%{?with_epsilon:BuildRequires: epsilon-compressor-devel}
69051332 82BuildRequires: expat-devel >= 1.95.0
779b0eec 83%{?with_fyba:BuildRequires: fyba-devel}
4537079d 84BuildRequires: freexl-devel >= 1.0
0316feee
JB
85BuildRequires: gcc >= 6:4.1
86BuildRequires: geos-devel >= 3.1.0
b459f4d7 87BuildRequires: giflib-devel >= 4.0
779b0eec 88%{?with_grass:BuildRequires: grass-devel >= 6.4}
6b59fa88 89BuildRequires: hdf-devel >= 4.0
69051332 90BuildRequires: hdf5-devel
6b59fa88 91BuildRequires: jasper-devel
9b4989ae
JB
92%{?with_java:BuildRequires: jdk}
93%{?with_java:BuildRequires: jpackage-utils}
0316feee 94BuildRequires: json-c-devel >= 0.11
77dfc6fa 95%{?with_kea:BuildRequires: kealib-devel}
8fd908ab 96BuildRequires: libcsf-devel >= 2.0-0.041111.6
4058fbc3 97BuildRequires: libdap-devel >= 3.10
b3cbf6a3 98BuildRequires: libgeotiff-devel >= 1.2.1
b88bb9ef 99%{?with_gta:BuildRequires: libgta-devel}
6b59fa88 100BuildRequires: libjpeg-devel >= 6b
9b4989ae 101#BuildRequires: libkml-devel >= 1.3.0
e354fe40 102BuildRequires: libpng-devel >= 2:1.2.8
4537079d 103%{?with_spatialite:BuildRequires: libspatialite-devel}
b3cbf6a3 104BuildRequires: libstdc++-devel
954ec354 105BuildRequires: libtiff-devel >= 4.0
69051332 106BuildRequires: libtool
e2b089e1 107BuildRequires: libuuid-devel
9b4989ae 108BuildRequires: libwebp-devel
0316feee 109BuildRequires: libxml2-devel >= 2
57a11500 110%{?with_mysql:BuildRequires: percona-server-devel}
80114ba8 111BuildRequires: netcdf-devel >= 4.1
6b59fa88 112BuildRequires: ogdi-devel >= 3.1
c9c08280 113%{?with_openjpeg:BuildRequires: openjpeg2-devel >= 2.0.0-2}
0316feee
JB
114# 8.1.7 for DB support, 10.0.1 for georaster
115%{?with_oci:BuildRequires: oracle-instantclient-devel >= 10.0.1}
954ec354 116#BuildRequires: pcidsk-devel > 0.3
a0ffd9c4 117BuildRequires: perl-devel
fac7da6f 118%{?with_podofo:BuildRequires: podofo-devel}
0077f857 119%{?with_poppler:BuildRequires: poppler-devel >= 0.24}
9b4989ae
JB
120# ensure it's compiled with PQescapeStringConn support
121BuildRequires: postgresql-backend-devel >= 8.1.4
122BuildRequires: postgresql-devel >= 8.1.4
123BuildRequires: proj-devel >= 4
9a2dbbce 124BuildRequires: python-devel >= 1:2.5
017b03bb 125BuildRequires: python-numpy-devel >= 1:1.0.0
9b4989ae 126BuildRequires: python-setuptools
779b0eec 127%{?with_rasdaman:BuildRequires: rasdaman-devel}
479cb83c 128BuildRequires: rpm-pythonprov
315a1c4a 129%{?with_ruby:BuildRequires: rpm-rubyprov}
9b4989ae 130BuildRequires: rpmbuild(macros) >= 1.344
4aafe7c0 131%{?with_ruby:BuildRequires: ruby-devel}
b88bb9ef 132BuildRequires: sed >= 4.0
9b4989ae 133BuildRequires: sqlite3-devel >= 3.0.0
479cb83c 134BuildRequires: swig-perl
0316feee 135BuildRequires: swig-php >= 2.0.12-2
9a2dbbce 136BuildRequires: swig-python >= 1.3
017b03bb 137%{?with_ruby:BuildRequires: swig-ruby}
479cb83c 138BuildRequires: texlive-dvips
139BuildRequires: texlive-latex
9831286f 140%{?with_odbc:BuildRequires: unixODBC-devel >= 2.2.15}
9b4989ae
JB
141%{?with_xerces:BuildRequires: xerces-c-devel >= 2.7.0}
142BuildRequires: xz-devel
faf5649c 143BuildRequires: zlib-devel >= 1.1.4
4537079d 144Requires: freexl >= 1.0
0316feee 145Requires: geos >= 3.1.0
b3cbf6a3 146Requires: libgeotiff >= 1.2.1
e354fe40 147Requires: libpng >= 2:1.2.8
954ec354 148Requires: libtiff >= 4.0
faf5649c
JB
149BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
150
151%description
152GDAL is a translator library for raster geospatial data formats that
153is released under an Open Source license. As a library, it presents a
154single abstract data model to the calling application for all
155supported formats. The related OGR library (which lives within the
156GDAL source tree) provides a similar capability for simple features
157vector data.
f05c79e8 158
d34f2ec8
JR
159%description -l pl.UTF-8
160GDAL to biblioteka konwertująca między formatami rastrowych danych
161dotyczących powierzchni Ziemi, udostępniona na licencji Open Source.
162Jako biblioteka udostępnia aplikacjom jeden abstrakcyjny model danych
163do wszystkich obsługiwanych formatów. Powiązana z nią biblioteka OGR
164(której źródła są dołączone do drzewa źródeł GDAL) daje podobne
165możliwości dla danych wektorowych.
faf5649c 166
6b59fa88
JB
167%package devel
168Summary: GDAL library header files
a28c1bee 169Summary(pl.UTF-8): Pliki nagłówkowe biblioteki GDAL
6b59fa88 170Group: Development/Libraries
1673a634 171Requires: %{name} = %{version}-%{release}
d3d190a4
JB
172%{?with_opencl:Requires: OpenCL-devel >= 1.0}
173%{?with_armadillo:Requires: armadillo-devel}
b3cbf6a3 174Requires: cfitsio-devel
6a3158ac 175%{?with_crnlib:Requires: crnlib-devel}
209aac6b
JB
176Requires: curl-devel
177%{?with_epsilon:Requires: epsilon-compressor-devel}
779b0eec 178%{?with_fyba:Requires: fyba-devel}
69051332 179Requires: expat-devel >= 1.95.0
4537079d 180Requires: freexl-devel >= 1.0
0316feee 181Requires: geos-devel >= 3.1.0
209aac6b 182Requires: giflib-devel >= 4.0
b3cbf6a3 183Requires: hdf-devel >= 4.0
69051332 184Requires: hdf5-devel
b3cbf6a3 185Requires: jasper-devel
0316feee 186Requires: json-c-devel >= 0.11
77dfc6fa 187%{?with_kea:Requires: kealib-devel}
d4d7a2c6 188Requires: libcsf-devel
4058fbc3 189Requires: libdap-devel >= 3.10
b3cbf6a3 190Requires: libgeotiff-devel >= 1.2.1
209aac6b
JB
191%{?with_gta:Requires: libgta-devel}
192Requires: libjpeg-devel >= 6b
e354fe40 193Requires: libpng-devel >= 2:1.2.8
4537079d 194%{?with_spatialite:Requires: libspatialite-devel}
b3cbf6a3 195Requires: libstdc++-devel
954ec354 196Requires: libtiff-devel >= 4.0
209aac6b
JB
197Requires: libuuid-devel
198Requires: libwebp-devel
0316feee 199Requires: libxml2-devel >= 2
57a11500 200%{?with_mysql:Requires: percona-server-devel}
9b4989ae 201Requires: netcdf-devel >= 4
b3cbf6a3 202Requires: ogdi-devel >= 3.1
c9c08280 203%{?with_openjpeg:Requires: openjpeg2-devel >= 2.0.0-2}
954ec354 204#Requires: pcidsk-devel > 0.3
209aac6b 205%{?with_podofo:Requires: podofo-devel}
0077f857 206%{?with_poppler:Requires: poppler-devel >= 0.24}
b3cbf6a3 207Requires: postgresql-devel
209aac6b 208Requires: proj-devel >= 4
779b0eec 209%{?with_rasdaman:Requires: rasdaman-devel}
9b4989ae 210Requires: sqlite3-devel >= 3.0.0
655672e5 211%{?with_odbc:Requires: unixODBC-devel}
69051332 212%{?with_xerces:Requires: xerces-c-devel >= 2.7.0}
209aac6b
JB
213Requires: xz-devel
214Requires: zlib-devel >= 1.1.4
6b59fa88
JB
215
216%description devel
217GDAL library header files.
218
d34f2ec8
JR
219%description devel -l pl.UTF-8
220Pliki nagłówkowe biblioteki GDAL.
6b59fa88
JB
221
222%package static
223Summary: GDAL static libraries
a28c1bee 224Summary(pl.UTF-8): Statyczne biblioteki GDAL
6b59fa88 225Group: Development/Libraries
1673a634 226Requires: %{name}-devel = %{version}-%{release}
6b59fa88
JB
227
228%description static
229GDAL static libraries.
230
d34f2ec8 231%description static -l pl.UTF-8
6b59fa88
JB
232Statyczne biblioteki GDAL.
233
a0ffd9c4
JB
234%package -n perl-gdal
235Summary: Perl bindings for GDAL
236Summary(pl.UTF-8): Wiązania Perla do pakietu GDAL
237Group: Development/Languages/Perl
238Requires: %{name} = %{version}-%{release}
239
240%description -n perl-gdal
241Perl bindings for GDAL - Geo::GDAL, Geo::OGR and Geo::OSR modules.
242
243%description -n perl-gdal -l pl.UTF-8
017b03bb 244Wiązania Perla do pakietu GDAL - moduły Geo::GDAL, Geo::OGR, Geo::OSR.
a0ffd9c4 245
ead243f9 246%package -n %{php_name}-gdal
9b4989ae
JB
247Summary: PHP bindings for GDAL library
248Summary(pl.UTF-8): Wiązania PHP do biblioteki GDAL
249Group: Development/Languages/PHP
250Requires: %{name} = %{version}-%{release}
251%{?requires_php_extension}
252
ead243f9 253%description -n %{php_name}-gdal
9b4989ae
JB
254PHP bindings for GDAL library
255
ead243f9 256%description -n %{php_name}-gdal -l pl.UTF-8
9b4989ae
JB
257Wiązania PHP do biblioteki GDAL.
258
6b59fa88
JB
259%package -n python-gdal
260Summary: GDAL Python module
a28c1bee 261Summary(pl.UTF-8): Moduł Pythona GDAL
6b59fa88 262Group: Libraries/Python
1673a634 263Requires: %{name} = %{version}-%{release}
315a1c4a 264Requires: python-libs
6b59fa88
JB
265
266%description -n python-gdal
267GDAL Python module.
268
d34f2ec8
JR
269%description -n python-gdal -l pl.UTF-8
270Moduł Pythona GDAL.
6b59fa88 271
a0ffd9c4
JB
272%package -n ruby-gdal
273Summary: Ruby bindings for GDAL
274Summary(pl.UTF-8): Wiązania języka Ruby do pakietu GDAL
275Group: Development/Languages
276Requires: %{name} = %{version}-%{release}
a0ffd9c4
JB
277
278%description -n ruby-gdal
279Ruby bindings for GDAL - gdal, gdalconst, ogr and osr modules.
280
281%description -n ruby-gdal -l pl.UTF-8
017b03bb
ER
282Wiązania języka Ruby do pakietu GDAL - moduły gdal, gdalconst, ogr i
283osr.
a0ffd9c4 284
faf5649c
JB
285%prep
286%setup -q
287%patch0 -p1
288%patch1 -p1
f1b5abea
JB
289%patch2 -p1
290%patch3 -p1
0316feee 291%patch5 -p1
0316feee 292%patch7 -p1
779b0eec
JB
293%patch8 -p1
294%patch9 -p1
779b0eec
JB
295%patch11 -p1
296%patch12 -p1
0a5f35eb 297%patch13 -p1
4ac72d8c 298%patch14 -p1
f9aa527b 299%patch15 -p1
0316feee
JB
300
301# need to regenerate (old ones don't support perl 5.10 or php 5.5)
302%{__rm} swig/{perl,php}/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
303
304%{__sed} -i \
305 -e 's/^CC=gcc/CC=%{__cc}/' \
306 -e 's/^CXX=g++/CXX=%{__cxx}/' \
307 -e 's/^CFLAGS=-fpic/CFLAGS=%{rpmcflags} -fPIC/' \
308 -e 's/^LDFLAGS=-shared/LDFLAGS=%{rpmldflags} -shared/' \
309 swig/php/GNUmakefile
315a1c4a
ER
310# Build with fPIC to allow Ruby bindings
311# Xcompiler should normally achieve that -- http://trac.osgeo.org/gdal/ticket/3978
312# http://trac.osgeo.org/gdal/ticket/1994
313sed -i 's|\$(CFLAGS)|$(CFLAGS) -fPIC|g' swig/ruby/RubyMakefile.mk
314# Install Ruby bindings to distribution specific directory
315sed -i 's|RUBY_EXTENSIONS_DIR :=.*|RUBY_EXTENSIONS_DIR := %{ruby_vendorarchdir}|' swig/ruby/RubyMakefile.mk
316
317# Install Ruby bindings into the proper place
318sed -i -e 's|^$(INSTALL_DIR):|$(DESTDIR)$(INSTALL_DIR):|' swig/ruby/RubyMakefile.mk
319sed -i -e 's|^install: $(INSTALL_DIR)|install: $(DESTDIR)$(INSTALL_DIR)|' swig/ruby/RubyMakefile.mk
320
f4952e6f
AM
321# our man path
322sed -i -e 's#^mandir=.*##g' configure.in
323
4058fbc3 324%{__rm} -r man
4ed54fac 325
b88bb9ef
JB
326%{__sed} -i -e 's,DODS_INC="-I.*,DODS_INC="$(pkg-config --cflags libdap)",' configure.in
327
faf5649c 328%build
e6e33a1a
JR
329%ifarch %{x8664}
330jvm_arch=amd64
331%endif
332%ifarch %{ix86}
333jvm_arch=i386
334%endif
335%ifarch x32
336jvm_arch=x32
337%endif
338
69051332 339%{__libtoolize}
69051332 340%{__aclocal} -I m4
faf5649c 341%{__autoconf}
0a5f35eb 342%{__autoheader}
6b59fa88 343%configure \
e582c3b1 344 --includedir=%{_includedir}/gdal \
5014b82a 345 --datadir=%{_datadir}/gdal \
d4d7a2c6 346 --with-dods-root=/usr \
d3d190a4 347 %{?with_armadillo:--with-armadillo} \
779b0eec 348 %{?with_crnlib:--with-dds} \
209aac6b 349 %{?with_epsilon:--with-epsilon} \
0316feee 350 %{?with_grass:--with-grass} \
b88bb9ef 351 %{!?with_gta:--without-gta} \
69051332 352 --with-hide-internal-symbols \
9b4989ae
JB
353 %{?with_java:--with-java=%{java_home}} \
354 --with-liblzma \
77dfc6fa 355 %{!?with_kea:--without-kea} \
fffcf251 356 %{?with_java:--with-mdb --with-jvm-lib-add-rpath --with-jvm-lib=%{java_home}/jre/lib/$jvm_arch/server} \
d3d190a4 357 %{?with_mysql:--with-mysql} \
0316feee 358 %{?with_oci:--with-oci --with-oci-include=/usr/include/oracle/client --with-oci-lib=%{_libdir}} \
d3d190a4 359 %{?with_opencl:--with-opencl} \
a0ffd9c4 360 --with-perl \
9b4989ae 361 %{?with_php:--with-php} \
fac7da6f
JB
362 %{?with_podofo:--with-podofo} \
363 %{?with_poppler:--with-poppler} \
69051332 364 --with-python \
779b0eec 365 %{?with_rasdaman:--with-rasdaman=%{_libdir}/rasdaman} \
4aafe7c0 366 %{?with_ruby:--with-ruby} \
779b0eec 367 %{?with_fyba:--with-sosi} \
4537079d 368 %{?with_spatialite:--with-spatialite} \
69051332 369 --with-sqlite3 \
9b4989ae 370 --with-webp \
655672e5 371 %{?with_xerces:--with-xerces} \
6b59fa88 372 --with-xerces-inc=/usr/include/xercesc \
80faacbe 373 --with-xerces-lib="-lxerces-c" \
69051332 374 --without-libgrass
954ec354 375# --with-pcidsk=/usr (needs > 0.3)
779b0eec 376# csharp builds, but has no configure option nor install target
faf5649c 377
69051332 378# regenerate where needed
825dc3dc 379%{__make} -j1 -C swig/perl generate
3df9ed7f 380%if %{with ruby}
02b013b1 381%{__make} -j1 -C swig/ruby generate
3df9ed7f 382%endif
69051332 383
779b0eec
JB
384%{__make} -j1 \
385 %{?with_grass:GRASS_INCLUDE="-I/usr/include/grass64"} \
386 %{?with_fyba:SOSI_INC="-I/usr/include/fyba"}
a0ffd9c4 387
825dc3dc 388%{__make} -j1 docs
3a591acf 389
f5a12c65
JK
390%{__make} -j1 man
391
faf5649c
JB
392%install
393rm -rf $RPM_BUILD_ROOT
faf5649c 394
825dc3dc 395%{__make} -j1 install install-man \
3a591acf
JB
396 DESTDIR=$RPM_BUILD_ROOT
397
388b39cb
ER
398rm -rf _html
399cp -a html _html
faf5649c 400
9b4989ae
JB
401%if %{with php}
402# missing in make install
ead243f9
ER
403install -d $RPM_BUILD_ROOT%{php_extensiondir}
404install -p swig/php/php_gdal.so $RPM_BUILD_ROOT%{php_extensiondir}/gdal.so
405install -p swig/php/php_gdalconst.so $RPM_BUILD_ROOT%{php_extensiondir}/gdalconst.so
406install -p swig/php/php_ogr.so $RPM_BUILD_ROOT%{php_extensiondir}/ogr.so
407install -p swig/php/php_osr.so $RPM_BUILD_ROOT%{php_extensiondir}/osr.so
9b4989ae
JB
408install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
409cat <<'EOF' >$RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/gdal.ini
ead243f9 410; Enable gdal extension modules
9b4989ae
JB
411extension=gdal.so
412extension=gdalconst.so
413extension=ogr.so
414extension=osr.so
415EOF
416%endif
417
374370d5
JB
418%py_comp $RPM_BUILD_ROOT%{py_sitedir}
419%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
420%py_postclean
5014b82a 421
017b03bb
ER
422%{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
423%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/.packlist
424%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/Const/.packlist
425%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OGR/.packlist
426%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OSR/.packlist
427
428# some doxygen trash
0316feee
JB
429%{__rm} $RPM_BUILD_ROOT%{_bindir}/gdal{compare,move}.dox
430%{__rm} $RPM_BUILD_ROOT%{_bindir}/gdal_{calc,edit,fillnodata,polygonize,proximity,sieve}.dox
017b03bb 431
faf5649c
JB
432%clean
433rm -rf $RPM_BUILD_ROOT
434
6b59fa88
JB
435%post -p /sbin/ldconfig
436%postun -p /sbin/ldconfig
437
faf5649c
JB
438%files
439%defattr(644,root,root,755)
c0a384ef 440%doc NEWS PROVENANCE.TXT
4058fbc3
JB
441%attr(755,root,root) %{_bindir}/epsg_tr.py
442%attr(755,root,root) %{_bindir}/esri2wkt.py
443%attr(755,root,root) %{_bindir}/gcps2vec.py
444%attr(755,root,root) %{_bindir}/gcps2wld.py
445%attr(755,root,root) %{_bindir}/gdal2tiles.py
446%attr(755,root,root) %{_bindir}/gdal2xyz.py
f4952e6f 447%attr(755,root,root) %{_bindir}/gdal_auth.py
4058fbc3 448%attr(755,root,root) %{_bindir}/gdal_contour
954ec354 449%attr(755,root,root) %{_bindir}/gdal_calc.py
f4952e6f 450%attr(755,root,root) %{_bindir}/gdal_edit.py
4058fbc3
JB
451%attr(755,root,root) %{_bindir}/gdal_fillnodata.py
452%attr(755,root,root) %{_bindir}/gdal_grid
453%attr(755,root,root) %{_bindir}/gdal_merge.py
454%attr(755,root,root) %{_bindir}/gdal_polygonize.py
455%attr(755,root,root) %{_bindir}/gdal_proximity.py
456%attr(755,root,root) %{_bindir}/gdal_rasterize
457%attr(755,root,root) %{_bindir}/gdal_retile.py
458%attr(755,root,root) %{_bindir}/gdal_sieve.py
459%attr(755,root,root) %{_bindir}/gdal_translate
460%attr(755,root,root) %{_bindir}/gdaladdo
461%attr(755,root,root) %{_bindir}/gdalbuildvrt
462%attr(755,root,root) %{_bindir}/gdalchksum.py
0316feee 463%attr(755,root,root) %{_bindir}/gdalcompare.py
4058fbc3
JB
464%attr(755,root,root) %{_bindir}/gdaldem
465%attr(755,root,root) %{_bindir}/gdalenhance
466%attr(755,root,root) %{_bindir}/gdalident.py
467%attr(755,root,root) %{_bindir}/gdalimport.py
468%attr(755,root,root) %{_bindir}/gdalinfo
954ec354 469%attr(755,root,root) %{_bindir}/gdallocationinfo
4058fbc3 470%attr(755,root,root) %{_bindir}/gdalmanage
f4952e6f
AM
471%attr(755,root,root) %{_bindir}/gdalmove.py
472%attr(755,root,root) %{_bindir}/gdalserver
9b4989ae 473%attr(755,root,root) %{_bindir}/gdalsrsinfo
4058fbc3
JB
474%attr(755,root,root) %{_bindir}/gdaltindex
475%attr(755,root,root) %{_bindir}/gdaltransform
476%attr(755,root,root) %{_bindir}/gdalwarp
477%attr(755,root,root) %{_bindir}/mkgraticule.py
478%attr(755,root,root) %{_bindir}/nearblack
479%attr(755,root,root) %{_bindir}/ogr2ogr
480%attr(755,root,root) %{_bindir}/ogrinfo
0316feee 481%attr(755,root,root) %{_bindir}/ogrlineref
4058fbc3
JB
482%attr(755,root,root) %{_bindir}/ogrtindex
483%attr(755,root,root) %{_bindir}/pct2rgb.py
484%attr(755,root,root) %{_bindir}/rgb2pct.py
485%attr(755,root,root) %{_bindir}/testepsg
5014b82a 486%attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
38239d5e 487%attr(755,root,root) %ghost %{_libdir}/libgdal.so.20
0a5f35eb 488%dir %{_libdir}/gdalplugins
6b59fa88 489%{_datadir}/gdal
4058fbc3 490%{_mandir}/man1/gdal2tiles.1*
0316feee 491%{_mandir}/man1/gdal_calc.1*
4058fbc3 492%{_mandir}/man1/gdal_contour.1*
f4952e6f 493%{_mandir}/man1/gdal_edit.1*
4058fbc3
JB
494%{_mandir}/man1/gdal_fillnodata.1*
495%{_mandir}/man1/gdal_grid.1*
496%{_mandir}/man1/gdal_merge.1*
f4952e6f
AM
497%{_mandir}/man1/gdal_polygonize.1*
498%{_mandir}/man1/gdal_proximity.1*
4058fbc3
JB
499%{_mandir}/man1/gdal_rasterize.1*
500%{_mandir}/man1/gdal_retile.1*
501%{_mandir}/man1/gdal_sieve.1*
502%{_mandir}/man1/gdal_translate.1*
503%{_mandir}/man1/gdal_utilities.1*
504%{_mandir}/man1/gdaladdo.1*
505%{_mandir}/man1/gdalbuildvrt.1*
0316feee 506%{_mandir}/man1/gdalcompare.1*
4058fbc3
JB
507%{_mandir}/man1/gdaldem.1*
508%{_mandir}/man1/gdalinfo.1*
954ec354 509%{_mandir}/man1/gdallocationinfo.1*
f4952e6f
AM
510%{_mandir}/man1/gdalmanage.1*
511%{_mandir}/man1/gdalmove.1*
9b4989ae 512%{_mandir}/man1/gdalsrsinfo.1*
4058fbc3
JB
513%{_mandir}/man1/gdaltindex.1*
514%{_mandir}/man1/gdaltransform.1*
515%{_mandir}/man1/gdalwarp.1*
516%{_mandir}/man1/nearblack.1*
517%{_mandir}/man1/ogr2ogr.1*
518%{_mandir}/man1/ogr_utilities.1*
519%{_mandir}/man1/ogrinfo.1*
0316feee 520%{_mandir}/man1/ogrlineref.1*
4058fbc3
JB
521%{_mandir}/man1/ogrtindex.1*
522%{_mandir}/man1/pct2rgb.1*
523%{_mandir}/man1/rgb2pct.1*
6b59fa88
JB
524
525%files devel
526%defattr(644,root,root,755)
388b39cb 527%doc _html/*
5014b82a 528%attr(755,root,root) %{_bindir}/gdal-config
6b59fa88 529%attr(755,root,root) %{_libdir}/libgdal.so
5014b82a 530%{_libdir}/libgdal.la
0316feee 531%{_pkgconfigdir}/gdal.pc
e582c3b1 532%{_includedir}/gdal
5014b82a 533%{_mandir}/man1/gdal-config.1*
6b59fa88
JB
534
535%files static
536%defattr(644,root,root,755)
9b5c0fd4 537%{_libdir}/libgdal.a
6b59fa88 538
a0ffd9c4
JB
539%files -n perl-gdal
540%defattr(644,root,root,755)
541%dir %{perl_vendorarch}/Geo
542%{perl_vendorarch}/Geo/GDAL.pm
543%dir %{perl_vendorarch}/Geo/GDAL
544%{perl_vendorarch}/Geo/GDAL/Const.pm
545%{perl_vendorarch}/Geo/OGR.pm
546%{perl_vendorarch}/Geo/OSR.pm
547%dir %{perl_vendorarch}/auto/Geo
548%dir %{perl_vendorarch}/auto/Geo/GDAL
a0ffd9c4
JB
549%attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/GDAL.so
550%dir %{perl_vendorarch}/auto/Geo/GDAL/Const
a0ffd9c4
JB
551%attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.so
552%dir %{perl_vendorarch}/auto/Geo/OGR
a0ffd9c4
JB
553%attr(755,root,root) %{perl_vendorarch}/auto/Geo/OGR/OGR.so
554%dir %{perl_vendorarch}/auto/Geo/OSR
a0ffd9c4 555%attr(755,root,root) %{perl_vendorarch}/auto/Geo/OSR/OSR.so
38239d5e 556%{_mandir}/man3/Geo::GDAL.3pm*
a0ffd9c4 557
9b4989ae 558%if %{with php}
ead243f9 559%files -n %{php_name}-gdal
9b4989ae
JB
560%defattr(644,root,root,755)
561%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/gdal.ini
562%attr(755,root,root) %{php_extensiondir}/gdal.so
563%attr(755,root,root) %{php_extensiondir}/gdalconst.so
564%attr(755,root,root) %{php_extensiondir}/ogr.so
565%attr(755,root,root) %{php_extensiondir}/osr.so
566%endif
567
6b59fa88
JB
568%files -n python-gdal
569%defattr(644,root,root,755)
9a2dbbce
JB
570%{py_sitedir}/gdal.py[co]
571%{py_sitedir}/gdalconst.py[co]
572%{py_sitedir}/gdalnumeric.py[co]
9a2dbbce
JB
573%{py_sitedir}/ogr.py[co]
574%{py_sitedir}/osr.py[co]
69051332
JB
575%{py_sitedir}/GDAL-*.egg-info
576%dir %{py_sitedir}/osgeo
577%attr(755,root,root) %{py_sitedir}/osgeo/_gdal.so
578%attr(755,root,root) %{py_sitedir}/osgeo/_gdal_array.so
579%attr(755,root,root) %{py_sitedir}/osgeo/_gdalconst.so
580%attr(755,root,root) %{py_sitedir}/osgeo/_ogr.so
581%attr(755,root,root) %{py_sitedir}/osgeo/_osr.so
582%{py_sitedir}/osgeo/*.py[co]
a0ffd9c4 583
4aafe7c0 584%if %{with ruby}
a0ffd9c4
JB
585%files -n ruby-gdal
586%defattr(644,root,root,755)
315a1c4a
ER
587%dir %{ruby_vendorarchdir}/gdal
588%attr(755,root,root) %{ruby_vendorarchdir}/gdal/gdal.so
589%attr(755,root,root) %{ruby_vendorarchdir}/gdal/gdalconst.so
590%attr(755,root,root) %{ruby_vendorarchdir}/gdal/ogr.so
591%attr(755,root,root) %{ruby_vendorarchdir}/gdal/osr.so
4aafe7c0 592%endif
This page took 0.121862 seconds and 4 git commands to generate.